Solaris 9 12/03 Release Notes

64–Bit Solaris Issue

SPARC: Sun UltraSPARC System (Sun4U) Might Need Boot Flash PROM Update

Note –

If your system is already running 64-bit ready firmware, then the flash PROM update is not required.

If you want to run the 64-bit Solaris software on an UltraSPARCTM system, you might need to update the system's flash PROM firmware. The Solaris 9 12/03 installation programs enable you to add 64-bit support. This 64-bit support is selected by default when you install on Sun UltraSPARC systems. A 64-bit system only boots in the 64-bit mode by default if it has a CPU speed of 200 MHz or greater.

Note –

If you choose to run the 32-bit Solaris software on any SunTM or UltraSPARC system, the flash PROM update is not needed.

The following table lists the UltraSPARC (Sun4UTM) systems that are affected and the minimum firmware versions that are needed. System type is the equivalent of the output of the uname -i command. You can determine which firmware version that you are running by using the prtconf -V command.

Table 1–2 Minimum Firmware Versions Required to Run 64–Bit Solaris Software on UltraSPARC Systems

System Type From uname -i

Minimum Firmware Version From prtconf -V











Note –

If a system is not listed in the previous table, the system does not need a flash PROM update.

For instructions on how to perform the flash PROM update by using the Solaris CD, refer to the Solaris 9 on Sun Hardware Collection. You can obtain the manual at