The lastcomm command gives information on previously executed commands. lastcomm with no arguments displays information about all the commands recorded during the current accounting file's lifetime. If called with arguments, lastcomm only displays accounting entries with a matching command-name, user-name, or terminal-name. If extended process accounting is active (see acctadm(1M)) and is recording the appropriate data items, lastcomm attempts to take data from the current extended process accounting file. If standard process accounting is active, lastcomm takes data from the current standard accounting file (see acct(2)).
If terminal-name is `- -', there was no controlling TTY for the process. The process was probably executed during boot time. If terminal-name is `??', the controlling TTY could not be decoded into a printable name.
For each process entry, lastcomm displays the following items of information:
The command name under which the process was called.
The process performed a fork but not an exec.
The process ran as a set-user-id program.
The name of the user who ran the process.
The terminal which the user was logged in on at the time (if applicable).
The amount of CPU time used by the process (in seconds).
The date and time the process exited.
The following options are supported:
Uses file as the source of accounting data. file may be either an extended process accounting file or a standard process accounting file.
Uses the currently active extended process accounting file. If extended processing accounting is inactive, no output will be produced.
example% lastcomm a.out root term/01
produces a listing of all the executions of commands named a.out by user root while using the terminal term/01.
example% lastcomm root
produces a listing of all the commands executed by user root.
See attributes(5) for descriptions of the following attributes:
|ATTRIBUTE TYPE||ATTRIBUTE VALUE|