The lumount and luumount commands are part of a suite of commands that make up the Live Upgrade feature of the Solaris operating environment. See live_upgrade(5) for a description of the Live Upgrade feature.
The lumount and luumount commands enable you to mount or unmount all of the filesystems in a boot environment (BE). This allows you to inspect or modify the files in a BE while that BE is not active. By default, lumount mounts the file systems on a mount point of the form /.alt.BE_name, where BE_name is the name of the BE whose file systems are being mounted. See NOTES.
The lumount and luumount commands require root privileges.
The lumount and luumount commands have the following options:
For luumount only, forcibly unmount a BE's file systems after attempting (and failing) an unforced unmount. This option is analogous to the umount(1M) -f option.
Error and status messages are sent to error_log, in addition to where they are sent in your current environment.
luumount unmounts the file systems of the BE that owns mount_point. See description of mount_point under OPERANDS, below. The use of -m is optional when specifying a mount point for luumount.
Name of the BE whose file systems will be unmounted. See description of BE_name under OPERANDS, below. The use of -n is optional when specifying a BE name for luumount.
All command output is sent to outfile, in addition to where it is sent in your current environment.
Enable XML output. Characteristics of XML are defined in DTD, in /usr/share/lib/xml/dtd/lu_cli.dtd.<num>, where <num> is the version number of the DTD file.
For luumount, if you supply an argument and specify neither -m nor -n, the command determines whether your argument is a BE name, a mount point, or a block device. If it is one of these three and the argument is associated with a BE that has mounted file systems, luumount unmounts the file systems of that BE. Otherwise, luumount returns an error.
Name of the BE whose file systems will be mounted or unmounted. This is a BE on the current system other than the active BE. Note that, for successful completion of an lumount or luumount command, the status of a BE must be complete, as reported by lustatus(1M). Also, none of the BE's disk slices can be mounted (through use of mount(1M)).
For lumount, a mount point to use instead of the default /.alt.BE_name. If mount_point does not exist, lumount creates it. For luumount, the BE associated with mount_point will have its file systems unmounted. Note that default mount points are automatically deleted upon unmounting with luumount. Mount points that you specify are not deleted.
For luumount only, block_device is the root slice of a BE, such as /dev/dsk/c0t4d0s0. luumount unmounts the file systems of the BE associated with block_device.
The following command creates the mount point /test and mounts the file systems of the BE second_disk on /test.
# lumount second_disk /test /test
You can then cd to /test to view the file systems of second_disk. If you did not specify /test as a mount point, lumount would create a default mount point named /.alt.second_disk.
The following command unmounts the file systems of the BE second_disk. In this example, we cd to / to ensure we are not in any of the file systems in second_disk.
# cd / # luumount second_disk #
If /dev/dsk/c0t4d0s0 were the root slice for second_disk, you could enter the following command to match the effect of the preceding command.
# cd / # luumount /dev/dsk/c0t4d0s0 #
list of BEs on the system
Live Upgrade DTD (see -X option)
See attributes(5) for descriptions of the following attributes:
|ATTRIBUTE TYPE||ATTRIBUTE VALUE|
lu(1M), luactivate(1M), lucancel(1M), lucompare(1M), lucreate(1M), lucurr(1M), ludelete(1M), ludesc(1M), lufslist(1M), lumake(1M), lurename(1M), lustatus(1M), luupgrade(1M), lutab(4), attributes(5), live_upgrade(5)
If a BE name contains slashes (/), lumount replaces those slashes with colons in a default mount point name. For example:
# lumount 'first/disk' /.alt.first:disk