The rcapadm command allows a user with the privileges described below to configure various attributes of the resource capping daemon. If used without arguments, rcapadm displays the current status of the resource capping daemon if it has been configured. See rcapd(1M) for more information.
In Solaris 9, rcapadm is available to users who have the Process Management profile in their list of profiles. The System Administrator role includes the Process Management profile.
The resource capping daemon (rcapd(1M)) is an optional feature.
Do not affect the running state of the resource capping daemon when enabling or disabling it.
Enable the resource capping daemon so that it will be started each time the system is booted. Also start the resource capping daemon now, if the -n option is not specified and it is not currently running.
Disable the resource capping daemon so that it will not be started when the system is booted. Also stop the resource capping daemon now, if the -n option is not specified and it is currently running.
Set intervals for various periodic operations performed by rcapd. All intervals are specified in seconds. You can set the following intervals:
The interval at which rcapd scans for new processes. The default scan interval is every 15 seconds. The minimum value is 1 second.
The interval of process resident set size sampling. The default sample interval is every 5 seconds. The minimum value is 1 second.
The interval at which various paging statistics are updated by rcapd, in seconds. These statistics can be viewed by using rcapstat(1SRM). The default reporting interval is every 5 seconds. When the interval is set to 0, statistics will not be updated.
Paging refers to the act of relocating portions of memory, called pages, to or from physical memory. rcapd pages out the most infrequently used pages.
The reconfiguration interval, in seconds. At each reconfiguration event, rcapd checks its configuration file for updates, and scans the project databases for new project caps. The default reconfiguration interval is every 60 seconds. The minimum interval is 0. When the interval is set to 0, no periodic reconfiguration occurs, although the running daemon can still be reconfigured by sending it SIGHUP.
Set the minimum physical memory utilization for memory cap enforcement. Caps will not be enforced until the physical memory available to processes is low. The percent value should be in the range 0 to 100. The minimum (and default) value is 0, which means that memory caps are always enforced.
# rcapadm -E -i scan=15,sample=5,report=5,config=60 -c 0
The following exit values are returned:
Successful completion. The modifications to the current configuration were valid and made successfully.
An error occurred. A fatal error occurred either in obtaining or modifying the resource capping configuration.
Invalid command-line options were specified.
See attributes(5) for descriptions of the following attributes:
|ATTRIBUTE TYPE||ATTRIBUTE VALUE|
“Physical Memory Control Using the Resource Capping Daemon” in System Administration Guide: Resource Management and Network Services