Sun GlassFish Enterprise Server 2.1 High Availability Administration Guide

Requirements for Using Apache Web Server

For the Apache Web Server, your installation must meet the minimum requirements.

With Apache, the load balancer plug-in requires:

The software sources are available at

In addition, before compiling Apache:

Note –

To use a C compiler other than gcc, set the path of the C compiler and make utility in the PATH environment variable.

Applying the Apache Web Server Patch to Apache 2.0.x

Before installing the load balancer plug-in for Apache 2.0.x, apply the patch for the Apache Web Server issue 12355. More details about this issue are available at This patch is required for the Auto Apply feature to work with Apache 2.0.x. To apply the patch, follow these steps.

  1. Untar http-2.0.59.tar and go to the directory httpd-2.0.59.

  2. Download the patch from and save it as a file, for example, 12355.diff.

  3. From the directory httpd-2.0.59/modules/ssl, run the following command:

    patch < 12355.diff