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Sun GlassFish Enterprise Manager Performance
Monitor 1.0 Getting Started Guide

Sun GlassFish Enterprise Manager Performance Monitor (Performance Monitor) is a client
application that connects to and monitors both local and remote installations of Sun GlassFish
Enterprise Server, providing a rich set of real-time performance metrics about servers, domains,
clusters, instances, web applications, JVMs, and so on.

Built on the NetBeans framework and encapsulating VisualVM, Performance Monitor presents
the performance metrics in convenient, easy-to-interpret graphs, and organizes the monitored
objects in a way familiar to users of the GlassFish Admin Console.

This Getting Started Guide contains the following sections:

■ “Revision History” on page 3
■ “Getting the Performance Monitor 1.0 Software” on page 4
■ “Installing Performance Monitor 1.0 on UNIX-Based Systems” on page 4
■ “Installing Performance Monitor 1.0 on Windows Systems” on page 5
■ “A Brief Tour of Performance Monitor 1.0” on page 6
■ “Performing Common Tasks” on page 9
■ “Additional Resources” on page 11
■ “Documentation, Support, and Training” on page 11
■ “Third-Party Web Site References” on page 11
■ “Sun Welcomes Your Comments” on page 12

Revision History

Version Date Description of Changes

10 January 2009 Initial release version.
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Getting the Performance Monitor 1.0 Software
Performance Monitor 1.0 is available to Sun customers with any of these entitlements:
■ Sun GlassFish Enterprise Server
■ Sun GlassFish Enterprise Server Unlimited Offering
■ Sun GlassFish Enterprise Suite (Gold or Platinum Support levels only)
■ Sun GlassFish Enterprise Suite Unlimited Offering
■ Sun Java Application Platform Suite
■ Sun Java Enterprise System
■ Sun Java Web Infrastructure Suite
■ Sun Web Space Server

To get the Performance Monitor 1.0 software, follow these steps:

1. Go to http://sunsolve.sun.com.
2. Read and accept the SunSolve License Agreement.

The SunSolve home page appears.
3. Locate and click the "Log In" link, situated on the right below "Sun support customers:".

The Log In page appears.
4. Enter the user name and password of the Sun Online Account associated with your

entitlement. Then, click "Log In".
The SunSolve home page appears again, with a welcome message on the right instead of
"Sun support customers:" and the "Log In" link.

5. Locate and click the "Patches and Updates" link.
The Patches and Updates page appears.

6. Locate the PatchFinder box, enter 140749 in the box, and click the "Find Patch" button.
The patch page for the latest Performance Monitor 1.0 software appears.

7. Click the "HTTP" link next to Download Patch and save the patch file (140749-nn.zip) to a
directory on your system.

8. Log out of SunSolve.

Installing Performance Monitor 1.0 on UNIX-Based Systems
To install Performance Monitor 1.0 on a UNIX-Based system, follow these steps:

1. Open a terminal window and navigate to the directory where the 140749-nn.zip patch file
was downloaded.

2. Use the unzip utility to unzip the patch file into the current directory. For example:

mysystem% unzip 140749-01.zip

Getting the Performance Monitor 1.0 Software
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The current directory now contains the 140749-nn patch subdirectory.
3. Navigate into the patch subdirectory and view its contents. The subdirectory contains two

files:
■ glassfish-performance-monitor-version.zip (the Performance Monitor software)
■ README.140749-nn (the readme file for the patch)

4. Use the unzip utility with the -d option to unzip the Performance Monitor zip file into the
directory where you want the Performance Monitor software installed. For example:

mysystem% unzip glassfish-performance-monitor-1.0.0.zip -d /opt

The directory into which you unzipped the Performance Monitor zip file now contains the
glassfish-perf-monitor subdirectory.

Installing Performance Monitor 1.0 on Windows Systems
To install Performance Monitor 1.0 on a Windows system, follow these steps:

1. Open an Explorer window and navigate to the directory where the 140749-nn.zip patch file
was downloaded.

2. Right-click the patch zip file and choose "Extract All..." from the context menu.
The Extraction Wizard window appears, displaying a welcome message.

3. Click "Next".
The Select a Destination page appears in the Extraction Wizard window.

4. Click "Next".
The files are extracted from the patch file. Then, the Extraction Complete page appears in
the Extraction Wizard window.

5. Make sure the "Show Extracted Files" box is checked, and then click "Finish".
The Extraction Wizard window closes and an Explorer window opens, displaying the
140749-nn patch folder.

6. Open the 140749-nn patch folder and view its contents. The patch folder contains two files:
■ glassfish-performance-monitor-version.zip (the Performance Monitor software)
■ README.140749-nn (the readme file for the patch)

7. Right-click the Performance Monitor zip file and choose "Extract All..." from the context
menu.
The Extraction Wizard window appears, displaying a welcome message.

8. Click "Next".
The Select a Destination page appears in the Extraction Wizard window.

9. Click "Browse" and then navigate to the folder where you want the Performance Monitor
software installed. ("Program Files" on the startup disk is a common choice.)

Installing Performance Monitor 1.0 on Windows Systems

Sun GlassFish Enterprise Manager Performance Monitor 1.0 Getting Started Guide 5



10. Click "Next" in the Extraction Wizard window.
The Performance Monitor software is extracted into the glassfish-perf-monitor subfolder in
the folder you specified. Then, the Extraction Complete page appears in the Extraction
Wizard window.

11. Click "Finish" to close the Extraction Wizard window.

A Brief Tour of Performance Monitor 1.0
Performance Monitor 1.0 provides a graphical interface that is simple and familiar to users of
graphical desktop systems.

The menu bar and taskbar appear across the top of the window, and the remainder of the
window is divided into two areas: the applications window on the left and the views window on
the right.

A Brief Tour of Performance Monitor 1.0
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The Menu Bar
The menu bar provides six menus:

Most of these menus and menu items are self-explanatory. However, a few of them are worth
highlighting:

■ File > Add Remote Host is the command to add a remote host under the Remote node of
the Applications window.

■ File > Add JMX Connection is the command to add a JMX connection to a GlassFish
domain running on a remote host under the Remote node of the Application window.

■ Tools > Options displays the Options window, where you can change various polling,
caching, and charting values.

■ Help > About displays information about brief information about Performance Monitor,
but it also provides Details and Logfile buttons to get more detailed information.

The Toolbar
The toolbar provides quick access to commonly used commands, and is customizable using the
View > Toolbars > Customize command. By default, Performance Monitor displays three
toolbars:

■ File, which provides quick access to these File menu commands:

A Brief Tour of Performance Monitor 1.0
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■ Add Remote Host
■ Add JMX Connection
■ Add VM Coredump
■ Add Application Snapshot

■ Snapshot, which provides quick access to these File menu commands:
■ Load
■ Save As

■ GlassFish, which provides two special commands:
■ Show All Java VMs, which controls whether only GlassFish VMs or all VMs on the

local system are displayed under the Local node in the Applications window.
■ Show System VMs, which controls whether VMs for system applications are

displayed in the Applications window.

Performance Monitor provides a fourth default toolbar, Memory, which displays memory
usage by Performance Monitor.

The Applications Window
The Applications window displays a tree outline of the items you are monitoring or can connect
to a monitor. The tree outline has four main branches, or nodes:

■ Local, which contains GlassFish domains, GlassFish instances, and other VMs on the local
system.

■ Remote, which contains connections to remote servers (and the GlassFish resources they
host).

■ VM Coredumps, which contains any VM coredumps loaded into Performance Monitor.
■ Snapshots, which contains any application or profiler snapshots loaded into Performance

Monitor.

For details about the items that can navigate to in the Applications windows, see the online help
for Performance Monitor, available at http://wikis.sun.com/display/PerfMonitorOLH.

The Views Window
The views windows displays the views, or performance metrics information, for items you are
monitoring. To display the view for an item, double-click it in the Applications window.

If you have opened views on multiple items, the views are listed in tabs across the top of the
views window.

A Brief Tour of Performance Monitor 1.0
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For details about the view (and the performance metrics) Prformance Monitor provides for
each type of item, see the online help for Performance Monitor, available at
http://wikis.sun.com/display/PerfMonitorOLH.

Performing Common Tasks
When using Performance Monitor, the task you want to perform can vary widely, depending on
the kind of problem you've encountered and are trying to diagnose with the help of
Performance Monitor. However, there are four tasks that you perform routinely as part of most
diagnosis sessions using Performance Monitor:
■ “Connecting to a Remote Host” on page 9
■ “Adding a JMX Connection to a Remote Host” on page 9
■ “Setting Monitoring Levels” on page 10
■ “Displaying the View for a Monitored Item” on page 11

Connecting to a Remote Host
Follow these steps to connect to a remote host system and add it under the Remote node in the
Applications window:

1. Right-click the Remote node in the Applications window, and then choose Add Remote
Host from the context menu that appears.
The Add Remote Host window is displayed.

2. In the Host Name box, enter the fully qualified host name or the IP address of the system to
connect to. Then, click OK.
The Add Remote Host window closes, and the remote host appears under the Remote note
in the Applications window.

Adding a JMX Connection to a Remote Host
Performance Monitor uses JMX connections to monitor GlassFish domains on remote host
systems. Follow these steps to add a JMX connection to a remote host:

1. In the Applications window, navigate to and select the remote host to which you want to add
a JMX connection.

2. Right-click the remote host, and then choose Add JMX Connection from the context menu
that appears.
The Add JMX Connection window is displayed.

3. In the Connection box, add the JMX port number after the host name and colon. In default
installations of GlassFish, the JMX port number is 8686.

Performing Common Tasks
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4. Make sure the Use security credentials box is checked. Then enter the GlassFish
administrator user name and password in the Username and Password boxes.

5. If TLS/SSL security has been set up on the JMX port of the GlassFish domain you are
connecting to, check the Use TLS/SSL box.

6. Click OK.

The Add JMX Connection window closes, and the JMX connection appears under the
remote host in the Applications window.

Setting Monitoring Levels
When GlassFish is installed, monitoring is off by default. Additionally, in many product
deployments, GlassFish is often run with monitoring off. Thus, you sometimes need to turn
monitoring on so that you can diagnose a problem with the help of Performance Monitor. In
Performance Monitor, you turn monitoring on in one of two ways, depending on whether you
want to monitor web services or other resources.

Setting Monitoring Levels for Web Services

1. In the Applications window, navigate to the GlassFish server instance hosting the web
services you want to monitor.

2. Click the plus sign next to the GlassFish server instance to display its resources.

3. Right-click Web Services, and then choose Open from the context menu that appears.

The Web Services view opens in the views window.

4. In the table of web services, check the Monitoring Level setting of the web service you want
to monitor. If the setting is OFF, choose LOW.

Monitoring is turned on for the web service.

Setting Monitoring Levels for Other Resources

1. In the Applications window, navigate to the GlassFish server instance hosting the resources
you want to monitor.

2. Right-click the GlassFish server instance, and then choose Open from the context menu that
appears.

The Server view opens in the views window.

3. In the list of monitors under Monitoring Configuration, click the OFF link next to any
monitor you want to turn on.

Each time you click the OFF link for a monitor, the monitoring level is set to LOW and the
resources handled by that monitor become available to Performance Monitor.

Performing Common Tasks
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Displaying the View for a Monitored Item
Follow these steps to display the view for a monitored item, and so see the graphs of
performance metrics for the item:

1. In the Applications window, navigate to the item whose performance metrics you want to
see.

2. Double-click the item.
The view for the item opens in the views window.

Additional Resources
For information about the monitoring features and capabilities of Sun GlassFish Enterprise
Server, see Chapter 18, “Monitoring Components and Services,” in Sun GlassFish Enterprise
Server 2.1 Administration Guide.

For information about the monitoring features and capabilities of VisualVM, which is
encapsulated in Performance Monitor, see the VisualVM Documentation and Resources page.

Documentation, Support, and Training
The Sun web site provides information about the following additional resources:

■ Documentation (http://www.sun.com/documentation/)
■ Support (http://www.sun.com/support/)
■ Training (http://www.sun.com/training/)

Third-Party Web Site References
Third-party URLs are referenced in this document and provide additional, related information.

Note – Sun is not responsible for the availability of third-party web sites mentioned in this
document. Sun does not endorse and is not responsible or liable for any content, advertising,
products, or other materials that are available on or through such sites or resources. Sun will not
be responsible or liable for any actual or alleged damage or loss caused or alleged to be caused by
or in connection with use of or reliance on any such content, goods, or services that are available
on or through such sites or resources.

Third-Party Web Site References
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Sun Welcomes Your Comments
Sun is interested in improving its documentation and welcomes your comments and
suggestions.

To share your comments, go to http://docs.sun.com and click Feedback. In the online form,
provide the document title and part number. The part number is a seven-digit or nine-digit
number that can be found on the title page of the book or at the top of the document.

Sun Welcomes Your Comments
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