Sun Java System Message Queue 4.2 Installation Guide

Upgrading from Previous Versions

Because Message Queue is installed with other products (such as Sun JavaTM System Application Server), you should check whether it has already been installed on your system. To do so, enter the command

   imqbrokerd  -version

If Message Queue is already installed, its version number will be displayed. The Message Queue 4.2 Installer will upgrade automatically to Version 4.2 from any Version 3.6 or later. If you have a version earlier than 3.6 installed, you will need to uninstall it before running the Message Queue 4.2 Installer.


Caution – Caution –

The Message Queue 4.2 Installer does not share the same product registry with other installers, such as those of the Sun Java Enterprise System (JES) and Sun Java System Application Server, which include Message Queue as a component. The Message Queue Installer also installs or upgrades shared software components that Message Queue depends on, such as the Java Software Development Kit (SDK), Netscape Portable Runtime (NSPR), Network Security Services (NSS), and JavaHelp. Using this Installer to upgrade an earlier version of Message Queue that was installed with another installer may upgrade such shared components without correctly updating their version numbers in the other installer’s product registry, leaving that registry in an inconsistent state.

If you later run the other installer, the inconsistent registry entries may in turn cause that installer to inadvertently remove Message Queue 4.2. The safest and cleanest way to upgrade an earlier version of Message Queue that was installed with a different installer is as follows:

  1. Use the other installer’s uninstaller to remove Message Queue.

  2. Use the Message Queue 4.2 Installer to install Message Queue 4.2.