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Preface

Common Desktop Environment: User’s Guide describes the basic features of the
Common Desktop Environment (CDE). It describes how to use the desktop
and desktop applications.

Who Should Use This Book

This book is intended for users who have Solaris Common Desktop
Environment installed on their workstation and who plan to use it as their
default desktop. To use this book, you should also be familiar with a three-
button mouse, graphical user interfaces, and typing commands at a command-

line prompt.
Before You Read This Book

You should first read the following books:

® Introduction to Solaris Common Desktop Environment

® Solaris Common Desktop Environment: User’s Transition Guide
How This Book Is Organized

This book contains the following chapters:

Chapter 1, “Basic Skills,” describes the basic skills you need to work with the
Common Desktop Environment, keyboard navigation, and some common
interface aspects of the desktop.
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Chapter 2, “Starting a Desktop Session,* describes how to log in to and out of
the desktop, and how to set the session that will appear at login.

Chapter 3, “Getting Help,” explains how to get help about an application and
how to navigate within the help viewer.

Chapter 4, “Using the Front Panel,” describes the Front Panel, a special
desktop window that contains a set of controls for doing common tasks. It
explains the Front Panel controls and how to customize the Front Panel.

Chapter 5, “Managing Files with File Manager,” explains how to work with
files and folders in the graphical user interface File Manager. It describes basic
skills, navigation, manipulating and locating files and folders, and the Trash
Can.

Chapter 6, “Running Applications from the Desktop,” explains how to run
applications from the desktop using Application Manager, File Manager, the
Front Panel, and terminal emulator windows.

Chapter 7, “Customizing the Desktop Environment,” explains how to use
Style Manager to customize the look and behavior of your desktop. It also
describes how to set personal environment variables.

Chapter 8, “Using Mailer,” describes how to send and receive electronic mail
messages through Mailer, and how to add and retrieve attachments.

Chapter 9, “Printing,” explains how to print through the desktop, and how to
change the default printer.

Chapter 10, “Using Text Editor,” describes the desktop Text Editor, which you
can use to create and edit short documents such as memos, mail messages, or
resource files.

Chapter 11, “Using Calendar,” explains how to use Calendar to set
appointments for yourself or a group, and how to create To Do lists.

Chapter 12, “Using Terminal,” explains how to display and customize
terminal emulator windows on the desktop.

Chapter 13, “Using Icon Editor,” explains how to create files for use as
desktop icons or backdrops.

Chapter 14, “Using Image Viewer,” describes how to capture snapshots and to
view, edit, print, and translate the file formats of monochrome and color
images and multiple page documents such as PostScript files.

Solaris CDE User’s Guide—February 1997



Appendix A, “Keyboard Shortcuts for the Desktop,” describes desktop
keyboard navigation.

Appendix B, “Running Localized Sessions,” explains how to change the
language for your desktop session, and how to change fonts for different
languages.

Glossary is a list of words and phrases found in this book and their definitions.

Related Books

Once you’ve read this book, you may want to read more detailed information
on the desktop in Solaris Common Desktop Environment: Advanced User’s and
System Administrator’s Guide.

Ordering Sun Documents

The SunDocs®™ program provides more than 250 manuals from Sun
Microsystems, Inc. If you live in the United States, Canada, Europe, or Japan,
you can purchase documentation sets or individual manuals using this
program.

For a list of documents and how to order them, see the catalog section of
SunExpress™ On The Internet at http://www.sun.com/sunexpress.
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What Typographic Changes Mean

The following table describes the typographic changes used in this book.

Table P-1

Typographic Conventions

Typeface or

Symbol Meaning Example
AaBbCc123  The names of commands, Edit your .login file.
files, and directories; Usels -a  to list all files.
on-screen computer output machine_name% You have mail.
AaBbCc123  What you type, contrasted machine_name% su
with on-screen computer Password:
output
AaBbCc123 Command-line placeholder: To delete a file, type rm filename.
replace with a real name or
value

AaBbCc123 Book titles, new words or
terms, or words to be
emphasized

Read Chapter 6 in User’s Guide.
These are called class options.
You must be root to do this.

Shell Prompts in Command Examples

The following table shows the default system prompt and superuser prompt
for the C shell, Bourne shell, and Korn shell.

Table P-2  Shell Prompts

Shell Prompt

C shell prompt machine_name%

C shell superuser prompt machine_name#

Bourne shell and Korn shell  $
prompt

Bourne shell and Korn shell #
superuser prompt
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This chapter provides an introduction to the Common Desktop Environment.

For information about logging in to the desktop, refer to Chapter 2, “Starting a

Desktop Session.”
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Mouse Skills

v To Click

¢ Press and release mouse button 1 without moving the mouse.
By default, mouse button 1 is the left button.

Tasks that you perform by clicking include:

® Selecting a window or icon, making it active or selected
® Choosing a button in a dialog box or a control in the Front Panel
® Choosing a hyperlink within a help window

v To Double-Click

¢ Press and release mouse button 1 twice in rapid succession, without moving
the mouse.

Here are some tasks you perform by double-clicking:
® Starting the default action for a File Manager or workspace icon
® Restoring a window icon (displaying the whole window again)

® Closing a window to remove it from the workspace—double-click the
Window menu button in the upper left corner of the window frame

To move a window or drop an icon, use the press-drag-release motion.

+ Point to the window’s title bar or anywhere on the icon, press and hold
mouse button 1, drag the mouse, then release the button.

Tasks you perform by dragging and dropping include:

®* Moving windows and icons on your screen

® Moving or copying files and folders within File Manager

® Dragging a slider within a scroll bar to scroll the contents of a window

® Printing a file by dropping its icon on the Printer control in the Front Panel
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Basic Keyboard SkKills

You can perform desktop tasks using your keyboard instead of your mouse.
When you use your keyboard for desktop navigation, note the following:

The Alt key is the same as the Extend char key on some keyboards
Return is the same as Enter on some keyboards
Pressing Esc halts most interactive operations

In Style Manager, the Window Behavior setting must be Click In Window To
Make Active (this is the default value)

For more information on the Window Behavior setting, refer to Chapter 7,
“Customizing the Desktop Environment.”

Keyboard focus uses the highlight to show you which element of a window,
menu, or control will respond to your input. To activate a selected menu item
or control (such as a button), press the Spacebar.

Here’s a summary of several common keyboard operations:

To move the highlight to the next window: Press Alt+Tab.

To move the keyboard highlight within a window: Press Tab and the arrow
keys (up, down, left, and right).

To close a window and remove it from the workspace: Press Alt+F4.

To minimize a window (turn it into an icon): Press Alt+Spacebar, then N to
choose Minimize from the Window menu.

To move a window: Press Alt+Spacebar, then M to choose Move from the
Window menu. Press the arrow keys to move the window up, down, left, or
right, then press Return.

Hold down Control while you press an arrow key to move the window
faster.

For more information about using your keyboard for desktop navigation, refer
to Appendix A, “Keyboard Shortcuts for the Desktop.”
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Overview of the Desktop

To help you organize and manage your work, the desktop provides windows,
workspaces, controls, menus, and the Front Panel.

Windows contain software applications and are framed with controls so you
can move them, size them, or place them in additional workspaces.

Workspaces are the screen areas where you place the windows needed for
your work, arrange them, and put them away when you’re done.

Controls enable you to manipulate objects, select choices, or type
information.

Menus provide access to commands you use to manage windows and
operate applications.

The Front Panel is a collection of frequently used controls, available in every
workspace.

Some of the windows, icons and objects you’ll encounter as you use the
desktop are:

Window Icons

Window icons

The Front Panel
Style Manager

File Manager
Application Manager
Workspace objects

When you minimize a window, it becomes an icon on the workspace. Shown
here are the window icons for File Manager and Style Manager.

To minimize a window, click the minimize button near the upper right corner
of the window frame.

|
J4_||| Minimize button
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To restore the window, double-click mouse button 1 on the icon. You can also
restore the window by clicking its icon to display the Window menu and then
choosing the menu’s Restore item. See “To Restore a Window from an Icon” on
page 13 for more information.

Front Panel

The Front Panel is a special window at the bottom of the display. It provides
controls, indicators, and subpanels you use in your everyday work. The Front
Panel also provides the workspace switch for selecting a workspace.
Many controls in the Front Panel, such as the File Manager control, start
applications when you click them. Some controls, like the Printer control, are
also drop zones. You can drag a file icon from File Manager and drop it on the
Printer control to be printed.
The clock is an example of an indicator.
Arrow buttons over Front Panel controls identify subpanels—click an arrow
button to open a subpanel.

Calendar Trash Can

File Manager Workspace switch Help Manager
Text Editor Application Manager

Style Manager
Printer |

[

Mailer

o . | o
m FﬁtJ r;—é,i l\@\@ o) = o \pﬁ: ﬂu E

Applications

Folders Personal Applications Personal Printers subpanel HeIp
subpanel subpanel subpanel subpanel

Figure 1-1  Front Panel controls

For more information, see Chapter 4, “Using the Front Panel.”
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Use Style Manager to easily customize many elements of the desktop
including:

® Colors

®* Workspace backdrops

® Font size and font group

® Keyboard, mouse, and window behavior

To start Style Manager, click its Front Panel control.

For more information about Style Manager, see Chapter 7, “Customizing the
Desktop Environment.”
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File Manager

—| File Manager — patten
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File Selected View Help
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| fhome/patten

142 Itermnis) 89 Hidden

File Manager displays the files, folders, and applications on your system as
icons. Working with File Manager icons saves you from having to learn
complex commands.

To open a File Manager view of your home folder, click the File Manager
control in the Front Panel.

For more information, see Chapter 5, “Managing Files with File Manager.”
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Application Manager

: i

—| fpplication Manager

File Selected Wiew Help

_

L |

Desktop_Apps Desktop_Tools Informatian FPrinters_Personal

7 Itemiz) 2 Hidden

Application Manager provides access to applications you use in your everyday
work through action icons. You use action icons to start applications.
Application Manager stores action icons in special folders called application
groups.

You can place the action icons you use frequently on the workspace backdrop.

To open Application Manager, click its Front Panel control.
For more information, see Chapter 6, “Running Applications from the
Desktop.”

Workspace Objects

sk lup_TuLl s

You can place the files, folders, and actions you use frequently on the
workspace backdrop as icons.

To place an object on the workspace, drag its icon from a File Manager or
Application Manager window and drop it directly on the workspace backdrop.

A workspace object is a reference to the actual object, not a copy. The actual
object remains unchanged within File Manager or Application Manager.
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Working with Windows

This section describes how to open, close, and manipulate windows in a
workspace.

Window Frame Controls

A window’s frame provides controls with which you can:

Focus attention on a window, making it active for input from your mouse or
keyboard. When you select a window and it becomes active, its frame
changes color.

Move a window.

Minimize a window into an icon.

Size a window.

Close a window, removing it from the desktop.

Display a window in other workspaces.

Refer to Chapter 7, “Customizing the Desktop Environment,” for information
about settings that make windows active.

Basic Skills 9
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Window
menu button Title bar Minimize button
I dtterm | Maximize button

Resize border

| | Resize corner

Figure 1-2  Window frame controls

Click the Window menu button to display the Window menu.

To close a window and remove it from the desktop, double-click the Window
menu button or display the Window menu and choose Close.

Click the minimize button to turn the window into a window icon. To restore a
window from its icon, double-click the icon.

Click the maximize button to display the window in its largest allowable size.
Return the window to its former size by clicking the maximize button again.

The title bar shows the name of the application that owns the window. Select
a window by clicking its title bar. You can move a window by dragging its title
bar.

Drag a window’s resize corner or border to resize the window.

For information on keyboard navigation and windows, see “Opening and
Closing Windows” in Appendix A, “Keyboard Shortcuts for the Desktop.”
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v To Open an Application Window

Mouse

¢ Click the application’s control in the Front Panel.

Or:

®* From within Application Manager, double-click the application’s icon.

®* From within File Manager, choose an action for a selected icon from the
Selected menu.

®* From the Workspace Programs submenu, choose the item with the
application name. See “Programs Submenu” on page 28 for details.

You can also select an icon in a File Manager or Application Manager window
by clicking it and then choose an action for the selected icon from the Selected
menu.

Keyboard
From the Front Panel:
1. Press Alt+Tab to move the keyboard focus to the Front Panel.

2. Press the arrow keys to move the highlight within the Front Panel and select
a control.

3. Press Spacebar or Return to choose the control and open the application’s
window.

From Application Manager:

1. Open the Application Manager window by choosing its Front Panel control
as described above.

2. Press the arrow keys to move the highlight to an application group icon
within the Application Manager window.

3. Press Return twice to open the application group.

4. Press the arrow keys to move the highlight to an application or action icon,
then press Return twice to start the application.
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v To Close an Application Window

Closing an application window removes it from all workspaces. Closing an
application is the same as quitting an application on other systems.

Caution — Before closing an application window, save your work. In most
applications you can do this by choosing Save from the File menu.
Mouse

® Choose Close from the application’s File menu.

® Or, double-click the Window menu button (in the upper left corner of the
application’s window). See Figure 1-2 on page 10.

Keyboard
1. Press Alt+Tab to move the highlight to the window you want to close.

2. Press Alt+F4.

v To Turn a Window into an Icon

To save screen space, you can minimize windows into window icons. This
keeps the windows easily available and programs running in them continue to
run.

Mouse

¢ Click the window’s minimize button. Q—\J!

Keyboard
1. Press Alt+Spacebar to display the Window menu.

2. Choose Minimize:

* Press Down Arrow until you select Minimize, then press Return.
e Or, press N, the menu’s mnemonic for Minimize.
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v To Restore a Window from an Icon

Mouse

+ Double-click the icon.

Keyboard

1. With keyboard focus on the icon, press Alt+Spacebar to display the Window
menu.

2. Press Down Arrow to select Restore, then press Return.

v To Move a Window or Window Icon

Mouse
1. Point to the window’s title bar or icon.

2. Drag the window or icon to its new location.

Keyboard
1. Press Alt+Spacebar to display the Window menu.
2. Press M, the menu’s mnemonic for Move.

3. Press the arrow keys to relocate the window or icon.

Hold down Control while you press an arrow key to speed up the
movement of the window or icon.

4. When you’ve moved the window or icon to where you want it, press
Return.

To cancel the move operation, press Esc.
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v To Resize a Window

Mouse

1. Place the pointer on a window’s border or corner.

The pointer changes to a resize arrow.

2. Drag the border or corner. An outline appears to show you the window’s
new size.

3. Release the mouse button when the outline shows the window’s desired
size.

Stretch or shrink
a window by
dragging its
border or corner

Keyboard
1. Press Alt+Spacebar to display the Window menu.
2. Press S, the menu’s mnemonic for Size.

3. Press the arrow keys to stretch or shrink the window.

Hold down Control while you press an arrow key to size the window faster.
4. When the outline shows the size you want, press Return.

To cancel the resize operation, press Esc.
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v To Bring a Window or Icon Forward

Mouse

® To bring a window or icon to the foreground of the workspace, click a
visible part of the window’s frame or anywhere on the icon.

® To bring a concealed window or icon to the foreground, choose Shuffle Up
from the Workspace menu.

Keyboard

® To bring the bottom window or icon in a workspace forward, press Alt+Up
Arrow.

® To place the top window in the background, press Alt+Down Arrow.

® To cycle through and select the windows and icons in a workspace, press
Alt+Tab or Alt+Esc.

® To cycle through and select the windows and icons in reverse order, press
Shift+Alt+Tab or Shift+Alt+Esc.

v To Copy and Paste Text into Windows
Copying and pasting eliminates the need to retype text.

You can copy from and paste text into:

® Text fields

® Terminal emulator windows
® Text Editor windows

® Mailer Compose windows

You can also copy text from a Mailer message view and a Help Viewer window
and paste it into Text Editor, terminal emulator, and Mailer Compose windows.

Selecting the Text To Be Copied
1. Move the pointer to the start of the text to be pasted.

2. Drag to the end of the text to be pasted, then release the mouse button,
leaving the text highlighted.
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Using Workspaces

Pasting Text
1. Place the text insertion cursor in the target location.

2. Click mouse button 2 to paste the text.

To deselect text, click in an empty area of the window that has the text
selected, or press Esc.

For related information, refer to:

® Chapter 3, “Getting Help”
® Chapter 10, “Using Text Editor”
® Chapter 12, “Using Terminal”

Workspaces are like separate screens of windows. To help organize your
desktop, you can place specific applications in a particular workspace and
name that workspace accordingly. For example, a workspace you’ve named
Reports could contain the tools you use to prepare reports, such as a
spreadsheet, desktop publisher, and graphics applications. You might set up
other workspaces according to your projects.

This section describes how to display workspaces, place windows in specific
workspaces, and rename workspaces.

For information about using your keyboard for desktop navigation, refer to
Appendix A, “Keyboard Shortcuts for the Desktop.”

v To Display Another Workspace

16

Mouse

¢ Click the workspace’s button in the workspace switch of the Front Panel.

[ &
[2!’ e e

pE: I

D
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Keyboard

1.

Press Alt+Tab until the keyboard focus, as shown by the highlight, is on the
Front Panel.

Press the arrow keys to move the highlight to the button for the workspace
you want to display.

Press Return.

v To Place a Window in Other Workspaces

Mouse

1.

Click the Window menu button.

The Window menu appears.
Choose Occupy Workspace from the Window menu.

In the Workspaces list of the Occupy Workspace dialog box, select the
workspaces in which you want the window to appear.

 To select more than one contiguous workspace name in the list, hold down
Shift while you click.

 To select discontiguous workspace names in the list, hold down Control
while you click.

» Click on a selected workspace to deselect it.
» To place the window in every workspace, click the All Workspaces button.

Click OK.

Keyboard

1.
2.

To display the Window menu, press Alt+Spacebar.

Press the Down Arrow key to select Occupy Workspace, then press Return.

The Occupy Workspace dialog box appears.

Press Tab until the keyboard focus, as shown by the highlight, is in the
Workspaces list.
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v To Rename

4.

5.

Select the workspaces in which you want the window to appear:
* Press Down Arrow or Up Arrow to move through the list.

» To select more than one waorkspace, press Shift+Down Arrow or Shift+Up
Arrow.

Press Return.

a Workspace

Mouse

1.

Click the Front Panel button for the workspace whose name you want to
change.

That workspace is displayed.

Click the workspace’s Front Panel button again.

The button becomes a text field.
Edit the workspace’s name in the text field.

Once you’ve renamed the workspace, press Return.

Keyboard

1.

Press Alt+Tab until the keyboard focus, as shown by the highlight, is on the
Front Panel.

Press the arrow keys to move the highlight to the button for the workspace
you want to rename.

Press Shift+F10 to display the workspace button’s pop-up menu.

Press the Down Arrow key to select the Rename item, then press Return.

The button becomes a text field.
Edit the workspace’s name in the text field.

Once you’ve renamed the workspace, press Return.
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Using Controls in Application Windows

Windows and dialog boxes contain controls that help you work with
applications. You use controls to manipulate objects, select choices, or type
information.

This section describes various types of controls you’ll come across while using
the desktop. Here’s a list of the most common controls:

® Buttons initiate commands, start actions, or specify options and settings.
Types of buttons include push buttons and radio buttons.

® Check boxes specify options and settings.

® Text fields provide areas where you can type information.

® Lists display a scrollable list of choices from which you can select.
® Sliders provide incremental selection from a range of values.

® Scroll bars enable you to scroll through a window’s contents.

v To Choose a Push Button

Choosing a push button immediately performs the associated command or
action. For example, choosing an OK button applies any changes made to a
dialog box then closes it.

As a shortcut, many dialog boxes automatically give focus to the OK button so
that you can quickly specify settings and then press Return to choose OK.

OK, Cancel, and Help

a | Cancel | Help | are examples of push

buttons

Mouse

¢ Click the button.
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Keyboard

1. Press Tab and the arrow keys until the button has the keyboard focus, as
shown by the highlight.

2. Press Return.

v To Select a Check Box or Radio Button

You select a check box to specify an option or setting. You can select more than
one check box in a group.

You also use a radio button to specify an option or setting, but only one radio
button in a group can be selected at a time.

[ Selected radio button

_lnselected radio button

W Selected check howx
_I Unselected check hox

Mouse

¢ Click the check box or radio button you want to select.

Keyboard

1. Press Tab and the arrow keys until the check box or radio button has the
keyboard focus, as shown by the highlight.

2. Press the Spacebar.
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v To Scroll the Contents of a Window

Windows often contain more information than you can see at one time. Use a
window’s scroll bar to bring the window’s contents into view.

Mouse

Click to move up one line

Click to move up one screen

Drag the slider to move to a region of
the window

Click to move down one screen

Click to move down one line

Keyboard
1. Press Tab to move to the window area you want to scroll.

2. Press the arrow keys, or Prev and Next, or Page Up and Page Down.

Hold down Control while you press an arrow key to scroll faster.
To use a slider:
1. Press Tab or an arrow key to move the highlight to the slider.

2. Press Up Arrow or Down Arrow to move the slider.

Hold down Control while you press an arrow key to move the slider faster.
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v To Select a List Item

A selected list item becomes highlighted. The highlighted item is acted upon

when you click a button, such as OK.

Mouse

1. Click the list item.

In a multiple-selection list, hold down Shift while you click the items.

To deselect an item, click it again.

2. Click a button, such as OK.

In some lists, double-clicking an item selects the item and chooses the default

command.

rar — Backdrop

b

Rakedsand |

v+ % | RicePaper
= |SkyDark
=t |Skylight

. |sprinkles
= Toronto
3 waterDrops
B waoly

py Warkspace

Close Help

Help Viewer

Three
Four

_ Al Workspaces

| OKI|

Cancel| Help|

Keyboard

1. Press Tab to move to the list.

2. Select the list item:

* In a single-selection list, use the arrow keys to reach your choice.

* In a multiple-selection list, use the arrow keys to reach your first selection,
then press Shift+Up Arrow or Shift+Down Arrow.

To deselect an item, press the Spacebar.
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3. Press Tab to move to a button, such as OK or Apply, then press Return.

v To Enter Text into an Empty Field

Text
insertion Enter file narme:
cursor T

0] | Llpdate| Cancel Help

A text field accepts information you type.

Mouse

1. Click the field to display the text insertion cursor.

2. Type the text.

In many dialog boxes, pressing Return completes the text entry and activates
the default button, such as OK or Apply.

Keyboard
1. Press Tab, Shift+Tab, or the arrow keys until you reach the text field.

A blinking cursor indicates that the text field has the keyboard focus.

2. Type the text, then press Control+Tab to move keyboard focus out of the text
field.
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v To Edit Text in a Field

Mouse

1. Select the text in the field to edit:

Characters Drag from the first character to the last character
Word Double-click the word

Line Triple-click the line

Multiline Quadruple-click the field

To deselect text, click an empty area in the window.

2. Type the replacement text.

Keyboard
1. Press Tab, Shift+Tab, or the arrow keys until you reach the field.

2. Use the editing keys to edit the field’s contents, then type the replacement

text.

Editing key Function

Arrow key Move the text insertion cursor

Backspace Delete the character to the left of the cursor

Delete or Delete char Delete the character to the right of the cursor

Control+Delete or
Control+Delete char  Delete from the cursor to the end of the line

3. Press Control+Tab to move keyboard focus out of the text field.
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Using Menus

Menus provide access to commands you use to manage windows and operate
software applications.

Choosing a menu item performs an associated action on the currently selected
object. For example, when you select a window and choose Minimize from its
Window menu, the window becomes an icon.

Menu items that appear dimmed are available only under certain conditions.
For example, the Window menu’s Restore item is available only when the
window is an icon.

Menus you’ll use on the desktop include:

®* Menus that you “pull down” from an application’s menu bar by clicking the
menu’s name or typing Alt and its mnemonic. A mnemonic is an underlined
character in a menu or item name.

—|

Mnemonic for the

File menu is Alt-F File Edit Format
 Mew = Shortcut key

for Print
Qpen.

Include...

Save
Save As.,
Print... Ctri+P

Close & [ t+F4

An application’s File menu is shown here.

The sequence of keys listed to the right of some items is called a shortcut key.
Typing mnemonics and shortcut keys gives you quick keyboard access to
menu items.
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® Menus that “pop up” when you click mouse button 3 (or press Shift+F10) in
an application window or on a workspace object.

Weorks pace Object

Remove From Workspace
DOpen Parent Folder
Rename

CIpen
Print

Window Menu
Use Window menu items to control windows and window icons.

This menu is displayed when you:

® Click the Window menu button in the upper left corner of a window

® Click on a window icon
® Press Alt+Spacebar with the keyboard focus on a window or window icon
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Window |
menu _—
button T
Move & lt+F7
Size & lt+F2
Minimize & t+F9
Maximize &lt+F10
Lower & lt+F3
Dccupy Workspace..,
laal
Close & [t+F
Restore Turns an icon back into a window
Move Changes the window’s location
Size Changes the size of the window (inactive for icons)
Minimize Turns the window into an icon
Maximize Enlarges the window to its greatest allowable size
Lower Moves the window to the background
Occupy Workspace Use to select the workspaces in which you want the

Occupy All Workspaces

Close

Workspace Menu

window to appear
Displays the window in all workspaces

Closes the window, removing it from the workspace

The Workspace menu is a pop-up menu that contains items for managing the

workspace.

To display the Workspace menu, click mouse button 3 on the workspace

backdrop.

Basic Skills
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Weorks pace Menu

Shuffle Up
Shuffle Down
Refresh

Minimize/Restore Front Panel

Restart Waorkspace Manager...

Log out,.,

Shuffle Up

Shuffle Down

Refresh

Brings the bottom window (in a stack of windows)
forward

Puts the top window (in a stack of windows) in the
background

Repaints the display

Minimize/Restore Front Panel

Turns the Front Panel into an icon or restores the Front

Panel from its icon

Restart Workspace Manager

Log out

Stops then restarts the Workspace Manager (typically

used after you have customized configuration files)

Begins the logout process (equivalent to the Front

Panel Exit control)

Note - You cannot access this menu through your keyboard.

Programs Submenu

You can also start many of the applications listed in the Programs submenu by
clicking their Front Panel controls or Application Manager icons.
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Warkspace Menu

Programs

Frograms
shuffle Up File Manager..
ShuTIe DF'W”_, s e, TERTEITOF.
T

AR . Calendar..
- Terminal...
CConsaole,,
Clock..
Calculator..

Ferformance Meter,.,
Printer Manager..
Audio Toaol..

Image WYiewer,,
Snapshot..,

lcon Editor..,

Stwle Manager..,
App Manager..,
Help..
answerBoolk,.,

Choose the following items to start
their associated OpenWindows
applications: Clock, Performance
Meter, and Answerbook.

You can also start the following
applications by clicking their Front
Panel controls: File Manager, Text
Editor, Mailer, Calendar, Print
Manager, Style Manager, and
Application Manager.

More OpenWindows desktop applications are available from within the
OpenWindows application group in Application Manager.

To Choose a Window Menu ltem

Mouse

+ Press mouse button 1 over the Window menu button or icon, drag to the

item, then release the mouse button.

Basic Skills
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Or:

1. Click the Window menu button to display the menu.

If the window is an icon, click the icon.
2. Click a menu item.

To close the menu without choosing an item, click anywhere other than the
menu.

Keyboard

1. Press Alt+Tab until you’ve placed the keyboard focus, as shown by the
highlight, on the window or window icon.

2. Press Alt+Spacebar to display the Window menu.

3. Press the key for the item’s mnemonic, the underlined character in the item
name.

To close the menu without choosing an item, press Esc.

v To Choose a Workspace Menu Item
1. Move the pointer over the workspace backdrop.
2. Press mouse button 3, drag to the item, then release the mouse button.

To close the menu without choosing an item, move the pointer away from the
menu and click.

Note — You cannot choose a Workspace menu item through your keyboard.

v To Choose a Menu ltem with the Mouse

1. Display the menu:
¢ Pull-down (menu bar) menu: Using mouse button 1, click the menu name.
* Pop-up menu: Click mouse button 3 inside the application.
* Object’s pop-up menu: Click the object with mouse button 3.

2. Click the item.
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You can also choose a menu item by pressing the mouse button, dragging to
the item, then releasing the mouse button.

To close a menu without choosing an item, move the pointer away from the
menu and click.

v To Choose a Menu Item with the Keyboard

Pull-down Menus

1. Press Alt+Tab until you’ve placed the keyboard focus, as shown by the
highlight, on the application window.

2. Display the menu by holding down Alt and then pressing the key for the
menu’s mnemonic (the underlined character in the menu’s name as shown
in the menu bar).

3. Press the key for the item’s mnemonic.

Or, press an arrow key to move to the item, then press Return.

Pop-up Menus

1. Press Alt+Tab until the keyboard focus is on the application window or
workspace object.

2. Press Shift+F10 to display the pop-up menu.

3. Press the key for the item’s mnemonic.

Or, press Down Arrow to move to the item, then press Return.
To close a menu without choosing an item, press Esc.

For more information about using your keyboard for desktop navigation, refer
to Appendix A, “Keyboard Shortcuts for the Desktop.”

Using Tear-Off Menus

In some applications such as Mailer and Calendar, you can tear off a menu,
which keeps it open on your desktop for repeated use. You can recognize the
availability of a tear-off menu by the appearance of a dotted line at the top of
the menu.
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Leaving the Desktop

32

v To Log Out

/N

To Invoke a Tear-Off Menu
1. Display the menu by clicking its name in the menu bar.
2. Click the dotted line above the first menu item.

The tear-off menu stays on your desktop until you dismiss it by either pressing
Alt+F4 or double-clicking the Window menu button (in the upper left corner of
the application’s window).

This section describes how to log out of and exit the desktop, and how to lock
your display to prevent unauthorized use of your system when you are away
from it and have not logged out.

Caution — Before logging out of the desktop, save your work in all open
application windows. Remember to check each workspace.

® Click the Exit control in the Front Panel.

Or, choose Log out from the Workspace menu:

=

Move the pointer over the workspace backdrop.

2. Press mouse button 3 to display the Workspace menu.

w

Drag to choose Log out, then release the mouse button.

Note - You cannot display the Workspace menu using your keyboard.
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As you log out of the desktop, your current session is saved. When you log
back in, the desktop will appear as it did before you logged out.

Applications that do not get saved as part of the current session include:

® Applications that you run in terminal emulator windows
®* Non-desktop applications that do not preserve their state during logout

You’ll need to restart these applications when you log in. For more
information, see Chapter 2, “Starting a Desktop Session.”

v To Lock Your Display

Getting Help

To prevent unauthorized use of your system when you are away from it and
have not logged out:

¢ Click the Lock control in the Front Panel.

E - | N

R =

To unlock your display, type your password.

For information about screen lock options, refer to Chapter 7, “Customizing
the Desktop Environment.”

You can request help by:

® Pressing F1 or the Help key

® Choosing an item from an application’s Help menu

® Clicking the Help button in a dialog box

® Opening the Help Manager to browse all the available help

For more information on using help, refer to Chapter 3, “Getting Help.”
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The quickest and easiest way to get help is to press the F1 key. When you press

F1, the application you are using displays the help topic most closely related to
your current activity.

Some keyboards have a dedicated Help key that may take the place of the F1
key.
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Help Menu

[ Help |

Cveryiew

Tasks

Tahle of Contents
Reference

an ltem

Using Help
About Text Editor

Most applications have a Help menu for requesting specific kinds of help.

Overview

Tasks

Reference

On Item

Using Help
About ...

Displays introductory information about the
application

Displays instructions for using the application

Displays summary information about application
components

Changes the pointer to a question mark—click the
qguestion mark pointer on an item to display its
description

Displays information about using Help

Displays version and copyright information about the
application (in this case, Text Editor)

To learn more about using help windows, choose Using Help from an
application’s Help menu. Or, you can press F1 while using a Help window.

v To Display the Help Manager

The Help Manager lists all the online help volumes installed on your system.

1. Click the Help Manager control in the Front Panel.

The Help Viewer opens, displaying the Help Manager.

2. Choose the Common Desktop Environment topic to display the list of help
volumes for the desktop.

3. Browse the list of titles. To open a volume, click its title.

Basic Skills
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Starting a Desktop Session 2

A desktop session occurs between the time you log in and the time you log
out.

The login screen, displayed by the Login Manager, is your gateway to the
desktop. It provides a place for you to type your login name and password.
The Options menu on the login screen lists your login options. In addition to
running a desktop session, you can run a failsafe session. You can also select
the language for your session.

Starting and Ending a Desktop Session 37
To Use a Session in a Different Language 38
Starting a Failsafe Session 39
Starting a Command-Line Session 39
Using a Home Session 40

Starting and Ending a Desktop Session

A desktop session starts when you log in. Session Manager is started after
Login Manager authenticates your login and password.

Session Manager provides the ability to manage sessions—to remember the
state of your most recent session and return you there the next time you log in.
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Session Manager saves and restores:

® The appearance and behavior settings — for example, fonts, colors, and
mouse settings.

® The window applications that were running — for example, your File
Manager and Text Editor windows. Certain types of applications can't be
saved and restored by Session Manager. For example, if you start the vi
editor from a command line in a Terminal window, Session Manager cannot
restore your editing session.

v To Log In to a Desktop Session
1. Type your login name and press Return or click OK.

2. Type your password and press Return or click OK.

If Login Manager does not recognize your name or password, click Start
Over and start the log in process over again.

Once you've logged in, Session Manager starts a session:

If this is the first time you've logged in, you'll get a new session.
If you've logged in before, your previous session will be restored.

v To Log Out

® Click the Exit control in the Front Panel.

® Or, choose Log out from the Workspace menu.

When you log out of a regular desktop session, Session Manager saves
information about your current session so that it can be restored the next time
you log in. Information about non-desktop applications may not be saved.

v To Use a Session in a Different Language
1. Choose Language from the Options menu on the login screen.
2. Choose the language group that includes the language you need.
3. Select a language.

4. Log in.
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The default language for your system is set by your system administrator. The
Options menu enables you to access other languages. Choosing a language in
the Options menu sets the LANG environment variable for your session. The
default language is restored at the end of the session.

Starting a Failsafe Session

A failsafe session is a session that starts a single Terminal window (and
optionally Workspace Manager). It is useful when you need access to a single
Terminal window to execute several commands before logging in to a desktop
session.

v To Log In to a Failsafe Session
1. Choose Session from the Options menu.
2. Choose Failsafe Session from the Session submenu.

3. Log in.

v To Log Out of a Failsafe Session

¢ Type the exit command in a Terminal window.

Starting a Command-Line Session

Command Line Login mode enables you to temporarily leave the desktop to
work in your operating system enviroment. Command Line Login mode is not
a desktop session. When your system is in Command Line Login mode, the
desktop is suspended. You log in using your operating system mechanism
rather than Login Manager. There are no windows because the X server is not
running.
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v To Log In to and Out of a Command-Line Session

Using a Home Session

Note — Certain types of configurations (for example, X terminals) do not
provide a Command Line Login mode option.

To enter Command Line Login mode:

1. Choose Command Line Login from the Options menu.

The login screen disappears and is replaced by a console prompt.
2. Supply your login and password as prompted.
To leave Command Line Login mode:

¢ Type exit at a command-line prompt.

Ordinarily, the desktop saves session information when you log out and uses
that information to start your next session. If you start or stop applications
during your session, or use Style Manager to change the appearance and
behavior of your system, changes you make are reflected in your next session.
This type of session is called a current session.

The desktop also provides a home session. A home session is a session that you
explicitly save. It's like taking a snapshot of your current session at some point
in time. Once you've saved a home session, you can specify that logging in
always restores that session instead of the current session.

v To Save a Home Session

40

1. Click the Style Manager control in the Front Panel.

2. Click the Startup control in Style Manager.
The Startup dialog box is displayed.

3. Click Set Home Session in the Startup dialog box.

4. Click OK in the confirmation dialog box that appears.

This saves the current state of your session.
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v To Automatically Start the Home Session at Login
1. Click the Style Manager control in the Front Panel.

2. Click the Startup control in Style Manager.
The Startup dialog box is displayed.

3. Select Return to Home session.
4. Click OK.

When you choose Return to Home session, Session Manager will not save your
session at logout.

¥ To Choose between the Current and Home Session for Each Session
1. Click the Style Manager control in the Front Panel.

2. Click the Startup control in Style Manager.
The Startup dialog box is displayed.

3. Select Ask Me at Logout.
4. Click OK.

You decide what will be your next session—current or home—at logout time. If
you choose to return to the home session, the current session information is not
saved. (You cannot change your mind the next time you log in.)
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GettingHelp

Online help is available for each of the standard applications in the Common
Desktop Environment (CDE). Whether you are using File Manager, Calendar,
or Mailer for example, you request and display help topics in the same way.
You can also browse help information on your system using the desktop Help
Manager.

Other applications installed on your desktop may take advantage of using
the desktop’s Help System or provide help in other ways.

Requesting Help 44
Using Help Windows 47
Selecting Help Topics 48
Moving between Help Topics 50
Searching for Specific Information 52
Browsing Help on Your System 55
Printing Help Topics 59
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Requesting Help

Here are the ways you can request Help:

® Press Fl—also known as the “help key”—to get context-sensitive help

® Choose a command from an application’s Help menu

® Open Help Manager from the Front Panel to browse help on your system

® Open the Help subpanel to choose help about the desktop or to choose On
Item Help

Press F1 — The Help Key

When you have a question, the quickest and easiest way to get help is to press
F1. When you press F1, the application you are using displays a help topic
most closely related to the component—a window or button for example—that
is highlighted. Because the application determines which help topic is most
appropriate, this type of help is called context-sensitive.

The F1 key is a quick way to get help on an application menu or dialog box.
For example, to request help about the File Manager File menu, display the File
menu and press F1. File Manager displays a description of each item in the
menu. Or, if a dialog box is open, pressing F1 will display an explanation of the
dialog box. The F1 key is a shortcut for clicking the dialog box’s Help button.

Note — Some computers have a dedicated “Help” key on the keyboard. If yours
does, it may take the place of the F1 key.

Using an Application’s Help Menu

44

Most applications have a Help menu that contains commands for requesting
different types of help such as an introduction, application tasks, or reference
information.
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Figure 3-1 CDE application Help menu

A typical CDE Help menu includes these commands:

Overview

Tasks

Reference

On Item

Using Help

About Application

Displays the home topic for the application. The home
topic is the first topic of the application’s help topic
hierarchy.

Displays task instructions for most operations performed
with the application.

Displays reference summaries for various components,
such as windows and dialog boxes, menus, and
application resources.

Enables you to click an item in any window of an
application and view a description of the item.

Provides help on using the help windows.

Displays the version and copyright information for the
application.

Applications can include additional choices. Also, non-CDE applications may
have different commands in their Help menus.

On Item Application Help

On Item help is interactive. It enables you to move the pointer to a specific
item (such as a menu, button or dialog box) and click the item to display its

corresponding help.

Getting Help

45



1]
w

v To Select On Item Help
1. Choose On Item from the Help menu.
The pointer changes to a ? (question mark).
2. Move the pointer to an item in the application and click mouse button 1.

A description of the item is displayed.

Using Help Manager

Help Manager is a special help volume that lists all the online help registered
on your system. Clicking the Help Manager control in the Front Panel opens
the Help Manager help volume.

i) 1

Figure 3-2 Help Manager control

Click any of the underlined titles to view the corresponding help information.
For additional instructions about using Help Manager see “Browsing Help on
Your System” on page 55.

For convenience, you can also find help about the desktop and the Front Panel
in the Help subpanel. It also provides On Item help for the Front Panel and its
subpanels.

—-| Help |

Install Icon

[idl] et Manager

= | Deskiop Introduction

= pront panet eip

=
A9 onttem Help

Figure 3-3  Help subpanel

46 Solaris CDE User’s Guide—February 1997



Using Help Windows

Topic free

Tapic
display area

The Help System is built into each of the CDE applications (and possibly other
applications installed on your system). When you ask for help while using an
application, the application displays a help window.

Applications can use two types of help windows to display help topics: a
general help window and a quick help window, shown in Figure 3-4.
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Quick help window

General help window
Figure 3-4  Types of help windows

General help windows have a topic tree and a topic display area. The topic tree
is a list of help topics that you can browse to find help on a subject. When you
choose a topic, it is displayed in the lower portion of the help window called
the topic display area.

Quick help windows are streamlined help windows. A quick help window has
just a topic display area and one or more buttons.
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Selecting Help Topics

There are two ways to select a help topic. You can choose a topic from the topic
tree. Or, within a help topic, you can select a hyperlink. A hyperlink is an active
word or phrase that “jumps” to another related help topic. Any underlined text
in a help window is a hyperlink.

Graphic images can also be used as hyperlinks. For more information about
hyperlinks, see “Using Hyperlinks” on page 49.

Using the Topic Tree

48

The topic tree is an outline of a help volume’s major topics. Subtopics are
indented under main topics. The current topic, whose contents are displayed in
the topic display area, is marked with an 00 (arrow). You can scroll the topic
display area to see all your choices or resize the entire help window.

You can also change the size of the topic pane. To do so, drag the sash control
shown in Figure 3-5. Then release the mouse button to set the new size.
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Figure 3-5 Resizing the topic tree
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v To Select A Topic
1. Move the pointer into the topic tree.

2. Click mouse button 1 on the topic you want to display.

Using Hyperlinks

Any underlined text in a help window is a hyperlink. It is easy to “jump” to
related help topics using hyperlinks—just click the underlined text.

What Hyperlinks Look Like

A solid underline identifies a standard hyperlink that displays the new topic in
the current help window. For example, the last paragraph in Figure 3-5 shows
a hyperlink of this type.

A dashed underline indicates a definition link, which displays a quick help
window.

A graphic—an icon, for example—can also be a hyperlink. A grey open-
cornered border identifies a graphic hyperlink. Figure 3-6 shows the different
hyperlink formats that can be used in help topics.

Standard Links Definition Links

Figure 3-6  Hyperlink formats

Links That Display a New Window

Most hyperlinks display the related topic in the same window. However, if you
choose a hyperlink that jumps to a help topic for another application, a new
window is displayed. Links that jump from one application’s online help into
another’s are called cross-volume or cross-application hyperlinks.
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v To Select A Hyperlink
1. Move the pointer to the underlined text or graphic image.

2. Click mouse button 1.

Moving between Help Topics
To move between help topics, use these commands on the Navigate menu:

Backtrack Returns to the previous topic. Backtrack enables you to return
to each topic you have visited.

History Displays a History dialog box that lists help volumes and
topics you have visited. Select a help topic to re-display it.

Home Topic  Returns to the home topic, or beginning of the help volume.

For convenience, Backtrack and History are also provided as push buttons.

Help Pop-up Menu

In a general help window, you can also use the Help pop-up menu as a
shortcut. The pop-up menu includes both Backtrack and Home Topic, which
are frequently used commands.

Quick help windows do not have a pop-up menu.

v To Display the Help Pop-up Menu
1. Point to the topic display area and press mouse button 3.

2. Choose Backtrack or Home Topic.

To Delete o Paleiis
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Figure 3-7  Help pop-up menu
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Location Indicators

Because hyperlinks can quickly take you from one piece of information to
another, you may need to know where you are. A quick look at your help
window can give you the information you need.

® The line located below the menu bar reports the name of the volume you are
viewing. This is helpful when you have explored several help volumes
using Help Manager, the help index, or cross-volume links.
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® Within the topic tree, the first item is the home topic, or the beginning of the
help volume. After exploring topics, you can easily return to the home topic
by scrolling to the top of the topic tree. Or, you can choose Home Topic from
the Navigate menu or pop-up menu.

® An O (arrow) points to the title of the current topic. As you choose topics,
the arrow moves to identify your selection. Scrolling the topic tree shows
you where you are located relative to other topics.

Knowing Where You’ve Been

A general help window keeps track of the topics that you have visited. The
History command opens a dialog box that lists the help volumes and help
topics you have visited.
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Figure 3-8  History dialog box

v To Use History To Return to a Topic
1. Click the History button.
2. Choose the title of the help volume or topic that you want to display.

3. When you’re done, click Close.

Searching for Specific Information

52

Like a book, a help volume has an index of important words and phrases that
you can use to find help topics on a subject. You can browse or search the
index of the current volume, selected volumes, or all help volumes available on
your system.
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Figure 3-9  Index Search dialog box

Because the help index can be quite large even for a single volume, index
entries can be expanded or contracted. A + (plus) sign indicates that the index
entry relates to more than one help topic. The number shows the count of help
topics. You can click the index item to list the topics.

For instance, the result of an index search for the word “display” is shown in
Figure 3-9. The -36 prefix tells you that there are 36 index entries that contain
the keyword “display.” Clicking any title marked by a + (plus) expands the list
and the + (plus) changes to a - (minus) sign. The last index entry shown in the
figure has been expanded in this way.

v To Search for Topics Using the Help Index

Note — The help index is available only in a general help window
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. To open the index, click the Index button.

The index lists all of the entries for the current help volume. You can choose
All Volumes to view an index for all available help volumes or choose
Selected if you want to select only certain volumes.

. Select the Entries with field, type the word or phrase you are looking for,

and press Return.

Index searches are not case sensitive. Wildcards such as * (asterisk) and ?
(question mark) can be used (see “Pattern Searches” below).

. Select the index entry you want to view.

If the entry has a + (plus sign) prefix, the list will expand to show additional
choices. Then select a help topic to view.

You may view as many topics as you want.

. Click Close when you are done.
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Pattern Searches

In a pattern search certain characters (known as “wildcards”) have special
meaning. You can combine these characters in a variety of ways.

Two frequently used wildcards are asterisk (*) and question mark (?). The *
matches any string of characters (including no characters), and ? matches any
single character. Other wildcards include:

. (period) Matches any character

| (vertical bar) Specifies two search patterns and matches either
pattern (logical OR)

() (parentheses) Encloses a pattern expression

To search for a character that has special meaning in a regular expression,
precede the character with a \ (backslash).

Examples

mouse.*clicking Matches entries that contain the word “mouse”
followed by any number of characters followed
by “clicking”

mouse | click Matches entries that contain the word “mouse”
or “click”

(session | style).*manager  Matches entries that contain “Session Manager”
or “Style Manager”

Browsing Help on Your System

You can browse all application help volumes registered on your system
without having to start each individual application—just start Help Manager
from the Front Panel.

At the top level, Help Manager groups help volumes into help families. For
example, the help family Common Desktop Environment lists help volumes
for the standard desktop applications. You can browse and display any of the
volumes listed.
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v

To Open Help Manager

1. Click the Help Manager control in the Front Panel (see Figure 3-2 on
page 46).

A help window displays a list of help families with online help. This is the
top level of Help Manager.
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Figure 3-10 Top-level view in Help Manager

2. Scroll the window to find the product group you are interested in and click
its title (underlined).

This lists the help volumes available for that product.
3. To open a particular help volume, click its title (underlined text).

4. To return to the top level of Help Manager, click the Top Level button.

Solaris CDE User’s Guide—February 1997



w
1]

For example, to browse File Manager’s online help:

1. Click the Help Manager control.

2. Choose Common Desktop Environment.

3. Scroll the list of help volumes until you see File Manager Help.
4. Click File Manager Help.

File Manager’s help is displayed. This is the same help information you
would see if you opened File Manager and chose Overview from the Help

menu.

fil-a- E_dil: Zearch !v!:mn'-nall.- Help

Wohena: Fii= Mensge Help

= File Manager Help Hackirack |
Talla ef Contenla .
Fim Minringer Tanks History.... |
Fia Wiuron gar Corcapi :
Fiis Wisrugar Kafarancs Irdes. ..
File haru o hisduagss
“Foaary Top Lavel|

File: .\-hna.ﬂhr Hnlp

Lhe File Menage: In crexie, ind, asd use workapsce shjecse S
Foldery, and sppde-xione. Each ohigscl B epiesemad by an itan n
Fili PARRADEE. Filg WA IJET BICRNY 040 B9 00 0 e bt af [herge
wiilh Hved e ORPICTS. For Caaipie, YouU CEN R0y, COAy, OpEn, and
ik & 17w

Figure 3-11 File Manager help viewed in Help Manager

v To Duplicate a Help Window

1. Choose New Window from the Help Manager File menu.

The current help window is duplicated. You can size the new window and
select topics independently of the original window.
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2. To remove the window, choose Close from the File menu.

Note — The New Window command is only available in the Help Manager help
window (see “Browsing Help on Your System” on page 55.

Displaying AnswerBook

Online manuals can be displayed by choosing AnswerBook from the Help
subpanel.

Displaying a Man Page

Manual reference pages, traditionally known as “man pages,” can be displayed
using the Man Page Viewer action. The action icon is located in the
Desktop_Apps folder in Application Manager.
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Figure 3-12 Man Page action icon
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v To Display a Man Page

Printing Help Topics

1. Click the Application Manager control in the Front Panel.

2. Double-click the Desktop_Apps icon.
3. Click the Man Page Viewer icon.

A dialog box is displayed, prompting you to enter a man page name.
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4. Type the name of the man page you want to see and press Return.
The man page is displayed in a quick help window.

5. Click Close to dismiss the man page.

Sometimes you may want to have a printed version of a help topic for a
particular application. You can print an individual help topic, a table of
contents and index, or the entire help volume. Printing options, such as paper
size, number of copies, and destination printer, can also be set in the Print
dialog box.

Printed help topics are directed to your default printer unless you provide a
different printer name in the dialog box. Printed output is text only.

Getting Help 59



1]
w

v To Print a Help Topic

1. Choose Print from the File menu. (In a quick help window, click the Print
button.)

You can use the default values in the Print dialog box and skip to step 5 or
enter new values for your print job.
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2. Optional. Type the name of the printer that you want to use.

Optional. Type the number of copies to print.

A ow

Optional. Click the paper size button to choose a paper size.

5. Select the topic or topics you want to print.

Current Topic (the default) Prints only the current topic

Current and Subtopics Prints the current topic and its subtopics

Table of Contents and Index  Prints the help volume table of contents
and index

Entire Volume Prints the contents of the help volume

including the table of contents and index
6. Click Print.
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Printing Configuration

The Print dialog box displays the name of your default printer. You can change
the default printer name by modifying the LPDEST environment variable. You
can also change the printer for a specific application by modifying the
application’s application defaults file.

v To Set the Printer Resource for an Application

+ Edit your HomeDirectory/.Xdefaults file by adding this resource:

application_name*printer printer.name
If you do not have an .Xdefaults file, create the file in your home
directory.
Example

You want to direct all printed help topics of an application named ImageScan
to a printer named laser2 rather than to your default printer.

Add this resource to your .Xdefaults file:

ImageScan*printer: laser2

Modifying Help Window Colors

You can change the colors of the topic tree or topic display area of a help
window by setting application resources. Choosing constrasting colors is
important. This ensures that text (foreground color) will be visible against the
background color.
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v To Change Help Window Colors for an Application

1. Edit your HomeDirectory/.Xdefaults file by adding these resources:

application_name*DtHelpDialog*DisplayArea.foreground: color
application_name*DtHelpDialog*DisplayArea.background: color
application_name*DtHelpDialog*TocArea.foreground: color
application_name*DtHelpDialog*TocArea.background: color
application_name*DtHelpQuickDialog*DisplayArea.foreground: color
application_name*DtHelpQuickDialog*DisplayArea.background: color

Substitute the name of the application whose help windows you want to
change for application_name.

You can ask your system administrator for a list of colors that you can use
or refer to your system documentation.

2. Save and close the file.

When you restart your application, it will use the new color values for the
topic tree and topic display area in its help windows.

For example, these resource entries change the foreground and background
colors of the topic tree (TocArea) and topic display area (DisplayArea) for an
application named DtCardCatalog.

DtCardCatalog*DtHelpDialog*TocArea.foreground: yellow
DtCardCatalog*DtHelpDialog*TocArea.background: blue
DtCardCatalog*DtHelpDialog*DisplayArea.foreground: yellow
DtCardCatalog*DtHelpDialog*DisplayArea.background: blue
DtCardCatalog*DtHelpQuickDialog*DisplayArea.foreground: yellow
DtCardCatalog*DtHelpQuickDialog*DisplayArea.background: blue

Quick help windows do not have a topic tree, so the TocArea resource is
omitted.
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Using the Front Panel 4

The Front Panel is a special desktop window that contains a set of controls for
doing common tasks. The Front Panel moves with you as you switch

workspaces.
Front Panel Elements 63
Basic Front Panel Skills 66
Tour of the Front Panel 71
Customizing the Front Panel 83
Customizing Workspaces 85

Front Panel Elements

The two main elements of the Front Panel are the Main Panel and the
subpanels. The Main Panel includes the workspace switch.
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Main Panel

The Main Panel is the horizontal window at the bottom of the display.

u]
-

.3_\'.‘,_1 Exl ﬁu_ﬂﬂ

Subpanels

It contains a number of controls you use often, including the workspace
switch, which contains buttons for changing to other workspaces.

Many of the controls in the Front Panel start applications when you click
them—for example, the File Manager and Style Manager controls.

Some controls are drop zones—for example, the Printer and Trash Can
controls. You can drag a file from File Manager or Application Manager to the
control.

Certain controls, such as the clock and busy light, are indicators that tell you
something about the state of your system. Other controls have a dual purpose;
for example, the Calendar and Mailer controls are both indicators (showing
today’s date and the arrival of new mail, respectively) and buttons for starting
applications.

If a control in the Main Panel has an arrow button on top of it, then that control
has a subpanel.
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Subpanels always contain:
® An Install Icon control. Use this control to customize the subpanel.
® A labelled copy of the control in the Main Panel.

The Workspace Switch

The workspace switch contains the buttons you use to change from one
workspace to another. The workspace switch also contains several controls.

Welorkspace bauttons

Warkepase Switch

Each workspace occupies the entire display, as though your display has several
layers. Workspaces multiply the amount of display area available for windows.
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Basic Front Panel Skills

66

This section covers basic skills for using Front Panel controls and subpanels.

v To Activate a Front Panel Control
¢ Click or double-click the control.

Some controls do not have a click action—for example, the Clock control and
the busy light.

v To Open a Subpanel
Controls that have subpanels have an arrow button on top of the control.
¢ Click the arrow button above the control.

Click here
N

¥ g “L e

v To Close a Subpanel

The subpanel closes automatically when you choose a control unless you have
moved the subpanel from its original location.

® Click the arrow control for the subpanel.

® Or, double-click the window button in the upper left corner of the subpanel
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Front Panel Pop-Up Menus

Each control in the Front Panel has a pop-up menu. The menu is different for
each control.

v To Display a Front Panel Pop-Up Menu
1. Point to the control.

2. Press and hold down mouse button 3.

Contents of the Pop-Up Menus

The contents of the pop-up menu depend on the behavior of the control and its
location.

Main Panel Controls

If the control starts an application, the first entry in the menu is a command
that starts the application. Choosing the menu item has the same effect as
clicking the control.
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In addition, the pop-up menu may contain these items:

Add Subpanel Adds a subpanel to the control

Delete Subpanel Removes the subpanel and its contents
Help Displays On Item help for the control
Switch Area

The switch area is the portion of the workspace switch not occupied by other
controls or workspace buttons.

=
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The switch area pop-up menu contains these items:

Add Workspace Adds a workspace and creates a workspace button in
the workspace switch

Help Displays help for the workspace switch
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Workspace Buttons

Use the workspace buttons to change workspaces. Each button has its own
menu.

o
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The workspace button pop-up menu includes these items:

Add Workspace Adds a workspace to your list of workspaces

Delete Deletes the workspace

Rename Changes the button into a text field for editing the
name

Help Displays help for the workspace switch

Subpanel Controls

The pop-up menus for subpanels include a command for making the control
the current Main Panel control.

Personal Applications

L
= :
- Terminal
# Terminal
e Coapy To Main Panel
| Delete
X it Hel
_E\g - 1l |

The pop-up menu for subpanel controls includes these items:

Copy to Main Panel  Duplicates the control in the Main Panel, replacing the
current Main Panel control
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Delete Deletes the control from the subpanel

Help Displays On Item help for the control

Front Panel Help

You can get help on:

® Individual controls
® Using and configuring the Front Panel

v To Get On Item Help on a Front Panel Control
+ Choose Help from the control’s pop-up menu.
Or:
1. Display the Help subpanel.

2. Click the On Item Help control.

The pointer changes shape.

3. Click the control on which you want help.

v To Get Help on Using and Configuring the Front Panel
1. Display the Help subpanel.
2. Click the Front Panel Help control.

This displays the Help Viewer and Front Panel help volume.

v To Move the Front Panel or a Subpanel
Subpanels are moved like other windows—»by dragging the title bar.

The Main Panel is moved using its move handles.
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¥ To Minimize the Front Panel

Tour of the Front Panel

Minimizing the Front Panel turns it into an icon.

¢ Click the Front Panel’s minimize button.
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The Front Panel window icon is labeled with the workspace name.

This section introduces the contents of the Main Panel and the subpanels:

Folders subpanel

Personal Applications subpanel
Personal Printers subpanel
Applications subpanel

Help subpanel

Your Front Panel may be customized with different or additional controls.
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Main Panel

T IR
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The Main Panel is the horizontal window at the bottom of the display

Table 4-1 describes the Main Panel controls.

Table 4-1 Main Panel Controls

(Text Editor)

Name Click Behavior Drop Behavior Indicator Behavior
i i Clock None None Current time of day
Calendar Starts the desktop Dropping an appointment | Current date
Calendar application file adds the appointment
to the calendar
- Folders Opens a File Manager Dropping a folder opens a | None
r- I (File Manager) | view of your home File Manager view of that
folder folder
Personal Starts the desktop Text Opens the file in a new None
':\L Applications Editor application Text Editor window

Mailer Starts the desktop Mailer | Opens the contents of the Changes appearance
,.-" application file in Mailer’s New when new mail arrives
4 Message window
Lock Locks the display and None None
[ra keyboard. You must type
=
your password to unlock
the system.
Workspace Changes workspaces None Indicates current
| Lo switch workspace

72
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Table 4-1 Main Panel Controls (Continued)

Name Click Behavior Drop Behavior Indicator Behavior
Busy light None None Blinks when the system
. is running an action
Personal Displays the status of the | Prints the file on the None
e Printers default printer printer
(Default)
Exit Begins logout from the None None
EXIT current session
Style Manager Opens the desktop Style None None
jﬁ- Manager application
Applications Opens an Application None None
u . . .
— I (Application Manager window
Manager)
Help Opens a Help Viewer Dropping a master volume | None
window displaying the file (*.sdl ) opens a Help
top level of help Viewer window with that
information help volume
Trash Can Opens the Trash Can Moves the file to the Trash | Different appearance

window

Can

when empty and
non-empty

Using the Front Panel
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Folders Subpanel

Use the File Manager subpanel to access your home folder or to open a floppy
diskette or CD-ROM that you have inserted into a disk drive.

Folders |

The following table describes the File Manager subpanel controls:

Table 4-2 Folders Subpanel Controls

Drop Behavior

Indicator Behavior

Home Folder

Opens your home
folder displaying the
top level file and folder
information

view of the dropped
folder

Name Click Behavior
Install Icon None Installs an icon dragged |[None
- ffrom File Manger or
I/Application Manager
into the subpanel
Opens a File Manager None
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Table 4-2

Folders Subpanel Controls

Name

Click Behavior

Drop Behavior

Indicator Behavior

Personal Bookmarks

Opens your Personal
Bookmarks folder
displaying bookmarks

Dropping text onto the
control creates a file
with a .url extension
in the Personal
Bookmarks folder

None

Open Floppy Opens one File None Not Applicable
E Manager window for
L each readable floppy
diskette you insert
Open CD-ROM Opens a File Manager None Not Applicable

window for each CD-
ROM you insert

Using the Front Panel
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Personal Applications Subpanel

Use the Personal Applications subpanel for applications you use frequently.
The default applications are Text Editor, Terminal, and Icon Editor.

| Personal Applications|

|!H, :_Il [P

The following table describes the Personal Applications subpanel controls.

Table 4-3 Personal Applications Subpanel Controls

Name Click Behavior Drop Behavior Indicator Behavior
Install Icon None Installs an icon dragged None
from File Manger or
Application Manager into
the subpanel
Text Editor Starts the desktop Text Opens the file in a new None
(duplicate of Editor application Text Editor window
control in Main
Panel)
Terminal Starts the desktop None None

Terminal Emulator

Web Browser Starts the Hotlava web None None
browser if PATH
contains the hotjava
command
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Personal Printers Subpanel

Use the Personal Printers subpanel for printers you use frequently.

Ferseanal FrinLer &
Inedadl kcon
TR

|'1"F|!|IMII'|-C|:|(‘1

The following table describes the Personal Printers subpanel controls.

Table 4-4 Personal Printers Subpanel Controls

Name Click Behavior Drop Behavior Indicator Behavior
Install Icon None Installs an icon dragged None
from File Manger or
Application Manager into
the subpanel
Default printer Display the status of Prints the file on the None
(duplicate of print jobs on the default | default printer or another
Main Panel printer printer of your choice
control)
Print Manager Starts the desktop Print Prints the file on the None

Manager default printer

Using the Front Panel
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Applications

Subpanel

Use the Applications subpanel for system applications and tools you use
frequently.

Applications

i

Gl [

The following table describes the Applications subpanel controls.

Table 4-5 Applications Subpanel Controls

Name Click Behavior Drop Behavior Indicator Behavior
Install Icon None Installs an icon dragged None
from File Manger or
Application Manager into
the subpanel
IApplications Opens an Application None None
-i Manager window

78
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Table 4-5 Applications Subpanel Controls

Name Click Behavior Drop Behavior Indicator Behavior
Desktop_Apps Opens the Desktop_Apps |None None
folder
Desktop_Controls  |Opens the None None
E Desktop_Controls folder
Information Opens the Information None None

ffolder

Using the Front Panel
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Help Subpanel

The Help subpanel enables you to access the Help Manager, Desktop
Introduction, and Front Panel help volumes, and On Item help.

Help |

1M 8

D el

The following table describes the Help subpanel controls.

Table 4-6 Help Subpanel Controls

the Desktop”

Name Click Behavior Drop Behavior Indicator Behavior
Install Icon None Installs an icon dragged None
from File Manager or
Application Manager into
the subpanel
) Help Manager Opens a Help Viewer Dropping a master volume | None
]E (duplicate of window displaying the file (*.sdl ) opens that
Main Panel top level of help help volume
control) information
Desktop Displays the help None None
E Introduction volume “Introducing
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Table 4-6 Help Subpanel Controls

Name Click Behavior Drop Behavior Indicator Behavior
- Front Panel Displays the Front Panel | None None
ol Help help volume
On Item Help Provides on-item help None None
E for the Front Panel. Click
this control, then click
the control on which you
want help.
AnswerBook Displays AnswerBook None None
@ viewer if you have
AnswerBook installed.

Using the Web Browser

The Personal Applications subpanel of the Front Panel contains a Web Browser
control. When you click the control, your PATHenvironment is searched for the
hotjiava command (for the Hotlava browser) or netscape command (for the
Netscape browser). You or your system administrator must customize your
login environment to include the browser commands if you want to use the
Web Browser control. See Solaris Common Desktop Environment: Advanced
User's and System Administrator's Guide for details on how to customize your
user PATHenvironment. Read about customizing the .dtprofile file if you
want the change to be specific to a user. Read “Changing the User or System
Path” if you are a system administrator and want the change to be network-
wide.

If the hotjava command is found, the HotJava browser is launched. If it is not
found in your PATH and the netscape command is found, the Netscape
browser is launched. If neither is found, an error dialog box appears reporting
the failure to find a browser. If you want Netscape to be your default browser,
and you have access to both Hotlava and Netscape, change the line

MAP_ACTION SDtHotJava
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Bookmarks

to

MAP_ACTION SDtWebClient

in your user-prefs.dt file.

A bookmark is a file containing a Web URL, or a folder or attachment
containing bookmarks. The Sample Bookmarks folder in the Application
Manager Information folder contains examples of bookmarks. Clicking on a
bookmark's icon brings up your default web browser with the web page
displayed that is described by the bookmark URL. Double click on the
index.html icon in the Sample Bookmarks folder to read about bookmarks.

Personal Bookmarks

The Folders subpanel of the Front Panel contains a Personal Bookmarks
control. When you click on the control, a File Manager view appears on the
desktop. It is initially empty. You can create bookmarks to put in this folder.
These Web URLs are then easily accessible through the Front Panel.

Creating Bookmarks

You can create bookmarks in any of the following ways:

® Copy an existing bookmark: Use the File Manager Selected menu to copy an
existing bookmark into your Personal Bookmarks folder, or hold down the
Control key and drag the icon onto the opened Personal Bookmarks File
Manager window or the Personal Bookmarks control on the Front Panel.

® Drag URL text onto the Personal Bookmarks window. This creates a new
file. The new file name is Untitled.url unless there is another file in your
Personal Bookmarks folder with that name. In that case, a dialog box
appears telling you to rename the new file.

®* Drag URL text onto the Personal Bookmarks control on the Front Panel. This
creates a new file with a .url extension.

You can create a bookmark using any URL that is normally available, such as
URLSs with http addresses.
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Sharing Bookmarks

If you drop URL text or a bookmark file or folder onto the Front Panel mail
icon, a mail compose window appears with the corresponding bookmark as an
attachment.

Customizing the Front Panel

There are two types of Front Panel customization:

® Easy customization

This is customization you can do using the desktop’s interface, including:
* Adding controls to subpanels

« Interchanging Main Panel and subpanel controls

* Adding subpanels

* Adding and deleting workspaces

« Renaming workspaces

® Advanced customization

This is customization that requires you to create or edit a Front Panel
configuration file. For more information, see the Advanced User’s and System
Administration Guide.

v To Put a Subpanel Control in the Main Panel
1. Point to the subpanel control you want to put in the Main Panel.
2. Choose Copy to Main Panel from the control’s pop-up menu.
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v To Add an Application or Other Icon to a Subpanel

You can add any type of File Manager or Application Manager icon to the
Front Panel. However, the most convenient use for this feature is adding
application icons.

1. Display the object’s icon in File Manager or Application Manager.
2. Display the subpanel to which the object is to be added.

3. Drag the object to the Install Icon control and drop it on the control.

How Installed Icons Work

The behavior of controls added to the Front Panel using the Install Icon control
depend on the type of icon that was dropped.

Type of Icon Installed  Behavior

File The same behavior as the file’s icon in File Manager
Folder Opens a File Manager view of the folder
Application group Opens an Application Manager view of the

application group
Application icon The same behavior as the application’s icon in File
Manager or Application Manager
Adding and Removing Subpanels

Any control in the Main Panel can have a subpanel.

v To Add a Subpanel
1. Point to a control in the Main Panel that does not have a subpanel.

2. Choose Add Subpanel from the control's pop-up menu.

v To Remove a Subpanel
1. Point to the control whose subpanel you want to remove.

2. Choose Delete Subpanel from the control's pop-up menu.

84 Solaris CDE User’s Guide—February 1997



N
Il

v To Replace a Control in the Main Panel

The easiest way to replace a control in the Main Panel is to exchange it with a
subpanel control. If the control does not have a subpanel, you can create one
temporarily or permanently.

1. If the control you want to replace does not have a subpanel, create one by
choosing Add Subpanel from the control’s pop-up menu.

2. Display the new subpanel.

3. If the control you want to put in the Main Panel is not already in the
subpanel, add it to the subpanel.

See “To Add an Application or Other Icon to a Subpanel” on page 84.

4. Choose Copy to Main Panel from the subpanel control’s pop-up menu.

v To Remove All User Customizations

Note — This procedure does not affect advanced customizations made by
manually editing Front Panel configuration files.

1. Open Application Manager and double-click the Desktop_Tools application
group icon.

2. Double-click Restore Front Panel.

The screen will go blank for several seconds while the Workspace Manager
is restarted.

The Restore Front Panel action removes all customization made using:

® The Install Icon control
® The Front Panel’s pop-up menus

Customizing Workspaces

You can use the Front Panel workspace switch to rename workspaces and
change the number of workspaces.
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v To Rename a Workspace
1. Point to the workspace button of the workspace you want to rename.

2. Choose Rename from the button’s pop-up menu (displayed by presssing
Shift+F10 or mouse button 3).

The workspace button turns into a text field.
3. Edit the text field.

4, Press Return.

v To Add Workspaces

1. Point to any area in the workspace switch and press mouse button 3 to
display the pop-up menu.

2. Choose Add Workspace from the pop-up menu.

The new workspace, named New, is placed at the end of the set of
workspaces.

3. Rename the workspace (see “To Rename a Workspace” above).

v To Remove Workspaces

If you remove a workspace that contains windows, those windows are moved
to the next workspace.

1. Point to the workspace button of the workspace you want to remove.

2. Choose Delete from the button’s pop-up menu (displayed by presssing
Shift+F10 or mouse button 3).

v To Customize the Controls in the Workspace Switch

This is an advanced task that requires you to create a Front Panel configuration
file. Advanced customization is covered in Advanced User’s and System
Administrator’s Guide.

Initially, the workspace switch has the four positions shown below.
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Paailien 3 Paaition 1
Rlank Fsit

Use this procedure to replace one of these controls. (Blank is also a control.)

1. Install the application you want placed in the switch into the Personal
Applications subpanel.

For example, if you want to add a Display System Load control to the
switch, drag it from the Desktop_Tools application group to the Personal
Applications subpanel.

2. Locate the Front Panel configuration file created automatically when you
installed the control in the Personal Applications subpanel. The definition is
located in the directory HomeDirectory/.dt/types/fp_dynamic

For example, when Display System Load is added to the Personal
Applications subpanel, it creates the file Xloadl.fp

3. Move the file from the HomeDirectory/.dt/types/fp_dynamic directory
to the HomeDirectory/.dt/types directory.

4. Open the file in the HomeDirectory/.dt/types directory for editing.

Edit the lines that define the CONTAINER_TYPENnd CONTAINER_NAME
the following:

CONTAINER_TYPE SWITCH
CONTAINER_NAME Switch
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10.

11.

Edit the line that defines the position (POSITION_HINTS). For example, to
put the control in the Blank location, set:

POSITION_HINTS 3
Save the configuration file.

Create another file in the HomeDirectory/.dt/types directory.

The file name must end with .fp . For example. you might create a new file
HomeDirectory/.dt/types/DeleteBlank.fp

Open the file for editing.

Open the file /usr/dt/appconfig/types/ language/dtwm.fp  in another
editor window.

This file is read-only. You will not have to write to it.

In /usr/dt/appconfig/types/ language/dtwm.fp , find the definition for
the switch control you are replacing.

For example, this is the definition for the Blank control:

CONTROL Blank

{
TYPE blank
CONTAINER_NAME Switch
CONTAINER_TYPE SWITCH
POSITION_HINTS 3

ICON FpbinkS

HELP_TOPIC FPOnltemSwitch

HELP_VOLUME FPanel
}
Copy the definition for the control you are replacing from
lusr/dt/appconfig/types/ language/dtwm.fp  to the new configuration
file.

For example, you would copy the definition for the Blank control to the new
file HomeDirectory/.dt/types/DeleteBlank.fp
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12.

13.
14.

Add the line DELETE True to the end of the definition, within the curly
braces:

CONTROL Blank

{
HELP_VOLUME FPanel
DELETE True

}

Save the file.

Choose Restart Workspace Manager from the Workspace menu.

You will see the new control in the switch.

g -

= =
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Managing Files with File Manager
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Use File Manager to create, find, and use desktop objects: files, folders, and

applications. Each object is represented by an icon in File Manager.

Introducing the File Manager Window and Desktop 92
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Basic File Management Skills 95
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Navigating to Folders and Subfolders 106
Deleting Objects to the Trash Can 109
File and Folder Ownership and Security 110
Using File Manager Objects on the Desktop 124
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Customizing File Manager Views 129
Using Removable Media with File Manager 138

91



1]
3

To open File Manager:

¢ Click the File Manager control in the Front Panel.

o 4
fEaksa

[ =

Introducing the File Manager Window and Desktop
The File Manager main window is a view of a folder on your system. The

folder you are currently viewing is called the current folder

Eh b Koy Menu bar and

File Selecled View H8E T " menus
Current folder ;
path j_j_j
hame kmog
fhame/kmig
53w Dryralat
Obiject viewing Ehtonal Bal bjecticons

area
] 1
58l p_Warkipice TATeanrd

1 o

135 Bems 72 Hidden

Current folder path Displays the path to the current folder
Menu bar and menus Contain the commands available in File Manager

Object viewing area  Shows the objects (files and folders) in the current
working folder

Object icons Icons representing the files and folders in the current
folder
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Basic File System Concepts

Files

Folders

This section describes basic file system concepts.

A file is a container that holds information. Most of the files you use contain
information (data) in some particular format—a document, a spreadsheet, a
chart. The format is the particular way the data is arranged inside the file. The
format of a file is known as its data type.

When File Manager is in one of its icon-view modes, you can identify the data
type of a file by the icon used to represent the file. Each data type has a
different icon.

Most application programs understand a limited number of data types. For
example, a document editor probably cannot read a spreadsheet file. The
desktop helps you recognize different types of files using a data-type database.
In most cases, when you double-click a file, the desktop will automatically
launch the application that understands that file’s data type.

The maximum allowable length of a file name varies from system to system.
Some operating systems do not allow file names longer than 14 characters. If
necessary, consult with your system administrator.

A folder is a container for files, similar to a folder in a file cabinet. In fact, File
Manager uses a folder icon to represent a folder. A folder can contain other
folders—sometimes called subfolders. With folders and subfolders, you can
create multiple layers of organization that form a hierarchy. In other contexts,
folders are often referred to as directories.

Within any single folder, each file name must be unique. However, files in
different folders may have the same name.

As you navigate from folder to folder, your current location is referred to as the
current folder.
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Objects

Paths

Since files and folders are both represented in File Manager as icons, the term
object is used to describe them both. Objects are discrete things on the desktop
that you can create and manipulate.

On the desktop, applications can also be represented as objects. For example,
Application Manager contains objects representing the applications available
on your system.

The location of a file is often specified by listing the folders and subfolders that
lead to the file—this list is called a path. A file's path is visible in two places in
File Manager. First it is shown in the iconic path as a string of folders. Second,
it is shown in a text form in the text path line above the view area. These two
areas can be turned off. (See “To Configure the Headers” on page 129 for more
information.)

Paths and Path Names

The path to an object is a way to specify where the object is located in the file
system. There are two ways to specify the path: absolute path and relative
path.

Absolute Paths

A path is an absolute path if it begins at the root folder. The root folder is the
single common folder on your system where the hierarchy begins. If a path
begins with a slash (/), it is an absolute path specified from the root folder. For
example, the following is an absolute path to the file letter:

[usr/dt/config/letter

Relative Paths

A path is relative if it describes the location of a file or folder as it relates to the
current folder. If you are in a folder and you want to move down the folder

tree, you don't need to type the absolute path name. You can just type the path
starting with the name of the next folder in the path. If a path does not begin
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with a slash, it is a relative path. For example, if the current folder is /usr/dt
and you want to move to the folder /usr/dt/config/letters , you would
use the following relative path:

config/letters

Two special folder names are useful when specifying relative paths. The “.
folder (sometimes called “dot”) represents the current folder. The “..” folder
(sometimes called “dot-dot”) represents the parent folder—the folder one level
up in the folder hierarchy. For example, if your current folder is

/usr/dt/config , then the relative path to the Dtwm file becomes:
..Japp-defaults/ language/Dtwm
because the file is in the /usr/dt/app-defaults/ language folder, one level

above the current folder and in the app-defaults  /language subfolder.

See Also

®* “To Change to Another Folder” on page 106
® “To Find an Object by Name” on page 127
® “To Find a File by Contents” on page 128

If you still want to learn more about your computer’s file system, refer to the
online help or documentation for your operating system. There are also many
commercial books available that cover the basics of file systems and file
management.

Basic File Management Skills

To get started using File Manager, you need to learn a few basic skills. Each
icon in File Manager represents an object that you can manipulate in a variety
of ways, including:

Object selection

Dragging and dropping

Using pop-up menus

Renaming objects

Getting online help on objects
Opening objects

Viewing information about an object
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v To Select a Single File or Folder

When you select the icon of a file or folder, its name is highlighted. Many
choices in File Manager’s menus apply to the currently selected file or folder.
The Selected menu contains choices that affect only the currently selected
objects. The contents of this menu will change as you select different kinds of
objects in the view area.

Mouse

+ Click once on the icon.

Keyboard

1. Use the Tab and arrow keys to move the highlight to the icon you want to
select.

2. Press the Spacebar.

To deselect a file or folder, select another icon or click an empty area within the
File Manager window.

v To Select Multiple Files and Folders

Selecting multiple files is useful if you want to delete several files at once, or
move a group of files to a new folder. Note that when you select more than one
object, the Actions portion of the Selected menu will be empty.

When multiple icons are selected, dragging any one of the selected icons drags
the whole group. The Selected menu and various menu commands that apply
only to a single object are inactive.

Mouse

® Press mouse button 1 in a blank area of the view, drag the mouse to draw a
box around the icons you want to select, then release the mouse button.

Or, you can click mouse button 1 to select the first icon, then hold down the
Control key and click mouse button 1 to select each additional icon. This
method is useful when the icons you want to select are not located next to
each other.

CDE User’s Guide—February 1997



5

®* To remove a single icon from a selected group, hold the Control key down
and click the icon you want to remove.

Keyboard
1. Select the first file or folder icon by pressing the Spacebar.

2. For each additional icon you want to select, move the highlight to it, then
press Control+Spacebar.

v To Drag and Drop a File or Folder
1. Put the mouse pointer over the file or folder.

2. Press and hold mouse button 1.

w

Drag the icon to where you want to drop it.
4. Release the mouse button.
So, the motion for dropping an object is press...drag...release.

To cancel a drag in progress, press Esc before releasing the mouse button.

Figure 5-1  Drag icon showing the object being dragged

If more than one icon is selected, you drag the entire group by dragging any of
the selected icons.

Note — You cannot drag and drop an object without a mouse or other pointing
device.
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Basic Drag-and-Drop Tasks

® To move a file to another folder, drop the icon on the destination folder's
icon. Or, if both the source and destination folders are open, drag the icon
from the source folder’s view window and drop it onto the background of
the folder's view window.

® To place an icon for a file or folder on the backdrop of your current
workspace, drop the file or folder icon outside of any window. A desktop
object is really just a reference to the real object, which remains in the File
Manager view, unchanged.

® To print a file, drop the file icon onto the Printer control in the Front Panel
(or one of the printers in the Personal Printers subpanel).

® To delete a file or folder, drop the file or folder icon onto the Trash Can
control in the Front Panel.

If you try to drop an icon in a location that does not support dropped objects,
the icon snaps back to its original location in File Manager or on the desktop.

v To Display a Pop-up Menu

Each object in File Manager has a pop-up menu. The File Manager window
itself has a pop-up menu viewable when the pointer is placed in a location in
the view window outside the boundaries of the individual file or folder objects.
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v To Rename

Mouse

1. Point to the icon whose pop-up menu you want to display and press mouse
button 3.

Editorial
Properties...
Put in Workspace
Put in Trash
Help
Open In Place
Open New View
Print

Figure 5-2  Sample pop-up menu

2. To choose a command from the menu, drag to the command, then release.
Or, click the command.

Keyboard

1. Using the Tab and direction keys, move the highlight to the icon whose
menu you want to display.

2. Press Shift+F10.

3. To choose a command from the menu, use the direction keys to highlight the
command, then press Return.

4. To cancel the menu without choosing a command, press Esc.

a File or Folder

Note - You can’t rename actions.

Mouse

1. Select the file or folder name by clicking the name beneath its icon.
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2. Type the new name.

3. Press Return. If you click outside the name without first pressing Return,
your changes will be lost.

To cancel a rename operation, press Esc.

Keyboard

1. Use the Tab and arrow keys to move to the icon for the file or folder you
want to rename.

2. Press the Spacebar to highlight (select) the icon name.
3. Choose Rename from the Selected menu.

4. Type the new name.

5. Press Return.

To cancel a rename operation, press Esc.

v To Get Help on a File or Folder

The description displayed when you ask for help on an icon describes the data
type associated with the file or folder. The description is specified in the data-
type definition.

Mouse
® Select the file or folder, then press F1.

® Or, put the mouse pointer on the object and select help from the object’s
pop-up menu (displayed by pressing mouse button 3).

® Or, choose On Item from the Help menu, then click the file or folder’s icon.

Keyboard

¢ Use the Tab and arrow keys to move to the icon, then press F1.
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See Also
® To find out more about how to use Help, see Chapter 3, “Getting Help.”

® For an introduction to creating data types and actions, see “Creating
Personal Actions and Data Types” in Chapter 6, “Running Applications
from the Desktop.”

v To View a File or Folder’s Information

Use the Information dialog box to view information about a file or folder.

Properties - a

Category: Infermation | Permissions

File Mame: SEEpar T ACLTRS TS LALA

Cnwrmer Mame: kmeg
Group Mame: staff
Size: O bytes
Last Accessed, Wed May 29 1436:24 1996

Last Madified: Wed May 29 1436:24 1996

Qk Apply Reset Cancel Help

1. In File Manager, select the icon of the file or folder whose information you
want to view.

2. Choose Properties from the File Manager Selected menu, or from the icon’s
pop-up menu (displayed by pressing Shift+F10 or mouse button 3).

The Properties dialog box appears.
3. Click the Information radio button.

4, Examine the information about the file or folder:
* Owner Name — The name of the file or folder’s owner
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* Group Name — The name of the group to which the file or folder belongs
 Size — The size of the file or folder

« Last Accessed — The date on which the file or folder was last accessed

« Last Modified — The date on which the file or folder was last modified

Note — If you want to view the information for another file or folder, select the
object, choose Properties from the Selected menu, and click the Information
radio button. If you bring up the Properties dialog box by typing sdtfprop& on
the command line, you can click Browse in the dialog box and select the file or
folder name to view properties.

Opening aFile or Folder

The most basic action you can perform on an object is to open it. “Open” is a
very general term, and the action taken depends on the type of object you are
opening. For example, opening a folder changes the File Manager view to
show the contents of that folder. Opening a data file usually starts the
application that created the file and loads the data file.

To Open a File or Folder
® Double-click the icon.

Double-clicking an icon executes the object’s default action, which is always
the first action in the Actions portion of the Selected menu. For most data
files, the default action opens the file by starting the appropriate application
and loading the file.

® Or, select the icon, then go to the menu bar and choose Open (or Open In
Place or Open New View) from the Selected menu.

® Or, choose an Open item from the icon's pop-up menu (displayed by
pressing Shift+F10 or mouse button 3).

Manipulating Files and Folders

102

The major identifying features of a file or folder are:
® [ts name and location in the folder hierarchy.

® Its owner permissions (properties).
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For more information on permissions and how to set them, see “File and
Folder Ownership and Security” on page 110.

Whether it is linked to another file. A linked file is a representation of
another file. Linked files provide a way for you to have one file that appears
to exist in two or more folders.

v To Create a New File or Folder

1.
2.
3.

Choose New File or New Folder from the File menu.
Type the name into the New File or New Folder field.

Click OK or press Return.

To close the New File or New Folder dialog box without creating a new file or
folder, click Cancel or press Esc.

There are two other ways to create objects:

Copy an existing object, then rename the copy (see “To Copy a File or
Folder” on page 104).

Create a new file within an application. For example, Text Editor creates a
new file when you save a new document.

v To Move a File or Folder

Note - If you attempt to move a file or subfolder from a folder where you do
not have permission to make changes, File Manager may create a copy of the
object, and display an error message indicating that you cannot delete the
original file.

Mouse

1.

Make the source and destination folders visible:

Open a File Manager view of the contents of the destination folder or the
icon of the closed destination folder.

Select the file or folder to be moved and drag it to the destination folder.
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If you move a folder, the entire folder and its contents are moved.

Keyboard

1.

5.

Use the Tab and direction keys to move the highlight to the file or folder to
be moved.

Press the Spacebar to select the object.
Choose Move to from the Selected menu.

Type a name into the Destination Folder text field.

For example, if you want to move the file report into the folder /u/john
you would type /u/john

Click OK or press Return.

If you move a folder, the entire folder and its contents are moved.

v To Copy a File or Folder

Mouse

1.

Make the source and destination folders visible:

Open a File Manager view of the contents of the destination folder or the
icon of the closed destination folder.

Select the file or folder to be copied.
Press and hold the Control key.

Drag the file or folder and drop it onto the destination folder.

Make sure that you release the mouse button before you release the Control
key. Otherwise, you will move instead of copy the file or folder.

Keyboard

1. Select the icon.

2. Choose Copy to from the Selected menu.
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3. Type a name into the Destination Folder text field.

Note that this must be the new full path name for the file. For example, if
you want to copy the file report into the folder /u/john , you would type
/u/john

4. Click OK or press Return.

To close the Copy File dialog box without copying a file, click Cancel or press
Esc.

v To Create a Symbolic Link

A link icon is a copy of an icon that points to the same file or folder as the
original icon. Any changes you make after opening the link icon will also
appear when you access the file or folder using the original icon.

Mouse

1. Make the source and destination folders visible:
« Open a File Manager view of the contents of the destination folder.

 Or, open a File Manager view that shows the icon of the closed destination
folder.

2. Select the file or folder to be copied.

3. Press and hold the Shift key and the Control key while dragging and
dropping the icon of a file or folder onto the icon of a new folder.

When you drop the icon, File Manager creates symbolic link in the new
folder that points to the original file or folder. Make sure that you release the
mouse button before you release the Shift key and the Control key.
Otherwise, you will move instead of link the file or folder.

Keyboard

1. Use the Tab and arrow keys to move the highlight to the icon of the file or
folder to which you want to link.

2. Press the Spacebar to select the icon.

3. Choose Copy as Link from the Selected menu.
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4.

5.

Type a name into the Destination Folder text field including the path for the
name of the folder where you want this link icon to appear. If you want this
link icon to have a different name that the original icon, type a new name in
the Name for copy text field.

Click OK or press Return.

Navigating to Folders and Subfolders

Each File Manager window (also called a view) shows the contents of a single
folder.

If you are not familiar with hierarchical file systems, see “Basic File System
Concepts” on page 93.

v To Change to Another Folder

You can change to another folder in any of the following ways:

Double-click a folder icon.

Select a folder icon and choose Open In Place from the Selected menu to
open the folder in the current window, or Open New View from the Selected
menu to open it in a new window.

Choose the Open In Place or Open New View command from the folder’s
pop-up menu (displayed by pressing Shift+F10 or mouse button 3).

Double-click a folder in the iconic path to change the view to that folder.

Select (click) the current folder line to change it into a text field. Type the
name of the path you want and then press Return.

In the current folder line, double-click a segment of the current path. For
example, if the current folder is /users/tom/.dt/types , you can change
to the /users/tom  folder by double-clicking the word tom.

Choose Go To from the File menu. Enter the folder’s full path name in the
Destination Folder text field of the Go To window.

v To Go to Your Home Folder

¢ Choose Go Home from the File menu.
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v To Change to the Parent Folder

® Choose Go Up from the File menu

® Or, double-click the .. (go up) icon.

v To Open a Terminal Window in the Current Folder

This procedure opens a terminal emulator window with the same current
folder as the File Manager window. This is a quick way to type a command to
affect the contents of the folder you are currently viewing.

¢ Choose Open Terminal from the File menu.

Note — You must have execute permission for a folder before you can open a
Terminal window from it.

To find out how to use terminal emulators, see Chapter 12, “Using Terminal.”

Executing an Action for a File or Folder

Actions act on objects, and are a basic part of working with them. For example,
printing the contents of an object uses the Print action. Starting an application
for a data file object uses an Open action, or some other application action.
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The Selected menu contains a list of commands followed by a list of actions
you can use with the selected icon. The contents of the actions portion of the
Selected menu change depending on the type of icon that is currently selected.

File Manager - kmcg

File | Selected  Wiew Heslg
_Mowve to,, |
Capy o Cirl+C
h mﬂﬂr.:-l.r A% Link.
Remarme,,,

Put in Workspace
‘;:l Put im Trash

O ProperTies

_'l'.i_elan:rAII Cirl+4 |
L |
i gesele:ft::.ll Cel+y,
pen in ACE

| Open New View \Actions portion of
a0z Print the Selected menu

-

1549 ltems 78 Hidden

The action listed at the top of the action portion of the menu (the default
action) is the action that will be taken when you double-click a file or folder. In
the menu shown in the figure, the default action is Open In Place.

v To Execute the Default Action

The default action is the first action listed in the actions portion of the Selected
menu.

+ Double-click the object’s icon.

v To Execute Other Actions
1. Select the object’s icon.

2. Choose the action you want to execute from the Selected menu or from the
object’s pop-up menu.
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Deleting Objects to the Trash Can

The Trash Can collects the files and folders that you delete. They are not
actually removed from the file system until the trash is “emptied.” You can
only change your mind and restore a file you’ve put in the Trash Can if the
Trash Can hasn’t been emptied.

v To Open the Trash Can Window

¢ Click the Trash Can control in the Front Panel.

=" iﬂl@

v To Put an Object in the Trash Can

® Choose Put in Trash from the object’s pop-up menu (displayed by pressing
Shift+F10 or mouse button 3).

® Or, select the object’s icon, then choose Put in Trash from the Selected menu.

® Or, drag the object’s icon and drop it onto the Trash Can control in the Front
Panel.

® Or, drag an object’s icon to the open Trash Can window.

v To Put Back a File or Folder from the Trash Can

® Drag the object from the Trash Can window to File Manager.

® Or, in the Trash Can window, select the object you want to restore and
choose Put back from the File menu.

® Or, choose Put back from the object’s pop-up menu (displayed by pressing
Shift+F10 or mouse button 3).

v To Delete a File or Folder Permanently

When you delete a file permanently, it cannot be recovered (unless you have a
backup mechanism.)
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1. Open the Trash Can.

2. Select the objects you want to empty from the Trash Can.

Select individual objects, or choose Select All from the File menu.

3. Choose Shred from the File menu or from the object’s pop-up menu
(displayed by pressing Shift+F10 or mouse button 3).

4. Click OK in the confirmation dialog box.

File and Folder Ownership and Security

110

The traditional UNIX file and folder protection scheme provides read, write,
and execute permissions for three user types: owner, group, and other. These are
called basic permissions.

Access Control Lists (ACLs) provide greater control over file and folder
permissions than do basic permissions. ACLs enable you to define file or folder
permissions for the owner, owner’s group, others, and specific users and
groups, and default permissions for each of these categories.

Basic Permissions

The permissions on a file or folder specify how it can be accessed. These
permissions apply to the basic user types as well as to the ACL default types
described in “Setting Default Permissions through an Access Control List” on
page 119.

® Read Permission — Allows access to retrieve, copy, or view the contents of the
object.

® Write Permission — For a file, allows access to change the contents of the file.
For a folder, allows access to create or delete objects from the folder.

® Execute Permission — For a file, allows access to run the file (for executable
files, scripts, and actions). For a folder, allows access to search and list the
folder’s contents.
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If you do not have permission to write inside a folder, the folder will look like

this:
A

If you do not have read or execute permission for a folder, the folder will look

like this:
_g]

Basic User Types

Examples

For a file or folder, the three basic types of users are:

® Owner — The user who owns the file or folder. Only a system administrator
(root user) can change the owner of a file or folder.

® Group — Users who have been grouped together by the system administrator.
For example, the members of a department might belong to the same group.
This group is the owning group and usually includes the file or folder’s
owner.

® Other — All other users on the system besides the owner and owning group.

To make a folder private:

® Change the folder's properties, giving yourself (the owner) read, write, and
execute permission, but giving no permissions for group and other. This
means that only you and the root user can view the contents of the folder.

To make an object that you've created available for everyone to use but protect
it so it isn't inadvertently overwritten:

® Change the file's properties, giving read and execute permission to owner,
group, and other. Don't give anyone write permission.
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v To View a File or Folder’s Permissions

1.

In File Manager, select the icon of the file or folder whose permissions you
want to view.

Choose Properties from the File Manager Selected menu, or from the icon’s
pop-up menu (displayed by pressing Shift+F10 or mouse button 3).

The Permissions dialog box is the default view.

Examine the file or folder’s Basic Permissions in the Effective column (“r”
stands for Read permission, “w” stands for Write permission, and “x”
stands for Execute permission).

* Owner — The permissions granted to the file or folder’s owner

* Group — The permissions granted to the file or folder’s group

* Other — The permissions granted to everyone besides the owner and

group

Note — The Read, Write, and Execute columns in the dialog box represent
requested permissions, and may be different than the permissions that are
actually in effect (which are shown in the Effective column). The requested

permissions may not be in effect because of the mask (see “Permissions Mask

on page 123).

If you want to look at the permissions for another file or folder, select the
object and choose Properties from the Selected menu. If you display the
Properties dialog box by typing sdtfprop& on the command line, you can
click Browse in the dialog box and select the file or folder name to view
properties.

v To Modify Basic Permissions

1.

In File Manager, select the icon of the file or folder whose permissions you
want to modify.

2. Choose Properties from the File Manager Selected menu or from the icon’s

pop-up menu (displayed by pressing Shift+F10 or mouse button 3).

The Permissions dialog box appears.
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v To Change

3. Click the check boxes to set the Owner, Group, and Other permissions.

The mask restricts the Group permissions, but does not affect Owner or
Other permissions. The actual read, write, and execute permissions that
Owner, Group, and Other receive appear in the Effective column.

4. Use the Apply Changes To option button to choose the scope of the changes.

For files, the options are This File Only (default), All Files in Parent Folder,
and All Files in Parent Folder and its Subfolders. For folders, the options are
This folder only (default) and This folder and its Subfolders.

5. Click OK on the Permissions dialog box to apply the current settings and
dismiss the dialog box. Click Apply to apply the settings without dismissing
the Permissions dialog box.

If you want to modify the permissions for another file or folder, select the
object and choose Properties from the Selected menu. If you display the
Properties dialog box by typing sdtfprop& on the command line, you can click
Browse in the dialog box and select the file or folder name to modify
properties.

See “Permissions Mask” on page 123 for a discussion of the mask.

File or Folder Ownership

Note — You must have logged in as the system administrator (root user) in
order to change the ownership of a file or folder. If you do not have permission
to change the properties, some of the controls in the Permissions dialog box are
unavailable.

1. In File Manager, select the icon of the file or folder whose ownership you
want to modify.

2. Choose Properties from the File Manager Selected menu or from the icon’s
pop-up menu (displayed by pressing Shift+F10 or mouse button 3).

The Permissions dialog box appears.
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3. To change the owner, type the new owner name into the Owner text field. To
change the owning group, type the new group name into the Group text
field.

You can specify a different owning group only if you are also a member of
another group, even if you are not the file or folder owner.

4. Click OK to apply the current settings and dismiss the dialog box. Click
Apply to apply the settings without dismissing the Permissions dialog box.

v To Browse and Edit Properties of Multiple Files and Folders

1. Open the Properties dialog box by typing sdtfprop& at the command line.

You can edit the File Name text field and click Browse to open the File
Selection dialog box only if you open the Properties dialog box from the
command line.

2. Click Browse or type the name of a file or folder in the File Name field.
3. Browse or edit the file or folder properties.

4. Click OK to apply the current settings and dismiss the dialog box. Click
Apply to apply the settings and continue the browsing and editing process.

Access Control Lists

ACLs enable you to define file or folder permissions for the owner, owner’s
group, others, and specific users and groups, and default permissions for each
of these categories. You can set up only one ACL per file or folder. An ACL
consists of ACL entries. Each entry has a user type associated with it, much as
basic permissions have Owner, Group, or Other associated with them.

If you want to grant file or folder access to a particular user or group, use the
User or Group type ACL entry, respectively. You must specify the name of the
user or group when you create the ACL entry. For example, you can use an
ACL to grant a friend read permission on your resume, while protecting it
from being read by the rest of the world (besides yourself).
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To create, modify, or view ACLs on a file or folder, it must reside on a Solaris
2.5 or later server or system, and you must be running Solaris 2.5 software or
later. Such files and folders are called ACL-enabled. To set, modify, and view
basic permissions and ACLs using the Properties Graphical User Interface
(GUI), you must be running CDE 1.1 or later.

Properties - a

Category: Imfermation ¢  Permissions
File Mame:  fexportsacltest/d UATA
Razlc Permissions: Read Write Execule Effective
Cwner: kmcg w o W
Group: staff e r--
e & P——
Access Control List Permissions: Hicle Access List
Type MName Requested Effective
Mask iy F— T e .ﬁl:ll:l
belale
C hamng)e...
Apply Changes To; This File Gnly
QK Apply Resel Cancel Help

You must be the owner of the file or folder to create or modify basic
permissions or ACLs for that file or folder. If you are not the owner, all fields in
the Properties dialog box are displayed as read-only.

Note — ACL terminology in this section refers to terminology used in the
Properties GUI. Command-line terminology may be slightly different.
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v To View an Access Control List

1.

In File Manager, select the icon of the file or folder whose Access Control
List (ACL) you want to view.

Choose Properties from the File Manager Selected menu or from the icon’s
pop-up menu (displayed by pressing Shift+F10 or mouse button 3).

The Properties dialog box appears.

If the file or folder has an ACL, it appears in the scrolling list labeled Access
Control List Permissions. If the file or folder has no ACL, the scrolling list is
hidden.

The Requested column shows the permissions that the owner requests for
each ACL entry. These permissions are restricted by the mask, and the
actual ACL entry permissions appear in the Effective column. See
“Permissions Mask” on page 123 for a discussion of the mask.

Note — To create, modify, or view ACLs on a file or folder, it must reside on a
Solaris 2.5 or later server or system, and you must be running Solaris 2.5 or
later.

v To Add an Access Control List Entry

Note — Adding the first Access Control List entry creates the Access Control
List.

In File Manager, select the icon of the file or folder whose ACL you want to
modify.

Choose Properties from the File Manager Selected menu or from the icon’s
pop-up menu (displayed by pressing Shift+F10 or mouse button 3).

The Permissions dialog box appears.

Click the Show Access Control List button if the ACL portion of the
Permissions dialog box is not visible.

Click the Add button.
The Add Access List Entry dialog box appears.

CDE User’s Guide—February 1997



3
1]

Properties = Add Acoess List Entry

Tt Mame; Permission  Effeciivie
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Group

Default Wser

Default Group

Default Chwning User
Default Chvning Group
Default Other Users
Default Mask

Cancel Help

5. Select an option from the Type option button.

6. Enter the name associated with the chosen Type, if it has one in the Name
field.

7. Click the Permission check boxes to reflect the values you want for the new
ACL entry.

The footer status line on the bottom of the dialog box informs you if the
permissions you request are restricted by the mask.

8. Click the Add button in the Add Access List Entry dialog box.

9. Use the Apply Changes To option button to choose the scope of the change.

For files, the options are This File Only (default), All Files in Parent Folder,
and All Files in Parent Folder and its Subfolders. For folders, the options are
This folder only (default) and This folder and its Subfolders.

10. Click OK to apply the current settings and dismiss the dialog box. Click
Apply to apply the settings without dismissing the dialog box.

v To Change an Access Control List Entry

1. In File Manager, select the icon of the file or folder for which you want to
change an ACL entry.

2. Choose Properties from the File Manager Selected menu or from the icon’s
pop-up menu (displayed by pressing Shift+F10 or mouse button 3).

The Permissions dialog box appears.
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3.

Select the entry in the Access Control List Permissions scrolling list that you
want to change.

4. Click the Change button.

Ty pe: Mame: Permission  Effective
User pin Frw ey -
Change Cancel Help

Effective permissions are being restricted by Mask value.

The Change Access List Entry dialog box appears.

Properties — Change Access List Entry

5.

Click the Permission check boxes to reflect the values you want for the ACL
entry.

The footer status line at the bottom of the dialog box informs you if the
permissions you request are restricted by the mask.

Click the Change button in the Change Access List Entry dialog box.

Use the Apply Changes To option button to choose the scope of the change.

For files, the options are This File Only (default), All Files in Parent Folder,
and All Files in Parent Folder and its Subfolders. For folders, the options are
This folder only (default) and This folder and its Subfolders.

Click OK to apply the current settings and dismiss the dialog box. Click
Apply to apply the settings without dismissing the dialog box.

v To Delete an Access Control List Entry

1.

In File Manager, select the icon of the file or folder for which you want to
delete an ACL entry.

Choose Properties from the File Manager Selected menu or from the icon’s
pop-up menu (displayed by pressing Shift+F10 or mouse button 3).

The Permissions dialog box appears.
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3. Select the entry in the Access Control List Permissions scrolling list that you
want to delete.

4. Click the Delete button.

A dialog box appears asking you to confirm this deletion. If you delete any
of the four required ACL default entries, all ACL default entries will be
deleted. See “Setting Default Permissions through an Access Control List”
for a description of required and optional default ACL entries.

Note — Removing all entries (except Mask) removes the entire Access Control
List.

5. Use the Apply Changes To option button to choose the scope of the change.

For files, the options are This File Only (default), All Files in Parent Folder,
and All Files in Parent Folder and its Subfolders. For folders, the options are
This folder only (default) and This folder and its Subfolders.

6. Click OK to apply the current settings and dismiss the dialog box. Click
Apply to apply the settings without dismissing the dialog box.

Setting Default Permissions through an Access Control List

When you create a file or folder within a folder, it inherits the basic
permissions set by the system administrator. (To determine the current
defaults, create a new file or folder and then choose Properties from the
Selected menu to view the permissions.)

You can use an Access Control List to set default basic permissions yourself for
any file or folder that is created within a folder. The ACL for that folder must
contain entries for all four of the following required Default entry types: Default
Owning User, Default Owning Group, Default Other, and Default Mask. An
ACL can contain only one entry of each required type.

The file or folder inherits the values for Owner, Group, and Other from the
person who creates it and inherits the basic permissions from the required ACL
Default entry types on the containing folder. ACL entries of these types do not
have names associated with them.
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You can also set optional Default entry types—Default User and

Default Group— for any file or folder that is created within a folder. You can
create as many Default User or Default Group ACL entries as you want. You
must specify the name of the user or group when you create the ACL entry.

Any ACL in which you want to put a Default User or Default Group entry
must also contain one of each required entry type.

Example

Suppose that the values for Owner and Group for a user named Carla are otto
and otto_staff , respectively. The value for Other (call it otto_other ) is
everyone at Carla’s company except for Carla and the members of

otto_staff . Carla creates these required Default ACLs on her folder named
Projectl

Default Owning User with permissions rwx (read, write, execute)
Default Owning Group with permissions rx (read, execute)
Default Other with permissions no-read, no-write, no-execute
Default Mask with permissions rw (read, write)

Any file or folder subsequently placed in the Projectl  folder inherits these
basic permissions from Projectl

® The file or folder Owner value is otto and otto has read, write, and
execute permission on that file or folder

® The file or folder Group value is otto_staff and otto_staff has read
and execute permission on that file or folder

® The file or folder Other value is otto_other  and otto_other has no-read,
no-write, and no-execute permission on that file or folder

Also, the file or folder has a Mask entry in the Access Control List Permissions
scrolling list with value rw (read, write).

If Carla also adds an optional ACL of type Default User (Default Group) for
the Projectl folder, then any file or folder subsequently placed in Projectl
will inherit an ACL of type User (Group).

To Set Required Default Entry Types

1. In File Manager, select the icon of the folder for which you want to set the
required ACL Default entry types.
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Choose Properties from the File Manager Selected menu or from the icon’s
pop-up menu (displayed by pressing Shift+F10 or mouse button 3).

The Permissions dialog box appears.
Click the Show Access Control List button if the folder has no ACL defined.

If the folder has an ACL defined, it will be visible when you open the
Permissions dialog box.

Click Add and select an ACL entry of type Default Owning User, Default
Owning Group, Default Other, or Default Mask.

A message appears reminding you that the other required ACL Default
entries will also be added.

Click the Permission check boxes to set the permissions for the Default
entry.

Click Add in the Add Access List Entry dialog box.

The other three required ACL Default entries are automatically created for
you, with permissions set to no-read, no-write, no-execute.

Optional. Change the permissions for the required ACL Default entries that
were automatically created in Step 6 above.

Use the Apply Changes To option button to choose the scope of the changes.
The options are This folder only (default) and This folder and its Subfolders.

Click OK to apply the current settings and dismiss the dialog box. Click
Apply to apply the settings without dismissing the dialog box.

To Delete Required ACL Default Entry Types

1.

In File Manager, select the icon of the folder for which you want to delete an
ACL Default entry.

Choose Properties from the File Manager Selected menu or from the icon’s
pop-up menu (displayed by pressing Shift+F10 or mouse button 3).

The Permissions dialog box appears.
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Select required ACL Default entry and click Delete.

A message appears to remind you that once you delete one of the required
default ACL entries, the other three are automatically deleted for you.

Click Delete in the confirmation dialog box.

Use the Apply Changes To option button to choose the scope of the change.
The options are This folder only (default) and This folder and its Subfolders.

Click OK to apply the current settings and dismiss the dialog box. Click
Apply to apply the settings without dismissing the dialog box.

To Set Optional ACL Default Entry Types

1.

In File Manager, select the icon of the folder for which you want to set an
optional ACL Default entry type.

Choose Properties from the File Manager Selected menu or from the icon’s
pop-up menu (displayed by pressing Shift+F10 or mouse button 3).

The Permissions dialog box appears.
Click the Show Access Control List button if the folder has no ACL defined.

If the folder has an ACL defined, it will be visible when you open the
Permissions dialog box.

Click Add and select an ACL entry of type Default User or Default Owning
Group.

If the ACL does not contain the required default entries, they will also be
created, with permissions set to no-read, no-write, no-execute.

Click the Permission check boxes to set the permissions for the Default
entry.

Click Add in the Add Access List Entry dialog box.

Continue to add as many ACL entries of type Default User or Default
Owning Group as you want.

Use the Apply Changes To option button to choose the scope of the changes.
The options are This folder only (default) and This folder and its Subfolders.
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9.

Click OK to apply the current settings and dismiss the dialog box. Click
Apply to apply the settings without dismissing the dialog box.

Permissions Mask

ACL-enabled files and folders have a mask defined whose default permissions
are the group permissions for the file or folder. The mask is the maximum
allowable permissions granted to any user on all ACL entries and for Group
basic permissions. It does not restrict Owner or Other basic permissions. For
example, if a file’s mask is read-only, then you cannot create an ACL with write
or execute permission for a user without changing the mask value.

Use the mask as a quick way to limit permissions for users and groups.

v To Modify the Mask

1.

In File Manager, select the icon of the file or folder whose mask you want to
modify.

Choose Properties from the File Manager Selected menu or from the icon’s
pop-up menu (displayed by pressing Shift+F10 or mouse button 3).

The Permissions dialog box appears.
Click the Show Access Control List button if the folder has no ACL defined.

If the folder has an ACL defined, it will be visible when you open the
Permissions dialog box.

Select the Mask entry in the Access Control List Permissions scrolling list.

The current mask permissions appear in the Effective column.
Click the Change button.

Click the Permission check boxes to reflect the values you want for the
mask.

Click the Change button in the Change Access List Entry dialog box.
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8. Use the Apply Changes To option button to choose the scope of the
permissions changes.

For files, the options are This File Only (default), All Files in Parent Folder,
and All Files in Parent Folder and its Subfolders. For folders, the options are
This folder only (default) and This folder and its Subfolders.

9. Click OK to apply the current settings and dismiss the dialog box. Click
Apply to apply the settings without dismissing the dialog box.

Using File Manager Objects on the Desktop

The desktop lets you put any file or folder icon directly on the backdrop of the
current workspace for quick access. Any icon you drop on the desktop stays
where you put it.

File Manager provides a way to view all the objects in your file system.
However, the object is only visible when you are viewing the folder it is in.

To make an object more accessible, you can put it directly on the workspace
backdrop. The desktop is that area or surface on which windows appear to lie.
When an object is placed there, it is called a workspace object. There is a separate
desktop for each workspace.

Placing an object on the workspace does not alter the original file or folder. In
fact, the icon that appears on the workspace is really just a shortcut for
accessing the real file or folder. Any operation you perform on the workspace
object is actually performed on the file or folder it represents.

Workspaces in the Desktop

You can have several workspaces on your desktop, so you can set up your
working environment by putting the files and folders in the workspaces where
you use them most, or in more than one workspace if needed.

Pop-up Menus

Each workspace object has its own pop-up menu, displayed with mouse
button 3 or by pressing Shift+F10 when the icon is selected. This menu
contains commands for manipulating the object, including all the actions that
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appear in the File Manager’s Selected menu when the object is selected. The
Workspace pop-up menu is similar to the pop-up menu available within File
Manager windows, but contains a few different commands.

v To Put a File or Folder on the Workspace Backdrop

This procedure creates a copy of the icon on the workspace backdrop. Any
changes you make to the copy on your workspace backdrop will also be made
to the original that is still in File Manager.

1. Switch to the workspace where you want to display the object.

2. Then:
» Drag and drop the object's icon onto the workspace.
* Or, select the icon, then choose the Put in Workspace command from the
Selected menu or from the icon's pop-up menu (displayed by pressing
Shift+F10 or mouse button 3).

You can repeat these steps to put an icon on the desktop in as many
workspaces as you want.

v To Display the Pop-up Menu for a Workspace Object

Mouse
1. Point to the object’s icon.
2. Press mouse button 3.

3. Choose a command from the menu by dragging to the command then
releasing the mouse button.

Keyboard
1. Move the highlight to the object’s icon using Alt+Tab.
2. Press Shift+F10.

3. Choose a command from the menu by using the direction keys to highlight
the command, then press Return.

To cancel the menu without choosing a command, press Esc.

Managing Files with File Manager 125



1]
3

v To Remove an Object from the Workspace
1. Switch to the workspace where the object resides.
2. Locate the object’s icon on the desktop.
3. Choose Remove From Workspace from the object’s pop-up menu.
Removing an object from the workspace does not alter the original object; that

is, the object still exists in File Manager.

Locating Files
Keeping track of many files can quickly become difficult. File Manager helps

by providing the ability to search for a file or folder by name. You can also
search for files based on the contents of the file.

126 CDE User’s Guide—February 1997



3
1]

v To Find an Object by Name

1. Choose Find from the File menu.

File Manager - Find
Fill im ene or more fields to specify which items to find:

File ar Falder Name:
File Contents: |

Follow Links:  Offl

Search Folder /homa/lonog

Files Forumel (by Mame):

Dipen Foloe) Pul |n Waorkspace

Shart Sop Cancel Help

2. Type the name of the file or folder you want to find into the File or Folder
Name field.

When you specify a file or folder name, you can include wildcard characters
such as asterisk (*) and question mark (?). The * matches any string of
characters (including no characters), and ? matches any single character. For

example:

ba* Matches all names that begin with the string ba

ba? Matches all three-character names that begin with the string ba
*.dt Matches all names that end with the .dt suffix

* 27?7 Matches all names that have a three-character suffix
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v To Find a File

The file name and contents can be specified using the same regular expression
syntax allowed by the find command. (Refer to the find man page and
grep man page for more information.)

Type the folder where you want the search to begin into the Search Folder
field. (By default, this field contains the name of the current folder.)

Find will search this folder and all of its subfolders.
Click Start or press Return.

File Manager begins searching the Search Folder and the folders it contains
for files that match the name you provided. Matches that are found are
listed in the Files Found list. Once you have found an object, you can select
it and click Open Folder to open the folder it is in or Put in Workspace to
place its icon on the current backdrop.

To stop the search, click the Stop button or press Return.

by Contents
Choose Find from the File menu.

Optional. You can use the File or Folder Name text field to narrow, and
therefore speed up, the search.

If you enter a partial name (using wildcards) File Manager examines only
the files that match the File or Folder Name field. If you leave the File or
Folder Name field empty, File Manager searches every file within the search
folder. Names can be specified using the same regular expression syntax
allowed by the grep command. (Refer to the grep man page for more
information.)

Type the text string you want to search for into the File Contents field.

Case is ignored for this string (upper- and lowercase letters are equivalent).
You do not have to use complete words. For example, if you type fi it will
find both fish and File.

Contents can be specified using the same regular expression syntax allowed
by the grep command. (Refer to the grep man page for more information.)
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4. Type the name of the folder where you want the search to begin into the

Search Folder field. (By default, this field contains the name of the current
folder.)

Click Start or press Return.

File Manager begins searching the search folder and the folders it contains
for files that contain the File Contents string. Matches that are found are
listed in the Files Found list. Once you have found an object, you can select
it in the list and then click Open Folder to open the folder it is in or Put In
Workspace to place its icon on the current backdrop.

To stop the search at any time, click the Stop button or press Return.

Customizing File Manager Views

File Manager provides several ways to see the contents of folders. You can:

Change the basic viewing structure from one folder at a time to seeing a tree
view. See “To Display the Tree View” on page 132.

Determine the sort order of objects. See “To Change the Order Icons Are
Sorted” on page 133.

Hide (filter) certain objects. See “To Show or Hide Files and Folders” on
page 135.

Change the style used for objects — names and small or large icons, names
alone, or a long list of names plus properties.

v To Configure the Headers

1.

2.

Choose Set View Options from the View menu.

Determine which headers to display:

« Select Iconic Path to show current folder path as a string of folder icons at
the top of the window.

 Select Text Path to show the current folder’s full path name in a text field
above the view pane.

 Select Message Line to show a count of the number of files in the folder.
The line will appear at the bottom of the window.
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To implement the chosen option and close the Set View Options dialog box,
click OK.

To implement the chosen option and leave the Set View Options dialog box
open, click Apply.

v To Configure How Icons are Placed

1.
2.

Choose Set View Options from the View menu.

Determine how you want to have the icons placed:

« Select As Placed to leave icons where they are dropped.

« Select Rows and Columns to automatically align the icons you drop into a
grid.

To implement the chosen option and close the Set View Options dialog box,
click OK.

To implement the chosen option and leave the Set View Options dialog box
open, click Apply.

Using the Tree View

The tree view resembles an outline. Files and folders contained in a folder are
listed beneath that folder in an indented list
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Figure 5-3  File Manager tree view

In the tree view, a folder can have three states. The states are shown and
changed using the buttons to the left of the folder. You can also open and close
the tree branches by selecting a folder and then pressing the + and - keys on
your keyboard (these are the keys in the center, not the numeric keypad):

+

+/-

The folder is in its closed state. None of the folder's

contents are shown. Clicking the button expands the
folder partially or fully, depending on the tree view

option currently in effect.

The folder is in its fully expanded state. All objects in
the folder are shown. Clicking the button fully closes
the folder.

The folder is in its partially expanded state. The only
contents shown are the folders it contains. (This view is
possible only when using tree view option by Folders,
then Files.) Clicking the button expands the folder to
show the filenames.
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You can alter the appearance of files and folders in the tree view by changing
the settings in the Show box in the Set View Options dialog box. Changes to
the preferences are only for the current session. To make them permanent, see
“To Save the Current Preferences as Your Default” on page 134.

If you double-click a folder in tree view, a new view of that folder opens that is
not in tree view mode.

v To Display the Tree View

The tree view shows a folder and the files and folders beneath it.
1. Change to the folder where you want the tree view to start.

2. Choose Set View Options from the View menu.

3. Select By Tree in the Show box.

4. Select one of the tree view options:

Folders only The tree shows folders only. To view files, double-click
a folder name. This is the default view.

Folders, then Files Folders only appear at first. Click the [+] button next to
each folder to view its contents. First click shows
subfolders. Second click shows files that are inside.
When you click the button the third time, the folder
contracts again.

Folders and Files  The tree shows both folders and files automatically.

5. To implement the chosen options and close the Set View Options dialog box,
click OK.

To implement the chosen options and leave the Set View Options dialog box
open, click Apply.

v To Display the Folder View

The folder view will show a folder and all the files and folders in that folder.
1. Change to the folder that you want to view.

2. Choose Set View Options from the View menu.
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3. Select By Single Folder in the Show box.

4. To implement the chosen options and close the Set View Options dialog box,
click OK.

To implement the chosen options and leave the Set View Options dialog box
open, click Apply.

You can alter the appearance of files and folders in the folder view by changing
the settings in the Show box in the Set View Options dialog box. Changes to
the preferences are only for the current session. To make them permanent, see
“To Save the Current Preferences as Your Default” on page 134.

v To Change How Objects Are Represented

1. Choose Set View Options from the View menu.

2. Select the representation you prefer from the Representation box.

By Name Only: Icons will not be displayed in File Manager. File Manager
indicates objects that are folders by adding a slash (/) after their names.
Executable programs have an asterisk (*) after their name.

By Large Icons: This is the default. The objects in File Manager will appear
with their name and large icon.

By Small Icons: The objects in File Manager will appear with their name
and small icon.

By Name, date, size, ...: The objects in File Manager will appear with their
file date, size, and so on in addition to the file name and icon.

3. Click OK or Apply.

v To Change the Order Icons Are Sorted

1. Choose Set View Options from the View menu.

2. Select the sort order you prefer from the Order box, and the direction from
the Direction box.
» Alphabetically: A to Z (Ascending) or Z to A (Descending). Icons with

names that start with capital letters appear first. Icons with names that
start with lowercase letters are at the bottom.
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* By File Type: By object type. For example, files, folders and actions are
different types of objects. Within each group of the same type, the icons
are sorted alphabetically (based on the order the data types are read into
the database).

« By Date: By date the files were last modified, oldest to newest (Ascending)
or newest to oldest (Descending).

« By Size: By file size, smallest to largest (Ascending) or largest to smallest
(Descending).

3. Click OK or Apply.

If you have Placement set to As Placed, icons are sorted only when you choose
Clean Up from the View menu or when you click Apply in the Set View
Options dialog box. If Placement is set to Rows and Columns, the icons are
sorted each time there’s a change to the folder’s contents, or when you choose
Update from the View menu.

v To Re-Sort (Clean Up) Objects

The Clean Up command sorts the objects in the current view (according to the
settings in the Set View Options dialog box) and lines them up in a grid
pattern. The settings in other File Manager windows are not affected.

¢ Choose Clean Up from the View menu.

The Clean Up command is unavailable if you have the Placement preference
set to Rows and Columns.

v To Save the Current Preferences as Your Default

When you apply changes using the Set View Options and Set Filter Options
dialog boxes, the changes only apply to the current session. If you want to save
the preferences so they will be used the next time you open File Manager:

1. Set the preferences that you want and apply them (using Set View Options
and Set Filter Options in the View menu).

2. Choose Save As Default Options from the View menu.

3. Click OK.
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These changes to the default view will not take effect until the next time you
click the File Manager control in the Front Panel.

After saving the current preferences, all new File Manager views you open use
the new preferences and filter list.

Hiding Files and Folders

Hidden files and folders are those whose file types are selected in the filter list.

The criterion for hiding or showing a file or folder is based on its data type.
Use the Set Filter Options command to change which data types are shown and
hidden. (See “To Specify Which Data Types Are Hidden” below.) The default
hidden data types are DOT_FILE, DOT_FOLDER, and CURRENT_FOLDER.

v To Show or Hide Files and Folders

v

¢ Choose Show Hidden Objects from the View menu.

Choosing the command a second time again reverses the toggle (from shown
to hidden and back again).

The criterion for hiding or showing a file or folder is based on its data type.
Use the Set Filter Options command to change which data types are shown and
hidden. (See “To Specify Which Data Types Are Hidden” below.) The default
hidden data types are DOT_FILE, DOT_FOLDER, and CURRENT_FOLDER.

To Specify Which Data Types Are Hidden

1. Choose Set Filter Options from the View menu.

Data types that have already been chosen to be hidden are highlighted.

2. In the Select File Types to be Hidden box, select the data types you want to
be hidden. File types that are already being hidden are highlighted.

Or, to reset the default filter list (DOT_FILE, DOT_FOLDER, and
CURRENT_FOLDER), click Defaults.
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3. Optional. Type a name pattern into the Also Hide (Optional) field specifying
additional file and folder names to be hidden.

The filter list specifies which files are not to be displayed. If you select all
object types or type * into the Filter String field, then no files are displayed.
If you type *.txt , then any file whose name ends in .txt  will be added to
the filter list and not displayed.

Advanced users: The Filter String may be any regular expression. Refer to the
regexp(5) man page for more information.

4. Click OK.
If you want to view the results before closing the dialog box, click Apply.

To reset to the default filter list, choose Defaults. This resets the default values
but does not apply them until you click Apply or OK.

Icon Browsing

Files with names that end in .pm or .bm contain icons. These are the files that
File Manager uses to build icons. By default, you must open these files to see
the icons they contain. If you enable icon browsing, File Manager displays the
contents of .pm or .bm files so you don’t have to open them to see what they

look like.
rf\\ . n
= i
Fphome. 1.pm Fphome. 1. pm

Figure 5-4  Icon with icon browsing enabled (left) and disabled (right)

v To Enable Icon Browsing

1. Copy the file /usr/dt/examples/types/ language/lconBrowse.dt into
your / HomeDirectory/.dt/types folder.

2. Open Application Manager and double-click Reload Actions in the
Desktop_Tools application group.

3. Restart File Manager.
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Note — The maximum default display area for icons is 38x38 pixels. So, if a
picture file is larger than 38x38, the picture will be clipped and only the top left
38x38 pixels will be shown. You can increase the size of the display area for
icons if you want larger images to be fully visible (see “To Change the Icon
Display Area Size”). However, a larger display size area will slow down the
opening of folders, and icons will be spread further apart in folder views.

v To Disable Icon Browsing
1. Remove your personal copy of the IconBrowse.dt file.

2. Open Application Manager and double-click Reload Actions in the
Desktop_Tools application group.

v To Change the Icon Display Area Size
1. Open a Terminal window and type dtpad ~/.Xdefaults
2. When the file is displayed, it may be empty or there may be text already in
the file. In either case, add the following four lines of text to the file:
Dtfile*smalllconWidth:24
Dtfile*smalllconHeight:24

Dtfile*largelconWidth:38
Dtfile*largelconHeight:38

When you type in these lines, replace the default numbers at the end of each
line with the new display area size you want.

3. Choose Save from the File menu.

4. Choose Close from the File menu.

Note — The change will not take effect until you exit the desktop and log back
in. If you should want to return to the default display area size, type the
default sizes back in or just remove the four lines you added, and then exit and
restart the desktop.
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Using Removable Media with File Manager

File Manager enables you to use removable media, such as diskettes and
CD-ROMs, on the workspace. You can view the contents of your diskettes or
CD-ROMs if you have a system with at least one diskette drive or one
CD-ROM drive and you are running Solaris CDE 1.1 or later.

Removable media are mounted on your file system in removable media
folders. File Manager enables you to view the contents of the removable media
without having to know the location of these folders.

File Manager restricts the view of a diskette or CD-ROM window to the
removable media folder and its subfolders. You cannot navigate out of the
folder /floppy /diskette_name when you view the diskette labeled
/diskette_name or navigate out of the folder /cdrom /cdrom_name when you
view the CD-ROM labeled Zcdrom_name.

Dragging and Dropping Files and Folders

When you drag a file or folder icon from a regular folder window, the default
drag-and-drop behavior is:

® A copy operation when you drop the icon onto a diskette window.
®* A move operation when you drop the icon onto a folder window.

®* A move operation when you drop the icon onto the Trash Can or to the
Trash window.

When you drag a file or folder icon from a diskette window, the default drag-
and-drop behavior is:

® A copy operation when you drop the icon onto another diskette window.
® A copy operation when you drop the icon onto a folder window.

®* A move operation when you drop the icon onto the Trash Can or to the
Trash Can window.

When you drag a file or folder icon from a CD-ROM window, the default drag-
and-drop behavior is:

® A copy operation when you drop the icon onto a diskette window.

® A copy operation when you drop the icon onto a folder window.
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Note — You cannot drag and drop files or folders onto a CD-ROM.

Removable Media Manipulation Skills

This section describes tasks that you can perform using diskettes and CD-
ROMs with File Manager.

v To View Files and Folders on a Diskette
1. Insert the diskette into a disk drive.

2. Select Open Floppy from the Folders subpanel on the Front Panel, or from
the File Manager File menu.

If the diskette is formatted and readable by the system, File Manager
displays a view of the diskette’s contents. If the diskette is unformatted or is
unreadable by the system, File Manager displays the Unreadable Floppy
dialog box.

Note — If your system has more than one disk drive, File Manager opens one
window for each readable diskette you insert when you choose Open Floppy
from the File menu.

v To View Files and Folders on a CD-ROM
¢+ Insert the CD-ROM into a CD-ROM drive.

File Manager displays a window containing a view of the CD-ROM
contents.

If you close the CD-ROM’s File Manager window, you can reopen it by
selecting Open CD-ROM from either the File Manager File menu or from the
Folders Subpanel on the Front Panel.

v To Format a Diskette

1. Choose Format Floppy from the diskette’s File Manager window File menu.

The Format Floppy dialog box appears.
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2. Select one of the three formatting options (UNIX, MS-DOS, NEC-DOS).
3. Click Format or press Return.

4. Optional. To rename the diskette, type the new name in the Floppy Name
text field and press Return.

To Rename a Diskette

1. Choose Rename Floppy from the diskette’s File Manager window File
menu.

The Rename Floppy dialog box appears.
2. Type the new name in the Floppy Name text field.

3. Click Rename or press Return.

To Eject a Diskette or CD-ROM
1. Choose Eject from the File Manager window File menu.

2. Remove the diskette or CD-ROM from the disk drive.

To Copy Files or Folders to a Diskette
1. Select the icon for the file or folder you want to copy.
2. Choose Copy to from the Selected menu.
The Copy Object dialog box appears.
3. Type a full path name in the Destination Folder text field.

Use /floppy  as the directory name. For example, if you want to copy the
file report onto a diskette named john , you would type /floppy/john

4. Type the file or folder name in the Name for copy text field.

In the above example, you would type report

5. Click OK or press Return.

Note — You cannot copy files or folders to a CD-ROM.
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To Move Files or Folders to a Diskette

Select the icon for the file or folder you want to move.

Choose Move to from the Selected menu.
The Move Object dialog box appears.
Type a full path name in the Destination Folder text field.

Use /floppy  as the directory name. For example, if you want to move the
file report onto a diskette named john , you would type /floppy/john

Click OK or press Return.

Note — You cannot move files or folders to a CD-ROM.

To Delete Files or Folders From a Diskette

Choose the Put in Trash command from the file or folder icon’s pop-up
menu (displayed by pressing Shift+F10 or mouse button 3).

Or, select the file or folder’s icon, then choose Put in Trash from the Selected
menu.

Or, drag the file or folder’s icon and drop it onto the Trash Can control in
the Front Panel.

Or, drag the file or folder’s icon to an open Trash Can window.

To Create Files and Folders on a Diskette

1.
2.

Choose New File or New Folder from the File menu.

Type a name in the New File Name field of the New File dialog box or New
Folder Name field of the New Folder dialog box.

Click OK or press Return.

To close the New File or New Folder dialog box without creating a new file
or folder, click Cancel or press Escape.

Note — You cannot create files or folders on a CD-ROM.
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Running Applicationsfromthe
Desktop 6

This chapter covers several ways to run applications from the desktop.

Running Applications Using Application Manager 143
Running Applications Using File Manager 153
Running and Organizing Applications Using the Front Panel 154
Running Applications from a Terminal Emulator Window 155

Running Applications Using Application Manager

Application Manager is a container for the applications and other tools available
on your system. Most of the applications and tools in Application Manager were
placed there by your system administrator or are built into the desktop.

Although configuring Application Manager is primarily a system

administration task, you can also make personal customizations to Application
Manager.

To open application manager:

® Click the Application Manager control in the Front Panel.

143
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Figure 6-1 Application Manager control

Application Manager Window

The Application Manager window is a special File Manager view of a special
folder on your system. It looks very much like a File Manager window, except
that the iconic and text path are not shown.

The top level of Application Manager is special because other folders and files
are never created directly in it. Instead, folders in other locations are gathered
into this location automatically when you log in.Contents of Application
Manager

The top level of Application Manager contains a set of application groups.

Application group far Buili-in appheation
regsterad application groups

Figure 6-2 Top level of Application Manager

Each application group is a folder containing one or more icons that you use to
start applications.
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An icon that starts an application is called an action icon or application icon.

|
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Figure 6-3  Action (application) icons in the Desktop_Apps application group

Some application groups contain other useful application files such as sample
data files, templates, and “read me” files.

The application groups in your Application Manager are either built in or
registered by your system administrator. Application registration is a process by
which an application lets the desktop know of its presence.

The application groups in Application Manager are gathered together each time
you log in. The application groups may be located on your system or on other
systems throughout the network.

Built-In Application Groups

The desktop provides these built-in application groups that are containers for
various tools and utilities available on your system:

Application Group Contents

Desktop applications such as File Manager, Style
Manager, and Calculator

Desktop_Apps
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Desktop_Tools Desktop administration and operating system tools
such as User Registration, Reload Application, vi text
editor, and Check Spelling

Information Icons representing frequently used help topics

System_Admin Tools used by system administrators

Application Manager Menus and Commands

Since Application Manager is closely related to the File Manager window, it
uses most of the same menus, commands, and other features.

For more information about using the Application Manager menus and dialog
boxes, see Chapter 5, “Managing Files with File Manager.”

Solaris User Registration

With this version of Solaris, system administrators and users can now register
with Sun Microsystems, establishing themselves as users of Solaris. Registering
enables users to receive information about new Sun products and services.

The registration process can be invoked from the CDE desktop by running the
User Registration application located in the Application Manager’s desktop
tools folder. The following procedure describes how to run an application from
Application Manager.

v To Run an Application from Application Manager

1. Open Application Manager.

2. Double-click the application group’s icon to display its contents.
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3. Double-click the application’s action icon.
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Figure 6-4 Opening an application window from Application Manager
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v To Get Help on an Application Icon

From the Icon’s Pop-up Menu

1. Point to the icon and press mouse button 3 to display its pop-up menu.

2. Choose Help from the pop-up menu.

From the Help Menu
1. Choose On Item from the Help menu.

2. Click the icon on which you want help.

v To Put an Application Icon in the Front Panel
1. Display the application’s icon in Application Manager.
2. Display the subpanel to which you want to add the application.

3. Drag the action icon from Application Manager to the Install Icon control in
the subpanel.
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Figure 6-5 Installing an application (action icon) in the Front Panel
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v To Put an Application Icon on the Workspace Backdrop

This procedure copies an application icon from Application Manager to the
workspace (backdrop). This makes the icon available when you don’t have an
Application Manager window open.

1. Open the application group containing the application you want to add.

2. Drag the application from Application Manager to the workspace backdrop.

v To Update Application Manager

The contents of your Application Manager are built each time you log in. Each
time it is built, it searches certain system and network locations for applications.

If your system administrator adds an application to your system or to an
application server while you are in a session, you must update your Application
Manager if you want the new application to be registered immediately.

There are two ways to update Application Manager:

® Open the Desktop_Tools application group and double-click Reload
Applications.

® Or, log out and back in.

v To Create a Personal Application Group

A personal application group is an application group that you can alter, since
you have write permission to it.

1. From your home folder, change to the .dt/appmanager  subfolder.

2. Create a new folder.

The folder name will become the name of the new application group.

3. Double-click Reload Applications in the Desktop_Apps application group.

Your new application group will become registered at the top level of
Application Manager.
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v To Add Applications to a Personal Application Group

® Copy icons from other application groups to the personal application group.

For example, you can copy (by pressing Control and dragging) the
Calculator icon from the Desktop_Tools application group to your new
personal application group.

Create an action for an application and then place an application (action)
icon in the personal application group. See “Creating Personal Actions and
Data Types” on page 151.

Advanced Application Manager Concepts

This section describes several advanced Application Manager concepts:

The relationship between file names and icon labels
The folder location of Application Manager
Creating personal actions and data types

Where to obtain additional information about customizing Application
Manager

File Names in Application Manager

In File Manager and Application Manager, files and folders are represented as
icons, and these icons are usually labeled with the file name. Action icons are
sometimes an exception to this rule.

In most cases you see the action icon’s label instead of the action file name.
Normally, you do not need to know the action file name. However, there are
situations where you may see the file name.

For example, if you use the Copy File dialog box to copy the icon (by selecting
the file and choosing Copy to from the Selected menu), the dialog box will
display the file name.
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Folder Location of Application Manager

Application Manager behaves very much like File Manager. This is because
Application Manager is a File Manager view of a special folder on your system
used to gather registered applications. Ordinarily, you do not need to know the
location of this special folder. However, its location may be useful to you if you
are trying to troubleshoot problems.

Login Manager creates the Application Manager folder each time you log in.
Its location is:
Ivar/dt/appconfig/appmanager/ special_folder_name

where special_folder_name is a name assigned by the system that is unique for
your system and login name.

Caution — You should never attempt to directly modify the special_folder_name
folder from a command line.

Creating Personal Actions and Data Types

The desktop provides a tool that helps you create icons for running scripts,
applications, and other commands. You may want to use this tool if you have a
personal application your system administrator has not configured for you.

For example, suppose you have your own favorite spreadsheet application that
you usually start by typing a command into a terminal emulator window:

FavoriteSpreadSheet -file data_file

You can create an icon that runs this command so that you won’t have to
continue manually typing it. To do this, you must create a special desktop
“macro” called an action. You can also create a data type for the data_files if you
like.

The desktop includes a tool called Create Action that makes it easy to create
actions and data types. To open the Create Action window, double-click the
Create Action icon in the Desktop_Tools application group.
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Figure 6-6  Create Action window

To see online instructions for using the window:

1. Choose Tasks from the Create Action window’s Help menu.

2. Click the hyperlink “To Create an Action With Create Action.”
Create Action:

® Creates an action for your application
® Places an action icon in your home folder.

You can move or copy that icon to other locations—for example, to a personal
application group that you’ve created.
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Registering Applications

When an application is registered in Application Manager, it has its own
application group. This application group is available to all users on the
system.

Registering applications is an advanced task, since it requires you to be the
root user. For instructions, see the Advanced User’s and System Administrator’s
Guide.

Running Applications Using File Manager

If an application uses data files, it may be configured so that the application
can be started from File Manager using any of its data files.

v To Run an Application from File Manager
® Double-click an application’s data file.

For example, double-clicking a bitmap file (a file whose name ends with
.bm) runs Icon Editor.

® Or, select an application’s data file and choose Open from the icon’s pop-up
menu or from the Selected menu.

Running Applications from the Desktop 153



6

Running and Organizing Applications Using the Front Panel

The Personal Applications subpanel is a container for applications you use
frequently.

Persamal Applications

i3
| k3

Initially, it contains:
Install Icon Drop zone for adding applications to the subpanel.

Text Editor Duplicates the control in the Main Panel. Opens the desktop
Text Editor.

Terminal Starts the desktop terminal emulator for entering commands
manually.

Web Browser Starts the Web browser to which your PATH defaults.

v To Put an Application in the Personal Applications Subpanel
1. Open the application group containing the application you want to add.
2. Display the subpanel to which you want to add the application.

3. Drag the application from Application Manager to the Install Icon control in
the Personal Applications subpanel.

v To Run an Application from the Personal Applications Subpanel

¢ To run the application, click its control.
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If the application icon that was installed in the subpanel is a drop zone, the
control is a drop zone too. You can run an application by dragging a data file
from File Manager to its control.

v To Replace the Main Panel Personal Applications Control

Initially, the Main Panel contains the Text Editor control. You can replace the
Text Editor control with the control of your choice.

1. Add the application you want in the Main Panel to the Personal
Applications subpanel.

See “To Put an Application in the Personal Applications Subpanel” on
page 154,

2. In the Personal Applications subpanel, point to the control you want in the
Main Panel and choose Copy to Main Panel from the control’s pop-up
menu.

Running Applications from a Terminal Emulator Window

A terminal emulator is an application whose window provides a command
line. The command line lets you type commands into your system—for
example, operating system commands, script names, or commands that run
applications.

All applications have a command that users can type to start them. The
application’s documentation usually describes how to use the command.

The desktop provides a terminal emulator called dtterm . Your system may
include other terminal emulators.

To open a terminal emulator window, click the Terminal control in the Personal
Applications subpanel.

For more information on using dtterm , see Chapter 12, “Using Terminal.”
v To Start an Application on Your System Using a Terminal Emulator

+ Type the command that starts the application into the terminal emulator
window.
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If the application has its own window, you should add an ampersand character
(&) to the end of the command. This runs the application “in the background,”
which lets you continue using the terminal emulator window while the

application is running.

For example, the following command runs the load meter program xload in
the background:
/usr/bin/X11/xload &
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v To Start an Application on Another System Using a Terminal Emulator

There are two ways to use a command line to start an application on another
system:

® Using rlogin
® Using remsh

Using rlogin

When you use rlogin , you use your terminal emulator to log in to a different
(remote) system. You then run the command to start the application on that
system.

1. Use the rlogin  command to log in to the system containing the
application.

rlogin remote_system_name
For example:
rlogin systemA

2. Type the command to start the application. Use the -display = option to
send the window back to your display.

For example, assuming your own system’s display name is MySystem:0 :

lusr/bin/X11/xload -label systemA -display MySystem:0

Using remsh

The term remsh stands for “remote shell.” It provides a one-step way to run an
application, since you do not have to log in before running the command.

¢ Type the command:

remsh remote_system_name -n command

The command must include the -display  option to send the window back
to your display.

For example:
remsh systemA -n /usr/bin/X11/xload -display MySystem:0
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Customizing the Desktop
Environment I

Style Manager can be used to customize the appearance of the desktop.

Customizing Screen Appearance 160
Customizing System Behavior 167
Customizing Startup and Logout 172

To start Style Manager:

¢ Click the Style Manager control in the Front Panel.

jmlfl |:.|.|/|J
]m%ﬂéﬁ

Figure 7-1  Style Manager Front Panel control

159



Customizing Screen Appearance

160

The Style Manager controls and the items that they control are:

Color Workspace colors and palettes
Font Application font sizes and font groups
Backdrop Workspace backdrop patterns
Keyboard Key click volume and character repeat capability
Mouse Mouse button click settings, double-click speed, pointer
acceleration, and pointer movement threshold
Beep Beeper volume, tone, and duration
Screen Number of minutes before your screen blanks and whether
your screen is covered and locked at that time
Window How a window acquires focus, if the window raises when it
receives focus, and where window icons are placed
Startup How your session begins and ends
Etyle Mannger
i, 3.
& oo gifi =n @ p O EF o
Figure 7-2  Style Manager controls

You can change the following aspects of your screen appearance:

® Workspace colors
®* Workspace backdrops
® Font sizes and font groups
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Colors

Be,leye

You set your workspace colors through a color palette. The number of color
buttons in the palette is determined by your display type and the Number of
Colors selection.

The default is More Colors for Applications, which keeps the number of colors
used on a high-color display to a minimum. To increase the number of color
buttons on a high-color display, select More Colors for Desktop in the Number
of Colors dialog box and restart the current session.

While you can't use more colors than your display allows, you can reduce the
number of colors used by the desktop by choosing a lower-valued color usage.

For example, if you have a high-color display and have selected More Colors
for Desktop but you want to run a color-rich application such as a computer-
aided design (CAD) program, you should choose More Colors for Applications
or Most Colors for Applications to decrease the number of colors that the
desktop uses. The remaining colors are available for the CAD program.

Color Buttons

Your display type and the Number of Colors selection determine the number
of color buttons that make up a palette. You will have two, four, or eight color
buttons in the Color dialog box. The different color buttons in the palette
control the colors used for different areas of the screen.

If you have eight color buttons, they will be used as follows (buttons
numbered from left to right, top to bottom):

1. Active window borders
2. Inactive window borders

3. Switch for workspace 1 and every fourth additonal workspace (workspace
509, ..)

4, Text and list areas

5. Main window background and switch for workspace 2 and every fourth
additional workspace (workspace 8, 12, ...)

6. Dialog box background and menu bar and switch for workspace 3 and
every fourth additional workspace (workspace 7, 11, ...)
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7. Switch for workspace 4 and every fourth additional workspace (workspace
6, 10, ...)

8. Front Panel background

If you have four color buttons, they will be used as follows (buttons numbered
from left to right):

1. Active window borders

2. Window bodies:
a. Inactive window borders
b. Main window and dialog box backgrounds and menu bar
c. Front Panel background

3. Workspace switches and backgrounds

4. Text and list areas

If you have two color buttons, they will be used as follows (buttons numbered
from left to right):

1. Active window borders

2. Everything else

To Select a Palette
1. Click the Style Manager Color control.

2. Select a palette from the Palettes list.

Style ﬂﬂna_;cr = Color
Palettes
| hnemome
| Brodea Add . , . |
| Babernet
| tncts Delete. .. |
| Cardzamn
| CEnmnsmn
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3.

Click OK.

Workspace colors come from predefined color palettes. The Color dialog box
lists the palettes that came with your system plus any palettes you have added.

To Modify an Existing Palette

1.
2.
3.

Click the Style Manager Color control.
Select a palette in the Color dialog box.

Double-click a color button to open the Modify Color dialog box, or click a
color button and then click Modify.

Adjust the settings for the level of red, green, blue, brightness, or hue by
adjusting the corresponding slider.

The old and new color samples will be displayed in the upper left corner of
the Modify Color dialog box.

Click OK in the Modify Color dialog box.
Repeat steps 2-4 to modify another color button.

Click OK in the Color dialog box.

To Grab a Color from the Workspace

1.
2.
3.

Click the Style Manager Color control.
Select a palette in the Color dialog box.

Double-click a color button to open the Modify Color dialog box, or click a
color button and then click Modify.

Click Grab Color to display the grab pointer.
Move the pointer to an area of color on the screen that you want to grab.

Click to make that color the new color.

Note — This causes the desktop to use one more color so applications have one
fewer color available to them.
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To Create a Custom Palette

You can create your own palette by copying and modifying an existing palette.
1. Click the Style Manager Color control.

2. Choose Add in the Color dialog box.

3. Type the new palette name and click OK in the Add Palette dialog box.

4. Modify the palette.

5. Click OK in the Color dialog box.

Adding a palette makes a copy of the currently selected palette with a unique
name. You then create your custom palette by modifying the copy and the
original palette is not changed.

To Delete a Palette

1. Click the Style Manager Color control.

2. Select the palette from the Palettes list.

3. Click Delete.

4. Click OK in the Delete Palette dialog box.

When you delete a palette, Style Manager prefixes the name of the palette with
a ~ and stores a copy in the HomeDirectory/.dt/palettes directory.

To Restore a Deleted Palette
1. Open a File Manager view showing HomeDirectory/.dt/palettes.

2. For system-supplied palettes, delete the file ~palette_name.dp

For user-added palettes, rename the deleted palette from ~palette_name.dp
to palette_name.dp.

3. Restart Style Manager (close, then reopen).
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Fonts
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To Change the Number of Colors Used by the Desktop

1.
2.
3.

4.

Click the Style Manager Color control.
Click Number of Colors in the Color dialog box.

Select an option to set the number of colors used by the desktop.

See “Colors” on page 161.

Click OK.

You must log out and back in for the change to take effect.

The font size and font group you select in Style Manager is used on titles,
menu bars, window labels and text. The new font size and font group is used
as applications are started. Existing windows will not reflect the change.

1.
2.
3.

To Select a Font Size
Click the Style Manager Font control.
Select a font size under Size.

Click OK to enable newly started applications to use the selected typeface,
or click Cancel to cancel the operation.

To Select a Font Group
Click the Style Manager Font control.
Select a font group under Font Group.

Look at the Preview window labels and text, which show the new font
typeface.

Click OK to enable newly started applications to use the selected typeface,
or click Cancel to cancel the operation.
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To Add a Font Group
1. Click the Style Manager Font control.
2. Choose Add in the Font dialog box.

3. Choose a font group from the System scrolling list and a font group from the
User scrolling list.

4. Click OK to open the Font Group Name dialog box.

5. Enter a name in the New Font Group Name field of the Font Group Name
dialog box for the new font group.

You can enter any non-blank name that you want.

6. Click OK to add a font group to the Font dialog box scrolling list.

To Delete a Font Group
1. Click the Style Manager Font control.
2. Select a font group from the Font Group scrolling list on the Font dialog box.
3. Click the Delete button.
The Delete Font Group dialog box appears.

4. Click OK to delete the font group from the Font Group scrolling list.

To View Font Attributes
1. Click the Style Manager Font control.
2. Click the Attributes button.

The Font Attribute dialog box appears. It provides name and location
information on the font size and font group you selected. This information
varies according to the alias family (system, user, user bold) and character
set you choose from the combo boxes at the top of the dialog box.

3. Click Close to dismiss the Font Attribute dialog box.
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Backdrops

77 You can select a backdrop pattern to cover each of your workspaces (the screen
Fror area underneath your windows). A unique backdrop for each workspace adds
variety and helps you to quickly identify the workspace you are in.

i d hel ickly identify th k i

Baoleleon

v To Select a Backdrop
1. Switch to the workspace where you want the backdrop.
2. Click the Style Manager Backdrop control.
3. Select a backdrop.
4. Click Apply.

Customizing System Behavior

You can adjust the following settings for system devices:
® Keyboard click volume and character repeat

® Mouse button click settings, double-click speed, pointer acceleration, and
pointer movement threshold

® Beeper volume, tone, and duration
® Screen blanking when not in use

® Window focus, movement, and icon behavior

v To Change Keyboard Behavior

1. Click the Style Manager Keyboard control.

ﬁ 2. Select the settings you want:

Heybuasd « Auto Repeat: Sets characters to repeat when you hold down their keys
 Click Volume: Determines the volume of key clicks (turned off at 0%)

3. To save the changes, click OK. To return to the default settings, click Default.
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v To Change Mouse Behavior
1. Click the Style Manager Mouse control.

2. Select the settings you want:
+ Handedness: Reverses mouse buttons 1 and 3.

» Button 2: Determines whether the middle mouse button is used to extend
selections (Adjust) or drag-and-drop objects (Transfer). If Adjust is
selected, transfer actions (drag) will require the use of mouse button 1.

* Double-Click: Determines the maximum time between clicks of a double-
click. (Test the speed by double-clicking in the mouse picture provided.) A
new double-click speed does not take effect until the next time you log in.

» Acceleration: Sets how fast the mouse pointer moves across the display.

« Threshold: The distance in pixels the pointer moves at a slow speed before
moving at the accelerated rate.

3. To save the changes, click OK. To return to the default settings, click Default.

v To Change Beep Settings

. @ 1. Click the Style Manager Beep control.

2. Select the settings you want:

=t « Volume: Determines the volume of the beep (turned off at 0%)
» Tone: Determines the pitch of the beep from 82 to 9000 Hertz
« Duration: Determines the length of the beep

3. To save the changes, click OK. To return to the default settings, click Default.

Screen without Lock Extensions

You can customize the screen blanker or Front Panel lock, or return the settings
to the default. If your system supports lock on timeout, see “Screen with Lock
Extensions” on page 169.

If you have a color display, bright colors on the screen can burn into the picture
tube. Setting the screen to go blank or be covered prevents this from
happening.
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v To Change Screen Blanker Settings
1. Click the Style Manager Screen control.

2. Select the settings you want:

» Screen Blanker: Enables (On) or disables (Off) the screen blanker
immediately, even before you click OK. When Screen Blanker is On the
Start Blanker slider is active.

« Start Blanker: Specifies the number of minutes from the last pointer
movement or keystroke before the screen is blanked. When this value is
changed, the new value goes into effect immediately, even before you click
OK.

3. To save the changes, click OK. To return to the default settings, click Default.

v To Change Front Panel Lock Settings
1. Click the Style Manager Screen control.

2. Select the settings you want:
» Use Backgrounds For Lock: Enables the lock backgrounds.
» Transparent Lock: Backgrounds are not used when the screen is locked.

» Backgrounds List: Displays the available backgrounds in a multiple-select
list. Select or deselect a background by clicking on the list item. The last
background selected will be displayed to the right of the list.

< Time Per Background: Specifies the number of minutes each selected
background runs before the next one starts when the screen is being
saved. The backgrounds are cycled through in the same sequence as they
appear in the list. A setting of 0 (zero) results in only the last background
(the one currently in the preview area) being used.

3. To save the changes, click OK. To return to the default settings, click Default.

Screen with Lock Extensions

You can customize the screen saver or screen lock, or return the settings to the
default. If your system does not support lock on timeout, see “Screen without
Lock Extensions” on page 168.
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If you have a color display, bright colors on the screen can burn into the picture
tube. Setting the screen to go blank or be covered prevents this from
happening.

To Change Screen Saver Settings
1. Click the Style Manager Screen control.

2. Select the settings you want:
 Screen Saver: Enables (On) or disables (Off) the screen saver immediately,
even before you click OK. When Screen Saver is On the Start Saver slider
is active.

» Screen Saver List: Displays the available screen savers in a multiple-select
list. Select or deselect a screen saver by clicking on the list item. The last
screen saver selected will be displayed to the right of the list.

« Start Saver: Sets the number of minutes from the last pointer movement or
keystroke before the screen saver starts. When this value is changed, the
new value goes into effect immediately, even before you click OK.

« Time per Saver: Specifies the number of minutes each selected screen
saver runs before the next one starts.

3. To save the changes, click OK. To return to the default settings, click Default.

To Change Screen Lock Settings

If the screen saver and screen lock are both enabled (On) and the Start Lock
value is smaller than the Start Saver value, when the screen lock times-out it
replaces the contents of the screen with the currently selected screen savers. If
Start Lock is greater than Start Screen, then the automatic screen lock simply
continues the current screen saver.

If the screen saver is disabled (Off) and automatic screen lock is enabled (On),
when the screen lock times-out the contents of the screen are not covered with
a screen saver.

1. Click the Style Manager Screen control.

2. Select the settings you want:

« Screen Lock: Enables (On) or disables (Off) Screen Lock on a timeout.
When this setting is changed, the new setting goes into effect immediately,
even before the dialog box is closed.
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« Start Lock: Specifies the number of minutes from the last pointer move or
keystroke before the screen lock starts. When this value is changed, the
new value goes into effect immediately, even before you click OK.

3. To save the changes, click OK. To return to the default settings, click Default.

You can change the window focus policy, how active windows are displayed,
and where window icons are displayed.

To Change Window Behavior
1. Click the Style Manager Window control.

2. Select the settings you want:
* Point In Window To Make Active: Makes a window active when the
mouse pointer enters it
¢ Click In Window To Make Active: Makes a window active when the
mouse pointer enters it and you click mouse button 1

3. To save your changes, click OK.

4. Click OK when asked to Restart the Workspace Manager.

To Change How Active Windows Are Displayed
1. Click the Style Manager Window control.

2. Select the settings you want:
* Raise Window When Made Active: Select this if you want a partially
concealed window to be brought to the top when it becomes active

« Allow Primary Windows On Top: Select this if you want the main window
to be displayed on top of secondary windows when you click the primary
window

» Show Contents During Move: Select this if you want to move the whole
window during a window move instead of just moving the outline at first

3. To save your changes, click OK.

4. Click OK when asked to Restart the Workspace Manager.
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v To Change Where Window Icons Are Displayed

1. Click the Style Manager Window control.

2. Select the settings you want:
e Use Icon Box: Displays your window icons in an icon box
« Place On Workspace: Displays your window icons on the workspace
backdrop

3. To save your changes, click OK.

4. Click OK when asked to Restart the Workspace Manager.

Customizing Startup and Logout

172

You can change the following options for startup and logout:

® Session started when you log in
® Session to be your home session
® | ogout confirmation preference

Whenever you are logged into the desktop, you are working in a current
session. By default, when you log out, the desktop saves your current session
and restores it the next time you log in.

You can also save a home session, a session you want to be able to return to
regardless of what you do during the current session.

v To Change How Your Next Session Starts

1. Click the Style Manager Startup control.

2. Select the settings you want:

* Resume current session: Starts your next session the way you left your last
one including any setting, client, or resource modifications

¢ Return to Home session: Starts the session you set as your home session

« Ask me at Logout: Select this if you want to be asked at logout whether to
restart the current session or restore the home session

To define a new home session based on your current session, select Set
Home Session.

3. To save your changes, click OK.
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v To Set a Home Session

When setting a home session, be sure to first select and save your desired
startup settings.

1.
2.
3.
4.

Click the Style Manager Startup control.
Click Set Home Session.
Click OK in the confirmation dialog box that appears.

Click OK in the Startup dialog box.

If you have never set a home session, the system default session is used when
you select Return to Home session.

v To Set Your Logout Confirmation Preference

1.
2.

Click the Style Manager Startup control.

Select On or Off for Logout Confirmation.

If you set Logout Confirmation to On, whenever you log out you will be
asked for confirmation that you want to log out.

Click OK.
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Using Mailer 8

Mailer is a desktop application for sending, receiving, and managing your
electronic mail (email) messages.

Starting Mailer 176
Logging In to Your IMAP Inbox 176
Using the Mailer Main Window 177
Viewing Your Mail Messages 178
Acting on Your Mail Messages 179
Sending Mail Messages 190
Editing and Formatting Outgoing Messages 200
Creating and Using Mailboxes 203
Printing Mail Messages 207
Working with Attachments 209
Customizing Mailer 211
Using the File Selection Dialog Box 214
Using Mailer Mnemonics and Keyboard Shortcuts 216
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Starting Mailer

The instructions in this chapter assume you are familiar with basic desktop
skills and keyboard navigation.

For more information, see Chapter 1, “Basic Skills,” and Appendix A,
“Keyboard Shortcuts for the Desktop.” Many of the tasks you do in Mailer can
be done using drag and drop.

+ Click the Mailer control in the Front Panel.

&
s = =5
r AL r .-:..l i

Figure 8-1 Mailer icons showing new, read, and no mail

When you start Mailer for the first time on your system, it looks for a local or
remote Internet Messaging Access Protocol (IMAP) mailbox in your email
setup.

® |If the setup does not indicate the type of mailbox you have, Mailer prompts
you to specify the mailbox type.

® |f the setup indicates that your mailbox is local, Mailer opens your Inbox
(which usually resides in the directory /var/mail/ username).

® |If the setup indicates that your mailbox is remote, Mailer opens the Mailer
Login dialog box so you can log in to the IMAP server.

After Mailer starts, the mailbox is displayed, along with message headers and
a view of the selected message.

Logging In to Your IMAP Inbox

176

With the Login dialog box displayed, do the following:
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1. Type the server name in the IMAP Server field.

The name that you type in this field becomes the default. Next time you log
in, Mailer displays it in the IMAP Server field.

To change this default, see “To Change the Default Mailbox Directory” on
page 206.

2. Type your login name in the Login field.
3. Type your password in the Password field.

4. Click Login.

Your IMAP Inbox opens with the headers of your email messages displayed
in the Message Header List.

Using the Mailer Main Window

The Mailer main window is shown in Figure 8-2.
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Figure 8-2  Mailer main window
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The main window contains the following areas:

Message Header List Displays information about mail messages

Toolbar Contains buttons for tasks that you perform frequently
Sash Resizes the Message Header List and message view area
Message view area Contains header fields and message text

Attachment list Displays icons of mail message attachments, if any

Viewing Your Mail Messages

Once you’'ve started Mailer and begun to collect email messages, you’ll want to
read and perhaps sort them.

v To Read a Mail Message

1. Choose Check for New Mail from the Mailbox menu to retrieve any new
messages that have been delivered to your mailbox.

2. Click to select the message to be viewed from the Message Header List.

The text of the message is displayed in the message view area.

Use the Next and Previous buttons on the Toolbar or options on the View
menu to continue to select and read messages in the message view area.

To open a message into a separate window for reading:

+ Select the message and choose Open from the Message menu. From this
window, the Edit and Attachments menus become available.

The message remains in the separate window even when you select another
message in your Message Header List. You can then view two messages at
the same time.

v To Change the Character Set of an Incoming Message

On occasion, you may receive an email message from a machine that uses an
encoding that is different from the default encoding for your machine. To be
able to read the message, change the character set for your machine to one that
matches the message's encoding (for example, US-ASCII).

1. Select the message in the Message Header List.
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2. Choose Change Char Set from the View menu or press Control+Y, the
keyboard accelerator.

Mailer displays the name of a character set (for example, US-ASCII) in the
footer immediately below the Toolbar icons.

3. Choose the Change Char Set menu item or press Control+Y again to cycle
through the choices until the correct one is displayed.

Selecting Default Char Set displays your message in the default encoding
for your machine.

Mailer converts the text of the message to the character set that you selected,
not its header or attachments.

Sorting Mail Messages

You can use the options on the View menu to order your messages.

By Date/Time Sorts messages with the most recent at the bottom

By Sender Sorts messages alphabetically by sender name

By Subject Sorts messages alphabetically by subject

By Size Sorts messages from the smallest to the largest

By Status Sorts messages together by read and new (useful if you read your mail

in non-sequential order)

The message headers are rearranged and redisplayed in the mailbox in the new
order.

Acting on Your Mail Messages

After reading your email, you may want to reply to, search for, delete, and
(possibly) undelete some messages.

v To Reply to a Message
1. Select the message to which you want to reply.

2. Decide on the type of reply:
» To reply to the sender, choose Reply from the Compose menu.

A Compose window is displayed with the email address of the recipient
and the message subject filled in.

Using Mailer 179



180

3.

» To reply to the sender and all recipients, choose Reply to All from the
Compose menu.

A Compose window is displayed with the email addresses of the
recipients and the subject of the message filled in.

« To reply to the sender or all recipients and include a copy of the
message, choose Reply, Include Message or Reply to All, Include Message
from the Compose menu.

A Compose window is displayed that includes the text of the message
with the email addresses of the recipients and the subject filled in.
Attachments are not included in the reply.

Type your reply and click Send.

For more information, see “To Address, Compose, and Send a Mail Message”
on page 191.

v To Forward a Message

1.
2.

4,

Select the message you want to forward.

Choose Forward from the Compose menu, or click the Forward button on
the Toolbar.

The text of the message to be forwarded is displayed within a new message,
as well as its attachments, if any.

If you do not want to forward the attachments, choose Forward, no
Attachments.

Type the addresses of the message recipients in the To or Cc fields, or use
the To or Cc button menus to access any aliases that you have set up.

Add any additional text and click Send.

See “To Address, Compose, and Send a Mail Message” on page 191 for more
information.

v To Edit an Incoming Message

1.

Select the message you want to change.
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2. Choose Forward from the Compose menu.
3. Address the message to yourself.

4. Edit the message in the Compose window and send it.

Note — You may want to create a separate mailbox for these edited messages as
they can add to the size of your Inbox.

v To Save an Incoming or an Outgoing Message as Text

1. Determine the save format.

« For an incoming message: Select the message, then choose Save As Text
from the Message menu.

e For an outgoing message: Choose Text from the Save As submenu of the
File menu in a Compose window.

2. Type a file name and location in the File Selection dialog box that appears.

3. Click Save.

v To Delete a Mail Message
To remove a message from the Message Header List:

1. Select the message for deletion.

You can drag to select multiple messages. Shift+Click selects several
messages in a row by moving the highlight up or down the Message Header
List. Control+Click selects discontiguous messages from the list, one at a
time.

2. Choose Delete from the Message menu, or click the Delete button in the
Toolbar.

The messages are deleted from the list.

Note — Even if a message has been deleted, you can get it back unless you
made your deletions permanent by choosing Destroy Deleted Messages from
the Mailbox menu. See the following section.
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v To Undelete a Mail Message

Do one of the following to undelete a mail message:

® To restore a message you just deleted, choose Undelete Last from the
Message menu.

® To restore an earlier message, choose Undelete from List from the Message
menu, then select one or more messages from the list of deleted messages,
and click the Undelete button.

Note — To make the deletions in the list permanent, choose Destroy Deleted
Messages from the Mailbox menu.

v To Destroy Deleted Messages When Closing the Mailbox

You can set your options so that when you close your mailbox, the messages
you deleted will be permanently destroyed. Doing so means that once you
close your mailbox, you cannot restore the messages that you deleted.

1. Choose Basic from the Options menu.

The Basic Options dialog box is displayed.

2. Select “When | close the mailbox” under Destroy Deleted Messages.

To remove the confirmation notice that appears each time you close the
mailbox and asks if you want to destroy deleted messages, deselect “Show
confirmation notice.”

3. Click OK or Apply to make your changes take effect.

Searching for Mail Messages Within a Mailbox

You can search for mail messages within a mailbox according to the search
criteria that you define. Basic search criteria fields in the Basic window of the
Search dialog box include: the addressees (To), the sender (From), the subject
(Subject), the carbon copy recipients (Cc), and the message text, including the
headers (Entire Message).

By creating a search script in the Advanced window of the Search dialog box
with keywords and arguments, you can define more sophisticated search
criteria for finding messages.
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The tables that follow show the keywords you can use in search scripts,
grouped under the following categories:

® Headers — Keywords that denote the headers or the text part of the
messages (Table 8-1)

® Dates — Keywords that indicate when the messages were sent (Table 8-2)
® States — Keywords that describe the status of the messages (Table 8-3)

® Operators — Keywords that join together other keywords to form a search
criterion (Table 8-4)

Note — Those keywords you can type manually but are not available through
the menus in the Advanced window of the Search dialog box are marked with
an asterisk (*).

Table 8-1 Headers Search Keywords

Keyword Explanation
TO

FROM

SUBJECT

CC

TEXT A keyword that pertains to the entire message, including headers and
attachments

BCC

HEADER A keyword to use according to the syntax:
header HeaderName HeaderValue, such as
header x-sun-charset us-ascii

BODY A keyword that applies to the message text and the text attachments, but
not the headers
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Table 8-2 lists and describes the Dates keywords.

Note — The date format is dd-mmm-yyyy (for example, 02-Apr-1996 ).

Table 8-2 Dates Search Keywords

Keyword Explanation

BEFORE

SINCE

ON

DURING

SENTSINCE

SENTBEFORE

SENTON

TODAY An argument for the keywords that are associated with
dates, such as before

YESTERDAY Same as above

LASTWEEK Same as above

THISMONTH Same as above

LASTMONTH Same as above

JANUARY..DECEMBER
SUNDAY..SATURDAY

Table 8-3 lists and describes the States keywords.

Table 8-3 States Search Keywords

Keyword Explanation

READ

UNREAD

NEW*

OLD*

DELETED* A keyword for messages that you have deleted, but not permanently
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Table 8-3 States Search Keywords (Continued)

Keyword Explanation

UNDELETED*

RECENT*

FLAGGED*

ANSWERED*

UNANSWERED*

KEYWORD*

UNKEYWORD*

DRAFT*

UNDRAFT*

ALL* A keyword that denotes all the messages in the mailbox

LARGER* A keyword that requires two arguments, such as smaller 300 , the
numeric denoting bytes

SMALLER* Same as above

Table 8-4 lists and describes the search operators.

Table 8-4 Search Operators

Operator Explanation

AND

OR

~ (not) A symbol that represents the logical not operator

( A symbol that denotes the beginning of an expression
) A symbol that denotes the end of an expression

Search scripts are not case sensitive.
Here are some examples:

To search for messages that were sent from john in April with either “urgent”
or “important” in the subject line:

from john and (subject urgent or subject important) and during april
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To search for messages that were sent from bill  with no carbon copy to

tigerteam  and not yet read:

from bill and ~(cc tigerteam) and unread

To search for messages that were addressed to bill

or sent with a carbon copy

to bill , with “monthly report” in the message, including the headers and

attachments:

(to bill or cc bill) and text “monthly report”

v To Find a Mail Message Within a Mailbox

1. Choose Search from the Message menu.

The Search dialog box is displayed.

Mallar —aa re® Lvar sl rlnal

Saarch Type: Baghc

i

Froem

Subject:

Cr

Entire Massaga

Search Down Egarch Up Save AL Wlew, Show Viewo.

S=lect All Claar Cancs| Helg

Figure 8-3  Mailer Search dialog box
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2. Type the text you want to search for in the appropriate field.

You can search for a match on one or more of the To, From, Subject, or Cc
fields. If you type the criteria in multiple fields, Mailer searches for
messages that match all of the criteria.

Within each field, Mailer considers the input as one criterion even if there
are multiple strings separated by spaces or commas. For example, if you
type wood smith in the To field, Mailer looks for a message that is
addressed to wood smith , not wood or smith .

The fields are not case-sensitive.

3. Click Search Down or Search Up to find the next or previous matching
message in your mailbox. To find all the matches, click Select All.

Note — To remove all the text in the fields in the Search dialog box, click Clear.

To Create Advanced Search Scripts

1. Choose Advanced from the Search Type menu.

The Advanced Search dialog box is displayed.

WA ller - Saarch Livar mail/marinal

Search Typs: Adyanced

Meaders ¢ | Dates SHates Crarators

Evample S=arch Strirg

fpror “mand frera| et and demtEsfiore g Ter ET1]

2. Type your script in the text area.
Choose keywords from the menus to help you create the script.

The keywords are not case sensitive.
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Using Views

Occasionally, you may want to display only the messages in your mailbox that
match one or more search criteria, such as messages to or from a certain
individual. You can do so by defining the criteria and saving them as a view.

1.

To Create a View

Choose Search from the Message menu.

The Mailer Search dialog box is displayed.
Specify your search criteria.

Click Save As View.

The Mailer Save As View dialog box is displayed.

Type a name in the Enter View Name field.

You cannot use All or New as a view name; they are listed under Default
Views. You may want to use a name that reflects the search criteria.

Click OK.

Mailer creates a new view and places it in the Custom Views list in the
Views dialog box. To see the list, click Show Views in the Search dialog box
or choose Show Views from the Mailbox menu.

To Display, Delete, or Update Views

1. Choose Show Views from the Mailbox menu.

If the Search dialog box is open, you can also click Show Views in that
dialog box.

The Views dialog box is displayed.
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Listed are:

» Default Views: Message statistics for the entire mailbox (All) and
messages that you have not yet read (New)

e Custom Views: Message statistics for the views that you have created.
Mailer displays the name of the view being loaded in the title bar of the
main window.

2. To display a view, double-click the view in the list, or select it and click
Load.

The messages that match the search criteria for that view are displayed in
the mailbox.

3. Optional. To update views, click Update.

Mailer revises the message statistics for all of the views for the mailbox.
4. Optional. To delete a view, select it and click Delete.

5. Click Close to close the dialog box.

To Edit a View

1. Select a view in the Custom Views list.
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2. Click Edit.

The Search dialog box is displayed with the fields filled in with the search
criteria for that view.

3. Edit the fields.

If Mailer cannot display the search criteria in the Basic window, then it loads
the search script in a text area in the Advanced window for you to edit.

4. Click Save as View.
Mailer displays the view name in the Enter View Name field.
5. Click OK to save the view with the same name.

Alternately, type a new name for the view and click OK to save it.

v To Rearrange the Order of the List Under Custom Views:

¢ Select a view under Custom Views. Click the up or down arrow button to
move the view up or down the list.

Sending Mail Messages

An email address is like your personal address for receiving electronic mail
messages. This is also the way you send messages to other email users. The
format used for email addresses is username@hostname. Your system
administrator uses this format to set up email addresses.

This section gives you most of the information you need to address, compose,
and send a message to another user.

Using Aliases

An alias is a private name for one or more user names (or user addresses). By
creating a distribution list of user addresses to which you frequently send mail
and giving the list a name, you can just type the name of the alias instead of
typing each address in the To or Cc field every time you send messages.

The name you give to your alias can be descriptive of a group of users, or just
a name you will remember.
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v To Create, Modify, or Delete an Alias

1. Choose Aliases from the Options menu in the main window, from the
Format menu in a Compose window, or from the To or Cc button menu in
the Compose window.

The Aliases Options dialog box is displayed.
2. Type the name for your alias in the Alias field.

3. Type the user addresses that will make up the alias in the Addresses field.

Each of these addresses should be in the form username@hostname, separated
by a comma, space, or both.

4. Click Add to add the information in the Alias and Addresses fields to the
scrolling list.

5. Optional. To change an alias, select it and edit the Alias or Addresses field, as
appropriate, then click Change.

6. Optional. To remove an alias, select it and click Delete.

7. Click OK or Apply to make the settings take effect.

v To Address, Compose, and Send a Mail Message

Once you have the receiving party’s email address, you can send a message.

Note — If this is the first time you are using email and if you know your own
email address, you can use these procedures to send a test message to yourself.

1. If Mailer is not already started, click the Mailer control in the Front Panel.
The Inbox is displayed.

2. Choose New Message from the Compose menu.

The (New Message) Compose window is displayed.
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Figure 8-4 Mailer Compose window

3. Type the email address of the recipient in the To field and press Return.

You can address a message to one or more people, or to an alias.

If one or more of the email addresses contains a space, then separate the
email addresses with commas; otherwise, separate them with commas or
spaces.

Alternatively, if you have created aliases, use the To button menu to access
them.

For information on aliases, see “Using Aliases” on page 190.

4. Optional. Type the topic or title of the message in the Subject field and press
Return.

5. Optional. Type the email addresses of users you want to be carbon copy

recipients of this message in the Cc field, or, if you have created aliases, use
the Cc button menu to access any aliases that you have set up.
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6.

10.

11.

Once your message is addressed, press Return to go to the text area and
compose the message.

To insert a text file, see “To Include a Text File in a Mail Message” on
page 197. Also see “Using a Template to Compose a Mail Message” on
page 194 and “Using a Draft to Compose a Mail Message” on page 195.

To find out about editing text in your message, see “Editing Text” on
page 201 or “Formatting Text” on page 201.

You can save the message you are composing at any time by choosing Text
from the Save As submenu of the File menu or from the Save As button
menu at the bottom of a Compose window.

Optional. Choose Include Signature from the Compose Format menu to place
your signature in the text area if you have deselected “Include signhature in
every message” in the Signature Options dialog box.

See “Using a Signature” on page 197 for details.

Optional. To format the text to the width of your Compose window, select
the text and choose Word Wrap from the Compose Format menu.

Optional. Add files to the message as attachments, if necessary.
To find out how to do so, see “To Add an Attachment” on page 209.

Optional. Choose Save Outgoing Mail from the Compose File menu to save a
copy of the message to the file that stores your outgoing messages
( HomeDirectory/Mail/sent.mail by default).

To change the default file name, choose Basic from the Options menu and
edit the “Save a copy of outgoing mail in” field.

Click the Send button, choose Send from the Compose File menu, or press
F3.

The Compose window closes, and the message is sent.

Note — Clicking Close removes the Compose window and discards your
message. Be sure to save any text you might want later before closing a
Compose window.
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To Change the Character Set of an Outgoing Message

If you need to send an email message to a machine that uses a different
encoding from the one for your machine, you can convert its text to your
recipient’s encoding.

1. After typing your message in the Compose window, choose Change Char
Set from the Format menu or press Control+Y, the keyboard accelerator.

Mailer displays the name of a character set (for example, 1SO-2022-JP) in the
footer of the Compose window.

2. Choose the Change Char Set menu item or press Control+Y again to cycle
through the choices until the correct one is displayed.

Selecting Default Char Set means that your message is sent in the default
encoding for your machine.

The display of the message in your Compose window does not change;
however, Mailer delivers it in the selected character set when you click
Send.

Note — Mailer converts only the text of the outgoing message, not its header or
attachments.

Using a Template to Compose a Mail Message

You can save a message as a template for use repeatedly, such as a template for
a status report that you send out monthly. The status report template might
contain, for example, the addresses, subject, and headings for the message
body. You could use that template and fill in the contents before emailing it as
a status report every month.

To Create a Template

1. Choose Templates from the Options menu of the Mail Options dialog box.

The Templates Options dialog box is displayed.

2. Click the New Template button.

A Compose window is displayed.
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3. Type the headers and template body.

4. Choose Template from the Save As button menu at the bottom of the
window, or from the Save As submenu of the File menu.

The Mailer Save As Template dialog box is displayed.

5. Type the template name in the text field, and click Save.

The template is saved in the default directory
HomeDirectory/MailTemplates . Its name and path are displayed in the
Templates scrolling list.

You can save an attachment as part of a template. Doing so is equivalent to
copying the attachment there. Editing or moving the source of the
attachment after it has been included in the template does not affect the
attachment in the template.

v To Use a Template

1. From the main window, choose New, Use Template from the Compose
menu, then choose the template you would like to use from the submenu.

The Compose window opens with the template loaded.

Note - If the Compose window is already open, you can load the template by
choosing its name from the Use Template submenu of the Format menu in the
Compose window.

2. Edit the headers and body, as necessary, and send the message as usual.

For more details, See “Editing and Formatting Outgoing Messages” on
page 200.

Using a Draft to Compose a Mail Message

Occasionally, while composing a message, you may want to save it as a draft,
then continue to work on it later before sending it as a message. A draft is
intended for one-time use only. Once you click Send after working on a draft in
the Compose window, Mailer deletes it from your file system.
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v To Create a Draft

1.

Choose New Message from the Compose menu.
A Compose window is displayed.
Compose the message as you normally would.

Choose Draft Message from the Save As button at the bottom of the
window, or from the Save As submenu of the File menu.

The Mailer Save As Draft dialog box is displayed.
Type a file name under Draft Name.
Click Save.

Mailer saves the draft in the default mailbox HomeDirectory/MailDrafts

Note — You can also save the message body only as text by choosing Text from
the Save As button.

v To Use a Draft

1.

Choose Continue Composing Draft from the Compose menu, then choose
the draft you would like to work on from the submenu.

The Compose window opens with the draft loaded.

Note - If the Compose window is already open, you can load the draft by
choosing its name from the Use Draft submenu of the Format menu.

2.

Continue with your edits and send the message as usual.

After you have clicked Send, Mailer posts a message that asks if you want to
delete that draft from the file system once the message is sent.
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v To Include Multiple Messages in a New Message

1.

2.
3.

From the Message Header List, select the email messages to be included in
your new message.

Shift+Click selects several messages in a row by moving the highlight up or
down the Message Header List. Control+Click selects discontiguous
messages from the list, one at a time.

Choose Forward from the Compose menu.

Compose and send your message as usual.

v To Include a Text File in a Mail Message

You can drag and drop a text file from File Manager to a Compose window or
follow these steps:

1.

Choose New Message from the Compose menu.

A Compose window is displayed.
Choose Include from the File menu in the Compose window.
Select the text file to be included in your email message.

Click Include.

The file is included in the text area of your message.

Compose and send your message as usual.

Using a Signature

A signature is text you can include with each mail message that you send. For
example, a typical signature might include your name, job title, company
name, and so on:

John Person

Marketing Manager

ABC Products, Inc.

Email: john.person@mymachine
Phone: (100) 555-1234
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You can either include this signature with each email message, or choose to
include it on an individual message basis.

To Create a Signhature

1.

Choose Signature from the Options menu in the main window or the
Format menu in a Compose window.

The Signature Options dialog box is displayed.
Type the text for the signature in the Signature text pane.
Click OK or Apply.

Your signature is saved in the default file HomeDirectory/.signature . You
can change this default location by typing a new path in the Save signature
to Path/File field.

To Include a Signature in All Messages

1.

Choose Signature from the Options menu in the main window or the
Format menu in a Compose window.

The Signature Options dialog box is displayed.
Select the “Include signature in every message” option.

Click OK or Apply.

To Include a Signature Only in Specific Messages

1.

Choose Signature from the Options menu in the main window or the
Format menu in a Compose window.

The Signature Options dialog box is displayed.
Deselect the “Include signature in every message” option.
Click OK or Apply.

In the Compose window for the message in which you want to include your
signature, choose Include Signature from the Format menu.
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v To Create an Automatic Reply (Vacation Message)

If you plan to be away from your mail for a period of time, such as during a
vacation, you can set up an automatic reply to alert the senders of your
incoming mail about your absence.

1.

Choose Vacation Message from the Options menu.

The Vacation Message Options dialog box is displayed.
Select On next to Vacation.

Type the date you want the vacation reply to start under Start Date.

The default is today’s date.
Type the End Date.

Your vacation message takes effect at 12:01 a.m. or later of the Start Date,
and ends at 12:01 a.m. of the End Date. If the start and end dates are the
same, then the vacation notifier ends at midnight of the End Date.

Optional. Under “Interval between replies to repeat senders,” set a number
for the interval during which the sender will receive one automatic reply
from you.

The default is seven days. which means the senders of your incoming mail
will receive only one automatic reply from you within seven days of your
absence, regardless of how many messages they send you during that
period.

Type a subject and the text for your vacation message.

The default for this field is “Out of the office.” If you use the variable
$SUBJECTIn your message, the subject of the incoming mail will be quoted
in your vacation message. For example:

I am on vacation, and will read your message regarding “$SUBJECT
when | return.

Click OK or Apply.

Once your vacation message is on, Mailer adds [Vacation] to the mailbox
name on the title bars of your Inbox and other mailboxes until your vacation
message is off.
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Note - To stop sending your vacation message before the End Date, select Off
next to Vacation, then click OK or Apply.

Sending Mail Messages in MIME or Sun Mail Tool Format

Mailer sends messages in MIME format (a published standard officially known
as RFC 1521 or RFC-MIME). If your email recipients see confusing codes like
=20 or =09 in the messages that you send, their mail applications are not
MIME-compliant.

You can solve this problem by having your email recipients use a MIME-
compliant mail application. If that is not possible, then send your email in Sun
Mail Tool format. However, most MIME-compliant mail readers do not
understand this proprietary format.

v To Send Mail Messages in MIME or Sun Mail Tool Format
1. Choose Send As from the Compose File menu.

2. Choose either Internet MIME or Sun Mail Tool from the submenu.

Your message is sent in the selected format.

If you do not specify a format, the default is Internet MIME. To change this
default:

1. Choose Advanced from the Options menu.

The Advanced Options dialog box is displayed.
2. Deselect the option, “Send mail in MIME format.”

3. Click OK.
Editing and Formatting Outgoing Messages

While composing an outgoing message, you can use Mailer to edit and format
your text, as well as check the spelling.
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Editing Text

You can use the Edit menu options in a Compose window to change the
message text you are composing.

Table 8-5 Mailer Compose Window Editing Options

Undo
Cut

Copy

Paste

Paste Special
(Bracketed or
Indented)

Clear

Delete

Select All
Find/Change

Check Spelling

Reverses the last editing action in the text area.

Removes the selected text and stores it on the clipboard. Only one
selection can be stored at a time. If text is already there, the most
current selection overwrites it.

Stores a copy of the selected text on the clipboard. Only one
selection can be stored at a time. If text is already there, the most
current selection overwrites it.

Inserts the contents of the clipboard at the insertion point.

Inserts the contents of the clipboard at the insertion point
surrounded above and below by Begin and End Included
Message text, or by indented markers.

Removes the selection and leaves the resulting white space.
Removes the selection and the resulting white space.
Selects all the text in the text area.

Opens a dialog box for you to search for words or phrases in
your message and make changes to occurrences that are found.

Runs the spelling checker on your mail message and displays a
dialog box that lists words that might be spelled incorrectly. You
can Find, Change, or Change All instances of a word.

For more information on editing functions, see Chapter 10, “Using Text

Editor.”

Formatting Text

You can use two of the Format menu options in the Compose window to make
formatting changes to the message you are composing.

Word Wrap

Using Mailer

Toggles the text entry mode that causes lines to automatically wrap
at the edge of the message. Note that if you have Word Wrap on and
the recipient’s window is of a different size, you may cause display
problems.
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Settings Displays a dialog box for setting margins and paragraph alignment,
and applying format settings to your message.

For more information on editing functions, see Chapter 10, “Using Text
Editor.”

v To Find or Change Text

1. Choose Find/Change from the Compose Edit menu.
The Find/Change dialog box is displayed.

Find/Change |
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Figure 8-5 Mailer Find/Change dialog box

2. Type (or copy and paste) the text you want to locate in the Find field.

3. Optional. To automatically change the located text to replacement text, type
the replacement text in the Change To field.

4. Select the appropriate option:
 Click Find to find and select the text.
 Click Change to change the first instance.
 Click Change All to change all instances.

5. Click Close to dismiss the dialog box.
v To Check Spelling

You can use the spelling checker in Mailer to verify and correct the spelling in
the message you are composing.
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1. Choose Check Spelling from the Edit menu in the Compose window.

The Spell dialog box is displayed, showing the first instance of a potentially
misspelled word under Word. Suggestions for the correct spelling are
displayed in a scrolling list. For details, see “To Correct Misspelled Words”
in Chapter 10, “Using Text Editor.”

Note — The spelling checker is case sensitive.

2. Click Close to exit the Spell dialog box.

Creating and Using Mailboxes

You may want to file certain mail messages for safekeeping. All your messages
are received by default in the mailbox (Inbox). Since keeping all your mail
messages in your Inbox probably is not practical, you may want to set up other
mailboxes to store groups of messages together.

Mailboxes help you organize your mail. You can create mailboxes by project,
by user, by email list, or any other system that works for you. You should place
these mailboxes in the default mailbox directory HomeDirectory/Mail

To find out how to change the default mailbox directory, see “To Change the
Default Mailbox Directory” on page 206.

v To Create a Mailbox
1. Choose New Mailbox from the Mailbox menu.
The File Selection dialog box is displayed.
2. Specify the mailbox name and location.
See “Using the File Selection Dialog Box” on page 214 for details.
3. Click New.

The new mailbox is created in HomeDirectory/Mail , the default mailbox
directory, and opened.

To find out how to change this directory, see “To Change the Default
Mailbox Directory” on page 206.
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v To Open a Mailbox
1. Choose Open Mailbox from the Mailbox menu.

2. Choose one of the following items in the submenu:
 Inbox — The mailbox where you receive email by default

< Sent Mail — The file that contains your outgoing messages
(HomeDirectory/Mail/sent.mail by default). This item is active only if
you have saved outgoing messages in this file.

» Select Mailbox — A mailbox that you specify from the File Selection dialog
box

e Other Mailboxes — One of the mailboxes in the default mailbox directory

< The mailboxes that you opened, or moved or copied messages to
previously in this Mailer session

v To Close a Mailbox
To close a mailbox:
¢ Choose Close from the Mailbox menu or Window menu, or press Alt+F4.

When the last open mailbox is closed, Mailer exits.

Filing Messages in Other Mailboxes

You can file some incoming messages by manually moving or copying them
into specific mailboxes.

v To Manually File Messages in Other Mailboxes

+ Select the messages that you want to file and do one of the following:

» Choose Select Mailbox from the Move menu (or the Copy To submenu of
the Message menu) and select the desired mailbox in the File Selection
dialog box.

« Choose Other Mailboxes from the Move menu (or the Copy To submenu
of the Message menu) and indicate the desired mailbox.

« Drag and drop messages to other mailboxes.

See “To Drag and Drop Messages to Other Mailboxes” on page 205 for
more information.
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For convenience, you can:

Add mailboxes where you frequently file messages to your Move menu
(and the Copy To submenu of the Message menu).

For information on adding mailboxes to your Move menu, refer to
“Customizing the Open, Move, and Copy To Menus” on page 206.

Set your Move menu to display the most recently visited mailboxes.

For details, refer to “To Change the Number of Mailboxes Displayed in the
Move Menu and Copy To Mailbox Submenu” on page 207.

v To Drag and Drop Messages to Other Mailboxes

1.

v To Remove a

Make sure Mailer is open on the desktop and its Message Header List is
visible.

Open the mailbox to which you want to move the message and make sure
you can see the Message Header List.

Select the message to be moved.

Drag the message and drop it onto the appropriate mailbox Message Header
List.

The message is moved to the end of the target mailbox.

You can also drag and drop a message to the file icon of the target mailbox
in File Manager. With this method, Mailer places a copy of the message in
the target mailbox instead of moving it.

Mailbox from Your File System
Open File Manager.
Select the mailbox to be deleted.

Choose Put in Trash from the Selected menu.

The mailbox is deleted.

See “To Put an Obiject in the Trash Can” in Chapter 5, “Managing Files with
File Manager,” for more information.
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Note — Do not remove a mailbox while it is open in Mailer.

v To Change the Default Mailbox Directory

1.

Choose Move Menu Setup from the Options menu.

The Move Menu Setup Options dialog box is displayed.
Type the directory name in the Default Mailbox Folder field.

Optional. Type the IMAP server name in the IMAP Filing Server field.

You can also specify the default mailbox folder for your IMAP server by
editing the Default IMAP Folder field; the default is HomeDirectory/Malil

Click OK or Apply.

Customizing the Open, Move, and Copy To Menus

Once you have set up a number of mailboxes, you may discover that there are
several mailboxes you use frequently. You can customize your Move menu, the
Open Mailbox submenu of the Mailbox menu, and the Copy To Mailbox
submenu of the Message menu to show these key mailboxes. Opening and
filing to mailboxes is much more efficient this way.

Adding the names of the mailboxes that you recently opened to the Move
Menu and Copy To Mailbox submenu of the Message menu can save you time
when you next move or copy messages to these mailboxes.

v To Add Mailboxes to the Open, Move, and Copy To Menus

1.

Choose Move Menu Setup from the Options menu.

The Move Menu Setup Options dialog box is displayed.

Select Local or IMAP Server to specify the server where the mailboxes are
located.

If you select IMAP Server, type the server name in the text field.
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Type the path to the mailbox under Path/Mailbox Name, then click Add.

The mailbox is added to the Move menu, as well as the Open Mailbox
submenu of the Mailbox menu and the Copy To Mailbox submenu of the
Message menu.

Optional. Make further customizations:

* To alter what is in the Path/Mailbox Name field once a mailbox name is
selected, edit that field and click Change.

« To delete a mailbox name from the scrolling list, select it and click Delete.
< To display the mailboxes in alphabetical order, click Alphabetize.

« To change the position of a selected mailbox in the scrolling list, click
Move Up or Move Down.

Click OK or Apply.

To Change the Number of Mailboxes Displayed in the Move
Menu and Copy To Mailbox Submenu

To change the number of mailboxes that are displayed on these menus:

1.

Choose Move Menu Setup from the Options menu.

The Move Menu Setup Options dialog box is displayed.

Increase or decrease the number of mailboxes you have recently opened in
the “Display up to: Recently visited mailboxes” field.

Click OK or Apply to make the change take effect.

Up to the desired number of mailboxes now appear on the Move menu and
the Copy To Mailbox submenu of the Message menu.

You can print messages with the default options, or set different print options
before starting the print job.
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v To Print a Copy of a Message with Default Options

1. Select the message to be printed in the Message Header List.

Shift+Click selects several messages in a row by moving the highlight up or
down the Message Header List. Control+Click selects discontiguous
messages from the list, one at a time.

2. Choose Print One from the Message menu.

v To Print a Message with Specific Options

1. Select the message to be printed.

Shift+Click selects several messages in a row by moving the highlight up or
down the Message Header List. Control+Click selects discontiguous
messages from the list, one at a time.

2. Choose Print from the Message menu.

3. Set the options you want to change:

* Type a new printer name in the Printer field.

* Indicate the number of copies in the Copies field.

< Type a banner page title in the Banner Page Title field.

» Select Print Page Numbers to print page numbers in your document.
* Type print command options in the Print Command Options field.

4. Click Print.

v To Print a Message Using Drag and Drop
1. Select the message to be printed.

2. Drag the message onto the Printer control in the Front Panel.

The Print dialog box is displayed.
3. Set the print options as desired and click Print.

For more information, see “To Print a Message with Specific Options” on
page 208.
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Working with Attachments
An attachment is an image, document, or executable file that you send or

receive with your email.

v To View an Attachment

1. Select the attachment icon in the attachment list.

intro.pgl.ps
Figure 8-6 Example of an attachment icon

2. Choose Open from the Attachments submenu in the Message menu, or
double-click the attachment icon.

Note — If Open does not appear on the Attachments submenu, you cannot
open the attachment.

v To Print an Attachment
1. Select the attachment.

2. Choose Print from the Attachments submenu in the Message menu.

Note — If your system does not provide the ability to print attachments, or if
the attachment cannot be printed, the Print item will not be available.

v To Add an Attachment

1. Compose your email message.
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2.

4.

Choose Add File from the Attachments menu in the Compose window.

The Mailer - Attachments - Add dialog box is displayed. See “Using the File
Selection Dialog Box” on page 214 for more information.

Select a file to attach and click Add.

The attachment is added to the attachment list in the lower portion of the
Compose window.

To remove an attachment you just added, select its icon and choose Delete
from the Attachments menu.

To restore a deleted attachment, choose Undelete from the Attachments
menu.

Optional. Choose Rename from the Attachments menu to change the name
of a selected attachment.

If you drag and drop messages from the Message Header List in the main
window to the attachment list, Mailer creates one mailbox that contains all of
the messages.

v To Save an Attachment to Your File System

1.
2.
3.

Select the attachment you want to save.
Choose Save As from the Attachments menu.

In the File Selection dialog box, indicate where you want to save the
attachment.

Type a new name, if desired, for the file.

Click Save.

The file is saved to the selected location.

Note — You can also drag and drop an attachment to File Manager. See
Chapter 5, “Managing Files with File Manager,” for more information.
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v To Attach a File from File Manager

1. Select the file within File Manager.

2. Optional. If the attachment list is not displayed, choose Show List from the
Attachments menu in a Compose window.

3. Drag the file from File Manager and drop it onto the attachment list in a
Compose window.

4. Send the message as usual.

Note — You can also drag an attachment from the attachment list to File
Manager. See Chapter 5, “Managing Files with File Manager.”

v To Attach a Calendar Appointment

Customizing Mailer

1. Create the calendar appointment in Calendar.

2. Drag the appointment from the Calendar Appointment Editor dialog box
and drop it onto the attachment list in the Compose window.

3. Send the message as usual.

Note - You can also drag a calendar appointment attachment from the
attachment list to Calendar. See “To Drag an Appointment from Another
Application to Calendar” in Chapter 11, “Using Calendar.”

Once you have used Mailer for some time, you may want to change some of its
defaults. The Options menu provides you with these choices:

Basic

Aliases

Compose Window
Message View
Move Menu Setup
Notification
Signature
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Templates
Toolbar

Vacation Message
Advanced

The following sections describe some of the customizations you can do using
the options in these dialog boxes.

v To Display Message Numbers in Your Mailbox

1.

Choose Basic from the Options menu.

The Basic Options dialog box is displayed.
Select the Display message numbers option.

Click OK or Apply to make your changes take effect.

The numbering appears on the left side of your Message Header List.

v To Change the Character Marker for Included Text in a Reply

Having a marker for text you include when you reply to a message sets it off
from the text you want to add. Mailer provides a right-angle bracket (>) as the
default. You can customize this marker to a character of your choice.

1.

Choose Compose Window from the Options menu.

The Compose Window Options dialog box is displayed.

Type the character you want to use under Indent Characters For Included
Message.

Click OK or Apply to make your changes take effect.

v To Set How Often Mailer Checks for Messages

1.

2.
3.

Choose Basic from the Options menu.

The Basic Options dialog box is displayed.
Increase or decrease the setting in the “Check for new mail every” field.

Click OK or Apply to make your changes take effect.
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v To Add Custom Fields to the Format Menu

Besides the To, Subject, Cc, and Bcc fields in the Format menu of a Compose
window, you may want to add your own fields, such as Reply-To, Return-
Receipt-To, and so on.

1.

Choose Compose Window from the Options menu.

The Compose Window Options dialog box is displayed.

Type a name in the Header Name field as it will appear in the Compose
window header (for example, Return-Receipt-To).

Optional. Type a default entry for the defined header field in the Default
Value field (for example, your email address).

Click Add to add the values to the scrolling list.

To change a custom field, select it and edit the Header Name or Default
Value field, as appropriate, then click Change.

To remove a custom field, select it and click Delete.

Click OK or Apply to make your changes take effect.

v To Customize Mail Notification

To determine how Mailer signals the arrival of new mail:

1. Choose Notification from the Options menu.

2. Under “Signal new mail with,” specify whether you want Mailer to beep,

the Header window to flash, or Mailer to play an audio file when new mail
arrives. You can choose to have all three signals if you desire.

Set the number of beeps and flashes by clicking on the up or down arrow
under Beeps and Flashes.

To play an audio file, either type the full path name of the file in the Sound
File text field, or click Select to specify that file in a File Selection dialog box.
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Configuring the Appearance of the Toolbar

From the settings in the Toolbar Options dialog box, you can change the
appearance of the Toolbar buttons (as icons or with text), determine which
buttons display, and set the order in which they are displayed.

By default, the following commands appear as icons: Delete; Next; Previous;
Reply, Include Message; Forward; New Message; and Print One.

g ¥ 4 18 = (4 S

To Customize the Toolbar

1. Choose Toolbar from the Options menu.

The Toolbar Options dialog box is displayed. Under Commands is a list of
the commands you can choose to be displayed in the Toolbar, either as
icons or with text. Those commands you have chosen to be displayed in the
Toolbar are shown in the Toolbar scrolling list.

2. Select Icons or Text as your preference for the display.

3. Optional. Click Add or Remove to add or remove a selected command from
the Toolbar.

4. Optional. Click Move Up or Move down to change the order in which the
buttons are displayed.

5. Click OK or Apply to make your changes take effect.

Using the File Selection Dialog Box

214

When you perform certain functions (like opening a mailbox or saving a
message), there is a standard method to access your file system. From a File
Selection dialog box, you are presented with a place to enter a path or folder
name or a place to select from the folders and files in your file system.
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Figure 8-7  File Selection dialog box

The title bar and the buttons of the dialog box vary, depending on the
operation you wish to perform.

The fields are:

Local or IMAP Server — Specifies the mail server type. If you select IMAP
Server, type its name in the text field.

Enter path or folder name - Indicates the path to the item. It can be a
location anywhere in your file system. If folders or file names are selected,
the path appears here.

Filter — Shows the filter criteria; an asterisk (*) shows all files. You can enter
wildcard characters to display only those files that match a suffix. For
example, *.doc lists only those files with a .doc suffix.

Folders — Lists the folders in the current directory.
Files — Lists the files within the current folder.

Enter file name — Shows the name of the mailbox. You can either type in the
name or select it from the list.

You can:

Click Open Mailbox (or whatever action is specified in the leftmost button)
to perform the operation and dismiss the dialog box.
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® Click Update to display a new list of files after changing the filter key or

changing to a new folder.

® Click Cancel to halt the operation without applying the changes and dismiss

the dialog box.

® Click Help to display information about this dialog box.

You can use keyboard alternatives to the mouse, called mnemonics, to navigate
and perform some functions in Mailer. The mnemonics and shortcuts in
Table 8-6 apply to Mailer only. Letters shown in uppercase should be typed as

lowercase.

For more information on keyboard shortcuts, see Appendix A, “Keyboard

Shortcuts for the Desktop.”

Note — Some Mailer shortcuts may interfere with UNIX key bindings. For more
information on these bindings, see Chapter 10, “Using Text Editor.”

Table 8-6 Keyboard Mnemonics and Shortcuts

Task Mnemonic Keyboard Shortcut
Mailbox menu

Check for New Mail Alt+X, then M Control+M

Show Views Alt+X, then S

Select All Messages Alt+X, then A

New Mailbox Alt+X, then N

Open Mailbox Alt+X, then O

Destroy Deleted Messages Alt+X, then D

Close Alt+X, then C Alt+F4
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Table 8-6 Keyboard Mnemonics and Shortcuts (Continued)

Task Mnemonic Keyboard Shortcut
Message menu

Open Alt+M, then O

Copy Selected Text Alt+M, then X Control+S
Select All Text Alt+M, then T

Save As Text Alt+M, then A

Attachments Alt+M, then H

Copy To Mailbox Alt+M, then C

Print One Alt+M, then E

Print Alt+M, then P Control+P
Search Alt+M, then S

Delete Alt+M, then D Control+D
Undelete Last Alt+M, then L

Undelete From List Alt+M, then U

Compose menu

New Message Alt+C, then M Control+N
New, Use Template Alt+C, then N

Forward Alt+C, then F

Forward, no Attachments Alt+C, then S

Reply Alt+C, then R Control+R
Reply to All Alt+C, then A

Reply, Include Message Alt+C, then |

Reply to All, Include Message Alt+C, then E

Continue Composing Draft Alt+C, then C

View menu

Next Alt+V, then N

Previous Alt+V, then P

Abbreviated Headers Alt+V, then H
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Table 8-6 Keyboard Mnemonics and Shortcuts (Continued)

Task Mnemonic Keyboard Shortcut
Change Char Set Alt+V, then C Control+Y
By Date/Time Alt+V, then D

By Sender Alt+V, then S

By Subject Alt+V, then B

By Size Alt+V, then Z

By Status Alt+V, then T

Options menu

Basic Alt+O, then B Control+l
Aliases Alt+0, then A

Compose Window Alt+0, then C

Message View Alt+O, then M

Move Menu Setup Alt+0O, then P

Notification Alt+O, then N

Signature Alt+0, then S

Templates Alt+0O, then T

Toolbar Alt+0, then R

Vacation Message Alt+0O, then V

Advanced Alt+0O, then D

Move menu

Inbox Alt+E, then |

Select Mailbox Alt+E, then S

Other Mailboxes Alt+E, then O

Help menu

Overview Alt+H, then V

Tasks Alt+H, then T

Reference Alt+H, then R

Messages Alt+H, then M
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Table 8-6 Keyboard Mnemonics and Shortcuts (Continued)

Task Mnemonic Keyboard Shortcut
On Item Alt+H, then O

Using Help Alt+H, then U

About Mailer Alt+H, then A

Compose File menu

Include Alt+F, then |

Save As Alt+F, then A

Save Outgoing Mail Alt+F, then M

Send Alt+F, then S F3

Send As Alt+F, then N

Close Alt+F, then C Alt+F4
Compose Edit menu

Undo Alt+E, then U Control+Z
Cut Alt+E, then T Control+X
Copy Alt+E, then C Control+C
Paste Alt+E, then P Control+V
Paste Special Alt+E, then L

Clear Alt+E, then E

Delete Alt+E, then D Del

Select All Alt+E, then S

Find/Change Alt+E, then F Control+F
Check Spelling Alt+E, then K

Compose Attachments menu

Add File Alt+A, then F

Save As Alt+A, then A

Delete Alt+A, then D

Undelete Alt+A, then U

Rename Alt+A, then R

Using Mailer

219



1]
o0

Table 8-6 Keyboard Mnemonics and Shortcuts (Continued)

Task Mnemonic Keyboard Shortcut
Select All Alt+A, then S

Show List Alt+A, then L

Open Alt+A, then O

Print Alt+A, then P

Compose Format menu

Word Wrap Alt+R, then W

Settings Alt+R, then S

Change Char Set Alt+R, then C Control+Y
Use Template Alt+R, then T

Use Draft Alt+R, then D

Include Signature Alt+R, then |

Signature Alt+R, then E

Vacation Message Alt+R, then V

Aliases Alt+R, then A

Add Bcc: Alt+R, then B

Miscellaneous

Move between buttons or fields Tab

Select multiple messages Shift+Click

Select discontiguous messages

Control+Click
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Your Default Printer

Printing 9

You can easily print files, find or cancel print jobs, and get information about
printers and print jobs through the desktop.

Your Default Printer 221
Printing Files 222
Printer Applications 226

Your system may have more than one printer that you can use for printing.
One of the printers will be designated as the default printer. The default printer
is the printer that your desktop automatically uses if you submit a document
for printing and you don’t specify a printer name. When you first open your
desktop, the default printer is shown in the Front Panel.

To find out how to display a printer other than your default printer in the
Front Panel, see “To Change the Front Panel Printer” on page 232.
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v To Determine the Default Printer

+ To find out the name of your default printer, double-click the Default printer
control in the Personal Printers subpanel in the Front Panel.

This starts the Printer Jobs application. The name under the printer icon is
the name of your default printer.

v To Change the Default Printer

Printing Files

222

To designate a different printer as the default printer:
1. Go to your home folder and open the file .dtprofile

2. Add or edit a line that sets a value for the LPDEST environment variable:
LPDEST=printer_device; export LPDEST
If you are using csh the syntax is:
setenv LPDEST  printer_device

Note — This change will take effect the next time you log out and back in again.

For example, the following line would change the default printer to the printer
whose device name is laser3d

LPDEST=laser3d; export LPDEST

If you are using csh the syntax is:
setenv LPDEST laser3d

The desktop can print different types of files, as listed in Table 9-1.
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Table 9-1 Types of Data That Can Be Printed (Initial Configuration)

Type of Data Data Type Requirement Description

Text file File name ends with.txt Text files containing ordinary
(ASCII) text data

PostScript File name ends with .ps, PostScript files
or content is recognized as  (requires a PostScript printer)
PostScript data

PCL File name ends Printer Control Language files
with.pcl, or content is (requires a PCL printer)
recognized as PCL data

Data Contains text data The default data type assigned
to all files containing ASCII data
that do not match other data

types

If applications are installed on your system that create other types of files, your
system administrator can add printing capabilities for them.

Note — Ensure that your destination printer is capable of printing PostScript'"
or PCL files before you try to print them.

Submitting a File to a Printer

There are many ways to submit a file to a printer:

® Using the Front Panel
® Using File Manager

® Using Print Manager
® Using applications

v To Print Using the Front Panel

1. Drag a single file or multiple files from File Manager to the Printer control in
the Front Panel or to a Printer icon in the Personal Printers subpanel.

The system then displays a Print dialog box for specifying print options. A
Print dialog box appears for each file you drag to the Printer control.
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Note — pscolor will not show on your system. It is only included as an example
of a printer that has been added to a system.

2. Optional. Use the text fields in the Print dialog box to set additional print
options. (See “Setting Print Options Using the Print Dialog Box” on
page 225.)

3. Click OK in the Print dialog box to send the job to the printer.

v To Print Using File Manager
1. Select the file in File Manager.

2. Choose Print from the Selected menu or the file’s pop-up menu.

The system displays a Print dialog box for specifying various print options.

3. Optional. Use the text fields in the Print dialog box to set additional print
options. (See “Setting Print Options Using the Print Dialog Box” on
page 225.)

4. Click OK in the Print dialog box to send the job to the printer.
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v To Print Using Print Manager
1. Start Print Manager from the Personal Printers subpanel.

2. Drag a file from File Manager to a printer icon in Print Manager.

In Print Manager, you can submit a document by dropping it on a printer
icon or into the jobs list area to the right of a printer.

Note - If you submit a job to a printer that is down (flag is showing), it may
never be printed even though it appears in the jobs list.

The system displays a Print dialog box for specifying various print options.

3. Optional. Use the text fields in the Print dialog box to set additional print
options. (See “Setting Print Options Using the Print Dialog Box” on
page 225.)

4. Click OK in the Print dialog box to send the job to the printer.

Setting Print Options Using the Print Dialog Box

The desktop displays the Print dialog box when you print text, PCL,
PostScript, and data files (see Table 9-1 on page 223).

Prirt
File:  roow profile
it Ljh_n% Lapias I
Bannes Page Title:
Frint Page Muembers
Prirnt Command Opbons:
Prant Canoel Help

When application data files, such as word processor documents, are submitted
for printing, they may display their own unique Print dialog boxes.
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Printer Applications

226

Use the Print dialog box to set these print options:

Printer The destination for the print job. The text field
initially displays the printer on which you dropped
the data file. In this example, the document was
dropped on a printer named lj4_n5

Copies The number of copies to print. The default is 1.

Banner Page Title A title to appear on the banner page. The banner
page is a sheet of paper that the printer prints
before it prints the first page of your document.

Print Page Numbers Prints page numbers on each page. If page
numbering is selected, Print Manager will not
display the true name of your document. Instead,
the name in the jobs list will be STDIN:XXXXX,
where XXXXX is a five-digit number.

Print Command Options Other options that change the way printing is
done. See the next section for more details on using
this field.

Print Command Options

You can use the Print Command Options text field in the Print dialog box to set
other print options. Type the proper Ip command flag in the text field for the
print option you want to use. To see a list of the I[p command flags, type
man Ip in a Terminal window.

For example, one of the Ip flags is -m. This flag tells the print server to send
you a mail message that tells you when it is done printing your document. To
use this flag you would type -m in the Print Command Options field of the
Print dialog box. Then when your document is done printing, a message
appears in your mailbox from the printer.

After you submit a document (print job) for printing, you can use the Print
Manager or Printer Jobs applications to find out about the progress of the
printing. Printer Jobs gives you information about jobs on a single printer.
Print Manager shows all the printers that are on your system.
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Print Manager

The Print Manager window is shown below. To find out how to modify it,
see “Changing the Print Manager Display” on page 233.

—| Print Manager -
Help
T
i Print jobs
E;rnlgrz?élose waiting to
button be printed

Message line—— E Pm ﬂm

v To Start Print Manager

¢ Click the Print Manager control in the Personal Printers subpanel in the
Front Panel.
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Starts Print Manager

Printer Jobs Application

Pereonal Pambers |

L

4101

The Printer Jobs application is the application you see when you open a single
printer from the Front Panel. The Printer Jobs application is a simplified
version of Print Manager that shows only a single printer instead of all the
printers on your system. The functions that are available inside Printer Jobs
work the same way as they do in Print Manager.

Print jobs waiting
to be printed

Fonter Joba
Prnters Gelectes] Wiam Help
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Default printer — || peceler | Jstterl /resume /report]l /pland
JEccue jahn Jahn nck

Up - In Servica

228 CDE User’s Guide—February 1997



(o}
1]

v To Start the Printer Jobs Application

+ Click the Printer control in the Front Panel.

Perons Prnben

Starts printer jobs -]

_:‘ﬁ:?Ei.iﬂ B |

Note — The pscolor printer is only shown in the figure as an example of a
printer that has been added to a system. It will not be on your subpanel.

Displaying Print Job Information

Information about the jobs waiting to be printed on a printer is displayed
when you open a printer icon. A display area to the right of the printer icon
displays an icon for each of the jobs waiting to be printed on it, and each job’s
position in line, job name, and owner.

v To Open a Printer Icon
There are three ways to open a printer:
® Click the Open [+] button to the left of the printer icon.

® Select a printer, then choose Open from the Selected menu or from the
printer’s pop-up menu (displayed by pressing Shift+F10 or mouse button 3).

® Double-click the printer icon.

Printing 229



1]
(o)

Note — Your job will not appear in the Print Manager or Printer Jobs window if
there are no jobs waiting to be printed when you send your job to the printer.

v To Close a Printer Icon
Close a printer if you don’t want to see the jobs waiting to be printed on it.
® Click the Close [-] button to the left of the printer icon.

® Select a printer, then choose Close from the Selected menu or from the
printer’s pop-up menu (displayed by pressing Shift+F10 or mouse button 3).

v To Find a Print Job

1. Choose Find from the Printers menu.

Find is available in Print Manager but not in the Printer Jobs application.

2. Type the name of the print job you want to find in the Job Name field.

For example, typing cat will find all jobs that include the fragment “cat” in
their name, such as “Catchall” and “catalog,” regardless of case.

To find jobs with the name “cat” only, you would select Exact match.

To find only jobs that match your capitalization, deselect Ignore case.

Note - Find only finds print jobs that list you as the owner and it searches all
printers, even those that are not currently displayed.

3. Click Start Find.

4. Once you have found a job, you can go directly to it in Print Manager or
cancel it. To go to a found job, select the job and click Goto. To cancel a
found job, select it and click Cancel Print Jobs.

v To Cancel a Print Job

1. Select a print job in the Print Manager or Printer Jobs window.
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2. Choose Cancel from the Selected menu or from the print job’s pop-up menu
(displayed by pressing Shift+F10 or mouse button 3).

3. Click Yes in the confirmation dialog box.

Print Job Properties

The following properties can be displayed for print jobs:

Job name

Job owner

Job number

Job size

Time job submitted
Date job submitted

Note — The term “not available” may appear in some fields to indicate that the
print system is not supplying that information.

Print Mapager = Priat Job Properties
dob Bawe: Step/Printing
Duner: dow
Job Number: 192
Bige: 3392 bytes
Submitfted
Thame: (8:30:45
Date: 1004/ M4

(1] 1 Help

v To Display Print Job Properties

1. Select a print job.
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2. Choose Properties from the Selected menu or the print job’s pop-up menu
(displayed by pressing Shift+F10 or mouse button 3).

The properties are displayed.

Printers and the Front Panel

The printer shown in the Front Panel is usually your default printer. You can
change it to another printer, or add a printer to the Personal Printers subpanel.

v To Change the Front Panel Printer

Note — This does not change your default printer assignment. To find out how
to change the default printer, see “To Change the Default Printer” on page 222.

1. Open the Personal Printers subpanel (by clicking the arrow above the
Printer control in the Front Panel) and verify that the icon for the printer
you want to move to the Front Panel appears.

If the printer is not in the Personal Printers subpanel, add it by following
the steps in “To Add a Printer to the Personal Printers Subpanel.”

2. In the subpanel, point to the printer icon you want to add to the Front Panel
and select Put In Main Panel from the icon’s pop-up menu (displayed by
pressing Shift+F10 or mouse button 3).

To verify that the printer has been changed, click the Printer control in the
Front Panel and check the name of the icon in the Printer Jobs window that
appears.

v To Add a Printer to the Personal Printers Subpanel

1. Open the Personal Printers subpanel (by clicking the arrow above the
Printer control in the Front Panel).

2. Start Print Manager.

3. Drag a printer icon from the Print Manager window to the Install Icon
control in the open subpanel.

232 CDE User’s Guide—February 1997



(o}
1]

Changing the Print Manager Display

This section describes how to change display parameters in Print Manager.

v To Change How Printers and Print Jobs Are Displayed
1. Start Print Manager.
2. Choose Set Options from the View menu.

3. Select how you want the print jobs represented:

« Large Icon — Displays printers and print jobs as large icons

< Small Icon — Displays printers and print jobs as small icons

* Name Only - Displays printer and print jobs as only text

* Details — Displays job owner, size, job humber, and the date and time each
job was submitted

« Show Labels — Displays a description of each details row to the left of the
job list area

Note — The term “not available” may appear in some fields to indicate that the
print server is not supplying that information

4. Click OK.

v To Change the Update Frequency
1. Start Print Manager.
2. Choose Set Options from the View menu.

3. Adjust the interval gauge to specify how frequently printers are queried for
information about their print jobs. The default is every 30 seconds.

4. Click OK.

v To Determine Which Jobs Are Displayed
1. Start Print Manager.

2. Choose Set Options from the View menu.
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3. Select which jobs you want shown:
* Only Mine — Displays just your print jobs
< Everyone’s — Displays all print jobs

4. Click OK.

v To Display the Print Manager Message Line
1. Start Print Manager.
2. Choose Set Options from the View menu.

3. Select Message Line to display a message line at the bottom of the Print
Manager window.

The message line shows the number of printers on your system and the
number that are currently hidden. It also presents messages telling you
when printer updates are being done.

4. Click OK.

v To Display the Print Manager Problem Flag
1. Start Print Manager.
2. Choose Set Options from the View menu.

3. Select Problem Flag to have a flag icon displayed next to printers when a
problem is found with one of them.

For more information on the problem, you can double-click the Flag icon.

4. Click OK.

v To Determine Which Printers Are Shown
1. Start Print Manager.

2. Choose Modify the Show List from the View menu.

Printers that are visible in the Print Manager window have highlighted
names.
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3.

4.

Printer Properties

Click a non-highlighted printer to make it visible in the Print Manager
window.

Click a highlighted printer to remove it from the main window. You can also
use Select All to show all the printers or Deselect All to hide all the printers.

Click OK.

The following properties can be displayed:

Icon label

Icons

Description

Printer queue
Printer queue status
Device name
Device status

v To Show a Printer’s Properties

1.

Select a printer in the Print Manager window or the printer in the Printer
Jobs window.

Choose Properties from the Selected menu or from the printer’s pop-up
menu (displayed by pressing Shift+F10 or mouse button 3).

v To Change a Printer’s Icon

1.

Select a printer in the Print Manager window or the printer in the Printer
Jobs window.

Choose Properties from the Selected menu or from the printer’s pop-up
menu (displayed by pressing Shift+F10 or mouse button 3).

Click Find Set.

Select the new icon you wish to use.

If the icon you want is not visible, choose another folder from the Icon
Folders menu. This dialog box will only display icons that have a complete
set of all three sizes.
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5. After you have selected an icon, click OK.

6. Click OK in the Properties dialog box.

v To Change a Printer’s Icon Label

1. Select a printer in the Print Manger window or the printer in the Printer
Jobs window.

2. Choose Properties from the Selected menu or from the printer’s pop-up
menu (displayed by pressing Shift+F10 or mouse button 3).

3. Type the new icon label in the Icon Label field.

4. Click OK.
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This chapter describes how to create and edit short documents such as memos,

mail messages, or resource files using Text Editor.

Opening and Closing Text Editor 238
Text Editor Window 239
Opening and Saving Documents 240
Moving the Cursor in a Document 245
Entering Text 244
Editing Text 248
Correcting Misspelled Words 253
Searching a Document 261
Formatting and Printing Documents 262
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Opening and Closing Text Editor

There are several ways to start Text Editor from your desktop.

v To Open Text Editor

® Click the Text Editor control in the Front Panel.

® Or, open the Personal Applications subpanel in the Front Panel and click the
Text Editor control.
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Text Editor can also be started from the command line by typing this command
in a Terminal window:

dtpad filename &

The file name is optional.

Note - If the path /usr/dt/bin has not been set in your .cshrc file, then
type /usr/dt/bin/dtpad to run Text Editor from the command line.

v To Close Text Editor

¢ Choose Close from the File menu or press Alt+F4.
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Text Editor Window

Note — If your keyboard does not have an Alt key, ask your system
administrator to identify the corresponding key.

You create and edit a document in the Text Editor window. The title bar
displays the name of the current document. A new document is named
(UNTITLED).
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Figure 10-1 Text Editor window

You can optionally display a status line that reports the number of lines in your
document and enables you to go to a specific line number.

v To Display the Status Line

The status line displays the line number where the insertion cursor is located
and the total number of lines in the document. It also reports Text Editor
messages and indicates whether Overstrike mode is active.

sy |[1 Tauwsd: G Chr gk |

¢ Choose Status Line from the Options menu. To remove the status line,
choose Status Line again from the menu.
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Opening and Saving Documents

You can create a new document or open an existing document. Opening a
document displays the contents of a selected file in the Text Editor window.

Saving a document stores the edited contents into a file. You can save a
document to its original file or to a new file.

v To Create a New Document

A new document named (UNTITLED) is created when you start Text Editor. To
enter text in your document, see “Entering Text” on page 244. You provide a
new file name when you save the document.

After finishing a document, you can create another document using the New
command.

¢ Choose New from the File menu.

The Text Editor window is cleared and a new document is created. If you
have not saved your current document, a dialog box is displayed that
enables you to save your document.

v To Save a Document to a New File
1. Choose Save As from the File menu.

The Save As dialog box lists files and folders located in your current folder.
You can store your document in the current folder, a subfolder, or a folder
that you specify.

If you used Wrap To Fit, the dialog box includes an additional choice about
handling line endings. If Wrap To Fit is set off, the dialog box omits this
choice (see “Using Wrap To Fit” on page 244).
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Figure 10-2 Save As dialog box

2. Optional. If you do not want to save the file to the current folder, choose a
subfolder or indicate a different folder.

 For a subfolder, select the subfolder in the Folders list and press Return.
 For a different folder, use the .. (go up) icon to change to a folder or type

its path name in the Enter path or folder name field.

3. Type a new file name in the Enter file name field.

4. Press Return or click OK.

v To Save a Document to the Original File

+ Choose Save from the File menu to save your work and continue editing

your document.

If you used Wrap To Fit, the Save dialog box includes an additional choice
about handling line endings (see “Using Wrap To Fit” on page 244).

Using Text Editor
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Opening an Existing Document

You can open an existing document in these ways:
® Open the document in Text Editor.

® Select the file icon in File Manager and choose Open from the File Manager

Selected menu.

® Double-click the file icon in File Manager.

® Drag the document’s file icon to the Text Editor control in the Front Panel.

v To Open an Existing Document from Text Editor
1. Choose Open from the File menu.

The Open a File dialog box lists files and folders in your current folder. You
can browse the documents listed, or change to a new folder to locate other

files on your system.
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Figure 10-3 Open a File dialog box
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2. Select the name of the document you want to open, or type the document
name in the Enter file name field.

3. Press Return or click OK.

Note — You can also use this shortcut: double-click the document name in the
dialog box.

v To Open an Existing Document from File Manager

1. Display the document’s file icon in a File Manager window.
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Figure 10-4 Document file icon

2. Open the document in one of the following ways:
» Double-click the document.

« Select the document, then choose Open from the File Manager Selected
menu.

» Drag the document file icon to the Front Panel and drop the icon on the
Text Editor control.
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Entering Text

As you create a document, you type and edit text. A cursor (I ) shows your
current position. Characters are inserted unless you set Overstrike mode (see
“To Set Overstrike Mode” on page 250).

v To Enter New Text
¢ Click in the document and start typing.

To start a new line, press Return. Or, you can use the Wrap To Fit option to
automatically wrap text at the edge of the window.

To start a paragraph, press Return twice.

Using Wrap To Fit

Wrap To Fit controls whether lines are automatically wrapped to fit the width
of the window. When Wrap To Fit is set on, lines are broken automatically at
the edge of the window. Because these line breaks are dynamic, you can resize
the Text Editor window and the text automatically adjusts to fit the new
window width.

When you save your document, you decide whether to add a line break to each
of the wrapped lines, or to retain the dynamic line endings. When you save
your document, you choose one of these options:

® Add a newline character (hard return) to the end of each wrapped line to
preserve each line ending as it currently appears.

® Or, preserve only line breaks that were created by pressing Return.
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v To Set Wrap To Fit On or Off

+ To set Wrap To Fit on, choose Wrap To Fit in the Options menu. To set Wrap
To Fit off, choose it from the menu again.
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Entering Special Characters

Different systems often use certain key combinations to insert special
characters. In some instances, a key combination may be reserved by Text
Editor. For example, a Text Editor mnemonic for displaying a menu might
conflict with a key sequence you want to use on your keyboard.

To insert the correct character you may need to override the reserved behavior
by preceding the key combination with Control+Q.

Moving the Cursor in a Document

As you enter and edit text, you move the insertion cursor using the mouse and
keyboard cursor keys. Using the mouse, move the pointer to the new location
in the document and click mouse button 1.

You can also use the keyboard cursor movement keys:

Key

Up Arrow

Down Arrow

Left Arrow

Right Arrow
Control+Left Arrow
Control+Right Arrow
Home

End

Control+Up Arrow
Control+Down Arrow
Control+Home
Control+End
Control+G

Using Text Editor

Cursor Movement

Up one line

Down one line

Left one character

Right one character

Move left to previous word
Move right to next word
Beginning of the current line
End of the current line
Beginning of the previous paragraph
Beginning of the next paragraph
Beginning of the document

End of the document

To the Line field in the status line
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Note — If your keyboard uses different key labels, ask your system
administrator to identify the corresponding keys.

v To Go to a Specific Line
1. Display the status line (see “To Display the Status Line” on page 239).
2. Press Control+G or click in the Line field of the status line.

3. Type the line number you want to go to and press Return.

v To Scroll a Document

+ Select and drag the vertical scroll bar to view more text. Use the horizontal
scroll bar to view long lines.

You can also use the scrolling keys:

Key Scroll Movement
Page Up Up one page
Page Down Down one page
Control+Page Up Left one page

Control+Page Down Right one page

Selecting Text

246

Before using edit commands such as cut and paste, you must select the text.
You can select text using the mouse or the keyboard.
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v To Select Text with the Mouse
1. Click at the beginning of the text you want to select.
2. Press and hold mouse button 1 and drag to the end of the text.

To deselect text, click any area in the window.

Note — To modify a selection you have made, press and hold the Shift key and
mouse button 1. Then drag forward or backward to adjust the amount of
selected text. Or, hold down the Shift key and one of the arrow keys to change
the selection.

You can also use these shortcuts for selecting text:
Word Double-click the word
Line Triple-click the line

All text Quadruple-click in the text

Secondary Selection

This method enables you select text and replace it with another selection,
which is used as the replacement text.

v To Replace Text Using Secondary Selection
1. Select the text that you want to replace.

2. Move the pointer to the beginning of the text you want to replace the first
selection with. Hold down the Alt key and mouse button 2 and drag to the
end of the text you want to use.

The text is underlined.

Note — If your keyboard does not have an Alt key, ask your system
administrator to identify the corresponding key.

3. Release the Alt key and mouse button.

The underlined text overwrites your first selection.
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v

Editing Text

248

To Select Text with the Keyboard

Text to Select
Text block

Cursor to beginning of line
Cursor to end of line

Cursor to beginning of paragraph
Cursor to end of paragraph
Cursor to beginning of document
Cursor to end of document

All text

Deselect all text

Action

Move the cursor to the beginning of the
text block. Hold down the Shift key and
an arrow key to move the cursor to the

end of the text block.

Shift+Home

Shift+End
Shift+Control+Up Arrow
Shift+Control+Down Arrow
Shift+Control+Home
Shift+Control+End
Control+/

Control+\

Minor edits can be made using the editing keys. You may also want to copy,
move, or delete portions of text, find and change a word or phrase, or check

the spelling of your document.

Editing Keys
Key Action
Backspace Deletes the character before the cursor
Delete Deletes the character following the insertion cursor
Control+Backspace Deletes the previous word
Shift+Backspace Deletes characters from the cursor to the beginning of
the line
Control+Delete Deletes all the characters from the cursor to the end

of the current line

Insert Toggles Overstrike and Insert mode
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Menu Shortcut Keys

You can also use these shortcut keys when making edits.

Control+C
Control+X
Control+V
Control+F

Control+Z

UNIX Key Bindings

Copy selected text
Cut selected text

Paste selected text
Find/Change text

Undo a cut, delete, clear, include, copy, or paste
command

UNIX™ key bindings enable you to use a set of extended Emacs keys, such as
Alt+B (back word) or Control+N (next line), in Text Editor. To enable UNIX key
bindings (which are set off by default) you edit a file in your home directory.

v To Enable UNIX Key Bindings

1. Add the following line to the .Xdefaults file in your home directory:

#include "/usr/dt/app-defaults/ language/UNIXbindings"

Replace language with the name of your language environment.

If the .Xdefaults

file does not exist, create the file in your home directory.

2. Log out of your current session.

3. Log in and restart Text Editor.

Some Text Editor menu accelerators conflict with UNIX key bindings. When
UNIX key bindings are enabled, Text Editor provides alternate menu
accelerators for these commands:

Command

Alternate Menu Accelerator

Find/Change (Control+F) Control+S

Paste (Control+V)
Print (Control+P)
Undo (Control+2)

Using Text Editor

Shift+Insert
no alternate accelerator

Control+_
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If you want to modify these menu accelerators, copy the contents of the
/usr/dt/app-defaults/ language/UNIXbindings  file into your
Xdefaults file and then make your changes.

Note — When using UNIX key bindings, the Delete key deletes the previous
character rather than the character that follows the cursor.

v To Set Overstrike Mode

As you type, new characters are inserted. If you want to type over existing
characters, change to Overstrike mode.

® Choose Overstrike from the Options menu. To return to Insert mode, choose
Overstrike again from the menu.

® Or, use the Insert key to switch between Insert and Overstrike mode.

When Overstrike mode is on, the cursor changes to a block ( ). If you use
Overstrike mode often, you may want to display the status line (see “To
Display the Status Line” on page 239) because it indicates whether Overstrike
mode is on or off.

v To Type Over Text

1. Select the text.

2. Type the replacement text.

You can also choose Overstrike from the Options menu to turn off Insert
mode and type over the text directly.

v To Delete Text

1. Select the text.
2. Choose Delete from the Edit menu or press the Delete key.

Deleted text cannot be pasted, but it can be recovered with the Undo command
(see “To Undo an Edit” on page 251).

If you intend to paste the text that you delete, use the Cut command (see “To
Move Text (Cut and Paste)” on page 251).
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v To Clear Text

The Clear command replaces the selected text with spaces or blank lines.

1.
2.

Select the text to be cleared.

Choose Clear from the Edit menu.

v To Undo an Edit

¢

v To Copy Text

1.
2.

Choose Undo from the Edit menu or press Control+Z.

Undo reverses the last cut, paste, clear, delete, change, include, or format
operation.

Select the text to be copied.

Choose Copy from the Edit menu or press Control+C.

A copy of the text is stored on a clipboard where it can be accessed or
replaced by other applications.

Click where you want to insert the text.

Choose Paste from the Edit menu or press Control+V.

You can also use drag and drop to copy text (see “To Copy Text Using Drag
and Drop” on page 260).

Note — Use this shortcut to copy a word or phrase: Select the text, move the
pointer to where you want to insert the text, and click mouse button 2. This is
a quick way to copy text into a dialog box.

v To Move Text (Cut and Paste)

1.
2.

Select the text.

Choose Cut from the Edit menu or press Control+X.

The text is erased from the document and stored on a clipboard where it can
be accessed or replaced by other applications.
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3. Move the cursor to where you want to insert the text.
4. Choose Paste from the Edit menu or press Control+V.

You can also use drag and drop to move text (see “To Move Text Using Drag
and Drop” on page 260).

v To Include a File

You can insert a text file into your document using a menu command or by
dragging a file icon into the Text Editor window (see “To Include a File Using
Drag and Drop” on page 260).

1. Position the cursor where you want to insert the text file.
2. Choose Include from the File menu.

The Include a File dialog box lists files and folders on your system. You can
browse the documents listed, or change to a new folder to locate other files
on your system.
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Figure 10-5 Include a File dialog box

3. Select the document you want to insert in the Files list.

4. Press Return or click OK.
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Correcting Misspelled Words

You can correct misspelled words with the Spelling Checker. You can also
customize your Personal Dictionary and Main Dictionary; see “Customizing
Spelling Checker Dictionaries” on page 255 for more information.

v To Correct Misspelled Words

1. Choose Check Spelling from the Edit menu.

Note — Your Spelling Checker dialog box may look different than the one
pictured in Figure 10-6. If so, go to Figure 10-7 on page 254 and follow the
instructions after that figure.

The Spell dialog box lists misspelled or unrecognized words.

The Check Spelling (Version 1) feature is only available for the English
language.
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Figure 10-6 Spell dialog box - Version 1

2. Select the misspelled word in the Misspelled Word list that you want to find
and press Return. Or, just double-click the word.

The next occurrence of the word is highlighted in your document.
3. Type the correct word into the Change To field.

4. Click Change to correct a single occurrence.

Or, click Change All to replace all occurrences.
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5. To find and change additional single occurrences, click Find and then
Change.

6. Click Close when you are done.

Note - If your Spelling Checker dialog box resembles Figure 10-7, follow the
instructions after the figure.

The Spelling Checker dialog box displays a misspelled or unrecognized word
and lists suggestions. To start a new spelling check while the Spelling Checker
dialog box is open, click Start Check.

—| Spelling Checker
Unknown ward,
ward: liines |
=URGESTIOn: | Hines Change | Change All |
liens skip | skip all |
linens
line's .
liners Learn Wurd| Qptions. |
Stop Check Close Help

Figure 10-7 Spelling Checker dialog box - Version 2

1. Take action on the first word found by the spelling checker:

If the suggested replacement is correct, click Change to correct this
occurrence, or Change All to change all occurrences. (You cannot Undo a
Change All.)

If you see the correct replacement in the list, select it and click Change or
Change All.

If the correct replacement is not in the list, type it in the suggestion field
and click Change or Change All.

If the word is correct and you want to add it to your Personal Dictionary,
click Learn Word.

If the word is correct but you do not want to add it to your Personal
Dictionary, click Skip to skip this occurrence, or Skip All to skip all
occurrences.
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2. Continue through the misspelled words found by the Spelling Checker.

3. To stop the Spelling Checker and leave the dialog box displayed, click Stop
Check.

To stop Spelling Checker and close the dialog box, click Close.

Customizing Spelling Checker Dictionaries

When you run Spelling Checker, it uses both your Personal Dictionary and
Main Dictionary. You can edit your Personal Dictionary and set your Main
Dictionary.

You can run Spelling Checker with or without your Personal Dictionary. You
can also remove words from your Personal Dictionary, import another user's
Personal Dictionary, and export your Personal Dictionary to make it accessible
to other users. When you import another user’s Personal Dictionary, you can
choose whether you want to append the imported Personal Dictionary to your
own Personal Dictionary, or overwrite your own Personal Dictionary with the
imported one.

Spelling Checker automatically sets your Main Dictionary to the default locale
installed on your system. You can change the Main Dictionary to a different
locale whenever Spelling Checker starts or change the locale just for the
current session.

v To Run Spelling Checker Without Your Personal Dictionary

1. Click Options in the Spelling Checker dialog box.
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2. Choose Personal Dictionary as the Category.

—| Spelling Checker : Options

Categary: Personal Dictionary — |

wWords in personal dictionary:
CDE Ak |

oTL

EBT IFrIp O P L.,
Fisl

Gaskins

InformalExample %
Ry

popup

7 Use Personal Dictionary

Ok | apply | RESEL | Cancell Help

Figure 10-8 Personal Dictionary dialog box

3. Deselect the Use Personal Dictionary checkbox.
4. Click OK to save your changes and close the dialog box.

Spelling Checker will now run only with your Main Dictionary.

To Remove a Word From Your Personal Dictionary
1. Click Options in the Spelling Checker dialog box.
2. Choose Personal Dictionary as the Category.

3. Select the word in the scrolling list.

To select more than one word, select the first word and then Shift-Click (or
Control-Click) to choose the other words. You can drag choose contiguous
words.

4. To delete the word from the list, click Remove.

5. To save your changes and close the dialog box, click OK.

Solaris CDE User’s Guide—February 1997



10

v To Import Another User's Personal Dictionary
1. Click Options in the Spelling Checker dialog box.

2. Click Import in the Spelling Checker Options dialog box.
The Spelling Checker Import dialog box is displayed.

—|  spelling Checker : Import

Filter

fheme/dfunsen, .dictionary /&

Cirectories Files
ifunsondictionary,”, JESEEE Tt efifunson,

Afunsonsdictionarys,

Selectioh

Jhome/funson, .dictionaryfcde-pargonal .

[+114 | Filter| Cancell Help |

Figure 10-9 Personal Dictionary Import dialog box

3. Select the dictionary you want to import in the Files list, or type the
dictionary name in the Selection field.

4. Press Return or click OK.

Note - You can also double-click the dictionary name in the dialog box.

5. In the dialog box that appears, choose whether you want to append the
imported personal dictionary to your own personal dictionary, or overwrite
your own personal dictionary with the imported one.

Vv To Export Your Personal Dictionary

1. Click Options in the Spelling Checker dialog box.
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2. Click Export in the Spelling Checker Options dialog box.
The Spelling Checker Export dialog box is displayed.

—|  sSpelling Checker : Export

Filter

Jhome/nixedy dictionary/ %

Cirectories Files

ie/nixned sdictionary” NS home nized c
1esninedsdictionarys.

[
Selection

Sheme/nixed) dictionaryfocde—parsonal q

1.4 | Filter | Cancell Help |

Figure 10-10 Personal Dictionary Export dialog box

3. Select the dictionary you want to export in the Files list, or type the
dictionary name in the Selection field.

4. Press Return or click OK.

Note — You can also double-click the dictionary name in the dialog box.

Now other users can import your dictionary. You can send your personal
dictionary to another user or tell them where it is in your file system.

v To Set Your Current Dictionary Locale

1. Click Options in the Spelling Checker dialog box.
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2. Choose Main Dictionary as the Category.

The Main Dictionary dialog box is displayed.

—-| Spelling Checker : Options

Categary: Main Dictionary — |

Current Cictionary: English (U5} =]

When spelling Checker Spens:
(" Set Dictionary To Match Locale Language

_JSetDictionary To: grigiici 100} — |

(414 | Apply | Reset | Cam-:ell Help |

Figure 10-11 Main Dictionary dialog box

3. Choose the desired locale as the Current Dictionary.

Note — This locale setting is for the current Spelling Checker session only. The
next time you restart Spelling Checker it will run with your default locale.

4. To save your changes and close the dialog box, click OK.

To Set Your Default Dictionary Locale
1. Click Options in the Spelling Checker dialog box.
2. Choose Main Dictionary as the Category.

3. Determine your main dictionary locale:
« To have your Main Dictionary match the default locale installed on your
system, select Set Dictionary to Match Locale Language.

« To override the system default locale, Set Dictionary To and choose the
desired locale.

4. To save your changes and close the dialog box, click OK.
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Using Drag and Drop

You can use drag and drop to move or copy text between Text Editor
documents or other applications. You can also include a file into your
document using drag and drop.

v To Move Text Using Drag and Drop

1.
2.

Select the text that you want to move.

With the pointer on the selection, press and hold mouse button 1, and drag
to where you want to insert the text.

Release the mouse button.

The text is inserted into your document relative to the position of the drag
icon.

v To Copy Text Using Drag and Drop

1.
2.

Select the text you want to copy.

With the pointer on the selection, press and hold the Control key and mouse
button 1, and drag to where you want to copy the text.

Release the Control key and mouse button.

The text is copied relative to the position of the drag icon.

v To Include a File Using Drag and Drop

When using drag and drop, the contents of the file are copied into the Text
Editor window at the position of the insertion cursor. The original file remains
intact.

1.
2.

Click in your document where you want to include the file.

Drag the file icon that you want to include into the Text Editor window.
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Searching a Document

You can search for a word or phrase in your document. The Find command
begins from the position of the insertion cursor and proceeds through the
entire document. You can automatically replace or delete occurrences found in
your document.

Searches are case sensitive. To find all occurrences, search for both lowercase
and uppercase instances.

v To Find Text

1. Choose Find/Change from the Edit menu or press Control+F.

Tesk By - el Chasee

T aip

Figure 10-12 Find/Change dialog box

2. Type the text you want to find in the Find field.

3. Press Return or click the Find button to locate the next occurrence of the
text.

4. To find additional occurrences, press Return or click Find again.

v To Find and Change Text
1. Choose Find/Change from the Edit menu or press Control+F.
2. Type the text you want to find in the Find field.

3. Type the replacement text in the Change To field.
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Press Return or click the Find button to locate the next occurrence of the
text.

Click Change to replace a single occurrence.

To find and change additional occurrences, click Find and then Change.

Or, click Change All to replace all occurrences.

A Caution — There is no Undo for Change All.

7.

Click Close when you are done.

v To Find and Delete Text

1.
2.

> w

Choose Find/Change from the Edit menu or press Control+F.
Type the text you want to delete in the Find field.
Leave the Change To field blank.

Press Return or click Find to locate the next occurrence.

5. Click Change to delete a single occurrence.

To find and change additional occurrences, click Find and then Change.

Or, click Change All to replace all occurrences.

Click Close when you are done.

Formatting and Printing Documents

262

Once your editing is complete, format your document by choosing margins
and text alignment.
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v To Format a Document

1. Choose Settings from the Format menu.

Tesk By’ = hreyi Sriirs
Lait bargnc | B Fagini Mg ||
ai Al
Fuid i
bty
C g
Farsyaph a8 Clooa Halp

Figure 10-13 Format Settings dialog box

2.

Enter margins.

The default left margin is 0 and the right margin is dynamically set to the
width of the Text Editor window. Margins are specified as a number of
character columns.

Select left, right, justify (block style), or center alignment.

Determine the scope of the formatting:
« To format a single paragraph, place the cursor in the paragraph, then click
Paragraph.

* To format the entire document, click All.

After closing the dialog box, choose Paragraph or All from the Format menu
to apply the settings.

v To Print an Open Document

1. Open the document in Text Editor.

2. Choose Print from the File menu or press Control+P.

The Print dialog box displays the name of your system’s printer and enables
you to set printing options. By default, your document is printed on your
system printer. If desired, you can direct your job to a different printer.
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Figure 10-14 Print dialog box

3. Optional. Set any of these printing options:

* Type the number of copies to print.

» Type text to appear on the printer banner page.

 Click Print Page Numbers if you want to number the pages.
* Type command-line printer options.

4. Click Print.

The Print dialog box closes when you print your document. To close the
dialog box without printing your file, click Cancel.

v To Print a Closed Document
1. Display the document’s file icon in File Manager.

2. Drag the file icon to the Printer control in the Front Panel.

The Print dialog box is opened.
3. Optional. Set printing options.
4. Click Print.
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Recovering a File

If Text Editor is interrupted due to a system error, it attempts to save your
changes in a recovery file in your current folder. The recovery file is named
#filename#, where filename is the name of the document. If you had never
named your document, the recovery file name is #UNTITLED#.

v To Recover a File

1.
2.
3.

Start Text Editor.
Open the recovery file.

Save the document using your original file name or provide a new name for
a previously unsaved document.

Text Editor and Other Applications

Other applications can use Text Editor as a tool to edit documents or other
types of information. Under certain conditions, an application may choose to
restrict your editing choices. In the example below, the File menu has been
modified. The Save As command has been replaced with a Copy To File
command and the New and Open commands are not available.

T Ecier = [UWTRLED]

I_|I|l- r_.rm Ir\.:rrmr ul,'ﬂlnnl. unlr\.
Feae

{leamr

I_nr hude,

E.!'UF

Limpy I tllﬂ..

trlnl. Larlsd

Elnu- AltEFd

Figure 10-15 Text Editor with modified File menu
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Using Calendar

Calendar is a desktop application that enables you to schedule appointments
and To Do items, set reminders, make and print appointment and To Do lists,
browse other calendars, and schedule group appointments.

Starting Calendar 268
Calendar Main Window 268
Calendar Views 270
Appointments 273
To Do Items 277
Printing Calendars, Appointment, or To Do Lists 280
Browsing Calendars on a Network 281
Scheduling Appointments on Other Calendars 283
Customizing Calendar 288
Other Calendar Tools 296
Using Federated Naming with Calendar 302
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Starting Calendar

¢ Click the Calendar control in the Front Panel.

Calendar control

i
§

¢ Type dtcm to start Calendar from the command line.

Calendar Main Window

The menus and tool bar controls are at the top of the main window. The
selected Calendar view is displayed in the lower part of the main window.
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Calendar Tool Bar

Calendar’s tool bar provides controls for quick navigation through calendars.
The tool bar controls and their functions are described in Table 11-1.

Table 11-1 Calendar Tool Bar Icons

Control

Function

|

Taday

m

Appointment Editor icon opens the Appointment Editor so you can
insert, delete, or edit Calendar appointments.

To Do Editor icon opens the To Do Editor so you can create, modify,
update, or set reminders for things you have to do.

Previous View arrow changes the Calendar view to display the view
before the current view. For example, if you are viewing August in
Month view, clicking the Previous View arrow changes the
Calendar display to July.

Today changes the Calendar view to display the current day in the
format you are viewing. For example, if you are viewing by month,
clicking Today displays the current month.

Next View arrow changes the Calendar view to display the view
after the current view. For example, if you are viewing August in
Month view, clicking the Next View arrow changes the Calendar
display to September.

Day View icon displays the calendar you are viewing with one day’s
appointments in the window plus a three-month mini-calendar.

Week View icon displays the calendar you are viewing with a week’s
appointments in the window plus a week grid showing scheduled
times.

Month View icon displays the calendar you are viewing with a
month’s appointments in the window.

Year View icon displays the calendar you are viewing with a year in
the window. Appointments are not displayed.
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Calendar Views

270

Day View

The Calendar view is the day, week, month, or year displayed in the main
Calendar window.

Day view displays the calendar you are viewing with one day’s appointments
in the window. Day view also provides a three-month mini-calendar that
displays the month you are viewing and the previous and next months.

Clicking on a day in the three-month mini-calendar changes the Day view to
display the selected day. Clicking on a month name in the mini-calendar
changes the Calendar display from Day view to Month view.
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Week View

Week view displays the calendar you are viewing with one week’s
appointments in the window. The selected day is highlighted.

Week view also provides a week grid showing at a glance the times that are
scheduled (shaded) and the times that are available (unshaded).

Clicking on a day name in the Week view changes the Calendar display from
Week view to Day view.
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Month View

Month view displays the calendar you are viewing with one month’s
appointments in the window. The selected day is highlighted.

Clicking on a day in Month view changes the Calendar display to Day view.
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Year View

Year view displays a year calendar. Appointments are not displayed. Clicking
on a month name in Year view changes the Calendar display to Month view.
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Appointments

Use the Appointment Editor to insert, change, or delete appointments on your
calendar.

v To Schedule a Basic Appointment

1. In Day, Week, or Month view, display the day for which you want to

schedule an appointment.

2. Double-click that day to open the Appointment Editor.
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Choose the Start and End times.

The default appointment duration is one hour. If your appointment is longer
or shorter, edit the time in the End field.

Type a description of the appointment in the What field.

For example, you may want to enter the appointment’s location and
purpose.

If you want to add optional settings to an appointment, see “To Set
Appointment Options.”

Click Insert.

The appointment is added to your calendar.

Click Cancel to close the Appointment Editor.

v To Set Appointment Options

1.
2.

Set up a basic appointment, as described above.

Click the More button in the Appointment Editor to display additional
appointment options.

Select the desired appointment in the Appointment Editor list.

Select Beep, Flash, Popup, or Mail (or more than one, in combination) for
the types of reminders you want.

Edit the reminder intervals and the Mail To entry if necessary.

Optional. To repeat the appointment more than once, choose an option from
the Occurs menu, and then choose an option from the For menu.

If you don’t see the interval you want, choose Repeat Every from the Occurs
menu, and type the desired interval in days, weeks, or months.
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7. Choose an option from the Privacy menu.

Others See Time and Text  Displays full appointment to others

Others See Time Only Displays only time commitment, not
description
Others See Nothing Displays nothing to others

8. Click Change.

If you set the appointment options at the same time as setting up a basic
appointment, click Insert at this step.

Note - If you are inserting multiple appointments one after another, be sure to
click Clear between insertions. This will reset options that you may not want to
carry over from one appointment to the next.

9. Click Cancel to close the Appointment Editor.

v To Change an Appointment
1. Click the Appointment Editor icon.
2. Select the appointment in the appointment list that you want to change.

3. Edit the appointment date, start or end time, description, reminders,
frequency, or privacy.

4. Click Change.

5. Click Cancel to close the Appointment Editor.

v To Delete an Appointment

[EY

. Click on the Appointment Editor icon to open it.

2. Select the appointment in the appointment list.

w

. Click Delete.

N

. Click Cancel to close the editor.
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v To Find an Appointment
1. Choose Find from the View menu.
The Find dialog box is displayed

2. Type some text in the in the Find field that can become a keyword for the
search; for example, conference

The Find field is not case-sensitive.

By default, Calendar searches the past and future six months in your
calendar. If you want to change the search range, click Search all to search
your entire calendar (can take a long time) or edit the dates in the Search
from fields.

3. Click Find.

Appointments with matching text are displayed in the Find window.
4. Select the desired appointment in the list.
5. Click Show Appointment to display the entire appointment.

6. Click Close to close the Find dialog box.

v To View an Appointment List

This section describes how to create an appointment list and display it on your
system. If you want to print your Appointment list, see “Printing Calendars,
Appointment, or To Do Lists.”

1. Display the view of the calendar that you want the appointment list to
show.

2. Choose Appointment List from the View menu.
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Calendar - Appaintment List
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Appointments are listed chronologically and show date, time, and
description. For example, if you are viewing by week, the Appointment List
displays the week’s appointments.

To Do Iltems

Use the To Do Editor to insert, update, or delete To Do items in your Calendar.

v To Insert a To Do Item

1. Click the To Do Editor icon.

%]

2. Type or edit the due date for the item in the Due Date field.

3. Type a description of the To Do item in the What field.
4. Click Insert.

5. Click Cancel to close the To Do Editor.
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v To Change a To Do Item

1.

oo

N o g &~ w

In Day, Week, or Month view, display the day for which you want to change
a To Do item.

Select that day.

Click the To Do Editor icon.

Select the To Do item in the To Do list.

Edit the due date or the description of the To Do item.

Click Completed to change the status of the To Do item, if applicable.
Click Change.

Click Cancel to close the To Do Editor.

v To Delete a To Do Item

Click the To Do Editor icon to open it.
Select the To Do item in the To Do list.
Click Delete.

Click Cancel to close the editor.

v To View a To Do List

This section describes how to create a list of To Do items and display it on your
system. If you want to print your To Do list, see “Printing Calendars,
Appointment, or To Do Lists.”

1.
2.

Display the view of the calendar that you want the To Do list to show.

Choose To Do List from the View menu.
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To Do items are listed chronologically and show a check box beside each
item, due date, and description. For example, if you are viewing by day, the
To Do List displays the day’s To Do items.

Marking To Do Items Completed

Calendar keeps track of the state of To Do items: whether they’re completed or
pending. In the To Do List dialog box, you can choose to display all To Do
items, only completed items, or only pending items.

If you make a To Do list and then want to check off an item on the list, use one
of the two methods described below.

v To Mark an Item Directly in the To Do List
1. Choose To Do List from the View menu.
2. Click the check box beside the To Do item you’ve completed.

3. Click Apply or OK.

This changes the item’s state to completed.

To return the item’s state to pending, click the check box again and apply
your changes.
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v To Use the To Do Editor To Mark an Item
1. Click the To Do Editor icon.
2. Select the To Do item in the To Do list.

3. Click Completed to mark the item completed.

To return the item’s state to pending, click Completed again.

4. Click Change.

This changes the item’s state to completed.

5. Click Cancel to close the To Do Editor.

Printing Calendars, Appointment, or To Do Lists

You can print any of the four Calendar views, plus appointment and To Do
lists. Calendar uses the default printer settings when you choose Print Current
View from the File menu. To customize printer settings, see “To Change the
Printer Settings for Future Print Jobs” on page 294.

v To Print Current Day, Week, Month, or Year Views
1. Display the Calendar view you want to print.

2. Choose Print Current View from the File menu.

v To Print Your Appointment or To Do List

1. Display the Calendar view containing the day for which you want to print
an appointment or To Do list.

2. Select that day.

3. Choose Print from the File menu.

The Print dialog box is displayed.
4. Choose Appointment List or To Do List from the Report Type menu.
5. Specify a printer in the Printer Name field.

6. Click Print.
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v To Change the Print Options for a Single Print Job

1.

9.
10.

Choose Print from the File menu.

The Print dialog box is displayed.

Double-click in the Printer Name field to select the contents and type a
printer name.

Choose the view or list you want to print from the Report Type menu.

Click the arrows next to the Copies field to adjust the number of copies to be
printed or type the number.

Optional. Change the range of time to print in the From or To fields.

Optional. Add printer options in the Print Command Options field.

For example, to save paper, you may want to specify -o nobanner to
suppress header pages.

To print Calendar data to a file instead of to a printer, select Print to file.

Click again on this setting to deselect it.
Edit the file name, if desired.
Click Print.

Click Close to close the Print dialog box.

Browsing Calendars on a Network

If you know the names of other calendars on a network, you can use Calendar
to browse those calendars. A practical example is to set up a meeting or
appointment for several people. You can use Calendar to check for free times.

To browse other calendars and possibly to insert an appointment, you need:

The calendar names in the form calendar-name@hostname, such as
kent@dailyplanet

To add calendars to the Browse list

To determine if you have access to other calendars

Using Calendar 281



11

282

Note — Calendar doesn’t yet provide a way for you to look up other calendar
names. Call or talk to people and get them to tell you their
calendar-name@hostname information.

By default, Calendar allows the “world” (all users) to have browse permission.
Only the calendar owner has insert and delete permission. To change access
and permissions, see “Changing Access and Permissions” on page 290.

v To Add or Delete Calendars in the Browse List

To add:

1. Choose Menu Editor from the Browse menu.

2. Type calendar-name@hostname in the User Name field.

3. Click Add Name.

4. Click OK to add the calendar to the Browse list and close the dialog box.
To delete:

1. Select a calendar name in the Browse list.

2. Click Remove Name.

3. To delete the calendar from the Browse list and close the dialog box, click
OK.

To delete the calendar and leave the dialog box displayed, click Apply.

4. To erase your changes and leave the dialog box displayed, click Reset.

To erase your changes and close the dialog box, click Cancel.

v To Determine Whether You Have Access to Other Calendars

1. Choose Compare Calendars from the Browse menu.

2. Select one or more entries in the Browse list that you want to check for
access.

3. Click Schedule to open the Group Appointment Editor.
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4. Look at the Calendar Access list.

The Calendar Access list displays the calendar names that you selected in
the Compare Calendars dialog box.

A “Y” in the Access column means you have insert access. An “N” means
you don’t.

Note — To add appointments or To Do items to other calendars, ask the owners
to grant you insert access. To find out how to grant or deny access to your
calendar by others, see “Changing Access and Permissions” on page 290.

Scheduling Appointments on Other Calendars

Once you’ve browsed calendars for free times and have permission to insert
appointments on other calendars, you can schedule a group appointment.

Use the Group Appointment Editor to insert, change, or delete a group
appointment on your and other calendars. If you don’t have insert access to
other calendars, you can use the Group Appointment Editor to mail notices of
group appointments to other users.

v To Schedule a Group Appointment
1. Choose Compare Calendars from the Browse menu.
2. Click one or more entries in the Browse list.

Notice that the grid overlays calendars one on top of another and displays
busy times shaded darker and available times unshaded.

3. Click in an unshaded time block in the grid.

4. Click Schedule.

The Group Appointment Editor is displayed with the fields for date, time,
and mail automatically filled out.

5. Type (or edit) the group appointment start time in the Start field.

6. Type (or edit) the group appointment end time in the End field.
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10.

11.

In the What field, type the appointment description, such as its location or
purpose.

Click More.
Choose the repeat interval and duration for the group appointment.

Click Insert to add the group appointment to the selected calendars.

If you don’t have insert access on all the calendars, you can send mail to
notify others about the group appointment. See “To Mail Reminders to a
Group Using Calendar.”

Click Cancel to close the Group Appointment Editor.

v To Mail Reminders to a Group Using Calendar

Once you’ve set up a group appointment (date, start and end times,
description, repeat interval), you may want to mail the group a reminder. With
the group appointment displayed in the Group Appointment Editor:

1.
2.

Click More to display additional options.
Click Mail.

Calendar displays a Compose window containing an appointment
attachment. The appointment attachment is pre-addressed to the selected
users and automatically filled out with the date and appointment start and
end times.

Click Deliver in the Compose window.

Calendar mails the reminder to the selected users.

Recipients of a mail message with a calendar-formatted reminder can drag the
message from the mailer header window and drop it on their calendars to
automatically schedule the pre-formatted appointment.

v To Create an Appointment Message Using a Mail Program

1. Start Mailer (or your regular mail program).

2. Open a compose window or create a blank message.
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3. Add a section to the message that includes exactly the following format.
Replace <tab> with a tab character, <blank line> with a blank line, and
replace the italicized format information with actual data.

<tab>** Calendar Appointment **
<blank line>

<tab>Date:<tab> mm/ dd/ yy
<tab>Start:<tab> hh: mm am
<tab>End:<tab> hh: mm pm
<tab>What:<tab> description line 1

<tab><tab> description line 2

An example might be:

** Calendar Appointment **

Date: 11/22/94
Start: 10:00 am
End: 11:00 am
What: Staff meeting
Monet conference room

4. Insert any additional text into the mail message.
5. Address the message to the recipient and include the subject of the message.
6. Send the message.

For information about using Mailer, see Chapter 8, “Using Mailer.”
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v To Drag an Appointment from Another Application to Calendar

From Mailer or File Manager, and possibly other applications, you can drag an
appointment icon to Calendar to schedule it.

From Mailer

1.

In Mailer’s Message Header List, click the header containing the formatted
appointment.

Drag the header to Calendar and drop it.

The pointer changes to an icon representing the moving file.

Calendar schedules your appointment and prints a message in the message
area stating that the appointment was scheduled.

Display the Calendar view containing the day on which you scheduled the
appointment.

Double-click that day to open the Appointment Editor.

Verify that the appointment is scheduled for the correct day and time.

For more information on using Mailer, see Chapter 8, “Using Mailer.”

From File Manager

If you have a file containing a formatted appointment:

1.

In an open File Manager window, navigate to a folder containing a file with
a formatted appointment.

With both the formatted appointment and Calendar visible on your screen,
drag the formatted appointment file to Calendar and drop it.

Calendar schedules your appointment.

Double-click that day to open the Appointment Editor.

Verify that the appointment is scheduled for the correct day and time.

For more information about File Manager, see Chapter 5, “Managing Files with
File Manager.”
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v To Drag an Appointment from Calendar to Another Application

From Calendar, you can drag an appointment icon to Mailer to mail it to
someone or to File Manager to save it in your file system.

To Mailer

1. Use the Appointment Editor to create an appointment but don’t click Insert.

2. Start Mailer and choose New Message from the Compose menu.
Make sure both the Appointment Editor and Mailer’s Compose window are
visible on your screen.

3. Drag the Drag Appt icon from the Appointment Editor and drop it on
Mailer’s attachment list.
The pointer changes to an appointment icon representing the moving file.
Mailer displays your appointment as a text file in the attachment list.

4. Compose and address your mail message and send it.

For more information on using Mailer, see Chapter 8, “Using Mailer.”

To File Manager

1.
2.

Use the Appointment Editor to create an appointment but don’t click Insert.

In an open File Manager window, navigate to a folder where you want to
save the appointment in a file.

With both the File Manager window and Calendar Appointment Editor
visible on your screen, drag the Drag Appt icon from the Appointment
Editor and drop it on the File Manager window.

The appointment is saved in a text file in the folder where you dropped it.

For more information about File Manager, see Chapter 5, “Managing Files with
File Manager.”
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Customizing Calendar

Calendar provides Options dialog boxes to change the settings for all future
appointments. To change the settings for individual appointments, see “To Set
Appointment Options” on page 274.

v To Change Appointment Editor Defaults

1. Choose Options from the File menu.

The Calendar Options dialog box is displayed.
2. Choose Editor Defaults from the Category menu.
3. Optional. Change the default appointment duration in the Duration field.

4. Optional. Change the default appointment start time by choosing from the
Start menu.

5. Select Beep, Flash, Popup, or Mail reminders.

Beep Causes your system to emit an electronic beep
Flash Causes your calendar to flash

Popup Displays a reminder dialog box

Mail Sends electronic mail

6. Edit the default time intervals if necessary.

The time interval fields are active for each reminder you select. They specify
the time before an appointment that the reminder is activated.

7. Choose a privacy option from the Privacy menu.

Others See Time Only The default — displays only the time of an
appointment so others can see you’re busy

Others See Time and Text  Displays the time and text of an appointment
in your calendar

Show Nothing Displays nothing about an appointment in
your calendar for maximum privacy

8. Click Apply to apply the new defaults to all future appointments.

9. Click Cancel to close the Calendar Options dialog box.
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Changing the Display Settings
You can customize many parts of the Calendar display:

® Determine the initial calendar that displays
® Set time boundaries
® Set the default view

v To Set the Initial Calendar Displayed

You can set Calendar to display a calendar other than your own when you first
start it.

1. Choose Options from the File menu

The Calendar Options dialog box is displayed.
2. Choose Display Settings from the Category menu.

3. Double-click in the Initial Calendar View field and type
calendar-name@hostname for the calendar you want to view each time you
start Calendar.

4. Click Apply.

5. Click Cancel to close the Options dialog box.

v To Set the Time Boundaries on Day and Week Views

Time boundaries are the earliest and latest hours you want displayed in your
calendar.

1. Choose Options from the File menu.
2. Choose Display Settings from the Category menu.

3. Move the Begin and End sliders to adjust the earliest and latest hours you
want displayed on your calendar.

4. Select 12 Hour or 24 Hour time display.
5. Click Apply.

6. Click Cancel to close the Options dialog box.

Using Calendar 289



11

v To Set the Default Calendar View

Calendar displays the default Calendar view each time you start it. The initial
default view is by month. You may want to set the default to the view you use
most often, such as Week view.

1. Choose Options from the File menu.

2. Choose Display Settings from the Category menu.

3. Select Day, Week, Month, or Year from the Default View options.
4. Click Apply.

5. Click Cancel to close the Options dialog box.

Changing Access and Permissions

You can set access to your calendar, controlling what others can do in your
calendar. To determine whether you have access to other calendars, see “To
Determine Whether You Have Access to Other Calendars” on page 282.

v To Grant Access to Your Calendar
1. Choose Options from the File menu.
2. Choose Access List and Permissions from the Category menu.

The Access List and Permissions dialog box is displayed.

Note — Depending on the version of your calendar, your Access List and
Permissions dialog box may look different than the one pictured in Figure 11-1.
If so, go to Figure 11-2 on page 292 and follow the instructions after that figure.
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Figure 11-1 Access List and Permissions dialog box — Version 1

3. In the User Name field, type username@hostname for the user to whom you

want to grant access. To grant access to everyone, type world in the User

Name field.

The default permission is for browse access only.

4. Select Browse, Insert, and/or Delete permissions.

Browse The default — enables others to see information in your
calendar

Insert Others can add appointments or To Do items to your
calendar

Delete Others can delete appointments or To Do items from

your calendar

5. Click Add Name to add username or world to the Access list with the

permissions you’ve chosen.

Note - Individual user access overrides world access; if everyone (world) has
browse access only and user X has browse and insert access, user X can browse

and insert entries in the current calendar.
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6.

To grant the selected access and close the dialog box, click OK.

To grant the selected access and leave the dialog box displayed, click Apply.
To erase your changes and leave the dialog box displayed, click Reset.

To erase your changes and close the dialog box, click Cancel.

Note — If your Access List and Permissions dialog box resembles Figure 11-2
below, follow the instructions after the figure.
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Figure 11-2 Access List and Permissions dialog box — Version 2

1.

In the User Name field, type username@hostname for the user to whom you
want to grant access. To grant access to everyone, type world in the User
Name field.

The default permission is for view access to public appointments only.

Select View, Insert, or Change permissions and Public, Semiprivate, or
Private access rights.

Permissions control whether others can perform specific operations on your
calendar. You can choose more than one permission.

Access rights control the specific types of appointments others can perform
operations on.
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Public Enables another user to display the time and
text of your appointments marked Others See
Time and Text

Semiprivate Enables another user to display the time and
text of your appointments marked Others See
Time Only

Private Enables another user to display the time and
text of your appointments marked Others See
Nothing

3. Click Add to add username or world to the Access list with the permissions
and access rights you’ve chosen.

Note — Individual user access overrides world access; if everyone (world) has
browse access only, and user X has browse and insert access, user X can browse
and insert entries in the current calendar.

4. To grant the selected access and permissions and close the dialog box, click
OK.

To grant the selected access and permissions and leave the dialog box
displayed, click Apply..

To erase your changes and leave the dialog box displayed, click Reset.

To erase your changes and close the dialog box, click Cancel.

To Deny Access to Your Calendar

1. Choose Options from the File menu.

2. Choose Access List and Permissions from the Category menu.

3. Select the user to whom you want to deny access in the Access list.

4. Click Remove Name (Calendar data version 3, Figure 11-1) or Delete
(Calendar data version 4, Figure 11-2) to remove the user from the Access
list.
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To remove access for the specified user and close the dialog box, click OK.

To remove access for the specified users and leave the dialog box displayed,
click Apply.

To erase your changes and leave the dialog box displayed, click Reset.

To erase your changes and close the dialog box, click Cancel.

v To Change the Printer Settings for Future Print Jobs

To print a Calendar view or appointment or To Do list using the default printer
settings, see “To Print Current Day, Week, Month, or Year Views” on page 280.
To change the printer settings for future print jobs:

1.

Choose Options from the File menu.

The Options dialog box is displayed.

Choose Printer Settings from the Category menu.

The Printer Settings dialog box is displayed.
Select Printer or File.
Type the name of your default printer.

Edit the Options field to specify print command-line options, if any.

For example, to save paper, you may want to specify -o nobanner to
suppress header pages.

Edit the page dimensions or position, if necessary.

Edit the number of units, if desired.

For example, if you are printing Week view and you set Units to 2, you will
print the current week and the next week.

Edit the number of copies if you want more than one.

Choose the desired privacy option for the information you want printed.

See Step 7 of “To Change Appointment Editor Defaults” on page 288 for
privacy options.
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10.

To save your changes and close the dialog box, click OK.

To save your changes and leave the dialog box displayed, click Apply.
To erase your changes and leave the dialog box displayed, click Reset.

To erase your changes and close the dialog box, click Cancel.

v To Change the Date Format

1.
2.

Choose Options from the File menu.

Choose Date Format from the Category menu.
The default date format in Calendar is MM/DD/YY.

Choose the desired date order option.
Choose the desired date separator.

To save your changes and close the dialog box, click OK.

To save your changes and leave the dialog box displayed, click Apply.
To erase your changes and leave the dialog box displayed, click Reset.

To erase your changes and close the dialog box, click Cancel.

v To Change the Default Time Zone

You can set Calendar to view your or another calendar’s appointments in a
time zone other than your local one.

1.
2.
3.

Choose Time Zone from the View menu.
Choose the Custom Time setting.

In the Hours field, edit the number of hours before or after Greenwich Mean
Time that you want your calendar set to.

For example, to synchronize your calendar for Pacific Standard Time, choose
GMT+8 hours. For Finland, choose GMT-2 hours. For Japan, choose GMT-9
hours. You may have to adjust by one hour for daylight, or summer, time.

To revert to your own time zone, click the My Time setting in the Time Zone
dialog box.
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5. Click OK to apply changes and close the dialog box.

Other Calendar Tools

Calendar includes several command-line interface tools:

sdtcm_admin - Use to create and administer calendars
sdtcm_convert - Use to convert data format or prune a calendar
dtcm_editor - Use to edit appointments

dtcm_lookup - Use to view calendar appointments

dtcm_insert - Use to insert calendar appointments

dtcm_delete - Use to delete calendar appointments

sdtcm_admin

Use sdtcm_admin from the command line to create and administer calendars.
This tool can be used to add or remove a calendar on a local system or
remotely on a host on the network. Use sdtcm_admin to list calendars that
exist on a host, or to grant and revoke access to users to a specific calendar.
Options to sdtcm_admin include:

-l Lists calendars on your system in a single

column

-h Lists calendars on other hosts

-a Adds a new calendar to a system (by default,
<login>@<localhost>)

-C Add a named calendar to a system

-d Delete a calendar from a system (by default,
removes )

See the sdtcm_admin(1) man page for more details and examples of the
other options.

Examples

To list calendars on your system:

% sdtcm_admin -I
kasso
vacation
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test
foobar
sleepy

To list calendars on another host:

% sdtcm_admin -l -h totoro
ytso

root

test

sportv4

To add a calendar with your login name to the host you are logged in to:

% sdtcm_admin -a

By default the -a option will create the calendar <login>@<localhost>. Other
calendars can be created on the host by using the -c option.

To create the calendar buildschedule on the local host, aha:

% sdtcm_admin -a -c buildschedule@aha

To create the calendar sleepy on the remote host totoro

% sdtcm_admin -a -c sleepy@totoro

To remove the calendar with your login name from the host you are logged in
to:

% sdtcm_admin -d

By default the -d option will remove the calendar <login>@<localhost>. For

example, if kasso is logged into aha and runs sdtcm_admin -d with no
other options, the following response will be displayed:

Delete the calendar kasso@aha [y/n]?
Respond y or n.

To remove the calendar old on the host aha:
% sdtcm_admin -d -c old@aha
You can only remove calendars for which you have Owner privileges. If you

attempt to remove a calendar that you do not own, you will see an error
message:

Delete the calendar old@aha [y/n]? y
sdtcm_admin: Could not delete calendar because: Permission denied.
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sdtcm_convert

Use sdtcm_convert to convert Calendar data format, prune a calendar, or
check data integrity. Use it to convert version 3 (OpenWindows) calendar data
format to version 4 (the extensible calendar data format), and vice versa.

sdtcm_convert  must be run by superuser or the owner of the calendar.
Superuser can run sdtcm_convert  on any calendar; a regular user can only
run sdtcm_convert  on his or her own calendar. Note that sdtcm_convert
can be used only on calendars located on the local host.

The version 3 data format is fixed and limited. In order to take advantage of
the new features supported by the calendar API, version 3 calendars should be
converted to the version 4 data format.

Note — OpenWindows Calendar Manager does not support the version 4 data
format. If you need to switch back to OpenWindows Calendar Manager and
you have a version 4 calendar, you should convert your calendar to the version
3 data format before switching the server. Be aware, however, that data not
supported in the version 3 data format (for example, all calendar attributes
except the access list, entry attributes such as date of creation or date of last
update, and so on) will be lost.

Options for sdtcm_convert  are listed and described below.

® Use the -v option to specify the data version of output.

Valid values are 3 (OpenWindows calendar data format) and 4 (the
extensible data format). If this option is not specified, the output data
version is the same as that of the specified calendar and no data conversion
is done.

Note — The data version of a calendar is displayed in the About Calendar
dialog box of Calendar, accessible from the Help menu.

® Use the -s option to specify the date to prune the calendar.

Appointments starting before the specified date are pruned. One-time
appointments with a start date on or after the specified date are included.
Repeating appointments are truncated such that the first appointment in the
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sequence will happen on or after the specified date and those sequences that
end before the specified date are removed. If this option is not specified, no
appointments are pruned.

® Use the -c option to specify the value for the character set attribute.

The value should be a valid Sun-specific locale name (Cor de, for example).
The CDE platform-independent equivalent of the locale name is stored in
the calendar. If this option is not specified, the CDE platform-independent
name of the current locale associated with the process is used. This option is
used when converting version 3 data to version 4 data and is ignored
otherwise.

® Use the -d option to specify the directory in which to save the original
calendar file which is saved in a filed called calorig.calendar

If this option is not specified, the backup file is placed in the

Ivar/spool/calendar directory.
See the sdtcm_convert(1) man page for more details and examples of
usage.

Examples

To convert the calendar userl to version 4 data format and also prune the
calendar:

% sdtcm_convert -v 4 -s 1/1/94 userl

To check data integrity of the calendar userl :
% sdtcm_convert userl

If no option is specified, sdtcm_convert  will check the calendar file for data
integrity.
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dtcm_editor

Use the standalone Appointment Editor to create a Calendar-formatted
appointment and save it in a file.

1. Type dtcm_editor  filename at the command line.

The standalone Appointment Editor is displayed.

—| Calendar Appointment

Date: [/4/1996

Start: |7 9:00 @00 — | [ AM _JPM
End: ¥ 9:30 @30 — | [ AM _JPM

What: I

Freguency

Cccurs: Cne Time | a"|

Za

Feast: | £ Drag Appt

- Save Reset

2. Type a date in the Date field.

Remember to use the date format set in the Date Format dialog box.
Choose the Start and End times for the appointment.
Type a description of the appointment in the What field.

Choose a frequency for the appointment from the Occurs menu.

o o ~ w

Click Save to write the appointment contents to the file you specified on the
command line.
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dtcm_lookup
Use dtcm_lookup  to view appointments on your calendar.

1. Type dtcm_lookup at the command line to view appointments for the
default view.

For example, if Day view is the default, to view appointments for the
current day:

system% dtcm_lookup
Appointments for Monday October 31, 1994:
1) Halloween
2) 2:30pm-3:30pm Staff meeting
3) 6:00pm Trick-or-treating
4) 7:15pm-10:00pm Choir practice
2. To choose the calendar, date, or range of time for which to look up
appointments, use the following syntax:
dtcm_lookup [-c calendar] [-d date] [-v view]

For example:
system% dtcm_lookup -c hamilton@artist -d 10/28/94 -v day
Appointments for Friday October 28, 1994:

1) 9:00am-10:00am Project meeting

2) 1:30pm-2:00pm Testing

dtcm_insert

Use dtcm_insert  from the command line to insert appointments on your
calendar. For example:

system% dtcm_insert -d 11/1/94 -s 11:30am -e 12:30pm -w workout
Appointments for Tuesday November 1, 1994:

1) 10:00am-11:00am one-on-one

2) 11:30am-12:30pm workout

3) 12:30pm-1:00pm eat lunch

Calendar automatically prints the appointments scheduled so you can see that
the new appointment was inserted.
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dtcm_delete

Use dtcm_delete  from the command line to delete appointments from your
calendar. For example:

system% dtcm_delete -d 11/1/94
Appointments for Tuesday November 1, 1994:
1) 10:00am-11:00am one-on-one
2) 11:30am-12:30pm workout
3) 12:30:pm-1:00pm eat lunch
Item to delete (number)? 3
Appointments for Tuesday November 1, 1994:
1) 10:00am-11:00am one-on-one
2) 11:30am-12:30pm workout

When you don’t want to delete any more items, press Return.

Using Federated Naming with Calendar

302

If your site uses Federated Naming Service (FNS), calendar naming can be
location independent: you can name a calendar without including its host
machine. For example, to name the calendar of user jsmith  without FNS, you
need to enter jsmith @hostmachine; with FNS you can enter jsmith  alone.

The default behavior of Calendar is unchanged; you can name calendars using
the form username@hostname. To use the new way of naming calendars, you
need to set the resource useFNS. You can turn this resource on either manually
by editing your .desksetdefaults file or through the Display Settings dialog
box. (Choose Options from the File menu and Display Settings from the
Category options menu in the Options dialog box. Click the Calendar Names:
Use Federated Naming checkbox and then click OK.)

Calendar Naming

When the useFNS feature is on, you can use both the old and new ways of
naming calendars. When you choose Show Other Calendar from the Browse
menu, you can enter simply rosanna to browse user rosanna 's calendar. Or
you could enter rosanna@alto  to name the calendar directly. The new names
can be entered wherever a calendar name is expected (Show Other Calendar,
Initial Calendar View in Display Settings Options, Browse list editor, Browse
short list, and so on).
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For location-independent naming to work, there must be a name space that
holds registered information about where the calendars are.

Calendar Registration

When you run Calendar with useFNS set on, Calendar will automatically
attempt to register your calendar into the name space. Once it has been
registered, someone can use just your username to browse your calendar. If
you subsequently move your calendar, change the User Calendar Location in
theDisplay Settings dialog box and the registered calendar address in the name
space will automatically be updated the next time you restart Calendar. You

can also update the information in the name space outside Calendar using the
FNS command, fnbind

In an NIS environment, auto-registration is not supported because NIS does
not support dynamic updates of arbitrary data. In addition, fnbind only
succeeds when run by root on the NIS master.

Naming Service Dependencies

In Solaris 2.5, FNS works with NIS+ only.

Build Dependencies

For CDE developers that build dtcm, you need to have the appropriate FNS
package installed on the build machine. For a Solaris 2.5 or earlier target, you
need to have the Solaris 2.5 SUNWfns package. These packages can be picked
up from the OSNet gates (/ws/on297-gate/packages, for example) or from
the packages directory of a specific Solaris release.

Runtime Dependencies
If dtcm cannot locate the appropriate SUNWfns package at runtime, it will

simply not use FNS. Calendar can always run on a system without the
SUNWIfns package.
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Using Terminal
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A terminal emulator displays a window that enables you to enter operating

system commands, use UNIX commands, and copy and paste text.

Default Desktop Terminal Emulator 306
Starting a Terminal Window 306
To Close a Terminal Window 309
Using a Terminal Window 310
Running dtterm on Another System 311
Customizing dtterm 313
dtterm Global Options 314
dtterm Terminal Options 319
Terminal Control Characters 324
Changing the Default Terminal Emulator 325

Note - Illlustrations shown in this chapter were taken from the default CDE
screens. Your screens may be different from the illustrations if you or your

system administrator have customized them.
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Default Desktop Terminal Emulator

The default terminal emulator on the desktop is dtterm . The dtterm
terminal emulator emulates that portion of the VT220 terminal that is
consistent with ANSI and 1SO standards.

The dtterm command-line prompt is a special character that is displayed in
the left margin of your terminal emulator. It can be a %", ~'<*, ~'$”, or

another special character. A small box or bar, called a cursor, shows where
characters will appear in the window when you type something on the

keyboard.
~| dtterm | m |J
Window Edit Options Help
51 =

Starting a Terminal Window

There are several ways you can start a Terminal window:

From the Front Panel

From Application Manager

From File Manager

From the Window menu

From an existing Terminal window
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v To Start a Terminal Window from the Front Panel

1. Click the arrow above the Text Editor control (or the control that appears as
the second one to the left of the workspace switches) in the Front Panel

2. Click the Terminal control in the Personal Applications subpanel.

Persamal Applications

&l |m Lf

£
]

R Y —
e Bl LS asd

The default Terminal window appears.

v To Start a Terminal Window from Application Manager

1. Click the Desktop_Apps control on the Front Panel.

Applications
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2. Double-click the Terminal icon (you may have to scroll down to see it).

3 Application Manager - Deskiop_Apps E '|_| |
File Selected View ﬂﬂn
1 Hidden

v To Start a Terminal Window from File Manager

1. Click the File Manager control on the Front Panel.

8 (@) <

The File Manager window appears.
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2. Choose Open Terminal from the File Manager File menu.

File selected View Help
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Open Terminal pOd-1380-10
Open Floppy _‘I
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Close Alt+F4)
1|
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| =
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v To Start a Terminal Window from the Window Menu

¢ Choose New from the Window menu of an existing Terminal window.

An exact replica of the Terminal window appears.

v To Close a Terminal Window
¢ Type exit at the command line and press Return.
Or, choose Exit from the Terminal Window menu.

Or, choose Close from the Window menu (displayed through the button at
the upper left of the window frame).

Note — Typing exit at the command line is the preferred method of closing a
Terminal window. The other two methods don’t terminate any background
processes you may have started, which can sometimes cause problems.

If you started the Terminal window from a command line, you can stop it by
pressing Control+C in the window from which you started it.

Using Terminal 309



=12

Using a Terminal Window

The Terminal window provides a means to start other applications, enter UNIX
commands, and copy and paste text between and within windows.

v To Start Applications in a Terminal Window
+ Type the command to start the application at the command-line prompt.

The general syntax for starting an application is:
application [ options] &

application The application name
options A list of optional information to be passed to the application
& Indicates that the application runs in the background; that is,

you can continue to use the Terminal window while the
application is also running

Refer to the man page or other documentation for each application to find the
command and options to use for that application.

For example, to start a digital clock from the command line, type:
xclock -digital &

v To Enter a Command
¢ Type the command and press Return.

For example, to obtain a list of the files in the current directory, type:

Is

To obtain a list of the files in the current directory and print it on the default
printer, type:

Is|lp

v To Copy and Paste Text

1. Use mouse button 1 and drag over the text you want to move.

The text appears highlighted.
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2. Release mouse button 1 after all the text you want is highlighted.

The highlighted text is copied to an internal clipboard. The text is not
removed from your original source.

3. Click mouse button 2 where you want to insert the text.

A copy of the contents of the clipboard is pasted at the location you
indicated. You can make additional copies by repeating the above steps.

v To Resize the Window Contents

When you change the size of a Terminal window, applications running in the
window may not know about the resizing. Use this procedure to resize the
application’s output.

+ To resize the window contents, type the following at the command-line
prompt:

eval ‘resize’

Note that resize is enclosed within a set of single close quotation marks rather
than double quotation marks.

Running dtterm on Another System

You can run dtterm on another system through various commands:

® The -display  option
® The rlogin command
® The remsh command

Using the -display Option
-display host:display[.screen]

where

host The name of a valid system on the network.

display The number of the display on the host.

screen Optional. The screen within the display. The default is 0.
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Using rlogin

Using remsh

You can find these values by typing env, and examining the DISPLAY line.
The terminal emulator is running on your system, but the window shows on
another system.

For example, the following command starts a dtterm window on the host
computer named hpcvxdm:

dtterm -display hpcvxdm:0 &

You can use rlogin  in an existing Terminal window to log in to a remote host.
Once the window is acting as a terminal to the remote host, you can run
applications there, redirecting the display back to your system if you desire.

For example, the following command logs onto a system named there , runs
the client xload , and redirects the display back to your original system.
Assume your system is named here .

rlogin there
xload -display here:0

The remsh command starts a shell on a remote host, performs some client
activity (often starting a terminal emulator on that host), and redirects the
display back to your original system if desired.

It has the syntax:

remsh remote -n client -display system: display[. screen]

where:

remote The remote host name

client The program you want to run on the remote host

system:display[.screen] The host and display on which the results are to be
displayed

The remsh command is often used when customizing a menu to access other
hosts.

For example, the following command runs xload on the remote host named
there , and directs output back to your system, here .
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remsh there -n /usr/bin/X11/xload -display here:0.0 &

Customizing dtterm
There are several ways in which you can customize dtterm
® Run it with special options, such as the menu bar and scroll bar
® Run the terminal emulator on another system
® Change global options such as cursor style and background color

® Change terminal options such as keyboard and screen control

Displaying the Menu Bar

By default, dtterm appears with a menu bar. You can remove it if you wish.

v To Remove the Menu Bar

¢ Choose Menu Bar from the Options menu.

The menu bar disappears from the dtterm window.

v To Restore the Menu Bar

1. Click mouse button 3 anywhere within the dtterm window.

A pop-up menu appears containing items identical to those of the menu bar.

dinerm

M
Sorell Bar

R

Irraral
Wb Bazs
Foal Sin
Tt
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2. Choose Menu Bar from the Options menu.

The menu bar appears at the top of the dtterm window.

Displaying the Scroll Bar

By default, dtterm appears without a scroll bar.

v To Display the Scroll Bar

¢ Choose Scroll Bar from the Options menu.

The scroll bar appears in the dtterm window.

To remove the scroll bar from the window, choose Scroll Bar from the
Options menu again.

dtterm Global Options

There are four areas that you can control from the Global Options dialog box:

Cursor control
Color control
Scroll behavior
Bell control

+ To display the Global Options dialog box, choose Global from the Options
menu.
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Cursor Control

You can control three aspects of the dtterm cursor: the cursor style, whether
the cursor blinks, and the blink rate.

To Determine Cursor Style

1. If the Global Options dialog box is not displayed, choose Global from the
Options menu.

2. Click the Cursor Style button and choose the cursor style option you want:

* Box (the default)
* Underline
« None (the cursor is invisible)
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3. Click OK at the bottom of the Global Options dialog box or press Return to
save your selection and exit the window.

To save your selection and retain the window, click Apply.

The changes you make will be visible on existing dtterm windows; you don’t
have to start a new one.

To Determine Cursor Blinking

The dtterm cursor blinks by default. You can turn off the blinking or change
the blink rate (see “To Set the Cursor Blink Rate”).

1. If the Global Options dialog box is not displayed, choose Global from the
Options menu.

2. Click the Blinking Cursor button in the Cursor Control section and choose
to either have the cursor blink (Enabled) or not blink (Disabled).

3. Click OK at the bottom of the Global Options dialog box or press Return to
save your selection and exit the window.

To save your selection and retain the window, click Apply.

Note that when this option is set to Disabled, the Blink Rate option and text
field are both inactive.

To Set the Cursor Blink Rate

The blink rate determines how often the dtterm window’s cursor blinks. The
default blink rate is 250 milliseconds. To change the cursor blink rate:

1. If the Global Options dialog box is not displayed, choose Global from the
Options menu.

2. In the Blink Rate text field, type the value in milliseconds that you want.

3. Click OK at the bottom of the Global Options dialog box or press Return to
save your selection and exit the window.

To save your selection and retain the window, click Apply.

The changes you make will be visible on existing dtterm windows; you don’t
have to start a new one.
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v To Switch Foreground and Background Colors (Color Control)

1. If the Global Options dialog box is not displayed, choose Global from the
Options menu.

2. Click the Window Background button in the Color Control section and
choose the color display you want:

« Normal displays the foreground and background colors normally.
« Inverse switches the foreground and background colors.

3. Click OK at the bottom of the Global Options dialog box or press Return to
save your selection and exit the window.

To save your selection and retain the window, click Apply.

v To Determine Scroll Behavior

Smooth scrolling displays each line sent to the Terminal window immediately,
rather than storing it in a buffer. This results in scrolling that is more pleasing
to the eye, but is slower. The default is smooth scrolling disabled. To enable
smooth scrolling:

1. If the Global Options dialog box is not displayed, choose Global from the
Options menu.

2. Click the Smooth Scrolling button and choose the type of scrolling you
want:

« Disabled (the default) disables smooth scrolling.
* Enabled starts smooth scrolling.

3. Click OK at the bottom of the Global Options dialog box or press Return to
save your selection and exit the window.

To save your selection and retain the window, click Apply.

Bell Control

There are three types of Bell Control options in dtterm

® Bell type
® Margin warning
® Margin distance
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v To Set the Bell Type

1. If the Global Options dialog box is not displayed, choose Global from the
Options menu.

2. Click the Bell Type button in the Bell Control section and choose the type of
bell you want:

e Audible (the default) causes the bell to make a sound.
« Visible causes the bell to blink the background color.

3. Click OK at the bottom of the Global Options dialog box or press Return to
save your selection and exit the window.

To save your selection and retain the window, click Apply.

To Set the Margin Warning

The Margin Warning option is used in conjunction with the Margin Distance
option to warn the user either visually or aurally that the cursor is within a
specified distance from the right margin. To set the margin warning:

1. If the Global Options dialog box is not displayed, choose Global from the
Options menu.

2. Click the Margin Warning button in the Bell Control section.
3. Choose Enabled or Disabled.

4. Click OK at the bottom of the Global Options dialog box or press Return to
save your selection and exit the window.

To save your selection and retain the window, click Apply.

Note that the Margin Distance option (see “To Set the Margin Distance”) is
inactive when Margin Warning is disabled.

To Set the Margin Distance

The Margin Distance option is only active when the Margin Warning option is
set to Enabled. You set the distance from the right margin of the dtterm
window at which you want the bell to ring (or appear, if Bell Type is set to
Visible). The default value is 10 characters.

To change the distance:
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1. If the Global Options dialog box is not displayed, choose Global from the
Options menu.

2. Click inside the Margin Distance text field in the Bell Control area and type
the number of characters from the right margin of the window at which you
want the margin warning to be issued.

3. Click OK at the bottom of the Global Options dialog box or press Return to
save your selection and exit the window.

To save your selection and retain the window, click Apply.

The changes you make will be visible on existing dtterm windows; you don’t
have to start a new one.

dtterm Terminal Options

There are two areas that you can control from the Terminal Options dialog box:

® Keyboard control
® Screen control

+ To display the Terminal Options dialog box, choose Terminal from the
Options menu.
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Changes you make through the Terminal Options dialog box are effective on
existing dtterm  windows; you don’t have to start a new one.

Keyboard Control

You can control four aspects of your keyboard through the Terminal Options

dialog box:

Cursor key mode
Keypad mode
Newline sequence
User function keys
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To Set the Cursor Key Mode

1. If the Terminal Options dialog box is not displayed, choose Terminal from

the Options menu.

2. Click the Cursor Key Mode button in the Keyboard Control section and

choose the mode you want:
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* In Normal mode (the default), the cursor keys move the cursor in the
specified direction.

« In Application mode, the cursor keys generate escape sequences that the
application uses for its own purpose.

Click OK at the bottom of the Terminal Options dialog box or press Return
to save your selection and exit the window.

To save your selection and retain the window, click Apply.

To Set the Keypad Mode

The keypad mode determines the behavior of keys on the numeric keypad.

1.

If the Terminal Options dialog box is not displayed, choose Terminal from
the Options menu.

Click the Keypad Mode button in the Keyboard Control section and choose
the mode you want:

¢ In Numeric mode, when keys on the numeric keypad are pressed, the
corresponding numeral is displayed in the dtterm  window.

« In Application mode, keys pressed on the numeric keypad generate
escape sequences that the application uses for its own purpose.

Click OK at the bottom of the Terminal Options dialog box or press Return
to save your selection and exit the window.

To save your selection and retain the window, click Apply.

To Determine the Newline Sequence

The Newline Sequence option determines how carriage returns at the ends of
lines are treated.

1.

If the Terminal Options dialog box is not displayed, choose Terminal from
the Options menu.

Click the Newline Sequence button in the Keyboard Control section and
choose the mode you want:

* Return Only (the default) generates only a carriage return.

» Return/Line Feed generates both a carriage return and a line feed.
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3. Click OK at the bottom of the Terminal Options dialog box or press Return
to save your selection and exit the window.

To save your selection and retain the window, click Apply.

To Set the User Function Keys

The User Function Keys option either locks or unlocks (the default) the user
function keys.

1. If the Terminal Options dialog box is not displayed, choose Terminal from
the Options menu.

2. Click the User Function Keys button in the Keyboard Control section and
choose Locked or Unlocked (the default).

3. Click OK at the bottom of the Terminal Options dialog box or press Return
to save your selection and exit the window.

To save your selection and retain the window, click Apply.

Screen Control

There are three aspects of screen control in a dtterm  window:

® 132 column switching
® End-of-line wrapping
® Reverse end-of-line-wrapping

To Set 132-Column Switching

This option corresponds to the following dtterm command-line options and
resources:

* -132
* +132
® 132

1. If the Terminal Options dialog box is not displayed, choose Terminal from
the Options menu.

2. Click the 132 Column Switching button in the Keyboard Control section and
choose the mode you want:
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» Disabled (the default) does not change the display when an application
switches to 132 columns.

< Enabled automatically enlarges the dtterm window to display 132
columns when the application switches to 132 columns.

3. Click OK at the bottom of the Terminal Options dialog box or press Return
to save your selection and exit the window.

To save your selection and retain the window, click Apply.

To Set End-of-Line Wrapping

This option determines whether text wraps at the end of a line. It corresponds
to the following dtterm command-line options and resources:

® -aw

®* +aw
® autoWrap

1. If the Terminal Options dialog box is not displayed, choose Terminal from
the Options menu.

2. Click the End-of-Line Wrapping button in the Keyboard Control section and
choose the mode you want:

« Enabled means characters automatically wrap to the next line when the
end-of-line is reached.

« Disabled means text does not wrap.

3. Click OK at the bottom of the Terminal Options dialog box or press Return
to save your selection and exit the window.

To save your selection and retain the window, click Apply.

To Set Reverse End-of-Line Wrapping

This option determines the behavior of backspacing at the end of a line. It
corresponds to the following dtterm command-line options and resources:

® -rw
® +rw
® reverseWrap
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1. If the Terminal Options dialog box is not displayed, choose Terminal from

the Options menu.

2. Click the Reverse End-of-Line Wrapping button in the Keyboard Control
section and choose the mode you want:

« Enabled means backspace characters automatically wrap to the next
higher line when the end-of-line is reached.

» Disabled (the default) means no wrapping occurs.

3. Click OK at the bottom of the Terminal Options dialog box or press Return
to save your selection and exit the window.

To save your selection and retain the window, click Apply.

Terminal Control Characters

324

Because dtterm only emulates a terminal, your control characters might not
be what you are used to on a physical terminal. The ttyModes resource
enables you to set control characters for your terminal emulator.

By default, Login Manager sets the control characters listed in Table 12-1.

Table 12-1 Terminal Control Characters

Control Name Character

Definition

erase Control+H
intr Control+C
kill Control+U
start Control+Q
stop Control+S
switch Control+@

Backspace erases characters

Interrupt: Cancel the current operation and redisplay
the command-line prompt.

Stop an operation or application.

Accept keyboard input: Used to continue an application
that has been paused.

Do not accept keyboard input: Used to pause an
application.

Switch between layers in a shell.

For example, to interrupt an operation in progress, you press Control+C.

The syntax for the ttyModes resource is:

ttyModes: Control +C name
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where name is the control, and C is the character. (™ is another way of

expressing Control.) For example, the default value of ttyModes describing
the preceding list is:

ttyModes: erase ~H intr ~C kill U start *Q stop S swtch *@

v To Set Terminal Control Characters

1. Use the EditResources action to update the ttyModes resource.

2. Choose Restart Workspace Manager from the Workspace menu.

Changing the Default Terminal Emulator

There are several other terminal emulators you can use in addition to dtterm
You can start most of them from an existing terminal emulator command line;
however, if you want to consistently use a terminal emulator other than
dtterm , you should change the default assignment. See Solaris Common

Desktop Environment: Advanced User’s and System Administrator’s Guide for more
information.
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Using Icon Editor 13

Icon Editor is a tool for creating both bitmap and pixmap image files for use as
icons or backdrops.

Basic Drawing Tasks 329
Saving Icon Files 333
Color Usage 335
Advanced Drawing Tasks 336

Icon Editor enables you to create and edit images in two formats, described in
Table 13-1.

Table 13-1 lcon Formats

Format Description File Name

X pixmap (XPM) Multicolor images that include static and *.pm
dynamic colors

X bitmap (XBM) Two-color images limited to a foreground and *.bm
background color (used for black and white
icons)
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Figure 13-1 Icon Editor main window

You create images by selecting drawing tools and colors, and using them in the
work area. As you draw, Icon Editor displays an actual-size copy of your icon
in both formats. You need to consider the two-color version of the icon even if
you are drawing an image for use on color systems, because icons may revert
to two colors if there are not enough free colors available on the workspace.

For information on designing icons, read the Visual Design chapter in Common
Desktop Environment: Style Guide and Certification Checklist.

Startup
To start Icon Editor:

¢ Open the Personal Applications subpanel and click the Icon Editor control.
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Basic Drawing Tasks
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Icon Editor starts with an empty drawing work area.

You can also start Icon Editor and have it load an icon into the work area in
one of the following ways:

®* In a File Manager view, locate the icon file and double-click it to open it.
(The default action for pixmap and bitmap files runs Icon Editor and loads
the file.)

® Drop an icon file on the Icon Editor control in the Personal Applications
subpanel.

® Click the Application Manager control in the Front Panel, then open
Desktop_Apps and double-click Icon Editor.

* Type the following command in a Terminal window:

dticon -f filename &
Note - If the path /usr/dt/bin has not been set in your .cshrc  file, then
type /usr/dt/bin/dticon to run Icon Editor from the command line.

This section describes how to create and edit an icon and how to use the Icon
Editor drawing tools.
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v To Open an Existing Icon

1.

Choose Open from the File menu.

If you have unsaved changes, Icon Editor warns you that your changes will
be lost by loading another icon. Click Cancel to cancel the Open command.
Click OK if you don’t want to save your changes.

Type the name of the file you want to load in the Enter file name field, or
select the icon file you want to load from the Files section of the Open File
dialog box.

Click Save.

Note — When you load a file, the Output Format (in the Options menu) is
automatically set to the format of the file you load.

You can also open an existing icon by double-clicking the icon file in File
Manager.

v To Start a New Icon

¢

Choose New from the File menu.

If you have unsaved changes, Icon Editor warns you that your changes will
be lost by starting a new icon. Click Cancel to cancel the New command or
click OK if you don’t want to save your changes.

Icon Editor clears the work area and resizes it to the default size (32x32).

If you have an icon already loaded, you can choose Clear Icon from the Edit
menu to start a new icon with the same size and name as the previously loaded
icon.

CDE User’s Guide—February 1997



13

v To Clear an Icon

v

1. Save your current icon, if necessary.
2. Choose Clear Icon from the Edit menu.

The entire icon drawing work area is cleared.

To Draw an Image
1. Select one of the drawing tools (listed in Table 13-2 on page 332).
2. Select a color (static color, static gray, or a dynamic color).

3. Begin drawing with the tool you've selected.

More details on drawing with each tool are provided below.

Drawing Tools

The drawing tools area of Icon Editor is shown in Figure 13-2.

Currently selected tool —— Pencil
Pencil | 2 Jﬁ — Flood
Line . | #|||—— Open Polygon
Rectangle [ 1] 57| —— closed Polygon
Circle {1 <]l —— Ellipse
feeole |
Eraser -.._! ' ——— Selection

Fill Solids check box | Fl-ll Zolids

Figure 13-2 lIcon Editor drawing tools
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Table 13-2 Using the Drawing Tools

Tool Purpose Action
Pencil For drawing freehand lines  Press and hold to draw freehand
and individual pixels. lines.
Line For drawing straight lines.  Press and hold to stretch the line.
Release to draw the line.
Rectangle For drawing solid or Press and hold to stretch the outline

outlined rectangles.

Circle For drawing solid or
outlined circles.

Eraser For erasing large areas of
the image.

Flood For flooding a region of
one color with the selected
color.

Open Polygon For drawing connected
straight lines.

Closed Polygon For drawing connected
straight lines, where the
first line and last line are
connected to form a closed

polygon.

Ellipse For drawing solid or
outlined ovals.

of the rectangle. Release to draw the
rectangle.

Point to where you want the center of
the circle, press and hold, drag to the
desired size, and release.

Press and hold; then drag over the
area to erase.

To erase individual pixels, select the
Pencil tool and the Transparent color.

Click any pixel within the region to
be flooded. The selected pixel and all
adjacent pixels of the same color are
recolored with the selected color. The
filled region extends in all directions,
bounded only by pixels of a different
color.

Click the starting point; then click for
each segment.
Double-click to end the last segment.

Click the starting point; then click for
each segment.
Double-click to end the last segment.

Press and hold, drag to the desired
size and shape, and release.
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Table 13-2 Using the Drawing Tools (Continued)

Tool Purpose Action

Selection For selecting an area to Point to the corner pixel of the region
work on. Several to be selected, press and hold, drag to
commands in the Edit the desired region, and release.
menu require an area to be
selected.

Fill Solids For changing the rectangle, Select the check box to automatically
circle, ellipse, and closed draw filled-in shapes. Deselect the
polygon tools to draw check box to return the tools to
filled-in shapes instead of  drawing outlines.
outlines.

v To Undo a Drawing Operation

Saving Icon Files

¢ Choose Undo from the Edit menu.

Only the single, most recent change can be undone.

When saving icon files, you must use the appropriate file-name suffix. There
are two suffixes appended to the base name of the icon, one for size and one
for format. Many icon names are in these general forms:

basename.size.format
basename.format

The basename is the image name used to reference the image.

size is a single letter indicating the standard size of the icon: | for large (48x48
pixels), mfor medium (32x32), s for small (24x24), or t for tiny (16x16). (See
“Icon Size Conventions” on page 334.) If your icon is not a standard size, you
can omit this letter.

format is pmfor X pixmaps (the color icon format) or bmfor X bitmaps (the
monochrome icon format).

If you save an icon in XBM format that has transparent color in it, an icon mask
file is also saved. The icon mask file is named basename.size_mformat. If you
move the icon you saved to another folder, you must also move the mask file.
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For example, suppose you specify an icon named mail for a file type you've
written. If you have a color display and have set the File Manager preferences
to use tiny icons, the assumed icon name is mail.t.pom . If it had transparent
color and you saved it in XBM format, two files would be created: mail.t.om
and mail.t_m.bm

Icon Size Conventions

Table 13-3 lists the recommended sizes—in pixels, width x height—for creating
new icons for use in CDE. Icons can be up to 256x256.

Table 13-3 Icon Size Recommendations

Usage High Medium Low

File Manager (Large) 32x32 32x32 32x32
File Manager (Small) 16x16 16x16 16x16
Application Manager (Large) 32x32 32x32 32x32
Application Manager (Small) 16x16 16x16 16x16
Front Panel 48x48 48x48 32x32
Front Panel subpanels 32x32 32x32 16x16
Minimized windows 48x48 48x48 32x32
Workspace 32x32 32x32 32x32

v To Save the Icon

1. Choose an output format from the Options menu:

* XBM for two-color X bitmap format
e XPM for multicolor X pixmap format (the default)

2. Choose Save from the File menu.

If the icon is unnamed or you choose Save As, Icon Editor prompts you for
a file name. Type the name and then click Save.

Note - If you save an icon in XBM format that has transparent color in it, an
icon mask file is also saved. The icon mask file is named
basename.size_mformat. If you move the icon you saved to another folder, you
must also move the mask file.
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v To Save the Icon with a New Name

Color Usage

1. Choose Save As from the File menu.
2. Type (or select) the file name under which you want to save the icon file.

3. Click Save.

If the file already exists, you will need to click OK in the warning dialog box
to overwrite the existing file.

Icons in the desktop use a palette of 22 colors:
® Eight static grays
® Eight static colors: red, blue, green, cyan, magenta, yellow, black, and white

® Five dynamic colors: Foreground, Background, TopShadow, BottomShadow,
and Select

® A transparent “color” that allows the background to show through

These colors are the default colors in Icon Editor. This set of colors provides a
reasonable palette with which to create icons. This limited palette was chosen
to maximize the attractiveness and readability of icons without using an
unnecessary humber of colors.

The dynamic colors represent the colors used to display the application on
which your icon will appear. If your icon appears in File Manager, File
Manager determines what the background color is. Dynamic colors are useful
for icons that you want to change color as different color palettes are selected
in Style Manager. Dynamic colors are also useful if the icon will be used in
more than one place and you want it to use the colors of the application where
it appears.

TopShadow and BottomShadow can be used for drawing a shadow under your
icon. You can use these colors to make the icon appear to be etched into the
surface. This is only recommended for Front Panel style icons.

The transparent color is useful for creating icons that have the illusion of being
nonrectangular, since it allows the color behind the icon to show through. If
your icon does not fill the entire bounding box, you should fill the unused area
with the transparent color.
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Advanced Drawing Tasks

After you become familiar with the basic drawing facilities in Icon Editor, you
may want to try some more advanced operations. Many of these operations
require you to first select an area of the icon. This is done using the Selection
tool (next to the eraser).

When an area of the icon is selected, you can:

Cut, copy or move it

Resize (scale) it

Flip it (horizontally or vertically)
Rotate it (right or left)

v To Select an Area of the Icon
1. Click the Selection tool (next to the eraser).

2. Drag a box around the area you want to select.

When an area is selected, a box flashes around the selected area.

v To Cut a Region of the Icon
1. Select the area of the icon you want to cut using the Selection tool.
2. Choose Cut from the Edit menu.

When you cut a portion of an icon, the exposed area becomes transparent (that
is, filled in with the Transparent color).

Note that after cutting a region, you can paste it back into the icon by choosing
Paste from the Edit menu.

v To Copy a Region of the Icon
1. Select the area of the icon you want to copy using the Selection tool.
2. Choose Copy from the Edit menu.
3. Choose Paste from the Edit menu.

4. Position the outline where you want to paste the copy, and then click.
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You may repeat steps 3 and 4 as many times as you like to paste multiple
copies of the region you copied.

v To Move a Region of the Icon
1. Select the area of the icon you want to move using the Selection tool.
2. Choose Cut from the Edit menu.
3. Choose Paste from the Edit menu.
4. Position the outline where you want to paste the area, and then click.

You may repeat steps 3 and 4 as many times as you like to paste multiple
copies of the region you cut.

v To Rotate Part of the Icon
1. Select the area of the icon you want to rotate using the Selection tool.

2. Choose Rotate then Left or Rotate then Right from the Edit menu.

3. Position the outline where you want to paste the rotated area, and then
click.
v To Flip (Mirror) Part of the Icon

Flipping an area creates a pixel-for-pixel mirror image of the selected area.
1. Select the area of the icon you want to flip using the Selection tool.

2. Choose Flip then Vertical or Flip then Horizontal from the Edit menu.
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Resizing Icons

You can resize the entire icon or a region of the icon.

v To Resize the Current Icon

1. Choose Resize Icon from the Edit menu.

Icon Editor displays a dialog box that prompts for the new size.
2. Edit the current width and height to specify the new size.
3. Click OK.

Note — If you make the icon smaller, the right and bottom edges are clipped
off. If you make the icon larger, the existing image remains in the upper left of
the icon.

v To Resize (Scale) a Region of the Icon
1. Select the area of the icon you want to resize using the Selection tool.
2. Choose Scale from the Edit menu.

3. Drag a box that defines the size and shape that you want the scaled image to
be.

The size of the box is shown in the upper right area. This determines how
the selected portion of the image will be scaled; it does not determine where
to place the results.

4. Position the outline where you want to paste the scaled copy, and then click.

Hotspots

Bitmap images (XBM format) can be used as special mouse pointer shapes. A
hotspot marks a single pixel within the image that is the true point of the
mouse pointer.
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v To Add a Hotspot
You can only have one hotspot in an icon.
1. Choose Add Hotspot from the Edit menu.

2. Click the pixel where you want the hotspot.

v To Delete a Hotspot

¢ Choose Delete Hotspot from the Edit menu.

Screen Captures

You can copy any area from any part of the screen into the Icon Editor. You
can copy (“grab”) a text or graphic that is displayed and load it into the Icon
Editor work area.

v To Capture (Grab) a Region of the Display
1. Save your current icon, if necessary.
2. Choose Grab Screen Image from the Edit menu.

3. Drag a box around the portion of the workspace you want to capture (press
mouse button 1, drag, and release).

Note — Capturing a region of the display could cause the icon to use up some
of the available colors on the desktop.
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Modifying the View of an Icon

You can change the view of an icon in the Icon Editor work area by changing
the magnification or using a grid.

v To Hide the Grid

4 Choose Visible Grid from the Options menu.

This will hide the grid. Choose Visible Grid from the Options menu again
to display the grid. The grid is displayed by default.

v To Change the Magnification of an Icon
1. Choose Magnification from the Options menu.

2. Choose the Magnification level you want from the submenu.
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Use Image Viewer to view, edit, print, and translate the file formats of
monochrome and color images and multiple page documents such as
PostScript files. Use the Snapshot function of Image Viewer to capture
snapshots of windows, user-defined regions, or the entire desktop screen.

Starting and Quitting Image Viewer 342
Viewing Images 343
Editing Images 345
Saving Images 350
Viewing PostScript Files 351
Printing 355
Image Viewer File Formats 358
Using Snapshot 359
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Starting and Quitting Image Viewer

There are several ways to start Image Viewer:

®* From the Workspace Programs menu
® From the Front Panel
® From the command line

v To Start Image Viewer from the Workspace Programs Menu

1. Place the mouse pointer anywhere on the background of the desktop (the
workspace) and click mouse button 3.

The Workspace menu appears.

2. Choose Programs, and then choose Image Viewer from the Programs
submenu.

The Image Viewer main window appears.

v To Start Image Viewer from the Front Panel

+ If Image Viewer has been installed in the Front Panel (either directly in the
Front Panel or in the Personal Applications subpanel), click the Image
Viewer icon to start the application.

=

1

~ZP

Image b
Figure 14-1 Image Viewer icon

To install Image Viewer in the Front Panel, see “To Put an Application Icon in
the Front Panel” on page 148 for instructions.

v To Start Image Viewer from the Command Line
You can start Image Viewer and open files directly from the command line.

¢ Type sdtimage to start Image Viewer.
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Or, type sdtimage filename to start Image Viewer and open a specific file.

v To Exit Image Viewer

¢ Choose Exit from the File menu.

Viewing Images

With Image Viewer, you can view, edit, print, and translate the file formats of
monochrome and color images and PostScript files. See “Image Viewer File
Formats” on page 358 for a list of the file formats that Image Viewer can open.
See “Viewing PostScript Files” on page 351 to learn how to view PostScript files.

v To Open an Image File
1. Choose Open from the File menu.
The Open dialog box appears.

2. To navigate among and display the contents of folders, double-click a folder
in the Folders list.

3. Select an image file from the Files list or type its name in the Enter file name
field.

4. Click OK to open the image file.

The image file is displayed in the View window.

v To Open an Image File Using Drag and Drop

+ If Image Viewer is already running, drop an image file icon on an open
Image Viewer window.

If Image Viewer is not running:
1. Drag an image file icon from File Manager and drop it on the workspace.

2. Click mouse button 3 over the image file icon on the workspace and choose
Open from the Workspace Object menu.

Image Viewer starts and the image file is displayed in Image Viewer’s View
window.
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3. To remove the icon from the Workspace when you are finished with it, click
mouse button 3 on the icon and select Remove From Workspace from the
pop-up menu.

v To View an Image in Gray Scale or Color
To determine whether images appear in gray scale or color:
1. Choose Options from the File menu.
2. Select either Gray Scale or Color for the View Image In setting.

3. If you chose to display images in color, set the Color option to the number
of colors you want used.

The Color setting depends on the type of display monitor you have. For
example, if only one option, such as 256, appears, that is the only option
available on your monitor.

4. Click OK to activate the settings and close the dialog box. Click Apply to
activate the setting and leave the dialog box displayed.

v To Move the Image within the View Window
1. Choose Palette from the Edit menu if the palette is not displayed.

2. Click the Pan tool in the palette.

See “Using the Palette Tools” on page 346 for information on the palette.

3. Move the pointer into the View window, over the image or page.

The pointer changes to a hand shape.
4. Drag the pointer in the direction you want to move the image or page.

5. Click the Pan tool to deselect it.

v To Change an Image Orientation in the View Window

To rotate the displayed image in 90-degree increments (mimics landscape or
portrait orientation):

1. Choose Page Viewing Controls from the View menu.
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2. Select a percentage by which you want the image rotated (90°, 180°, or 270°).
3. Select whether you want the image rotated Right or Left.

4. Click OK to rotate the image and close the dialog box, or Apply to rotate the

image and leave the dialog box displayed.

v To Display Information about an Image

Editing Images

¢ Choose Image Info from the View menu.

The Image Information dialog box appears.

Imass Vidwer — |rsas Afarmatian
Helght 1.0 in F 37 % & & 963 gin
Widthe B.S1n f 208 m J 708 pig

Colges WA

Flle Siz= 6.9 KEyied
Fll& Farmat PostScri ot

LS8 Halp

Figure 14-2 Image Information dialog box

The dialog box displays the following information about the image:

Height of the page in inches, centimeters, and pixels
Width of the page in inches, centimeters, and pixels
Number of colors used in the file

Size of the file in Kbytes

Format of the file

You can use Image Viewer to manipulate images in many ways:

® Select a region to save
® Rotate, flip, or scale the image
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Using the Palette Tools

The Palette dialog box provides tools that enable you to manipulate images.

—| Image \Wiewer — Palette
Rotate tools ——
— 1 3 & °
Pan tool — |\‘§ g +’.:" a0y
Selector tool —— a0
LI L
Scale tool ____|
\\
£ i M0 & %
_ e w?‘!" v
Flip tools -]
~1 % 100
=l
Reuert| Close | Help |

Figure 14-3 Palette dialog box

® Pan tool — Use to move the contents of the View window
® Selector tool — Use to select a region to be saved as a new image

® Rotate tool — Use to rotate the contents of the View window to the right or
left

® Flip tool — Use to flip the image horizontally or vertically

® Scale tool — Use to size the image

v To Display the Palette Automatically

You normally display the Image Viewer Palette by choosing Palette from the
Edit menu. However, you can also automatically display the palette whenever
you open a document:

1. Choose Options from the File menu.
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v To Select a

2.
3.

Select Display Palette On Opening Document.
Click OK or Apply.

Region to Save as a New File

You can cut out a region of an image or page and save that region as a new file.

1.
2.
3.

Select Palette from the Edit menu if the palette is not displayed.
Click the Selector tool in the palette.
Move the pointer into the View window.

Place the target pointer over a corner of the region you want to save as a
new image and drag mouse button 1 to the opposite corner.

Image Viewer draws a border around the region you define.

Choose Save Selection As from the File menu.

The Save Selection As dialog box appears.

Select the file format in which you want your file written.

For a list of the formats, see “Image Viewer File Formats” on page 358.

Optional. Choose a compression method from the Compression menu
button.

The default is None (no compression); compressed files require less disk
space.

Optional. Choose the number of colors to save for your file from the Colors
menu button.

The choices depend on the type of monitor you have.
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9. Click OK.

v To Rotate an Image

1. Select Palette from the Edit menu if the palette is not displayed.

Rotate = = '
clockwise i ‘; il A0 y —

Use to set
Rotate / degree of rotation
counter- 90 /
clockwise | 1

2. Specify the number of degrees you want the image or page rotated.

The default value is 90 degrees; change the value in one of the following
ways:

* Double-click in the Rotate Degrees field and type the number
* Click the arrow buttons
e Drag the slider

3. Click one of the rotate tools to rotate the image or page left or right.

Image Viewer rotates the image or page according to the value in the Rotate
Degrees field.

4. To restore the image to its last-saved orientation, click Revert.

v To Flip an Image
1. Select Palette from the Edit menu if the palette is not displayed.

2. Click one of the flip tools to invert or create a mirror image of the currently
displayed image or page.
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3. To restore the image to its last-saved orientation, click Revert.

v To Scale an Image
To enlarge or reduce an image proportionally:

1. Select Palette from the Edit menu if the palette is not displayed.

Click to scale qo0 A& %
the image to the g v e
percentage value Use to set the scale
ercentage value
100 P
] ~

2. Specify the scale percentage.

The default value is 100%; change the value in one of the following ways:

* Double-click in the Scale Percentage field and type the number
 Click the arrow buttons
« Drag the slider

3. Click the Scale tool.

Image Viewer scales the image according to the value in the Scale
Percentage field.

4. To restore the image to its last-saved size, click Revert.

v To Undo an Edit Operation

Image Viewer provides two methods for cancelling an unsaved edit operation:
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v To Save an

v To Save an

Choose Undo from the Edit menu to cancel the last unsaved edit made to an
image or page.

Or, click the Revert button on the palette to cancel all unsaved changes and
display the last saved version of the image or page.

You can save changes you make to an image or page in the same file you
opened, or to a new file. Saving to a new file enables you to save to a different
format or name.

Edited Image in the Same File

1.

Choose Save from the File menu.

The Save dialog box appears.

Click OK.

A dialog box is displayed, asking you if you want to overwrite the existing
file.

Click Overwrite Existing File to save the changes in the existing file.

Click Cancel if you do not want to overwrite the existing file. Change the
file name or change folders in the Save dialog box to save the changes to a
new file.

Image as a New File

To save a file and specify its format, folder, and name:

1.
2.
3.

Choose Save As from the File menu.
Double-click a folder name in the Folder list to open it.
Type the name of the file in the Enter file name field.

Select the file format in which you want your file written.

For a list of the formats, see “Image Viewer File Formats” on page 358.
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5. Choose a compression method from the Compression menu button.

The default is None (no compression); compressed files require less disk
space.

6. Choose the number of colors to save for your file from the Colors menu
button.

The choices depend on the type of monitor you have.

7. Click OK.

Image Viewer saves your file in the specified format.

Viewing PostScript Files

With Image Viewer you can view and manipulate PostScript files as well as
image files. (See “Viewing Images” on page 343 to learn how to view image files.)

v To Open a PostScript File from the File Menu
1. Choose Open from the File menu.

2. To navigate among and display the contents of folders, choose a folder from
the Folders list.

3. Choose a PostScript file from the Files list or type the PostScript file name in
the Enter file name field.

4. Click OK to open the PostScript file.

The PostScript file is displayed in Image Viewer’s View window.

v To Open a PostScript File Using Drag and Drop

+ If Image Viewer is already running, drop a PostScript file icon on an open
Image Viewer window.

If Image Viewer is not running:

1. Drag a PostScript file icon from File Manager and drop it on the Workspace.
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2. Press or click mouse button 3 over the PostScript file icon on the workspace
and choose Open from the Workspace Object menu.

Image Viewer is started up and the PostScript file is displayed in Image
Viewer’s View window.

3. To remove the icon from the Workspace when you are finished with it, click
mouse button 3 on the icon and select Remove From Workspace from the
popup menu.

v To View a PostScript File in Black and White or Color
1. Choose Options from the File menu.
2. Select either Black & White or Color for the Display PostScript setting.
3. Click OK or Apply.

v To Page through a PostScript File

+ Use the Page slider or the arrow buttons.

mMmags Vieear — tEps

) S = ™ Help

Fags 2 - -

Using your keyboard, you can view:

® The first page by pressing Home

®* The next page by pressing PgDn or Return

® The previous page by pressing PgUp, Back Space, or Del[ete]
® The last page by pressing End

v To View a Specific Page of a PostScript File

1. Choose Page Overview from the View menu.

The Page Overview window uses thumbnail page buttons to show simple
renderings of the pages in a document. Up to 16 thumbnail page buttons are
displayed in a set. Clicking the scroll bar displays up to 12 new thumbnail
page buttons.
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Note - If the Page Overview menu item is unavailable, Image Viewer is
loading the information for the Page Overview dialog box. For a long
document, this may take a while.

2. Determine the page you want to view.
* Double-click the thumbnail page button.
« Or, type the page number in the text field and click Display Page.

v To Reverse Page Order

The page order of a document is often reversed when the file is prepared for
printing; this is a convenient way to collate a document on printers that produce
pages printed side up. To reverse the page order of a document you are viewing:

1. Choose Page Viewing Controls from the View menu.

The Page Viewing Controls dialog box appears.

2. Select the order in which you want the pages of the current document
displayed (First Page First or Last Page First).

3. Click OK to apply your choices and close the dialog box.

v To Change the Size of the Displayed Page

The page description language used to create some documents may not include
page size information. This can cause page boundaries to display incorrectly. To
change the displayed page size:
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1.

2.
3.

Choose Page Viewing Controls from the View menu.
The Page Viewing Controls dialog box appears.
Select the size of the page you want for displaying the current document.

Click OK to apply your choices and close the dialog box.

See “Print Dialog Box” on page 355 for information on changing the size of
the printed page.

v To Save a PostScript Page as a Bitmap Image

1.

Choose Save Page As Image from the File menu.

The Save Page As Image dialog box appears.

Select the file you want to save.

If you do not specify a file, Image Viewer saves the page currently displayed
in the View window.

You can filter the Files list by typing a file-name condition in the Filter field
and clicking Update. For example, typing *.ps will list only the files ending
in .ps in the Files list.

Select the format in which you want to save the page from the File Format
list.

See Table 14-1 on page 358 for a list of file formats in which Image Viewer
can save an image.

Optional. Set a compression type through the Compression button menu.

Optional. Choose the number of colors for the image from the Colors button
menu.

The default is 256.

Type the name under which you want to save the file in the Enter file name
field.

Click OK.
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Printing

You can print an image or PostScript file in Image Viewer and set parameters
for image position, orientation, and size, plus the more standard print settings
such as page size and number of copies.

Print Dialog Box
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Figure 14-4 Print dialog box

The dialog box settings are:

Copies Increase or decrease the number of copies to
print.

Using Image Viewer 355



14

Header Page

Printer

Page Size

Page Range

Image Size

Image Orientation

Image Position

v To Print an Image or PostScript File

Choose whether to print a header page.

Select the printer on which to print your image
from a list of printers.

Select from a list of standard page sizes. This
value should correspond with the size of the
paper in your printer.

Choose whether to print the entire document
or one page.

If Page Range is This Page (As Image), you can
choose whether to scale the image.

Choose between Portrait, which prints an
image vertically on the page, and Landscape,
which prints it horizontally.

Choose between Centered (default), which
prints the image in the center of the page, and
Margins, which uses the entered values for the
top and left margins. The button labeled “in”
or “cm” controls whether margin values are in
inches or centimeters.

1. Choose Print from the File menu.

The Print dialog box appears.

2. Determine your print parameters.

See “Print Dialog Box” on page 355 for a description of the dialog box

settings.

3. Click Print.

v To Preview a File to Be Printed

To see how the contents of the View window will appear when printed with the
current Print dialog box settings:
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1. Choose Print Preview from the File menu.

The Print Preview dialog box appears.

If the image is too big to fit on a single page, lines in the Print Preview
window show you the boundaries of the printed page.

2. To control which area of the image or page is printed, move the pointer into
the window (it changes to a hand shape) and use mouse button 1 to drag
the image into position.

3. To print the image, click Print, and then click Print in the Print dialog box
that is displayed.

See “Print Dialog Box” on page 355 for information about print settings.

4. Click Close to close the Print Preview dialog box.

v To Print a Single Copy
To print a single copy of the image or multiple-page document you are viewing:

¢ Choose Print One from the File menu.

Image Viewer prints one copy of the file, using the current Print dialog box
settings.

See “Print Dialog Box” on page 355 for information about Print settings. .
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Image Viewer File Formats

358

You may want to identify the specific format, or file type, of the file you want to
open. Image Viewer can open files in the formats listed in Table 14-1, which you

can specify by choosing Open As from the File menu.

Table 14-1 Image Viewer Open File Formats

Andrew Toolkit

Atari Compressed Spectrum*
Atari Degas 1*

Atari Degas 3*

Atari Uncompressed Spectrum*
AutoCAD Slide

Benet Yee Face File

CMU Window Manager
Encapsulated PostScript (EPSF)
FITS

GEM

GIF

Gould Scanner

Group 3 FAX

HIPS

HP Paintlet

IFF ILBM

Img-Whatnot

JFIF (JPEG)

Kodak Photo CD (4Base)
Kodak Photo CD (Base)
Kodak Photo CD (Base/16)

Kodak Photo CD (Base/4)
Lisp Machine Bit-Array
MGR

MTV/PRT Ray-Tracer
MacPaint

PBM

PC PaintBrush

PGM

PICT

PPM

PostScript

QRT Ray-Tracer

Sun lcon

Sun Raster

TIFF

TrueVision Targa
Usenix FaceSaver

X Bitmap

X11 Window Dump (XWD)
XPM

Xerox Doodle Brush

Xim

*SPARC only.
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Image Viewer can save files in the formats listed below:

Encapsulated PostScript (EPSF)  GIF

JFIF (JPEG) PostScript
Sun Raster TIFF
XPM

Using Snapshot

Snapshot takes a “snapshot” of a window, of a region of the desktop, or of the
entire desktop screen. You can then view, save, or edit the snapshot in Image
Viewer.

v To Start Image Viewer Snapshot

¢ Choose Snapshot from the Image Viewer File menu

Or, start Image Viewer with the -snapshot option:

sdtimage -snapshot

~| Image Wiewer — Snapshot

Shap Tvpe: [ Window ) Region ) Screen

Snap Delaw: I /| Seconds

et Duireivves e tedienoor
Jangiy LAV LN

_| Hide ‘Window During Capture

Snap | Cancel | Help |

Figure 14-5 Snapshot window
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v To Take a Snapshot of a Window

1. If Snapshot is not running, choose Snapshot from the Image Viewer File
menu.

2. Select Window as the Snap Type.
3. Click the Snap button.
The mouse pointer becomes a plus sign.

4. Move the mouse pointer to the window to be snapped and click mouse
button 1.

The message at the bottom of the Snapshot dialog box reads “Snap
succeeded” once the window is snapped.

v To Take a Snapshot of a Region

1. If Snapshot is not running, choose Snapshot from the Image Viewer File
menu.

2. Select Region as the Snap Type.
3. Click the Snap button.
The mouse pointer becomes a plus sign.

4. Move the mouse pointer to a corner of the region to be snapped, press and
hold mouse button 1, drag the mouse diagonally to encompass the region to
be snapped, and release mouse button 1.

The message at the bottom of the window reads “Snap succeeded” once the
region is snapped.

v To Take a Snapshot of the Screen

1. If Snapshot is not running, choose Snapshot from the Image Viewer File
menu.

2. Select Screen as the Snap Type.
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3.

Click the Snap button.

The message at the bottom of the window reads “Snap succeeded” once the
screen is snapped.

v To Take a Delayed Snapshot

When taking a snapshot of a menu or some other pop-up or pull-down element,
you can delay the time between clicking Snap and the snapshot being taken.

1.

If Snapshot is not running, choose Snapshot from the Image Viewer File
menu.

Determine the number of seconds to delay by using the down arrow button
and selecting a value or by typing in the text field.

The next time you click Snap, the snapshot will be delayed by the specified
number of seconds.

Optional. If you want to hear the seconds counted off before the snapshot is
taken, select Beep During Countdown.

Select a Snap Type and click Snap.

If Snap Type is Region, drag mouse button 1 to select the region to be
snapped.

Make any necessary adjustments to the image during the snap delay time.

You can display a menu, for instance, by clicking on an item in a menu bar.

After the specified number of seconds, the window, region, or screen is
snapped and “Snap succeeded” is displayed in the message area at the
bottom of the window.

v To Hide the Snapshot Dialog Box While Taking a Snapshot

If you want a snapshot of the entire screen and do not want the Snapshot dialog
box to be included in the image, you can hide the Snapshot dialog box while you
take a snapshot.

1.

If Snapshot is not running, choose Snapshot from the Image Viewer File
menu.
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2. Select the Hide Window During Capture check box.

The Snap Delay changes to 8 seconds and the message area at the bottom of
the Snapshot dialog box displays “Timer adjusted to guarantee correct
operation.”

3. Click Snap to take the snapshot.

All Image Viewer windows disappear and do not reappear until after the
snapshot has been taken.

v To Save a Snapshot

See “To Save an Image as a New File” on page 350 for instructions for saving a
captured snapshot image.
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Keyboard Shortcutsforthe
Desktop A

This appendix describes keyboard alternatives to using your mouse.

Menu Shortcuts 364
Moving the Keyboard Focus 365
Opening and Closing Windows 366
Online Help Keyboard Navigation 372

Keyboard shortcuts offer a way to accomplish desktop tasks such as moving
and selecting windows and controls, choosing menus, and navigating in
workspaces without the use of your mouse.

When you use the keyboard to navigate on the desktop, note that:
® The Alt key is the same as the Extend char key on some keyboards.
® Return is the same as Enter on some keyboards.

® In Style Manager, the Window Behavior setting must be Click In Window To
Make Active (this is the default).

For more information on the Window Behavior setting, refer to Chapter 7,
“Customizing the Desktop Environment.”

363
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Menu Shortcuts

Menu items that appear dimmed are unavailable. They are available only
under certain conditions.

An underlined character in a menu name or item is called a mnemonic. The
sequence of keys listed to the right of some menu items is called a shortcut key.

Mnemonics and shortcut keys provide quick keyboard access to menu items.
To choose an item from a pull-down menu using the menu’s mnemonics:
1. Hold down Alt and press the underlined letter in the menu’s name.

2. Press the underlined letter in the menu item’s name.

Keyboard Focus and the Highlight

364

Keyboard focus uses the highlight to show you which element of a window,
menu, or control will respond to your input. To activate a selected menu item
or control (such as a button), press the Spacebar.

In windows and dialog boxes, you can move the keyboard focus among tab
groups. A tab group is a collection of related controls, such as a set of buttons.

The OK, Cancel, and

ok | Cancel | Help | Help buttons are a tab

group

This portion of a dialog box shows the keyboard focus on the OK button.
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Moving the Keyboard Focus

To move the keyboard focus, as shown by the highlight:

® Within a window, dialog box, or the front panel

Press To Move To
Tab The next tab group
Shift+Tab The previous tab group

Down Arrow
Up Arrow
F10

The next control in the tab group
The previous control in a tab group

The window’s menu bar—use the arrow keys to display menus and

move among their items

Shift+F10

The selected object’s pop-up menu—use the arrow keys to move

among the menu’s items

Alt+Spacebar

The Window menu

® Within a workspace

Press

To Move To

Alt+Tab or Alt+Esc
Shift+Alt+Tab
Alt+Up Arrow
Alt+Down Arrow

Alt+F6

Shift+Alt+F6

The next window or icon

The previous window or icon

The bottom window in a stack of windows (bringing it forward)
The bottom of the window stack

The next window belonging to an application, or between the
Front Panel and a subpanel

The previous window belonging to an application, or between
the Front Panel and a subpanel

® Within a menu

Press

To Move To

Down Arrow

Up Arrow

The next menu item

The previous menu item

Keyboard Shortcuts for the Desktop
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Press the Spacebar to choose a selected item from within a menu.

Press Esc to dismiss a menu.

Opening and Closing Windows

This section describes how to do window-related activities through your
keyboard.

v To Open an Application Window

From the Front Panel:

1.
2.

Press Alt+Tab to move the keyboard focus to the Front Panel.

Press the arrow keys to move the highlight within the Front Panel and select
a control.

Press Return or the Spacebar to choose the control and open the
application’s window.

From Application Manager:

1.

Open the Application Manager window by choosing its Front Panel control
as described above.

Press the arrow keys to move the highlight to an application group icon
within the Application Manager window.

Press Return twice to open the application group.

Press the arrow keys to move the highlight to an application or action icon,
then press Return twice to start the application.

From a terminal emulator window:

1.

2.

Open a terminal emulator window by choosing its Front Panel control as
described above.

When the window opens, type the command that starts the application.

v To Close an Application Window

Closing a window removes it from all workspaces.
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i i Caution — Before closing an application window, save your work.

1. Press Alt+Tab to move the highlight to the window you want to close.

2. Press Alt+F4.

v To Select a Window or Icon

¢ Press Alt+Tab to move the highlight to the window or icon you want to
select.

When a window or icon is selected, its border changes color to show that it
is active and will receive input from the mouse or keyboard.

v To Turn a Window into an Icon (Minimize)

1. Press Alt+Tab to move the highlight to the window you want to minimize.
2. Press Alt+Spacebar to display the Window menu.

3. Choose the Minimize item:
« Press Down Arrow until you select Minimize, then press Return.
e Or, press N, the menu’s mnemonic for Minimize.

v To Restore a Window from an Icon
1. Press Alt+Tab to move the highlight to the icon you want to restore.
2. Press Alt+Spacebar to display the Window menu.

3. Press Down Arrow to choose Restore, then press Return.
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v To Move a Window or Window Icon

1.

5.

Press Alt+Tab to move the highlight to the window or icon you want to
move.

Press Alt+Spacebar to display the Window menu.
Press M, the menu’s mnemonic for Move.

Press the arrow keys to relocate the window or icon.

Hold down Control while you press an arrow key to speed up the
movement of the window or icon.

When you’ve moved the window or icon where you want it, press Return.

To cancel the move operation, press Esc.

v To Resize a Window

1.

5.

Press Alt+Tab to move the highlight to the window you want to resize.
Press Alt+Spacebar to display the Window menu.
Press S, the menu’s mnemonic for Size.

Press the arrow keys to stretch or shrink the window. An outline appears to
show you the window’s size.

Hold down Control while you press an arrow key to size the window faster.

When the outline shows the size you want, press Return.

To cancel the resize operation, press Esc.

v To Scroll a Window’s Contents

1. Press Alt+Tab to move the keyboard focus, as shown by the highlight, to the

window whose contents you want to scroll.

2. Press Tab to move to the window area you want to scroll.

3. Press the arrow keys, Prev and Next, or Page Up and Page Down.

Hold down Control while you press an arrow key to scroll faster.
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v To Select a List Item

Some windows and dialog boxes display lists from which you select options or
settings.

1.
2.

Press Tab to move the highlight to the list.
Press the arrow keys to move through the list.

To select more then one contiguous item in lists that allow you to do so,
press Shift+Down Arrow or Shift+Up Arrow.

Press Tab to move the highlight to the appropriate button (such as OK), then
press Return.

v To Display a Pull-down Menu

To display a pull-down menu from a window’s menu bar:

1.
2.

3.

Press Alt+Tab to move the highlight to the application window.

Press F10 to move the highlight to the name of the first menu in the menu
bar, then use the arrow keys to display menus and move among their items.

Press Return to choose a highlighted item.

To dismiss a menu without choosing an item, press Esc.

v To Use a Pop-up Menu

With the keyboard focus on the component whose pop-up menu you want to
display:

1.
2.

Press Shift+F10 to display the pop-up menu.

Choose a menu item:

* Press the Down Arrow key to move through the menu, highlight the item
you want, then press Return.

* Or, type the underlined letter in the menu item’s name (its mnemonic).

« Or, type the shortcut key, as listed to the right of the item’s name.
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v To Use the Window Menu

1.

Press Alt+Tab or Alt+Esc to move the keyboard focus, as shown by the
highlight, to the window or icon.

Press Alt+Spacebar to display the Window menu.

Press the key for the menu item’s mnemonic (the underlined character in the
item’s name).

To close the menu without choosing an item, press Esc.

v To Switch to Another Workspace

v To Rename

1.

a

Press Alt+Tab until you’ve placed the keyboard focus, as shown by the
highlight, on the Front Panel.

Press the arrow keys to move the highlight to the button for the workspace
you want to display.

Press Return or the Spacebar.

Workspace

Press Alt+Tab until you’ve placed the keyboard focus, as shown by the
highlight, on the Front Panel.

Press the arrow keys to move the highlight to the button for the workspace
you want to rename.

Press Shift+F10 to display the workspace button’s pop-up menu.

Press the Down Arrow key to select Rename, then press Return.

The button becomes a text field.
Edit the workspace’s name in the text field.

Once you’ve renamed the workspace, press Return.
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v To Move among Windows

To move to the next window or icon, press Alt+Tab or Alt+Esc.

To move to the previous window or icon, press Shift+Alt+Tab or Shift+Alt+Esc.

To shuffle through a stack of windows, press Alt+Up Arrow or Alt+Down
Arrow.

To move between the windows belonging to an application, or the Front Panel
and a subpanel, press Alt+F6 or Shift+Alt+F6.

v To Display a Window in Other Workspaces

1.

v To Choose a

Press Alt+Tab to move the keyboard focus, as shown by the highlight, to the
window you want to display in other workspaces.

Display the Window menu by pressing Alt+Spacebar.

Press the Down Arrow key to select Occupy Workspace, then press Return.
The Occupy Workspace dialog box appears.

Press Tab until the keyboard focus is in the Workspaces list.

Select the workspaces in which you want the window to appear:
* Press Down Arrow or Up Arrow to move through the list.

» To select more than one waorkspace, press Shift+Down Arrow or Shift+Up
Arrow.

Press Tab to move the keyboard focus to OK, then press Return or the
Spacebar.

Front Panel Control
Press Alt+Tab to move the keyboard focus to the Front Panel.

Press the arrow keys to move the highlight within the Front Panel and select
a control.

Press Return or the Spacebar to choose the control and open the
application’s window.
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v To Choose a Subpanel Control

1.
2.

Press Alt+Tab to move the keyboard focus to the Front Panel.

Press the arrow keys to move the highlight within the Front Panel to one of
the subpanel arrow controls, then press Return.

Press the arrow keys to move the highlight among the controls within the
subpanel, then press Return or the Spacebar to choose a selected control.

To close the subpanel without choosing a control, press Esc.

v To Move the Front Panel

1.

A won

5.

Press Alt+Tab to move the keyboard focus to the Front Panel.
Press Alt+Spacebar to display the Front Panel menu.
Press M, the menu’s mnemonic for Move.

Press the arrow keys to relocate the Front Panel.

Hold down Control while you press an arrow key to speed up the
movement of the Front Panel.

When you’ve moved the Front Panel to where you want it, press Return.

To cancel the move operation, press Esc.

Online Help Keyboard Navigation

Choose hyperlinks to display related information. Help topic hyperlinks
appear as:

¢ Underlined text
®* An open-cornered box surrounding a graphic

v To Get Help in Any Window

¢ Press F1 (or the Help key if your keyboard has one).
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v To Choose a Help Topic Hyperlink

1. If the help window does not already have the keyboard focus, press Alt+Tab
to move the highlight to the help window.

2. Press Tab and the arrow keys to move the highlight to the hyperlink you
want to choose, then press Return.

To return from a hyperlink to the previous topic:
¢ Press Control+B, the keyboard accelerator for Backtrack.

For more information about using Help, refer to Chapter 3, “Getting Help.”
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Running Localized Sessions B

You can customize the desktop user interface in many different languages.
Various elements such as screens, default languages, fonts, input (keyboard)
methods, and icons can be changed. In addition, the menus, online help, and
error messages can be localized and are available in multiple languages.

Default Language at Login 375
Logging In to a Language-Specific Session 376
Creating or Editing a Language-Specific File 376
Using a Language-Specific Terminal Emulator 377
Specifying Fonts 377
Changing Fonts 378
Choosing Your Input Method and Keyboard 379

Default Language atLogin

The messages and menus in the initial login window are displayed in the
default language. If the default language has not been set up, the messages and
menus are displayed using a generic “C” locale environment. You can change
the language from the Options menu in the login screen.
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Logging In to a Language-Specific Session

Logging in to a specific language through the desktop is easy. However, specific
hardware requirements such as keyboards and printers may be required to make
the localized session more usable. These requirements vary by language,
character set, and country. Software and fonts can further increase the effective
localization of your system. To log in to a language-specific session:

1. Use the Options menu in the login screen to select a language.

The list of languages includes all the supported languages.

2. Log in normally with your name and password.

Creating or Editing a Language-Specific File

376

v

You can create, edit, and print language-specific files. You can also give files
language-specific names. However, for system administration files that are
shared across a network, the file names should just contain ASCII characters.
Different systems on the network might be using different locales.

If you have logged in to the desktop in a specific language, all applications will
be invoked using that language. However, you can still invoke an application
with another language.

If you want to create a file with a different language, invoke a new instance of
Text Editor specifying your desired language.

To Create or Edit a Language-Specific File

1. In a Terminal window, set the LANG environment variable to the desired
language. For example, to set the locale to Japanese, you can type:

LANG=apanese_locale

where Japanese_locale sets the value of the LANG environment variable for
the Japanese character set. Refer to your specific platform to determine the
value for Japanese_locale.

2. In the same window, call Text Editor (dtpad ) under the desired language by
typing:
/usr/dt/bin/dtpad &
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To start Text Editor with the Japanese language directly, type:
[usr/dt/bin/dtpad -xnllanguage Japanese_locale

You can now enter Japanese characters if the locale-specific files have been
installed. You can also use the Text Editor session to edit a previously created
Japanese file.

See “To Specify Fonts from the Command Line” on page 378 for an example of
specifying a font set.

Using a Language-Specific Terminal Emulator

Specifying Fonts

The following example uses dtterm  and will start a Japanese terminal emulator.
It assumes that the default language is not Japanese, that you are using the Korn
shell, and that the locale-specific files have been installed.

¢ From a command line in a Korn shell Terminal window type:
LANG=apanese_locale dtterm

where Japanese_locale sets the value of the LANG environment variable for
the Japanese character set. Refer to your specific platform to determine the
value for Japanese_locale.

The user usually changes fonts using Style Manager, which in turn restarts
Workspace Manager, resetting the desktop fonts. You can also customize fonts
at the command line or in resource files. In an internationalized environment,
the user must specify fonts that are independent of the code set. This is
necessary because the specification can be used under various locales with
different code sets than the character set (charset) of the font. Therefore, all font
lists should be specified with a font set.

Font Specification

A font specification within a fontlist can be either an X Logical Function
Description (XLFD) name or an alias for the XLFD name. For example, the
following are valid font specifications for a 14-point font:

-dt-interface system-medium-r-normal-serif-*-*-*-*-p-*-js08859-1
Or, -*-r-*-14-*is08859-1
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Font Set Specification

Changing Fonts

The font set specification within a fontlist is a list of XLFD names or their aliases
(sometimes called a base name list). The names are separated by semi-colons,
and any blank space before or after the semicolon is ignored. Pattern-matching
(wildcard) characters can be specified to help shorten XLFD names.

A font set specification is determined by the locale that is running. For
example, the Japanese locale defines three fonts (character sets) necessary to
display all of its characters. The following example identifies the set of Mincho
fonts needed.
® Sample name list with character set:
-dt-interface system-medium-r-normal-serif-*-*-*-*-p-*-14;
-dt-mincho-medium-r-normal--14-*-*-m-*-jisx0201.1976-0;
-dt-mincho-medium-r-normal--28-*-*-*-m-*-jisx0208.1983-0:
® Sample single pattern name without character set:
-dt-*-medium-*-24-*-m-*:

The preceding two cases can be used with a Japanese locale as long as there are
fonts that match the base name list.

You can change the fonts of dtterm by using either of the following methods:

® Specifying fonts from the command line
® Specifying fonts within a resource file

v To Specify Fonts from the Command Line

To change the fonts for the menu from the command line, type:

dtterm -xrm "*fontList: fontset’

where fontset is a font set specification. A font set specification can be specified
by a full X Logical Font Description (XLFD) name list, a simple XLFD pattern,

or an alias name. Note that a font set specification is determined by the locale
that is running.

For example, to use a larger font except for the menu font, type:

dtterm -xrm "*fontList:-dt-interface user-medium-r-normal-[*-*-*-*:'

378
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To use a smaller font except for the menu font, type:

dtterm -xrm "*fontList:-dt-interface user-medium-r-normal-s*-*-*-*:'

These specifications will work for any locale.

v To Specify Fonts within a Resource File
For example, to change the fonts for the dtterm command in a resource file:

1. Edit the Dtterm resource file in the /usr/dt/app-defaults/ language
directory.

You can use either the class name (Dtterm ) or the application name
(dtterm ) for a resource file of Dtterm .

Also, setting the LANG environment variable alters the search path of
resource files to include the /usr/dt/app-defaults/ language directory,
where language is the locale name.

After setting the LANG environment variable, the search path for resource
files would include the following two folders:

lusr/dt/app-defaults/ language/Dtterm
[usr/dt/app-defaults/C/Dtterm

2. Insert the font set you want to use at the bottom of the file.
For example, to use a monospace font, put this line at the bottom of the file:
dtterm -fn -dt-interface user-medium-r-normal-*-*-*-*

3. Save the file.

Choosing Your Input Method and Keyboard

Each locale has a single default input method associated with it. If the user
does nothing, this default is selected. Because there may be many input
methods installed at any one time, the following sections explain how various
input methods are selected on behalf of the user.
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Using Input Method Modifiers

When there is more than one input method for a locale, use the
XmNinputMethod resource to identify the one you would like used. This is
done by specifying a modifier. The modifier must be of the following form,
where modifier is the name used to uniquely identify the input method:

inputMethod :@im= modifier

The modifier string specified in the XmNinputMethod resource is used to
choose which input method is used.

Alternatively, set the XMODIFIERS environment variable. The syntax is the
same as for the XmNinputMethod resource, but values are not. Values for
XMODIFIERS are vendor specific.

Specifying the Input Method Style

The input method style determines how pre-editing will occur. It is controlled
by the XmNpreeditType resource. The syntax, possible values, and default
value type of the XmNpreeditType resource are:

Syntax value[,value,....]
Possible values OverTheSpot, OffTheSpot, Root, None
Default value OverTheSpot, OffTheSpot, Root

The string list, separated by a comma, specifies the priority order for this
resource. The first value supported by the input method is used.

For more information, see the Solaris Common Desktop Environment: Advanced
User’s and System Administrator’s Guide.

Changing the X Keyboard Map at the Server

If the keymaps currently used by the X server do not match the physical
keyboard on the system, you can change them manually by using the xmodmap
command or a vendor keyboard mapping utility. For information on the
xmodmap command, type man xmodmap
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access privileges

action

action icon

action label

action name

active

Glossary

Permissions granted to a user or group of users to perform various operations
on a file or folder (directory). See permission.

A desktop construct that provides a method for running applications,
executing commands, and other activities such as printing, removing files, and
changing directories. Actions are defined in a database of configuration files.

An icon that represents an action in a File Manager or Application Manager
window, or in the workspace. An action icon is created by creating an empty
executable file with the same name as the action it represents.

The name displayed under the icon of an action. See action name.

The name associated with an action, which by default is displayed under the
icon for the action. See action label.

A window, window element, or icon that is currently affected by keyboard and
mouse input. Active windows are differentiated from other windows on the
workspace by a distinctive title-bar color or shade. An active window element
is indicated by a highlight or selection cursor.
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active window

address

alias

application

application group

application icon

Application Manager

application server

Apply

Appointment Editor

Appointment List

arrow button

arrow keys

382

A window that receives keyboard input.

An electronic mail location of a user.

An alternative name or names assigned to a program or to an electronic mail
address.

In electronic mail, an address for mailing to a group of users. An alias can be
created to send electronic mail to a small group of people or to many people.

See software application.

An Application Manager folder that holds a specific software application or set
of software applications.

See action icon.

A window containing objects representing the system actions available to you.

A host computer that provides access to a software application.

A choice that causes a selection (or group of selections) in a dialog box to take
effect.

In Calendar, a window you use to schedule, change, or delete an appointment.

A chronological list of appointments displayed by Calendar.

An element of a scroll bar used to scroll a window by small increments. Also, a
control in the Front Panel used to slide up or slide down a subpanel.

The four directional keys on a keyboard. Also see navigation keys.
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attachment

backdrop

background

Backtrack

base name

bitmap

busy light

button

Calculator

Calendar

Calendar view

Cancel

In Mailer, a data object within an electronic mail message that is displayed as
an icon in the Attachments list. An attachment can be text, sound, or a graphic.
Multiple messages can be added (attached) to a single electronic mail message.

The pattern that covers the workspace background.

The underlying area of a window on which elements, such as buttons and lists,
are displayed.

In Help Manager, a button and Navigate menu item you use to follow links
backward, in the reverse order they were traversed.

The file name of an icon file minus the file-name suffixes for size (I , .m, .s ,
.t ) and type (.bm, .pm). For example, the base name of an icon file named
myicon.m.pm is myicon .

An image stored in a raster format. Usually refers to an image limited to two
colors (a foreground and a background color). Contrast with pixmap.

A control that blinks when a Front Panel action has been invoked prior to the
appearance of a window or when reloading actions.

A generic term for a window control. See push button.

A software application that mimics the function of a hand-held calculator.

A software application that enables you to schedule appointments and create
To Do lists.

The day, week, month, or year displayed in the main Calendar window.

A push button that removes a window without applying any changes made in
that window.
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CDE

check box

choose

click

client

clipboard

Clock

Close

command-line prompt

Compose window

configuration file

384

An acronym for Common Desktop Environment, a graphical user interface
running on UNIX.

A nonexclusive control whose setting is indicated by the presence or absence of
a check mark. A check box has two states, on and off.

To use the mouse or keyboard to pick a menu item, button, or icon that begins
a command or action. Contrast with select.

To press and release a mouse button without moving the mouse pointer.
Unless otherwise specified, mouse button 1 is assumed.

A system or software application that requests services from another
application, usually across a network.

A buffer that temporarily stores the last cut, copy, or pasted data.

A Front Panel control that displays the local time.

A menu item used to remove a window and all related secondary windows
from all workspaces.

A prompt (usually % >, or $) that shows the computer is ready to accept
commands. In a terminal emulation window, you display the command-line
prompt by pressing Return.

In Mailer, the window you use to create new electronic mail messages. Several
message-composing options are available from the Compose window menu
bar.

A file that is used to customize the properties of an application.
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container

control

Create Action

current folder

current item, current selection

current session

cursor

customization

data type

A control intended to hold objects or data. A folder and a notebook are
examples of containers.

In Mailer, your electronic mailbox and filing system that contains all mail
messages. Once a message is put in a container, you can display, modify,
delete, print, include, forward, and reply to it.

A generic term for a variety of elements (such as buttons, check boxes, and
scroll bars) that perform an action or indicate an option setting. See Front Panel
control.

A software application that enables you to associate an icon with a command
so that the command can be issued by clicking on the icon. Create Action is
also used to define specific data types for an application’s data files and to
associate icons with those data types.

The currently opened folder in an active File Manager view.

The currently highlighted item in a list.

The session saved by Session Manager when you log off. At the next login,
unless you specify otherwise, this session automatically opens, enabling work
to continue where you left off. Contrast with home session.

A graphical device that shows the area that will receive keyboard or pointing
device input.

The process of changing settings to alter the appearance and behavior of the
desktop and applications running on the desktop.

A mechanism that associates particular data files with the appropriate
applications and actions. Data types can determine the type of a file based on
file-naming conventions, such as a particular extension name, or on the
contents of the file.

Glossary 385



default

desktop

dialog box

dimmed

directory

double-click

drag

drag and drop

drag transfer

drop

drop target

drop zone

386

A value set automatically by an application.

See workspace.

A window displayed by an application that requires user input.

Reduced contrast to show unavailable emphasis.

A collection of files and other subdirectories. In graphical user interface
applications, may be called a folder.

To quickly press a mouse button twice without moving the mouse pointer.
Unless otherwise specified, mouse button 1 is assumed. Double-clicking can
often be used as an alternative to selecting menu items.

To press and hold down any mouse button while moving the pointer—and the
object under the pointer—on the screen.

To directly manipulate an icon by using a pointing device to move and place
the icon somewhere else. Also referred to as drag transfer.

See drag and drop.

After starting the drag of an object, the act of releasing the mouse button. If the
object is dropped in an appropriate area, an action is initiated.

A rectangular graphic that represents the drop zone in an application.

An area of the workspace, including the Trash Can, Print Manager, and Mailer
Front Panel controls, that accepts a dropped icon. Icons can be dropped on the
workspace for quick access.
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element

email

environment variables

error message

execute

Exit button

extended selection

file

File Manager

file name

file server

A generic term for any entity that can be considered a standalone item in a
broader context, such as an item in a list or a control in a window.

Short name for “electronic mail.” Email usually describes text messages
addressed and sent to you electronically and are received in your electronic
mailbox. Sometimes just known as “mail.”

Standard UNIX variables that are used by the shell and by applications.

A message that requires the user’s immediate attention. Error messages are
used to convey a message about a user error.

A file or folder (directory) access permission. For files, execute permission
enables the user to run a program or shell script file. For folders (directories),
execute permission enables the user to access the folder (directory) contents.

A Front Panel control used to log out of the desktop.

To add multiple items to a selected set by augmenting the selection technique.
For example, you can add to a selection by moving the pointer to a new item
and pressing Control and mouse button 2 simultaneously.

A unit of data, such as text, program, image, and so on, that is stored in a
folder (directory).

The software application that manages the files and directories on your system.

The name of the file as it is stored in a folder (directory) or on a storage device.
A file name consists of a base name and any suffixes. A fully qualified file
name also includes the path.

A host computer that stores data files used by applications.
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file suffix

file type

filter

focus

folder

font

foreground

Front Panel

Front Panel control

Front Panel move handles
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A suffix added to the end of a file name, often used in file typing or to
categorize files for the user.

Characteristics of a file that determine how it is used. The type of a file may be
determined by a portion of its name (for example, the file extension) or by its
content.

Used to display only objects that meet certain criteria, such as a name pattern
match, and to hide all other objects from view.

The place to which keyboard input is directed, indicated by the highlight.

An icon that represents a directory.

A complete set of characters (letters, digits, and special characters) of one size
and one typeface. Ten-point Helvetica bold is an example of a font.

The content of a window and the color or shading used to distinguish it from
the window’s background.

A centrally located window containing controls for accessing applications and
utilities, including the workspace switch. The Front Panel occupies all
workspaces.

An object in the Front Panel used as an interface to basic system services and
frequently performed tasks and operations. Controls in the default Front Panel
are: Clock, Calendar, Mailer, Text Editor, Help Viewer, File Manager, Printer,
Style Manager, Application Manager, and Trash Can.

An area on each end of the Front Panel used for moving the Front Panel and
for bringing it to the front of the workspace.
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grab handles (or handles)

group

Group Appointment

header

Help

help family

Help Index

help key

Help Manager

Help Viewer

help volume

help window

The small squares displayed at the corners and midpoints of a selected graphic
element.

A collection of users who are referred to by a common name.
Also, a permission setting that determines a group’s access to files.

In Calendar, an appointment for a group of people, scheduled using the Group
Appointment Editor.

In Mailer, the basic information about an electronic mail message as it appears
in the mailer container. A message header displays the name of the sender,
subject, the date and time it was received, and message size.

A button or menu item used to access information about objects, choices, tasks,
and error messages.

A set of help volumes that provide online information about related
applications.

An alphabetic listing of help topics.

A designated key, usually the F1 key, used to request online help information
about what the cursor is currently on.

Some keyboards have a dedicated Help key that may take the place of F1.

A special help volume that lists all the online help registered on your system.

The software application that displays online help.

A complete body of help information about a subject.

A secondary window that displays help information.
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hierarchical file system

highlight

history

home directory

HomeDirectory

home folder

home session

host

hyperlink

icon

Icon Editor
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A way to organize data on computer systems using a hierarchy of containers,
often called folders (directories) and files. In this scheme, folders may contain
other folders and files. The successive containment of folders within folders
creates the levels of organization, which is the hierarchy.

(v) To make something stand out on the screen by selecting or choosing it.
Also (n) the visual indicator that something is selected.

A list of the most recently accessed commands, files, folders, or help topics.

A directory where you keep personal files and additional directories. In
graphical user interface applications, may be called the home folder.

Symbolizes your home directory. For example: If your home directory is
/users/fanna , then / HomeDirectory/bitmaps/smile.bm represents
/users/anna/bitmaps/smile.bm

A folder where you keep personal files and additional directories. By default,
File Manager and Terminal Emulator windows are set to the home folder when
you first open them. When discussing command-line activities, may be called
the home directory.

A choice at logout to designate a particular session, other than the one you are
currently in, as the one you will automatically return to at the next login.

A computer system.

In Help text, text or a graphic you click to display another Help topic.

A graphical representation of an object consisting of an image, an image
background, and a label. An icon can be directly manipulated.

The software application used to create new icons and to modify existing icons.
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Inbox

index

insertion point

Install Icon

ITE

items

label

link

list

Lock button

log in

login

The main or default Mailer container. The Inbox receives all incoming mail.
Messages can be moved out of the Inbox and put in various containers.

In a help volume, an alphabetical list of words or phrases that can be searched
to find help on a subject. The Help System displays the index when you choose
the Index button in a help dialog box.

The point at which data typed on the keyboard, or pasted from the clipboard
or a file, appears on the screen. In text, a synonym for cursor.

An item on a subpanel used to install icons into the Front Panel using drag and
drop.

Internal Terminal Emulator. ITE allows use of a bitmapped display as a
terminal (through command-line mode from the login screen).

Elements in a list or menu.

The text appearing next to an icon or control that names the element.

Synonym for symbolic link.

A control that contains elements from which you select. Also called selection
list.

A Front Panel control used to lock the screen.

To supply a user name and password to gain access to a system or desktop
session.

The process of gaining access to a system.
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log out

logout

Mailer

mailer container

Mailer control

Main Panel

mapping

Maximize

maximize button

menu

menu bar

menu item
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To terminate or end access to a system or desktop session.

The termination of a desktop session.

An application that enables you to send, receive, and compose electronic mail
messages.

The electronic mail box and filing system that contains all mail messages. Once
a message is put in a container, you can display, modify, delete, print, include,
forward, and reply to it.

The Front Panel control used to start the Mailer software application. Dropping
a file on the control loads the file into the Mailer Compose window.

The portion of the Front Panel excluding the subpanels.

A method of using one action to run another action. Also, a pairing of entities
in one set with those in another set.

A choice that enlarges a window to its largest possible size.

A button on a window’s title bar that you choose to display the window in its
largest size.

A list of items from which you select to perform a particular application task.
Also see submenu.

The part of the application window between the title bar and the work area
where menu names are listed.

An element in a menu that represents a choice (for example, Copy on the Edit
menu).
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Minimize

minimize button

mnemonic

modifier key

mouse

mouse button

mouse button 1

mouse button 2

mouse button 3

Move

To turn a window into an icon. The push button that minimizes a window is
located near the upper right corner of the window frame.

A button on a window’s title bar that you choose to display the window as an
icon.

A single, underlined character in a command. The mnemonic indicates that
you can choose the command by typing that letter. Mnemonics are used most
commonly in menu commands; however, other buttons may also have
mnemonics.

A key that when pressed and held along with another key or mouse button
changes the meaning of the second key or mouse click. Control, Alt, and Shift
are examples.

A device for moving the pointer and making selections.

A mechanism on a mouse that you press to make selections.

On a mouse, the leftmost button when configured for right-handed use; the
rightmost button when configured for left-handed use. Mouse button 1 is
primarily used for selection, and is the default button for the “click”
instruction.

On a three-button mouse, the middle button. Mouse button 2 has two modes:
Transfer and Adjust.

On a mouse, the rightmost button when configured for right-handed use; the
leftmost button when configured for left-handed use. Mouse button 3 activates
pop-up menus.

A Window menu choice used to put a window in a different location on the
screen.
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navigation keys

newline character

object

object type

OK

On Item help

On Item Help control

overwrite

page
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The keyboard keys used to move the current location of the cursor. These
include the arrow keys (with or without the Control key); the Tab key (with or
without the Control or Shift keys); the Begin and End keys (with or without the
Control key); and the Page Up and Page Down keys.

An unseen character that marks the end of a line of text in a document. It tells
a printer or screen to break a line and start a new one.

Any logical piece of data that has associated behavior. For example, in File
Manager, files, folders, actions, and applications are all considered objects.
Each type of object has specific associated actions. Typically, each object is
represented as an icon.

A desktop mechanism used to associate particular data files with the
appropriate applications and actions. Object typing defines the criteria for
typing the file (such as name or contents), the appearance (the icon used in File
Manager), and the behavior of the object (for example, what happens when
you double-click it).

A choice that accepts the information in a window and closes it. If the window
contains changed information, those changes are applied before the window is
closed.

When you choose On Item from the Help menu, the cursor changes to a
guestion mark and you can obtain information about a particular command,
operation, dialog box, or control by clicking that object.

A Front Panel control used to access item help information on the Front Panel.

To replace.

To advance text displayed in a window by one full screen at a time, usually
using a scroll bar.
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palette

parent directory

parent folder

password

path

pause

permission

pixmap

point

pointer

pop-up menu

Print Manager

A range of graphically displayed choices, such as colors or collections of tools,
that you can select in an application.

A directory that contains subdirectories and files. In graphical user interface
applications, this may be called the parent folder.

A folder that contains subfolders and files. When discussing command-line
activities, this may be called the parent directory.

A sequence of characters that users type to prove their identity to the system.

A text string that specifies the hierarchical location of a folder (directory).

To temporarily suspend a process without ending it.

A setting that determines how users or groups of users may access a file or
folder (directory).

An image stored in a raster format. Usually refers to an image that may have
more than two colors. Contrast with bitmap.

To move the mouse until the pointer rests on a particular screen element or
area.

A cursor that shows the area that receives input from a pointing device. The
pointer can take the form of an arrow, an I-beam, a cross, or other graphic. Also
see cursor.

A menu that, when requested, is displayed next to the object with which it is
associated. Pop-up menus are usually displayed by clicking mouse button 3 or
pressing Shift+F10.

A software application that shows all the printers on your system.
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print server

Printer control

Printer Jobs

program

Properties

pull-down menu

push button

gueue

radio button

Read

Reset
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A host computer to which one or more printers are connected, or the UNIX
process that manages those printers.

The Front Panel control used to start the Printer software application.
Dropping a file on the control displays a dialog box you can use to print the
file to the default printer.

A software application that provides information about jobs on a single printer.

A sequence of instructions that a computer can interpret and execute.

A menu item used to set characteristics of an item, such as its date or name, or
display identifying characteristics of an item, such as typefaces.

A menu of related choices that extends from a cascading choice when you click
mouse button 1 on a menu bar item or the Window menu button.

A control that immediately starts an action by an application, usually
executing a command (such as Apply), displaying a window, or displaying a
menu.

An ordered list of jobs waiting to be performed.

An exclusive control whose setting is indicated by the presence or absence of a
graphical indicator, usually part of a radio group. A radio button has two
states, on and off.

Permission to look at the data in a file or permission to list the files and folders
(directories) in a folder (directory).

A button or menu item used to return an item to the condition it was in when
it was last opened or to the condition it was in before the most recent changes
were applied to it, whichever is more recent.
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resize border

resource

restart

Restore

root, root user

root directory

run

sash

screen lock

screen saver

scroll

A control used to change the size of a window or a pane in a window.

A mechanism of the X Window System™ for specifying an attribute
(appearance or behavior) of a window or application. Resources are usually
named after the elements they control.

To stop a process and start it again.

A menu item used to return a window to the size and position it occupied
before you minimized or maximized it.

See superuser.

In a hierarchical file system, the directory that contains all other directories and
files. Represented by a / (slash) in UNIX systems.

To start an application or action.

A box on a separator or split bar that enables you to increase or decrease the
size of a window pane using the mouse. You can navigate to the sash using the
keyboard.

A function that locks the workstation screen, barring further input until the
valid user password is entered.

A choice that, after a specified time period, switches off the workstation
display or varies the images that are displayed, thereby prolonging the life of
the screen.

To move the cursor through data one increment at a time. While scrolling, data
shifts within the window to indicate the current position of the cursor.
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scroll bar

scroll box

select

server

session

Session Manager

session server

shortcut

shortcut keys

398

A control located at the right or bottom of a window that enables you to
display window content not currently visible.

The part of a scroll bar that shows the position of the visible information
relative to the total amount of information available in a window. You click a
scroll box to see information that is not currently visible.

To add highlighting or some other visual cue to an item or element so that it
can be operated or enabled. Selection does not imply the initiation of an action
but rather a change of state, such as highlighting an item in a list, or toggling a
check box on.

A system that supplies services to a client.

The elapsed time between user login and logout. Also, a particular
configuration of workspaces that includes Style Manager settings, open
applications, and the size and position of objects.

A software application that controls saving sessions, restoring sessions, screen
locking and unlocking, and the use of screen savers. When a session is saved,
the state of the desktop environment (location of icons, size and location of
open windows, open/closed status of applications, current color palette, and
S0 on) is preserved so that it can be restored at the next login.

A system that provides networked sessions. Session files reside on the session
server and are used whenever you log in to a system on the network.

General term for a mouse gesture that simplifies filling out a dialog box. For
example: As a shortcut, double-click an item in the Filename list box to select it
and choose OK in one action.

A keyboard key sequence used to activate a menu item, usually through a
special accelerator key. For example: Press Alt+F to choose Print from the File
menu.
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slider

software application

status area

Style Manager

subdirectory

subfolder

submenu

subpanel

suffix

superuser

A control that uses a track and arm to set a value from among the available
values. The position of the arm (or a separate indicator) gives the currently set
value.

A computer program that provides you with tools to do work. Style Manager,
Text Editor, and File Manager are examples of software applications.

A part of a window where information is displayed that shows the state of an
object or the state of a particular view of an object.

The software application used to customize some of the visual elements and
system device behaviors of the workspace environment, including colors and
fonts, and keyboard, mouse, window, and session start-up behaviors.

A directory contained within another directory (sometimes called the parent
directory). In graphical user interface applications, this may be called a subfolder.

A folder contained within another folder (sometimes called the parent folder).
When discussing command-line activities, this may be called a subdirectory.

A menu displayed by choosing an item from a menu.

An extension of the Front Panel that slides up, providing access to additional
elements. Subpanels usually contain groups of related elements.

A part of a file name, added at the end, separated from other suffixes or the
base file name by some punctuation, such as a period (.).

A login identity that enables special permissions for modifying system files
that most users do not have permission to modify. Superuser is also called “the
root user” or “root” because the user ID for superuser is root . On most
computer systems, only a few users have permission to become superuser.
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symbolic link

template

Terminal

terminal emulator

text cursor

Text Editor

text field

title bar

toggle

topic tree

Trash Can
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A type of link that is capable of pointing to a file or directory that resides on
another physical storage device or partition.

In Mailer, an ASCII file you can create for conveniently including frequently
typed information, such as your name and electronic mail address, in your
mail messages.

In the Front Panel, an item in the Personal Applications subpanel used to open
a terminal window.

A window that emulates a particular type of terminal for running nonwindow
programs. Terminal emulator windows are most commonly used for typing
commands to interact with the computer’s operating system.

A cursor that shows the insertion point for textual input. This cursor usually
takes the form of an I-beam. Contrast with location cursor and pointer.

The software application used to create and edit documents.

A rectangular area in a window where information is typed. Text fields with
keyboard focus have a blinking text insertion cursor.

The topmost area of a window containing the window title, window menu
button, and the maximize and minimize buttons. See also window title.

To change the state of a two-state control, such as a radio button or check box,
using either the mouse or keyboard.

In a general help dialog box, a list of topics that can be selected to display help
information.

A container for deleted files or folders.
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tree view

user name

window

window frame

window icon

Window Manager

Window menu

Window menu button

work area

workspace

A view of a folder or files that includes all lower-level folders in the search
path.

An identifier for making a user known to the system. Sometimes called a login
name. For example, a user whose name is John Doe might have the user name
jdoe. The login screen prompts for the user name.

A rectangular area on the display. Software applications typically have one
main window from which secondary windows, called dialog boxes, can be
opened.

The visible part of a window that surrounds a software application. A window
frame can contain up to five controls: title bar, resize borders, minimize button,
maximize button, and the Window menu button.

A minimized window.

The software application that provides users with the capability to manipulate
windows on the workspace; for example, opening, resizing, moving, and
closing windows.

The menu displayed by choosing the Window menu button. The menu
provides choices that manipulate the location or size of the window, such as
Move, Size, Minimize, and Maximize.

The control at the upper left corner of a window, next to the title bar. Choosing
it displays the Window menu.

The part of a window where controls and text appear.

The current screen display, the icons and windows it contains, and the
unoccupied screen area where icons can be placed.
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workspace backdrop

workspace background

workspace icon

Workspace Manager

Workspace menu

workspace object

workspace switch

workspace switch area

Wrap To Fit

Write
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See backdrop.

The portion of the display not covered by windows or icons.

An icon that has been copied from File Manager to the workspace.

The software application that controls the size, placement, and operation of
windows within multiple workspaces.

The menu displayed by pointing at an unoccupied area of the workspace and
clicking button 3 on the mouse.

An object that resides in a workspace, rather than inside a viewer in a window.
Workspace objects include windows, icons (minimized windows), and objects
that have been dragged from File Manager and Application Manager and
dropped on a workspace.

A control that enables you to select one workspace from among several
workspaces.

The rectangular area in the center of the Front Panel that contains the
workspace switches, the Lock control, the Exit button, and the busy light.

In Text Editor, this setting controls whether lines are automatically wrapped to
fit the window width as you enter text. If set, lines wrap at the edge of the
window. If not set, you must press Return to end the line.

Permission to modify the contents of a file or folder.

Solaris CDE User’s Guide—February 1997



Index

Symbols
.. (parent directory), 135

A

absolute path, 94
accelerators, keyboard, Mailer, 216
access
denying to your calendar, 293
granting to your calendar, 290, 293
to calendar, changing, 290
to other calendars, 282
Access Control Lists, 110, 114
adding entries, 116
changing entries, 117
default permissions, 119
deleting entries, 118
viewing, 116
ACL-enabled, 115
action icon, 145
and file names, 150
help on, 148
actions
creating, 151
double-clicking, 102
executing, 107
executing the default, 108
Actions menu, 102

add calendar, 297
adding
applications, 151
applications to Front Panel, 148
applications to personal application
group, 150
attachments to mail messages, 209
calendars to Browse list, 282
controls with Install Icon, 84
group appointment, 283
mail signatures to all messages, 198
palette, 164
subpanels, 84
To Do item, 277
workspaces, 86
addresses, 190
aliases, 190
AnswerBook, displaying, 58
application
adding to Front Panel, 84
application groups, 144 to 146
built-in, 145
definition of, 144
personal, 149
application help, 44
application icon, 145
help on, 148
on workspace backdrop, 149
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Application Manager, 143
application groups, 144
built at login, 145
customizing, 149
folders in, 144
Front Panel control, 8, 143
labels and file names, 150
location in file system, 151
opening, 8,143
running applications from, 146
starting Icon Editor from, 329
updating, 149
window, 144
Application Manager control, 73
applications
adding, 151
adding to Front Panel, 148
adding to Personal Applications
subpanel, 154
registering, 153
reloading, 149
running from Application
Manager, 146
running from File Manager, 153
running from Front Panel, 154
running from Personal Applications
subpanel, 155
running from terminal emulator, 155
starting in Terminal window, 310
using Text Editor with, 265
applications, opening, 28
Appointment Editor
changing defaults, 288
Group, 283
options, 274
standalone, 300
using, 273
appointment list
displaying, 276
printing, 280
appointments
adding to mail message, 211
basic, 273
changing, 275
creating, 273
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creating using standalone
Appointment Editor, 300

deleting, 275

deleting using dtcm_delete , 302

dragging from File Manager, 286

dragging from Mailer, 286

dragging to File Manager, 287

dragging to Mailer, 287

finding, 276

finding using dtcm_lookup , 301

format for mail message, 284

frequency of, 274

inserting, 273

inserting using dtcm_insert , 301

inserting using standalone
Appointment Editor, 300

looking up, 301

mailing, 284, 290

options, 274

reminders, 274

scheduling, 273

scheduling using standalone
Appointment Editor, 300

attachments

adding to mail message, 209

adding with drag and drop, 211

as part of a template, saving, 195

printing, 209

reading, 209

saving, 210

viewing, 209

automatic mail messages, 199

B

Backdrop dialog box, 167
backdrop, See workspace backdrop
Backspace key, 24

base name font list, 378

basic appointment, 273

basic file management skills, 95

basic permissions, 112
default, 119

basic user types, 111



Beep Calendar reminder, 274
Beep dialog box, 168
beep, changing settings for, 168
bell options in Terminal, 317 to 319
BottomShadow, 335
Browse list, 282
browsing calendars, 281
Browsing Help on Your System, 58
Busy light, 73
buttons
check box, 20
OK, 19
radio, 20
types of, 19

C

Calendar
add, 297
convert version 3 to version 4, 298
creating, 296
delete, 297
Front Panel control, 268
list calendars, 296
menus, 268
saving data in a file, 281
starting, 268
starting from command line, 268
Tool bar, 268
tool bar, 269
Calendar access
world (anyone), 291, 292
Calendar control, 72
Calendar tools, 296
Calendar views
changing, 270, 271, 272, 273
changing default, 290
Day, 270
default, 268
displaying, 270
Month, 272
printing, 280
Week, 271
Year, 273

Index

calendars
access to other, 282
browsing, 281
comparing, 282
deleting from the Browse list, 282
canceling
dragging, 97
print jobs, 230
capturing region of display, 339, 340
CD-ROM, 138
ejecting, 140
changing
Appointment Editor defaults, 288
appointments, 275
beep settings, 168
calendar access and permissions, 290
Calendar printer settings, 294
Calendar time zone, 295
Calendar views, 270, 271, 272, 273
colors, 162
date format in Calendar, 295
default Calendar view, 290
File Manager default preferences, 134
Front Panel lock settings, 169
how your next session starts, 172, 173
initial calendar displayed, 289
number of colors, 165
permissions for your calendar, 292
printer icon, 235
printer label, 236
privacy defaults in Calendar, 288
reminders in Calendar, 288
time boundaries on Day and Week
views, 289
To Do item, 278
changing the character set of an incoming
message, 178
changing the character set of an outgoing
message, 194
character marker for included mail
messages, changing, 212
character set
incoming message, changing, 178
outgoing message, changing, 194
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check boxes, 19, 20
choosing
Front Panel controls with the
keyboard, 371
help, 33
help topic hyperlinks with the
keyboard, 373
menu items, 31
push buttons, 19
subpanel controls with the
keyboard, 372
Window menu items, 29
Workspace menu items, 30
Clean Up (command in View menu), 133,
134
clicking, 2
to make window active, 171
Clock control, 72
closing
application windows, 12, 366
subpanels, 66
color
changing, 162
displaying use of in image, 345
for icons, 335
grabbing from workspace, 163
in help windows, 61
limiting usage of, 165
in Terminal window, 317
viewing image in, 344
Color dialog box, 162, 163, 164
Color setting in Image Viewer, 344
command line
to start Calendar, 268
Command Line Login mode
definition of, 39
exiting, 40
logging in to, 40
commands
entering in Terminal window, 310
issuing for printing, 226
Compare Calendars grid, using, 283
comparing calendars, 282
contents, finding file using, 128
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control
adding to subpanel, 84
control characters in Terminal, 324 to 325
Control key, 3
controls
adding with Install Icon, 84
customizing in the workspace
switch, 86 to 89
deleting, 70
moving to Main Panel, 83
replacing in Main Panel, 85
convert version 3 Calendar to version
4, 298
copying
files, 104
folders, 104
objects, 104
palette, 164
a region of an icon, 336
text, 251
text in Terminal window, 310
Create Action, 151
creating, 151
actions, 151
appointment using standalone
Appointment Editor, 300
appointments, 273
custom palette, 164
data types, 151
document, 240
file with language-specific
characters, 376
files, 103
folders, 103
mail aliases, 191
mail search scripts, 187
mail signatures, 198
mailboxes, 182, 203
objects, 103
personal application group, 149
To Do items, 277
creating a calendar, 296
current folder, 93
current session, 33



definition of, 40, 172
resuming at, 172
cursor movement keys, 245
cursor options in Terminal, 315 to 316
custom fields in Format menu,
adding, 213
Custom Time, in Calendar, 295
customizing
Calendar printer settings, 281, 294
colors, 163
File Manager views, 129 to 130
keyboard behavior, 167
mouse behavior, 168
palette, 163
screen saver, 169, 170
cutting a region of an icon, 336

D

data types, 151

date format, 295

Day view
Calendar, 270
changing time boundaries, 289
three-month mini-calendar, 270

default actions, 108

default permissions, 119
optional Default entry types, 120, 122
required Default entry types, 119,

120, 121

default printer
changing, 222
control, 77
definition of, 221
determining, 222

default terminal emulator, 306
changing, 325

defaults
Calendar view, 268
changing access and permissions, 290
changing Appointment Editor, 288
changing Calendar reminder, 288
changing Calendar view, 290
changing privacy, 288

Index

date format in Calendar, 295
initial calendar displayed, 289
time boundaries on Day and Week
views, 289
delaying a snapshot, 361
delete calendar, 297
Delete char key, 24
Delete key, 24
deleting
appointments, 275
appointments using
dtcm_delete , 302
calendars from Browse list, 282
controls from subpanels, 70
files, 109
folders, 110
mail messages, 181
palette, 164
subpanels, 84
text, 250
text in a field, 24
To Do items, 278
workspaces, 86
denying access to your calendar, 293
deselecting text, 16
desktop
current session, 33
exiting, 32
help, 33
logging out, 32
overview, 4
windows, 4
workspaces, 4, 16
Desktop Introduction control, 80
desktop session, 38
directories, See folders
diskette, 138
copying files and folders to, 140
creating files and folders on, 141
deleting files and folders from, 141
ejecting, 140
formatting, 139
moving files and folders to, 141
renaming, 140

407



display

capturing region of, 339, 340
locking, 33

refreshing, 28

unlocking, 33

displaying

appointment list, 276

Calendar views, 270

concealed windows, 15

Front Panel pop-up menus, 67
help, 33

image in color, 344

man pages, 59

message line in Print Manager, 234
pop-up menus, 26, 30, 369
PostScript file in black and white, 352
PostScript file in color, 352
PostScript files, 351

print job properties, 231

print jobs, 229

Print Manager problem flag, 234
printer properties, 235
pull-down menus, 25, 30, 369
subpanels, 66

To Do list, 278

Window menu, 26

Workspace menu, 27
workspaces, 16, 370

document

creating, 240

editing, 237

formatting, 262

going to specific line in, 246

including file in, 252

including file through drag and
drop, 260

justifying text in, 263

margins, 263

new lines in, 244

opening existing, 242 to 243

opening existing from File
Manager, 243

printing, 263

restoring, 237

saving, 240
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searching, 261
word wrap, 244
dot files, 135
double-clicking, 2
action performed, 102
drafts
creating for mail messages, 196
using for mail messages, 195
drag and drop, in Text Editor, 260
dragging, 2
appointment from Calendar to File
Manager, 287
appointment from Calendar to
Mailer, 287
appointment from File Manager to
Calendar, 286
appointment from Mailer to
Calendar, 286
canceling, 97
file to Text Editor, 260
files, 97
folders, 97
objects, 97
text, 260
drawing icon image, 331
undo, 333
drawing tools for Icon Editor, 331 to 333
dropping
file in Text Editor, 260
files, 97
folders, 97
icon file, 329
objects, 97
text, 260
dtcm
to start Calendar from command
line, 268
, 298
, 302

dtcm_convert
dtcm_delete
dtcm_editor , 300
dtcm_insert , 301
dtcm_lookup , 301
dtterm command, 306



dtterm, See Terminal
due date, setting for To Do item, 277
dynamic colors for icons, 335

E
editing
existing mail message text, 180
file with language-specific
characters, 376
text fields, 24
text or document, 237
effective permissions, 112
encoding
incoming messages, 178
outgoing messages, 194
Enter key, 3
entering

commands in Terminal window, 310

text in a text field, 23
Esc key, 3
executing actions, 107
Exit control, 32, 38, 73
Extend char key, 3

F

F1 key, 33
failsafe session, 39
file management, basic skills, 95
File Manager
changing icon display area size
in, 137
determining headers for, 130
disabling icon browsing in, 137
Front Panel control, 7, 92
icon browsing in, 136
Information dialog box, 101
main window, 92
opening, 7
opening existing text document
from, 243
printing using, 224
removable media, 138

Index

File
File

running applications from, 153
saving current preferences as
default, 134

starting, 92

starting Icon Editor from, 329
Manager control, 72
Manager views

aligning icons in, 134
arranging icons in, 130
changing, 129

changing sort order of, 133
customizing, 129 to 130
folder, 132

saving, 134

tree, 130 to 132

file names

and action icons, 150
in Application Manager, 150

file path, 94
file system

files

concepts, 93
hierarchical, 93
moving through, 106

ACL-enabled, 115

changing ownership, 113

copying, 104

copying to diskette, 140

creating, 103

creating on diskette, 141

default permissions, 119

deleting from diskette, 141

dragging, 97

dropping, 97

dropping in Text Editor
document, 260

finding by contents, 128

finding by name, 127

getting help on, 100

hidden, 135

hiding, 135

including in document through drag
and drop, 260

including in mail messages, 197
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including in Text Editor creating on diskette, 141

document, 252 default permissions, 119
with language-specific definition of, 93
characters, 376 deleting, 110
locating, 126 deleting from diskette, 141
moving, 103 dragging, 97
moving to diskette, 141 dropping, 97
opening, 102 getting help on, 100
ownership, 110 hidden, 135
putting on workspace backdrop, 125 hiding, 135
removing from workspace, 126 moving, 103
renaming, 99 moving to diskette, 141
restoring from Trash Can, 109 opening, 102
security, 110 ownership, 110
selecting multiple, 96 putting on workspace backdrop, 125
selecting single, 96 removing from workspace, 126
sorting, 134 renaming, 99
types for printing, 222 to 223 restoring from Trash Can, 109
viewing on CD-ROM, 139 security, 110
viewing on diskette, 139 selecting multiple, 96
filing mail messages selecting single, 96
manually, 204 sorting, 134
finding viewing on CD-ROM, 139
appointment using viewing on diskette, 139
dtcm_lookup , 301 Font dialog box, 165, 166
appointments, 276 font group
files, 126 adding, 166
mail messages, 182 deleting, 166
objects, 126 selecting, 165
objects using wildcards, 127 font set specification, 378
print jobs, 230 font specification, 377
Flash Calendar reminder, 274 fonts
Flip tool, in Image Viewer, 346 internationalizing, 377 to 379
flipping an image, 348 selecting font group, 165
flipping part of an icon, 337 selecting new size for, 165, 166
folder view in File Manager, 132 specifying from the command
folders line, 378 to 379
ACL-enabled, 115 speci_fying vv_ithin a resource file, 379
changing, 106 wewmg attrlb'utes, .166
changing ownership, 113 format of image, displaying, 345
changing to, 106 formatting
copying, 104 document in Text Editor, 262
copying to diskette, 140 mail message text, 201
creating, 103 forwarding messages, 180
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frame controls, 9
frequency of appointments, 274
Front Panel, 63 to 89
adding applications to, 148, 154
Application Manager control, 143
Calendar control, 268
changing the printer in, 232
contents, 72
drop zones, 64
Exit control, 32, 38
File Manager control, 92
help, 70
Help control, 81
Icon Editor control, 329
Lock control, 33
lock settings, 169
minimizing, 71
moving, 70
On Item help, 70
pop-up menus, 67
printing through, 223 to 224
removing customizations made
through the GUI, 85
restoring default, 85
running applications from, 154
Style Manager control, 73
Text Editor control, 238

G

grabbing

region of display, 339, 340
grabbing color from workspace, 163
granting access to your calendar, 290
gray scale, displaying image in, 344
grid

Calendar Week view, 271

Compare Calendars, 283

in lcon Editor, 340

Group Appointment Editor, starting, 283

group appointments
inserting, 283
mailing reminders, 284
scheduling, 283

Index

H
height of image, displaying, 345
help
on action icon, 148
on application icon, 148
browsing, 55
context-sensitive, 44
displaying, 33
displaying for file, 100
displaying for folder, 100
displaying topics, 48
Front Panel, 70
hyperlinks, 372
index, 52
keyboard navigation, 372
moving between topics, 50
on objects, 100
On Item help, 45
pop-up menu, 50
printing help topics, 59
using Help key, 44
window colors, 61
windows, 47
help commands
Backtrack, 50
History, 50
Home Topic, 50
Index, 54
New Window, 57
Print, 60
Top Level, 56
Help key, 33
Help Manager
Front Panel control, 46
opening, 56
Help Manager control, 73, 80
Help menu, 35
help windows
color in, 61
duplicating, 57
topic display area, 47
topic tree, 47
types of, 47
hidden files, 135
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hiding
files, 135
folders, 135
Icon Editor grid, 340
objects, 135
waiting print jobs, 230

Snapshot dialog box during snap, 361

hierarchical file system, 93
highlight, keyboard, 364
home folder, navigating to, 106
home session
definition of, 40, 172
returning to, 172
setting, 40, 173

starting automatically at login, 41

hotspot in an icon, 339
hyperlink, used in help, 48

icon browsing, 137
Icon Editor
control, 329
drawing tools, 331 to 333
hiding grid in, 340
opening icon for editing, 329
saving icon, 334
saving icon with new name, 335
starting, 328
starting a new icon, 330
starting from Application
Manager, 329
starting from File Manager, 329
starting from Terminal, 329
Icon Editor control, 76
icons

aligning in File Manager view, 134
arranging in File Manager view, 130

behavior of in Front Panel, 84

browsing in File Manager, 136

changing display area size in File
Manager, 137

changing for printer, 235

changing magnification of, 340
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clearing loaded, 331

color usage for, 335
copying a region of, 336
cutting a region of, 336
displaying in icon box, 172
displaying on workspace, 172
drawing image, 331
flipping part of, 337
hotspot, 339

moving a region of, 337
naming, 333 to 334
opening existing, 330
output format, 334
resizing, 338

resizing a region of, 338
rotating part of, 337
saving, 334

saving with new name, 335
selecting an area of, 336
selecting multiple, 96
selecting single, 96

size conventions for, 334

image

changing orientation in the View
window, 344

displaying color usage of, 345

displaying format of, 345

displaying height of, 345

displaying in color, 344

displaying in gray scale, 344

displaying size of, 345

displaying width of, 345

flipping, 348

moving within View window, 344

opening in Image Viewer, 343

rotating, 348

saving, 350

saving a PostScript file page as, 354

saving region of to new file, 347

saving to a new file, 350

scaling, 349

Image Viewer

opening image in, 343
palette tools, 346
starting from command line, 342



starting from Front Panel, 342
starting from Workspace Programs
menu, 342
IMAP
default mailbox folder in IMAP
server, 206
filing server, 206
mailbox, 176
included text, marker for, 201
including multiple messages in a mail
message, 197
indicator controls, 64
initial calendar displayed, changing, 289
input method for locales, 380
inserting
appointment, 273
appointment using
dtcm_insert , 301
appointment using standalone
Appointment Editor, 300
group appointment, 283
To Do item, 277
Install Icon
behavior of icons installed with, 84
control, 65, 76, 77
Install Icon control, 84
internationalization and fonts, 377
Internet Messaging Access Protocol
(IMAP) Inbox, logging in to, 176

J

justification, setting in Text Editor, 263

K

keyboard
basic skills, 3
choosing menu items with, 31
cursor movement keys in Text

Editor, 245

customizing behavior, 167
displaying menus with, 369
focus, 364, 365

Index

highlight, 364
navigation, 3, 363
navigation and Window Behavior
setting, 3
options in Terminal, 320 to 322
shortcuts, 3, 363
tab groups, 364
Keyboard dialog box, 167
keyboard shortcuts, Mailer, 216
keymaps, changing, 380
keywords, for mail search scripts, 183 to
186

L

labels

changing for printer, 236

in Application Manager, 150
LANG environment variable, 376
language, setting for desktop session, 38
language-specific

characters in file, 376

data, 376

login, 376

sessions, 375

terminal emulator, 377

Text Editor, 376
link, creating symbolic, 105
list

of appointments, 276

of To Do items, 278
list calendars, 296
lists

scrollable, 19

selecting items in, 22
local time, setting in Calendar, 295
Lock control, 33,72
locking the display, 33
logging in, 38

to language-specific session, 376
logging in to

IMAP Inbox, 176

Mailer, 176
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logging out, 32, 38 Calendar appointment, 284, 290

login screen, 37 reminders of group appointment, 284
login, language-specific, 376 Main Panel, 64
logout confirmation, 173 changing controls in, 83
logout, determining session resumption contents, 72
at, 172 moving subpanel control to, 69

replacing a control, 85
replacing Personal Applications
control in, 155

looking up appointments, 301

M man pages, displaying, 58, 59
magnification of icons, 340 managing files, 95

mail aliases, 190 margins, document, 263

Mail Calendar reminder, 274 marking To Do item completed
mail messages, See messages using To Do Editor, 280

mail notification, customizing, 213 using To Do list, 279

mail search scripts mask, 123
creating, 187 modifying, 123
keywords for, 183 to 186 maximize button, 10
mail signatures menu bar
adding to specific messages, 198 removing from Terminal
automatically adding to all window, 313
messages, 198 restoring to Terminal window, 313
creating, 198 menus
mailboxes Calendar, 268
adding to menus, 206 mnemonics, 25, 364
changing default directory for, 206 shortcut keys, 25, 364
closing, 204 using, 25
creating, 203 Window, 26
filing messages in, 204 Workspace, 27
filing using drag and drop, 205 message filing
opening, 204 manual, 204
removing, 205 messages
views of, 188 to 190 adding attachments to, 209
Mailer adding Calendar appointments
keyboard accelerators, 216 to, 211
logging in to, 176 adding signature to specific, 198
main window, 178 automatically generated, 199
mnemonics, 216 Calendar appointment format
starting, 176 for, 284
Mailer control, 72 changing character set of
Mailer Inbox _ incoming, 178
IMAP (remote), 176 changing chargcter set of
local, 176 outgoing, 194
mailing changing text, 202
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checking spelling, 202
deleting, 181

displaying numbers of, 212
editing existing, 180

filing, 204

finding text in, 202
forwarding, 180

frequency of checking for new, 212
including signature in all, 198

including text files, 197
printing, 207

reading, 178

replying to, 179
restoring deleted, 182
saving as template, 194
searching for, 182

setting marker for included text

in, 201
sorting, 179
viewing, 178

MIME format, email in, 200
minimize button, 10
minimizing
Front Panel, 71
windows, 12
mnemonics, Mailer, 216
mnemonics, menu, 25, 364
Modify dialog box, 163
Month view, 272
mouse
choosing a menu item, 30
click, 2
customizing behavior, 168
double-click, 2
dragging, 2
using, 2
mouse button 1, 2
mouse button 2, 16
mouse button 3, 26
Mouse dialog box, 168
moving
controls to Main Panel, 83
files, 103
folders, 103

Index

Front Panel, 70

icons, 13

keyboard focus, 365
objects, 103

a region of an icon, 337
subpanels, 70
windows, 13, 368

My Time, setting Calendar time zone, 295

N

name, finding file by, 127
names

for icon files, 333 to 334

navigating

to home folder, 106

moving text insertion cursor, 245

to specific line in document, 246
with keyboard, 363

Next key, 21
notification of new mail, customizing, 213

@)

objects
aligning in File Manager view, 134

copying, 104
creating, 103
dragging, 97
dropping, 97
executing action of, 107
finding by name, 127
folder, 93

getting help on, 100
hiding, 135
manipulating, 102
moving, 103
opening, 102

pop-up menu for, 125

putting on workspace backdrop, 125

removing from workspace, 126
renaming, 99

restoring from Trash Can, 109
selecting multiple, 96
selecting single, 96
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416

sort order in File Manager, 133
sorting, 134
workspace, 8
Occupy Workspace dialog box, 17
OK button, 19
On Item help, 45, 100
On Item Help control, 81
online help, 43
displaying, 33
keyboard navigation, 372
opening
application windows, 11, 366
existing document, 242 to 243
files, 102
folders, 102
icon, 329
mailboxes, 204
objects, 102
Style Manager, 159
subpanels, 66
Terminal window in current
directory, 107
opening applications, 28
overstrike mode, in Text Editor, 250

P

Page Down key, 21
Page Up key, 21
palette
adding, 164
creating, 164
deleting, 164
modifying, 163
restoring, 164
selecting, 162
palette (Image Viewer)
description of tools in, 346
displaying automatically, 346
Pan tool, in Image Viewer, 346
parent folder, navigating to, 107
pasting
text, 16
text in Terminal window, 310
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path, 94
pending To Do item, 279
permissions
Access Control Lists, 114
basic, 110

basic user types, 111

changing for your calendar, 290, 292

default, 119

effective, 112

mask, 123

modifying basic, 112

setting for your calendar, 291
Permissions dialog box, 112, 121, 122
personal application group

adding applications to, 150

creating, 149
Personal Applications control, 72
Personal Applications subpanel, 154

adding applications to, 154

customizing, 155

replacing the Front Panel control

of, 155

running applications from, 155
pointing to make window active, 171
Popup Calendar reminder, 274
pop-up menus

displaying, 26, 30, 98

for objects, 124, 125

Front Panel, 67

for subpanels, 69
PostScript file

changing the size of display of, 354

displaying, 351
displaying in black and white, 352
displaying in color, 352
paging through, 352
printing, 356 to 357
reversing page order, 353

saving a page as bitmap image, 354

viewing a specific page, 352
preferences, saving File Manager
current, 134
Prev key, 21
print commands, issuing, 226



Print dialog box, 225 to 226
print jobs
canceling, 230
definition of, 229
determining type in Print Manager
display, 233
display of in Print Manager, 233
displaying, 229
displaying properties of, 231
finding, 230
hiding, 230
properties, 231
Print Manager
determining type of print jobs
displayed, 233
display of print jobs in, 233
displaying message line in, 234
printer display in, 233
printing using, 225
problem flag, 234
starting, 227 to 228
window, 227
Print Manager control, 77
print options, setting, 226
printer
changing the default, 222
changing the Front Panel, 232
definition of default, 221
determining the default, 222
Printer control, 73, 77
Printer Jobs, 228
starting, 229
printers
changing icon of, 235
changing label of, 236
display of in Print Manager, 233
displaying properties of, 235
printing, 356 to 357
allowable file types, 222 to 223
appointment list, 280
Calendar views, 280
changing Calendar printer
settings, 294
document, 263

Index

using File Manager, 224

through the Front Panel, 223 to 224

help topics, 59

image, 356 to 357

issuing print commands, 226

mail attachments, 209

mail messages, 207

PostScript file, 356 to 357

using Print Manager, 225

setting options for, 226

To Do list, 280
privacy, changing Calendar defaults, 288
Programs submenu, 28
properties

of print jobs, 231
Properties dialog box, 101, 114, 115, 116

opening from command-line, 114
pull-down menus, displaying, 25, 30
push buttons, 19

Q

question mark pointer, 35

R

radio buttons, 20
reading mail messages, 178
refreshing the display, 28
region of screen, taking a snapshot of, 360
registering applications, 153
registration, user, 146
relative path, 94
reloading applications, 149
reminders
appointment, 274
changing defaults, 288
of group appointment, mailing, 284
removable media, 138
drag-and-drop behavior, 138
viewing files and folders, 139

removing
files or folders from workspace, 126
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418

Front Panel customizations made
through the pop-up
menus, 85

Front Panel customizations made
with the Install Icon
control, 85

mailboxes, 205

menu bar from Terminal
window, 313

scroll bar from Terminal window, 314

workspaces, 86
remsh command, 157
renaming

files, 99

folders, 99

objects, 99

workspaces, 18, 69, 370
renaming workspaces, 86
replacing controls in Main Panel, 85
replying to mail messages, 179
resizing

icons, 338

aregion of an icon, 338

windows, 14, 368

restoring
deleted mail messages, 182
items in Trash Can, 109
menu bar to Terminal window, 313
palette, 164
scroll bar to Terminal window, 314
Text Editor file, 265
window icon, 13
windows from an icon, 13, 367
Return key, 3
reversing page order display, 353
rlogin  command, 157
Rotate tool, in Image Viewer, 346
rotating an image, 348
rotating part of an icon, 337

S

saving
Calendar data in a file, 281

Solaris CDE User’s Guide—February 1997

document to new file, 240
document to original file, 241
icons, 334
icons with new name, 335
images, 350
incoming or outgoing mail message
as text, 181
mail attachments, 210
mail message as template, 194
Scale tool, in Image Viewer, 346
scaling an image, 349
scheduling
appointments, 273
appointments using standalone
Appointment Editor, 300
group appointments, 283
To Do items, 277
screen blanker, settings for, 169
screen control options in Terminal, 322 to
324
Screen dialog box, 169 to 171
screen lock
duration before starting, 171
enabling, 170
screen saver, customizing, 169, 170
screen, taking snapshot of, 360
scroll bar
removing from Terminal
window, 314
restoring to Terminal window, 314
scrolling
setting in Terminal window, 317
window contents, 21
scrolling window contents, 368
sdtcm_admin
creating a calendar, 296
search and replace, in Text Editor, 261
search scripts, See mail search scripts
searching for mail messages, 182 to 187
secondary selection, in Text Editor, 246
selecting
an area of an icon, 336
backdrop, 167



check boxes, 20
files, 96
folders, 96
font size, 165, 166
icons, 96
list items, 22, 369
multiple files, 96
multiple folders, 96
multiple icons, 96
multiple objects, 96
objects, 96
palette, 162
radio buttons, 20
text, 15, 246
awindow, 10
Selector tool, in Image Viewer, 346
sending mail messages in MIME or Sun
Mail Tool format, 200
session
changing startup, 172
current, 40, 172
determining for each login, 41
home, 40, 172
language-specific, 375
shortcut keys, 25, 364
in Text Editor, 249
shortcuts, keyboard, Mailer, 216
signatures for mail messages
adding to specific messages, 198
automatically adding to all
messages, 198
creating, 198
size of image, displaying, 345
sizes of icons, 334
sliders, 19, 21
Snapshot
hiding dialog box during snap, 361
starting, 359
snapshot
delaying, 361
of region, 360
of screen, 360
of window, 360
sort order

Index

changing File Manager, 133
of objects, 133
sorting
files and folders, 134
mail messages, 179
special characters
in Terminal, 324 to 325
in Text Editor, 245
spelling, correcting in Text Editor, 253
standalone Appointment Editor, 300
starting
Application Manager, 143
applications in Terminal
window, 310
Calendar, 268
Calendar from command line, 268
Command Line Login Mode, 40
File Manager, 92
home session automatically at
login, 41
Icon Editor, 328
Image Viewer from command
line, 342
Image Viewer from Front Panel, 342
Image Viewer from Workspace
Programs menu, 342
Mailer, 176
new icon, 330
Print Manager, 227 to 228
Printer Jobs, 229
Snapshot, 359
Style Manager, 159
Terminal, 306 to 309
terminal emulator with specific
language, 377
Text Editor with specific
language, 376
startup
changing session, 172
Startup dialog box, 172 to 173
status line
in Text Editor window, 239
Style Manager
opening, 159

419



starting, 6, 159

Window Behavior setting, 3
Style Manager control, 73
subdirectories

changing to, 106
subfolders

changing to, 106
submenu, Programs, 28
subpanel

adding, 84

deleting, 84
subpanels, 64

adding, 84

deleting, 84

displaying, 66

moving, 70

opening and closing, 66
Sun Mail Tool format, email in, 200
symbolic link, creating, 105

T

tab groups, 364
Tab key, 365
templates
creating for mail messages, 194
using for mail messages, 194
Terminal
bell options, 317 to 319
color control in, 317
control characters in, 324 to 325
cursor options, 315 to 316
entering commands in window, 310
Global Options dialog box, 314
keyboard options, 320 to 322
removing menu bar from
window, 313
removing scroll bar from
window, 314
resizing window, 311
restoring menu bar to window, 313
restoring scroll bar to window, 314
running on another system, 311 to
312
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screen control options, 322 to 324
scroll behavior in, 317
setting language through, 376
starting, 306 to 309
starting applications in window, 310
starting Icon Editor from, 329
stopping, 309
Terminal Options dialog box, 320
Terminal control, 76
terminal emulator
See also Terminal
changing the default, 325
default, 306
definition of, 305
language-specific, 377
running applications from, 155
Terminal window
opening in current directory from File
Manager, 107
text
alignment, 263
automatic wrapping, 244
copying, 251
copying and pasting among
windows, 15
copying in Terminal window, 310
cutting and pasting, 251
deleting, 24, 250
deselecting, 16
dragging, 260
dropping, 260
editing, 237
editing in a field, 24
entering, 244
entering in a field, 23
finding in Text Editor, 261
justifying, 263
pasting, 16
pasting in Terminal window, 311
selecting, 15, 24, 246
selecting characters, 24
selecting lines, 24
selecting words, 24
Text Editor
closing, 238



cursor keys, 245
drag and drop in, 260
editing keys, 248
entering text, 244
formatting document in, 262, 263
Front Panel control, 238
menu shortcut keys, 249
opening document, 240
printing document, 263
saving document, 240
saving document to new file, 240
saving document to original file, 241
special characters and, 245
Spelling Checker, 253, 259
Spelling Checker, customizing
dictionaries, 255, 259

starting, 238
starting with specific language, 376
status line, 239
UNIX (Emacs) key bindings, 249
used in other applications, 265
using Undo in, 251
window, 239
word wrap, 244
Wrap To Fit option, 244

Text Editor control, 72, 76

text fields, 19

three-month mini-calendar
Calendar Day view, 270

time zone, in Calendar, 295

title bar, 10

To Do items
changing, 278
deleting, 278

inserting, 277
marking completed, 278, 279
pending, 279
scheduling, 277
setting due date, 277
To Do list
displaying, 278
printing, 280
Tool bar, Calendar, 268
tool bar, Calendar, 269

Index

Toolbar in Mailer, configuring, 214
tools
Calendar, 296
topic display area, 47
topic tree, 47
TopShadow, 335
Trash Can
emptying, 109
opening, 109
restoring objects from, 109
using, 109
Trash Can control, 73
tree view, in File Manager, 130 to 132

U

Undo, in Text Editor, 251
UNIX key bindings, 249
unlocking the display, 33
user registration, 146

Vv

version 3 Calendar
convert to version 4, 298
viewing
See also displaying
mail attachments, 209
mail messages, 178
views
Calendar, 270
controlling File Manager, 129
of mailboxes, 188 to 190

w

Week grid, Calendar Week view, 271
Week view
Calendar, 271
changing time boundaries, 289
Week grid, 271
width of image, displaying, 345
wildcards
for finding files, 127
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422

to search help index, 52
Window menu

displaying, 26

items, 26

keyboard usage, 370
Window menu button, 10, 12, 26
windows

bringing forward, 15

closing, 12

copying and pasting text, 15

determining how to display

active, 171

dragging, 14

focus policy for, 171

frame controls, 9

icon display policy for, 172

icons, 4

icons, moving, 13

icons, restoring, 13

moving, 13

opening, 11

placing in other workspaces, 17, 371

policy for activating, 171

removing, 12

resize border, 10

resizing, 14, 368

restoring from an icon, 13, 367

scroll bar, 21

scrolling, 21, 368

selecting with keyboard, 367

taking a snapshot of, 360

title bar, 10

turning into an icon, 12, 367
word wrap, 244

workspace
adding, 86
deleting, 86

renaming, 86

workspace backdrop
putting file or folder on, 125
selecting, 167

Workspace menu, 27
workspace objects, 8
workspace switch, 64, 65
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customizing, 86
customizing controls in, 86 to 89
help for, 69
switch area of, 68
workspaces
adding, 86
bringing windows forward in, 15
changing colors of, 162
customizing, 85
deleting, 86
displaying, 16
keyboard navigation, 371
placing windows in, 17
removing files or folders from, 126
removing objects from, 126
renaming, 18, 69, 370
world access
to grant access to anyone, 291, 292
Wrap to Fit, turning on and off, 244

X

XLFD, 377

XmNinputMethod resource, 380
XmNpreeditType resource, 380
XMODIFIERS environment variable, 380
xmodmapcommand, 380

Y

Year view, 273



