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Chapter 1
Installing Forte Express
Forte provides a platform-specific installation program to install Forte Express on each 
Forte node type. The installation programs and the Forte source files they install are 
included with the Forte Express CD.

This Express Installation Guide provides instructions for:

■ installing Forte Express Release 2.5 for the first time onto your existing Forte Release 3 
installation

■ upgrading to Express Release 2.5
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Conventions
This manual uses standard Forte documentation conventions in specifying command 
syntax and in documenting TOOL code.

Command Syntax Conventions
The specifications of command syntax in this manual use a “brackets and braces” format. 
The following table describes this format: 

Format Description

bold Bold text is a reserved word; type the word exactly as shown.

italics Italicized text is a generic term that represents a set of options or values. Substitute an 
appropriate clause or value where you see italic text.

UPPERCASE Uppercase text represents a constant. Type uppercase text exactly as shown.

underline Underlined text represents a default value. 

vertical bars | Vertical bars indicate a mutually exclusive choice between items. See braces and brackets, 
below.

braces { } Braces indicate a required clause. When a list of items separated by vertical bars is enclosed in 
braces, you must enter one of the items from the list. Do not enter the braces or vertical bars.

brackets [ ] Brackets indicate an optional clause. When a list of items separated by vertical bars is enclosed 
by brackets, you can either select one item from the list or ignore the entire clause. Do not 
enter the brackets or vertical bars.

ellipsis … The item preceding an ellipsis may be repeated one or more times. When a clause in braces is 
followed by an ellipsis, you can use the clause one or more times. When a clause in brackets is 
followed by an ellipsis, you can use the clause zero or more times. 
Forte Express Installation Guide



Before Installing Forte Express 7
Before Installing Forte Express
The Forte Express software comes on the Forte Express CD. You will need a CD-ROM drive 
accessible to your target installation node to install Express from the CD.

To install Forte Express Release 2.5, you must already have installed Forte System Software 
Release 3 on your target node. The Express installer programs will not execute on machines 
without an installation of the Forte Release 3 system software.

For a list of platforms that the Forte system software supports, see the platform matrix at 
http://www.forte.com/support/platforms.html.

Upgrading If you are upgrading Express, see “Upgrading Express” on page 11.
Chapter 1Installing Forte Express
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Understanding the Forte Express Directory Structure
The figure below shows a typical Forte System Software directory structure. The 
FORTE_ROOT structure includes a userapp directory, where the Forte Express installer 
places Forte Express files. In the userapp directory, the Express installer creates an express 
directory. Within the express directory, the installer creates a clx directory, representing the 
compatibility level of the Express installation, and containing the Forte Express image 
repositories.

The Forte Express installer adds a compatibility level directory for each successive version 
of Forte Express you install, rather than replacing existing directories. This way, you can 
refer to a prior Express release when necessary. For example, when you install Forte Express 
for the first time, the installer creates a cl0 directory; when you install a succeeding version 
of Express, the installer creates a cl1 compatibility level directory, and then a cl2 directory, 
and so on.

Figure 1 Typical Forte System Software Directory Structure with Forte Express

Forte Express Directories

Forte Express compatibility
level directories—cl1, cl2, etc.

Directory for Express messages

sysdata
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Installing Forte Express for the First Time
You install Forte Express from the Forte Express CD. The Forte Express CD provides the 
Forte Express software for every platform Forte supports. The CD meets the ISO 9660 
standard, meaning that it is readable on UNIX, OpenVMS, and Windows platforms.

The CD contains platform-specific installation programs. Each directory on the Express 
CD, as shown in Figure 1 on page 8, contains the Forte Express software and installer for its 
respective platform. The ALL_UNIX directory, for example, contains the Express software 
and installer for all the UNIX platforms Forte supports.

UNIX
� To install Forte Express on a UNIX node:

1 Mount the Forte Express CD.

2 Set your current directory to the ALL_UNIX directory on the CD.

Depending on your platform, the directory or command names may be in upper or 
lower case.

3 Type the following command.

This starts the Express installer for UNIX, which prompts you through the Express 
installation process.

Windows
� To install Forte Express on a Windows node:

1 Mount the Forte Express CD.

2 From the Program Manager, select File > Run.

This raises the Run dialog box.

3 Type the following command in the Run dialog box and click OK.

./exinstal.sh

F:\PC_NT\SETUP
Chapter 1Installing Forte Express
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VAX/OpenVMS or Alpha/OpenVMS
� To install Forte Express on a VAX/OpenVMS or an Alpha/OpenVMS node:

1 Mount the Forte Express CD.

Running the following DCL script will assist with the mount command for the CD-ROM. 

2 Start the Forte Express installer, VMSINSTAL, using FTEXP as the saveset name.

Take the following commands as an example.

$! Forte_CD.com:

$!   Mount a Forte software distribution CD-ROM on an

$!   OpenVMS node without specifying the volume name.

$! usage:

$!   @Forte_CD device_name 

$! example:

$!   @FORTE_CD DKA600: 

$!

$ devnam = f$getdvi(p1,"DEVNAM")

$ mount/noassist/override=identification ’devnam’

$ volume = f$getdvi(devnam,"VOLNAM")

$ dismount ’devnam’

$ mount/system/media=cdrom/undefined_fat=(FIXED:NONE:32256) -

 ’devnam’ ’EXPRESS’ cd

for VAX/OpenVMS $ SYS$UPDATE:VMSINSTAL FTEXP CD_ROM_device_name: [VAX_VMS]

for Alpha/OpenVMS $ SYS$UPDATE:VMSINSTAL FTEXP CD_ROM_device_name: [AXP_VMS]
Forte Express Installation Guide
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Upgrading Express
When you conduct an Express installation atop an existing version of Express, the installer 
upgrades the installation. The Express installer upgrades an Express installation in part by 
integrating new versions of the following projects into the system baseline of your 
development repository:

■ AppModel

■ ExpressDBBrowser

■ ExpressDomains

■ ExpressServices

■ ExpressWindows

Caution To integrate these projects, the installer must check out all the classes in each of the 
projects listed above. If you have any classes in these projects checked out already, then the 
upgrade procedure will fail. You must undo the checkouts for all classes in the projects 
before starting the upgrade procedure.

Starting Forte Express Release 2.5 
with Non-Release 2 Projects

You may have Express projects in your workspace that are not Express Release 2.5 
projects if:

■ you created projects with Forte before purchasing Forte Express

■ you created projects with earlier releases of Forte Express

In these cases, you must upgrade your workspace and your repository. 

Upgrading Your Repository
� To upgrade your repository:

1 Start the Express Release 2.5 application.

Express prompts you with the following dialog:

2 Click Yes to tell Express to proceed with the upgrade. 

Express then prompts you with another dialog:

3 Click Yes to tell Express to proceed with upgrading the repository.

Progress messages appear until the upgrade is complete.
Chapter 1Installing Forte Express
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Updating Your Workspace
If you share with others a repository of Express projects created with earlier releases of 
Express, and someone in your group has already upgraded it to Release 2.5, you need only 
update your own workspace.

� To determine whether you need to update your workspace:

1 Start the Express Release 2.5 application.

2 Choose the File > Open Workspace command.

If your workspace needs updating, Express prompts you with the following dialog:

3 Click OK to close the window.

� To update your workspace:

1 In the Repository Workspace, choose File > Update Workspace command.
Forte Express Installation Guide
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The Forte Documentation Set
Forte produces a comprehensive documentation set describing the libraries, languages, 
workshops, and utilities of the Forte Application Environment. The complete Forte Release 
3 documentation set consists of the following manuals in addition to comprehensive 
online Help.

Forte 4GL
■ A Guide to the Forte 4GL Workshops

■ Accessing Databases

■ Building International Applications

■ Escript and System Agent Reference Manual

■ Forte 4GL Java Interoperability Guide

■ Forte 4GL Programming Guide

■ Forte 4GL System Installation Guide

■ Forte 4GL System Management Guide

■ Fscript Reference Manual

■ Getting Started With Forte 4GL

■ Integrating with External Systems

■ Programming with System Agents

■ TOOL Reference Manual

■ Using Forte 4GL for OS/390

Forte Express
■ A Guide to Forte Express

■ Customizing Forte Express Applications

■ Forte Express Installation Guide

Forte WebEnterprise and WebEnterprise Designer
■ A Guide to WebEnterprise

■ Customizing WebEnterprise Designer Applications

■ Getting Started with WebEnterprise Designer

■ WebEnterprise Installation Guide
Chapter 1Installing Forte Express
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Forte Example Programs
In this manual, we often include code fragments to illustrate the use of a feature that is 
being discussed. If a code fragment has been extracted from a Forte example program, the 
name of the example program is given after the code fragment. If a major topic is 
illustrated by a Forte example program, reference will be made to the example program in 
the text.

These Forte example programs come with the Forte product. They are located in 
subdirectories under $FORTE_ROOT/install/examples. The files containing the examples 
have a .pex suffix. You can search for TOOL commands or anything of special interest with 
operating system commands. The .pex files are text files, so it is safe to edit them, though 
you should only change private copies of the files. 
Forte Express Installation Guide
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Viewing and Searching PDF Files
You can view and search 4GL PDF files directly from the documentation CD-ROM, store 
them locally on your computer, or store them on a server for multiuser network access. 

Note You need Acrobat Reader 4.0+ to view and print the files. Acrobat Reader with Search is 
recommended and is available as a free download from http://www.adobe.com. If you do 
not use Acrobat Reader with Search, you can only view and print files; you cannot search 
across the collection of files.

� To copy the documentation to a client or server:

1 Copy the fortedoc directory and its contents from the CD-ROM to the client or server 
hard disk.

You can specify any convenient location for the fortedoc directory; the location is not 
dependent on the Forte distribution.

2 Set up a directory structure that keeps the fortedoc.pdf and the 4gl directory in the same 
relative location.

The directory structure must be preserved to use the Acrobat search feature.

Note To uninstall the documentation, delete the fortedoc directory.

� To view and search the documentation:

1 Open the file fortedoc.pdf, located in the fortedoc directory.

2 Click the Search button at the bottom of the page or select Edit > Search > Query.

3 Enter the word or text string you are looking for in the Find Results Containing Text field 
of the Adobe Acrobat Search dialog box, and click Search.

A Search Results window displays the documents that contain the desired text. If more 
than one document from the collection contains the desired text, they are ranked for 
relevancy.

Note For details on how to expand or limit a search query using wild-card characters and 
operators, see the Adobe Acrobat Help.

4 Click the document title with the highest relevance (usually the first one in the list or 
with a solid-filled icon) to display the document.

All occurrences of the word or phrase on a page are highlighted. 

5 Click the buttons on the Acrobat Reader toolbar or use shortcut keys to navigate 
through the search results, as shown in the following table: 

6 To return to the fortedoc.pdf file, click the Homepage bookmark at the top of the 
bookmarks list.

7 To revisit the query results, click the Results button at the bottom of the fortedoc.pdf 
home page or select Edit > Search > Results.

Toolbar Button Keyboard Command

Next Highlight Ctrl+]

Previous Highlight Ctrl+[

Next Document Ctrl+Shift+]
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