|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 11 Express 11/10|
- file system debugger
fsdb [-F FSType] [-V] [-o FSType-specific_options] special
fsdb is a file system debugger that allows for the manual repair of a file system after a crash. special is a special device used to indicate the file system to be debugged. fsdb is intended for experienced users only. FSType is the file system type to be debugged. Since different FSTypes have different structures and hence different debugging capabilities, the manual pages for the FSType-specific fsdb should be consulted for a more detailed description of the debugging capabilities.
Specify the FSType on which to operate. The FSType should either be specified here or be determinable from /etc/vfstab by matching the special with an entry in the table, or by consulting /etc/default/fs.
Echo the complete command line, but do not execute the command. The command line is generated by using the options and arguments provided by the user and adding to them information derived from /etc/vfstab. This option may be used to verify and validate the command line.
Specify FSType-specific options.
See largefile(5) for the description of the behavior of fsdb when encountering files greater than or equal to 2 Gbyte ( 231 bytes).
default local file system type. Default values can be set for the following flags in /etc/default/fs. For example: LOCAL=ufs
The default partition for a command if no FSType is specified.
list of default parameters for each file system
See attributes(5) for descriptions of the following attributes:
This command may not be supported for all FSTypes.