|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 11 Express 11/10|
- lists devices based on criteria
getdev [-ae] [criteria]... [device]...
getdev generates a list of devices that match certain criteria. The criteria includes a list of attributes (given in expressions) and a list of devices. If no criteria are given, all devices are included in the list.
Devices must satisfy at least one of the criteria in the list unless the -a option is used. Then, only those devices which match all of the criteria in a list will be included.
Devices which are defined on the command line and which match the criteria are included in the generated list. However, if the -e option is used, the list becomes a set of devices to be excluded from the list. See OPTIONS and OPERANDS.
The following options are supported:
Specifies that a device must match all criteria to be included in the list generated by this command. The option has no effect if no criteria are defined.
Specifies that the list of devices which follows on the command line should be excluded from the list generated by this command. Without the -e the named devices are included in the generated list. The flag has no effect if no devices are defined.
The following operands are supported:
Defines the criteria that a device must match to be included in the generated list. criteria is specified by expressions.
There are four possible expression types which the criteria specified in the criteria argument may follow:
Selects all devices whose attribute attribute is defined and is equal to value.
Selects all devices whose attribute attribute is defined and does not equal value.
Selects all devices which have the attribute attribute defined.
Selects all devices which do not have the attribute attribute defined.
See the putdev(1M) manual page for a complete listing and description of available attributes.
Defines the devices which should be included in the generated list. This can be the pathname of the device or the device alias.
The following exit values are returned:
Command syntax was incorrect, invalid option was used, or an internal error occurred.
Device table could not be opened for reading.
See attributes(5) for descriptions of the following attributes: