|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 11 Express 11/10|
- search HAL global device list
hal-find-by-capability --capability capability [--help] [--verbose] [--version]
hal-find-by-property --key key --string value [--help] [--verbose] [--version]
The hal-find commands, hal-find-by-capability and hal-find-by-property, search the Hardware Abstraction Layer (HAL) device list by specified criteria and displays results on the standard output. hal-find-by-capability searches by capability, such as volume or block. hal-find-by-property searches by property, such as block.is_volume or volume.disc.has_audio.
The following options are supported:
HAL device capability to search for.
Display list of options.
The key to the property that is the basis of the search.
The string value associated with the property that is the basis of the search.
Display version and exit.
See attributes(5) for descriptions of the following attributes: