|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 11 Express 11/10|
- generate a self-signed certificate for secure communication
/usr/bin/imqkeytool [-broker] [-servlet keystore_location]
The imqkeytool utility generates a self-signed certificate for secure communication. The certificate can be used by a broker instance to establish a secure connection with a client, or by a Message Queue-supplied HTTPS servlet to establish a secure connection with a broker instance. An HTTPS servlet is an SSL-enabled varient of the HyperText Transfer Protocol that establishes a secure connection with a broker instance.
Without an option, imqkeytool generates a self-signed certificate for a broker instance.
imqkeytool uses command line options to specify whether the certificate is used by a broker instance or by a servlet.
The following options are supported:
Generate a self-signed certificate for the broker and places it in the Message Queue keystore. All broker instances running on a system must use the same certificate.
Display usage help. Do not execute anything else on the command line.
Generate a self-signed certificate for an HTTPS servlet and places it in keystore_location.
keystore_location refers to the location of the keystore. You should move this keystore to a location where it is accessible and readable by the Message Queue HTTPS servlet to establish a secure connection with a broker.
The following environment variables affect the execution of this command:
Specify the Java 2 compatible runtime. When this environment variable is not set it defaults to /usr/j2se.
The following exit values are returned:
An error occurred.
Contains Message Queue keystore in which imqkeytool stores a self-signed certificate for brokers.
See attributes(5) for descriptions of the following attributes:
Sun Java System Message Queue Administrator's Guide