|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 11 Express 11/10|
- host key table (keytab) manipulation utility
/usr/sbin/k5srvutil operation [-ik] [-f filename]
The k5srvutil command allows a system manager to list or change keys currently in his keytab or to add new keys to the keytab.
The operand operation must be one of the following:
Lists the keys in a keytab, showing version number and principal name.
Changes all the keys in the keytab to new randomly-generated keys, updating the keys in the Kerberos server's database to match those by using the kadmin protocol. If a key's version number does not match the version number stored in the Kerberos server's database, the operation fails. The old keys are retained so that existing tickets continue to work. If the -i flag is specified, k5srvutil prompts for yes or no before changing each key. If the -k option is used, the old and new keys are displayed.
Deletes keys that are not the most recent version from the keytab. This operation should be used at some point after a change operation to remove old keys. If the -i flag is specified, k5srvutil asks the user whether the old keys associated with each principal should be removed.
Deletes particular keys in the keytab, interactively prompting for each key.
In all cases, the default keytab file is /etc/krb5.keytab file unless this is overridden by the -f option.
k5srvutil uses the kadmin(1M) program to edit the keytab in place. However, old keys are retained, so they are available in case of failure.
The following options are supported:
Specify a keytab file other than the default file, /etc/krb5.keytab.
Prompts user before changing keys when using the change or delold operands.
Displays old and new keys when using the change operand.
See attributes(5) for descriptions of the following attributes: