|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 11 Express 11/10|
- create an NTFS file system
mkntfs [options] device [number_of_sectors]
mkntfs [-C] [-c cluster-size] [-F] [-f] [-H heads] [-h] [-I] [-L volume-label] [-l] [-n] [-p part-start-sect] [-Q] [-q] [-S sectors-per-track] [-s sector-size] [-T] [-V] [-v] [-z mft-zone-multiplier] [--debug] device [number-of-sectors]
The mkntfs utility is used to create an NTFS file system on a device, usually a disk partition, or file. The device operand is the special file corresponding to the device; for example, /dev/dsk/c0d0p0. The number-of-sectors operand is the number of blocks on the device. If omitted, mkntfs automatically figures the file system size.
Supported options are listed below. Most options have both single-letter and full-name forms. Multiple single-letter options that do not take an argument can be combined. For example, -fv is the equivalent of -f -v. A full-name option can be abbreviated to a unique prefix of its name.
Options are divided among basic, advanced, output, and help options, as listed below.
Enable compression on the volume.
Perform quick (fast) format. This option skips both zeroing of the volume and bad sector checking.
Set the volume label for the filesystem to string.
Causes mkntfs to not actually create a file system, but display what it would do if it were to create a file system. All formatting steps are carried out except the actual writing to the device.
Specify the size of clusters in bytes. Valid cluster size values are powers of two, with at least 256, and at most 65536, bytes per cluster. If omitted, mkntfs uses 4096 bytes as the default cluster size.
Note that the default cluster size is set to be at least equal to the sector size, as a cluster cannot be smaller than a sector. Also, note that values greater than 4096 have the side effect that compression is disabled on the volume. This is due to limitations in the NTFS compression algorithm used by Windows.
Force mkntfs to run, even if the specified device is not a block special device, or appears to be mounted.
Specify the number of heads. The maximum is 65535 (0xffff). If omitted, mkntfs attempts to determine the number of heads automatically. If that fails a default of 0 is used. Note that specifying num is required for Windows to be able to boot from the created volume.
Disable content indexing on the volume. This option is only meaningful on Windows 2000 and later. Windows NT 4.0 and earlier ignore this, as they do not implement content indexing.
Specify the partition start sector. The maximum is 4294967295 (232-1). If omitted, mkntfs attempts to determine sectorautomatically. If that fails, a default of 0 is used. Note that specifying sector is required for Windows to be able to boot from the created volume.
Specify the number of sectors per track. The maximum is 65535 (0xffff). If omitted, mkntfs attempts to determine the number of sectors-per-track automatically and if that fails a default of 0 is used. Note that sectors-per-track is required for Windows to be able to boot from the created volume.
Specify the size of sectors in bytes. Valid sector size values are 256, 512, 1024, 2048, and 4096. If omitted, mkntfs attempts to determine the sector-size automatically. If that fails, a default of 512 bytes per sector is used.
Fake the time to be 00:00:00 UTC, Jan 1, 1970, instead of the current system time. This can be useful for debugging purposes.
Set the master file table (MFT) zone multiplier, which determines the size of the MFT zone to use on the volume. The MFT zone is the area at the beginning of the volume reserved for the MFT, which stores the on-disk inodes (MFT records). It is noteworthy that small files are stored entirely within the inode; thus, if you expect to use the volume for storing large numbers of very small files, it is useful to set the zone multiplier to a higher value. Although the MFT zone is resized on the fly as required during operation of the NTFS driver, choosing an optimal value reduces fragmentation. Valid values are 1, 2, 3, and 4. The values have the following meaning:
MFT zone MFT zone size multiplier (% of volume size) 1 12.5% (default) 2 25.0% 3 37.5% 4 50.0%
Includes the verbose output from the -v option, as well as additional output useful for debugging mkntfs.
Verbose execution. Errors are written to stderr, no output to stdout occurs at all. Useful if mkntfs is run in a script.
Show a list of options with a brief description of each one.
Display the mkntfs licensing information and exit.
Display the mkntfs version number and exit.
See attributes(5) for descriptions of the following attributes:
mkntfs was written by Anton Altaparmakov, Richard Russon, Erik Sornes and Szabolcs Szakacsits.