|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 11 Express 11/10|
- return network configuration information
The netstrategy command determines the network configuration strategy in use on a system and returns information in a form that is easily consumable by a script. The command returns three tokens:
<root filesystem type> <primary interface> <network config strategy>
These tokens are described as follows:
Type of filesystem that contains the bootable kernel, as would be specified in the fstype column of the mnttab(4).
Name of the primary network interface. For a diskless machine, this is the interface used to load the kernel.
The means by which a system obtains its IP address for booting. This can be one of rarp, dhcp, or none.
The netstrategy command is not intended for use on a command line.
The netstrategy command has no options.
An error occurred.
See attributes(5) for descriptions of the following attributes: