|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 11 Express 11/10|
- show machine, software revision, and patch revision information
/usr/bin/showrev [-a] [-p | -p -R root_path] [-w] [-c command] [-s hostname]
showrev displays revision information for the current hardware and software. With no arguments, showrev shows the system revision information including hostname, hostid, release, kernel architecture, application architecture, hardware provider, domain, and kernel version.
If a command is supplied with the -c option, showrev shows the PATH and LD_LIBRARY_PATH and finds out all the directories within the PATH that contain it. For each file found, its file type, revision, permissions, library information, and checksum are printed as well.
The following options are supported:
Print all system revision information available. Window system and patch information are added.
Print the revision information about command.
Print only the revision information about patches.
Define the full path name of a directory to use as the root_path. By specifying the root path, showrev retrieves the revision information about the patch from package system information files located under a directory tree starting at root_path. The root_path can be specified when retrieving installed patch information in a client from a server, for example, /export/root/client1.
Note - The root file system of any non-global zones must not be referenced with the -R option. Doing so might damage the global zone's file system, might compromise the security of the global zone, and might damage the non-global zone's file system. See zones(5).
Perform this operation on the specified hostname. The -s operation completes correctly only when hostname is running Solaris 2.5 or compatible versions.
Print only the OpenWindows revision information.
Varies, based on flags passed. If no flags are passed, output similar to the following appears:
Hostname: system1 Hostid: 7233808e Release: 5.10 Kernel architecture: sun4u Application architecture: sparc Hardware provider: Sun_Microsystems Domain: a.network.COM Kernel version: SunOS 5.10 generic
The following error values are returned:
An error occurred.
See attributes(5) for descriptions of the following attributes:
For the -s option to work when hostname is running a version of Solaris prior to 2.5, the Solstice AdminSuite must be installed on hostname.