|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 11 Express 11/10|
- xVM control daemon
The xend daemon provides control of the Solaris xVM domains on a system. Its administrative interface is xm(1M).
The xend service is managed by the service management facility, smf(5), under the service identifier:
Specifies the default network interface used for guest domain networking. By default, the empty string is specified, in which case the first interface listed in the output of dladm(1M) show-link is used. If you need to use a different interface, for example, bge0, you should change this property appropriately.
The number of physical CPUs to be used for the virtual CPUs of the control domain (dom0). The default of 0 implies that each virtual CPU will be placed on its own physical CPU where possible. Note that physical CPUs can still be shared between dom0 and other domains unless they are configured not to do so.
The minimum amount of memory guaranteed to the control domain (dom0). The default is 196 (MB). Using the xVM milestone service, svc:/milestone/xvm, or the Hypervisor Visual Panel will change this value to whichever is lower, half of system memory or 2048 (MB).
Controls whether a domain core dump should be created if a domain crashes. Dumps are generated in /var/xen/dump and can be processed with mdb(1). The default is true.
Sets the password required by any client connecting to a VNC session for a guest domain. Defaults to "" (no password). VNC password authentication is not secure and should not be used for securing guest domain consoles.
Address to listen on for VNC connections. By default this is 127.0.0.1, which has a special meaning: only users or processes with the PRIV_VIRT_MANAGE privilege are allowed to connect, and they must be logged on locally. If you set this to any other value, then anyone will be able to connect to VNC sessions, regardless of authorization.
Address that xend listens on for relocation requests. If blank or not present, all interfaces are used. The default is 127.0.0.1.
A space-separated list of regular expressions. If the host name of a system matches any one of the given regular expressions, it is allowed to connect and interact with the relocation server, if the server has been enabled by the xend-relocation-server property. The default is ^localhost$.
Controls whether the xend relocation server (for live migration) should listen for relocation requests on TCP port 8002. The default is true.
Controls whether the legacy HTTP server interface should be provided on the local machine. The default is true.
Example 1 Modifying an Existing Property
Use the following sequence of commands to modify an existing xend property.
# svccfg -s svc:/system/xvm/xend:default listprop # svccfg -s svc:/system/xvm/xend:default setprop config/dom0-cpus = 1 # svcadm refresh svc:/system/xvm/xend:default
Example 2 Enabling Live Migration
By default, xend listens only on the loopback address for requests from the localhost. If you want to allow other machines to live migrate to the local machine, you need to configure xend appropriately. For example:
# svccfg -s svc:system/xvm/xend svc:/system/xvm/xend> setprop config/xend-relocation-address = "" svc:/system/xvm/xend> setprop config/xend-relocation-hosts-allow = \ "^flax$ ^localhost$" svc:/system/xvm/xend> end # svcadm refresh svc:system/xvm/xend:default && \ svcadm restart svc:system/xvm/xend:default
Log files for xend.
Domain crash dump files.
See attributes(5) for descriptions of the following attributes: