|Skip Navigation Links|
|Exit Print View|
|man pages section 4: File Formats Oracle Solaris 11 Express 11/10|
- configuration properties for Solaris Network Data Management Protocol (NDMP) server
The behavior of the Solaris NDMP server is specified by property values that are stored in the Service Management Facility, smf(5).
An authorized user can use the ndmpadm(1M) command to set global values for these properties in SMF.
You can set the following properties by using the ndmpadm set command:
Backup the files marked as quarantined by AV. Acceptable values are yes or no. The default is no.
Set the Direct Access Recovery mode. Acceptable values are yes or no. The default is no.
Set the debug level. The debug-level can be set to either 0 (off) or 1 (on). The default is 0.
The path to which to save the debug log. The default is /var/ndmp.
Choose either SystemV or BSD tape drives for the data management application. Valid values are sysv and bsd. The default is sysv.
Enable or disable backing up the directories containing modified files or directories in dump(1) backup format. Acceptable values are yes or no. The default is no.
Determines whether the change timestamp (ctime) of files and directories is used to determine whether a file should be backed up in level backup. If this parameter is set to yes, only the modification time (mtime) of the file or directory determines whether it should be backed up. Acceptable values are yes or no. The default value is no.
Restore quarantined files on top of current files if they already exist. Acceptable values are yes or no. The default value is no.
Restore the files that had been marked as quarantined by AV and are backed up. Acceptable values are yes or no. The default value is no.
Enable or disable backing up the directories containing modified files or directories in tar(1) backup format. Acceptable values are yes or no. The default value is no.
Set the maximum sequence number for subsequent token-based incremental backup in NDMP-V4. The default value is 9. There are two limits for this value: soft-limit, which is 59, and hard-limit, equal to 64. If the token sequence number, passed by the DMA, is between the soft and hard limits, a warning message is issued to the DMA. The token sequence number can never exceed the hard-limit value.
Set the maximum active NDMP protocol version. Valid values are currently 2, 3, and 4. The default is 4.
Override the value of ZFS_FORCE. yes forces a value of y. no forces a value of n. By default, zfs-force-override has a value of off and does not override ZFS_FORCE.
The following property can only be set when using the ndmpadm enable or ndmpadm disable command:
Sets the password encryption type for the authentication of local users. Valid values are cram-md5 or cleartext.
See attributes(5) for descriptions of the following attributes: