JavaScript is required to for searching.
Skip Navigation Links
Exit Print View
Oracle Java CAPS BPEL Designer and Service Engine User's Guide     Java CAPS Documentation
search filter icon
search icon

Document Information

BPEL Designer and Service Engine User's Guide


The JBI Runtime Environment

To View the Installed or Deployed JBI Components

The BPEL Designer

The BPEL Service Engine

The Composite Application Project

BPEL Designer and Service Engine Features

BPEL Service Engine Features

Supported WS-BPEL 2.0 Constructs

BPEL Service Engine and Oracle SOA Suite

Understanding the BPEL Module Project

Creating Sample Processes in the BPEL Designer

A Synchronous Sample Process

An Asynchronous Sample Process

Travel Reservation Service Sample

Creating a Sample BPEL Module Project

Navigating in the BPEL Designer

The BPEL Designer Window

The BPEL Editor Views

Cloning Document Views

Element Documentation and Report Generation

Creating Documentation for an Element

Generation a Report

The Navigator Window

XML View

Logical View

The Properties Window


Collapsing and Expanding Process Blocks in the Diagram

To Collapse and Expand a Process Block

Zooming In and Out of the Diagram

Printing BPEL Diagrams and Source Files

To Preview and Print a BPEL Diagram or Source File

To Customize Print Options

To Customize Page Settings

Creating a BPEL Module Project

Starting GlassFish

To Check the Status of the GlassFish V2 Application Server in the NetBeans IDE

To Register the GlassFish V2 Application Server with the NetBeans IDE

To Start the GlassFish V2 Application Server in the NetBeans IDE

Creating a new BPEL Module Project

To Create a BPEL Module Project

Creating the XML Schema and the WSDL Document

Creating a BPEL Process Using the BPEL Designer

To Create the BPEL Process

Creating a Composite Application Project

To Create a New Composite Application Project

Building and Deploying the Composite Application Project

To Build and Deploy the Composite Application Project

Testing the Composite Application

Test the HelloWorldApplication Composite Application Project


Developing a BPEL Process Using the Diagram

The BPEL Diagram

Configuring Element Properties in the Design View

Finding Usages of BPEL Components

To Find Usages of a BPEL Component

Saving Your Changes

The BPEL Designer Palette Elements


The Process Element

Adding BPEL Components to the Process

BPEL Process Properties

The Web Service Elements

Using the Invoke Element


Invoke Properties


Using the Receive Element


Receive properties


Using the Reply Element


Reply Properties


Using the Partner Link Element

Partner Link Types and Roles


Partner Link Properties

Partner Link Layout

Dynamic Partner Links and Dynamic Addressing

The Basic Activities

Using the Assign Element


Assign Element Properties

Using the JavaScript Element


JavaScript Element Properties

Using the Validate Element


Validate Element Properties

Using the Empty Element


Empty Element Properties

Using the Wait Element


Wait Element Properties

Using the Throw Element


Throw Element Properties

Using the Rethrow Element


ReThrow Element Properties

Using the Exit Element


Exit Element Properties

Using the Compensate Element


Compensate Element Properties

Using the CompensateScope Element


CompensateScope Element Properties

The Structured Activities

Using the If Element


Adding an Else If Branch to the If Element

Adding an Else Branch to the If Element

Reordering Else If Branches

If Element Properties

Using the While Element


While Element Properties

Using the Repeat Until Element


Repeat Until Element Properties

Using the For Each Element


For Each Element Properties

Using the Pick Element


Adding an On Alarm branch

Pick Element Properties

Using the Flow Element


Adding Branches to the Flow Element

Changing the Order of Elements inside Flow

Flow Element Properties

Using the Sequence Element


Adding Child Activities to the Sequence

Changing the Order of Elements inside Sequence

Sequence Element Properties

Using the Scope Element


Scope Element Properties


To Define a Variable

To Edit a Variable

Using the BPEL Mapper

About the BPEL Mapper

To Open the BPEL Mapper Window

Creating BPEL Mappings

To Create a Mapping Without Using any Functions

To Use a Function in a Mapping

To Delete a Link or Function in a Mapping

Working with Predicates

To Create a Predicate

To Edit a Predicate

To Delete a Predicate

XPath Function Reference






Date & Time


Mapping Examples

Assign Activity Scenario

If Activity Scenario

Predicate Scenario

Using Type Cast and Pseudo-Components

Type Cast


Type Cast and Validation

Type Cast and Pseudo Component Limitations

Using Normalized Message Properties

Using Normalized Message Properties in a BPEL Process

Using Predefined Normalized Message Properties in a BPEL Process

To Use Predefined Normalized Message Properties in a BPEL Process

Adding Additional Normalized Message Properties to a BPEL Process

To Add a Normalized Message Property Shortcut to a BPEL Process

To Edit an NM Property Shortcut

To Delete an NM Property Shortcut

To Add a Normalized Message Property to a BPEL Process

To Delete an NM Property

BPEL Code Generation Using NM Properties

General Normalized Message Properties

Binding Component Specific Normalized Message Properties

Using Handlers

Using a Fault Handler

When to Use


Catch Element

Catch Element Properties

Catch All Element

Using an Event Handler

When to Use


On Event Element


On Alarm Element

On Alarm Element Properties

Using a Compensation Handler

When to Use

To Add a Compensation Handler to Scope or Invoke Elements

Using a Termination Handler

When to Use

To Add a Termination Handler to Scope or Process Elements

Using Correlation

Understanding Correlation. Using the Correlation Wizard

Elements That Use and Express Correlation

Defining Correlation Using the Correlation Wizard


Validation Criteria

Validation Types


The Output window

The Design view

The Navigator window

BPEL Process Logging and Alerting

Defining Logging

To Log the Variable Value

To Set the Log Level for the BPEL Service Engine

To View the Log File

Defining Alerting

Configuring the BPEL Service Engine Runtime Properties

Accessing the BPEL Service Engine Runtime Properties

Runtime Property Descriptions

BPEL Service Engine Deployment Artifacts

Testing and Debugging BPEL Processes

Testing a BPEL Process

To Add a Test Case and Bind it to a BPEL Operation

To Set the Test Properties

To Customize Test Input

To Run the Test Cases

Looking at Test Case Results

Debugging BPEL Processes

Steps in Debugging BPEL Processes

Starting and Finishing a BPEL Debugging Session

Using Breakpoints to Debug BPEL Processes

Debugging Commands

To disable a breakpoint

Group operations over breakpoints

Monitoring Execution of BPEL Processes

BPEL Debugger Windows

Sessions Window

BPEL Process Instances Window

Correlation Sets and Faults information

Local Variables Window

Watches Window

BPEL Process Execution Window

BPEL Partner Links Window

BPEL Debugger Console Messages

Monitoring the BPEL Service Engine

Installing the BPEL Monitor API and Command Line Monitoring Tool

To Install the Monitoring Tool

Using the BPEL Monitor Command Line Tool

To Use the BPEL Monitor Command Line Tool

Command Usage Pattern

More Information

Configuring Quality of Service (QOS) Properties, Throttling, and Redelivery

Configuring the Quality of Service Properties

To Access the Config QOS Properties Editor

Quality of Service Properties

Configuring Message Throttling

Configuring an Endpoint for Throttling

Configuring Redelivery

Using Dynamic Partner Links and Dynamic Addressing

Using a Literal to Construct an Endpoint

Using an Existing Partner Link's Endpoint

Using an Incoming Message to Extract the Endpoint

Using a Database Query to Provide an Endpoint

Sending Service Endpoint References

Configuring Persistence for the BPEL Service Engine

Setting the JVM Classpath to the Database JDBC Drivers

To Set the GlassFish JVM Classpath Settings

Configuring the User and Database for Persistence

Derby (JavaDB)



Setting max_allowed_packet

Creating an XA Connection Pool and a JDBC Resource

To Create an XA Connection Pool

Create a New JDBC Resource

Creating a Non-XA Connection Pool and JDBC Resource

Enabling Persistence for the BPEL Service Engine

To Enable Persistence for the BPEL Service Engine

Truncating and Dropping Tables

Drop and Truncate Scripts

Configuring Failover for the BPEL Service Engine

Failover Considerations

BPEL BluePrints


Using BPEL Schemas Different from the BPEL 2.0 Specification

Service Endpoint Conflict

Relationship of Service Endpoint to Test Cases

Troubleshooting Port Numbers

GlassFish V2 Application Server HTTP Port

Travel Reservation Service Endpoint Conflict

Change URLs

Test Run

Test Run Failures

Disabling Firewalls when Using Servers

Required Correlation Set Usage is Not Detected by the Validation System

Navigating in the BPEL Designer

This section explores the navigation capabilities of the BPEL Designer.

The BPEL Editor Views

The Navigator Window

The Properties Window


Zooming In and Out of the Diagram

Printing BPEL Diagrams and Source Files

The BPEL Designer Window

The new BPEL file opens in the Design view of the BPEL Designer.

image:Image shows the NetBeans IDE displaying the Design view of the BPEL Designer

To open the BPEL Designer, either create a new BPEL Process or open an existing BPEL Process. The image above shows the NetBeans IDE open to the BluePrint1 Project's BPEL process in the BPEL Designer. If the Pallet and Properties windows are not displayed in your current view, click Windows -> Reset Windows from the NetBeans menu.

The BPEL Designer includes the following components:

The BPEL Editor Views

In the BPEL Editor you can switch between Source View, Design View, Mapper View and Logging View. All the views are always kept in sync.

Cloning Document Views

The Clone Document feature is a customization option which enables you to clone documents views. For example, if you want to see both the source and the design view of a BPEL process at the same time (or the Design and Mapper view) follow the instructions below.

Several views of one document are always kept in sync.

To Clone the Document View

  1. Open the BPEL file
  2. Right click the tab with the file name and choose Clone Document.

    Another tab with the same document is created.

  3. Drag and drop one of the tabs to the location you choose: left, right or to the bottom of the screen. An orange frame will show you where the window you are dragging will be placed.

Element Documentation and Report Generation

The BPEL Designer includes a feature that allows you to create comments (documentation) attached to the elements of a BPEL process. This documentation is then included with the source code of the BPEL process and can later be extracted and included in a report.

Creating Documentation for an Element

  1. Select an element on the diagram or in the Navigator window.

  2. Click the selected element's Documentation icon which appears next to the selected element in the diagram.

    A documentation window appears.

  3. Type any information or comments that you feel are useful, into the Documentation window. This documentation is now available to you whenever you open the Documentation window, and is also written to the element's Properties file.

Generation a Report

The Report Generation feature of the BPEL Designer enables you to generate a PDF document describing the BPEL Process. By creating a custom report you can create a more verbose report or include information for only those elements that have documentation, in the report.

  1. From the BPEL Diagram toolbar, press the Generate Report button. The report, in PDF format, is added to the project's Process files in the Projects window.

    The report includes the following information:

    • The name of the process

    • The diagram

    • Information about partner links

    • Information about imported documents

    • A list of all defined variables

    • Information about the process elements

    • Documentation created for the process elements

  2. To customize a report so it includes all of the element properties, or to include only elements that have documentation, click the Customize Report button in the BPEL Diagram toolbar.

    A Customize Report dialog box appears.

    • Choose Generate Verbose Report to include all of the element properties in the report.

    • Choose Include Only Elements with Documentation to only include elements with documentation in the report.

  3. Click OK, and click the Generate Report button. If a report already exists, the new report will overwrite the existing report in the Projects window.

The Navigator Window

The Navigator window is a companion of the BPEL Designer. If the Navigator window is not visible, you can manually invoke it by selecting Window -> Navigating -> Navigator from the main menu or pressing the Ctrl-7 key combination.

The Navigator window provides two distinct views of the BPEL process: BPEL Logical View and XML View. You can switch between the XML View and BPEL Logical View using the drop-down menu in the upper part of the Navigator window.

XML View

The XML View is identical to the Navigator view that is available for all XML documents opened in the IDE. The XML View is a companion to the BPEL Source view. Double-click any Navigator node and the Source view adjusts the current line of code to show the selected element.

Logical View

The Navigator also provides the BPEL Logical View of BPEL processes. When you select BPEL constructs in the Design view, the BPEL Logical View shows the same element selected. Alternatively, when you select a node in the BPEL Logical View's tree, the corresponding element is selected on the diagram.

Right-clicking the nodes in the BPEL Logical View invokes context menus with actions relevant to the particular node. For example, for the Assign element, the actions are Go to Source, Go to Design, Wrap With, Move Up and Move Down, Toggle Breakpoint, Delete, Show BPEL Mapper, and Properties. The Go to Source and Go to Design actions, available for most of the nodes, have associated keyboard shortcuts: Alt-O for Go to Source and Alt-D for Go to Design.

In general, the nodes in the Navigator window correspond to the elements on the diagram. In addition, there are nodes, such as Variables and Correlation Sets, that are related to functionality not directly accessible from the diagram.

To view the variables used in the business process, expand the Variables node in the BPEL Logical View of the Navigator window. For variables, the following commands are available in the context menu:

Of particular relevance is the Imports node, which lists XSD and WSDL files referenced with the help of the Import element in your BPEL file. Using the context menu for the Imports node, you can add reference to an XSD or WSDL file. Note that only files located in the project folder may be referenced.

To Add a Resource File (WSDL or XSD) as an Import

  1. In the BPEL Logical View of the Navigator window, right-click the Imports node and choose one of the following, depending on the format of the imported file: Add WSDL Import or Add Schema Import.
  2. In the Create New Import dialog box, select the file in your project structure to add it as import.

    Note - Before you can import a file, you must first add the files stored in your project directory to the project structure, then you can add them as imports. The files that are already referenced are displayed in the strike-through style.

  3. View the values in the read-only Namespace and Type fields and click OK.

    The resource file you have just added appears under the Imports node in the Navigator window.

To Add a Property to a WSDL File

From the Navigator window you can add properties and property aliases to the WSDL files referenced in the BPEL document.

  1. In the BPEL Logical View of the Navigator window, right-click a WSDL file under the Imports node and then select Add Property.
  2. In the Create New Correlation Property dialog box, specify the property name.
  3. Select the property type and click OK.

To Add a Property Alias to a WSDL File

  1. In the BPEL Logical View of the Navigator window, right-click a WSDL file under the Imports node and then select Add Property Alias.
  2. In the Create New Property Alias dialog box, click Browse next to the Property field to specify the property.
  3. In the Property Chooser dialog box, select the property for which you are creating the alias and click OK. The Property Type field in the Create New Property Alias dialog box is populated with the type.
  4. In the Map Property To tree, expand the WSDL file node and select the message or message part.
  5. To add a query, enter the query string in the Query text field.

    If the Synchronous with Tree checkbox is selected, the Query field is updated each time you change the selection in the Map Property To tree.

  6. Click OK.

See Also

For more information on defining properties and property aliases with the WSDL Editor, refer to Using the WSDL Editor.

The Properties Window

The Properties window contains the properties information for the currently selected element of the process. You can also use the IDE's Properties window to configure all BPEL element properties. The contents of the Properties window differs depending on the active element of the process. To open the Properties window, choose Window -> Properties or press Ctrl-Shift-7.


When you open a BPEL file from the Projects window, the diagram opens in the Editing Mode of the Design view by default. In this mode, you can edit the diagram and scroll through it. The Editing Mode is enabled when the Navigation mode is selected on the Editor toolbar.

image:Navigation mode is turned on

In the Editing Mode, you can scroll through the diagram by using the following methods:

Collapsing and Expanding Process Blocks in the Diagram

The diagram enables you to collapse and expand process blocks to allow you to focus on other processes.

To Collapse and Expand a Process Block

  1. Click on the block's border to highlight the block. A Collapse button appears above the left corner of the block.
  2. Click the Collapse button. The process block is displayed as a small block in the diagram flow.
  3. To expand the process block, click the Expand icon in the center of the collapsed process block. That block is expanded.

Zooming In and Out of the Diagram

The zoom feature enables you to reduce or enlarge the size of your diagram to get a closer view or to see more of the diagram at a reduced size. You can change the zoom value using the Zoom Value drop-down list on the Editor toolbar.

The minimum scale size is 33% and some large diagrams might not fit entirely the window.

To change the scale do one of the following:

Printing BPEL Diagrams and Source Files

You can print BPEL diagrams and source files and customize printing settings, including border, headers, footers, colors, line numbers, and zooming, to suit your preferences.

To Preview and Print a BPEL Diagram or Source File

  1. Open a BPEL file in the Design view.
  2. Choose File from the main menu and select one of the following commands:
    • Print Preview. Preview the print layout or configure print settings.

    • Print to HTML. Print the .BPEL file as an HTML file.

To Customize Print Options

  1. In the IDE, select an object you want to print.
  2. In the Print Preview window, click Print Options. The Print Options dialog box opens.
  3. Change the print settings to suit your preferences:
    • Print Border — Adds a border to the printed page. Click the Color icon to change the border color.

    • Print Header and Print Footer — Specifies the text, alignment, color, and font of the header and footer.

      • To hide the header or footer, clear the Print Header or Print Footer check boxes, respectively.

      • To specify the header or footer pattern text, click in the field corresponding to the alignment (Left, Center, or Right) and select one of the buttons below. For example, to add the time of printing at the bottom left corner, select the Print Footer checkbox, click into the Left field, and click the "Time of printing " icon.

      • Click the Choose Footer Color and Choose Footer Font icons to modify the color and the font for the page header and footer.

    • Line Numbers — Specifies whether to print line numbers for source files.

    • Wrap Lines — Wraps the lines to fit them on the page.

    • Print as in Editor — The printed page will look like you see it in the editor.

    • Text Font and Color — Specifies the color and font of the text when you are printing, for example, source files.

    • Background Color — Specifies the background color.

    • Line spacing — Specifies the value for line spacing.

    • Zoom — Specifies the scale for the printed text or diagram on the page. You can select to fit width or height or choose a specific zoom scale.

  4. Click OK.

To Customize Page Settings

  1. In the IDE, select an object you want to print.
  2. Choose File -> Print Preview.
  3. In the Print Preview window, click Page Setup. The Page Setup dialog box opens.
  4. You can also invoke the Page Setup dialog box by choosing File -> Page Setup.
  5. On the Page Setup page specify the following parameters:
    • Paper size

    • Source of the paper

    • Paper orientation

    • Margin sizes

  6. Click Printer button and specify the printer.
  7. Click OK.