Skip Headers
Oracle® Real User Experience Insight User's Guide
Release 11.1 for Linux x86-64

Part Number E22309-01
Go to Documentation Home
Go to Book List
Book List
Go to Table of Contents
Go to Index
Go to Feedback page
Contact Us

Go to previous page
Go to next page
PDF · Mobi · ePub

2 Working With Reports

This chapter describes the standard library reports that are available to you, how to use reports, control the report mailings you receive, as well as how to modify and create your own reports. The use of the two report modes, inline and print layout, is also explained.

2.1 Introducing the Report Library

Reports provide you with the insight you need to assess the performance of your network infrastructure. They also allow you to see whether defined KPIs and SLAs are being achieved. They enable you to quickly identify any problem areas and, together with the use of alerts, ensure that the necessary corrective action is taken promptly and accurately where required.

RUEI comes with an extensive library of predefined (standard) reports that provides you instant and powerful insight into your organization's monitored operations. These reports are available through the report library, which you can view by clicking the Reports tab. This is shown in Figure 2-1.

Figure 2-1 The Standard Report Library

Description of Figure 2-1 follows
Description of "Figure 2-1 The Standard Report Library"

The Standard Report Library

The report library is made up of categories (or folders) containing reports dedicated to particular aspects of the monitored traffic. This enables you to quickly locate the information most relevant to you. These reports are fully describes in Appendix T, "Standard Report Library". The information available in each report category is outlined in Table 2-1.

Table 2-1 Report Categories

Category Description


Provides information about monitored application pages. This includes page views, the objects that appear on the pages, and their loading and reading times.


Provides information about monitored application pages. This includes page views, the objects that appear on the pages, and their loading and reading times.


Provides information about the monitored domains, including traffic, page views, and loading and reading times.

E-Business Suite

Provides information about EBS-enabled applications.

JD Edwards Suite

Provides information about JD Edwards-enabled applications.

Key pages

Provides information about pages that have been chosen to receive special attention. For these pages, additional information is recorded.


Provides daily or weekly information on dashboard items (such as SLAs and KPIs).

Oracle ADF suites

Provides information about Oracle ADF-based applications.


Provides cumulative information about the monitored Web site, such as failures, total traffic, sessions, and page views.


Provides information about client sessions based on assigned IP ranges.


Provides information about Siebel-based applications.


Contains access to historical user flow dataFoot 1 .


Provides information about failed or slow hits, and performance killers.

User flows

Provides client information about all defined Web application user flows. For example, how many user flows were initiated by visitors, how long did they take, and how many were completed and aborted.

WebLogic Portal

Provides information about WebLogic Portal-based applications.

Footnote 1 In version 6.5.1, transactions were renamed to user flows, and there are important differences in the way they are processed and reported.

2.2 Customizing the Report Library

You can modify the standard report library to better suit your organization's requirements. Using menus, you can rename, remove, or add a report category or subcategory.

It is not possible to modify or delete any standard report. Nor is possible to change their associated permissions. As such, these reports are available to authorized users on a read-only basis. If you want to use a modified version of a standard report, you should use the standard report as the basis for a custom report. The procedure to do this is described in Section 2.10, "Creating New Reports".

To add a category to the main report library, right click the Report categories item. The context menu shown in Figure 2-2 appears.

Figure 2-2 Report Categories Menu

Description of Figure 2-2 follows
Description of "Figure 2-2 Report Categories Menu"

The following options are available:

After selecting the required option, you are prompted to specify a unique name for the new category. Report categories are ordered alphabetically, and private categories appear below public ones.

To add a subcategory, or to rename or remove a category, right click the appropriate category. The menu shown in Figure 2-3 appears.

Figure 2-3 Report Category Sub-Menu

Description of Figure 2-3 follows
Description of "Figure 2-3 Report Category Sub-Menu"

The following options are available:

Report Permissions and Power Users

Each user-created report and report category is assigned a usage type. This is either Business or IT, or both. This distinction is also the basis for the user rights explained in Section 14.2, "Understanding User Roles and Permissions". If you have been assigned Analytical or Full access level rights as both a Business and IT user (that is, you are a so-called power user), you should be aware that access to the reports you create is controlled on individual report level, and not report category level.

For example, if you create a new public category with the usage type Business, such as the one shown in Figure 2-4, any IT-related reports that are saved to this category cannot be accessed by Business users.

Figure 2-4 Creation of New Public Business Category

Description of Figure 2-4 follows
Description of "Figure 2-4 Creation of New Public Business Category"

For this reason, it is recommended that you do not mix reports aimed at different types of users within categories.

2.3 Using the Mailing Facility

You can use the Mailing facility to obtain a ready overview of the reports you receive through automatic E-mails, and the frequency (daily, weekly, or monthly) with which they are sent to you. An example is shown in Figure 2-5.

Figure 2-5 Example Mailing Profile

Description of Figure 2-5 follows
Description of "Figure 2-5 Example Mailing Profile"

Use the check boxes to the right of a report to specify the frequency with which you want to receive a report. Alternatively, right click a report and select Mailing and the report frequency (Daily, Weekly, or Monthly). You can also select Remove from mailing to stop receiving the selected report.

You can use the Daily, Weekly, or Monthly command buttons in the Send mailing now panel to request previous reports. If a command button is unavailable, it means that there are no reports in the mailing list with that frequency.


The report mailing facility is scheduled to run at 6 am (Reporter system time) every day.

For example, if you click Weekly, a list (shown in Figure 2-7) allows you to select a particular week, and you will receive all the weekly reports for the selected week that are currently checked in your mailing profile.

Figure 2-7 Send Mailing Now Dialog

Description of Figure 2-7 follows
Description of "Figure 2-7 Send Mailing Now Dialog"

2.4 Using the Favorites Facility

To help you quickly locate the reports you work with most often, click the Favorites option. This facility allows you to create shortcuts to them.

To add a report to your Favorites section, right click the required report, and select Add to Favorites from the menu shown in Figure 2-6. To open the report, click the shortcut, or select View from the menu. To review or change the report´s current mailing frequency, select Mailing and the required option.

To delete a shortcut from your Favorites, right click it, and select Remove from Favorites from context menu the shown in Figure 2-8.

Figure 2-8 Favorites Context Menu

Description of Figure 2-8 follows
Description of "Figure 2-8 Favorites Context Menu"

2.5 Using the Calendar

A report provides information about a particular date or period. Hence, it is necessary to specify the period for which you want information. Use the Calendar, shown in Figure 2-9, to specify the required date or period.


The Calendar contains the following parts:

Note that while viewing a report, you are free to change your period selection at any time. Simply use the controls described above, and the report is immediately updated to reflect your new period selection.

2.6 Using Report Filters

If you open a report created with a report filter (described in Section 3.8.3, "Using Report Filters"), you are prompted to specify a filter for the report. For example, if the report concerns the daily values of defined KPIs, you are prompted for the KPI you want to view. This is shown in Figure 2-10.

Figure 2-10 Example Report Filter

Description of Figure 2-10 follows
Description of "Figure 2-10 Example Report Filter"

Select the required value from the displayed list, and click View report. The report then opens.

2.7 Understanding Report Components

Each report consists of a header, an Information screen, and a number of sections. These report parts are described in the following sections.

The Report Header

The report header contains general information about the report you are viewing. This includes the report's title, an indication of the reported metrics, and the date or period to which the report refers. An example is shown in Figure 2-11.

Figure 2-11 Example Report Header

Description of Figure 2-11 follows
Description of "Figure 2-11 Example Report Header"

The Information Screen

The information screen provides a glossary of the terms used in the report. This is useful when you (or other report users) need an explanation of the metrics used in a report. An example is shown in Figure 2-12.

Figure 2-12 Example Report Glossary

Description of Figure 2-12 follows
Description of "Figure 2-12 Example Report Glossary"

Note you can also obtain a complete list of all terms used in reports, together with an explanation of them, by right-clicking within the glossary and selecting Full glossary.

Report Sections

Typically, a report contains several sections, and the number of available sections varies between reports. For example, a daily traffic report would contain two sections: one reporting traffic in terms of page views for the requested period, and the other reporting traffic in terms of bytes.

You can move between report sections by using the icons in the toolbar at the top of the report panel. In addition, they allow you to view the report's information screen, and switch between a graphic and table (value) view of the report's data. These icons are shown in Figure 2-13 and explained in Table 2-2.

Figure 2-13 Inline Layout Icons

Description of Figure 2-13 follows
Description of "Figure 2-13 Inline Layout Icons"

Table 2-2 Inline Layout Icons Explained

Icon Description
Description of informscreenicon.gif follows
Description of the illustration informscreenicon.gif


Provides a brief explanation of the metrics currently shown in the report.

Description of barcharticon.gif follows
Description of the illustration barcharticon.gif


Displays the standard graphic visualization (pie chart, line chart, or bar chart) for the report section. The graphic form depends on the underlying data.

Description of valuelisticon.gif follows
Description of the illustration valuelisticon.gif


Shows the underlying data values for the data in the report.

Description of leftgreenarrow.gif follows
Description of the illustration leftgreenarrow.gif Description of rightgreenarrow.gif follows
Description of the illustration rightgreenarrow.gif

Previous and Next section.

Use these controls to move between the report's sections. The number of available sections varies between reports.

Description of currentsection.jpg follows
Description of the illustration currentsection.jpg

Indicates the current section in the report.

Description of previewicon.gif follows
Description of the illustration previewicon.gif


Opens the report in print layout mode. This is the mode to use when you want to customize the report, or create a new report based on it.

Description of pdfcreateicon.gif follows
Description of the illustration pdfcreateicon.gif

Download PDF.

Create an Adobe PDF file of the report's current contents.

In addition to the options shown in Figure 2-13, you can also use Browse option (shown in Figure 2-14) within each section's context menu to obtain a complete view of the data from which the report section is derived. This is described in Chapter 3, "Working With the Data Browser."

Figure 2-14 Report Section Menu

Description of Figure 2-14 follows
Description of "Figure 2-14 Report Section Menu"

Each section within a report can be enabled or disabled. When disabled, a section is shown as collapsed, and must be enabled to make it visible again. An example of a disabled report section is shown in Figure 2-15.

Figure 2-15 Disabled Report Section

Description of Figure 2-15 follows
Description of "Figure 2-15 Disabled Report Section"

It is important to understand that this facility is used to control the content of the final (saved) report. For example, if the existing report that you are using as the basis for your new report contains sections that are not relevant to the new report, you can use this feature to remove them from the final report.

2.8 Interpreting Reported Values

When using reports (and the Data Browser described in Chapter 3, "Working With the Data Browser"), a value list may sometimes contain the text "n/a" rather than a reported value. This is caused by no measured data being available. With line graphs and bar charts, this situation is indicated by a 0 (zero) value. This can arise in the following situations:

2.9 Working With Print Layout Mode

When a report is opened, it is shown in inline mode. This offers a high-level overview of the report's contents, and provides ready access to more detailed information available through the report. When browsing a report, this is the mode that you will use. However, when you want to customize reports, or create new ones, a more powerful editing mode is required: this is called print layout. An example is shown in Figure 2-16.

Figure 2-16 Example Report in Print Layout

Description of Figure 2-16 follows
Description of "Figure 2-16 Example Report in Print Layout"

This layout can be thought of as the report's template: it defines the report's structure and appearance. To view a report in print layout, select Preview from the taskbar at the top of the report panel (shown in Figure 2-13). The report's print layout is shown in a new window.

The first major difference you will notice between the two layouts is that, in print layout, all report sections (including the Information screen) are shown. This provides you with a complete overview of the report's contents. The other major difference is that the report's data is shown in both graphic and value (table) form.

You can use the context menu (shown in Figure 2-16) available under each section to modify the section to your requirements. It allows you to add descriptions to sections, enable and disable report sections (explained in Section 2.7, "Understanding Report Components"), remove sections from the report, and change the order in which sections appear in the report.

2.9.1 Working With Value Lists

By default, data in report sections is shown in graphic form. However, sometimes you want to see "hard" numbers, rather than a graphic visualization. In addition, you may be planning to distribute the report to users whose printing or display facilities are limited. Therefore, you can use the Values and Graph icons in the toolbar at the top of the report panel (see Figure 2-13) to switch between the two views. An example of a value table is shown in Figure 2-17.

Figure 2-17 Example Value Table

Description of Figure 2-17 follows
Description of "Figure 2-17 Example Value Table"

2.9.2 Limiting Value Lists

Within a value list, you can select Limit value lists from the menu to specify the number of values that are shown in the selected section. The dialog shown in Figure 2-18 appears.

Figure 2-18 Limit Value List Dialog

Description of Figure 2-18 follows
Description of "Figure 2-18 Limit Value List Dialog"

If you specify a value of -1, all available values will be shown. It is recommended that you use this facility with care because of potentially very large value lists. The default is 100.

2.9.3 Working in Compare Mode

When a report is created using the compare facility (described in Section 3.9, "Comparing Data Across Different Periods"), an additional option, Compare, is available within the context menu of its main section.This allows you to specify the offset period to be used in the report. The available periods depend on the report's active time selection (day, week, or month).

2.10 Creating New Reports

In addition to the standard reports provided in the report library, you can also create new reports. To do so, you should use an existing report as the basis for your new report, and then modify it to meet your requirements. To save the new report, do the following:

  1. When you are ready to create the new report, select Save as new from the File menu. The dialog shown in Figure 2-19 appears:

    Figure 2-19 Save As New Report Dialog

    Description of Figure 2-19 follows
    Description of "Figure 2-19 Save As New Report Dialog"

  2. Specify a title and brief description for the new report, and the category to which it should be saved. As mentioned earlier, if you save the report to a private category, it will only be available to you. The Options tab allows you to specify whether the glossary is included in the report. When ready, click Save.

    Note that if the report you created is not immediately visible in the report library, click the Reports icon to refresh the displayed structure.

Modifying Exiting Reports

You can use the facilities described in Section 2.7, "Understanding Report Components" to modify a report. Note that it is not possible to modify standard reports (described in Section 2.1, "Introducing the Report Library"). Your ability to create new reports depends on your assigned user permissions. If you create a public report, it is editable by users with the necessary permissions, and is available on a read-only basis to all other users.

2.11 Exporting Reports to PDF

You can click the Download report as PDF icon or select Download report as PDF from the File menu to create an Adobe PDF file of the report's current contents. Note that sections that are disabled in print layout are not included in the generated PDF file.


In order to view the generated PDF files, the Adobe Acrobat Reader must be installed. It is available for download from the Adobe Web site (

2.12 Exporting Report Data

The report data within RUEI is available for export to host or client systems. For example, to a Business Intelligence (BI) system. The exported data is in Unicode (UTF-8) format. Access to the data is controlled through configuration of a system file. To use this facility, do the following:

  1. Select System, and then Report data export. The window shown in Figure 2-20 appears.

    Figure 2-20 Report Data Export Window

    Description of Figure 2-20 follows
    Description of "Figure 2-20 Report Data Export Window"

  2. Select the required report from the list, and specify the period for which data should be available. A URL to the report data appears. Copy and send this to all relevant hosts.

  3. Configure the access control file (described below) file to manage access to the export.php file for the required users or systems. By default, access to the file is denied to any HTTP request.

Additional Arguments

By default, exported data is provided for a complete day, and in XML format. However, the arguments shown in Table 2-3 can also be specified.

Table 2-3 Additional Arguments for Report Data Export Facility

Argument name Argument value Description



Export data in PDF format.



Export data in XLS format.



Export data in XML format (default).



Export data in comma-separated values.



Export data in tab-separated values.



Export data in Web Query Format.

dateFoot 1 


Export data provided for a complete day (default).



Export data provided for a specific hour.


yyymmddhhmmFoot 2 

Export data provided for a specific 5-minute period.

date-toFootref 1


Export data provided up to a specific day.



Export data provided up to a specific hour.


yyymmddhhmmFootref 2

Export data provided up to a specific 5-minute period.

Footnote 1 The time range arguments are always in local time with respect to the Reporter system.

Footnote 2 The lowest granularity of the date format is a 5-minute period. Therefore, specifying a date of yyyymmdd1215 will return values for the period 1215-1219.

For example:


exports the selected report data in comma-separated values format for the period 25-27 October 2010.

Configuring Access Control

This section presents a brief overview of how to secure access to the export.php file and, therefore, manage access to the exported data. A complete description of Apache Web server access control file functionality is available at the following location:

Configuring Access Control

By default, all access to the export file is blocked by the following entry in the /etc/httpd/conf.d/uxinsight.conf file:

<Files export.php>    Deny from all</Files>

To grant access to the export facility, the Deny from all entry must be overridden with an .htaccess file. By default, the .htaccess file is not present, but can be created in the /opt/ruei/gui directory. Below is an example for access to authenticated users only:

<Files export.php>
Order deny,allow
AuthUserFile /opt/ruei/.credentials
AuthName "Exports"
AuthType Digest
# Uncomment line below in case of IE6
# BrowserMatch "MSIE" AuthDigestEnableQueryStringHack=On 
Require valid-user
Allow from all

The third line contains a reference to a credential file. This files contains a list of user name and password combinations which the Apache Web server uses to validate each login attempt. It can be created using the htdigest utility.

$ htdigest -c /opt/ruei/.credentials "Exports" <username>Adding password for <username> in realm Exports.New password: passwordRe-type new password: password