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1 Introduction 

This guide shows how a business user can use ATG Content Administration to create and manage Web 
site content. It is divided into the following chapters: 

 Overview 

 Getting Started 

 Using the BCC Home Page 

 Creating and Managing Projects 

 Managing Tasks 

 Creating and Managing Assets 

Related documentation 

Refer to the following ATG manuals for related information: 

 

See this manual... For information on... 

ATG Installation and Configuration Guide Running ATG Content Administration by 
assembling and deploying an application that 
includes it 

ATG Content Administration Programming Guide Setting up and customizing ATG Content 
Administration 

ATG Business Control Center User’s Guide Using Personalization features of the ATG 
Business Control Center—specifically, user profile 
and content targeting features. 

ATG Merchandising Guide for Business Users Creating projects to edit commerce and ATG 
Search assets, and various personalization assets 
such as targeters and content groups. 

 

http://www.atg.com/repositories/ContentCatalogRepository_en/manuals/ATG10.0.1/atginstall/index.html�
http://www.atg.com/repositories/ContentCatalogRepository_en/manuals/ATG10.0.1/pubadmin/index.html�
http://www.atg.com/repositories/ContentCatalogRepository_en/manuals/ATG10.0.1/bccuser/index.html�
http://www.atg.com/repositories/ContentCatalogRepository_en/manuals/Merch10.0.1/merchbusiness/index.html�
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2 Overview 

ATG Content Administration is a complete application for creating and maintaining the content required 
for ATG Web applications. ATG Content Administration streamlines the process of developing site content 
by letting you manage all stages of the content lifecycle: creation, approval, and deployment. 

In this chapter 

This chapter contains the following sections: 

 Features 

 Terminology 

 Project Workflow 

Features 
ATG Content Administration is a Web content management system that lets you create and maintain Web 
site content. You can perform the following tasks: 

 Create and edit content 

 Maintain versioned content 

 Manage the content approval process 

 Deliver content to the Web site 

Terminology 
The following list describes key terms used in ATG Content Administration. 

Asset: The most basic component of ATG Content Administration, an asset is any object that is part of an 
ATG application. Examples of assets include: file assets—images, HTML, text, and binary files, folders, 
scenarios and slots. You can edit assets in the ATG Business Control Center, or download and edit them in 
a third-party application. For more information, see Creating and Managing Assets. 

Project: A collection of related assets that are brought together in order to be edited, reviewed, and 
deployed to your Web site as a single unit. For example, a project might be a collection of press releases 
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that are posted once a week. Each project moves through the workflow that is defined for its project type. 
For more information, see the Creating and Managing Projects chapter. 

Task: A stage in the lifecycle of a project—for example, content authoring, approval, and deployment. For 
more information, see Managing Tasks chapter. 

Workflow: A series of tasks that a project must pass through before it is complete. Workflows define the 
order in which tasks are performed, the possible outcomes of each task, and the users who can work on 
each one. Workflows are configured by an administrator outside the ATG Business Control Center. For 
general information on viewing and creating workflows, see the ATG Personalization Guide for Business 
Users. For detailed information about workflows that are used by Content Administration, see the ATG 
Content Administration Programming Guide. 

Version: A numbered instance of an asset that is maintained in the Content Administration versioning 
system. All assets in Content Administration are versioned, thus ensuring that users always access the 
most recently saved instance of an asset. Each time you add an asset to a project and check it in, the 
system assigns the asset a new version number. For more information, see Asset Version Numbering. 

Check-in: The stage in a project’s lifecycle when all project assets are submitted to the versioned 
repository and become the latest versions. 

Deployment: The process of copying the latest versions of a project’s assets to other servers, including 
your production Web site. For a brief description, see Deploying Assets in this guide. For more detailed 
information, see the ATG Content Administration Programming Guide. 

Project Workflow 
The following diagram shows the steps a business user typically performs to create an asset and publish it 
to a Web site. It follows the pattern of a project that uses the default workflow that is provided with the 
system. 

http://www.atg.com/repositories/ContentCatalogRepository_en/manuals/ATG10.0.1/business/index.html�
http://www.atg.com/repositories/ContentCatalogRepository_en/manuals/ATG10.0.1/business/index.html�
http://www.atg.com/repositories/ContentCatalogRepository_en/manuals/ATG10.0.1/pubadmin/index.html�
http://www.atg.com/repositories/ContentCatalogRepository_en/manuals/ATG10.0.1/pubadmin/index.html�
http://www.atg.com/repositories/ContentCatalogRepository_en/manuals/ATG10.0.1/pubadmin/index.html�
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Author 

The first task of a new project. During the Author task, the user can add assets to the project and edit 
them. When authoring is complete, the user advances the project by choosing Ready for Review. 

Review content 

Typically assigned to an editor or manager in charge of content review, this task has two possible 
outcomes: 
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 Approve Content advances the workflow progresses to the next task, Approve for 

Deployment. 

 Reject returns the project to the Author task for further updates. 

Deploy 

Deploying assets to a site is typically assigned to managers or administrators, and generally consists of 
two tasks: 

 Approve for Deployment or Approve and Deploy initiates a process which concludes 
by copying project assets to the target Web site. The user can also reject the project 
and return to the Author task. 

 Verify Deployment validates the project deployed on target, then checks in project 
assets and closes the project. The user can also revert the project, which restores the 
target site to its previous state and returns the project to the Author task. 

Note: The action and outcome labels shown above, such as Author and Review, are the default labels for 
the installed workflow. These labels might be reconfigured for your site. 



A T G  C o n t e n t  A d m i n i s t r a t i o n  G u i d e  f o r  B u s i n e s s  U s e r s  

1 1  

3  -  G e t t i n g  S t a r t e d  

μ
3 Getting Started 

This section contains information on the following introductory topics: 

 Accessing the ATG Business Control Center 

 Overview of the ATG Business Control Center 

Accessing the ATG Business Control Center 
The ATG Business Control Center is a Web-based interface to all ATG Content Administration business 
user features. 

Requirements 

To use the ATG Business Control Center and access specific areas within it, you need the following user 
configuration: 

 

User profile Defined by a system administrator in the Personalization > Users interface of 
the ATG Control Center. 

When you log into the ATG Business Control Center, you are prompted to 
enter a user name and password. The values to enter are the login name and 
password specified in your user profile. 

ATG Content 
Administration role 

Added to your user profile through the Personalization > Internal Users > 
Organizations and Roles interface in the ATG Business Control Center—for 
example, EPub-User or EPub-Manager. 

Although you do not need one of these roles to access the ATG Business 
Control Center, you do need one to access all ATG Content Administration 
features. See Managing Tasks for more information. 

ATG Portal role Provides access to the ATG Business Control Center—for example 100001-
member. These roles are also assigned through the Personalization > Users > 
Organizations and Roles interface. In this case, the appropriate roles are 
located in the Global Roles > Bizui folder 
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Web browser The ATG Business Control Center supports various browsers and operating 

systems. For more information, see the Supported Environments page on 
atg.com: http://www.atg.com/en/products/requirements/ 

Note: If you use Internet Explorer, you must make some minor changes to 
your Windows registry to avoid receiving some browser-related errors, 
specifically a “This page cannot be displayed” error when you attempt enter 
data into a form. For detailed instructions, point your browser to the following 
URL: 

http://hostname:port/dyn/dyn/iefix/ 

 

Steps 

To access the ATG Business Control Center: 

1. Make sure that the database where you store versioned assets is running. 

For evaluation purposes, start the SOLID database installed with ATG 9.1: 

Start > Programs > ATG 9.1 > ATG Content Administration > Start SOLID Server 

2. Make sure that an application that includes the ATG Content Administration modules 
you use to create and manage versioned assets is running. The module, for evaluation 
purposes, is PubPortlet. For information on application assembly and ATG modules, 
see the ATG Installation and Configuration Guide. 

Note that instructions for running the ATG Content Administration applications you 
use for staging or production servers (also called target sites) are different. Refer to the 
ATG Content Administration Programming Guide for more information. 

3. Point your Web browser to the server where ATG Content Administration is running: 

http://hostname:port/atg/bcc 

where: 

 hostname is the name of the server where the ATG Content Administration 
application is running 

 port is the port the application server uses to listen for HTTP requests. For 
example, the URL on JBoss that uses the default port might be: 

http://anycorp.androcles:8080/atg/bcc 

For default ports, see the ATG Installation and Configuration Guide. 

4. When the ATG Business Control Center login dialog box appears, enter the case-
sensitive login name and password that are defined in your ATG user profile. 

A default profile is provided for evaluators. 

http://www.atg.com/en/products/requirements/�
http://www.atg.com/repositories/ContentCatalogRepository_en/manuals/ATG10.0.1/atginstall/index.html�
http://www.atg.com/repositories/ContentCatalogRepository_en/manuals/ATG10.0.1/pubadmin/index.html�
http://www.atg.com/repositories/ContentCatalogRepository_en/manuals/ATG10.0.1/atginstall/index.html�
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Overview of the ATG Business Control Center 

The ATG Business Control Center is a set of HTML-based pages that you use to access functionality for 
several products in the ATG suite, including ATG Content Administration. For business users, it is the 
primary work area for ATG Content Administration. 

The ATG Business Control Center features the following working areas: 

BCC Home page: Lists current ATG Content Administration projects and tasks that are assigned to you. 
Each task is a link to the task editing area. The home page also contains links to commonly used 
functional areas of the ATG Business Control Center. This page is customizable, so other elements might 
appear here as well. For more information, see Using the BCC Home page. 

Available Projects page: An entry point for creating and working with Content Administration projects. 
When you first display this page in a session, it lists all active projects to which you have access. Each 
project name links to its Project page, which contains the following tabs: 

 

Project tab Purpose 

Tasks Assign tasks to a project and change the status of any tasks assigned to you. See 
Managing Tasks for more information. 

Assets Create and manage assets—the files and other ancillary objects required for a 
project. See Creating and Managing Assets. 

History Create and read comments and other information associated with a project. For 
more information on this tab, see Creating and Managing Projects. 

Properties Available if your site developers have extended ATG Content Administration code to 
include custom project data. Also appears if you are using ATG Adaptive Customer 
Outreach 2005. See Using the Properties Tab for more information. 

 

Browse Assets page: Use to find and view the checked-in version of any asset in the system (see Browse 
All Versioned Assets). 

Admin Console pages: Used by system administrators to configure and manage deployment. These 
pages display only to users with the appropriate security access. For information on how to display and 
use these pages, refer to the ATG Content Administration Programming Guide. 

Using the browser Back button 

Navigating to previous pages by using your browser’s Back button can yield unexpected results and 
errors, and is not recommended. Instead, navigate to different pages in ATG Business Control Center by 
using its own links and other navigation controls. 

If an error appears after using the Back button, close the browser and restart it. 

http://www.atg.com/repositories/ContentCatalogRepository_en/manuals/ATG10.0.1/pubadmin/index.html�
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4 Using the BCC Home Page 

The ATG Business Control Center Home page is displayed after you log in for the first time. You can 
display it at any time by clicking the BCC Home link. The contents of this page can be customized for your 
organization, and its appearance also varies according to the ATG products you have installed. 

The following image shows the default BCC Home page with some sample data: 

 

The BCC Home page provides summary information about active projects and easy access to frequently-
used areas of ATG Content Administration. By default, the page contains two lists: 

 Operations contains links to activities you can perform in the ATG applications to 
which you have access—for example, project types that are configured for ATG 
Content Administration. If you have access to ATG Outreach or ATG Merchandising, 
the list also contains links to functions in those applications. 

 To Do shows active projects and the tasks that are currently awaiting activity for each 
one. 



A T G  C o n t e n t  A d m i n i s t r a t i o n  G u i d e  f o r  B u s i n e s s  U s e r s  

 

1 6  

4  -  U s i n g  t h e  B C C  H o m e  P a g e  

μ
Operations 

The Operations list contains links to commonly used functions in the ATG Business Control Center. By 
default, the Operations list displays two links: 

 Content Administration 

 Personalization 

Additional items appear under Operations if other ATG products are installed that extend the ATG 
Business Control Center framework. 

Note: If no items appear in the Operations list, your ATG session might have expired. Start a new session 
by logging out of the ATG Business Control Center and logging back in again. 

Content Administration 

Options under this entry give you access to Content Administration features. 

 The projects types your Content Administration environment is set up to create. You 
click one of these options when you want to start a new project. By default, only one 
option appears, Content Administration Project. For more information, see Creating 
and Managing Projects. 

Access to project type items is determined by the security configuration for the 
underlying workflow. If a project type is missing, check that your user profile is 
assigned a role with Execute access to the corresponding workflow. For more 
information, see Project and Workflow Security in the ATG Content Administration 
Programming Guide. 

 Browse Projects links to the Available Projects page, which lists open projects. See 
Creating and Managing Projects. 

 Browse Assets lets you find and view the checked-in version of any asset in the 
system. See Browse All Versioned Assets. 

 Admin Console lets system administrators configure and manage deployment. See 
the ATG Content Administration Programming Guide. 

Access to the last three items is controlled by the PublishingActivities.xml file. 
For more information, see the ATG Content Administration Programming Guide. 

Personalization 

Options under this entry allow access to various Personalization features that are provided with the ATG 
platform. You use them to manage: 

 User profiles, organizations, and roles 

 User segments 

 Content groups 

 Content targeters 

http://www.atg.com/repositories/ContentCatalogRepository_en/manuals/ATG10.0.1/pubadmin/index.html�
http://www.atg.com/repositories/ContentCatalogRepository_en/manuals/ATG10.0.1/pubadmin/index.html�
http://www.atg.com/repositories/ContentCatalogRepository_en/manuals/ATG10.0.1/pubadmin/index.html�
http://www.atg.com/repositories/ContentCatalogRepository_en/manuals/ATG10.0.1/pubadmin/index.html�
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These features are described in the ATG Business Control Center User’s Guide. 

To Do 
The To Do list shows active ATG Content Administration projects and the task that is current for each one. 
The Show list provides various project filters: 

 Projects with My Tasks displays only projects with active tasks that are assigned to 
you. This list excludes any projects you created unless you are assigned to the current 
task. 

 All Projects and Tasks displays all active projects and shows the task that is currently 
active for each one. 

 Projects I Created displays all active projects that you created. 

 Projects with Unassigned Tasks displays active projects whose current task has not 
been assigned to anyone. 

If you want to see completed projects as well as active ones, or to search for a specific project, use the 
Available Projects page. To display it, click Browse Projects in the Operations list. See Creating and 
Managing Projects for more information. 

To assign a task to someone, or to change the existing assignment, select the appropriate name from the 
dropdown list and click Assign. You can also use the Tasks tab to do this; see Managing Tasks for more 
information. 

Clicking Go to Project takes you to the Project page for that project. See Creating and Managing Projects 
for more information. 

Clicking the name of a task takes you to the project’s Tasks tab, which is the primary interface for 
performing all task-related activities. For example, if you want to change a task’s status or to view all tasks 
in a project, including those that have not yet been completed, use the Tasks tab. See Managing Tasks for 
more information. Note that the effect of clicking the name of a task differs if you are running additional 
ATG applications such as ATG Merchandising. 

Note: If you are using Internet Explorer and you are running ATG Content Administration on an IBM 
WebSphere or Oracle WebLogic application server, new projects might not appear in the To Do list on the 
BCC Home page after you create them. The problem is caused by Internet Explorer’s automatic page 
caching behavior. To resolve it, in Internet Explorer select Tools > Internet Options > General > Settings. 
Change the Check for Newer Versions of Stored Pages option from Automatically to Every Visit to the 
Page. 

http://www.atg.com/repositories/ContentCatalogRepository_en/manuals/ATG10.0.1/bccuser/index.html�
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5 Creating and Managing Projects 

All business user activities for ATG Content Administration are conducted as part of a project. A project 
serves two complementary purposes: 

 Acts as a container of related assets 

 Controls the flow and assignment of asset management tasks. Project tasks typically 
include content creation, editing, review, approval, and deployment. 

When you create a project, you specify the project type to use. Each project type has a workflow that 
determines the project tasks and their order of execution. For more technical information on workflows, 
see the ATG Content Administration Programming Guide. 

When a project is complete, its assets are checked in to the Content Administration versioned repository. 
The checked-in assets become the latest versions. Project assets are checked in only after project 
deployment to the production site is complete and the project is marked as complete. 

In this chapter 

This chapter describes how to use ATG Content Administration to manage and configure your projects. It 
includes the following sections: 

 Project Type and Workflow 

 Displaying Projects 

 Creating Projects 

 Adding Notes to a Project 

 Deleting Projects 

 Using the Properties Tab 

Project Type and Workflow 
Each project is driven by a workflow that acts as a template for the project, specifying various stages in its 
lifecycle. These stages include the tasks that ATG Business Control Center displays for each project. 

You create a project from the BCC Home page by choosing a project type from the Operations list: 

http://www.atg.com/repositories/ContentCatalogRepository_en/manuals/ATG10.0.1/pubadmin/index.html�
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Each project type has a workflow associated with it. The previous example displays three project types: 

 Approval on Production Site Required 

 Content Administration Project 

 Multi-Language Content 

By default, ATG Content Administration provides one workflow that you can associate with project types. 
Depending on how Content Administration is configured on your site, this workflow conforms to one of 
the following models: 

 Production-only supports deployment to a single target. 

 Staging/production supports deployment to two targets: first a staging target, then a 
production target. 

Production-Only 

The production-only workflow contains these tasks: 

 

Task Required action 

Author Add or edit project assets. 

Content review Sign off on asset changes. 

Approve for production 
deployment 

Approve deployment of project assets. You can specify immediate 
deployment, or defer until later. If deferred, actual deployment is 
started by the RecurringDeploymentService or an administrator. 

Wait for production 
deployment completion 

No action required. 

Verify production 
deployment 

Accept the deployment of assets to production. All assets are 
checked in and the project is marked as complete. 

 

Staging/Production 

The staging/production workflow contains these tasks: 
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Task  Required action 

Author Add or edit project assets. 

Content review Sign off on asset changes. 

Approve for staging 
deployment 

Approve deployment of project assets to the staging site. You can 
specify immediate deployment of assets, or defer deployment to 
action by the RecurringDeploymentService or an administrator. 

Wait for staging deployment 
completion 

No action required. 

Verify staging deployment Accept the deployment of assets to the staging site. 

Approve for production 
deployment 

Approve deployment of project assets to the production site. You 
can specify immediate deployment of assets, or defer deployment to 
action by the RecurringDeploymentService or an administrator. 

Wait for production 
deployment completion 

No action required. 

Verify production 
deployment 

Accept the deployment of assets to production. All assets are 
checked in and the project is marked as complete. 

 

By default, the BCC Home page only displays one project type, Content Administration Project. Your site 
can be configured to display multiple project types, as shown in the earlier example. 

There is usually is no relationship between a project’s workflow and project assets. Any type and number 
of assets can be added to any type of project workflow. 

You can ascertain a project’s type on its Project page, at the top of any tab: 

 

For detailed information about the workflows used in ATG Content Administration, see the ATG Content 
Administration Programming Guide. 
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Displaying Projects 

The BCC Home page displays a To Do list that lets you view and access active projects. Alternatively, the 
Available Projects page provides a comprehensive list of projects, and lets you search for and display a 
particular project. 

To access the Available Projects page: 

1. Display the BCC Home page. 

2. Under Operations, expand the Content Administration list. 

3. Click Browse Projects. 

The Available Projects page appears: 

 

The Available Projects page lists all projects you can work on or view. You can filter projects by setting one 
or more List Options fields (you might need to scroll to the right to display them). For example, you can 
specify to show only completed projects, or only those that you created. For more information, see 
Filtering Projects later in this section. 

Note: If a new project does not appear in the list, click Refresh Results. 

To open a project, click on its name. 
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Projects Summary 

The Available Projects page provides summary information about listed projects under the following 
columns: 

 Project Name shows the name assigned to this project. The name is also a link: 
clicking on it displays the project details screen. 

 Project Status shows the project’s current status, one of the following: 

 Active Project: The project is currently available to be worked on. The task that 
triggers deployment remains outstanding. 

 Project Complete: Project assets are deployed (or await deployment) and the 
project cannot be changed. 

The following status entries might appear for the campaigns used by ATG Adaptive 
Customer Outreach 2005: 

 Active Project and Campaign Running on Site 

 Campaign Running on Site 

 Definition shows the project type. A project’s type determines its workflow. The 
default project type is Content Administration Project, which is initially configured to 
use the installed workflow. 

 Creator shows name of the person who created the project in the ATG Business 
Control Center. 

 Start Date shows the project’s creation date. 

 Editable shows a padlock icon for projects that are currently unavailable for changes. 
Projects become automatically non-editable at certain stages of their lifecycle. For 
more information, see Non-Editable Projects. 

 Current Task: Owner shows which task is currently pending completion, and the 
name of the user who is assigned this task. More than one task can appear if the 
underlying workflow defines concurrent tasks—for example, Create Graphic: Jim 
Walker and Create Text: Mary O’Brien. 

Each task entry is a link; clicking on displays the details page for that task. 

 Description is text that spans all project columns. Project description text is optionally 
entered on project creation by the project creator (see Creating Projects). 

Sorting Projects 

You can sort projects on data in the following columns: Project Name, Creator, Status, and Start Date. For 
example, if you click Start Date, projects are sorted from most recent start date to least recent. If you click 
Start Date again, the display order reverses, showing oldest projects at the top. 

Filtering Projects 

To show a different set of projects in the Available Projects list, or to find and display projects that meet 
specific criteria, use the List Options box on the right side of the page: 
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You can set one or more List Options fields, then click Go to apply those settings. 

 

Setting Action 

Show Projects with Status Shows only projects of the specified status. The dropdown list displays 
all valid status entries. To display all projects, set this field to All 
Projects. 

Type of Project Show only projects of the chosen type, The dropdown list displays all 
project types that are defined for your site. 

Whose Name Contains Lets you search for projects whose name includes the characters you 
specify. Leaving the field blank includes any name in the search. 

All/Mine Only Show all projects, or only those that you created. 

Results Per Page Set the number of projects to display on each page. 

 

Tip: If a project does not appear in the Available Projects list, set Show Projects with Status to All Projects 
and click Go. 

Non-Editable Projects 

In the following circumstances, a project is considered non-editable—that is, no changes can be made to 
the project, including working versions of its assets. A project can be non-editable for one of these 
reasons: 
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 The Author task for an active project is complete and is now in a later stage such as 

Content Review. 

 The project status is Complete. 

The Available Projects list displays padlock icons for non-editable projects in their Editable field. You can 
view project information in the ATG Business Control Center, but controls in the Tasks and Assets tabs 
that allow changes are disabled. 

If the Author task is complete and the project’s status is still Active, you can return the project to editable 
status by selecting Reject as the outcome of the next task, Content Review. (You must be part of the 
owner pool for the Content Review task to complete this step.) The project reverts to the Author task and 
becomes available for further editing. For more information, see Managing Tasks. 

Creating Projects 
To create a project: 

1. Display the ATG Business Control Center Home page. If necessary, click BCC Home. 

2. Under Operations, expand the Content Administration list. Each option represents a 
project type that is defined for your environment. 

3. Select the desired project type. Your choice determines the workflow to be used by 
the new project and defines its tasks. By default, all installations provide the project 
type Content Administration Project, which invokes the installed workflow. 

4. Name the project, up to 50 characters. Although not required, it is a good idea to 
assign unique project names to facilitate easy identification by other users. 

5. In the Project Description field, optionally enter text to identify the project’s purpose. 
The text you add appears in the Available Projects list. After you finish creating this 
project, you cannot edit or delete this text. 

6. Click Continue. 

The system uses this information to create the project, and displays its Tasks tab, where you can assign 
this project’s tasks to Content Administration users (see Assigning Tasks). 

Important: After you create a project, click Refresh Results on the Available Projects page in order to 
display the new project. If the new item does not appear, check the List Options settings (see Filtering 
Projects). 

Adding Notes to a Project 
You can add project notes through the History tab of its Project page. Notes can be written by users who 
are assigned to project tasks. Notes are also entered automatically by the system to track events that 
occur during the project’s lifecycle. For example, when you create a project, this event is automatically 
recorded as a note and displayed in the History tab. 
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To view project notes: 

1. Open the Project page by clicking the project’s name in the Available Projects page or 
by clicking Go To Project on the BCC Home page. 

2. Display the History tab: 

 

The History tab includes the following information 

 Project creation date 

 Task completion date 

 User or system-generated notes associated with task completion 

Each entry contains the following data: 

 Name of the user who performed the action 

 Date and time that the action occurred 

 Display name of the workflow element associated with this action 

To create a history entry: 

1. Click Add Note. 

2. In the dialog, enter the note text. 

Note: After you submit this note, you cannot delete it or edit its contents. 

3. Click Add. The new note is added to this project’s history. 
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4. Click Close. The note is appended to the bottom of the history tab. 

Deleting Projects 
You can delete only active projects—that is, projects whose deployment task is still pending. When you 
delete an active project, the system deletes from the database the project and all objects associated with 
it. All working versions of project assets are discarded. 

To delete a project, you must be the owner of its current task, or the task must be unassigned. 

To delete an active project: 

1. Navigate to the project’s Tasks tab. 

2. From the Select Action drop-down list, choose Delete Project. 

3. Click Go. 

4. A confirmation dialog appears. 

Note: The deletion is irreversible, and all working versions of the project assets are also 
removed from the system. 

5. Click OK. 

Using the Properties Tab 
ATG Content Administration can be customized so you can associate additional data with a project. This 
additional project data corresponds to any custom repository items your developers define for use as 
assets (see the ATG Content Administration Programming Guide). 

If custom data is defined for a project, a new Properties tab appears on its Project page. The Properties tab 
includes editors that let you manage the type of additional data that the project contains. For specific 
information about using this tab, contact your developers or system administrator. 

The Properties tab appears if your ATG product suite includes ATG Outreach. For more information, refer 
to the ATG Outreach documentation. 

http://www.atg.com/repositories/ContentCatalogRepository_en/manuals/ATG10.0.1/pubadmin/index.html�
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6 Managing Tasks 

Tasks represent the steps that users perform during a project’s lifecycle: for example, authoring, 
approving content, and deploying to a production site. A project’s workflow determines its tasks and their 
sequence. 

In this chapter 

This chapter includes the following sections on working with tasks: 

 Viewing Tasks 

 Assigning Tasks 

 Completing Tasks 

Viewing Tasks 
You can view tasks in two ways: 

 View all active tasks, either assigned to you or to all users, from the BCC Home page’s 
To Do list. 

 View all tasks—complete, active, and pending—for a given project via its Tasks tab. 

The Tasks tab for a project displays all project tasks and their status: 
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From this tab, you can: 

 Assign tasks to yourself or to other users. 

 Change the status of tasks assigned to you, and of unassigned tasks. 

Project workflow and tasks 

The set of project tasks and their sequence is determined by the project’s underlying workflow, which is 
associated with the project type. In order to modify this task list, you must edit the workflow in the ACC, 
or create a project type that uses a different workflow. However, you must not change the workflow of 
any active projects; doing so disassociates the workflow from the project and makes the project 
inaccessible. For information on editing workflows, see the ATG Personalization Guide for Business Users. 

Task assignment 

The Owner column shows who is assigned to the current task. Some tasks represent steps in the workflow 
that are executed by the system and do not require an owner. In these cases, no dropdown list appears in 
the Owner column. See Assigning Tasks for information on how to change the owner of a task. 

Task actions 

The current task contains a dropdown list in the Actions column, with several task-specific options for 
completing this task. For more information, see Completing Tasks. 

Assigning Tasks 
You use the Tasks tab to assign owners to project tasks. When you are assigned a task, it appears on BCC 
Home page’s To Do list, when you select My Projects and Tasks. This helps you quickly identify the work 
you need to do. 

http://www.atg.com/repositories/ContentCatalogRepository_en/manuals/ATG10.0.1/business/index.html�
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An unassigned task can be completed by any user who is part of that task’s owner pool. An assigned task 
can only be completed by its owner. All other users can make changes to the project during that time—
for example, add assets to the project—but they have no access to the task’s Actions control. 

To assign a task to a user, you must be a member of the task’s owner pool. This constraint also applies to 
the project’s creator. For more about owner pools, see User Roles and Task Ownership. 

To assign a task: 

1. Display the Tasks tab. 

2. In the Owner column, choose a user from the dropdown list. 

3. Click Assign. 

If a user does not appear in the Owner list, verify that the following conditions are true: 

 A user profile exists for this person. To verify: 

 Navigate to the BCC home page 

 Under Operations, choose Personalization > Users 

 If necessary, create a profile. 

 The person’s profile is assigned a role that enables access to this task: 

 Check which user roles enable access to this task: view the project’s workflow in 
the ATG Control Center (ACC) and check access rights for the corresponding 
task element. 

 Check whether the user has the desired role: navigate to the BCC home page 
and choose Personalization > Users > Orgs and Roles 

For information about default user role task ownership, see User Roles and Task 
Ownership in this chapter. 

For more information on using the ATG Control Center, see the ATG Personalization Guide for Business 
Users. For information on creating or modifying user profiles, see the ATG Business Control Center User’s 
Guide. 

Releasing Tasks 

Releasing a task from its owner returns it to the pool of unassigned tasks. Any user who belongs to a task’s 
owner pool can release it. 

1. Navigate to the desired Tasks tab. 

2. From the task’s Owner dropdown list, select Release. 

3. Click Assign. 

http://www.atg.com/repositories/ContentCatalogRepository_en/manuals/ATG10.0.1/business/index.html�
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The task’s owner is set to Unassigned. 

You can also release tasks through the BCC Home page: 

1. Display the BCC Home page. 

2. Change the To Do list so it displays the project with the task you wish to release. 

3. From the Owner dropdown list, choose Release. 

4. Click Assign. 

If you change the To Do list to display All Projects and Tasks or Unassigned Tasks, the task appears. 

User Roles and Task Ownership 

A task is accessible to any user who belongs to its owner pool. Any user who belongs to a task’s owner 
pool can complete the task or assign it to another user in the pool. Membership in an owner pool is 
determined by the Set Access Rights option in the workflow’s corresponding task element. For more 
information on viewing and setting this option through the ATG Control Center, see the Using Workflows 
chapter of the ATG Personalization Guide for Business Users. 

The Set Access Rights option lists the user roles with access to the task. A user can be assigned one or 
more roles. Any user who has a role with access to a task is a member of that task’s owner pool. 

The following list shows the default owner pools for the workflow tasks that are provided with ATG 
Content Administration: 

 

Task Owner pool roles 

Author administrators-
group 
EPub-Admin 
EPub-Manager 
EPub-Super-Admin 
EPub-User 
managers-group 

http://www.atg.com/repositories/ContentCatalogRepository_en/manuals/ATG10.0.1/business/index.html�
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Content Review EPub-Manager 

EPub-SuperAdmin 
managers-group 

Approve for staging/production deployment EPub-Manager 
EPub-Super-Admin 
managers-group 

Verify staging/production deployment EPub-Manager 
EPub-Super-Admin 
EPub-User 
managers-group 

 

Completing Tasks 
When you finish working on a task, you tell the system that the task is complete as follows: 

1. Display the Tasks tab. 

2. Choose the appropriate option from the Actions dropdown list. This control appears 
only to the task owner or, if unassigned, to members of the owner pool. 

3. Click Go. 

4. In the confirmation dialog box that appears, optionally enter a comment and click OK. 

Available Action options vary according to the task, and are set by the available task outcomes in the 
project’s workflow. For example, the installed workflow’s Author task specifies the option Ready for 
Review to indicate task completion. The Content Review task specifies two options, Approve and Reject, 
to indicate completion. For more information, see the Using Workflows chapter of the ATG Personalization 
Guide for Business Users. 

When you choose an action, it generally indicates to the system that you completed the task and wish to 
move the project on to the next task. If the user chooses Reject, the previous task is reactivated. 

Note: If you successfully set up and initiated deployment targets, those targets must be currently 
accessible in order for some tasks to complete. Specifically, you cannot complete the Content Review task 
if a target configured for deployment is unavailable. If you choose Approve Content, an error appears 
when you click Go and the next task does not become active. For more information about setting up 
deployment targets, see the ATG Content Administration Programming Guide. 

http://www.atg.com/repositories/ContentCatalogRepository_en/manuals/ATG10.0.1/business/index.html�
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7 Creating and Managing Assets 

An asset is an object that forms part of an ATG application. An asset often represents a piece of content 
that you need to create or edit for display on a Web site—for example, a JPEG image, or a file containing 
press release text. A project can include personalization assets, such as scenarios and slots. 

Asset constraints 

Always use Site Administration to edit site configurations. For more information, see the Multisite 
Administration and Configuration Guide. 

Use Content Administration to edit the content of file assets, slots, and scenarios. Always use the ATG 
Merchandising user interface to edit the following assets: 

 All other personalization assets such as targeters and content groups 

 All commerce assets such as price lists, product catalogs, and promotions 

 ATG Search Merchandising assets such as facets 

For more information, see the ATG Merchandising Guide for Business Users. 

In this chapter 

This chapter describes how to use the ATG Business Control Center to manage and configure assets. It 
includes the following sections: 

 Project Asset Lifecycle 

 Viewing Assets 

 Creating Assets 

 Adding Assets to a Project 

 Editing Assets 

 Versioning Assets 

 Deploying Assets 

 Asset Types 

 Linking Assets 

 Removing Assets from a Project 

 Viewing an Asset’s History 

 Previewing Assets 

http://www.atg.com/repositories/ContentCatalogRepository_en/manuals/Merch10.0.1/merchbusiness/index.html�
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 Deleting Assets from the System 

Project Asset Lifecycle 
The following diagram shows how a project uses an asset. In this example, the base versions of assets A 
and B are revised in a project and deployed to a site. The deployed version of each asset becomes 
version 2 of the asset in the repository. 
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The following list describes the stages in the lifecycle of an asset. 

1. Add assets to a project 
When you add an asset to a project, a working version of the asset is automatically 
created. If the asset is new, it exists only as a working asset; no checked-in version 
exists, and it is visible only within the project. 

2. Edit the project asset 
An asset is accessible only from a project, where it can be viewed, edited and saved. 
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Changes that you save to a working version are visible only within the project, and are 
not accessible to other projects. 

3. Deploy and check in project assets 
Project assets are checked in to the versioned repository after deployment to the 
target site is complete and verified. The checked-in asset becomes the latest version 
that is available to projects and users. For more information, see Versioning Assets. 

Viewing Assets 
You can view assets in two ways: 

 View project assets via its Assets tab. 

 Browse all versioned assets. 

View Project Assets 

The Assets tab lists all project assets and provides summary information about each one. It also lets you 
access the pages where you create and edit assets. 

To display the Assets tab for a specific project: 

1. Select the project from the BCC Home page or the Available Projects page. 

2. Click the Assets tab. 

 

The Assets tab contains the following information about project assets: 

 Asset Name: The name of the asset that was specified when it was added to the 
project. The name is also a link; clicking it displays the asset details page. 

 Type: The asset type. For possible values, see Asset Types. 

 Base Version: The version number of the asset that was used to create the working 
version in the project. The base version is the latest checked-in version. If there is no 
number in this column, the asset is new (in other words, it was created as part of this 
project), and only a working version exists. 
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 Current Version: The number of the working version of this asset. 

 Status: Shows the status of the asset within the project: 

 Created: The asset is new. A working version exists, but there is no checked-in 
version. 

 Modified: At least one checked-in version of this asset already exists (in other 
words, the asset has been used in another project). 

 Deleted: The asset is in the process of being deleted, either through the ATG 
Control Center or through the Browse tab in the ATG Business Control Center. 
(Note that no changes, including deletion, can be made to an asset unless the 
asset is in a project.) Assets do not appear as Deleted if you simply remove them 
from a project. For more information, see Deleting Assets from the System. 

Asset display in the ATG Business Control Center is configured through the View Mapping system. For 
more information, see Customizing Asset Display in the ATG Content Administration Programming Guide. 

Browse All Versioned Assets 

The Browse Assets page lets you find, view, and perform a limited set of operations on the checked-in 
version (and historical version data) of any asset in the versioning system. Although you can create and 
work on projects without using the Browse Assets page, the following examples show some situations in 
which you might want to take advantage of its features: 

 A customer asks for information about a product that your company offered last year. 
The item is no longer displayed on your Web site, but it is stored as a versioned asset. 
You can use the Browse Assets page to locate and examine the asset. 

 You want to add an existing asset to a new project. Before adding it, you want to verify 
that this asset is the one you actually want to use. 

 Your manager reports that an article on the Web site is incorrect. You are sure you 
corrected the text some time ago, but when you look at the site, you don’t see the 
changes you made. You want to look at the currently checked-in version of the article 
to see whether it’s the one you corrected. 

 You want to delete an asset from the versioning system. The Browse tab provides the 
only interface for performing this operation. See Deleting Assets from the System. 

To use the Browse Assets page to find an asset: 

1. Display the BCC Home page. 

2. In the Operations list, expand the ATG Content Administration option and click Browse 
Assets. The Browse Assets page appears. 

The system displays Search and Browse tabs, which you can use to search for a specific asset or browse 
through your existing asset directories. These are the same asset picker tabs you use when you add assets 
to a project. For more information on how to use them, see the Creating and Managing Assets chapter. 

http://www.atg.com/repositories/ContentCatalogRepository_en/manuals/ATG10.0.1/pubadmin/index.html�


A T G  C o n t e n t  A d m i n i s t r a t i o n  G u i d e  f o r  B u s i n e s s  U s e r s  

3 9  

7  -  C r e a t i n g  a n d  M a n a g i n g  A s s e t s  

μ
Creating Assets 

The following default asset types are created directly in the ATG Business Control Center: 

 Simple text files 

 Segments (profile groups) for use in ATG Adaptive Customer Outreach campaigns 

 Commerce assets (via ATG Merchandising) 

 Content groups and content targeters 

Other asset types are created elsewhere (in the ACC or in a third-party application such as a graphics 
editor). They can then be added to ATG Content Administration through the Asset tab interface in the 
ATG Business Control Center. 

The following table shows where you create, edit, and add different types of ATG Content Administration 
assets. 

Note: Your system might include custom asset types not shown here. 

 

Kind of Asset Example Create and Edit Add to Projects 

Simple text files .txt files, HTML files ATG Business Control 
Center 

ATG Business 
Control Center 

Profile groups (user 
segments), content groups, 
content targeters 

ATG Business Control 
Center 

ATG Business 
Control Center 

Personalization 
assets 

   

 Scenarios, slots ACC ATG Business 
Control Center 

Image files JPEGs Third-party application ATG Business 
Control Center 

Commerce assets Catalogs, price lists, 
promotions 

ATG Merchandising ATG 
Merchandising 

 

Note: Nested content groups and profile groups are not supported by ATG Content Administration, as 
the deployment system cannot detect that the “containing” group depends on the “contained” group 
and so deploys them together. 
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Adding Assets to a Project 

Any user who belongs to the owner pool for at least one task in a project can add assets to that project. 
The Author task must be active to allow assets to be added. For more information on task owners and 
status, refer to Managing Tasks. 

The following sections show how to add assets to projects through the Assets tab in the ATG Business 
Control Center: 

 Adding a New Asset 

 Adding an Existing Asset 

For information on using the ACC to add assets to projects, refer to Asset Types. 

Adding a New Asset 

This section describes the basic procedure for adding to a project an asset that does not already exist in 
the versioning system—that is, the asset is new and unused by other projects. 

The following procedure applies to all new assets regardless of how they are created. 

1. Display the Assets tab for the target project (see View Project Assets). 

2. Click Add Asset to Project. This option appears only if the project is open for editing. 
The Asset Picker appears: 

 

3. In the Repository field, choose the versioned repository that stores data for the new 
asset’s type. 
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4. In the Asset Type field, choose one of the asset types. 

5. Click Create New. The asset’s Properties tab displays. 

6. In the File Name field, enter the asset’s name. The following requirements apply: 

 The name is unique within its target folder. 

 Optionally, the asset has a filename extension appropriate for its type—for 
example, .jpg for a JPEG. Although not required, appending the correct 
extension facilitates editing the asset, by enabling the system to identify an 
appropriate editor. 

7. Fill in the remaining fields for this asset as needed. The fields correspond to this asset 
type’s properties. For more information, see Asset Types. 

8. In the Parent Folder Path field, specify the folder to store this asset. By default, all new 
assets are stored in the ATG root directory (\). Some asset types such as scenarios 
require a specific folder; otherwise, you can store the asset anywhere that makes 
sense. 

Note: Assets that require a specific folder location can be added to projects through 
the ACC, which selects the appropriate location automatically. 

9. Click Apply. The system creates the asset, adds it to the project, and gives it the 
potential version number 1 (see Asset Version Numbering). 

10. Click Back to the Project’s Assets. 

Adding an Existing Asset 

Often, a project needs to revise existing assets previously checked in from other projects. For example, a 
page on a corporate Web site might include biographies of company executives. With the arrival of a new 
executive, the text needs to be changed. To do so, you can add the checked-in version of this text asset to 
a new project, where it becomes the working version. 

To add an existing asset to a project: 

1. Display the Assets tab for the target project (see View Project Assets). 

2. Click Add Asset to Project. This option appears only if the project is open for editing 
(see Non-Editable Projects ). 

3. In the Repository field, select the versioned repository that stores this asset. 

4. In the Asset Type field, select the asset’s type (see Asset Types). 

5. Click Add Existing. The Asset Picker appears with two tabs: 

 Search lets you query the versioned repository for assets by name or partial 
name, and choose from the results list. 

  Browse lets you browse through the hierarchy of asset folders for the desired 
asset. 

6. Click Add. 

7. When you finish adding assets, click Close. 
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8. The system adds the asset to the project and gives it the current (or working) version 

number (see Asset Version Numbering for more information). 

Adding Assets from the Browse Assets Page 

You can use the Browse Assets page to find an asset and add it to any active project: 

1. From the BCC Home page, click: 

Operations > Content Administration Project > Browse Assets 

2. Use the Search or Browse tab to locate the desired assets. 

3. In the results list, check the desired assets. 

Note: the results list might require several pages. 

4. From the two dropdown lists at the bottom of the page, choose: 

 Modify 

 An active project. 

5. Check Take Me to Project. 

6. Click Go. The project’s Assets tab displays. 

Editing Assets 
The procedures for editing assets are similar to the ones for adding them to projects. You edit some asset 
types directly in the ATG Business Control Center, and others through third-party applications. Scenarios 
and slots are edited within the ACC. 

You can only edit assets that belong to projects. This ensures that asset changes always take place under 
the version control system. Asset editing only occurs during the project’s Author task. When the Author 
task is complete, further edits to that asset (from within that project) are prohibited. 

This section covers the following topics: 

 Editing Assets in the ATG Business Control Center 

 Editing Assets in Third-Party Applications 

 Editing Scenario and Slot Assets 

Editing Assets in the ATG Business Control Center 

You can edit text file, personalization and ATG commerce assets directly in the ATG Business Control 
Center: 

1. Display the Assets tab for the project that contains the asset to edit. 

2. Click the name of the asset to display its Properties tab. 

3. Edit asset properties as needed. 
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4. Click Apply. The ATG Content Administration system replaces the working version of 

the asset with the asset you just changed. The current version number stays the same. 

Using the HTML editor 

The ATG Business Control Center has its own HTML editor, which you can use to open and modify some 
assets. The editor is packaged with ATG Content Administration as a Java applet. 

When you display the Properties tab of an asset configured to use this editor, a message appears asking 
you to accept the applet: 

 

Click Yes to start the applet. The following example shows the editor with some sample data: 
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The editor provides a range of HTML authoring features, including spellchecking, drag-and-drop from 
applications such as Microsoft Word and Web pages, and support for international character sets. The 
Design and Code tabs at the bottom of the screen let you switch between WYSIWYG and HTML editing. 

Editing Assets in Third-Party Applications 

In some cases you can download an asset from the ATG Business Control Center and edit it in another 
application such as a graphics editor. When you finish editing, you upload the file so that the system can 
replace the existing working version with the one you just edited. 

The availability of the download feature depends on how an asset is configured. For more information, 
see the ATG Content Administration Programming Guide. 

To edit an asset in a third-party application: 

1. Display the Assets tab for the project that contains the asset you want to edit. 

2. Click the name of the asset. The asset’s Properties tab appears. 

3. Click Download. 

4. In your browser’s Download dialog, click Open or Save: 

 Open opens the file for editing in the application that is associated with asset’s 
name extension. 

 Save prompts you to save the file on your system. 

5. Edit the file in the third-party application, and save it on your system. 

Note: You can save the downloaded file anywhere on your system and under any 
name, regardless of the location the asset’s previous source, or its asset name. 

http://www.atg.com/repositories/ContentCatalogRepository_en/manuals/ATG10.0.1/pubadmin/index.html�
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6. Return to the ATG Business Control Center, and display the asset’s Properties tab. 

7. In the Uploaded File field, find the file by clicking Browse, or enter its path manually. 

8. Click Upload. 

9. Click Apply. 

ATG Content Administration replaces the working version of the asset with the 
uploaded file. Because no check-in occurred, the version number is unchanged. 

Editing Scenario and Slot Assets 

Scenarios and slots are edited from ATG Control Center (ACC). In order to properly version these asset 
types, the ACC provides additional interface controls when you run it on the same server as ATG Content 
Administration. 

To edit an asset in the ACC: 

1. Make sure ATG Content Administration is running with the appropriate modules. See 
the ATG Installation and Configuration Guide for information on ATG modules and 
application assembly. 

2. Start the ACC that is connected to the ATG Content Administration server. See the ATG 
Installation and Configuration Guide. 

3. From the ACC, choose Tools > Select Project. 

4. Click Pick a Project to Work, and choose the project whose assets you wish to edit. 

Note: Only editable projects are listed (see Non-Editable Projects). 

5. Click OK. 

6. Choose Publishing > Current Project. The ACC lists project assets: 

http://www.atg.com/repositories/ContentCatalogRepository_en/manuals/ATG10.0.1/atginstall/index.html�
http://www.atg.com/repositories/ContentCatalogRepository_en/manuals/ATG10.0.1/atginstall/index.html�
http://www.atg.com/repositories/ContentCatalogRepository_en/manuals/ATG10.0.1/atginstall/index.html�
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The following information is listed for each asset: 

 Name 

 Asset type—for example, scenario 

 Base version number (the checked-in version) 

 Current version number (the working version) 

 Status, one of the following: 

Added: The asset has a working version only (the asset has not yet been 
checked into the versioning system). If an asset has the status Added, a plus 
sign appears next to it in the list. 

Modified: The asset has at least one checked-in version. The status is shown 
with a check mark next to the asset. 

Deleted: The asset is in the process of being deleted. The status is shown with 
an X next to the asset. Assets appear as Deleted for one of the following 
reasons: 

You used the Browse tab in the ATG Business Control Center to select an asset 
for deletion, and you specified this project as the one to delete the asset (assets 
can be modified only if they are added to a project first). 

You delete an asset through the ACC. The asset is removed from the list in the 
window you used to remove it, but it appears as Deleted in the Publishing > 
Current Process list. This behavior occurs because an asset must be added to a 
project before any changes, including deletion, can be made to it. 

7. Click the name of the asset to edit. An editing window for the asset’s type opens. 

8. Change the asset as required, then choose File > Save. 
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You cannot edit assets whose status is Deleted. If you select an asset that cannot usually be edited in the 
ACC and therefore has no corresponding editor—for example, the .sec file associated with a scenario—
the following message appears: 

Could not find an editor for asset (asset-name) 

Confirming inclusion of edited assets in projects 

By default, any item you edit through a copy of the ACC that is connected to the ATG Content 
Administration server is automatically added to the current project if it has not been added already. 
Optionally, you can enable a confirmation dialog box that warns you the item is about to be added as an 
asset and lets you cancel the request to save the changes. 

To enable the confirmation dialog box, select Tools > Preferences > Publishing, then select Require 
Confirmation Before Automatically Adding Items to Process. The following message appears whenever 
you edit and save an item that has not been added to a project: 

If you save this item, it will be added to the current project. Do 

you wish to proceed? 

If you select No when the confirmation message appears, the changes you made are preserved in the 
editing window but not saved. You must undo the changes manually. 

Note that this confirmation applies only when you edit and save items in the ACC; it does not apply to 
creating items. New items are always added to the current project. 

Versioning Assets 
Because content management projects are typically collaborative, where the same asset might be reused 
by multiple projects, an asset’s lifecycle must be carefully controlled—for example, to prevent several 
users from editing the same content simultaneously. Also, the latest version of an asset—the version that 
is deployed to a production site—must be preserved. ATG’s Version Management system controls an 
asset’s lifecycle, and many aspects of asset behavior in ATG Content Administration are affected by this 
system. 

Asset Version Numbering 

The versioning system maintains two types of version numbers: 

 Base version number: The latest checked-in version of the asset. When an asset is 
created, its initial base version number is 1. 

 Potential version number: The version number that is conditionally assigned to each 
checked-out version of an asset. 

When you add an asset to a project, the system assigns it a potential version number. When the project 
checks in its asset, the system converts the potential version number to the new base version. If another 
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project checked in the same asset earlier, the system assigns the next available number to the new base 
version. 

For example: 

1. John adds the asset ExecProfiles to his project. ExecProfiles is new to the versioned 
repository, so it has base version number 1. When John adds ExecProfiles to his 
project, the system assigns his working version potential version number 2. 

2. While John is editing ExecProfiles, Susan also adds this asset to her own project, which 
gets potential version number 3. 

3. Susan deploys her project and its assets are checked in, including ExecProfiles. The 
system uses its potential version number and renumbers the base version number as 
3. 

4. John gets an alert that tells him a conflict exists between his version of ExecProfiles 
and the new base version that Susan checked in. John can resolve this conflict either 
by overriding the base version, or by merging the two conflicting versions (see 
Resolving Asset Conflicts). 

5. John deploys his project and its assets are checked in. The system increments the base 
version number of ExecProfiles to 4. 

To view an asset’s version number, display the Assets tab and examine the Base Version and Current 
Version columns. For more information, see View Project Assets. 

More detailed information about an asset’s version history is available in the Assets > History tab. For 
more information, refer to Viewing an Asset’s History. 

Checking in Assets 

Assets are checked in to the versioning system automatically after project deployment is complete. When 
an asset is checked in, it becomes the new base version of the asset. For more information, see Asset 
Version Numbering. 

Resolving Asset Conflicts 

The ATG Business Control Center includes a conflict resolution feature that warns you if the asset you 
used to create your working version has been changed by someone else. For example: 

1. Ray adds an existing asset to a new project. 

2. You add the same asset to a different project. 

3. Ray edits his working version of the asset and deploys his project. The assets in his 
project are checked in and constitute a new base version of those assets. They now 
contain changes that the working versions in your project do not contain. 

4. The next time you view your project’s Assets tab, the Current Version column displays 
Merge With Latest for the asset, as shown below for the asset directions.txt: 
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The Merge with Latest note indicates that the version of the asset you are editing was not created using 
the latest checked-in (base) version. Assets that have conflicts appear at the top of the list. 

Clicking the Merge with Latest link takes you to the Merge Assets page: 

 

The Merge Assets page displays the properties of your working version next to the properties of the latest 
checked-in version so that you can compare them. 

You can resolve conflicts in three ways: 
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 Override the checked-in version with your working version by clicking Use My Version. 

When you check in this asset, your changes are preserved in the latest version. 

 Override the changes in your working version with the checked-in version by clicking 
Use Latest Version. All your changes are lost in favor of the checked-in version. 

 Manually merge properties from both versions. 

Note: You must resolve all outstanding version conflicts in a project before you can complete the current 
task. Attempts to complete that task yield an error message. 

Merging versions 

To keep some of your properties and add some from the latest version: 

1. Select the properties from each version that you would like to include in your working 
version. These properties will combine to form the new base version when your asset 
is checked in. 

2. Click Merge Selected Properties. If the message “Please select the properties you wish 
to merge” appears when you click this button, make sure that you have specified 
either your version or the latest version for every property. In other words, do not 
leave any property unselected. 

Concurrent update exceptions 

The versioning system handles cases where two people edit the same asset in different projects. If a 
project leaves its Author task unassigned, two or more users might edit that project asset at the same 
time. In this case, the system does not detect any version conflict. The project allows only one user to save 
changes to the asset. Subsequent attempts by other users to save changes to the same asset yield a 
Concurrent Update Exception message and their changes are not saved. 

Comparing Asset Versions 

ATG Content Administration contains compare features that let you review the differences between two 
versions of an asset. You can compare only checked-in versions of the same asset; the working version of 
an asset cannot be compared with any other version. 

Note also that you can use the compare feature only for repository assets, not for file assets. Repository 
assets include ATG Commerce assets, such as product catalogs, and many custom asset types. File assets 
include any assets created using the WWW Text File Asset or WWW Binary File Asset types, as well as 
personalization assets such as scenarios, slots, and targeters and any other asset stored in the 
/atg/epub/file/ConfigFileSystem repository. 

To perform the comparison: 

1. Display the Assets tab. 

2. Click the name of the asset whose versions you want to compare. 

3. Display the History tab. 

4. Select the two versions you want to compare. 

5. Click Compare Selected Versions. 
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The Compare Asset History page appears, showing the properties of the two versions side by side in two 
columns. See Resolving Asset Conflicts for information on how to merge the properties together. 

The compare feature is also available through the Browse Assets page. See Browse All Versioned Assets 
for more information. 

Deploying Assets 
You can deploy project assets after the appropriate task in the project is complete—often, after content 
reviewers sign off on a project. All project assets are deployed at the same time. 

The actual deployment process is configurable. The installed workflow provides two deployment choices: 

 Approve and Deploy begins the deployment of project assets to the target site. 

 Approve for Deployment approves the project for deployment, which is started by the 
RecurringDeploymentService or an administrator. 

You can also configure a one-off deployment target, where assets can be deployed from a project at any 
workflow stage. 

System administrators configure and monitor deployment through the Admin Console pages, which is 
accessible to users with the appropriate access rights. For more information about deployment options 
and tools, see Deploying Project Assets in the ATG Content Administration Programming Guide. 

Asset Locking 

In order to ensure that deployed asset versions are consistent among all targets, project assets are locked 
when the project is approved for deployment, and remain locked until deployment is complete and 
project assets are checked in. While assets are locked, they cannot be deployed from other projects. This 
behavior prevents other users from building on the changes you make to an asset until those changes are 
approved. 

The assets remain locked until one of two actions occurs after production deployment: 

 The deployment is verified and project assets are checked in. Changes to the assets 
become visible to other projects. 

 Project assets are reverted from the all target sites. 

Resolving Asset Locks 

In order to ensure versioning integrity, a deploying project obtains exclusive locks on its assets when 
deployment starts. It releases those locks only after deployment is complete and project assets are 
checked in, or when the deployment is reverted. Until a project’s asset locks are released, other projects 
that share those assets cannot deploy. 

If project deployment is blocked by other projects, you can use the project’s Lock Conflicts tab in order to 
determine which other projects might have locks on its assets. For example, two projects—project1 and 

http://www.atg.com/repositories/ContentCatalogRepository_en/manuals/ATG10.0.1/pubadmin/index.html�
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project2—might concurrently have the same asset. If project1 is already approved for deployment, it 
holds an exclusive lock on the shared asset. Consequently, attempts to deploy project2 yield the 
following error message. 

Failed to approve the project project2 (id: prj20018) for deployment. Unable to 

obtain exclusive locks to one or more assets. Use the Lock Conflicts page to 

determine which assets are locked by other projects. 

In order to view all projects that have locks on project2 assets, click on the project2 Lock Conflicts tab. In 
this case, only one project is listed, project1: 

 

You can determine which assets are locked in two ways: 

 Download an Excel file of all blocking assets. 

 Click View Locked Assets. This displays the Locked Assets tab of the deploying project, 
which lists the assets that are locked against other projects: 
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Deploying to a One-Off Target 

One-off should be characterized as appropriate only for specialized circumstances—generally, to deploy 
content to a development server; it should not be used to deploy content to production or staging. 

Full deployments to one-off target sites do not include previously deployed but active projects. Full 
deployments to one-off target sites only deploy checked in projects. 

Asset Types 
The following table lists the asset types that appear by default for ATG Content Administration. Additional 
asset types customized for your environment might also appear in the ATG Business Control Center. 

 

Asset types Use for 

WWW Binary File Asset Any file except a text file. Examples: Image files, .zip 
files, video files. See Binary File Assets. 

WWW Text File Asset Any file that contains simple text. Examples: Plain text 
files, HTML files, JSPs. See Text File Assets. 

Folder Lets you add a folder to the asset hierarchy. 
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Targeter 
Content group 
Profile group 
Segment 
Slot 
Scenario 

Items corresponding to each asset type shown; for 
example, Targeter is an ATG Personalization content 
targeter. Most are not commonly added to projects by 
business users. 

For more information on targeters and content groups, 
see the ATG Business Control Center User’s Guide. 

For more information on user segments, slots, and 
scenarios, see User Segment Assets and Scenario and 
Slot Assets. 

ATG Commerce asset types. For 
example: 

Product 
SKU 
Price 

Items corresponding to each asset type shown; for 
example SKU is an ATG Commerce SKU stored in the 
product catalog versioned repository. See the ATG 
Merchandising Guide for Business Users for more 
information. 

 

The following sections provide details about adding and editing assets of each type shown above. 

 Binary File Assets 

 Text File Assets 

 User Segment Assets 

 Scenario and Slot Assets 

Binary File Assets 

Specify the type WWW Binary File Asset in order to add any type of binary file from a third-party 
application—for example, image files such as JPEGs and GIFs, FLA files, PDF files, and .zip files. While this 
option is also valid for text files, you should use WWW Text File Asset for these. 

To add a binary file to a project as a new asset, follow the procedure in Adding a New Asset and supply 
values for the following fields: 

 

In this field... Supply... 

Repository WWW File System 

Asset Type WWW Binary File Asset 

File Name The asset’s name. 

The file name should be unique within its target folder; and optionally it has a 
filename extension appropriate for its type—for example, .jpg for a JPEG. 
Although not required, appending the correct extension facilitates editing the 
asset, by enabling the system to identify an appropriate editor 

http://www.atg.com/repositories/ContentCatalogRepository_en/manuals/Merch10.0.1/merchbusiness/index.html�
http://www.atg.com/repositories/ContentCatalogRepository_en/manuals/Merch10.0.1/merchbusiness/index.html�
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Uploaded File The source file to upload. Find the file by clicking Browse, or enter its path 

manually. 

Parent Folder Path (optional) The folder to store this asset. By default, all new assets are stored in 
the ATG root directory (\). 

 

When you finish supplying these values, click Apply. The file is added as an asset. If the asset is an image, a 
Display Image button appears for viewing the image. A Download button might also appear for binary 
assets (see Editing Assets in Third-Party Applications). 

Text File Assets 

Specify the type WWW Text File Asset in order to add a file that contains editable text—for example, 
HTML, JSP, or plain text. By associating this type with text files, the system can display appropriate text-
editing features for this asset. 

To add a text file to a project as a new asset, follow the procedure in Adding a New Asset and supply 
values for the following fields: 

 

In this field... Supply... 

Repository WWW File System 

Asset Type WWW Text File Asset 

File Name The asset’s name. 

The file name should be unique within its target folder; and optionally it 
has a filename extension appropriate for its type—for example .txt, 
.html, or .jsp. Although not required, appending the correct extension 
facilitates editing the asset, by enabling the system to identify an 
appropriate editor 

Text field | Uploaded File The asset’s text, either manually entered or pasted into the text field, or 
uploaded from an external source file, via the Uploaded File field. For 
Uploaded File, specify the source file to upload by clicking Browse, or 
entering its path manually. 

You can only use one of these fields to supply the text source. If you 
upload an external file, its contents appear only after you click Apply and 
refresh the page. 

Parent Folder Path (optional) The folder to store this asset. By default, all new assets are 
stored in the ATG root directory (\). 
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User Segment Assets 

Business campaigns, including the campaigns managed by ATG Outreach, can be targeted to specific 
groups of users, or user segments. User segments are defined with a set of profile properties. Any user 
whose profile includes the specified properties is included in the segment. 

You can create user segments in two places in the ATG Business Control Center: 

 Asset interface in the ATG Content Administration area 

 Personalization > Targeting and Segmentation option 

Both options automatically add user segments as assets to the selected project, and are versioned and 
deployed like other assets. For information on how to create a user segment, refer to the ATG Business 
Control Center User’s Guide. 

Scenario and Slot Assets 

The scenarios and slots that you create for use with the ATG Scenarios module can be added to projects 
as assets, where they are versioned and deployed by ATG Content Administration. Unlike other asset 
types, you must use the ATG Control Center (ACC) to create and edit scenario and slot assets. 

The ACC identifies items (such as scenarios and slots) that can be included in ATG Content Administration 
projects as versioned assets, by displaying document icons at the menu level: 

 

Note: Document icons appear only if the ACC is connected to the ATG Content Administration server. See 
the procedure in the next section for more information. 

Adding new scenario and slot assets to a project 

You can add scenarios or slots to ATG Content Administration projects in several ways. If the scenarios or 
slots already exist as assets, you can add them to projects like other assets (see Adding an Existing Asset). 

You can also add the asset to the project at the same time you create it. This approach, described in the 
following procedure, can be more efficient than creating the asset in the ACC, then switching to the ATG 
Business Control Center and adding it to the project: 

1. Make sure that ATG Content Administration is running with the appropriate modules. 
See the ATG Installation and Configuration Guide for information on ATG modules and 
application assembly. 

2. Start the ACC and connect to the ATG Content Administration server. For more 
information, refer to the ATG Installation and Configuration Guide. 

http://www.atg.com/repositories/ContentCatalogRepository_en/manuals/ATG10.0.1/bccuser/index.html�
http://www.atg.com/repositories/ContentCatalogRepository_en/manuals/ATG10.0.1/bccuser/index.html�
http://www.atg.com/repositories/ContentCatalogRepository_en/manuals/ATG10.0.1/atginstall/index.html�
http://www.atg.com/repositories/ContentCatalogRepository_en/manuals/ATG10.0.1/atginstall/index.html�
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3. From the ACC, choose Tools > Select Project. 

4. Click Pick a Project to Work, and select the project that is to get the new asset. 

Note: The selection list contains only editable projects (see Non-Editable Projects). 

5. Click OK. 

6. In the ACC, create the scenario or slot item (see the ATG Personalization Guide for 
Business Users). 

7. Save the item. 

8. Confirm that the item was added to the project: 

 Choose Publishing > Current Project 

 Choose View > Refresh 

The item you created is added to the list of project assets and has the current version 
number 1 to indicate that it is the first working version of this asset. If you switch to the 
ATG Business Control Center and refresh the project’s Asset tab, the new asset appears 
in the display. 

See Editing Scenario and Slot Assets for more about using the ACC interface elements that are enabled 
when you run ATG Content Administration. 

Note: Projects that contain new scenarios or slots must be checked in to make the asset available to other 
personalization assets. For example, if you create a slot as part of a project, the slot becomes available to a 
scenario only when the project is complete. 

Adding existing scenario or slot assets to a project 

You can add an existing scenario or slot asset to a project in two ways: in the ATG Business Control Center 
(see Adding an Existing Asset); or in the ACC, as described below: 

1. Make sure that ATG Content Administration is running with the appropriate modules. 
See the ATG Installation and Configuration Guide for information on ATG modules and 
application assembly. 

2. Start the ACC and connect to the ATG Content Administration server. For more 
information, refer to the ATG Installation and Configuration Guide. 

3. From the ACC, choose Tools > Select Project. 

4. Click Pick a Project to Work, and select the project that is to get the new asset. 

Note: The selection list contains only editable projects (see Non-Editable Projects). 

5. Click OK. 

6. Display the top-level list that contains the target asset. For example, select Scenarios > 
Slots to display the list of existing targeters. 

7. Highlight the item: click its entry in any column other than the Name column. 

8. Select File > Add Item to Current Project. 

9. Confirm that the item was added to the project: 

http://www.atg.com/repositories/ContentCatalogRepository_en/manuals/ATG10.0.1/business/index.html�
http://www.atg.com/repositories/ContentCatalogRepository_en/manuals/ATG10.0.1/business/index.html�
http://www.atg.com/repositories/ContentCatalogRepository_en/manuals/ATG10.0.1/atginstall/index.html�
http://www.atg.com/repositories/ContentCatalogRepository_en/manuals/ATG10.0.1/atginstall/index.html�
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 Choose Publishing > Current Project 

 Choose View > Refresh 

The item is added to the list of project assets. 

Changing projects in the ACC 

To change the current project in the ACC: 

1. Select Tools > Select Process. 

A message appears, informing you that switching processes will cause the ACC to 
reinitialize. 

2. Click Yes. 

3. Select the project to use as the current project. 

Linking Assets 
An asset can be configured to contain a property whose value is a link to another asset. In the following 
example, the Reference property contains a link to an item named Currency Converter: 

 

To link one asset to another: 

1. Click the control (typically a button) that indicates a link is expected as the property 
value. 

2. The Asset Picker appears, where you specify either an existing or new asset as the link 
target: 

 If you choose an existing asset, you can edit the target asset as needed, then 
save your changes. This asset is automatically added to the project when you 
finish editing it 

 If you specify a new asset, standard fields appear that let you create it. For more 
information on creating assets, see Adding a New Asset. 

The type of asset you can specify as the link is determined by the repository definition for the property. 
Therefore, the selection fields where you specify the target asset’s repository and type typically contain 
just one choice. 

The target asset is deployed with other project assets. 

You can quickly access and edit a target asset by clicking its link from the parent asset. This shortcut to 
linked assets is especially useful when multiple assets are linked together. 
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Removing Assets from a Project 

Removing an asset from a project discards any changes that anyone has made to the working version of 
the asset since it was added to the project. 

To remove one or more assets from a project: 

1. In the Available Projects page, select the project containing the assets you want to 
remove. 

2. Display the Assets tab. 

3. Use the checkboxes in the left column to select the assets you want to remove. 

4. Click Remove Assets from Project. 

Viewing an Asset’s History 
Viewing an asset’s history lets you see when the asset was created, the version numbers associated with 
each check-in, a listing of the different times the asset was checked in, and the identity of the user who 
created or modified the asset. 

To view an asset’s history: 

1. Display the Assets tab. 

2. Click the name of the asset whose history you want to see. 

3. Display the History tab: 

 

You can use the Compare Selected Versions button to compare the properties of two versions of an asset. 
See Comparing Asset Versions for more information. 
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Restrictions 

Two restrictions apply to viewing an asset’s history: 

 An asset’s history is available for viewing only after it has been checked in. 

 If the ATG Business Control Center is open while a versioned repository purge 
executes, the asset history that is shown after the purge completes might be invalid. 
Attempts to access a purged asset version will cause errors. In this case, exit the ATG 
Business Control Center and log in again. 

Previewing Assets 
You can preview project assets to see how they behave and look on a Web site. For example, you can 
preview how an article displays with a specific stylesheet. The asset displays on the selected landing page 
in a separate browser window; it shows any changes that you made in the current project. If you make 
further changes, you can preview them by refreshing the browser window. You can preview assets from 
the perspective of different user profiles; you can also view them on more than one site if multiple sites 
are configured. 

Preview functionality must be set up by your administrator. For information on preview options and setup 
requirements, see “Setting Up Preview” in the ATG Business Control Center Administration and Development 
Guide. 

To preview an asset: 

1. Create or edit the asset, following the procedures described earlier in this chapter. 

2. From the asset’s Properties tab, click Preview. 

3. From the Preview Launcher, choose the appropriate user profile, landing page, and 
desired site if multiple sites are configured. 

The following graphic depicts the Preview Launcher as it might appear in an environment where multiple 
sites are configured: 

http://www.atg.com/repositories/ContentCatalogRepository_en/manuals/ATG10.0.1/bccadmin/index.html�
http://www.atg.com/repositories/ContentCatalogRepository_en/manuals/ATG10.0.1/bccadmin/index.html�
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Deleting Assets from the System 
Deleting an asset removes the base (checked-in) version of that asset from the system. If you only want to 
remove the working version of an asset from a project, see Removing Assets from a Project. 

Caution: Do not delete file assets by directly deleting them from the file system where they are stored—
for example, by locating them in Windows Explorer and deleting them. Doing so causes data integrity 
failure. Instead, follow the procedure shown below. 

To delete an asset: 

1. Open the Browse Assets page, and find the assets to delete. 

2. Check the assets to delete (see Browse All Versioned Assets). 

3. In the action dropdown list at the bottom of the page, select Delete. 

4. From the two dropdown lists at the bottom of the page, choose: 

 Delete 

 Any project 

Note: All versioned asset operations, including deletion, occur within the context of an 
active project; therefore, in order to delete an asset, you must first add it to an active 
project. When this project’s assets are checked in, the system removes the target asset 
from the versioned repository. 

5. Optionally, click Take Me to Project, in order to verify that the asset is added to the 
specified project. 



A T G  C o n t e n t  A d m i n i s t r a t i o n  G u i d e  f o r  B u s i n e s s  U s e r s  

 

6 2  

7  -  C r e a t i n g  a n d  M a n a g i n g  A s s e t s  

μ
6. Click Go. If you chose Take Me to Project, the project’s Assets tab is displayed and lists 

the asset to be deleted. 

7. When project assets are checked in, the asset is deleted. 

Note: In the case of scenario assets, deletion removes only the scenario’s .sdl file. The corresponding 
.sec file, which is generated by the ACC and maintains a list of the ACC roles that have security access to 
the scenario, remains in the project after deletion and is deployed to the target server. 

Canceling asset deletion 

You can cancel deletion of an asset any time before the project assets are checked in; afterwards, the 
deletion is irreversible. 

To cancel deletion of an asset, simply remove the asset from its project: 

1. Display the project Assets tab. 

2. Check the asset. 

3. Click Remove Assets from Project. 
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add edited assets to project, 47 
change projects, 58 
edit assets in, 45 
roles used by ATG Content Administration, 32 

Admin Console, 13 
Asset tab, 37 
assets, 7 

add existing to project, 41 
add new to project, 40 
add to project, 36, 40 
binary file, 54 
check in, 37, 48 
compare, 50 
create, 39 
delete, 61 
deploy, 51 
download from BCC, 44 
edit, 36, 42 
edit in third-party application, 44 
find, 38 
lifecycle, 36 
linked, 58 
merge versions, 50 
preview, 60 
remove from project, 59 
resolve version conflicts, 48 
scenario, 56 
slot, 56 
status in project, 38 
text file, 55 
types, 39, 53 
user segments, 56 
version history, 59 
version numbering, 37 
view, 37, 38 

ATG Business Control Center. See BCC 
author task, 9 
Available Projects page, 23 

lock icon, 24 
sort projects, 23 

B 
BCC, 13 

Available Projects page, 13 

Home page, 13 
requirements, 11 
start, 11 

BCC Home page 
overview, 15 
To Do list, 17 

binary file assets, 54 
add to project, 54 

Browse page, 38 
Business Control Center. See BCC 

C 
check-in, 8 
Compare Selected Versions option, 59 
comparing assets, 50 

D 
deployment, 8 

assets, 51 

E 
Edit Assets workflow 

tasks, 20 

H 
History tab, 25 

assets, 59 
HTML editor, 43 

L 
lock icon, 24 

M 
Merge Assets page, 49 
Merge with Latest alert, 48 

N 
notes 

add to projects, 25 
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P 
project, 7, 19 

add assets, 40 
add existing assets, 41 

scenarios, 57 
slots, 57 

add new assets, 40 
binary files, 54 
scenarios, 56 
slots, 56 
text files, 55 
user segments, 56 

add notes, 25 
change in ACC, 58 
check in, 8 
create, 25 
custom properties, 27 
delete, 27 
deploy, 8 
find, 23 
History tab, 25 
non-editable, 24 
Properties tab, 27 
remove assets, 59 
resolve asset version conflicts, 48 
sort on Available Projects page, 23 
status, 23 
summary data, 23 
view active, 13 
view assets, 37 
workflow, 8, 19 

Properties tab, 27 

R 
review task, 9 
roles, ACC, used by ATG Content Administration, 32 

S 
scenario assets, 56 

add existing to project, 57 
add new to project, 56 

slot assets, 56 
add existing to project, 57 

add new to project, 56 
Standard workflow, 8 

T 
tasks, 8 

access rights, 32 
assign, 30 
author, 9 
complete, 33 
display, 29 
ownership, 32 
release from owner, 31 
review, 9 
workflow, 20 

Tasks tab, 29 
text file assets, 55 

add new to project, 55 
To Do list, 17 

U 
user segment assets, 56 

add new to project, 56 

V 
versioning system 

asset version history, 59 
asset versions, 8 
check in assets, 48 
delete assets, 61 
merge asset versions, 50 
resolve asset conflicts, 48 

W 
workflow, 8 

associate with projects, 19 
steps in, 8 
tasks, 20 

WWW Binary File Asset type, 54 
WWW Text File Asset type, 55 
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