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1 Introduction 

This manual is designed for people whose job responsibilities include a range of planning activities that 
define the business strategies for their Web site. It describes how to use the ATG platform to perform 
typical tasks such as segmenting site visitors into target groups, deciding what Web site content to 
display to whom, and creating promotional campaigns. It also describes how to create business reports 
that can be used to analyze site and customer data. 

This manual provides the following: 

 A high-level description of the products that make up the ATG platform and how you 
can use them to create a personalized Web site. The ATG product suite is a highly 
flexible system with many powerful features; this manual may give you some ideas for 
enhancing your Web site (for example, did you know that you can use ATG products to 
test your site’s design on a sample audience?). 

 Information on who does what in the process of designing and maintaining a Web 
site. Specifically, the manual shows what you do in relation to what the application 
developer or the page developer does. This information not only helps you identify 
and understand your own tasks but helps you discuss your plans with other team 
members. 

 Detailed procedures and examples that show you how to perform each task. 

Parts of the ATG Platform 
The ATG platform is composed of the following pieces: the Dynamo Application Framework, the ATG 
Personalization module, and the ATG Scenarios module, which are described below. The platform runs on 
a variety of Web application servers, specifically Oracle WebLogic Server, IBM WebSphere, and JBoss. 

Dynamo Application Framework 

The Dynamo Application Framework provides the foundation layer of code necessary for running the ATG 
platform on the application server your company uses. At its core is Nucleus, a framework of predefined 
Java components and services that your application developers can customize and use as the basis for 
building a Web site. There are no business user tasks that require you to interact directly with the Dynamo 
Application Framework. For more information about it, refer to the ATG Programming Guide. 
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ATG Personalization Module 

The Personalization module provides features that are specifically designed to support Web site 
personalization, which is the process of displaying different content to each site visitor depending on his 
or her preferences and requirements. In order to create and maintain a personalized Web site, you must 
make a series of decisions about your site visitors and the content you want to show them; for example, 
how do you want to segment your site visitors? Do you want to show specific content to different age 
groups? Do you plan to use a site visitor’s income bracket to determine what to show her? And what 
content, specifically, do you want to show to each group of people? 

Once you have planned your approach to the relationship between site visitors and content, you use the 
ATG Control Center to do the following: 

 Create profile groups 

 Group similar content items together 

 Match content groups to profile groups 

 Determine the visitor behavior that you will track and use to update profiles 

For an overview of these tasks, see Overview: Creating a Personalized Web Site. 

ATG Scenarios Module 

The Scenarios module extends the functionality of the Personalization module, providing a set of 
advanced targeting features that companies can use to plan and manage long term personalization and 
customer relationships. Principally, you can use the Scenarios module to do the following: 

 Create scenarios, which are event-driven campaigns designed to manage interactions 
between site visitors and content over a long period of time. 

 Analyze Web site and visitor data through powerful reporting features, and then use 
that data to refine the content that you show your visitors. 

As a business user, therefore, your tasks with the Scenarios module include the following: 

 Planning, creating, and maintaining scenarios 

 Creating Web site reports and analyzing results 

About the Quincy Funds Demo Application 

When you install the ATG platform, you have the additional option of installing the Quincy Funds demo. 
This application is a demonstration Web site for the Scenarios module that shows how you can use ATG 
products to manage visitor profiles and deliver personalized content to site visitors. You log into the site 
as a visitor, and then you can see both your visitor profile and the site content change as a result of 
choices you make as you move from page to page. 

To understand personalization and the part that scenarios play in personalizing Web content, it is highly 
recommended that you take a look at the Quincy Funds demo and read its accompanying manual, the 
ATG Quincy Funds Demo Documentation. 
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ATG Control Center 

The ATG Control Center is the point-and-click user interface that gives you access to all features of the 
ATG platform. Business users carry out all their ATG platform tasks within the ATG Control Center. 

One copy of the ATG Control Center is installed automatically with the ATG platform. However, you can 
install and run as many copies of the ATG Control Center as you require – for example, if your company 
has three business managers who perform ATG-related tasks, they can each install the ATG Control Center 
on their own machines and connect to the same ATG server. For more information on installing additional 
copies of the ATG Control Center, please see the ATG Installation and Configuration Guide. 

Important: If your ATG product environment uses ATG Content Administration, you use the browser-
based ATG Business Control Center, rather than the ATG Control Center, to perform many of the tasks 
described in this guide, including setting up content targeting and managing user profiles, organizations, 
and roles. 

The table below shows the recommended interface for working with each of the items listed if your ATG 
environment uses ATG Content Administration. 

 

Item Manage in ATG Control Center 
(ACC)? 

Manage in ATG Business 
Control Center (BCC)? 

User profiles, roles, and 
organizations 

Possible Recommended 

Profile groups Possible Recommended (in the BCC, 
user segments have 
superseded profile groups) 

Content items Possible Possible using the ATG 
Content Administration 
interface. Refer to the ATG 
Content Administration Guide 
for Business Users for 
information. 

Content targeters Possible Recommended 

Content groups Possible Recommended 

Scenarios and slots Required – scenarios exist only in 
the ACC 

Not possible 

Workflows Required – workflows exist only 
in the ACC 

Not possible 

 

Important: If you have a multisite ATG environment, where your ATG products are being used to support 
more than one customer-facing Web site, you are required to use the ATG Business Control Center to 
manage all items shown above except scenarios, slots, and workflows. In a multisite configuration, these 
items have additional features that are available only in the BCC. 
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The ATG Business Control Center is described in the ATG Business Control Center Administration and 
Development Guide and the ATG Business Control Center User’s Guide. 

Additional Products 

ATG provides additional products that run on top of the ATG platform. Typically these must be purchased 
separately. These products include ATG Content Administration, ATG Commerce (Business and 
Consumer), and ATG Merchandising. Please refer to the separate documentation for these products for 
information on the business tasks associated with them. 

Starting the ATG Control Center 
The following procedure describes how to start an ATG Control Center that is installed in a Windows 
environment on the same machine as the ATG server. For information on starting an ATG Control Center 
that is installed on a different machine, or for information on starting the ATG Control Center in a UNIX 
environment, refer to the ATG Installation and Configuration Guide. 

Typical ATG installations use both a production server and a staging server. The production server is the 
machine that serves the “live” Web site that your visitors can see. The staging server, by contrast, serves an 
internal version of the Web site for in-house testing purposes. The staging site is not accessible to outside 
visitors. 

In most cases, you should connect to the staging server when you do any work in the ATG Control Center. 
After you test your changes on the staging site, you (or your ATG system administrator) can copy your 
changes to the live site on the production server. If you have questions about which server to connect to, 
check with your system administrator. (For more information on copying your changes to the production 
server, see Copying and Switching Databases in the ATG Installation and Configuration Guide.) 

Before you start the ATG Control Center: 

1. Make sure the SOLID Server database (or the database your company uses for its ATG 
product suite) is installed and running on the server to which you are going to 
connect. For example, to start the SOLID Server database for evaluation purposes, 
select Programs > ATG 10.0.2 > ATG Adaptive Scenario Engine > Start SOLID Server 
from the Windows Start menu. 

2. Start ATG 10.0.2 by selecting Programs > ATG 10.0.2 > ATG Adaptive Scenario Engine > 
Start ATG 10.0.2 from the Windows Start menu. This option starts the Dynamo 
Application Framework, ATG Personalization module, and ATG Scenarios module on 
the Web application server that you specified when you installed ATG 10.0.2 (for 
example, JBoss). 

To start the ATG Control Center: 

1. From the Start menu, select Programs > ATG 10.0.2 > Tools > ATG Control Center. 

2. When the Connect to Server dialog box appears, enter your user name and password 
for the ATG server to which you are connecting this copy of the ATG Control Center. 
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The default value for both is admin (note that the user name and password are case 
sensitive, and the defaults use lowercase characters). 

If you do not know the required login information, check with your ATG system 
administrator. 

For information on other ATG Control Center startup options, please refer to the ATG Installation and 
Configuration Guide. 

ATG Control Center Basics 
When you start the ATG Control Center, the following screen appears: 

 

ATG Control Center main window 

The area at the left of the screen is the main ATG Control Center menu. When you click on any of these 
menu items, a sublist of secondary menu items appears, and a task window opens to the right. 
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Note that the number of items you see in the main menu depends on the parts of the ATG product suite 
that your company has installed. The following table shows the items you see with each product in the 
suite. 

 

Product Menu items in ATG Control Center main window 

Dynamo Application Framework People and Organizations 
Pages and Components 
Utilities 

Personalization module People and Organizations 
Content 
Targeting 
Pages and Components 
Utilities 

Scenarios module People and Organizations 
Content 
Targeting 
Workflow (see note below) 
Scenarios 
Pages and Components 
Utilities 

ATG Content Administration, ATG 
Business Commerce, ATG Consumer 
Commerce, or other ATG products 

Additional items appear (for example, Publishing) 

 

Note: The Workflow menu item appears only if your system includes at least one custom workflow type or 
if you are running ATG Content Administration. For more information, see Using Workflows. 

Security Access in the ATG Control Center 
As explained earlier, the menu items that appear when you start the ATG Control Center depend on the 
parts of the product suite that you have installed. However, the options that appear depend also on your 
security access role, which is set by your company’s ATG Control Center administrator. 

The administrator uses the People and Organizations > Control Center Groups option to create a series of 
roles that correspond to different areas of Web site design and management. Examples might be 
“application developer,” “designer,” “content editor,” or “business analyst.” He or she defines access 
privileges for each role; for example, the administrator might give access to the Pages and Components 
option to the application developer role but not to the business analyst role. 

The administrator then uses the People and Organizations > Control Center Users option to create a user 
profile for everyone who uses the ATG Control Center, and assigns each user one of the roles that he or 
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she has set up. The parts of the ATG Control Center that you can use, therefore, depend on the role you 
have been assigned. 

For more information, please see Managing Access Control in the ATG Programming Guide. 

Stopping the ATG Control Center 
To shut the ATG Control Center down completely, select Exit from the File menu. This option 
automatically disconnects you from the ATG server and closes the ATG Control Center window. 

If you want to disconnect from the server without closing the ATG Control Center, select Disconnect from 
Server from the Tools menu. The main ATG Control Center window remains open, but you must log in 
again before you can do any work in the task windows. 

ATG Control Center in Other Documentation 
Please note that this manual covers only those parts of the ATG Control Center that apply to business 
users. For example, it does not describe how to use the Components By Module or Components By Path 
menu items, which are used by application developers but accessed only rarely by other users. In 
addition, this manual describes only ATG server products and does not explain how to use applications 
such as ATG Business or Consumer Commerce, which are described in their own documentation. 

The following list shows where to look for information on the parts of the ATG Control Center not covered 
by this manual: 

 

Menu Item Associated Task Documented 
in… 

People and Organizations > 
Control Center Users 

Setting up security access for the ATG 
Control Center 

ATG Programming 
Guide 

People and Organizations > 
Control Center Groups 

Setting up security access for the ATG 
Control Center 

ATG Programming 
Guide 

People and Organizations > 
Profile Repository 

Creating and maintaining user profiles ATG 
Personalization 
Programming 
Guide 

Pages and Components > 
Dynamo Server Pages 

Creating content pages (JHTML files) ATG Page 
Developer’s Guide 

Pages and Components > J2EE 
Pages 

Creating content pages (JSP files) ATG Page 
Developer’s Guide 
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Pages and Components > 
Components by Module 

Pages and Components > 
Components by Module 

Creating and managing Nucleus 
components 

ATG Programming 
Guide 

 

Note also that the ATG Control Center online help contains extensive information on all areas of the 
product. To access the help, select Help > Help. 
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2 Overview: Creating a Personalized 

Web Site 

The tasks that a business user performs with ATG 10.0.2 cover a range of planning and management 
activities related to setting up and maintaining a Web site. You perform many of these activities in the 
ATG Control Center. However, the tasks you carry out depend on the parts of the ATG product suite that 
you have installed. 

This chapter presents an overview of the steps you carry out to set up a fully personalized site with the 
ATG platform. 

1. Set up visitor profiles 

At the foundation of ATG’s personalization system are visitor profiles, a collection of 
properties that you use to store a range of data about everyone who visits your Web 
site. You use this data to tailor the content of your site so that, on subsequent visits, 
each person sees information that matches his or her interests and requirements. 

The ATG system creates visitor profiles automatically, but there are some setup and 
maintenance tasks that you may need to perform to prepare them for the next step in 
the personalization process. 

For more information, see Setting Up Visitor Profiles. 

2. Create profile groups 

The next step is to put your visitor profiles into groups that represent your Web site’s 
target audiences. For example, you could set up groups based on income range, 
geographic location, or buying style. You use the profile groups to determine what 
content you show to whom – for example, you might advertise a specific product to 
one group and a different product to another. 

For more information, see Creating Profile Groups. 

3. Set up content items 

Web site content is the text, images, and other items (for example, magazine articles or 
product descriptions) that your visitors see on your site’s pages. Content is usually 
created by a site designer or page developer, and it is stored in content repositories. 
Like a visitor profile, each content item has a range of properties that defines it. You 
use these properties when you set up content groups, targeting rules, and tracking 
sensors for your site, and preparing these properties is one of the tasks you perform as 
part of setting up a personalized site. 

For more information, see Setting Up Content Items. 
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4. Group content items together 

In the same way that you group visitor profiles together, you must also identify similar 
content items and put them into groups. For example, if you based your profile groups 
on geographic location (one for U.S. visitors and another for European visitors), you 
would then create content groups that defined the content that was appropriate for 
each profile (articles on the New York stock exchange for the US group, articles on 
European markets for the European group). 

For more information, see Creating Content Groups. 

5. Match content with your target audiences 

Now that you have set up visitor profile groups and content groups, you can create 
business rules (called content targeters) that match the two together – in other 
words, business rules define the content that you show to each profile group. For 
example, you could write a rule telling the site to display items from the content group 
that includes articles about the US stock market to anyone in the profile group for site 
visitors from the US. In addition to varying content delivery according to a visitor’s 
profile, you can also change it according to the date, the time of day, and other 
conditions. For more information, see Matching Content with Your Target Audiences. 

If you use the Scenarios module, you can create and use scenarios instead of targeting 
rules to control the content that you display to each profile group. See Creating 
Scenarios for more information. 

6. Track visitor behavior 

An important part of the process of personalizing a Web site is updating visitor profiles 
with fresh data. This step allows you to consistently show visitors the content that is 
most relevant for them. For example, you probably want to track the site pages that 
each visitor displays so that you can determine the content that interests him or her 
the most. To do this, you set up tracking sensors that monitor your visitors’ Web site 
behavior and activities and update their profiles accordingly. For more information, 
see Tracking Visitor Behavior. 

If your site use the Scenarios module, you can use scenarios instead of sensors to track 
visitor behavior and update their profiles. See Creating Scenarios for more 
information. 

7. Preview your Web site 

The ATG Control Center provides preview features that you use to check how your 
Web site will look to visitors with certain profile properties under various time 
conditions. For example, you can see how a particular page in the Quincy Funds demo 
will appear to visitors who describe their investment strategy as “conservative.” For 
more information about previewing, see Previewing Your Web Site. 

8. Analyze data 

This step applies only if your site uses ATG Customer Intelligence. 

Creating business reports allows you to capture and analyze a wide range of data 
related to your site visitors and their activities at your Web site. By analyzing this data, 
you can improve your visitors’ experiences at your Web site, predicting their needs 
and responding by providing more relevant content. You can also use data from 



A T G  P e r s o n a l i z a t i o n  G u i d e  f o r  B u s i n e s s  U s e r s  

 

1 1  

2  -  O v e r v i e w :  C r e a t i n g  a  P e r s o n a l i z e d  W e b  S i t e  

μ
reports to fine-tune your scenarios and make changes to your Web site design. For 
more information, refer to the ATG Customer Intelligence documentation. 

Additional Business User Activities 
You can also use the ATG platform to create and maintain workflows, which allow you to set up many 
business processes so that they can be performed online. For example, you can set up a Web-based 
approval process for employee expenses and make it available on your company’s intranet. Although not 
required as part of setting up a personalized Web site, activities such as creating workflows allow you to 
further streamline your organization’s internal practices by making them part of the same system you use 
to interact with the people who visit your external Web site. 

For more information on workflows, see Using Workflows. 
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3 Setting Up Visitor Profiles 

When a person visits your Web site, the ATG platform automatically creates a profile for him or her and 
stores it in a profile repository set up by the application developers working on your Web site. The profile 
contains properties that describe the person’s characteristics. There are two kinds of profile properties: 
explicit and implicit. Site visitors provide explicit properties themselves, for example when they fill out a 
registration form to become a member of your site. Examples of explicit properties are a person’s name 
and address. Implicit properties, in contrast, represent information that the system gathers about visitors 
by tracking their behavior at your site. A list of recently browsed Web pages is an example of an implicit 
property. 

Keeping track of profile properties makes it possible for a Web application to “remember” who users are 
from one visit to the next, and to deliver personalized content to them accordingly. For example, you 
could have an option on your registration form that asks visitors to indicate their income range; the 
system stores this information as a profile property. You could then set up your site content so that you 
display different items according to the income range of each site visitor. 

Usually, the system updates profile properties automatically; you do not have to change them yourself. 
However, the ATG Control Center includes options that let you view the profiles in the repository. You can 
also use them to add, edit, and delete profiles if necessary. 

Note: If your ATG installation uses ATG Content Administration, it is recommended that you use the ATG 
Business Control Center to manage visitor profiles. For more information, refer to the ATG Business Control 
Center Administration and Development Guide. 

Viewing Visitor Profiles 
Business users generally view profiles in the profile repository by means of the Users window. To display 
it, select People and Organizations > Users. The following image shows the Users window: 
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People and Organizations > Users window 

Use the query editor at the top of the window to find and display visitor profiles. For example, to find all 
profiles that have a Gender property set to female, you would do the following: 

1. Click in the small diamond after User and select whose from the drop-down list that 
appears. 

2. Click in the area after whose and select Gender from the drop-down list. (The items 
you see in this list correspond to the properties in your profile repository, so Gender 
might not appear on your system.) 

3. Click in the area after Gender and select is from the drop-down list. The items here 
are operators that define the relationship between the first half of the expression and 
the second. 

4. Click in the area after is and select female from the drop-down list. (The items here 
are the possible values for the property you specified in step 3.) 

At this point, the query would look like this: 



A T G  P e r s o n a l i z a t i o n  G u i d e  f o r  B u s i n e s s  U s e r s  

 

1 5  

3  -  S e t t i n g  U p  V i s i t o r  P r o f i l e s  

μ
 

Click List. In the panel on the left, the system displays a list of all the profiles with a 
Gender property set to female. (By default, items in this list are ordered alphabetically 
by their Login Name values.) 

When you select a profile from the list, a table showing the properties in the profile and their current 
values appears on the right side of the window: 

 

Sample Profile in the Users Window 

Information in the right pane is displayed as follows: 

 The Profile tab shows the profile properties for this visitor. 

 The Roles tab shows the organizational and global roles to which this person is 
assigned. Organizational roles appear with checkboxes at the top of the window. 
Global roles appear in the Additional Roles list at the bottom. For more information, 
see Creating Roles later in this chapter. 
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Determining the Profile Type 

In versions 5.5 and later of the Personalization module, it is possible to have more than one type of visitor 
profile in the same profile repository. The developers working on your site can create a base set of profile 
properties for every user, and then create sub-types that include additional properties unique to each 
subset. For example, you could create a base set of profile properties that are common to all site users, 
and then add two sub-types, “administrator” and “visitor.” Each sub-type would have its own distinct 
properties in addition to the common ones. 

These sub-types are called “profile types,” and you can use them in most places in the ATG Control Center 
where you are required to define groups of site visitors; for example, you can use them as filters in 
scenario People elements or as part of a content targeting rule. 

To view the different profile types in your system, use the query field in the Users window. Click the Users 
entry as shown in the following example, taken from the profile repository supplied with the Quincy 
Funds demo: 

 

In this example, the profile repository includes the base profile type, User, as well as two sub-types, 
Investor and Broker. 

To see the profile properties associated with a specific profile type, perform a query for that type and then 
click List. The names of site visitors assigned that profile type appear in the list on the left of the Users 
window. When you select one of the names, the right pane of the window displays the properties from 
the base profile type in your system as well as the properties that are unique for that type. 

Note that the ATG Control Center does not currently support changing a user’s sub-type after you have 
created his or her profile. For example, in the Quincy Funds demo, you cannot change a user’s profile sub-
type from “broker” to “investor.” If you do need to change a user’s sub-type, you must delete his or her 
profile and then add a new one, specifying the correct sub-type. 

For more information, refer to Defining the Profile Repository in the ATG Personalization Programming 
Guide. 

Editing Profile Values 

As mentioned above, you do not usually have to edit the values in profile properties yourself; the ATG 
system does this automatically. For example, as part of creating a personalized Web site, you set up 
sensors or scenarios that track visitor’s behavior at your site and change profile properties accordingly. Or 
your developers might create a registration form with specific fields for new members to fill out; they set 
the form up so that the system updates the new member’s profile with the information he or she enters. 
However, there may be some situations in which you do have to edit a value yourself. For example, a site 
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visitor might contact customer service with a request to change some of his or her information. To edit a 
value, do the following: 

1. Select People and Organizations > Users. 

2. Find and display the visitor profile that contains the value you want to change. 

3. Click the cell for that value to make it active. 

4. Change the value as needed. The way you enter the new value depends on the type of 
property you are working with. 

 If a drop-down menu button appears when you highlight the value field, click 
the button and select the new entry from the list. 

 If an ellipsis button (a button with “…”) appears when you highlight the value 
field, click the button. An edit dialog box appears, which you use to specify the 
new entry. In some cases you select the entry from a list of possible values; in 
others, you type the entry into the edit box. 

 For fields that can contain more than one value, an ellipsis button leads to a 
dialog box containing Insert Before and Insert After buttons. See Filling in 
Properties with Multiple Values for more information on how to use this dialog 
box. 

 If the value field contains a small black arrow, the value is linked to another item 
type in the repository. Click the arrow. Then click the ellipsis button to open a 
search dialog box where you can select or create new repository items of that 
type. 

 If no buttons or other interface elements appear when you highlight the value 
field, you can type the new value directly into the cell. 

 Required properties have an asterisk next to their names. 

 Read-only properties are displayed in gray. You cannot edit their values. 

 Some properties are linked to other properties from which they inherit their 
values. For more information, see Editing Derived Properties. 

5. Select File > Save. 

Editing Derived Properties 

Some profile property values are inherited from other properties or from a parent organization or role 
(see Using Organizations and Roles later in this chapter). These properties have the following icons: 

 Indicates a property that inherits its value from another property (for example, in a parent 
organization or role). 

 To see how the property inherits its value, click the icon and select Derivation Details 
from the pop-up menu. 

 To override the inherited value, click the “...” button or type the new value directly into 
the field. 

 Indicates a property whose inherited value is currently being overridden by its own local value. 
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 To see how the property inherits its value, click the icon and select Derivation Details 

from the pop-up menu. 

 To use the derived value, click the icon and select Use Derived Value from the pop-up 
menu. 

 Indicates a property whose value comes from a property in a different repository item. 

 To edit the repository item, double-click the icon to open the Item Editor. 

 To select or create another repository item of that type, click the “...” button. 

Adding Visitor Profiles 

When a site visitor registers at your site, the ATG system automatically adds a profile for him or her to the 
profile repository. (It also creates a different type of temporary profile for anonymous visitors – those who 
visit your site but do not register. For more information, see Working with User Profiles in the ATG 
Personalization Programming Guide.) For this reason, you do not usually have to add profiles to the system 
yourself. However, if you do have to add a profile, for example for test purposes, follow this procedure: 

1. Display the Users window (People and Organizations > Users). 

2. Select File > New User. The New Item dialog box appears. 

3. In the Item Type list, select the type of profile that you want to add. For more 
information on different profile types, see Determining the Profile Type. 

4. Enter values as necessary. Properties with an asterisk are required, but the rest are 
optional. See Editing Profile Values for more information. 

The system adds the new profile and displays it in the list on the left of the Users 
window. (By default, items in this list are ordered alphabetically by their Login Name 
values.) 

Deleting Visitor Profiles 

To delete a visitor profile from the profile repository, do the following: 

1. Display the Users window (People and Organizations > Users). 

2. Find and display the profile you want to delete. 

3. Right-click on the user’s name in the list on the left. 

4. Select Delete from the pop-up menu. 

5. Click Yes to confirm the deletion. 

A Note about the Profile Repository Window 

Depending on your security access role (see Security Access in the ATG Control Center), you may be able 
to view and work with visitor profiles through both the Users window and the People and Organizations > 
Profile Repository window. 

The Users window is designed for business users. It shows a subset of information that is contained in the 
profile repository. When you add, edit, or delete information in the Users window, you are in effect 
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making these changes to the profile repository as well. For example, if you edit a value in the Users 
window (changing a visitor’s marital status to “married,”), the change also appears in the Profile 
Repository window. The reverse, however, is not always true; when you add or edit certain properties 
through the Profile Repository window, your changes do not appear in the Users window until you restart 
the ATG server to which the ATG Control Center is attached. 

The same caveat applies to the Organizations and Roles windows (see the next section). It is highly 
recommended that you use these windows rather than the Profile Repository window to add or edit user 
directory items. 

Using Organizations and Roles 
In addition to setting up profiles for individual users (customers who are site visitors, or other types of site 
users such as administrators), you can set up additional profiles for abstract entities called “organizations” 
and “roles” and use them to create a multi-level organization of site users grouped by function. 

Some sites require only a one-level or flat organizational structure for their visitors. For example, a large 
retail site may have many different types of visitor (new customers, frequent buyers, customers with a 
high income, residents of a specific area), and those visitors may have dramatically different needs in 
terms of the content of the site. Regardless of their different requirements, however, they perform 
essentially the same role – retail customer – at the site. For a site such as this, the organizational structure 
of visitors requires one level only. 

A profile repository configuration that includes organizations and roles is useful for sites that serve a 
variety of visitors with widely differing functions. (Often, for these sites, the term “user” is more 
appropriate than “visitor” or “customer.”) For example, a business-to-business commerce site might have 
some users who are buyers and others who have the supervisory role of approving certain purchasing 
decisions. In addition, other users may act as administrators for the site. In this case, the site’s 
organizational structure could have two or possibly three levels. Other examples of sites that might 
involve multi-level user relationships are sites that manage interactions between a business and its 
partners, or sites that function as an Internet community or discussion forum. 

How Organizations and Roles Work 

Organizations correspond to the different ways you can group users. For example, you could set up 
organizations that correspond to the different business units in a company, or to different geographic 
areas. Like users, each organization has its own profile in the profile repository. The following example 
shows the profile of an organization called US Motor Works: 
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Organization profile 

Roles correspond to specific functions that a person can perform within an organization, such as “vice 
president” or “administrator.” Like users and organizations, each role has its own profile in the repository. 
The following example shows the profile of a role called “Senior Approver”: 

 

Role profile 

After you have set up organizations and roles, you assign users to them. Depending on the way your 
profile repository is configured, users can inherit the profile properties of the organization or role to which 
they are assigned. In the same way, you can assign roles to organizations; in this case, any user who is a 
member of an organization automatically inherits any roles you have assigned to it. You can also create a 
hierarchy by assigning organizations to other organizations; for example, you could assign two 
organizations called “North West” and “South West” to an organization called “Western Region.” Again, 
each child organization can inherit the profile properties of the parent organization. 

You can use a combination of users, organizations, and roles (also called a “user directory”) to control 
access to various areas of the site. You can also use them as you would use profile groups – you can set up 
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scenarios and targeters that deliver appropriate content to members of a given organization, for example, 
or to users assigned a specific role. (For more information on scenarios, see Creating Scenarios. For more 
information on profile groups, see Creating Profile Groups.) 

Note that the ATG Control Center itself contains a working implementation of a user directory. Each ATG 
Control Center user has a profile in the Admin SQL Repository, and the ATG system administrator can view 
and edit the profiles through the People and Organizations > Control Center Users window. In addition, 
the administrator uses the People and Organizations > Control Center Groups window to set up ATG 
Control Center roles (for example, developer, designer, or manager) that include access rights to each 
area of the ATG Control Center. The administrator then assigns each user to a role, and the user inherits 
the access rights of that role. 

For information on how to use organizations and roles for site security and access control, refer to the ATG 
Programming Guide. 

Creating Organizations 
You can use the People and Organizations > Organizations window in the ATG Control Center to add, 
view, and delete organizations. You can also use it to assign users and roles to organizations. The 
following image shows the Organizations window: 

 

People and Organizations > Organizations window 
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The left pane shows any organizations you have already set up. 

Information in the right pane is displayed as follows: 

 The Profile tab shows the profile properties for this organization. Note that, as you can 
for user profiles, you can have more than one type of profile for organizations in your 
system. Each type shares a set of base properties and then has a set of additional 
properties unique to that type. In the image above, the profile type for this 
organization is group. 

 The Members tab shows a list of the users assigned to this organization. Click on a 
user’s name to see his or her profile and roles. 

 The Roles tab shows a list of roles that belong to this organization. 

Adding a New Organization 

Before you can add new organizations in the ATG Control Center, you may have to set up an organization 
template by adding the profile properties that make up an organization to the profile repository 
definition file. For information on how to do this, refer to Working with the Dynamo User Directory in the 
ATG Personalization Programming Guide. 

To add a new organization, complete the steps below. 

1. Select People and Organizations > Organizations. The Organizations window appears. 

2. In the left pane of the window, select the position in the organization hierarchy where 
you want to create the new organization. (See also Assigning an Organization to 
Another Organization.) 

3. Click the New Organization button. The New Item dialog box appears. 

4. Select Organization from the Item Type dropdown list. 

5. In the New Organization Values area of this dialog box, specify values for this 
organization’s profile properties. Properties with an asterisk are required. Other 
properties are optional. 

For information on how to add new properties to the template for this organization, 
refer to Working with the Dynamo User Directory in the ATG Personalization 
Programming Guide. 

6. Click OK. The new organization appears in the list in the left pane. 

Duplicating Organizations 

If your user directory contains several organizations with similar profiles, you can save time during the 
setup process by creating one and then copying it as many times as you need. You then have to edit only 
the profile properties that are unique to each one. 

1. In the left pane of the Organizations window, select the organization you want to 
copy. 

2. Right-click the organization’s name in the list. 
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3. Select Duplicate from the right-click menu. A copy of the organization appears in the 

list on the left. 

4. Type a new name for the copy in the Name field and change any other properties as 
required. 

5. Select File > Save. 

Deleting Organizations 

To delete an organization, complete the following steps: 

1. Check any existing profile groups, content targeters, and scenarios that may contain 
references to the organization you want to delete, and rewrite them if necessary. 

2. In the People and Organizations > Organizations window, select the organization you 
want to delete. 

3. Select File > Delete Organization. 

Assigning Users to an Organization 

To assign users to an organization, complete the steps below. Note: It is highly recommended that you 
perform this task in the Organizations window, as described, rather than in the Profile Repository window. 
See A Note about the Profile Repository Window for more information. 

1. In the People and Organizations > Organizations window, select the organization to 
which you want to add a user. 

2. Display the Members tab for this organization. 

3. Click the Add Member button. The New Item dialog box appears. You can add an 
existing user to the organization or create a user and add him or her as a member of 
the organization. 

To create a user in the repository, click the New Item button and enter the user’s 
profile information in the form that appears. 

To add an existing user as a member of the organization, find the user in the 
repository by creating a query in the query field at the top of the window. You can 
select more than one member from the list that your query returns. Hold down the 
Control key while selecting the users you want to add, and click OK when you are 
ready to add the users to the organization. 

The new member appears in the top half of the Members window. If you click the new 
member’s name, his or her profile appears in the bottom half of the window. Click the 
Roles tab to show a list of roles to which this user is assigned. 

You can delete members of an organization by selecting them from the list of members and choosing File 
> Remove Members. 

If your organizational structure includes several levels, refer to A Note about Displaying Organizational 
Inheritance for information on displaying the membership list for child and parent organizations. 



A T G  P e r s o n a l i z a t i o n  G u i d e  f o r  B u s i n e s s  U s e r s  

 

2 4  

3  -  S e t t i n g  U p  V i s i t o r  P r o f i l e s  

μ
Assigning an Organization to Another Organization 

As described earlier, you can set up multi-level organizations where one organization is considered to be 
the “child” of another. In this case, the child organization inherits the properties of its parent organization. 
Any user that you assign to the child organization is automatically a member of the parent as well 
(assuming your profile repository is set up to allow inheritance). 

To turn an existing organization into the child of another, use drag and drop functionality: 

1. Display the People and Organizations > Organizations window. 

2. Select the organization that you want to turn into a child organization. 

3. Drag its icon to the new place in the tree. 

To create an organization as a child of another organization, follow the steps in Adding a New 
Organization. In step 2, select the organization that you want to designate as the parent, and then 
continue with the procedure. 

A Note about Displaying Organizational Inheritance 

Note that the Organizations window shows only users who are directly assigned to each organization; 
users who are members of a child organization are not listed as members of the parent organization, even 
though they do inherit membership of the parent. Consider the following example. You create a parent 
organization called West Coast and a child organization called Sales. You assign an employee called Ruth 
to the child organization. She inherits membership of the parent organization, but in the Members panel 
of the Organizations window she appears only as a member of the Sales organization, the one to which 
she is directly assigned. 

See also A Note about Displaying Role Inheritance. 

Creating Roles 
 

You can then use the People and Organizations > Roles window in the ATG Control Center to add, view, 
and delete roles, and to assign roles to users and organizations. The following image shows the Roles 
window: 
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People and Organizations > Roles window 

The list in the left pane shows any roles and organizations you have already created. Information in the 
right pane of the Roles window is displayed as follows: 

 The Profile tab shows the profile properties for this role. Note that, as you can for user 
profiles and organizations, you can have more than one type of profile for roles in your 
system. Each type shares a set of base properties and then has a set of additional 
properties unique to that type. 

 The Members tab shows a list of the users and organizations assigned to this role. 

Roles can be either global or organizational as described the following sections. 

Global Roles 

Global roles represent any type of generic or specific function or activity that you choose. You can do the 
following with a global role: 

 Assign it to any users or organizations, which then inherit the properties of that role as 
additions to their own profiles. 

 Group similar global roles together into folders to help you manage them more easily. 
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Organizational Roles 

Organizational roles are specific to a particular organization. You can do the following with an 
organizational role: 

 Assign it to the organization under which you created it in the Roles window. (Note 
that you cannot assign an organizational role that you created for Company Y to 
Company Z.) The role is then automatically assigned to all users who belong to that 
organization. 

 Assign it to any individual user who is a member of the organization to which the role 
belongs. In this case, other members of the organization do not automatically inherit 
the role’s properties. 

Organizational roles contain a property called “function” that you can use as a way of identifying similar 
roles in different organizations. Suppose you have a business-to-business commerce site. The companies 
with whom you do business are defined as organizations in the ATG Control Center – you create an 
organization called Company A and another called Company B. Each company has buyers who are 
responsible for buying products from your site. You decide that you want to offer different prices to each 
buyer depending on his or her organization; for example, you want buyers from Company A to have a 
15% discount on any backordered item, but you do not want to offer this discount to buyers from 
Company B. 

You set up two organizational roles, Buyer A and Buyer B, and assign one to each organization. You can 
then design your pricing structures and scenarios to differentiate between the two, offering distinct 
discounts to each role. However, in other ways the two roles are very similar, and you decide you want to 
establish a connection between them. You specify “buyer” as the function property for each role – this 
property acts as a sort of keyword and allows ATG 10.0.2 to keep track of the fact that the roles are related. 
Your site developers could then write custom applications that use this property in a variety of ways; for 
example, they could create custom scenario events that are triggered by members of any organizational 
role with a given function value. (See Creating Scenarios for more information.) 

The following images show the profiles you set up for the two organizational roles. Note that the value of 
the Function property is the same for each one. 
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Adding a New Role 

Before you can create new roles in the ATG Control Center, you may have to set up a role template by 
adding the profile properties that make up a role to the profile repository definition file. For information 
on how to do this, refer to Working with the Dynamo User Directory in the ATG Personalization Programming 
Guide. 

In addition, it is important to consider the following information about role names before you start 
adding roles: 

 The names you give global roles must be unique within their folder. However, if you 
want to use global roles to define membership of a profile group (so that you can then 
use a person’s role as a basis for content targeting, for example), all global roles names 
must be unique within the profile repository. 

 The names you give organizational roles need to be unique only within their 
organization, even if you plan to use them to define a profile group. 

For more information on using roles within a profile group or to perform content targeting, see Defining 
Profile Group Members. 

To add a new role, complete the following steps: 

1. In the list on the left, select the position where you want the new role to appear. For 
example, to create a global role in a specific folder, select that folder. If you are 
creating an organizational role, select the organization to which you want this role to 
apply. Note: To create an organizational role, you need to have created the 
corresponding organization already. See Adding a New Organization earlier in this 
chapter. 

2. Click the New Role button. The New Item dialog box appears. 
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3. In the New Role Values area of this dialog box, specify values for this role’s profile 

properties. Properties with an asterisk are required. Other properties are optional. 

For information on how to add new properties to the template for this role, refer to 
Working with the Dynamo User Directory in the ATG Personalization Programming Guide. 

If the role’s properties include Direct Access Rights, you may be able to use roles to 
control user access to the pages of your Web site. For more information, see Using 
Roles for Access Control. 

4. Click OK. The ATG Control Center adds the new role to the list. 

Important: Organizational roles are not automatically assigned to the organizations 
under which you create them. You must assign them explicitly. See Assigning a Role 
for more information. 

Deleting Roles 

To delete a role, complete the following steps: 

1. Check any existing profile groups, content targeters, and scenarios that may contain 
references to the role you want to delete, and rewrite them if necessary. 

2. In the People and Organizations > Roles window, select the role you want to delete. 

3. Select File > Delete Role. 

Assigning a Role 

If you assign a role to a user, he or she inherits its profile properties, including any accompanying security 
access rights. Similarly, if you assign a role to an organization, every member of that organization inherits 
that role. (Note that your profile repository may be configured so that this behavior does not occur; see 
the ATG Personalization Programming Guide for information on configuring profile property inheritance.) 

There are several methods you can use to assign roles to users or organizations. The one you choose 
depends on the scope of the task. If you are assigning a role to many users or several organizations, for 
example during initial configuration of a new system, use the Roles window. See Assigning a Role to 
Multiple Users or One or More Organizations. If you are working with just one user, for example a new 
employee that you have added to an existing system, it is easier to assign roles through the Users 
window. See Assigning a Role to a Single User. 

Note: It is not recommended that you perform this task in the Profile Repository window. See A Note 
about the Profile Repository Window for more information. 

Assigning a Role to Multiple Users or One or More Organizations 

This method uses the Roles window to assign roles, which represents the easiest way to complete this 
task in cases where you are working with a large number of users at once. It is also a convenient way to 
assign roles to any number of organizations. 

1. Display the People and Organizations > Roles window. 

2. Select the role you want to assign. 
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3. Select File > Add Member. The Add Member dialog box appears. 

4. Use the query box at the top of the display to list the users or organizations to whom 
you want to assign the role. You can assign a global role to anyone or to any 
organization, but you can assign organizational roles only to users who are already 
members of that organization. 

5. Click OK. 

Assigning a Role to a Single User 

The procedure below describes how to use the People and Organizations > Users window to assign roles. 
This method is convenient for situations where you want to assign a role to an individual user. 

1. Display the People and Organizations > Users window. 

2. Select the user to whom you want to assign a role. 

3. Display the Roles tab. The roles available to this user appear. The top panel shows all 
organizational roles available to the organization to which this user belongs. The 
bottom panel (Additional Roles) shows all global roles that you have already assigned 
to this user. 

Organizational roles that have already been assigned to all users in this organization 
appear in gray; you cannot edit them in this window. Organizational roles that you 
created for this organization but have not assigned to all users appear in black. To 
assign one of these to this user, select the checkbox. 

A Note about Displaying Role Inheritance 

As described earlier, users who are members of a given organization automatically acquire any global or 
organizational roles that you assign to that organization. Role inheritance also works for child 
organizations; a user who is assigned to a child organization inherits the roles of the parent organization. 

Note that the only way to view all the roles that a user has inherited is through the People and 
Organizations > Roles window. You cannot identify all a user’s inherited roles through the Users window; 
in this window, you can see only the roles that a user is assigned individually and the roles associated with 
the organization to which he or she has been directly assigned. 

Consider the following example. You create an organization called West Coast and you create an 
organizational role for it called West Coast Employee. Then you create a child organization called Sales 
and an organizational role for it called Sales Team. You assign an employee called Ruth to the child 
organization. She inherits the Sales Team role from her own organization, and she also inherits the West 
Coast Employee role from the parent organization. 
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Organization: West Coast

Role: West Coast Employee

Organization: Sales
Role: Sales Team

User: Ruth

Parent organization

Child organization

 

If you view Ruth’s role information in the People and Organizations > Users window, or through the Users 
panel that appears in the People and Organizations > Organizations window, you can see only the Sales 
Team role, which is the role associated with the organization to which she is directly assigned. The West 
Coast Employee role is not listed. 

 

Users window showing roles for organizations to which a user is directly assigned 

To confirm that Ruth has indeed inherited the role of West Coast Employee, use the Roles window: 

1. Display the People and Organizations > Roles window. 

2. Select the West Coast Employee role from the list on the left. 
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3. Display the Members tab. 

4. In the query box, specify Items of Type User, and then click List. 

5. Verify that Ruth’s name appears in the list, as shown in the image below: 

 

Roles window showing all users assigned to an organizational role 

See also A Note about Displaying Organizational Inheritance. 

Using Roles for Access Control 

Depending on the configuration of your ATG product suite, you may be able to use roles to control access 
to the pages of your Web site. For example, you might have several pages on your site that you want to 
make available only to customer service representatives. You can set up a role called Customer Service 
Rep and add an access right to that role that allows entry to the specified site pages. Any user who is 
assigned that role (either directly or by inheriting it through membership of an organization) can access 
the appropriate pages. For information on how to set up roles to perform access control, see the ATG 
Personalization Programming Guide. 

Note that role-based access rights are typically used to control access among internal users (employees of 
your company). For external site visitors, such as customers, access control to specific areas of a Web 
application is usually configured through methods such as registration, login requirements, and password 
authentication. For more information, see the ATG Personalization Programming Guide. 
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4 Creating Profile Groups 

A profile group represents a segment of your target audience. You create these groups in the Profile 
Groups window by defining rules that include or exclude visitors according to their profile properties. For 
example, you could create a profile group called HighEarners that includes female college graduates 
earning more than $150,000 per year but excludes people from California. The rules that define this group 
might look something like this: 

Include these people: 

   people whose Gender is Female 

   and whose educationLevel is College Graduate 

   and whose annualIncome is greater than 150000.00 

--------------------------------------------------- 

Exclude these people: 

   people whose Home address.state is California 

Once you set up this profile group, you can use the Targeting > Content Targeters window to create 
targeting rules for delivering personalized content to people who match the HighEarners criteria. For 
example: 

Show this content: 

   newLuxuryCars.jsp 

To these people: 

   people in group HighEarners 

As you can see, segmenting your target audiences into profile groups can simplify your targeting rules 
and make them easier to maintain. 

Important: In the ATG Business Control Center, profile groups have been replaced by user segments, 
which provide additional functionality (a more flexible editor for specifying the rules that make up a 
group). If your ATG installation uses ATG Content Administration, it is strongly recommended that you use 
the ATG Business Control Center rather than the ACC to accomplish the tasks described in this chapter. In 
addition, if you are working in a multisite ATG environment (one in which a single instance of ATG 
products supports more than one Web site), please be aware that profile groups do not have any multisite 
capability. User segments created through the ATG Business Control Center are multisite aware. For more 
information on user segments, refer to the ATG Business Control Center User’s Guide. For information on a 
multisite environment, refer to the ATG Multisite Administration Guide. 

Using Profile Groups with Organizations and Roles 

Profile groups can exist independently of organizations and roles (see Using Organizations and Roles). 
You do not have to set up a user directory in order to perform content targeting with profile groups. 
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Conversely, you can set up a user directory and use it to perform content targeting without creating any 
profile groups; instead, you can create content targeters or scenarios that use a person’s assigned 
organization or role to determine the content to display. For examples, see Creating Scenarios. 

Viewing Profile Groups 
You can view a list of existing profile groups through the Profile and Content Groups window in the ATG 
Control Center. To display this window, select Targeting > Profile and Content Groups. 

 

Targeting > Profile and Content Groups window 

The window has the following features: 

 The panel on the left shows a list of folders containing the profile or content groups 
that have already been created for your Web site. Profile groups are identified by the 

icon. 

 The panel on the right panel shows all profile groups in the selected folder. You can 
add new groups to this list by clicking the New Group button on the toolbar. For more 
information, see Creating New Profile Groups. 

 The Name column shows the name of each group in the selected folder. Note that the 
arrow next to the column title shows how groups are sorted in this list; in this example, 
the profile groups are sorted alphabetically by their entry in the Name column. 
Clicking the column title reverses the sort order. 
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 The Content Source column shows the name of the repository containing the visitor 

profiles that are included in this group. (Note: Repositories are typically set up by the 
application developers working on your Web site. For more information on how 
repositories are created, refer to the ATG Repository Guide.) 

 The Content Type column shows the specific subset of items in the repository to which 
the visitor profiles in this group must belong. (The subset is often used elsewhere in 
the product for organizational or querying purposes.) 

 The Description column displays a brief description of each group. If the column is too 
narrow to display all the text, hold the mouse pointer over a description that you want 
to read. The description text appears in a blue box. 

To display the rules that define membership of a given profile group, click the group’s name in the Name 
column. The following window appears: 

 

Profile Group Definition window 

The window has the following features: 

 Include and Exclude buttons, which allow you to add rules that include or exclude 
specific profiles from this group; for example, you could set up a rule that includes any 
profile whose gender property is “male” or a rule that excludes profiles whose age 
property contains a value less than 21. 

 A blue definition panel that shows the rules for this profile group. 
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 A series of buttons (All People, People in Group(s), People with Role(s), People 

Whose…) that you use to define the rule selected in the definition panel. Note that 
more buttons become available as you edit the rule. 

Creating New Profile Groups 
Whenever you create a profile group, the system assigns a new property with the same name as the 
profile group to every profile of that type in the repository. It sets that property to “true” or “false” 
according to whether the profile meets the criteria for that group. For example, if you create a profile 
group called HighEarners for profiles of type Investor, the system gives every Investor profile a new 
property called HighEarners. If a profile fits the criteria for that group, the system sets the HighEarners 
property in that profile to “true.” If a profile does not fit the group criteria, the HighEarners property is set 
to “false.” The system uses this method to determine which profiles belong to each group. 

To create a profile group: 

1. Display the Targeting > Profile and Content Groups window, and click the New Group 
button in the toolbar. The Select New Group Type dialog box appears. 

2. Click Create New Profile Group, and then click Next. The following dialog box appears: 

 

Specify the folder where you want to store this profile group and then type a name for 
the group. Do not include spaces in the name. Note that these folders are internal to 
the ATG Personalization module, which tracks them through an ATG-specific path 
called a Nucleus address (for more information on Nucleus, refer to the ATG 
Programming Guide.) The address for a group folder is 
/atg/registry/RepositoryGroups/<folder name>. For example, the 
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UserProfiles folder shown in the example is located at the Nucleus address 
/atg/registry/RepositoryGroups/UserProfiles. Any new folders you create 
will be located at a similar address. 

3. Click Next. The following dialog box appears: 

 

Type a brief description for this profile group. The text appears in the Description 
column in the Profile and Contents Group window. You can edit the description later if 
necessary. 

4. Click Next. The following dialog box appears: 
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Select the profile type that corresponds to the visitors you want to belong to that 
group (assuming they meet the additional criteria you define). Using the example 
shown in the previous section, if you wanted all visitors to be able to qualify for a 
group called NewMembers, you would specify the base type of profile, Users. For a 
profile group called HighEarners that you knew would apply exclusively to visitors 
who were investors, you could specify the sub-type Investor as the profile type for that 
group. By constraining the potential membership of a profile group to a specific sub-
type of profile, you can minimize the number of profiles that the system must change 
as a result of creating the new group. 

5. Click Finish. 

The Profile Group Definition window appears, allowing you to set up the rules that 
define the members of the group. For more information, see Defining Profile Group 
Members. 

Defining Profile Group Members 
Each time you create a profile group, you need to set up a profile group definition that specifies the 
people you want to include in (or exclude from) the group. These definitions are made up of individual 
rule sets, each beginning with the phrase “Include these people” or “Exclude these people.” A horizontal line 
separates multiple rule sets within a single definition. For examples, see the Profile Group Definition 
Samples section. 

To create a profile group definition: 

1. Select the profile group from the Profile and Content Groups window. The Profile 
Group Definition window appears. 

2. Click Include or Exclude. 

 Use Include to specify the people you want to include in the group. 
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 Use Exclude to specify the people you do not want to include the group. 

The beginning of the new rule set appears in the definition panel. For example, if you 
click Include, the phrase “Include these people” appears. The following button bar 
appears immediately below the rule text: 

 

3. Specify the people you want to include or exclude: 

 Click All People if you want to include (or exclude) all visitors in the profile 
group. 

 Click People in Group(s) if you want to include or exclude people from other 
existing profile groups. The Profile Groups dialog box appears as shown below, 
allowing you to choose from among the existing groups listed in the Profile 
Groups panel. 

 

If multiple groups exist and you want to select more than one, hold down the 
Control key while making your selections. You can choose Everyone in Selected 
Groups or Only Those People Common to Selected Groups. When you click OK, 
a list of the groups you select appears at the bottom of the Profile Group 
Definition panel along with an Edit Groups button. Click this button if you need 
to change your group selections. 

If you select People in Group(s), you can define additional criteria by clicking the 
Whose button (described later in this section). 

 Click People with Role(s) if you want to include people assigned to specific 
global or organizational roles. When you select this option, the Select Role 
dialog box appears as shown below: 
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Use this dialog box to specify the role or roles you want to include in this profile 
group. If you specify more than one role, for example Role A and Role B, the 
profile group will include anyone who is assigned to either Role A or Role B (the 
equivalent of the Everyone in Selected Groups option described above). It is not 
limited to those people who are assigned both roles. 

Similarly, if you create a group that includes a role and another profile group, 
for example Role A and Profile Group B, the group will include everyone who is 
assigned Role A or is a member of Profile Group B. 

If you do require “and” instead of “or” behavior for groups that include more 
than one role, create the rule set by hand rather than through the ATG Control 
Center. For more information, see Creating a Rule Set for a Profile Group that 
Includes Roles in the ATG Personalization Programming Guide. 

Note that using roles to define profile groups gives you a way to use roles in 
content targeters or scenarios. Create a profile group that includes specific 
roles, and then include that profile group in the targeter or scenario. 

 Click People Whose (or Whose if you selected the People in Group(s) option 
described above) if you want to include or exclude people based on specific 
profile properties. When you select this option, several drop-down lists appear 
as shown below, allowing you to select the property, comparison operator and 
value you want to use to define the group. 
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The properties that are available for selection are drawn from the profile 
repository created for your Web site. (For more information, refer to Setting Up a 
Profile Repository in the ATG Personalization Programming Guide.) The selections 
in the Comparison Operator and Value drop-down lists change depending on 
the property you select. If the property has a limited set of values, the Value list 
includes all your possible choices. If the property has an unlimited number of 
values, you can type a unique value directly into the list as shown below. The 
required value type (“string” or “timestamp,” for example) appears next to the 
text field. 

 

4. If you want to add other condition statements to the rule, click the And Whose or the 
Or Whose buttons at the bottom of the Profile Group Definition window. For 
examples, see the Profile Group Definition Samples section. 

5. If you want to make the group definition even more specific, click Include or Exclude 
again to create a rule set within the definition, and then repeat step 3. 

6. Select File > Save when all your definition rules are set. Note that if you view a different 
switch windows without saving, the ATG Control Center automatically saves your 
changes. 

Important: After you create or edit profile groups in the ATG Control Center, you must copy your changes 
from the staging server to your live site. For more information, see Copying and Switching Databases in the 
ATG Installation and Configuration Guide. 

Deleting a Rule in a Profile Group Definition 

If you need to delete any of the rules you set up for a profile group, do the following: 

1. In the Profile Group Definition window, select the part of the definition you want to 
delete. 

 If you want to delete the entire definition, choose Edit > Select Entire Rule Set. 
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 If you want to delete an entire rule within the definition, click on the first line of 

the rule (Include these people:, for example) or choose Edit > Select Entire 
Rule. 

 If you want to delete a specific line within a rule, click on just that line. 

2. Select Edit > Delete. 

3. Select File > Save. 

Profile Group Definition Samples 

There are countless ways to combine profile group options to specify the people you want to include or 
exclude from certain groups. Profile group definitions are based on Boolean (“and/or”) logic, meaning 
that you can use AND statements and OR statements to create more sophisticated inclusion and 
exclusion rules. AND statements let you include (or exclude) people who meet all conditions in the profile 
group definition. OR statements let you include (or exclude) people who meet any of the conditions in the 
profile group definition. The following samples show how these subtle changes in the wording of a 
definition can change a group’s makeup completely. 

Sample 1: All people in the profile group called CarLovers who are (a) from Boston AND (b) male: 

Include these people: 

   people in group CarLovers 

   whose Home address.city is Boston 

   and whose Gender is male 

 

Sample 2: All people in the profile group called CarLovers who are (a) from Boston OR (b) male: 

Include these people: 

   people in group CarLovers 

   whose Home address.city is Boston 

   or whose Gender is male 
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Sample 3: All people in the profile group called CarLovers PLUS all people from Boston PLUS all male 
users. 

Include these people: 

   people in group CarLovers 

--------------------------------------------- 

Include these people: 

   people whose Home address.city is Boston 

--------------------------------------------- 

Include these people: 

   people whose Gender is male 

 

Moving or Renaming Profile Groups 
Important: When you rename a profile group, you must update all references you’ve made to it in other 
ATG Control Center windows. For example, if the group is referenced by a content targeter, be sure to 
update the targeting rules in the Content Targeters window. (For details, see the Setting Up Targeting 
Business Rules section.) Otherwise, the targeter will continue to refer to the old group name and errors 
will occur whenever it is invoked on the Web site. 
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To rename an existing profile group or move it to another folder: 

1. Select the profile group in the Profile and Content Groups window. 

2. Select File > Move/Rename Group. (Note: You cannot move or rename a group that is 
currently open in the ATG Control Center. To close the group, navigate to it by using 
the arrow buttons in the toolbar, and then select File > Close.) 

The Rename Group dialog box appears. 

3. To move the group to a different folder, select the destination folder from the list at 
the top of the dialog box. To rename the group, type the new name (do not include 
spaces). Note that these folders are internal to the ATG Personalization module; for 
more information, see Creating New Profile Groups. 

4. Click OK. 

Editing Profile Group Descriptions 
The Description column in the Profile and Content Groups window displays a description of each profile 
group. To edit the description: 

1. Select the group from the Profile and Content Groups window. (To select a group 
without opening it, click any column other than the Name column.) 

2. Select File > Edit Description. The Edit Description dialog box opens. 

3. Type the new description for the group and click OK. 

Deleting Profile Groups 
You can delete profile groups that you no longer need. Doing so only removes the group name, 
description, and definitions from the ATG Control Center; it does not affect the profiles of any group 
members. 

Important: When you delete a profile group, you must delete all references you’ve made to it in other 
ATG Control Center windows. For example, if the group is referenced by a content targeter, be sure to edit 
the targeting rules in the Content Targeters window. (For details, see the Setting Up Targeting Business 
Rules section.) Otherwise, the targeter will continue to refer to the deleted group and errors will occur 
whenever it is invoked on the Web site. 

To delete an existing profile group: 

1. If the group you want to delete is open, navigate to the group’s window by using the 
arrow buttons on the toolbar, and then close it by selecting File > Close. 

2. Select the profile group from the Profile and Content Groups window. (To select a 
group without opening it, click any column other than the Name column.) 

3. Select File > Delete Group. 
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4. When the confirmation dialog box appears, click Yes to confirm the deletion. 

Copying Profile Groups to the Live Site 
After you create or edit profile groups in the ATG Control Center, you must copy your changes from the 
staging server to the live site. For more information, see Copying and Switching Databases in the ATG 
Installation and Configuration Guide. 
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5 Setting Up Content Items 

A content item is a single piece of information available for display on your Web site, such as a press 
release, a mutual fund prospectus, or an image of a product. Each content item has certain properties, 
usually determined by the author or content administrator, that describe its characteristics. For example, 
a mutual fund prospectus might have a content property called LastModified with a value of 
“04/16/2000.” 

All the content items for your site are stored in searchable content repositories. These repositories are 
typically set up by the application developers working on your Web site. (For more information on how 
content repositories work, see the ATG Repository Guide.) Your site may also be set up to access content 
stored in a third-party content management system from another commercial vendor. 

As stated above, the properties for your content items are usually specified by the content administrator 
or the person who initially adds each content item to its repository. In some cases, however, you might 
want to edit one or more properties, for example in preparation for putting similar content items into 
groups (explained in the next chapter, Creating Content Groups). The process of editing content 
properties, sometimes called “tagging” content, is explained in this chapter, along with other basic 
procedures for managing content repositories. 

Note: If your ATG installation uses ATG Content Administration, you can also use the ATG Business 
Control Center to create and manage content items. For more information, refer to the ATG Content 
Administration Guide for Business Users. 

Using the Content Repository Editor Window 
The Content menu includes all the content repositories (if any) that you can access through the ATG 
Control Center. If you have installed the Quincy Funds demo, the content repositories you see in the list 
include Investment Tips, Funds, Images, and Features. When you click on a repository in this list, the 
repository editor opens on the right side of the window. This editor lets you view, add and delete content 
items and edit their property values. 

Note that, in some cases, you can view content items but you may not be able to edit their property 
values. This behavior depends on one of the following: 

 Your access rights to individual items or the folders in which they are located. See 
Security Access in the ATG Control Center for more information. 

 The type of repository in which the content item is stored. For example, if your site 
uses a hybrid SQL/file system content repository, you may be able to view the items in 
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the ATG Control Center but not edit them directly. (The Quincy Funds demo uses this 
type of configuration.) 

Values that you cannot edit appear in gray in the repository editor window. 

The following illustration shows the content repository editor window, in this case for the Products 
repository in the ATG Commerce Motorprise demo: 

 

Use the search bar at the top of the window to specify and display the content items you want to work 
with. 
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Click each part of the editor (including the diamonds) and specify the option you want from the menu 
that appears. Then click List. The system shows all the items in the repository that meet your criteria. For 
detailed information on using the search bar, please refer to the online help for the ATG Control Center. 

Adding New Content Items to a Repository 
The following procedure shows how to add a new item to a content repository. 

1. Select the repository to which you want to add the new item. (For example, if you were 
adding content to the Investment Tips repository in the Quincy Funds demo, you 
would select Content > Investment Tips.) 

2. For repositories that can hold more than one type of item, change the search criteria at 
the top of the window to show the type of item you want to add. (The types of items in 
a repository correspond to the different item descriptors in the repository definition 
file. For more information, refer to the SQL Repositories chapter in the ATG Repository 
Guide.) You perform this step so that the File > New Item menu option, which you 
select next, displays the New Item dialog box that is appropriate for the type of item 
you are adding. 

After you change the search criteria, you can click List to display existing items of this 
type. This part of the step is optional. 

3. Select File > New Item. The New Item dialog box appears, with a form showing the 
properties you can supply for this item. The properties vary depending on the content 
repository you are working with and on the specific properties that your company 
defined for this type of item when it set up the repository. 

4. Fill in the properties as needed. Required properties have an asterisk next to their 
names. For more information, see Editing Content Property Values. 

5. Click OK when you have finished. 

For information on adding a completely new content repository to the system, please refer to the ATG 
Repository Guide. 

Editing Content Property Values 
To change the property values of an existing content item, do the following: 
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1. Display the item whose property values you want to change. See Using the Content 

Repository Editor Window for more information. 

2. Change the properties as needed. The technique you use depends on the type of 
property you are editing. For some, you type the value directly into the field next to 
the property’s name. For others, a button appears when you click the value field, and 
you then click the button to display an edit box or to select from a list of predefined 
values. 

Also note the following about filling in properties: 

 Required properties have an asterisk next to their names. 

 Read-only properties are displayed in gray. You cannot edit their values. See 
Using the Content Repository Editor Window for more information. 

 Some property fields contain a small black arrow:  This symbol indicates that 
the value is linked to another item type in the repository. Click the arrow. Then 
click the “...” button to open a search dialog box where you can select or create 
new repository items of that type. 

For information on how to edit properties that can have multiple values, see Filling in 
Properties with Multiple Values. 

3. Select File > Save when you have finished editing property values. 

Filling in Properties with Multiple Values 

Some properties can have more than one value (sometimes called an array of values). In the Offers 
content repository (Quincy Funds demo), the keywords property is an example: 

 

To edit this type of property, click the Value field so that a button appears, as follows: 

 

When you click the button, an edit dialog box appears: 



A T G  P e r s o n a l i z a t i o n  G u i d e  f o r  B u s i n e s s  U s e r s  

 

5 1  

5  -  S e t t i n g  U p  C o n t e n t  I t e m s  

μ

 

To add a new value, click Insert Before. An empty line appears into which you type the value you want: 

 

To edit an existing value, click its line to make it active and then edit the text as required. 

To add another value, click Insert After. Another line appears after the first. Type the second value into the 
new line. 
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Add more values as required, making sure that each line contains only one value. If necessary, use the 
Move Up and Move Down buttons to reorder the lines. 

When you have finished, click OK. The set of values appears, separated by commas: 

 

Deleting Content Items 
To delete a content item from a repository, do the following: 

1. Display the item you want to delete. For more information, see Using the Content 
Repository Editor Window. 

2. Select the item by clicking its name in the list. 

3. Select File > Delete Item and click Yes when the confirmation dialog box appears. 

Note: After you delete an item, make sure you also remove any references to it that you may have set up 
elsewhere in the system. For example, check your scenarios for references to the deleted item in Event 
elements such as the Views element. 
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6 Creating Content Groups 

The Content Groups window lets you create and define content groups -- collections of content items 
that share common properties -- for easier targeting. For example, you could create a content group 
called NewNYInfo that includes special content items for new site members who live in New York. The 
rules that define this group might look like this: 

Include this content: 

   items whose TargetAudience is NewUsers 

   and whose keywords includes New York 

You can then use the Content Targeters window to set up the business rules for delivering this content to 
its intended audience. For example: 

Show this content: 

   items in group NewNYInfo 

to these people: 

   people whose Registration date is after 03/31/2004 

Whenever you create a content group, the system assigns a new property with the same name as the 
content group to every content item in the repository. It sets that property to “true” or “false” according to 
whether the content item matches the group definition. For example, if you create a content group called 
NewNYInfo, the system gives every content item a new property called NewNYInfo. If an item fits the 
criteria for that group, the system sets the NewNYInfo property for that content to “true.” If an item does 
not fit the group criteria, the NewNYInfo property is set to “false.” The system uses this method to 
determine which items belong to each group. 

Important: If your ATG installation uses ATG Content Administration, it is strongly recommended that 
you use the ATG Business Control Center instead of the ACC to manage content groups. In addition, if you 
are working in a multisite ATG environment (one in which a single instance of ATG products supports 
more than one Web site), you cannot create or edit site-aware content groups in the ACC. These must be 
managed through the ATG Business Control Center. For more information, refer to the ATG Business 
Control Center User’s Guide. For information on a multisite environment, refer to the ATG Multisite 
Administration Guide. 

Viewing Content Groups 
You can view a list of existing content groups through the Profile and Content Groups window in the ATG 
Control Center. To display this window, select Targeting > Profile and Content Groups. 
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Targeting > Profile and Content Groups window 

The window has the following features: 

 The panel on the left shows a list of folders containing the profile or content groups 
that have already been created for your Web site. Content groups are identified by the 

 icon. 

 The panel on the right panel shows all content groups in the selected folder. You can 
add new groups to this list by clicking the New Group button on the toolbar. For more 
information, see Creating New Content Groups. 

 The Name column shows the name of each group in the selected folder. Note that the 
arrow next to the column title shows how groups are sorted in this list; in this example, 
the content groups are sorted in reverse alphabetical order by their entry in the 
Description column. Clicking the column title reverses the sort order. 

 The Content Source column shows the name of the content repository that stores the 
items included in this group. (Note: Content repositories are typically set up by the 
application developers working on your Web site. For more information on how 
repositories are created, refer to the ATG Repository Guide.) 

 The Content Type column shows the specific subset of items in the repository to which 
the content items in this group must belong. (The subset is often used elsewhere in 
the product for organizational or querying purposes.) 
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 The Description column displays a brief description of each group. If the column is too 

narrow to display all the text, hold the mouse pointer over a description that you want 
to read. The description text appears in a blue box. 

To display the rules that define the items that are included in a given content group, click the group’s 
name in the Name column. The following window appears: 

 

Content Group Definition window 

The window has the following features: 

 Include and Exclude buttons, which allow you to add rules that include or exclude 
specific content items from this group; for example, you could set up a rule that 
includes any item whose author is “M. Hamilton” or a rule that excludes any item 
created before January 1, 2003. 

 A blue definition panel that shows the rules for this content group. 

 A series of buttons (All Items, Items in Group(s), Items in Folder(s), These Particular 
Items, Items Whose…) that you use to define the rule selected in the definition panel. 
Note that more buttons become available as you edit the rule. 

Creating New Content Groups 
To create a content group: 
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1. Display the Targeting > Profile and Content Groups window, and click the New Group 

button in the toolbar. The Select New Group Type dialog box appears. 

2. Click Create New Content Group, and then click Next. The following dialog box 
appears: 

 

Specify the folder where you want to store this content group and then type a name 
for the group. Do not include spaces in the name. Note that these folders are internal 
to the ATG Personalization module, which tracks them through an ATG-specific path 
called a Nucleus address (for more information on Nucleus, refer to the ATG 
Programming Guide.) The address for a group folder is 
/atg/registry/RepositoryGroups/<folder name>. For example, the Features 
folder shown in the example is located at the Nucleus address 
/atg/registry/RepositoryGroups/Features. Any new folders you create will be 
located at a similar address. 

3. Click Next. The following dialog box appears: 
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Type a brief description for this content group. The text appears in the Description 
column in the Profile and Contents Group window. You can edit the description later if 
necessary. 

4. Click Next. The following dialog box appears: 

 

Select a repository from the Content Source drop-down list. The repository you select 
determines the content type, items, and content properties you can choose to include 
in or exclude from this group. 

Select the content type that corresponds to the items you want to include in or 
exclude from this group (assuming they meet the additional criteria you define). 

5. Click Finish. 
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The Content Group Definition window appears, allowing you to set up the rules that 
define the items that make up the group. For more information, see the next section, 
Setting Up Content Group Definitions. 

Setting Up Content Group Definitions 
Each time you add a new content group, you need to define the content items that it will include. These 
definitions are made up of individual rule sets, each beginning with the phrase “Include this content” or 
“Exclude this content”. A horizontal line separates multiple rule sets within a definition. For examples, see 
the Content Group Definition Samples section. 

To define the items in a content group: 

1. Select the group from the Profile and Content Groups window. The Content Group 
Definition window appears. 

2. Click Include or Exclude at the top of the Content Group Definition window. 

 Use Include to define the content group by the content you want to include. 

 Use Exclude to define the content group by the content you want to exclude. 

The beginning of the new rule appears in the Content Group Definition panel. For 
example, if you click Include, the phrase “Include this content” appears. The following 
button bar appears immediately below the rule text: 

 

Note: You may have to resize the window in order to see all the options. 

3. Specify the content you want to include or exclude: 

 Click All Items if you want to include (or exclude) all content items stored in the 
selected repository. (To see the items that this repository holds, select the name 
of the repository from the Content menu in the main ATG Control Center 
window, and then display all items.) 

 Click Items in Group(s) if you want to include or exclude items from other 
existing content groups. The Content Groups dialog box appears as shown 
below, allowing you to choose from among the existing groups listed in the 
Content Groups panel. 
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If multiple groups exist and you want to select more than one, hold down the 
Control key while making your selections. You can choose All Items in Selected 
Groups or Only Those Items Common to Selected Groups. When you click OK, a 
list of the groups you select appears at the bottom of the Content Group 
Definition panel along with an Edit Groups button. Click this button if you need 
to change your group selections. 

If you select the Items in Group(s) option, you can define additional criteria by 
clicking the Whose button (described below). 

 Click Items in Folder(s) if you want to include or exclude all items from specific 
repository folders. The Select Items in Folders dialog box appears. 

 

Select the folders containing the content you want to use, and then click the >> 
button to move them to the Selected Items list on the right. Click OK when you 
complete your selections. 

You can then define additional criteria by clicking the Whose button (described 
below). 
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 Click These Particular Items if you want to include or exclude specific items from 

the repository. When the Select Items dialog box (similar to the dialog box 
shown above) opens, select the individual content items you want to use and 
click the >> button to move them to the Selected Items list on the right. Click 
OK when you have completed your selections. 

You can then define additional criteria by clicking the Whose button (described 
below). 

 Click Items Whose (or Whose if you clicked the Items in Groups(s), Items in 
Folder(s), or These Particular Items options) if you want to include or exclude 
items based on specific content properties. When you select this option, several 
drop-down lists appear as shown below, allowing you to select the property, 
comparison operator, and value you want to use. 

 

The properties that are available for selection depend on the repository you are 
working in. The selections in the Operator and Value drop-down lists change 
depending on the property you select. If the property has a limited set of 
values, the Value list will include all of your possible choices. If the property has 
an unlimited number of values, you can type a unique value directly into the list 
as shown below. The required value type (“string,” for example) appears next 
the text field. 

 

4. If you want to add other condition statements to the rule, click the And Whose and Or 
Whose buttons at the bottom of the Content Group Definition panel. For examples, 
see the Content Group Definition Samples section. 

5. If you want to make the group definition even more specific, click Include or Exclude 
again to create a rule set within the definition, and then repeat step 3. 

6. Click Save when all your definition rules are set. Note: If you select another content 
group from the Content Groups panel or switch to another task window before saving 
your changes, the ATG Control Center saves them automatically. 

Important: After you add new content groups to a repository, you must copy your changes from the 
staging server to your live site. For more information, see Copying and Switching Databases in the ATG 
Installation and Configuration Guide. 
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Deleting Content Group Definitions 

To delete all or part of a content group definition: 

1. In the Content Group Definition panel, select the part of the definition you want to 
delete. 

 If you want to delete the entire definition, choose Edit > Select Entire Rule Set. 

 If you want to delete an entire rule within the definition, click on the first line of 
the rule (Include this content:, for example) or choose Edit > Select Entire 
Rule. 

 If you want to delete a specific line within a rule, click on just that line. 

2. Select Edit > Delete. 

3. Select File > Save. 

Content Group Definition Samples 

There are countless ways to combine content group options to specify the content you want to include or 
exclude from certain groups. Content group definitions are based on Boolean (“and/or”) logic, meaning 
that you can use AND statements and OR statements to create more sophisticated inclusion and 
exclusion rules. AND statements let you include (or exclude) content items that meet all conditions in the 
definition. OR statements let you include (or exclude) content items that meet any of the conditions in the 
definition. The following samples show how these subtle changes in the wording of a definition can 
change a content group’s makeup completely. 

Sample 1: All items in the content group Cars that (a) include the keyword “luxury” AND (b) have US 
English as their language: 

Include this content: 

   items in group Cars 

   whose keywords includes luxury 

   and whose Language is en_US 
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In content group Cars Language = en_US

Keyword = “luxury”

Include ONLY these content items

 

Sample 2: All items in the content group Cars that (a) include the keyword “luxury” OR (b) have US 
English as their language: 

Include this content: 

   items in group Cars 

   whose keywords includes luxury 

   or whose Language is en_US 

In content group Cars Language = en_US

Keyword = “luxury”

Include ANY of these content items

 

Sample 3: All content items in the content group Cars PLUS all content in US English PLUS all content 
that contains the keyword luxury: 

Include this content: 

   items in group Cars 

-------------------------------------------------- 

Include this content: 

   whose Language is en_US 

-------------------------------------------------- 

Include this content: 

   whose keywords includes luxury 
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Include ALL of these content items

In content group Cars Language = en_US

Keyword = “luxury”
 

Moving or Renaming Content Groups 
Important: When you rename a content group, you must update all references you’ve made to it in other 
ATG Control Center windows. For example, if the group is referenced by a content targeter, be sure to 
update the targeting rules in the Content Targeters window. (For details, see the Setting Up Targeting 
Business Rules section.) Otherwise, the targeter will continue to refer to the old group name and errors 
will occur whenever it is invoked on the Web site. 

To rename an existing content group or move it to another folder: 

1. Select the content group in the Profile and Content Groups window. 

2. Select File > Move/Rename Group. (Note: You cannot move or rename a group that is 
currently open in the ATG Control Center. To close the group, navigate to it by using 
the arrow buttons in the toolbar, and then select File > Close.) 

The Rename Content Group dialog box appears. 

3. To move the group to a different folder, select the destination folder from the list at 
the top of the dialog box. To rename the group, type the new name (do not include 
spaces). Note that these folders are internal to the ATG Personalization module; for 
more information, see Creating New Content Groups. 

4. Click OK. 

Editing Content Group Descriptions 
The Description column in the Profile and Content Groups window displays a description of each content 
group. To edit the description: 

1. Select the group from the Profile and Content Groups window. (To select a group 
without opening it, click any column other than the Name column.) 

2. Select File > Edit Description. The Edit Description dialog box opens. 
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3. Type the new description for the group and click OK. 

Deleting Content Groups 
You can delete content groups that you no longer need. Doing so only removes the group name, 
description, and definitions from the ATG Control Center; it does not affect the content items within the 
group. 

Important: When you delete a content group, you must delete all references you’ve made to it in other 
ATG Control Center windows. For example, if the group is referenced by a content targeter, be sure to edit 
the targeting rules in the Content Targeters window. (For details, see the Setting Up Targeting Business 
Rules section.) Otherwise, the targeter will continue to refer to the deleted group and errors will occur 
whenever it is invoked on the Web site. 

To delete an existing content group: 

1. If the group you want to delete is open, navigate to the group’s window by using the 
arrow buttons on the toolbar, and then close it by selecting File > Close. 

2. Select the content group from the Profile and Content Groups window. (To select a 
group without opening it, click any column other than the Name column.) 

3. Select File > Delete Group. 

4. When the confirmation dialog box appears, click Yes to confirm the deletion. 

Copying Content Groups to the Live Site 
After you create or edit content groups in the ATG Control Center, you must copy your changes from the 
staging server to the live site. For more information, see Copying and Switching Databases in the ATG 
Installation and Configuration Guide. 
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7 Matching Content with Your Target 

Audiences 

After you have set up profile groups and content groups, you need to tell the system which content 
groups to show to whom and the circumstances in which to do it. One way to do this is by setting up 
content targeters, which are business rules that you create through the Targeting > Content Targeters 
window in the ATG Control Center. Content targeters define the content that you display to each profile 
group. 

A content targeter can contain two kinds of business rules: show and hide. Each rule type is made up of 
specific conditions related to content, people, time, and environmental factors and generally reads as 
follows: Show/Hide this content… to/from these people… at these times… under these conditions. For 
example, let’s say you wanted to show new feature articles (in a content group called 
newMemberFeatures) to registered site users (in a profile group called registeredMembers) every 
Monday. In this case, you might create a targeter called newFeatures with the following rule set: 

Show this content: 

   items in group newMemberFeatures 

to these people: 

   people in group registeredMembers 

at these times: 

   every Mon of every month 

When this targeter is invoked, it initially looks at all conditions except the content conditions. First, it 
checks to see if the registeredMembers property in the visitor’s profile is set to “true” (the people 
condition). If this or any other condition fails, the targeter completely ignores the rule set. If the condition 
passes, it goes on to see if the current day is a Monday (the time condition). If all of these conditions pass, 
the targeter looks at the content condition to determine the items to show or hide. In this case, it shows 
the visitor all items in the newMemberFeatures content group. 

After you create a targeter, a page developer uses a targeting servlet bean to embed it in the appropriate 
site pages so that it will display the specified content to visitors who meet your targeting conditions. 
(Typically, page developers use the Document Editor window in the ATG Control Center to embed 
targeters in JHTML or JSP (JavaServer Page) files. For more information, see the ATG Page Developer’s 
Guide.) Once the targeter is in place, you can use Targeting > Preview window to test it on the staging site 
before moving it to your live server. 

Multiple targeters can be used to produce a single Web page. For example, nine separate targeters are 
invoked to produce the “investor” home page (investorhome.jsp) of the Quincy Funds demo. 
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Important: If your ATG installation uses ATG Content Administration, it is strongly recommended that 
you use the ATG Business Control Center instead of the ACC to manage content targeters. In addition, if 
you are working in a multisite ATG environment (one in which a single instance of ATG products supports 
more than one Web site), you cannot create or edit site-aware content targeters in the ACC. These must 
be managed through the ATG Business Control Center. For more information, refer to the ATG Business 
Control Center User’s Guide. For information on a multisite environment, refer to the ATG Multisite 
Administration Guide. 

Using Scenarios to Match Content to Profiles 

If you use the Scenarios module, you can match content to profile groups in two ways: you can either 
create targeters (as described above), or you can use scenarios to achieve essentially the same results. The 
method you choose depends on whether you require the advanced features that scenarios provide, or 
whether the slightly simpler features of targeters meet your requirements. You can also set up a 
combination of the two methods. For information on the differences between the two, see How Are 
Scenarios Different from Targeters?. 

The rest of this chapter describes using targeters to match content to profile groups. For information on 
using scenarios, see Creating Scenarios. 

Using the Content Targeters Window 
To open the Content Targeters window, select Targeting from the main ATG Control Center window, and 
then select Content Targeters. The following window appears: 
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Targeting > Content Targeters window 

 The panel on the left shows a list of folders containing the content targeters that have 
been created for your Web site. 

 The panel on the right shows all the content targeters (identified by the  icon) in 
the selected folder. You can add new targeters by clicking the New Content Targeter 
button in the toolbar. (See the Adding New Content Targeters section for more 
information.) 

 The Name column shows the name of each targeter in the selected folder. Note that 
the arrow next to the column title shows how targeters are sorted in this list; in this 
example, targeters are sorted alphabetically by their entry in the Name column. 
Clicking the column title reverses the sort order. 

 The Content Source column shows the name of the repository containing the content 
that will be delivered by this targeter. (A single targeter can deliver content from one 
repository only.) 

 The Content Type column shows the specific subset of items in the repository to which 
the targeters in this group must belong. (The subset is often used elsewhere in the 
product for organizational or querying purposes.) 

 The Description column displays a brief description of each targeter. If the column is 
too narrow to display all the text, hold the mouse pointer over a description that you 
want to read. The description text appears in a blue box. 
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To display the rules that make up a given targeter, click the targeter’s name in the Name column. The 
following window appears: 

 

 The Business Rules panel lets you define the circumstances under which this targeter 
displays content items to your Web site visitors. For more information, see the Setting 
Up Targeting Business Rules section. 

Note: The various drop-down lists and options that appear in the Business Rules panel 
change as you build your targeting rules. 

When you click Step 2 Specify options for displaying this content, the features of the window change 
as shown below, allowing you to sort the targeting results by certain content properties. Note: This is an 
optional step in the targeter creation process. For more information, see the Sorting Targeting Results 
section. 
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 The Sort Items By list shows you the properties you can use for sorting. The properties 
that appear in this list vary depending on the selected targeter’s repository. 

 The Selected Properties list on the right displays the properties you select for sorting. 
Use the Add and Remove buttons to edit this list. 

 The Order buttons in the lower right corner let you switch between ascending (A-Z, 1-
9) or descending (Z-A, 9-1) sort order for each property in the Selected Properties list. 

Adding New Content Targeters 
To add a new content targeter to the Content Targeters panel: 

1. Click the New Content Targeter toolbar button in the top right corner of the Content 
Targeters window. The New Content Targeter dialog box appears. 
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2. Select a repository from the Content Source drop-down list. The repository you select 
determines the content items, content type, and content properties you can target 
against. The targeter will apply only to items in this repository. 

3. From the Content Type list, select the type of content you want to target against. The 
type corresponds to the subset of items defined by the item descriptor type in the 
content repository definition file. Each item type has its own properties. For more 
information, refer to the ATG Repository Guide. 

4. Click Next. The following dialog box appears: 
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5. Type a brief description of this content targeter. (You can edit this description later if 
necessary.) When you have finished, click Next. The following dialog box appears: 

 

6. Select the folder where you want to store this content targeter. Any folders already 
created to store targeters for your Web site appear in the list. Note that these folders 
are internal to the ATG Personalization module, which tracks them through an ATG-
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specific path called a Nucleus address (for more information on Nucleus, refer to the 
ATG Programming Guide.) The address for a targeter folder is 
/atg/registry/RepositoryTargeters/<folder name>. For example, the 
Investment Tips folder shown in the example is located at the Nucleus address 
/atg/registry/RepositoryTargeters/InvestmentTips. Any new folders you 
create will be located at a similar address. 

In the example, the folder names correspond to the content repositories in the Quincy 
Funds demo, but it is not required that you use the same names as your content 
repositories. 

7. Type the name of the new targeter. Do not include spaces in the name. Targeter 
names must be unique within a folder, but in addition it is suggested that you make all 
targeter names unique (regardless of their folder), so that page developers who insert 
targeters into site pages can distinguish them easily. 

8. Click Finish. The new targeter appears in the Content Targeters window. 

Next, you need to set up the business rules for this targeter. For more information, see Setting Up 
Targeting Business Rules. 

Setting Up Targeting Business Rules 
Each time you add a new content targeter, you need to set up the business rules for delivering the 
selected content to its target audience. For examples, see the Business Rule Samples section. 

A word about targeters and site performance: The ATG Personalization module caches (or temporarily 
stores) the content that it displays after each targeting operation. This behavior allows it to serve the 
content much faster to the next visitor who matches the targeting criteria. This caching mechanism will 
not be effective if your targeting rules include profile or request properties (time of day, for example) that 
have many possible values for each visitor. For example, if you created a targeter that included a multi-
value property called interests and there are many possible value combinations for each visitor 
(“skiing, golf, hockey,” “biking, golf,” “soccer, tennis, swimming,”), it is unlikely that the Personalization 
module would be able to use the page results cached from previous requests, and the targeting 
operation would take longer. 

Note: When creating or editing targeting rules, you can discard your changes and restore any previously 
saved settings by selecting File > Revert. This option is only available before you save your changes. 

To set up or edit the business rules for a content targeter: 

1. Select the targeter from the Content Targeters panel. 

2. Click Show or Hide at the top of the Business Rules panel. 

 Show lets you specify the content you want visitors to see. 

 Hide lets you lets you specify the content you don’t want visitors to see. 

Note: Show rules are evaluated before hide rules. 
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The beginning of the new rule appears in the Business Rules panel. For example, if you 
click Show, you see the phrase “Show this content”. The following button bar appears 
immediately below the rule text, allowing you to set up the rest of your targeting rules. 

 

3. Use the above button bar to set the rule’s content, people, time, and environment 
conditions. The following sections cover each of these steps in detail: 

 Setting Content Conditions 

 Setting People Conditions 

 Setting Date and Time Conditions 

 Setting Environment Conditions 

4. If you want to add another rule set, select Add Another Rule Set from the Edit menu, 
and repeat steps 2-3. For more information on creating multiple rule sets, see the 
Creating and Prioritizing Multiple Rule Sets section. 

You can also include any available rule macros (reusable business rules) by selecting 
Include Rule Macro from the Edit menu. For details, see the Creating Reusable Business 
Rules (Rule Macros) section. 

5. When you have finished setting up your targeting rules, click the Save button. 

After you save the targeter, a page developer can embed it into the appropriate site 
pages using the Pages and Components option. 

Important: After you create or edit a content targeter, you must copy your changes from the staging 
server to your live site. See Copying and Switching Databases in the ATG Installation and Configuration 
Guide. 

Setting Content Conditions 

Content conditions are used to find content items that match some sort of criteria. For example: 

Show this content: 

   items whose keywords includes Hiking 

You can combine multiple content conditions by using AND statements and OR statements. For 
examples, see the Business Rule Samples section. 

If your product suite includes ATG Commerce, the content you can show includes any promotions you 
have set up. For more information, on promotions, refer to the ATG Commerce documentation. 

To set a rule’s content conditions: 

1. Click the Show/Hide This Content button below the Business Rules panel. The content-
related option buttons appear as shown below: 
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Note that you may have to resize the ATG Control Center window to see all the 
options. 

2. Specify the content you want to show or hide: 

 Click All Items if you want to show (or hide) all content items stored in the 
selected repository. 

 Click Items in Group(s) if you want to show or hide items from content groups 
created in the Profile and Content Groups window. The Content Groups dialog 
box appears as shown below. 

 

If multiple groups exist and you want to select more than one, hold down the 
Control key while making your selections. You can choose All Items in Selected 
Groups or Only Those Items Common to Selected Groups. (A list of the groups 
you select appears at the bottom of the Business Rules panel along with an Edit 
Groups button. Click this button if you need to change your group selections.) 

If you select the Items in Group(s) option you can define additional criteria by 
clicking the Whose button (described below). 

 Click Items in Folder(s) if you want to show or hide all items from specific 
repository folders. The Select Items in Folders dialog box appears: 
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Select the folders containing the content you want to use, and then click the >> 
button to move them to the Selected Items list on the right. Click OK when you 
have completed your selections. 

You can then define additional criteria by clicking the Whose button (described 
below). 

 Click These Particular Items if you want to show or hide specific content items. 
When the Select Items dialog box opens, select the individual content items 
you want to include. Use the Selective Listing tab (similar to the dialog box 
shown above) to search for items of a specific repository type, or use the Folder 
Listing tab to display items according to the folder that contains them. In either 
tab, click the >> button to move the items to the Selected Items list on the 
right. Click OK when you complete your selections. 

You can then define additional criteria by clicking the Whose button (described 
below). 

 Click Items Whose (or Whose if you clicked the Items in Groups(s), Items in 
Folder(s), or These Particular Items options) if you want to show or hide items 
based on specific content properties. When you select this option, several drop-
down lists appear as shown below, allowing you to select the property, 
comparison operator, and value you want to use. 

 

The properties that are available for selection depend on the repository you are 
working with. The selections in the Comparison Operator and Value drop-down 
lists change depending on the property you select. If the property has a limited 
set of values, the Value list will include all of your possible choices. If the 
property has an unlimited number of values, you can type a unique value 
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directly into the list as shown below. The required value type (“string,” for 
example) appears next the text field. 

 

In addition to any preset content properties values, or any values you might 
type yourself, the value list also contains the environment options described in 
the following table. You can use these options to set the value of your selected 
content property by testing it against a particular environment condition. 

 

Browser’s Select Browser’s to add a browser-related property to the definition. For example, 
…items whose absolutePath is Browser’s request.remoteHost. 

Locale’s Select Locale’s to add a locale-related property. For example, …items whose language 
is Locale’s acceptLanguage. 

Note: Locale properties are relevant if you are working on a localized Web site that 
displays content in different languages depending on the language setting in a 
visitor’s browser. For more information about internationalization and localization, see 
the ATG Programming Guide. 

Person’s Select Person’s to add another person-related property. For example, …items whose 
keywords includes Person’s Actual Investment Goal. 

Request’s Select Request’s to add a request-related property. For example, …items whose 
relativePath is Request’s requestURI. 

Today’s Select Today’s to add a time-related property. For example, …items whose lastModified 
is Today’s date. 

 

The application developers working on your Web site can add other options to 
this list by setting up a TargetingSourceMap service in the Personalization 
module. For more information, see Setting Up Targeting Services in the ATG 
Personalization Programming Guide. 

When you select one of these options, the ATG Control Center displays another 
drop-down list like the one pictured below, prompting you to select a related 
property. The properties that are available depend on the option you select 
from the Value list. 

 

3. If you want to add other content conditions, click the And Whose and Or Whose 
buttons at the bottom of the Business Rules panel. 
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Next, you need to specify your target audience. See the following section, Setting People Conditions, for 
details. 

Setting People Conditions 

People conditions are tested against visitor profile properties to see if the rule set should be applied. For 
example: 

Show this content: 

   items in group NewNYinfo 

to these people: 

   people whose Registration date is after 03/31/2004 

You can combine multiple people conditions using AND statements and OR statements. For examples, 
see the Business Rule Samples section. 

To set a rule’s people conditions: 

1. Click the To These People button below the Business Rules panel. The people-related 
option buttons appear as shown below: 

 

2. Specify the people you want to include in (or exclude from) your target audience: 

 Click All People if you want to include (or exclude) all visitors. 

 Click People in Group(s) if you want to include or exclude people from profile 
groups created in the Profile window. The Profile Groups dialog box appears as 
shown below. 

 

If multiple groups exist and you want to select more than one, hold down the 
Control key while making your selections. You can choose Everyone in Selected 
Groups or Only Those People Common to Selected Groups. (A list of the groups 
you select appears at the bottom of the Business Rules panel along with an Edit 
Groups button. Click this button if you need to change your group selections.) 

If you select People in Group(s), you can define additional criteria by clicking the 
Whose button (described next). 



A T G  P e r s o n a l i z a t i o n  G u i d e  f o r  B u s i n e s s  U s e r s  

 

7 8  

7  -  M a t c h i n g  C o n t e n t  w i t h  Y o u r  T a r g e t  A u d i e n c e s  

μ
Note that you can use this option to target content according to the global or 
organizational role to which a person assigned. To do this, create a profile 
group that includes specific roles, and then include the profile group in the 
content targeter. For more information, see Defining Profile Group Members. 

 Click People Whose (or Whose if you selected the People in Group(s) option 
described above) if you want to include or exclude people based on specific 
profile properties. When you select this option, several drop-down lists appear 
as shown below, allowing you to select the property, comparison operator and 
value you want to use to define the group. 

 

The properties that are available for selection are drawn from the profile 
repository created for your Personalization module. (For more information, refer 
to Setting Up a Profile Repository in the ATG Personalization Programming Guide.) 
The selections in the Comparison Operator and Value drop-down lists change 
depending on the property you select. If the property has a limited set of 
values, the Value list will include all of your possible choices. If the property has 
an unlimited number of values, you can type a unique value directly into the list 
as shown below. The required value type (“string,” for example) appears next to 
the text field. 

 

3. If you want to add other conditions to the rule, click the And Whose or the Or Whose 
buttons at the bottom of the Business Rules panel. 

Next you set the time conditions for displaying the content. See the following section, Setting Date and 
Time Conditions, for details. 

Setting Date and Time Conditions 

Date and time conditions are tested against the current time to see if the rule set should be applied. For 
example: 

Show this content: 

   items in group newMemberFeatures 

To these people: 

   people in group NewMembers 

At these times: 
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   every Mon, Wed, Fri between 9:00am and 9:00pm 

   between 01-Jan-2000, 12:00am and 01-Jan-2001,11:59pm 

To set the rule’s date and time conditions: 

1. Click the At These Times button below the Business Rules panel. The time-related 
option buttons appear as shown below: 

 

2. Set the time conditions you want to use. 

 Click On to show or hide content on a specific date. For example, On Dec19, 
2003. 

Note: Click any “date” button such as one pictured above to select a new date 
from a pop-up calendar. Select All Day from the drop-down list to display the 
content all day. Select Between These Times from the drop-down list (illustrated 
in the next example) to set specific display times. 

 Click Between to show or hide content between specific dates. For example, 
between Dec 19, 2003, 12:00:00 AM and Dec 31, 2003, 11:59:00 PM, between 
9:00am and 5.00pm. 

 Click Starting On to show or hide content starting on a specific date (without an 
end date). For example, after Dec 19, 2003, 12:00:00 AM. 

 Click Up Until to show or hide content beginning immediately up until a 
specific date. For example, before Dec 18, 2003, 11:59:00 PM. 

 Click These Week Days to show or hide content on certain days of the week. For 
example, the first Monday of every month between 9:00am and 11:59pm. 

 

 Click These Month Days to show or hide content on certain days of each month. 
For example, on these days of the month: 1, 5. When you select this option, the 
Month Days dialog box appears. 



A T G  P e r s o n a l i z a t i o n  G u i d e  f o r  B u s i n e s s  U s e r s  

 

8 0  

7  -  M a t c h i n g  C o n t e n t  w i t h  Y o u r  T a r g e t  A u d i e n c e s  

μ

 

If you want to select more than one day, hold down the Control key while 
making your selections. Click OK when you have finished. 

Next, you can set other environment conditions for the rule. See the following section, Setting 
Environment Conditions, for more information. 

Setting Environment Conditions 

Environment conditions cover properties that are not necessarily related to the visitor’s profile or the 
current time. For example, the type of Web browser a visitor is using might not be included in his or her 
visitor profile, but that information is available when the visitor accesses the site and it can be used for 
targeting then. For example: 

Show this content: 

   items whose platform is Macintosh 

Under these conditions: 

   if Browser's using Macintosh system is true 

To set environment conditions: 

1. Click the Under These Conditions button below the Business Rules panel. A drop-
down list appears as shown below: 

 

2. Select one of the following preset environment options from the drop-down list: 
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Browser’s Select Browser’s to set a browser-related condition. For example: Browser's 

remoteHost is name.example.com. 

Locale’s Select Locale’s to set a locale-related condition. For example, if Locale's 
defaultRequestLocale is en_ US. 

Note: Locale options are relevant if you are working on a localized Web site that 
displays content in different languages depending on the language setting in a 
visitor’s browser. For more information about internationalization and localization, 
refer to the ATG Programming Guide. 

Person’s Select Person’s to set a person-related condition. For example, if Person's Home 
address.state is NY. 

Request’s Select Request’s to set a request-related condition. For example, if Request's 
loggingInfo is false. 

Developer’s Note: The ATG Control Center does not display form parameters in the 
drop-down list of Request properties. If you want to include form request parameters 
in your targeting business rules, you can work around this by creating a request-
scoped Form Handler object and adding it to the TargetingSourceMap service in the 
Personalization module. (For more information on setting up a TargetingSourceMap 
service, see Setting Up Targeting Services in the ATG Personalization Programming 
Guide.) Once your new Form Handler is in the TargetingSourceMap, all the object’s 
properties should appear in a drop-down list of Form Handler properties in the ATG 
Control Center. You can then select them for your targeting business rules. 

Today’s Select Today’s to set a time-related condition. For example, if Today's date is 
10/20/2003. 

 

The application developers working on your Web site can add other environment 
options to this list by setting up a TargetingSourceMap service in the Personalization 
module. For more information, see Setting Up Targeting Services in the ATG 
Personalization Programming Guide. 

When you select one of these options, the ATG Control Center displays additional 
drop-down lists (illustrated below), allowing you to select the property, comparison 
operator, and value you want to use. 

 

The selections in the Comparison Operator and Value drop-down lists depend on the 
property you select. If the property has a limited set of values, the Value list will include 
all of your possible choices. If the property has an unlimited number of values, you can 
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type a unique value directly into the list as shown below. The required value type 
(“string,” for example) appears next to the text field. 

 

The Value list also includes the same environment options as the drop-down list in the 
upper left corner. When you select one of these options from the Value list, another 
drop-down list appears as shown below, allowing you to select another property. 

 

3. If you want to add another condition statement to the rule, click the And or the Or 
button at the bottom of the Business Rules panel. 

Sorting Targeting Results 

As an optional step when creating targeting rules, you can sort targeting results by specific content 
properties (author name, for example) in either ascending (A-Z, 1-9) or descending (Z-A, 9-1) order. This 
allows you to control the order in which the content items are retrieved and displayed from a content 
repository. 

For example, if you sort targeted content items in ascending order by author, items are displayed from 
the content repository in alphabetical order by author name. The application developers can then, in turn, 
set up a targeting servlet bean that controls the order in which these retrieved items appear on a Web 
page. For example, the developers can set up a servlet bean that displays the first 10 items as they are 
retrieved from the content repository (in alphabetical order by author). They can also specify additional 
sorting criteria within the servlet bean that re-sorts and displays those 10 items (by title, for example). 

Note: The sorting order specified by a developer in a targeting servlet bean overrides the sorting order 
specified in the content targeter. If no sorting order is specified in the servlet bean, items are displayed in 
the order in which they are retrieved from a content repository. 

To sort targeted content items: 

1. Click Step 2 Specify options for displaying this content at the top of the Content 
Targeters window. 

2. In the Sort Items By list, select the properties you want to sort by. 

3. Click the Add button to move your selected properties to the Selected Properties list 
on the right side of the window. If you want to select multiple properties, hold down 
the Control key while making your selections. 

An arrow appears to the right of each property, indicating its current sorting order. (By 
default, properties are sorted in ascending order.) If you want to change a property’s 
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sorting order, select it and click one of the Order buttons in the lower right corner of 
the window. 

Note: Properties are used in the order in which they appear in the Selected Properties 
list. If you want to change the order, select a property, remove it (by clicking the 
Remove button), and re-add it to the list (by clicking the Add button). 

Creating and Prioritizing Multiple Rule Sets 

Business rules are evaluated sequentially as they appear in the Business Rules panel in the content 
targeter window. Inserting breaks between rules creates different sets of rules. When rules are grouped in 
sets, you can move them up or down to change the order in which they are evaluated. You can also use 
multiple rule sets to display default content in the event that certain rule conditions fail. 

For example, the Features targeter in the Quincy Funds demo includes three rule sets: 

Show this content: 

   items whose Target Audience includes Person's Strategy 

   and whose Language starts with Locale's localeString 

to these people: 

   people whose User type is investor 

-------------If no items were selected, try the following rules---------- 

Show this content: 

   items whose Target Audience includes guests 

   and whose Language starts with Locale's localeString 

to these people: 

   people whose User type is guest 

-------------If no items were selected, try the following rules----------- 

Show this content: 

   items whose Target Audience includes anybody 

   and whose Language starts with Locale's localeString 

to everyone 

If the first set produces no results, the system uses the Show rule in the second set. If the second set 
produces no results either, the system uses the Show rule in the third set. 

Note: You must organize your rules into rule sets as you create the rules; you cannot break rules into sets 
later. 

To create a rule set: 

1. Select Add Another Rule Set from the Edit menu. The following rule break appears at 
the bottom of the rule list: 

-----If no items were selected, try the following rules----- 

2. Set up the rules for the new rule set. (See the Setting Up Targeting Business Rules 
section for details.) You can move the rule set by choosing Select Entire Rule Set from 
the Edit menu and clicking the Move Up or Move Down buttons in the Business Rules 
panel. 

3. Click Save. 
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Creating Reusable Business Rules (Rule Macros) 

If there are certain business rules that you apply on a routine basis, you can create a set of reusable rules 
called a rule macro that you can insert into any content targeter. 

You create rule macros in the same way you set up content targeters. The only difference is that macros 
are standalone rule sets, meaning that they aren’t associated with a particular content targeter. Also, rule 
macros cannot include rule breaks as described in the previous section. 

To create a rule macro: 

1. Display the Content Targeters window, and then select File > New Rule Macro. The 
New Rule Macro dialog box appears: 

 

2. Select a content repository from the Content Source drop-down list. The repository 
you select determines the content items, content type, and content properties you 
can target against. The targeting rules in this macro will apply only to items in this 
repository. 

3. From the Content Type list, select the type of content you want to target against. 

4. Click Next. The following dialog box appears: 
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5. Type a brief description of this macro, and then click Next. The following dialog box 
appears: 

 

6. Specify the folder where you want to store this macro. Note that these folders are 
internal to the ATG Personalization module. For a more detailed explanation, refer to 
Adding New Content Targeters. 
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7. Type the name of the new macro. Do not include spaces in the name. 

8. Click Finish. 

9. Set up the targeting business rules for the macro. For details, see the Setting Up 
Targeting Business Rules section. 

10. Save the business rules for this macro and close the business rules window. The new 
macro (identified by the  icon) appears in the list of targeters in the Content 
Targeters window. (The macro is located in the folder you specified in step 6.) 

You can insert this macro into any content targeter by selecting Include Rule Macro 
from the Edit menu. 

Deleting Business Rules 

To delete all or part of a targeting business rule: 

1. In the Business Rules panel, select the part of the business rule you want to delete: 

 If you want to delete a specific line within rule set, click on just that line. 

 If you want to delete a single rule (a Show or Hide rule with its associated 
phrases), click on a line within that rule and then choose Edit > Select Entire 
Rule. 

 If you want to delete an entire rule set (one or more Show or Hide rules with no 
breaks between them) choose Edit > Select Entire Rule Set. 

2. Select Edit > Delete. 

3. Select File > Save. 

See Deleting Content Targeters for information on deleting entire content targeters from the ATG Control 
Center. 

Business Rule Samples 

The following examples show some of the many ways you can combine the choices in the business rules 
section to create targeting rules. 

Sample 1: Show the content item car.jsp to all people who belong to the profile group CarLovers and 
live in Boston from December 2, 2003 to December 6, 2003. If the user does not fit this description, show 
him or her the content item generic.jsp. 

Show this content: 

    car.jsp 

to these people: 

    people in the group CarLovers 

    whose Home address.city is Boston 

at these times: 

    between Dec 2, 2003, 12:00:00 AM and Dec 6, 2003, 11:58:00 PM 

--------If no items were selected, try the following rules-------- 

Show this content: 
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    generic.jsp 

to everyone 

at these times: 

    between Dec 2, 2003, 12:00:00 AM and Dec 6, 2003, 11:58:00 PM 

Like profile group and content group definitions, targeting business rules are based on Boolean (“and/or”) 
logic. This means that you can use AND statements and OR statements to create more sophisticated 
targeting rules. AND statements let you show (or hide) content if all conditions in the rule are met. OR 
statements let you show (or hide) content if any of the conditions in the rule are met. The following 
samples show how these subtle wording changes can change the meaning of a rule completely. 

Sample 2: Show the content item car.jsp to all people in the profile group called CarLovers who are 
(a) from Boston AND (b) male: 

Show this content: 

   car.jsp 

to these people: 

   people in group CarLovers 

   whose homeAddress.city is Boston 

   and whose Gender is male 

 

Sample 3: Show the content item car.jsp to all people in the profile group called CarLovers who are 
(a) from Boston OR (b) male: 

Show this content: 

   car.jsp 

to these people: 

   people in group CarLovers 

   whose Home address.city is Boston 

   or whose Gender is male 
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Moving or Renaming Content Targeters 
Important: Renaming a content targeter that is currently in use by a Web page may result in errors when 
users visit that page. Before renaming any targeter, be sure all references to it are updated accordingly. 

To rename an existing content targeter or move it to another folder: 

1. Select the content targeter from the Content Targeters panel. 

2. Select Move/Rename Content Targeter from the File menu. (Note: You cannot move 
or rename a targeter that is currently open in the ATG Control Center. To close the 
targeter, navigate to it by using the arrow buttons in the toolbar, and then select File > 
Close.) 

The Rename Content Targeter dialog box appears. 



A T G  P e r s o n a l i z a t i o n  G u i d e  f o r  B u s i n e s s  U s e r s  

 

8 9  

7  -  M a t c h i n g  C o n t e n t  w i t h  Y o u r  T a r g e t  A u d i e n c e s  

μ

 

3. To move the targeter to a different folder, select the destination folder from the list at 
the top. To rename the targeter, type the new targeter name (do not include spaces). 
Note that these folders are internal to the ATG Personalization module; for more 
information, see Adding New Content Targeters. 

4. Click OK. 

Editing Content Targeter Descriptions 
The Description column in the Content Targeters window displays a description of each targeter. To edit 
the description: 

1. Select the targeter from the Content Targeters window. (To select a targeter without 
opening it, click any column other than the Name column.) 

2. Select File > Edit Description. The Edit Description dialog box opens. 

3. Type the new description for the targeter and click OK. 
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Deleting Content Targeters 

You can delete targeters that you no longer need. Doing so removes only the targeter’s name, 
description, and targeting rules from the ATG Control Center; it does not affect any content or profile 
information referenced within the targeting rules. 

Important: Deleting a content targeter that is currently being used by a Web page will result in errors 
when users visit that page. Before deleting any targeter, make sure that it is no longer in use on your Web 
site. 

To delete a content targeter: 

1. If the targeter you want to delete is open, navigate to the targeter’s window by using 
the arrow button on the toolbar, and then close it by selecting File > Close. 

2. Select the content targeter from the Content Targeters window. (To select a targeter 
without opening it, click any column other than the Name column.) 

3. Select File > Delete Content Targeter. 

4. When the confirmation dialog box appears, click Yes to confirm the deletion. 

Copying Targeters to the Live Site 
After you create or edit content targeters in the ATG Control Center, you must copy your changes from 
the staging server to the live site. For more information, see Copying and Switching Databases in the ATG 
Installation and Configuration Guide. 
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8 Tracking Visitor Behavior 

An important part of the process of personalizing a Web site is gathering information about each visitor 
and then tailoring the content of the site to meet that visitor’s preferences and probable requirements. As 
explained earlier in Setting Up Visitor Profiles, you can gather information by asking visitors to supply 
information about themselves directly. For example, you can have them fill in a registration form in which 
you ask them to supply their age group or income range. You can also gather information implicitly by 
monitoring what visitors do on your site. For example, which pages do they visit? Which images do they 
display? What products have they bought? You then use this information to tailor the content of your 
Web site for each person. The next time a visitor comes to your site, he or she sees content that better 
meets his or her needs. Over time, you can develop detailed profiles of your site visitors, allowing you to 
provide better service for your customers and build more reliable relationships with them. 

If your Web site does not use scenarios, you can use the Targeting > Tracking Sensors window in the ATG 
Control Center to gather implicit information about your site visitors and change content accordingly. 
You set up tracking sensors to monitor visitor behavior on your Web site, including their session activity 
and the specific content they view. You then create action statements for these sensors that tell the 
system how to change a visitor’s profile in response to each event. These statements take the following 
form: When a visitor <does this>, perform these actions. For example: 

When a visitor: 

   views this type of content 

      Add the value of Aggressive Index to the person's Aggressive 

      Index attribute 

You then set up targeting rules that display different content according to the properties in each user’s 
profile. For more information on targeting rules, see Matching Content with Your Target Audiences. 

Using Scenarios to Track Visitor Behavior 

If you use the Scenarios module as part of your ATG product suite, you must use scenarios instead of 
sensors to track visitor behavior and change their profiles. 

The rest of this chapter describes using tracking sensors. For information on using scenarios instead, see 
Creating Scenarios. 

Using the Tracking Sensors Window 
To open the Tracking Sensors window, select Targeting from the main ATG Control Center menu and then 
select Tracking Sensors. The following window appears: 
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Targeting > Tracking Sensors 

Note: If the Tracking Sensors option does not appear, use scenarios instead of tracking sensors to track 
visitor behavior. Please refer to Creating Scenarios for more information. 

The Tracking Sensors window is divided into three panels: 

 The Tracking Sensors panel on the left lists the tracking sensors available for your Web 
site. These sensors are divided into the following categories: Session, Pages, Content 
Items, and Content Types. 

Note: You add individual tracking sensors to the Page, Content Item, and Content 
Type categories by clicking the New Tracking Sensor toolbar button in the top right 
corner of the window. (For details, see the Adding New Tracking Sensors section.) 
However, as described below, the Session tracking sensors are pre-defined. You 
cannot add new Session sensors; you need only to create action statements in order to 
use them. 

 The When a Visitor panel shows the events you can track within each category. These 
events are preset; you cannot change them or add new ones. 

 Session. Track when a visitor: 

starts a new session 
ends the session 
logs in 
logs out 
registers 
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 Pages. Track when a visitor views a particular page. 

 Content Items. Track when a visitor views a particular content item, such as an 
HTML or GIF file. 

 Content Types. Track when a visitor views content of a particular type, such as 
HTML or XML. 

 The Performs These Actions panel lets you create action statements that control how 
visitor profiles are updated in response to selected tracking events. For more 
information, see the Creating Action Statements for Tracking Sensors section. 

Adding New Tracking Sensors 
In order to track the pages, content items, and content types that your Web site visitors are viewing, you 
must add individual tracking sensors to those categories in the Tracking Sensors panel. (Note: Session 
tracking sensors are preset. You cannot add new Session sensors; you only need to create action 
statements in order to use them. For more information, see the Creating Action Statements for Tracking 
Sensors section.) 

To add a new Page, Content Item, or Content Type tracking sensor: 

1. Click the New Tracking Sensor button in the toolbar at the top of the Tracking Sensors 
window. The New Tracking Sensor dialog box appears. 

2. Select a tracking category (Content Item, Content Type, or Page) from the Monitor 
drop-down list. 

 If you select Content Item (as shown above), choose a repository from the 
Content Source list, and then select the item you want to track. 

 If you select Content Type, choose a repository from the Content Source list. 
The dialog box shows you the types of content stored in that repository (HTML, 
for example), allowing you to select the type you want to track. 

 If you select Page, select the page you want to track from the document 
directory. 

3. Click OK. 

The new sensor appears under the appropriate category in the Tracking Sensors panel. 
Content Item and Content Type sensors are listed under the content repository you 
selected. 

Next you create an action statement that controls how this tracking event affects visitor profile 
information. See the following section, Creating Action Statements for Tracking Sensors. 
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Creating Action Statements for Tracking Sensors 

Each time you add a new tracking sensor (or use one of the pre-defined Session sensors), you need to 
specify how you want the tracking results to modify visitor profile information. The ATG Control Center 
guides you through this process by helping you create simple action statements that update specific 
visitor properties. 

To create an action statement: 

1. Click on the tracking sensor in the Tracking Sensors panel. 

2. Select a tracking event in the When a Visitor panel. The event you choose represents 
the first part of your action statement. For example, 

When a visitor: 

   views this type of content 

As shown below, several drop-down lists appear below the Perform These Actions 
panel, allowing you to construct the rest of your action statement. 

 

3. Select one of the following actions from the drop-down list: 

 Assign assigns the value of the selected tracking property to the selected 
profile property. 

 Append appends the value of the selected tracking property to the selected 
profile property. 

 Append Once appends the value of the selected tracking property to the 
selected profile property unless the property has already been appended. (After 
the property has been appended once, you can’t append it again.) 

 Add adds the value of the selected tracking property to the selected profile 
property. 

 Subtract subtracts the value of the selected tracking property from the 
selected profile property. 

The next part of your action statement appears in the Perform These Actions panel. 
For example: 

When a visitor: 

   views this type of content 

Perform these actions: 

   Add... 

4. Select a tracking property from the drop-down list (or select Enter a Value to type your 
own value). For example, if you were to select a property called Aggressive Index, 
the following text would appear in the Perform These Actions panel: 
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When a visitor: 

   views this type of content 

Perform these actions: 

   Add the value of Aggressive Index... 

Note: The properties that appear in this list vary depending on the kind of tracking 
sensor you are working with. Content Item sensors use properties that are specific to 
all items within a particular content repository. Similarly, Content Type sensors use 
properties that are shared by all repository items of a particular type. Session and Page 
tracking sensors have pre-defined properties for you to choose from when you are 
creating action statements. For more information, see the Tracking Sensor Properties 
section. 

5. Select a profile property from the drop-down list. Note: The properties that appear in 
this list vary depending on the tracking sensor property you selected in the previous 
step. Only those properties of matching type are displayed. 

For example, if you were to select a profile property called Aggressive Index, the 
following text would appear in the Perform These Actions panel: 

When a visitor: 

   views this type of content 

Perform these actions: 

   Add the value of Aggressive Index to the person's Aggressive 

      Index attribute 

6. If you want to add other lines to the action statement, click the New Action button and 
repeat steps 3-5. 

7. Click Save. (If you select another sensor from the Tracking Sensors panel or switch to 
another task window before saving your changes, the ATG Control Center saves them 
automatically.) 

Important: After you add new tracking sensors, you must copy your changes from the staging server to 
your live site. For more information, see Copying and Switching Databases in the ATG Installation and 
Configuration Guide. 

Tracking Sensor Properties 

The following table lists the common properties you can apply to any tracking sensor and the pre-defined 
properties you can use for Session and Page sensors. 

Note: Content Item and Content Type sensors can use the common properties listed below along with 
the properties specific to their particular content repository and content type. 

 

Common Tracking Properties Description 

time The time (in milliseconds) at which the tracking event occurred. 

timeAsDate The time at which the tracking event occurred (as a Date object). 
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event type An integer index that represents the event in the When a Visitor 

panel (e.g., When a visitor logs in). 

Session Tracking Properties 

creationTime The time at which the session object was created. 

session id The ID for this session. 

lastAccessedTime The time at which this session object was last accessed. 

mimeType The MIME type of the request. 

usingCookies True if the client driving this session is using cookies to maintain 
the session. 

usingUrlRewriting True if the client driving this session is using URL rewriting to 
maintain the session. 

Page Tracking Properties 

path The path of the page relative to the document root. 

 

Removing Tracking Sensors 
You can remove Page, Content Item, or Content Type tracking sensors when you no longer need them. 
You cannot remove Session tracking sensors, but you can disable them by deleting their action 
statements. For more information, see Deleting Action Statements. 

To remove a tracking sensor: 

1. In the Tracking Sensors panel, select the tracking sensor you want to delete. 

2. Select File > Delete Tracking Sensor. The ATG Control Center removes the tracking 
sensor and action statement. 

Deleting Action Statements 

To delete all or part of an action statement: 

1. In the Perform These Actions panel, select the part of the statement you want to 
delete. 

2. Select Edit > Delete. 

3. Click Save. 
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Copying Tracking Sensors to the Live Site 

After you create or edit tracking sensors in the ATG Control Center, you must copy your changes from the 
staging server to the live site. For more information, see Copying and Switching Databases in the ATG 
Installation and Configuration Guide. 
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9 Creating Scenarios 

The Scenarios module is a component of the ATG platform that you can use to set up and manage 
customer scenarios, which are a choreographed series of interactions with your Web site visitors. In a 
scenario, you anticipate and track the actions of the people who visit your Web site, and you respond 
appropriately by, for example, tailoring the content of the Web site, offering price promotions, or sending 
targeted e-mail messages. 

The following is an example of a scenario: Your statistics show you that 30 percent of people who register 
for membership at your Web site never return for a second visit. You decide that you need to improve 
your record of retaining new members, and you come up with the following plan: 

 You will send a “Welcome!” e-mail to all new members as soon as they register, 
thanking them for joining your site and highlighting the services you can provide. 

 To members who do not return to the site within the next month, you will send an e-
mail offering an incentive to return. 

You use the Scenarios module to set up a scenario that implements the plan as a series of triggers and 
responses. You create the scenario by selecting building blocks from lists in the Scenarios area of the ATG 
Control Center and arranging them like a flow diagram. When it is finished, you have a graphical 
representation of the entire scenario, which makes it easy to visualize and change as necessary. The 
following shows a completed scenario: 

 

At the start of a scenario, the system considers all possible subjects (the set of all site visitors, whether 
currently active or not) for inclusion. As subjects move through the scenario, they encounter building 
blocks (called elements) that affect their progress in various ways. Some elements prevent the subject 
from proceeding further until a particular event occurs. Some carry out an action of some kind. Others 
narrow the set of subjects passing through the scenario by specifying criteria that subjects must meet to 
proceed. 

The elements in a scenario tell the Scenarios module the following: 

 The group of people to whom you want the scenario to apply; 

 The events that you want the system to watch for; 
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 The actions you want the system to perform in response; 

 The data you want the system to collect; 

 The timing of the scenario. You can use timing elements to define a qualifying window 
for actions, an amount of time that you want the system to wait at any stage, and the 
time and date that you want the system to perform a specific action. 

If you use ATG products in a multisite environment, meaning your installation supports two or more 
customer-facing Web sites that share data such as user profiles or a shopping cart, you can also specify 
the site or sites to which elements in the scenario apply. For information on setting up a multisite 
environment, refer to the ATG Multisite Administration Guide. 

Scenario Templates 

For scenarios that you will use frequently, you can set up templates. With a template, you can save a 
scenario and then use it as a pattern to create others. For more information, see Creating Templates for 
Scenarios. 

User Sampling 

You can also use scenarios to perform user sampling, in which you test scenarios and other Web site 
content on different groups of site visitors and then use the results of the test to fine-tune your Web site. 
For more information, see Performing User Sampling. 

How Are Scenarios Different from Targeters? 
Several features in the Scenarios module are also available in a different form in the Personalization 
module. For example, you can set up targeters in the Personalization module that respond to user actions 
by displaying personalized content on a page or by sending e-mail. 

The Scenarios module, however, introduces an element of time to the way you interact with visitors and 
personalize your site content. Scenarios can contain elements that tell the system to wait for a specified 
period before continuing with the next step; for example, you can have the system identify new 
members, and then wait three months before sending out a follow-up message. It is primarily this feature 
that turns a collection of unconnected personalization and targeting activities into a campaign and allows 
you to choreograph (and therefore better control) the relationship between your visitors and your Web 
site. 

The following guidelines below suggest when to use scenarios and when to use targeters. 

 Scenarios are triggered by events. If you want to personalize content as a result of a 
site visitor’s doing something specific (for example, logging in), use a scenario. 
Targeters are not event based. 

 The business rules you can set up through targeters are more flexible in some cases 
than scenarios. For this reason, if you need to set up highly complex rules to match 
content to visitors, use targeters. 
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 Scenarios use a feature called slots to display dynamic content. Slots provide some 

powerful advantages over targeters (for example, you can set up empty slots that 
generate their own requests for content). 

 The reporting features of the Scenarios module rely on scenarios to supply data. If you 
want to use reports to track and analyze business information, you must set up 
appropriate scenarios. 

 As described above, scenarios are time aware. If you want to set up a long-term 
approach to content and visitor management, use scenarios. 

Scenarios and targeters are, however, complementary features. You can use a combination of targeters 
and scenarios to achieve the results you want. 

Security Access in Scenarios 
The Scenarios option in the main ATG Control Center navigation menu contains two items: Scenarios and 
Scenario Templates. Your ability to access these items is determined by the security rights that the ATG 
system administrator assigns to your group in the People and Organizations > Control Center Groups 
window. For example, he or she may give access to scenario templates to some users but not others. For 
more information, refer to Security Access in the ATG Control Center. 

In addition, the administrator can define an additional layer of security that controls access to specific 
scenario folders and individual scenarios. 

Note also that your access rights to content repositories may also affect the items that you can include 
when you create scenarios. If, for example, you are trying to include a specific file in a slot element, and 
that file does not appear as an option in the list, you may want to check that your Control Center group 
has the appropriate access rights to the content repository in which the file is stored. 

For more information, refer to Setting Up Scenario Security Access in the ATG Personalization Programming 
Guide. 

Creating a Scenario: Basic Steps 
This section describes the basic steps you perform to create scenarios. Important: If you want to create or 
edit scenarios through the ACC on the management server (the server where ATG Content Administration 
and the ATG Business Control Center are installed), you must run the ATG platform with the Preview layer. 
For more information, see the ATG Business Control Center Administration and Development Guide. 

The following example shows how you would create a scenario to implement the plan outlined at the 
beginning of this chapter for retaining more new members at your Web site. The plan can be summarized 
as follows: 

 Send a “Welcome!” e-mail to all new members as soon as they register. 
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 For members who do not return to the site within the next month, send an e-mail 

including a special offer. 

Complete the following steps to create this scenario: 

1. Start the ATG Control Center. (For more information, see Starting the ATG Control 
Center.) Note that you must use the ATG Control Center that is connected to the 
scenario editor server; otherwise, the menu options that allow you to create and edit 
scenarios will not be available. For more information on the differences between 
global, individual, and scenario editor servers, refer to the ATG Personalization 
Programming Guide. 

2. Select Scenarios from the main ATG Control Center window, and then select Scenarios. 
The following window appears: 

 

Scenarios > Scenarios window 

3. Select By Folders from the dropdown list in the top left corner of the window. 

4. Select File > New Scenario. The Create New Scenario wizard appears. 

5. In the first screen, Use Scenario Template?, click No. 

Templates are pre-defined scenarios that contain a variety of standard elements. You 
can customize templates by adding your own elements, and you can create your own 
new templates for scenarios you expect to use frequently. For more information, see 
Creating Templates for Scenarios or Creating a Scenario from a Template. 
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6. Click Next, and use the window that appears to name the new scenario and to specify 

the folder where you want to save it. Note that these folders are internal to the ATG 
Scenarios module. 

7. Click Finish. The scenario editor window appears, and it displays the first element of a 
new segment. Segments are the individual phases of a scenario. 

 

8. Double-click the word “Segment” to make the text editable, and type a descriptive 
name. Then press Enter. The new name appears. 

 

The following section shows how to add elements to the new scenario segment: 

To add the next element, move the mouse over the line between the two rectangles and click the small 
diamond that appears on the line. (The line is called a connector.) A drop-down list appears showing the 
types of elements you can select. 

 

A set of standard elements is provided with the Scenarios module, but you can also add your own if 
necessary. For more information, see Adding Custom Elements to Scenarios. 

 Event elements are the “what” part of the scenario. They define the visitor behavior 
that you want to use as a trigger for the next element in the scenario. Examples: “visits 
page in folder /shoes” or “views an item from Products in the category ‘shoes.’” For 
more information, see Using Event Elements in Scenarios. 
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 People elements are the “who” part of the scenario. They act as filters that define the 

group of site visitors to include. Example: “People whose gender is female.” The 
system compares the criterion in the People element to the visitor profiles in your 
profile repository and includes in the scenario those people whose profiles match the 
criterion. For more information, see Using People Elements in Scenarios. 

 Time elements are the “when” part of the scenario. They can define either a specific 
moment in time (for example, “on March 13th at 12:00 PM”) or a period of time that you 
want the system to wait between elements (for example, “wait three months”). For 
more information, see Using Time Elements in Scenarios. 

 Condition elements add an “if” condition to the scenario, qualifying the preceding 
element. For example, after a visits page in folder /shoes element, you could 
have a Condition element that specifies the exact page: “if page is 
/shoes/hikingboots.jsp.” If the site visitor meets the criterion, the system applies 
the next scenario element. For more information, see Using Condition Elements in 
Scenarios. 

 Action elements extend the “what” part of the scenario. While Event elements define 
what the site visitor does, Action elements define what the system does in response. 
For example, you can have the system send an e-mail, modify a specific property in a 
user’s profile, or display a specific piece of content in a slot. (For more information on 
slots, see Using Slots.) For more information, see Using Action Elements in Scenarios. 

 Fork elements add parallel “if” conditions, allowing you to divide a scenario into 
separate branches and treat each branch differently. For example, you can have the 
system split the group of visitors according to gender, with one branch for female 
visitors and another for male visitors. You could then add different Action elements to 
each branch, displaying appropriate promotional items to each group. For more 
information, see Using Fork Elements in Scenarios. 

The following image shows a scenario that includes a fork: 

 

You can also use forks to watch for and handle multiple events within the same 
scenario. For example, you can create a scenario that watches for any visitor to log into 
a Web site and then watches for them to visit any one of a number of pages. You 
would add a Fork element and then add a “Visits” Event element to each branch, with 
each branch handling a different page. 

You can create nested forks (forks within a fork), which allow you to handle complex 
“if” criteria within a single scenario. 
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 Randomizing Fork elements are the foundation for the powerful user sampling 

functionality of the Scenarios module. They are essentially the same as forks, except 
they allow you to divide the group of site visitors by percentage. So, for example, you 
could divide a scenario into two branches, displaying Product A to 50 percent of the 
group and Product B to the other 50 percent. You use this element type in 
combination with the Scenario module’s data tracking features to measure the success 
of scenarios and Web content; in this case, you could measure the popularity of 
Product A over Product B in terms of quantity sold. 

For more information, see Performing User Sampling. 

 Add Branch elements allow you to add new empty branches to a fork. 

 Otherwise elements allow you to add an “else” statement to a fork. For more 
information, see Using Otherwise Elements in Scenarios. 

 Stop elements prevent a visitor from progressing through a scenario in a given 
situation. When a visitor triggers a stop element, he or she is removed from the 
scenario and does not proceed to any subsequent elements. A Stop element is also 
added automatically to the end of each scenario. For more information, see Specifying 
the End of a Scenario. 

In this example, the first step in the scenario is to identify people who have just registered at your site. 
You select Event and then you select Registers from the list of available event types. 

 

Click the check mark at the end of the edit box to accept this element as part of the scenario. (Clicking the 
x removes this element.) 

The ATG Control Center displays the new element in the scenario: 

 

The Registers element tells the system to wait for a visitor to register at your site and then allow him or 
her to continue to the next element of the scenario. You can also include various qualifiers that further 
define the registration event – for example, you can include a qualifier that tells the system to watch only 
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for those registrations that occur during a specific type of visitor session. For this example, however, you 
want to apply the scenario to all registrations, so you do not add any qualifications to the element. 

Note that the connector (the line between elements) has changed from a triple line to a single one. The 
difference in line width shows that any remaining elements in the scenario apply only to individual site 
visitors rather than to all visitors. 

Next, you want the scenario to send a “Welcome!” e-mail to the people who just registered. First you add a 
Time element, Wait 5 Minutes, to allow the system to process the registration before sending the 
message. You click the connector and add the Time element. Then you add an Action element, selecting 
Send Email from the menu. In the Send Email element, you specify welcome.jsp from the list of available 
targeted e-mail templates. (Your page developer sets these up in the Pages and Components > Pages 
area of the ATG Control Center. For more information, see Working with Targeted E-Mail.) 

 

Note: In most cases, it is not necessary to add a Wait element between an Event element and a Send 
Email element. The exception is the Registers event. 

At this point you want the system to respond differently to new members depending on their behavior. 

You add a Fork element to the scenario. You use one branch to handle members who do return to the 
site. To this branch you add an Event element, selecting “Logs in” from the list of available events. 

 

You use the other branch for people who do not satisfy the “Logs in” condition in the first branch. You 
add a Time element, selecting “Wait thirty days” from the list. To that same branch, you then add a Send 
Email Action element, selecting newmemberoffer.jsp from the list of targeted e-mail templates. Again, a 
page developer sets these up in the Pages and Components > Pages area of the ATG Control Center. 

 

Note that the vertical order of the branches is not important. 

Select File > Save. The scenario is complete. It is not active, however, until you enable it and then copy it 
to your live site (see Enabling and Disabling Scenarios). 
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A Note About Scenarios with More than One Segment 

Scenarios can contain as many segments as you require. However, it is important to note that there is no 
physical connection between separate segments in the same scenario; visitors do not pass from the end 
of one segment to the beginning of the next. The advantage of including more than one segment in a 
scenario is organizational: you can give the scenario a meaningful name (for example, “promotions”) and 
then keep all segments related to that subject in the same scenario. 

To add a new segment to a scenario, select Edit > Add Segment. 

By default, the segments in a scenario are not processed in any specific order. For example, if two 
segments contain the same element (for example, a Registers element), you cannot by default control 
which segment will be triggered first; the order depends on variables such as the number of scenario 
servers that are waiting for events and the speed with which each one processes the events it receives. 
(For more information, refer to the ATG Personalization Programming Guide.) You can change this 
behavior, however, by specifying a priority level for each segment. If two segments contain the same 
element, the element within the segment with the higher priority level is triggered first. 

Consider the following example: 

 

Between the dates shown in the New Member Email segment, both segments are waiting for a site visitor 
to register as a new member. However, the priority level of the second segment is higher, so the Registers 
element in the second segment is processed first. 

To set a segment’s priority level, perform the following steps: 

1. Right-click the segment’s name. 

2. Select Set Segment Priority from the pop-up menu. 

3. Type the priority level for this segment. The default value is 0. You can enter negative 
as well as positive values. Higher values take priority; for example, a segment with 
priority 2 is processed before segments with priority 0 or -1. 

The segment’s priority level is displayed only if the value is other than 0. 
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Note that a segment’s priority level applies only within its own scenario. 

Editing or Deleting Scenario Elements 

To change an element that you have included in a scenario, double-click it to make it active and then 
change it as necessary. The following list shows different ways to navigate through a scenario and edit its 
elements: 

 To move to the next piece of an element, press the right arrow key, the Tab key, or the 
spacebar. 

 To move to the previous piece of an element, press the left arrow key, Shift+Tab, or 
Shift+spacebar. 

 To move to the first element in a segment, press Home. To move to the last element, 
press End. 

 You can copy and paste elements both within a single segment and from one 
segment or scenario into another. To do this, click the element to copy, and then 
select Edit > Copy. Click the place where you want to position the copy, and then 
select Edit > Paste. 

 You can also edit elements by right-clicking them and using the edit menu that 
appears, or by dragging and dropping them. When you drag an element, you can 
either drag the original element or drag a copy, leaving the original in place. To drag a 
copy, hold down the Ctrl key while you move the element. 

 To delete a single element, click it once to make it editable and then select Edit > 
Delete. 

 To delete a whole scenario segment, click the first element in the segment, and then 
select Edit > Delete. 

Important: If you change or delete a scenario segment that is currently enabled, the Scenarios module 
may remove from the segment any site visitors who are currently progressing through it. Refer to 
Changing an Enabled Scenario for information on possible effects of your action. 

Caution: Specifying a Range of Values in an Expression 

Some elements can contain expressions for which you specify a range of values separated by commas, for 
example “People whose last name is one of [Smith, Jones, Garcia].” 

In these expressions, do not type the comma manually. Instead, select the final bracket so that a menu 
appears, like this: 

 

Select the comma from the menu, and type the next value as required: 
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The expressions to which this caution applies are “is one of,” “is not one of,” and “includes any of.” 

Working with Read-Only Scenarios 

Scenarios can be designated as “read only” to prevent accidental editing. If you attempt to open a read-
only scenario, a message appears, informing you that you will not be able to make any changes to it. You 
can, however, copy elements of the scenario for use elsewhere. You can also enable, disable, and delete 
read-only scenarios. 

For more information, refer to ATG Personalization Programming Guide. 

Repeating an Element 

By default, the system automatically applies a scenario more than once to the same site visitor as long as 
she meets the criteria that trigger the scenario. Consider the following example from the Quincy Funds 
demo (the PromoteGrowthFund scenario in the QuincyFunds\InvestorPromotions folder): 

 

In this scenario, the system waits for visitors to register or log in. If the visitor’s fund list does not include a 
fund called growth.xml, the system displays a message promoting that fund. The scenario is active for a 
nineteen-month period. If the same visitor logs in again during that period, the system applies the 
scenario again, displaying the message if appropriate. 

The arrows around the portion of the scenario that contains the two forks show that an individual visitor 
can repeat this scenario. (Note that the first arrow is sometimes larger than the one shown here to 
accommodate elements that take up more vertical space on the screen. There is no functional difference 
between the different sizes.) 

In many cases, repeat behavior is appropriate. In others it is not. Consider the following example: 
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In this scenario, the system e-mails a coupon to people who view specific catalog items during a two-
month period. However, in this case, the default behavior for repeating a scenario has been turned off, so 
the system will send the coupon only once to each visitor no matter how many times he views the 
triggering item. 

To turn off the repeat behavior, do the following: 

1. Right-click the first element in the segment (the element that shows the name). 

2. Deselect the Toggle Allow Individuals to Repeat option from the menu that appears. 

The system removes the arrow from the beginning of the scenario (specifically, from 
before the Views event) and replaces the arrow at the end with a People icon in a grid, 
as shown below: 

 

You can repeat a whole scenario, and you can also repeat individual Event and Time elements within a 
scenario, as shown in the following example: 

 

Here, the Time element can occur more than once. In this case, the scenario sends out an e-mail 
containing a monthly offer on the first day of every month. 

Unlike whole segments, individual elements do not repeat by default. You must turn this behavior on. To 
repeat an individual element: 

1. Right-click the element you want to repeat. 

2. Select Toggle Multiple Occurrences from the menu. 

The system displays arrows at each end of the element to show that it can occur more 
than once. 

Note that you cannot repeat individual elements if the repeat behavior is turned off for the whole 
scenario. 
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Using People Elements in Scenarios 

Use People elements to filter site visitors by their profile group or according to specific properties in the 
profile repository. 

 

Element Use 

People whose Lets you use specific properties in the visitors’ profiles as criteria for including 
them in the scenario. If the property you specify matches the profile, the 
visitor proceeds to the next element in the scenario. 

Examples: People whose gender is female 

People whose Receive email is yes 

People in group Lets you filter visitors according to the profile groups that you set up using the 
Targeting > Profile Groups window in the ATG Control Center. Visitors who 
belong to the specified profile group proceed to the next element in the 
scenario. 

Example: People in group Brokers 

People with profile 
type 

Lets you filter visitors according to any profile types your site developers have 
set up. Visitors whose profile belongs to the specified type proceed to the next 
element in the scenario. 

For more information on profile types, refer to the . 

People in 
organization 

Lets you filter visitors according to any Dynamo User Directory organizations 
you have defined using the People and Organizations > Organizations option. 
People who belong to the specified organization, either directly or through 
inheritance, proceed to the next element in the scenario. 

Example: People in organization Sales 

For more information on organizations, refer to the ATG Personalization 
Programming Guide. 

People with role Lets you filter visitors according to any Dynamo User Directory roles you have 
defined using the People and Organizations > Roles option. People who are 
assigned to or have inherited the specified role proceed to the next element in 
the scenario. 

Example: People with role Administrator 

For more information on roles, refer to the ATG Personalization Programming 
Guide. 

 

You can create complex conditions by combining more than one People element. For example, the 
following scenario sends an e-mail to people who belong to the profile group Investors and whose 
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Receive Email property is set to Yes. It achieves its results by having two People elements, one after the 
other. The second element applies only to people who have progressed through the first element. 

 

Using Time Elements in Scenarios 
The Scenarios module includes four Time elements: 

 Wait 

 On 

 At 

 Between 

The following sections describe how to use these elements. 

Using the Wait Element 

Use the Wait element to define the length of time that you want the system to wait for a specified event 
or before performing a given action. 

Note 1: If you include a Registers event element in a scenario, it is highly recommended that you insert a 
Wait element directly after it and set the amount of time to wait to 5 minutes. This extra wait period 
ensures that the system has enough time to process the registration before it proceeds to any other 
elements in the scenario. See Creating a Scenario: Basic Steps for an example. 

Note 2: It is possible to set up repeated timer events that, for example, send an e-mail every week or 
record an audit trail event every day. (You do this by adding a Wait element to your scenario and turning 
on the Toggle Multiple Occurrences feature for the Wait element. For more information, see Repeating an 
Element.) However, if you choose a repetition interval that is very short, for example every minute or 
every two minutes, be aware that the action after the Wait element may not recur exactly at the expected 
time. This behavior occurs because the Scenarios module takes a certain amount of time to deliver the 
internal messages it uses to fire elements. For this reason, it is not recommended that you set up repeated 
timer events with a very short interval if you require them to occur precisely as scheduled. 

Using the On Element 

Use the On element to define an exact time when you want a scenario action to occur. This element is an 
effective way to start a scenario. You can also use it as a filter element in the middle of a scenario, for 
example at the beginning of a branch in a Fork element. (See Using Fork Elements in Scenarios.) 

On elements can have the following variations: 
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 On date: at a specific date and time, for example on Monday, November 13th at 8:00 

am. You could use this element at the beginning of a scenario to specify the day and 
time you want the scenario to take effect. You could also use it to define a specific date 
and time for an action – for example, you could use it to send a targeted e-mail at a 
specific time. 

 On weekday: on a specific day of the week, for example on Tuesday. In this example, 
the system applies the element on the first Tuesday after you enable it, and then 
repeats it every Tuesday after that. 

 On weekday in month: on a numbered weekday of a given month, for example on 
the second Tuesday in November. If you keep the scenario enabled, the system 
repeats the element every year. 

 On monthday: on a numbered day of the current month, for example on day 27 of the 
month. The system applies this element on the next occurrence of the specified day 
after you enable the scenario. It repeats the element every month on that day. 

To select one of these variations, click the small diamond after the word On in the element and select the 
option you want from the list that appears. 

See Repeating an Element for more information on how to change the default repeat behavior for these 
and other elements. 

Using the At Element 

The At element acts as a simpler version of the On Date element, specifying a time of day only. When you 
include an At element in a scenario and then enable the scenario, the system waits for the next instance 
of that time and then activates the element. 

Using the Between Element 

The Between element acts as a filter that defines a period of time during which the elements in a scenario 
can occur. It is an useful way to start a scenario that you want to be in effect for a limited time only. The 
following example shows a scenario that offers a seminar-related promotion to visitors from certain areas. 
The Between element limits the display of the offer to a specific period: 

 

You can use the following variations of the Between element: 

 Between times, for example “Between 2 PM and 4 PM.” 

 Between dates, for example “Between December 1st 2000 and December 24th 2000.” 

 Between dates and times, for example “Between December 1st 2000 at 12:00 am and 
December 10th at 11:59 PM.” 



A T G  P e r s o n a l i z a t i o n  G u i d e  f o r  B u s i n e s s  U s e r s  

 

1 1 4  

9  -  C r e a t i n g  S c e n a r i o s  

μ
To select one of these variations, click the small diamond after the word Between in the element and 
select the option you want from the list that appears. 

In all cases, the element takes effect on the next instance of these dates and/or times after you enable the 
scenario. The system repeats Between Times elements every day. It does not repeat Between Dates or 
Between Dates and Times elements unless you specify that you want it to do so. (See Repeating an 
Element.) 

Like On elements, you can also use Between elements as filters in the middle of a scenario, for example at 
the beginning of a branch in a Fork element. (See Using Fork Elements in Scenarios.) 

Editing a Time Element 

To change one of the pieces within a Time element, click the diamond that appears within the element 
itself and use the menu that appears. The following image shows the options that appear for the On 
element: 

 

Using Event Elements in Scenarios 
This section describes the default Event elements you can insert into a scenario segment (see Creating a 
Scenario: Basic Steps). 

If your application developers have added any custom events, these appear as additional options in the 
Events element in the Scenarios task area. For more information, see Adding Custom Events, Actions, and 
Conditions to Scenarios in the ATG Personalization Programming Guide. And, if your product suite includes 
ATG Commerce, additional Commerce-related events will appear (for example, Uses Promotion). For more 
information on these events, refer to the ATG Commerce documentation. 

If you use ATG products in a multisite environment (one in which your installation supports several 
customer-facing Web sites that share data such as user profiles or shopping carts), you can specify the 
sites that each event applies to. By default, events apply to all the sites in your system. For example, a 
Registers event is triggered when a user registers on any Web site unless you configure the event to apply 
to specific sites only. See the ATG Multisite Administration Guide for information on how to set up a 
multisite environment. 

Note for developers: Scenario Event elements are triggered when the ScenarioManager component 
receives events sent as Dynamo Message System messages. The optional parameters that appear in the 
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scenario editor for a specific Event element correspond to the properties of the message bean that 
represents that event, including properties inherited from any parent classes. For example, the 
parameters you can select to further define the Logs In event are the properties associated with the 
DPSMessageSource component. For technical information on each Event element, refer to Using Scenario 
Events in the ATG Personalization Programming Guide. 

A Form is Submitted 

The system watches for a visitor to submit a form on one of your site pages, typically by completing one 
or more text fields and clicking an appropriately named button. 

You can use the optional parameters within this element to further define the form whose submission 
you want to trigger this event. 

 

Parameter The element is triggered when… 

with any attributes Any form is submitted 

where formName The form whose name you specify is submitted. 

Example: A form is submitted where formName is decemberSurvey 

The formName value is the name that the page developer gives the form 
when he or she adds it to a site page. To find the name of a particular form, 
look at the code for the JHTML or JSP file in which the form is located. Use the 
Pages area of the ATG Control Center to display the file. 

If the developer does not give the form a specific name (in other words, of he 
or she does not provide a formName value, the system uses the form’s 
absoluteName property instead; for example, the formName of the 
/atg/userprofiling/ProfileFormHandler component defaults to 
/atg/userprofiling/ProfileFormHandler. 

For more information on how to spot this value on a page, refer to the ATG 
Page Developer’s Guide. 

Where Site 

Where Site's 

A form is submitted on one or more specific Web sites or on a site that 
matches the criteria you select. If these parameters are not set, the event 
applies to all Web sites in your system. 

See Specifying Site Parameters for information on these options. 

 

An Email is Received 

The system watches for an e-mail message to arrive. (Specifically, this element watches for e-mail 
messages to be received by the atg/dynamo/service/POP3Service component.) 

You can use this element to monitor incoming e-mails that you receive as part of activity on your Web 
site. For example, you could use it to set up a scenario that keeps count of the number of e-mail responses 
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you receive to a targeted e-mail campaign. Alternatively, you could create a scenario that watches for 
messages with a specific subject line and forwards them to your Customer Service group. 

Use the optional parameters within this element as follows: 

 

Parameter The element is triggered by… 

where bounced The bounced value of the message, which indicates whether the e-
mail is one that was returned because it was undeliverable. 

where 

bouncedEmailAddress 

The e-mail address of the person to whom a bounced message was 
sent. 

where 

bouncedReplyCode 

The RFC 821 reply code of a bounced e-mail. RFC 821 reply codes are 
part of the Simple Mail Transfer Protocol (SMTP) standard for sending 
and receiving e-mail. (For more information, refer to 
http://www.ietf.org/rfc.html.) 

Example: 550 

where 

bouncedStatusCode 

The enhanced RFC 1893 status code of a bounced e-mail. (For more 
information, refer to http://www.ietf.org/rfc.html.) 

Example: 5.1.1 

where 

bouncedErrorMessage 

The text error message from a bounced e-mail that indicates why a 
message was refused. 

Example: User unknown 

The text is the mail server’s interpretation of the enhanced RFC 1893 
status code. For information on the text you can specify, please refer 
to the documentation for the mail server used by your site. 

where message Properties of the content of the message 

where messageCc The e-mail address of the recipient or recipients included in the “CC” 
field of the message 

where messageFrom The e-mail address of the person who sent the message (the “From” 
field in an e-mail). 

Example: An e-mail is received where messageFrom includes atg.com 

In this case, the system watches for incoming e-mail from the domain 
atg.com. 

where 

messageRecipients 

Any e-mail address in either the “To” or “CC” fields 

where messageReplyTo The Reply-To e-mail address of the message 
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Parameter The element is triggered by… 

where messageSubject The subject line of the message. 

Example: An e-mail is received where messageSubject is Enroll me! 

where messageTo The e-mail address of the recipient or recipients of the message (the 
“To” field in an e-mail) 

where originalSubject The original subject line of the message. The original subject is the 
subject line without the word “Re:” that may be added if this e-mail 
message is a response to another. 

Example: An e-mail is received where originalSubject is Come back, we 
miss you! 

In this case, an incoming message with the subject line Re: Come back, 
we miss you! will trigger this element. 

where receivedDate The date on which the message was received 

 

Clicks a Link 

The system watches for a site visitor to follow a link from one site page to another. This element is 
specifically designed for scenarios in which you want to track aspects of visitor navigation through your 
sites. For example, you might want to record the number of times that visitors display a given set of pages 
during a specified time period, or keep track of the links that visitors follow most often from a given page. 

This element is similar to the Visits element (see below), except that the Clicks a Link element works only 
for links that page developers have set up with an anchor tag that includes a dsource parameter. The 
following shows an example of the JSP code that a page developer would add to a site page for this type 
of link: 

<dsp:a href="content/welcome.jsp"> 

  <dsp:param value="OnSale, MemberDiscount" name="dsource"/> 

  Click here to see this month's discounts! 

</dsp:a> 

The values that the page developer specifies for the dsource parameter (in the example, OnSale and 
MemberDiscount) can be any text that he or she chooses. The system uses them to identify and 
distinguish the links. For example, the page developer might give several links the same dsource value to 
identify that they belong to a similar group, such as links that point to a specific set of content pages. 
(Note that dsource is the default name for this parameter, but developers may change it. To see the 
parameter name for a given link, display the page containing the link in the Pages and Components area 
of the ATG Control Center.) 

The Clicks a Link element contains the following optional parameters: 
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Parameter The element is triggered when… 

anywhere A site visitor clicks any link whose anchor tag contains a dsource 
parameter. 

from page A site visitor clicks any dsource link on the specified page. 

Examples: 
Clicks a link from page named /welcome.jsp 

Clicks a link from page in folder /content/today/ 

to page A site visitor clicks any dsource link that goes to the specified page. 

Examples: 
Clicks a link to page named /thismonthonly.jsp 

Clicks a link to page in folder /content/monthlyspecials 

where source name list A site visitor clicks a link containing a specific dsource parameter. 

Examples: 
Clicks a link where source name list includes OnSale. 

Clicks a link where source name list includes any of 

[OnSale, MemberDiscount, MonthlyPromo] 

 

You can also use this element for links that you include in e-mail messages that you send to site visitors 
(for example, as part of a promotional campaign). Make sure that the link contains a dsource parameter 
as shown above. 

Note that in a multisite ATG environment, pages typically exist on more than one Web site. For example, 
you could have several sites that all use the same login.jsp page. The page would include code that 
showed different content for each site. If you have a link on a page that is common to several sites, the 
Clicks A Link event will be triggered for all sites. To avoid this behavior and have the event apply to 
specific sites only, include an Event’s Site… condition element after the Clicks a Link event, as shown: 

Clicks a Link > Event's Site Is ATG Home 

Dynamo Shuts Down 

The system watches for the ATG server to shut down. 

Dynamo Starts 

The system watches for the ATG server to be started. 

Is Referred by External Site 

The system watches for a visitor to arrive at your site or at a specific page on the site by clicking a link from 
a site or page with given attributes (for example, a specific URL). 
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Examples: 

Is referred by external site where referrerURL is 

http://www.example.com/products/shoes.jsp 

Is referred by external site where referrerSite is www.example.com 

Is referred by external site where referrerPage is /products/shoes.jsp 

Note that this event can be used to track arrivals both from external sites and from pages within your own 
Web site. 

 

Parameter The element is triggered when… 

with any attributes The visitor Is referred by any other site, including sites that are not part of an 
ATG multisite environment 

where attributes See the examples above. 

Where Site 

Where Site's 

The visitor Is referred by one or more specific ATG-registered Web sites or by a 
registered site that matches the criteria you select. (“Registered” sites are 
those supported by an ATG multisite environment.) 

Example: 

Is referred by external site where Site is ATG Home 

See Specifying Site Parameters for information on these options. 

 

Items Requested 

The system watches for a visitor to perform an action on the site (for example, visit a given page) that 
causes an active slot to request content items. See Using Slots for more information. 

You must specify the slot that you want to use to trigger this element. To do this, use the By Slot 
parameter within this element to select an existing slot. Example: Items requested by slot TodayOnly. This 
example tells the system to watch for a visitor to perform an action that causes a slot named TodayOnly to 
request content items. 

Bear in mind that in a multisite environment, the slot may exist on more than on Web site. 

Logs In 

The system watches for a visitor to log into your site (typically through a Login page that contains ID and 
password fields set up by your site developers). 

 

Parameter The element is triggered when… 

with any attributes A site visitor logs into any Web site supported by your system. 
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Parameter The element is triggered when… 

Where Site 

Where Site's 

A visitor logs into one or more specific Web sites or into a site that matches 
the criteria you select. If these parameters are not set, the event applies to all 
Web sites in your system. 

See Specifying Site Parameters for information on these options. 

 

Logs Out 

The system watches for a visitor to log out of your site (typically by clicking a Log Out button set up by 
your site developers). 

 

Parameter The element is triggered when… 

with any attributes A site visitor logs out of any Web site supported by your system. 

Where Site 

Where Site's 

A visitor logs out of one or more specific Web sites or out of a site that 
matches the criteria you select. If these parameters are not set, the event 
applies to all Web sites in your system. 

See Specifying Site Parameters for information on these options. 

 

Profile Property Updated by Admin 

The system watches for an administrator to change a specific property in a user’s profile (or in a group of 
profiles), typically through a batch profile change form on your site. See also the description of the Profile 
Updated by Admin element. 

Note that this event is not triggered if an administrator changes a profile through the ATG Control Center. 

Profile Property Updated by User 

The system watches for a visitor to change one of the values in his or her profile, typically through a form 
that page developers have set up for this purpose on your site. For example, a visitor might use an Edit My 
Profile form on your site to change her home address or product preferences. 

Use the optional parameters in this element to define the type of change that you want to trigger the 
element. The parameters that you can choose correspond to properties in the Profile repository. 

Examples: 

Changes Marital status from single to married 
Changes Home address’s city to Boston 
Changes Interests by removing dancing 
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See also the description of the Profile Updated by User element. 

Profile Registered by Admin 

The system watches for an administrator to register a user or a group of users at your site (typically by 
completing a batch registration form). 

 

Parameter The element is triggered when… 

with any attributes The administrator registers a user at any Web site supported by your system. 

Where Site 

Where Site's 

The registration occurs on one or more specific Web sites or on a site that 
matches the criteria you select. If these parameters are not set, the event 
applies to all Web sites in your system. 

See Specifying Site Parameters for information on these options. 

 

Profile Updated by Admin 

The system watches for an administrator to change or delete a user profile or a group of profiles, typically 
through a batch profile update form that page developers have added to your site. 

Note that this event is not triggered if an administrator changes a profile through the ATG Control Center. 

Profile Updated By User 

The system watches for a visitor to change his or her profile. This element is similar to the Updates Profile 
Property element described above, except that here the scenario watches for any change to a profile 
rather than watching for a change to a specific property. 

Registers 

The system watches for a previously anonymous visitor to register at your site (typically by completing a 
registration form set up by your site developers). 

Note: If you include a Registers event element in a scenario, it is highly recommended that you insert a 
Wait element directly after it and set the amount of time to wait to 5 minutes. This extra wait period 
ensures that the system has enough time to process the registration before it proceeds to any other 
elements in the scenario. See Creating a Scenario: Basic Steps for an example. 

 

Parameter The element is triggered when… 

with any attributes A visitor registers at any Web site supported by your system. 
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Parameter The element is triggered when… 

Where Site 

Where Site's 

A visitor registers at one or more specific Web sites or at a site that matches 
the criteria you select. If these parameters are not set, the event applies to all 
Web sites in your system. 

See Specifying Site Parameters for information on these options. 

 

Session Ends 

The system watches for a site visitor to leave the site (or for his or her session to expire). 

 

Parameter The element is triggered when… 

with any attributes A session ends on any Web site supported by your system. 

Where Site 

Where Site's 

A session ends on one or more specific Web sites or on a site that matches the 
criteria you select. If these parameters are not set, the event applies to all Web 
sites in your system. 

See Specifying Site Parameters for information on these options. 

 

Session Starts 

The system watches for a site visitor to access the site (or to start a new session). 

 

Parameter The element is triggered when… 

with any attributes A session starts on any Web site supported by your system. 

Where Site 

Where Site's 

A session starts on one or more specific Web sites or on a site that matches 
the criteria you select. If these parameters are not set, the event applies to all 
Web sites in your system. 

See Specifying Site Parameters for information on these options. 

 

For more information on configuring a multisite ATG environment, refer to the ATG Multisite 
Administration Guide. 

Switches Site Context 

The site context identifies the current site in a multisite environment. With this event, the system watches 
for the site context to change, which indicates a visitor has navigated from one of your registered Web 
sites to another. 
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Parameter The element is triggered when… 

with any attributes A visitor switches to or from any Web site that is supported by your system. 

Where Site is 
switched to 

A visitor switches to a Web site that meets the criteria specified. 

Example: Switches site context where site is switched to is ATG Home 

Where Site is 
switched from 

A visitor switches from a Web site that meets the criteria specified. 

Where Site is 
switched to's 

Where Site is 
switched from's 

The options you can specify correspond to the properties set for the site in 
the Site Administration utility. See Specifying Site Parameters. 

 

For more information on configuring a multisite ATG environment, refer to the ATG Multisite 
Administration Guide. 

Note: The scenario editor includes a Site Visit event, which is used by ATG Customer Intelligence to gather 
data for reports. The event is not intended to be used for tracking activity related to registered sites in a 
multisite ATG environment. 

Visits 

The system watches for a visitor to display specific pages. You can use the optional parameters to define 
the pages that you want to trigger this Event element. 

Examples: Visits any page 

Visits a page named Quincy Funds J2EE DAF Demo:/en/mypreferences.jsp 

Visits a page in folder Pioneer CyclingJSP: /en/catalog 

Visits elements work for any page that a visitor specifically requests for display on the site (for example, by 
clicking a link that leads to that page). However, there are some circumstances in which a page request 
does not trigger a Visits element because it does not involve specifically requesting that page from the 
system. For example, in the Quincy Funds demo, the investorhome.jsp page is displayed within the 
index.jsp page by way of code that looks at the visitor’s userType profile property. Visitors never 
request investorhome.jsp directly. When you include a page in a Visits element, make sure that page is 
one for which visitors can issue a specific display request. 

It is also important to be aware that in a multisite environment, the same pages typically exist on all your 
registered Web sites. (The pages contain code that causes different content to appear on each site as 
needed.) For example, the ATG Commerce Reference Store demo contains one login.jsp page that 
appears on three sites: ATG Home, ATG Store, and ATG Store Germany. If you select this page, the event 
will be triggered when a customer visits the login page on any of these sites. In this case, to restrict the 
event to one site, you can add an Event's Site condition element that specifies the site , as shown: 
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Visits a page named ATG Commerce Reference Store:/myaccount/login.jsp 

> Event's Site is ATG Store 

Note: When you select the options Visits a page named… or Visits a page in folder…, you are prompted to 
select a page or folder from a list of available choices. The ATG Control Center automatically prepends the 
necessary path information for the item (the path includes either the ATG document root or, for J2EE 
applications, the context root). By contrast, if you select Visits page with Dynamo path or Visits page in 
Dynamo folder, you must type the fully qualified path to the page or folder yourself. These latter options 
exist mostly for backwards compatibility and replicate the way users specified document paths in earlier 
versions of the product. It is recommended that you use Visits a page named… or Visits a page in folder… if 
you have any doubt about the path of the item you want to use in this element. 

Views 

The system watches for a site visitor to view an item from a content repository. You can use the optional 
parameters within this element to specify the exact items or repositories that trigger this event. 

Example: Views any item. This example tells the system to watch for a visitor to view any item from any 
repository. 

Example: Views an item from Funds whose Aggressive Index is 3. An element that you set up this way tells 
the system to watch for a visitor to view any item from the given repository (Funds) that has its Aggressive 
Index property set to 3. 

In a multisite environment, you can use an Event's Site condition element to constrain the event to 
one or more specific sites. See the description of the Visits element for more information. 

GSA Repository Cache Invalidation Received 

The system watches for a repository item to be flushed from the cache by the JMS Distributed Cache 
Invalidation Service. For more information, refer to Using Scenario Events in the ATG Personalization 
Programming Guide. You can use the optional parameters to specify the repository items you want to use 
to trigger this event. 

 itemDescriptorName – a specific item type. The invalidation of cached items of that 
type triggers this event. 

 repositoryPath -- The Nucleus address of a cached GSARepository component. 
Invalidation of the entire repository triggers this event. 

 itemId -- The ID of a specific cached repository item. Invalidation of that item triggers 
this event. 

Profile Marker Added 

This scenario element detects when a Profile Marker Manager adds a marker to a profile. 

You can use the optional parameters within this element to define the event that triggers this scenario 
element. 
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Parameter The element is triggered when… 

where eventDate The marker is added on the date and time you specify. 

where markedItemId The marker is added to the profile whose ID you specify. 

where markedItemType The marker is added to an item of the particular repository item type 
you specify. 

where parentSessionID This event occurs during the session you specify. 

where profileID The marker is added to the profile whose ID you specify. 

where repositoryName The marker is added to an item that uses the repository you specify. 

where sessionID The marker is added during the session you specify. 

where 
markerAddedData's 

The marker being added has the creation date, data, key, marker ID, 
repository item type or value you specify. 

 

For more information on the ProfileMarkerAdded event, see the Marking a User Profile section in the 
Using Profile Markers chapter of the ATG Personalization Programming Guide. 

Profile Marker Removed 

This scenario element detects when a Profile Marker Manager removes a marker from a profile. 

You can use the optional parameters within this element to define the event that triggers this scenario 
element. 

 

Parameter The element is triggered when… 

where eventDate The marker is removed at the date and time you specify. 

where markedItemId The marker is removed from the profile whose ID you specify. 

where markedItemType The marker is removed from the particular repository item type you 
specify. 

where parentSessionID This event occurs during the session you specify. 

where profileID The marker is removed from the profile whose ID you specify. 

where repositoryName The marker is removed from an item in the repository you specify. 

where sessionID The marker is removed during the session you specify. 

where 
markerRemovedData's 

The marker being removed has the creation date, data, key, marker ID, 
repository item type or value you specify. 
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For more information on the ProfileMarkerRemoved event, see the Removing Profile Markers section in 
the Using Profile Markers chapter of the ATG Personalization Programming Guide. 

Profile Marker Replaced 

This scenario element detects when a Profile Marker Manager replaces one profile marker with another. 

You can use the optional parameters within this element to define the event that triggers this scenario 
element. 

 

Parameter The element is triggered when… 

where eventDate The marker is replaced at the date and time you specify. 

where markedItemId The marker being replaced was attached to the profile with the ID you 
specify. 

where markedItemType The marker being replaced was attached to an item of the particular 
repository item type you specify. 

where parentSessionID This event occurs during the session you specify. 

where profileID The marker being replaced was attached to the profile whose ID you 
specify. 

where repositoryName The marker being replaced was attached to an item in the repository 
you specify. 

where sessionID The marker is replaced during the session you specify. 

where 
markerAddedData's 

The marker being added has the creation date, data, key, marker ID, 
repository item type or value you specify. 

where 
markerAddedData's 

The marker being replaced has the creation date, data, key, marker ID, 
repository item type or value you specify. 

 

Business Process Stage Reached 

The system watches for a stage in a business process to be reached. 

 

Parameter The element is triggered by... 

with any attributes Any business process stage is reached 

where BusinessProcessName A business process stage is reached in the business process 

Example: Business Process Stage Reached where 
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businessProcessName is ShoppingProcess 

where BusinessProcessStage The business process stage whose name you specify is reached. 

Example: Business Process Stage Reached where 
businessProcessStage is AddedToCart 

where 
BusinessProcessStageSeque

nce 

The business process stage whose sequence number you specify is 
reached. The sequence number is an integer. 

Example: Business Process Stage Reached where 
businessProcessStageSequence is 2 

 

For more information, see the Defining and Tracking Business Processes chapter in the ATG Personalization 
Programming Guide. 

Specifying Site Parameters 

If you have a multisite ATG environment (one in which a single ATG installation supports several Web sites 
that share items such user profiles and shopping carts), you can configure many of the scenario events 
described in this chapter so they apply only to specific sites. For example, you can configure a Logs In 
event so it is triggered when a visitor logs into Site A but not when a visitor logs into Site B. By default, 
events apply to all sites in your system. 

Examples: 

Logs in where Site is ATG Home 

Registers where Site is one of ATG Home, ATG Store Germany 

There are two parameters you can use to create site-specific scenario events: Where Site (shown in the 
examples above) and Where Site's. See the sections that follow for information on how to use each 
one. 

Only Web sites that have been registered in the Site Administration utility and deployed appear as 
options in scenario events. For more information on Site Administration, refer to the ATG Multisite 
Administration Guide. 

Using the Where Site Parameter 

Use the where Site parameter to specify one or more Web sites to which you want the event to apply. If 
you do not specify any sites, the event applies to all Web sites in your system. 

To pick one or more sites from a list, complete the following steps: 

1. Select where Site. 

2. Select an operator (for example is, is not, is one of). 

3. Select item. 
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4. Click No Items Specified and then click Choose Item (see the image below). The 

Site dialog box appears. 

5. Click List to show all the sites registered with Site Administration. 

6. Select the site you want. 

7. Click OK. 

 

 

Using the Where Site’s Parameter 

When you register a Web site with Site Administration, you provide values for a number of configuration 
properties that define the site and are stored in the Site repository. Examples include the site’s name, an 
opening date for when the site becomes active, and a status showing whether the site is currently 
enabled or disabled. The Site's parameter allows you to use these properties as triggers for firing the 
event. 

 

For information on each property, refer to the ATG Multisite Administration Guide. 

Using Condition Elements in Scenarios 
Condition elements follow and further qualify an Event element, essentially adding an “if” statement to it. 
The options that appear for the condition vary according to the event. 
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Element Use 

Event’s Uses properties of the associated ATG event to qualify the scenario Event element. See 
Using Event Elements in Scenarios for more information. 

Note that the Event’s condition contains a Site option. This option exists for 
environments that support more than one Web site. It allows you to qualify the event 
by site. See the description of the Visits event for an example. 

Variable Qualifies the event using a variable that you defined earlier in this segment. (You use 
Set Variable Action elements to define variables. See Using Action Elements in 
Scenarios for more information.) 

Request’s Qualifies the event using the contents or characteristics of the HTTP request issued to 
the ATG system by the visitor’s Web browser. 

Browser’s Qualifies the event according to a characteristic or setting of the site visitor’s Web 
browser. Example: 

Browser's supports cookies is true 

Locale’s Adds a locale-related qualification to the event. 

Locale-related elements are relevant if you are working on a Web site that displays 
content in different languages depending on the language setting in a visitor’s 
browser. For more information about localization and internationalization, refer to the 
ATG Programming Guide. 

Today’s Uses a specific date or time to qualify the event. Example: 

Today's dateAsDate is after Dec 1, 2001, 12:00 AM 

For more information, refer to the next section, Using the Today’s Condition. 

 

Using the Today’s Condition 

This section explains the choices available for the Today’s condition element in the scenario editor. The 
choices correspond to the properties of the CurrentDate Nucleus component 
(/atg/dynamo/service/CurrentDate). The Scenarios module uses the property values of this 
component to calculate whether to apply the condition to a given scenario. You can view this component 
and its current values if you have access to the Pages and Components area of the ATG Control Center. 
For information about viewing components, refer to the ATG Control Center online help. 

The properties that are most useful for business managers to specify within the Today’s condition are 
described below. 

 

Property Description Example 

date An integer that represents the day of the 
month (1 to 31) 

Today's date is 4 
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Property Description Example 

dateAsDate An integer that represents the date as a 
month, day, year, and time. This option is 
a good choice if you want to use a 
specific date to trigger the scenario 
element. The system time in this case is 
always considered to be 12:00:00 AM, and 
the scenario editor ignores any time you 
specify in the element. For example, if 
you include the following value in the 
scenario: 

Today's dateAsDate is Jan 10, 

2004, 9:00 AM 

the scenario editor translates the value to 
the following: 

Jan 10, 2004, 00:00:00 AM EST 

and triggers the condition element when 
the system’s dateAsDate is Jan 10, 2004, 
12:00:00 AM EST. 

Today's dateAsDate is 

Oct 4, 2003, 12:00:00 

AM EST 

dayOfWeek An integer that represents the day of the 
week (1 to 7, with 1 representing Sunday 
by default) 

Today's dayOfWeek is 5 

dayOfWeekInMonth An integer that represents the occurrence 
of the day of the week in the month (1 to 
5). For example, to specify the first 
occurrence of any weekday in the month, 
enter 1. 

Today's 

dayOfWeekInMonth is 1 

dayOfWeekName The full name of the day of the week Today's dayOfWeekName 

is Thursday 

hour An integer that represents the hour of the 
day (0 to 23, with 23 representing 11 PM) 

Today's hour is 16 

minute An integer that represents the minute of 
the hour (0 to 59) 

Today's minute is 30 

month An integer that represents the month of 
the year (1 to 12) 

Today's month is 10 

monthName The full name of the current month Today's monthName is 

October 

second An integer that represents the second of 
the minute (0 to 59) 

Today's second is 15 
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Property Description Example 

shortDayOfWeekName The abbreviated name of the day of the 
week (Sun, Mon, Tue, Wed, Thu, Fri, Sat) 

Today's 

shortDayOfWeekName is 

Thu 

shortMonthName The abbreviated name of the month (Jan, 
Feb, Mar, Apr, May, Jun, Jul, Aug, Sep, Oct, 
Nov, Dec) 

Today's shortMonthName 

is Oct 

weekOfMonth An integer that represents the week of 
the month (1 to 5) 

Today's weekOfMonth 1 

year The current year Today's year is 2004 

 

Specifying a Date or Time as a Condition 

Time elements (At, On, Between) allow you to specify a date or time that a scenario element should occur. 
For more information, see Using Time Elements in Scenarios. In addition, you can also include the date 
and time as qualifying conditions within some other scenario elements. The Today’s condition element, 
described in the previous section, is one example. Other examples of elements that can include time as 
conditions are as follows: 

People whose date of birth is before Jan 1, 1970 12:00 AM 

People whose registration date is after July 1, 2004 12:00 AM 

Note that, if you use “is” with a date and time expression, the value you specify must match exactly the 
value in the visitor’s profile. Consider the following example: 

People whose last activity is Jan 1, 2004 12:00 AM 

Here, only those visitors whose Last Activity property has an exact value of Jan 1, 2004 12:00:00 AM 
will be included in the scenario. 

Using relative dates with the expression “is” requires caution for the same reason. Consider the following: 

People whose registration date is 2 days ago 

Here, only those visitors whose registration date (including its millisecond value) exactly matches the date 
and time 48 hours ago will be included in the scenario. A better way to specify this relative date 
expression is as follows: 

People whose registration date is after 2 days ago and before 1 days ago 

It may be helpful to use the People and Organizations > Users window in the ATG Control Center to check 
that your date and time conditions will produce the results you expect. Use the date and time values you 
specified in the scenario as the List criteria at the top of the Users window; the profiles that are displayed 
when you click the List button, correspond to the registered visitors who will be included in this scenario. 
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If no profiles appear, you may have specified the values incorrectly. Change the List criteria to Items of 
Type User (Any Item) and examine the way the date and time are specified in the property you want 
to use in the scenario. 

Profile Marker Conditions 

The profile marker conditions determine whether the active profile contains markers that have the key, 
value, and data property values you specify. 

For more information on the conditions described in this section, see the Using Marked Profiles section in 
the Using Profile Markers chapter of the ATG Personalization Programming Guide. 

Profile Has a Marker 

The Profile has a Marker condition checks the active user profile for a marker that matches the 
criteria you provide. For example, you can configure the condition to check for profile markers that have 
the key, value or data values you specify in the Type a String text box. If you’d prefer to keep a broad 
scope, use the any value setting for a parameter, indicating that its value isn’t used to narrow the scope 
of the condition. Setting key, value, and data to any value at the same time causes the scenario to 
advance when any profile markers are present on the active profile. You can set value and data to NULL 
if you’d like the condition to check for markers that have no values for these properties. 

Profile’s Last Marker Has 

The Profile's last marker has condition checks the last marker added to the active user profile for 
the key, value, or data values you specify. To specify a particular value for one of these three properties, 
select Type a String and enter the value. You can set value or data to NULL in order to configure the 
condition to watch for profile markers that don’t have values for these properties. Keeping a property set 
to any value indicates that its value isn’t used to narrow the scope of the condition. 

Profile’s Last Marker With Key 

The Profile's last marker with key condition monitors the last marker added to the active user 
profile that has the key you specify. You must include a value for the key property, but you can also 
include a value for value and data properties by selecting Type a String and entering the value. 
Another option is to set the properties to NULL so that only markers that don’t have values for these 
properties cause the scenario to advance. Keeping an element set to any value indicates that its value 
isn’t used to narrow the scope of the condition. 

Business Process Stage Conditions 

You can also use condition elements that depend on an object’s stage in a business process. For more 
information, see the Defining and Tracking Business Processes chapter in the ATG Personalization 
Programming Guide. 

Has Reached Stage 

The Has Reached Stage condition tests whether a business object has reached a business process stage. 
Example: 
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Has Reached Stage with process name= ShoppingProcess and stage = Browsed 

Most Recent Stage Reached 

Tests whether the business process stage most recently reached matches the specified stage. Example: 

Most recent stage reached for process name= ShoppingProcess is 

stage = AddedToCart 

Using Action Elements in Scenarios 
This section describes the default Action elements you can insert into a scenario segment (see Creating a 
Scenario: Basic Steps). 

If your application developers have added any custom actions, these appear as additional options in the 
Action element in the Scenarios task area. For more information, see Adding Custom Events, Actions, and 
Conditions to Scenarios in the ATG Personalization Programming Guide. Additional options also appear if 
your product suite includes ATG Commerce. For more information on Commerce-related actions, refer to 
the ATG Commerce documentation. 

Note: Several of the action elements described in the following sections include a with Dynamo path… 
option (for example, Send email with Dynamo path…). This option exists mostly for backwards 
compatibility and replicates the way users specified document paths in earlier versions of the product. If 
you choose this option, you must type the fully qualified path, including the ATG document root or the 
J2EE context root, to the page you want to use. The alternative option, with path… (for example, Send 
email with path…), does not require you to type the path but instead allows you to select the page 
from a list. The ATG Control Center then prepends the appropriate path information automatically. 

Set Variable 

The Set Variable action defines a named variable that you can use to store or mark information 
temporarily in a scenario. For example, you could create a scenario that watches for people to buy 
products between 12 and 3 AM and then sets a variable called Late Night Shopper to “true.” You could 
then include a Record Audit Trail element that tracks the number of people whose Late Night Shopper 
variable is set to “true” and use the data you collect to create a report. 

Note that scenario variables apply only to the segment in which you set them; you cannot set a variable in 
one scenario and then use that same variable in another scenario to trigger an event. 

Variables can be any of the following types: 

 string – any characters you enter, for example “test” or “item purchased” 

 long – any integer you choose 

 double -- any number with a floating point value that you choose 

 flag – true or false 

 date – any month, date, and year that you specify 
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Send Notification 

The Send Notification action sends a specified e-mail message to a given recipient or group of recipients. 
It is designed for business situations in which you want to notify a person or group in response to an 
earlier event in the scenario. For example, you might want to notify your Sales department if a site visitor 
displays a page showing pricing information about a new product. By contrast, the Send E-mail action 
(described later in this chapter) is designed for situations in which you want to send a message as part of 
an e-mail campaign to a targeted group of site visitors. 

You can define the recipients of the Send Notification action as users (people with user profiles in the 
Profile repository) or e-mail addresses. Use the Send notification to people… option if the recipient 
is part of your system and has a profile; use the Send notification to address option if the recipient 
does not have a profile in your system. 

Examples: 

Send notification with path Example Corps Web App:/news/update.jsp to 

people Mary Garcia 

Send notification with path Example Corps Web App:/news/update.jsp to 

addresses esmith@example.com,swerner@example.com 

The profile associated with the message is by default the profile of the recipient. For that reason, any 
content in the message that uses a profile will refer to the recipient’s profile. For information on other 
options, refer to the ATG Personalization Programming Guide. 

If the action follows an event that is site aware (for example, Logs In or Registers), you can also specify 
a Web site so that the notification message can contain site-specific references. 

Registers where Site is MyStore > Send notification with path Example 

Corps Web App:/en/newMember.jsp to people Mary Garcia with site Event's 

Site 

In this example, the site specified in the Registers event, MyStore, is picked up by the Send Notification 
action (Event's Site is MyStore) and can be used to customize the content of the Send Notification 
message: 

“Alert: New member registered today at MyStore.” 

Page developers use the Pages and Components > Pages area of the ATG Control Center to create the 
text for the e-mail messages. For more information, see Working with Targeted E-Mail. 

For information on how to send an attachment with the e-mail message, see Sending Attachments with 
Scenario-Based E-Mail Messages in the ATG Personalization Programming Guide. 

Change 

The Change action changes a specified property in the visitor’s profile. 

Example: 
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Change Person's interests to skating 

You can also use this element to change any variables that you set earlier in the scenario. 

Disable Scenario 

The Disable Scenario action prevents any further processing of elements for the given scenario. All site 
visitors passing through the scenario when the element is triggered are removed from the scenario. The 
effect of this action element is the same as disabling a scenario manually through the File menu; for more 
information, refer to Disabling a Scenario. 

Example: 

 

If a scenario is disabled as a result of this action, the Last Modified By column in the Scenarios window 
shows “System” for this scenario. 

Redirect Page 

The Redirect Page action sends visitors to a different page on your site. 

Examples: 

Redirect to page with path Example Corps Web 

App:/errors/RegistrationError.jsp 

Note: When you add a Redirect action to a scenario, make sure that the action does not conflict with any 
other redirect activity that may be occurring on the site. For example, if you design a scenario that 
redirects users after a Login event, make sure your login pages do not perform their own redirect as well. 
Conflicting redirects could cause unexpected behavior to occur. 

Send Email 

The Send Email action sends a specified e-mail message to the visitors who have reached this point in the 
scenario. (See also the Send Notification action above.) 

Example: Send e-mail with path ATG Commerce Reference 

Store:/emailtemplates/newPassword.jsp 

Page developers use the Pages and Components > Pages area of the ATG Control Center to create the 
text for the e-mail messages. For more information, see Working with Targeted E-Mail. 

If the action follows an event that is site aware (for example, Logs In or Registers), you can also specify 
a Web site so that the e-mail message can contain site-specific references. Example: 
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Logs in where Site is ATG Home > Send e-mail with path ATG Commerce 

Reference Store:/emailtemplates/backInStockNotify.jsp with site 

Event's Site 

In this example, the site specified in the Logs In event, ATG Home, is picked up by the Send Email action 
(Event's Site is ATG Home) and can be used to customize the content of the e-mail message: 

“Welcome back! The item you backordered on ATG Home is ready to ship.” 

For information on how to send an attachment with the e-mail message, see Sending Attachments with 
Scenario-Based E-Mail Messages in the ATG Personalization Programming Guide. 

Add Items to Slot 

Use the Add Items to Slot action to display content (or any other repository) items in a given slot. Specify 
the slot to use and the items to show in it. Example: Add Items to Slot ProductSlot named 
Springtrak Shatterproof Helmet, Arribia Bike Shorts, Springtrak Insulated Water 

Bottle 

You can also specify an existing targeter instead of a list of content items. In this case, the system uses the 
criteria in the targeter to define the content items to display. 

In some cases you may be working in a multisite ATG environment (one in which a single installation of 
ATG products supports more than one Web site). Typically in such an environment, all sites contain the 
same pages (for example, all sites contain the same login page). A slot could therefore exist on all your 
Web sites. Make sure you configure the action so the slot displays content that is appropriate for each site. 

For more information, see Using Slots. 

Remove Items from Slot 

Use the Remove Items from Slot action to clear items that you previously included in a slot. For more 
information, see Using Slots. 

Example: Remove items from HomePageSlot named helmet.gif 

Record Event 

Use the Record Event action to track data for inclusion in reports. Allows you to track a scenario event or 
action and store information about it in a specified dataset. 

Example: Record event Logs In in dataset /logins.xml 

Record Audit Trail 

Use the Record Audit Trail action to track data that monitors scenario activities. See Recording Scenario 
Activity for more information. 
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Add Marker To Profile 

Use the AddMarkerToProfile action when you want to create a marker and attach it to the active user 
profile. When you use this action, you must specify a key, which will be the value saved to the marker’s 
key property. You can also provide values for the value and data properties or keep them empty (NULL). 

In addition, you need to indicate whether the marker you’re adding must be unique or if duplicate 
markers are permitted. If your application accepts unique markers only, you need to determine how new 
duplicate markers are handled: if a marker exists, should it be replaced by an identical new one or should 
the new one be discarded? The options available to you are allow duplicates, replace duplicates, and 
don’t add if there are duplicates. 

Remove All Markers From Profile 

Use the RemoveAllMarkersFromProfile action when you want to delete all markers from a particular 
property on the active user profile. 

Remove Markers From Profile 

Use the RemoveMarkersFromProfile action when you want to remove markers that have a particular 
key from the active user’s profile. You can further describe the markers you want to remove by specifying 
the values they must have for their value or data properties. For example, you can set this action to 
remove all markers that have key A, value B and data C from the active profile. You can also indicate 
that you want all markers that don’t have values set for value and data by setting them to NULL. If you’d 
rather not limit the markers you remove based on value and data values, keep these elements set to any 
value, indicating that their values aren’t used in determining marker removal. 

Add Stage Reached 

The Add Stage Reached action adds a business process stage to an item. You need to have defined the 
business process and its stages, as described in the Defining and Tracking Business Processes chapter in the 
ATG Personalization Programming Guide. Example: 

Add stage reached with process name = ShoppingProcess and 

stage = ShippingInfoComplete 

Note that you can instead use the AddBusinessProcessStage servlet bean to do the same thing in a 
page. 

Remove Stage(s) Reached 

The Remove Stage(s) Reached action removes a business process stage from an item. Example: 

Remove stage(s) reached with process name = ShoppingProcess and 

stage = ShippingInfoComplete 

You can also remove all stages from the item, as in this example: 
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Remove stage(s) reached with process name = ShoppingProcess 

and stage = any value 

Note that you can instead use the RemoveBusinessProcessStage servlet bean to do the same thing in a 
page. 

Using Fork Elements in Scenarios 
As described earlier, fork elements add parallel “if” conditions, allowing you to divide a scenario into 
separate branches and treat each branch differently. You add Fork elements to a scenario in the same way 
that you add other elements, but their extra features mean that you work with them a little differently. 

Adding Forks to a Scenario 

To add a fork to a scenario segment, click the diamond on the connector line where you want to position 
the fork, and select Fork from the menu. 

Alternatively, to add a fork around an existing element, drag the connector line before the element to the 
connector line after the element. A fork appears, with the existing element on one of the new branches. 

Adding Elements to a Fork 

To add elements to a fork, point the mouse at one of the branches so that a diamond appears on it. Click 
the diamond and select the appropriate option from the menu that appears: 
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Editing or Deleting a Fork Element 

To select a Fork element for editing or deleting, click its left side so that a gray line appears and the 
element turns yellow: 

 

Then change the element as necessary. To delete it, select Edit > Delete. 

Adding Branches to a Fork 

By default, all Fork elements have two branches. To add more branches, point the mouse at one of the 
existing branches so that a diamond appears on it. Click the diamond and then select Add Branch from 
the menu that appears. 

Alternatively, move the mouse to any empty area inside the Fork element so that a triangle with a dotted 
line appears. Click the triangle to add a new branch. 



A T G  P e r s o n a l i z a t i o n  G u i d e  f o r  B u s i n e s s  U s e r s  

 

1 4 0  

9  -  C r e a t i n g  S c e n a r i o s  

μ
Deleting Branches 

To delete a single branch, point the mouse at the left end of the branch so that a triangle appears on it, 
and right-click the triangle. Then select Delete from the menu that appears. (Note: Each Fork element 
must have at least two branches; if you perform this action in a fork that has only two branches, it deletes 
the whole fork and inserts any elements it contained into the main segment.) 

 

Requiring All Fork Branches to Succeed 

By default, only one branch of a fork has to succeed for the scenario to progress to the next element. Take 
a look at the following example: 

 

Any visitor who passes through the Logs In element enters both branches of the fork. If he or she then 
visits either page, the system applies the next element in the scenario. It does not wait for the person to 
visit the other page before continuing. 

In some situations, however, you might want to restrict the system from progressing beyond the fork until 
the elements on every branch have occurred. In the following example, a person must visit both pages 
before the system progresses to the next element: 
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Note that the positioning of the Visits elements in a fork rather than in a single line means that the person 
can visit the pages in either order. 

To force the system to wait for all elements in all branches of a fork to occur before progressing, do the 
following: 

1. Select the whole Fork element by clicking its left side. The left side turns blue and the 
fork turns yellow. 

2. Right-click the left side of the fork (the blue line) and select Require All Branches to 
Succeed from the menu that appears. Note that you cannot select this option if you 
have already selected Allow Only One Branch to Succeed. 

The system displays a blue circle at the right side of the Fork element to show that all elements in the fork 
must occur. 

Allowing Only One Branch to Succeed 

As explained in the previous section, any visitor who enters a fork enters all branches. As soon as a visitor 
completes one branch in the fork, he or she progresses to the next element in the scenario (the first 
element after the fork). However, it is important to note that the visitor is not prevented from completing 
the other branches; the system keeps waiting for him or her to do so for as long as the scenario is active. 
Consider the example below: 

 

A visitor logs in and enters both branches of the fork. She visits the page bargains.jhtml, and the 
system displays the specified content items in a slot on the page. Later in the same session the visitor 
visits the page whatsnew.jhtml, thus completing the second branch. The next element is triggered 
again, and the system displays the specified items in the slot. 

If necessary you can change this behavior so that only one branch in any fork can succeed. If a visitor 
completes the elements in one branch, he is automatically removed from the other branches. To use this 
feature, do the following: 

1. Select the whole Fork element by clicking its left side. The left side turns blue and the 
fork turns yellow. 
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2. Right-click the left side of the fork (the blue line) and select Allow Only One Branch to 

Succeed from the menu that appears. Note that you cannot select this option if you 
have already selected Require All Branches to Succeed. 

The system displays a blue circle at the beginning of each branch to show that only one branch can 
succeed. 

Using Otherwise Elements in Scenarios 

Otherwise elements are used only in forks. If you set up “if” elements for one or more branches in a fork, 
you can use the Otherwise element as an “else” statement to handle all visitors who do not meet the 
criteria of the other branches. 

Using an Otherwise element is optional, but it is highly recommended. If you do not include this element, 
site visitors who do not qualify for the other branches do not proceed to the next element in the scenario. 
However, the system does keep waiting for them to do so, which may have a negative effect on site 
performance. See Tips for Creating Efficient Scenarios for more information. 

The following example shows an Otherwise element: 

 

Here, the two Otherwise elements are followed by Stop elements. The effect is as follows: people who log 
in but are not in the profile group Investors are removed from the scenario. People who are in the group 
Investors but not in the group Women are also excluded from the scenario. 

Note that Otherwise elements are designed to work only in conjunction with Condition or People 
elements. Do not use them on the branch of a fork whose other branches start with Event elements. In the 
example above, you could not do the following: 

 

This use of an Otherwise element is invalid. If site visitors reach this stage in the scenario, the system will 
keep waiting for them to visit the specified page for as long as the scenario is active. It will not apply the 
Otherwise element to them if, for example, they visit a different page or log out of the site. 
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Adding Custom Elements to Scenarios 

If the Event, Action, or Condition elements that come with the system do not meet all your requirements, 
your application developers can create custom ones. Custom elements appear in the ATG Control Center 
and you can use them as you would use standard elements. 

Note that events, actions, and conditions are the only elements you can customize. The process for 
adding both is explained in Adding Custom Events, Actions, and Conditions to Scenarios in the ATG 
Programming Guide. 

Using Slots 
A slot is a Nucleus component that you can use to set up and display a series of personalized content 
items on one or more Web pages. (For more information on Nucleus, refer to the ATG Programming 
Guide.) As described earlier in this guide, it is possible to create and display personalized content through 
content targeters; however, slots provide some powerful features not available through targeters. 

 You can include slots in scenarios, giving you greater control over the circumstances in 
which they are displayed. For example, you can include Time elements in a scenario 
that change the slots after a specific period. Using scenarios, you can also set up a type 
of slot called an active slot that requests its own content according to criteria you 
specify. 

 With slots, the system can more efficiently cache the items that it shows, which makes 
displaying them faster. 

 Targeters can be used to display repository items only. Slots are often used to show 
repository items (such as images), but you can also use them to display any of the 
following: 

 Text strings 

 Dates 

 Numbers (Java types Long and Double) 

The type of item that a slot displays is determined by the developer who creates the 
slot component. Note, however, that a single slot can display only one type of item; for 
example, a slot cannot contain both a repository item and a date. 

Slot Basics 

In this example, your site includes a Login page called login.jsp. You decide to put a banner containing 
dynamic content on the Login page. 

The application developer creates the slot as a Nucleus component. He or she can do this in three ways: 
by writing a .properties file; by using the Component Editor in the ATG Control Center; or by using the 
Scenarios > Slots window in the ATG Control Center. This process is described in the Using Slot 
Components chapter in the ATG Personalization Programming Guide. 
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The page designer then uses a targeting servlet bean to display the slot component, adding it to the 
banner area of the login.jsp page. This process is described in the chapter Setting Up Targeting Services 
in the ATG Personalization Programming Guide. 

After the slot has been added to the appropriate site page, you use the ATG Control Center to create a 
scenario that does the following: 

 Defines the events that trigger the display of items in the slot. 

 Includes an Add Items to Slot element that specifies the content items you want to 
display and the slot you want to show them in. 

In this example, you set up a scenario that waits for visitors to access the Login page and then specifies 
three content items, X, Y, and Z, for display in a slot named ProductSlot. (Item X is perhaps an image 
containing a “Welcome!” message, and items Y and Z are images of two products that are currently on 
promotion.) 

 

When someone triggers the scenario by visiting the Login page, the scenario fills the slot named 
ProductSlot with content items X, Y, and Z. The slot component then displays the items in the slot, 
which the page developer has already added to the Login page. The system uses various methods and 
settings to define the order in which to show items and the number of items that appear at once. See 
How Content Is Displayed in Slots for more information. 

How Content is Displayed in Slots 

The slot component can display the specified items in different ways depending on how the application 
developer configures the component. For example, the slot can show items once each or in continuous 
rotation. You can specify the order of display or have the slot display its items randomly. You can also limit 
the number of items that can appear in the slot at any one time. The sections that follow describe some of 
these settings. For more information on other options that you can define for slots, refer to Using Slot 
Components in the ATG Personalization Programming Guide. 

Defining the Order of Display 

By default, if you do not specify the other ordering options, the system displays items in the order in 
which they arrive in the slot. 

When you create a scenario for a slot, you can use the At Priority option in the Add Items to Slot element 
to set an order for items from this scenario relative to items that come from other scenarios. For example, 
suppose you have two scenarios called Welcome and Login that contribute two items each to the same 
slot. You set the At Priority option to 1 for the Welcome scenario items and you set it to 2 for the Login 
scenario items. (1 is a lower priority value than 2 for items in slots.) 

A site visitor triggers the Welcome scenario first. It adds two items, A and B, to the slot. 
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The visitor then triggers the Login scenario, which also adds two items, C and D, to the same slot, but with 
a higher priority (2). 

When the visitor views the page containing the slot, the system displays items in this order: C, D, A, B. 

For information on finding and setting the At Priority option, refer to Creating a Scenario to Fill a Slot. 

The Ordering property in the slot component also changes the order in which items appear. The 
application developer defines this property when he or she sets up the component. For more information, 
see Using Slot Components in the ATG Personalization Programming Guide. 

Active or Passive Slots? 

One of the settings that the application developer defines when he or she creates the slot component is 
the event generation mode, which can be passive (the default) or active. 

When a site visitor views a page containing a passive slot, the slot displays any items that contributing 
scenarios have currently defined for it. The slot itself does not issue a request for content items. The 
model for passive slots can be summed up as follows: 

1. You create one or more contributing scenarios containing Add Item to Slot elements. 
These elements specify content items that will fill the passive slot in step 3. 

2. A visitor displays a page containing the slot. 

3. The slot displays the items that are currently defined for it. 

Active slot components, however, can act as scenario events, which allows them to issue their own 
requests for items. When a site visitor views a page containing an active slot, the slot triggers a scenario 
that tells the system which content items to display. The model for active slots looks like this: 

1. A visitor displays a page containing the active slot. 

2. The slot generates a scenario event, triggering one or more Add Item to Slot elements 
that fill it with items for display. 

This behavior means that an empty slot can fill itself with content on demand, which can have advantages 
for larger sites. For example, suppose you have 50 pages on which you want to display the same slot. With 
the passive model, you would have to specify each page as part of setting up the contributing scenario, or 
run the scenario for all pages in the site. With the active model, you do not have to specify pages because 
the slot requests its own items when any of those 50 pages is displayed. 

For information on creating an active slot, see Creating a Scenario for an Active Slot. 

Note for developers: The Passive setting in the slot .properties file corresponds to the “Never” 
option in the Slot Wizard. The Active setting corresponds to the “When empty” option. 

Creating a Scenario to Fill a Slot 

You create a slot scenario in the same way that you create other scenarios: define the circumstances in 
which you want the items in the slot to appear, and create scenario elements accordingly. 
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In the ATG Control Center, create a scenario. (Either use the Blank template to create this scenario from 
scratch, or use another template that you have designed specifically for this type of scenario.) 

1. Add the elements that correspond to the circumstances in which you want the slot to 
appear. 

2. Add the slot by creating an Action element and selecting Add Items to Slot as the 
option. 

 

Use the second option to specify the slot to which you want to add items. 

 

If the slot contains repository items (for example, images), a Named option appears, 
which you use to specify one or more repository items to add to the slot. These are the 
items that appear when the page is displayed. 

 

If the slot is designed to contain other types of item, for example dates, the option that 
appears is specific to that type. For dates, you can specify exact values (for example, 
May 5, 2004) or relative values (1 Week Ago). When the page is displayed, the slot 
shows the values you entered as exact dates. 
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Use the At Priority option to specify the order to show items in cases where there is 
more than one scenario contributing items to the slot. If you leave the priority option 
at the default setting (at default priority), the system shows items in the order 
in which the slot receives them. If you change the priority, the system shows the items 
in relative order. For example, items that you define as priority 2 appear before items 
at priority 1 from a different contributing scenario, regardless of the order in which the 
slot receives the items. 

Note that the slot component itself also contains settings that define the order in 
which the items are displayed. For more information, see Defining the Order of 
Display. 

 

If you have difficulty displaying the At Priority options, click the check mark to add the 
slot element to the scenario, then select it again by double-clicking it. Then you can 
activate each part of the slot element in turn by pressing either the spacebar or the 
right arrow key. When the highlight reaches the diamond, the At Priority options 
appear. 

3. Click the check mark to add the completed element to the scenario. 

 

Using a Targeter to Define the Content of a Slot 

In the procedure in the preceding section, step 2 shows how to specify the content items that appear in a 
slot. However, rather than specifying content items directly, you can include a reference to a content 
targeter instead. The system then uses the business rules in the targeter to define the items that appear in 
the slot. This feature allows you to add the more complex condition statements available through 
targeters to define your slot content. 

Note that you can use this option only with slots that contain repository items. 
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To use a targeter to define slot content, do the following: 

1. Set up the targeter you want to use. For more information, see Adding New Content 
Targeters. 

2. Create the scenario for the slot as described in the previous section. 

3. Select From Targeter as shown in the following image: 

 

Note that this option is available only if the slot element is preceded by an Event 
element that is associated with a system request, for example Logs In or Visits. 

4. Specify the targeter to use: 

 

Specify the priority if applicable. For more information, see Defining the Order of 
Display. 

Defining Multisite Content for Slots 

In some cases you may be working in a multisite ATG environment (one in which a single instance of ATG 
products supports more than one Web site). Typically in such an environment, all sites contain the same 
pages (for example, all sites contain the same login page). The page contains code that displays different 
content for each site. For this reason, when you set up a slot to show content, be aware that the same 
content may appear on all your Web sites unless the page or the slot is configured to restrict content to 
specific sites. 

One way to restrict the content is to use site-aware targeters to fill slots. Site-aware targeters can include 
overrides that display different content on each site. Note that only targeters created through the ATG 
Business Control Center support multisite features. You cannot create site-aware targeters through the 
ACC. For information on creating targeters, refer to the ATG Business Control Center User’s Guide. 
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After you have created a site-aware targeter that has appropriate rules for each site, you can use it to a fill 
a slot by following the procedure in the previous section, Using a Targeter to Define the Content of a Slot. 
Select the site-aware targeter and then specify the site whose override rule you want to use, as shown: 

Logs in where Site is ATG Home > Add Items to Slot Named MySlot from 

Targeter MySiteAwareTargeter > with Site Event's Site 

In this example, the site specified in the Logs In event (ATG Home) is picked up by the Add Items to Slot 
action (Event's Site is ATG Home). The override rule added for ATG Home to the site-aware targeter is 
used to display content in the slot. The following example also works: 

Logs in > Add Items to Slot Named MySlot from Targeter 

MySiteAwareTargeter > with Site ATG Home 

In this example, however, content specified by the override rule for ATG Home is displayed in the slot 
regardless of the site where the visitor logged in. 

For information on creating multisite targeters, refer to the ATG Business Control Center User’s Guide. For 
information on configuring a multisite environment, see the ATG Multisite Administration Guide. 

Defining a Temporary Slot from an Event Element 

As an alternative to defining slots as Nucleus components, application developers can send them as 
properties of the JMS messages that control scenario event elements. This method provides flexibility 
because it allows developers to create slots on demand rather than having to register them first in 
Nucleus. (For more information, refer to ATG Personalization Programming Guide.) These slots are, 
however, temporary, and they cannot be persisted across visitor sessions. In addition, you cannot use this 
method for slots that contain repository items; you can use it only for slots that contain text strings, dates, 
or the Java number types Long and Double. 

To set up a slot this way, perform the following steps: 

1. Add the event element that contains the slot you want to fill. 

2. Immediately after the event element, insert an Add Items to Slot element. Click the 
word Named to display a pop-up menu, and select the option Given by Event’s. 

3. Use the options that appear after Given by Event’s to specify the content you want to 
display. For example, if the content of the slot is a date value, select With Date Values 
and then specify the dates. See Creating a Scenario to Fill a Slot for more information. 

Slots that are created as part of event elements do not appear in the Slots window in the ACC. 

You can also use event elements to define the Remove Items from Slot element. See Creating an Element 
to Remove a Slot for more information on this element. 

Creating a Scenario for an Active Slot 

As described earlier, slot components have an event generation setting that determines whether a slot is 
passive (the default) or active. For more information, see Active or Passive Slots?. To create a scenario that 
uses an active slot to request content, do the following: 
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1. Have an application developer create a component for the slot you want to use. Make 

sure that he or she specifies active as the event generation mode for this slot. (In the 
Slot Wizard, the option to choose is When Empty.) 

2. Create a segment (see Creating a Scenario: Basic Steps). 

3. Add an Event element, and select Items Requested from the list of events. 

4. Specify the slot you want to use as the active slot. 

 

5. Insert an Add Items to Slot element (an Action element). In this element, you select the 
same slot that you specified in step 4, and then you define the content items you want 
to appear. 

 

6. Specify the priority if applicable. For more information, see Defining the Order of 
Display. 

For more information on active slots, see Active or Passive Slots? 

Creating an Element to Remove a Slot 

You can also set up an Action element that removes specific content from a slot or clears a slot 
completely. This feature is most useful for slots with a rotating item retrieval mode; for destructive slots, 
the system removes items automatically. 

To remove contents from a slot, do the following: 

1. Add an Action element to a scenario and select Remove Items from Slot as the option. 

2. Specify the slot from which you want to remove content items. 

3. The next part of the element contains three options as shown: 

 

Use the Named option to specify the item or items you want to remove. 



A T G  P e r s o n a l i z a t i o n  G u i d e  f o r  B u s i n e s s  U s e r s  

 

1 5 1  

9  -  C r e a t i n g  S c e n a r i o s  

μ
Or: Use the From Targeter option to remove content defined by a specific targeter. 

Or: Use the All Items option to clear the slot completely. 

4. If you chose Named, specify the item or items to remove. If you chose From Targeter, 
specify the targeter whose content you want to remove. 

The finished element looks as follows: 

 

Note that you can also use a preceding event element to define the slot contents to remove; for more 
information, see Defining a Temporary Slot from an Event Element. 

Specifying the End of a Scenario 
You are not required to use any specific elements to define the end of a scenario. The Scenarios module 
keeps track of each visitor’s progress through a scenario, and after the final element in a scenario is 
complete for a specific visitor, the scenario is considered to be over for him or her, unless repeat behavior 
is enabled for this scenario and the visitor triggers the scenario again. 

However, it is important to be aware that scenarios do not stop automatically when a visitor’s site session 
ends. Take a look at the following example, which shows part of a possible scenario: 

 

In this example, the system waits for a visitor to log into the site, and then waits for him or her to view a 
page from a specific folder. However, if a visitor logs in but does not complete the next element, and then 
subsequently leaves the site, the system does not stop waiting for him to view one of the given pages and 
will keep waiting for an infinite amount of time. This behavior does not necessarily have any adverse 
effects, but if your site has many visitors and you create a large number of scenarios in this way, it may 
cause performance to slow down. It is also probably not the behavior you wanted; you may have 
expected the system to exclude from the rest of the scenario any visitors who leave the site. 

To avoid this problem, include an element that recognizes when a visitor leaves the site: 
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In this example, the system waits for the visitor to view the given page or to end his session, and then 
continues to the next element. Visitors whose sessions end are eliminated from the rest of the scenario. 

If you want to explicitly prevent a visitor from progressing through a scenario if he or she meets given 
criteria, you can add a Stop element. This elements works the same way as the Stop elements in 
workflows. For an example, refer to Using Stop Elements in Workflows. 

If you want to force a scenario to end for all visitors if certain circumstances occur, you can include a 
Disable Scenario element. For more information, see Using Action Elements in Scenarios. 

Note that the list of event elements in the scenario editor does include an event called Scenario Ends, 
which is exposed in the editor as part of the back-end operation of the Disable Scenario action. It is fired 
automatically when a scenario is deleted or disabled; you do not have to add this element to a scenario to 
indicate that the scenario has finished. For more information on this event, refer to the ATG 
Personalization Programming Guide. 

Refer to Designing Effective Scenarios in the ATG Personalization Programming Guide for more information 
on efficient ways to both create and terminate a scenario. 

Recording Scenario Activity 
For the purposes of managing your company’s relationship with its site visitors, it is useful to be able to 
track what happens as a result of the elements within a scenario. For example, if you set up a scenario that 
sends a promotional e-mail to new members offering them a discount on a product, it is helpful to keep a 
record of the members to whom the e-mail is sent. Information such as this can help you monitor the 
success of your promotions, and it also allows you to provide better customer service. 

You can track anything that happens in a scenario through recorder elements, which you insert at specific 
points in the scenario. Recorder elements collect data you can use to create reports. The Scenarios 
module comes with a predefined recorder element called an Audit Trail that you can use to keep a simple 
record of what happens in a scenario. 

The Audit Trail (which is a type of Action element) works as follows: When you create a scenario, you 
insert an Audit Trail element after scenario elements that you think are significant and that you want to 
track. When a site visitor triggers that element in the scenario, the system records information that 
includes the following: 
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 A description of the activity, for example, “Sent Mountain Bike Promotional E-Mail.” 

You specify the description yourself in the Label option of the element – see Creating 
an Audit Trail. 

 The date and time of the activity. 

 The profile ID of the site visitor who triggered the element. 

The system records this information in a predefined dataset called Audit Trail. The data can then be 
included in a report. 

Creating an Audit Trail 

To insert an Audit Trail element in a scenario, do the following: 

1. After an element that you want to record, add an Action element, and select Record 
Audit Trail from the list of available elements. 

2. In the With Label field, type the description of the activity as you want it to appear in 
the report. 

3. Click the checkmark at the end of the element to add it to the scenario. 

The following image shows an Audit Trail element in a scenario: 

 

You can add as many Audit Trail elements to a scenario as you need. Make sure that each label is unique. 

Enabling and Disabling Scenarios 
The system does not put scenarios into effect automatically. This behavior allows you to activate scenarios 
only when you are ready for them to begin. At the appropriate time, do the following: 

1. In the Scenario task window, right-click the name of the scenario you want to enable. 

2. Select Enable Scenario from the pop-up menu. 

(Alternatively, you can open the scenario for editing, and then select File > Enable 
Scenario.) 

The system displays a red dot next to the scenario name (see the WelcomeMail 
scenario in the example below) to show that you have marked it as active. 
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If the scenario contains any invalid or incomplete elements, an error message appears 
when you try to enable the scenario. Edit the elements as indicated, and then try 
enabling the scenario again. 

3. Copy the appropriate scenario file to the production server for your live site. 

4. Update the scenario server with the new information. 

Important: The scenario is not active until you complete steps 3 and 4. For more 
information, see Copying and Switching Databases in the ATG Installation and 
Configuration Guide. 

Notes: Many scenarios contain Time elements that also affect when a scenario begins. For example, if 
your scenario includes an On element that tells the scenario to begin on a specific date, you can enable 
the scenario before that, but it will not take effect until then. 

You can enable a scenario only if your copy of the ATG Control Center is connected to the scenario editor 
server. See Configuring Scenarios in the ATG Personalization Programming Guide for more information on 
the differences between global, individual, and scenario editor servers. 

Changing an Enabled Scenario 

If you have already enabled a scenario, changing it may cause the Scenarios module to lose information 
about any site visitors who are currently progressing through the scenario. For example, assume you have 
enabled a simple scenario with one segment that watches for visitors in a given profile group to log in, 
waits two weeks, and then sends them an e-mail reminding them to log in again. A site visitor called Jim, 
who belongs to the specified profile group, logs in on Monday. The next day, you decide to make some 
changes to the scenario. Depending on the nature of the changes you make, the Scenarios module may 
be unable to “move” Jim from the old version of the scenario to the new one. Its knowledge of Jim’s 
current position in the scenario (his scenario state) may be lost, and Jim may be removed from the 
scenario before he has progressed to the end. 

When you make a change to an enabled scenario segment, you can check to see whether the type of 
changes you have made will cause the system to remove any visitors who are currently progressing 
through it. 

1. Make your changes to the segment as required. 

2. Click the first element in the segment (the name element) so that it is active. 

3. Select File > Verify Changes. 
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If the changes you have made will cause visitors to be removed from the segment, the 
system displays the following message: 

“Data for the current participants will be discarded if the current changes are saved.” 

If the changes will not require the system to remove anyone from the segment, the 
following message appears instead: 

 “Data for the current participants will be preserved if the current changes are saved.” 

In both cases, “data” here means information about the visitor’s position in the 
scenario. No other information or data is affected. 

In general terms, changes that you make to a scenario can be classed as either “topographical” or 
“cosmetic.” Topographical changes are those that involve making major changes to the structure of a 
segment, for example by adding or removing new elements, in particular forks, branches, and “Waits” 
elements to the beginning or middle of a segment. (However, adding a new element to the end of a 
segment does not disturb the topography of a scenario and does not cause visitors to be removed from 
it.) 

Cosmetic changes usually involve changing only the details of a specific element. For example, if a 
segment includes a Visits element and you change only the name of the specific page within that 
element, you have made a cosmetic change. 

Usually, topographical changes require the system to remove visitors from scenario segments, but 
cosmetic changes do not. 

Notes: When you use the Verify Changes option, the system does not check whether any site visitors are, 
in fact, currently progressing through the scenario. It simply verifies the type of changes you are planning 
and alerts you to their possible effect. 

The system performs the same check when you attempt to save changes to an enabled segment, 
regardless of whether you have used the Verify Changes option. If your changes require the removal of 
site visitors, the system displays the following message: “Data for the current participants will be 
discarded and the scenario will be restarted. Proceed?” 

Only information about the visitor’s scenario state is lost. If the system has already made changes to the 
profile database as a result of the scenario elements through which visitors have already passed, it keeps 
these changes. For example, assume you have a scenario segment that performs content targeting by 
watching for visitors to visit a given page, updating a profile property called “Confidence Index,” and then 
displaying appropriate content on the site’s home page. If you make a major topographical change to this 
segment (for example, you add a fork), the system will remove any visitors who are currently moving 
through this segment. However, if any visitor has progressed past the element that changes his or her 
profile property, the change is not lost when the visitor is removed. 

The Verify Changes feature does give you some valuable information about the effects of your changes to 
a given scenario segment. However, it is still very important to take care when you edit an enabled 
scenario, and to minimize this activity whenever possible. Visitors whose scenario state is lost can 
progress through the scenario again if they meet the criteria that trigger the scenario’s elements. This 
behavior may have undesirable results; for example, if you use ATG Commerce and you have a scenario 
that e-mails discount coupons to site visitors who perform specific actions, you may accidentally send the 
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coupon twice to the same visitor. In addition, any data that you collect for reports may be distorted if you 
accidentally allow visitors to pass through a scenario twice. 

Disabling a Scenario 

To stop a scenario that is currently active, do the following: 

1. In the Scenario task window, right-click the name of the scenario you want to disable. 

2. Select Disable Scenario from the pop-up menu. 

3. (Alternatively, you can open the scenario for editing, and then select File > Disable 
Scenario.) 

The system displays the following message: “Disable scenario and discard data for 
current participants?” Note that this message does not necessarily indicate that any 
visitors are currently progressing through the scenario. It simply reminds you that the 
system will subsequently lose scenario state information for any visitors who are. For 
more information, see Changing an Enabled Scenario. 

If you click Yes, the system removes the red dot from the display to show that you 
have marked the scenario as disabled. 

4. Copy the appropriate scenario file to the production server for your live site. 

5. Update the scenario server with the new information. 

Important: The scenario is not disabled until you complete steps 4 and 5. For more 
information, see Copying and Switching Databases in the ATG Installation and 
Configuration Guide. 

Organizing and Viewing Scenarios 
By default, the ATG Control Center organizes and displays scenarios according to the folder in which they 
are located. You can change this setting, however, and display scenarios according to criteria such as a 
scenario’s contents or creation date. This feature can be extremely useful if you have large numbers of 
scenarios to track and maintain. For example, suppose the page developers working on your site renamed 
one of its pages from Welcome.jsp to 2002_Welcome.jsp. You would have to find and update every 
scenario that uses this page so that your campaigns would work as planned. Using this feature, you could 
choose to display scenarios according to the site pages they reference, and then look for any that include 
Welcome.jsp. 

To change the way in which the ATG Control Center displays scenarios, use the By Folders dropdown list 
in the top left corner of the main scenario window. 
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Use the options in this list as follows: 

 

Option Organizes scenarios according to… 

By Profile Groups The profile groups that are referenced by the People elements within each 
scenario. 

By Profile Properties The profile properties that are referenced by any elements within each 
scenario. 

By Slots The slots that are referenced by the Add Items to Slot, Remove Items from 
Slot, or Items Requested by Slot elements within each scenario. 

By Actions The actions that the scenarios contain. 

By Events The events that the scenarios contain. 

By Dates Any absolute dates or ranges of absolute dates that the scenarios contain. 
For example, dates referred to by an On or Between time element would 
qualify, but a date included as a property of an event (People whose Date of 
Birth is January 1) would not. 

By Authors The ATG Control Center users who created the scenarios. 

By Creation Dates The dates on which the scenarios were created in the ATG Control Center. 

By Last Modified The dates on which the scenarios were last edited in the ATG Control Center. 

By E-Mail Templates The e-mail templates (JHTML or JSP files) referenced by any Send E-Mail or 
Send Notification elements within each scenario. 

By Pages The Web site pages referenced by any Visits or Redirect To elements within 
each scenario. 

 

Note that this feature works for entire scenarios rather than for individual segments within a scenario. 

Creating Templates for Scenarios 
Templates are useful for scenarios that you or another business manager will create often. For example, if 
you regularly run the same type of promotion for your e-commerce site – you plan monthly promotions 
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in which the start date and the products on sale change each time, but other elements such as the target 
group of users stay the same – you can create a template, and then use it as a quick, reliable way to carry 
out similar promotions at appropriate times. Another example might be a seasonal promotion that you 
run with very few changes every year (for example, a promotion for Mother’s Day). By creating a template 
for the promotional scenario, you can save time and effort because you will not have to recreate it each 
year. A template based on a successful, well tested scenario also helps you avoid errors. 

Note: The ATG system administrator uses the People and Organizations > Control Center Groups window 
to determine whether you have access to the Scenario Templates menu item. In addition, the 
administrator can control access to specific templates through the Security menu at the top of the 
Scenario Templates window. For more information, refer to Security Access in Scenarios. 

To create a template: 

1. In the ATG Control Center, select Scenarios > Scenario Templates. The Scenario 
Template window appears, as shown below: 

 

2. Select File > New Scenario Template. The New Scenario Template dialog box appears. 

3. Specify a name for the new template. 

4. Click OK. The system displays the first element of a new scenario segment, as follows: 
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5. Add the elements that you need for the template. For information on how to do this, 
see Creating a Scenario: Basic Steps. When you add an element that you want to be a 
placeholder in the template, do the following: 

 Display the menu that shows the possible options for each element item. See 
the following example: 

 

 Check the Placeholder option. 

Note: If this option does not appear, the element you are editing is not one that 
you can use as a placeholder. 

When you check the Placeholder option, the system displays a blank field 
underneath it. In this field, enter the text that you want people who use this 
template to see for this placeholder. The text appears as a field label in the 
Define New Scenario dialog box. 
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Important: Because of the nature of the Define New Scenario dialog box, users 
rely on the text you specify here to understand the purpose of each element in 
your template. For this reason, make sure you enter text that is as descriptive 
and clear as possible. For more information on the Define New Scenario dialog 
box, see Creating a Scenario from a Template. 

 

In the Scenario Template editor, placeholders appear within parentheses: 

 

6. When you have finished adding elements and placeholders, select File > Save Scenario 
Template. The new template is ready to use. 

An example of a scenario template, the QFScheduledMailing template from the Quincy Funds demo, is 
shown below 

 

Creating a Scenario from a Template 
The example in Creating a Scenario: Basic Steps showed how to create a scenario from scratch. However, 
you can also use a template as a quick way to create a scenario. 

To create a scenario from a template: 

1. In the ATG Control Center, select Scenarios > Scenarios. 
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2. Select File > New Scenario. The Use Scenario Template? dialog box appears. Click Yes 

and then click Next. 

3. The Choose Scenario Template dialog box appears. 

4. Select the template you want to use. See Creating Templates for Scenarios for more 
information. 

5. Click Next. The Choose Scenario Name dialog box appears. 

6. Specify a name for the scenario you are about to create. Also specify the folder in 
which you want to save it. 

7. Click Finish. 

The system displays the Define New Scenario dialog box, which contains fields that 
correspond to the elements in the template. Each field shows a placeholder value that 
represents an element you can change each time you use this template. Templates 
usually contain other elements that do not change; these do not appear here. 

The dialog box that corresponds to the Quincy Funds QFScheduledMailing template 
looks like this: 

 

Note: Because you see only some of the elements in the template, it can be difficult to 
understand what the associated scenario does by looking at this dialog box. You can 
overcome this problem in several ways: 

 Use the Scenario Template editor to view the template and see what it does. 
However, you can do this only if your security access level allows you to create 
and edit templates. 
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 Ask the person who created the template to print a copy of it for you (see 

Printing Scenarios). 

 Alternatively, just click OK here without changing any values. The scenario 
appears in the Scenario Editor with all the elements set to their default values. 
You can then review the scenario to see what it does, and edit the elements as 
you would edit any other scenario. 

8. Edit the fields by replacing the placeholder values with the real values that you need. 
To edit the fields, click each placeholder and then select the value you want from the 
list that appears. 

9. When you have finished editing, click OK. The completed scenario appears across the 
window. 

Printing Scenarios 
To print a scenario or a scenario template: 

1. Display the scenario or scenario template in the editing window. 

2. Select File > Print. A dialog box appears, prompting you to choose whether to have 
the system scale the scenario to fit the page or print it full size (on multiple pages if 
necessary). The page size and orientation are the ones you have currently selected for 
your printer. Select Scale to Fit Page unless the scenario is so short that you are sure it 
will fit on the page. 

3. Click OK. A standard print dialog box appears, allowing you to print the scenario or 
template to the specified printer. 

The system prints all segments of the scenario or template you selected. 

You can also choose to save a scenario or a scenario template in JPEG format for use as an image in 
another application. To do so, select File > Save as JPEG and then specify a name and location for the file. 

Using Scenarios to Track Visitor Behavior 
The chapter Tracking Visitor Behavior describes the process of monitoring the activities of your Web site 
visitors and using that information to update their profiles. It explains that you perform this task in 
different ways depending on the components of your ATG product suite. 

If you use the Scenarios module, you use scenarios to track visitor behavior and update profiles. This 
section includes some sample scenarios that show how to do this. 

Tracking Items that a Visitor Displays: Example 1 

The first example shows how a We site tracks the items that a visitor views: 
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For this site, each visitor profile has a property called Products Viewed Recently that contains a list of IDs 
corresponding to the products that the visitor views. The scenario watches for a visitor to view any 
product from the catalog, and then updates his or her profile by adding the product’s ID (its repository ID) 
to the list in the Products Viewed Recently property. It uses an Action element, Change, to update the 
profile. 

The site’s application developers can then use the new value in the property as a way to personalize 
content. For example, they could perform cross selling by setting up a slot that shows helmets by a given 
manufacturer to anyone whose Products Viewed Recently list contains one of that manufacturer’s bikes. 

Tracking Items that a Visitor Displays: Example 2 

The second example shows how a Web site tracks the price range of items that a visitor views and then 
updates the profile with that information: 

 

The scenario watches for a visitor to view any product from the product catalog. Each item in the catalog 
has a Price Range property, for example CHEAP. Each visitor’s profile has a property called Price 
Preference, which is a positive or negative number. The scenario contains a fork with Condition elements 
that tell the system to monitor the Price Range property of the items that visitor displays and adjust his or 
her Price Preference property accordingly. 

The site can then use the Price Preference property to personalize the content that each visitor sees in the 
future. For example, it could offer promotions specifically tailored to anyone whose Price Preference 
property is more than 5. 

Tracking Searches 

The next example shows how a Web site can monitor a visitor’s catalog searches: 
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This segment of the scenario watches for a site visitor to enter text into a search field for the store’s 
product catalog. For this site, each visitor profile has a property called Person’s Recent User Searches that 
contains a list of the words that a visitor has entered in a search field. When the scenario senses that a 
visitor has performed a search, it adds the text to the list. Again, the site can then use this information to 
personalize content. For example, it could be used it to set up a one-click Search feature so that visitors 
can keep track of and repeat recent site searches. 

Note: In the examples shown above, the visitor profile contains custom properties that were added for 
demonstration purposes. The properties you can use to track visitor behavior depend on your site’s 
profile repository. 

Using the Scenario Values Profile Property 

As explained earlier in this chapter, you can use scenario elements, specifically the Change element, to 
update any property in your profile repository. The profile repository, however, also contains a property 
called Scenario Values that your application developers can set up to store any additional information 
about each visitor that you gather from scenarios – perhaps information that is valuable but of only 
occasional importance. The property can store more than one value at a time. In this case, the values are 
called “keys,” and when you use the Scenario Values property in a scenario, the ATG Control Center 
prompts you to specify the key to change. 

Example: You decide that, for a few months, you will keep track of visitors who come to your site between 
the hours of 2:00 AM and 5:00 AM. Your application developers set up the Scenario Values profile 
property so that one of its keys is latevisitor and the possible values for this key are true and false. 
You create the following scenario: 

 

This scenario watches for people to log into the site between the specified times, and then it changes the 
latevisitor key in the Scenario Values property to true. You can now use this value to personalize site 
content _in the same way that you would use any other profile property – for example, you can use it as a 
way to filter site visitors in another scenario or in a content targeter. 

Note also that the Scenarios module includes a scenario element called Set Variable that you can use to 
track any type of information you want for the duration of a single scenario segment only. See Using 
Action Elements in Scenarios for more information. 
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Moving or Renaming Scenarios 

Follow these steps to rename an existing scenario or move it to another folder. 

1. Display the list of existing scenarios in the Scenarios window. 

2. Select the scenario you want to move or rename. (To select one without opening it, 
click its entry in any column except the Name column.) 

3. Select File > Move/Rename Scenario. (Note: You cannot move or rename a scenario 
that is currently open in the ATG Control Center. To close the scenario, navigate to it 
by using the arrow buttons in the toolbar, and then select File > Close.) 

The Rename Scenario dialog box appears. 

4. To move the scenario to a different folder, select the destination folder from the list at 
the top of the dialog box. To rename the scenario, type the new name (do not include 
spaces). 

5. Click OK. 

Tips for Creating Efficient Scenarios 
The Designing Effective Scenarios chapter in the ATG Personalization Programming Guide contains 
important information on the best way to design scenarios so that site performance is as efficient as 
possible. It is highly recommended that you read this chapter before creating large numbers of scenarios 
for your Web site. 
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10 Working with Targeted E-Mail 

As part of your promotional campaigns or your plans to build long-term customer relationships, you can 
set up and send targeted e-mails – e-mails whose content is personalized for each recipient. The following 
example shows an e-mail message that has personalized content, highlighted here in italics: 

To: mjones@example.com 

From: customerservice@pioneerbikes.com 

Subject: Order Confirmation 

 

Dear Michelle Jones, 

 

Thank you for your order. We shipped it today to: 

430 Chestnut Street 

Orpington, MA 12345 

 

May we suggest ordering these great products to complement your Arribia cycling 

gloves? 

 

Arribia bike shorts 

Springtrak insulated water bottle 

Springtrak shatterproof helmet 

 

Thank you for shopping with us! 

Sincerely, 

Customer Service 

Pioneer Bike Store 

Creating a Targeted E-Mail Message 
For every type of e-mail you want to send, the page developers working on your site create a JHTML or 
JSP template file that contains the body of the message. They include both the standard content (the text 
that is the same for every recipient) and the code elements that ATG uses to generate the personalized 
content. 

The following example shows how the corresponding JSP file might look for the e-mail message above. 
Again, for the purposes of illustration, the code that produces the personalized content is shown in italic 
type: 
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<%@ taglib uri="/dspTaglib" prefix="dsp" %> 

<%@ page import="atg.servlet.*"%> 

<dsp:page> 

 

 

<html> 

 

<dsp:setvalue value="customerservice@pioneerbikes.com" param="messageFrom"/> 

<dsp:setvalue value="Order Confirmation" param="messageSubject"/> 

 

<dsp:importbean bean="/atg/userprofiling/Profile"/> 

 

<p>Dear <dsp:valueof bean="Profile.firstName"/> 

<dsp:valueof bean="Profile.lastName"/>, 

 

<p>Thank you for your order. We shipped it today to:<br> 

<dsp:valueof bean="Profile.address"/><br> 

<dsp:valueof bean="Profile.city"/>, <dsp:valueof bean="Profile.State"/> 

<dsp:valueof bean="Profile.zipCode"/> 

 

<p>May we suggest ordering these great products to complement your 

<dsp:valueof bean="Profile.lastProductShipped"/>? 

 

<p><dsp:droplet name="/atg/targeting/TargetingForEach"> 

<dsp:param bean="/targeters/crossellTargeter" name="targeter"/> 

<dsp:oparam name="output"> 

<dsp:valueof param="element.name"/><br> 

</dsp:oparam> 

</dsp:droplet> 

 

<p>Thank you for shopping with us!<br> 

Sincerely,<br> 

Customer Service<br> 

Pioneer Bike Store 

 

</html> 

 

</BODY> 

</HTML> 

 

</dsp:page> 

Note for page developers: In the e-mail template, you can include references to the message bean 
representing the scenario event that causes the system to send the e-mail. Consider the following 
example: 
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In the body of the welcome.jsp e-mail, you can reference the properties of the Visits Page message, for 
example: 

<dsp:valueof param="message.path"/> 

This example would display the value of the message’s path property, which in this case is /login.jsp. 
For more information on how the Scenarios module uses message beans, refer to Using Scenario Events in 
the ATG Personalization Programming Guide. 

How the ATG System Uses the E-Mail Template 
Many of the code elements in the e-mail template (the JHTML or JSP file that contains the body of the 
message) refer to visitor profiles in your profile repository. For example, the JSP code <dsp:valueof 
bean="Profile.firstName"/> refers to the firstName property of the visitor profile – in other words, 
to the first name that you have stored for each visitor. For each person to whom you send the message, 
the ATG system checks the current value in that property (in this case, “Michelle”) and inserts that value 
into the appropriate place in the text of the message. It performs this process for every code element in 
the file. 

As another example, the code <dsp:valueof param="element.name/"> refers to a set of catalog 
products that your application developer has included in a targeting servlet bean called 
crossellTargeter. When it produces the message, the system checks the targeting servlet bean and 
inserts the element.name values specified by the bean (in this case, “Arribia bike shorts,” “Springtrak 
insulated water bottle,” and “Springtrak shatterproof helmet”) into the appropriate place in the text of the 
message. 

In this way, the system builds an e-mail message that is different for every recipient. 

Note that the example shown above uses setvalue parameters for the “Subject” and “From” fields in the 
e-mail. Using this feature means that even these fields can change according to the recipient. You could 
change the Subject field so that, instead of just stating “Order Confirmation,” it includes the name of the 
product that each recipient has ordered, for example “Order Confirmation: Arribia Cycling Gloves.” In 
addition, by changing the subject line, you could use one template file for different purposes, saving 
development time. This feature makes the e-mail template highly flexible. 

For information on different methods for defining the “Subject” and “From” fields, please refer to the 
targeted e-mail chapter in the ATG Personalization Programming Guide. 
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Addressing and Sending the Message 

The ATG system does not use the e-mail template to determine who will receive the e-mail to which the 
file corresponds. Instead, it determines recipients (and addresses the message) using one of the following 
methods. 

Using a Scenario to Address and Send a Message 

You can create a scenario that includes a Send E-Mail element as well as one or more elements that define 
the recipients of the specified e-mail. The following example shows a simple scenario that sends a 
message to people in a specific profile group: 

 

This scenario tells the system to send the message contained in the file NewYearPromo.jsp to all the 
members of the profile group “investors” on January 1, 2001. Visitors’ e-mail addresses are stored in their 
profiles, so the system checks the address for each person and uses it to send each message. 

For detailed information on setting up scenarios, see Creating Scenarios. 

Using Other Methods to Address and Send a Message 

As an alternative to using a scenario, your developers can use a targeting service to create a list of 
recipients for the message. They can base the list on specific properties in a visitor profile (for example, 
they can include anyone whose gender property is female), or they can base the list on profile groups 
(for example, they can include all members of a group called NewMembers). After the list is set up, 
developers use ATG’s TemplateEmailSender service to send the message. For more information on 
both these steps, see the targeted e-mail chapter of the ATG Personalization Programming Guide. 

Configuring the ATG Platform to Send E-Mail Messages 

Note that the application developers working on your site must configure the ATG platform so that your 
site can send and receive e-mail messages. For information, please refer to the E-Mail Sender section of the 
ATG Personalization Programming Guide. 

Setting Up a Cold Call E-Mail Campaign 
As part of an initiative to increase your customer base, you might want to set up a “cold call” e-mail 
campaign during which you do the following: 

 Send a set of promotional offers to a list of e-mail addresses. 

 Keep track of the offers you have sent to each address. 
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 Include URLs in the e-mail that take customers to a special registration form – one that 

allows you to preserve the tracking information that you have previously recorded for 
that e-mail address. 

Your application developers could set up this type of campaign in various ways. One possible approach is 
as follows: 

1. Create profile items in the visitor profile repository for each e-mail address on the cold 
call list. For each profile, specify the following key properties: 

 Enter the e-mail address as the login property (because the user has not 
chosen one yet). 

 Leave the password property empty. 

 Set the email property to the e-mail address. 

This configuration permits scenarios to send targeted e-mail messages to these 
addresses and to set profile properties that track the offers you have sent. 

2. Send a targeted e-mail message that includes a site URL with parameters that specify 
both the e-mail address and any optional offer code (see the Quincy Funds demo for 
an example of offer code processing). 

3. On the page to which the URL directs the visitor, use the e-mail address to log in the 
visitor (the e-mail address is also the login property in the visitor’s profile). Use the 
atg.userprofiling.ProfileTools service to perform the login and also to check 
that the profile belongs to a cold-call subject rather than to a known visitor. In 
addition, process the offer code if there is one. 

4. Display a change-user-name-and-password form as if it were a regular registration 
form. This behavior enables visitors to select their own logins and passwords to 
replace the ones you set up as part of the cold call campaign. 
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11 Previewing Your Web Site 

After you have set up your profile groups, content, and targeting rules, you can preview your Web site to 
see how it will look to different kinds of visitors under various circumstances. 

You can preview the site in two ways: 

 Use the Preview with Profile toolbar button in the People and Organizations > 
Profile Repository window. This method is useful if you want to preview the Web site 
as it looks now from the point of view of a specific visitor –someone who has an 
existing profile in your system. For example, if you have the Quincy Funds demo, you 
can use this method to preview the Quincy Funds site as a broker, Jack Smith. 

 Use the Preview window (Targeting > Preview). Use this method if you want to 
preview the Web site according to a set of profile properties that do not necessarily 
correspond to any single profile. For example, if you want to see how a page on your 
site will look to female visitors who have a last activity date of December 31, 2001, use 
the Preview window. 

This method also allows you to see how the Web site will look at a specific time and 
date. 

Using the Preview with Profile Toolbar Button 
Follow these steps to use the Preview with Profile toolbar button to preview your Web site: 

1. Select People and Organizations > Profile Repository. 

2. Display the visitor profile you want to use to preview the site. For example, if you have 
the Quincy Funds demo, you could display the profile for broker Jack Smith. 

3. Click the Preview with Profile button on the toolbar. The button has this icon: 

 

4. The Preview Site Using Profile dialog box appears. Use it to specify the page that you 
want to preview. For example, you could select the brokerhome.jsp page from the 
Quincy Funds demo: 
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When you click OK, the system displays the specified page in your Web browser. The 
content of the page is personalized for the profile you selected in step 2. 

Using the Preview Window 
Previewing your site using this method involves three steps: 

1. Specifying your visitor properties (the person you want to “be” when you look at the 
site). 

2. Setting date and time conditions (optional). 

3. Selecting the page you want to preview. 

To open the Preview window, select Targeting > Preview from the main ATG Control Center window. The 
following window appears: 
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The three “step” buttons at the top of the window show how to preview your site. As you click each step, 
the features of the window change accordingly. 

Note: The profile properties that you see depend on the profile repository you use for your Web site. For 
more information, see Setting Up a Profile Repository in the ATG Personalization Programming Guide. 

Specifying Your Visitor Attributes 

When you preview your site, you need to specify your visitor attributes. In other words, you need to 
specify the person you want to “be” when you look at a particular page. You can do this by editing the 
property values in the ATG Control Center’s test profile. 

As you preview your site, click the Refresh toolbar button to update your test profile with the latest data 
from the ATG server. This shows you how your profile properties change as you perform various actions 
on the site. 

To specify your visitor attributes: 

1. Click Step 1 Specify the attributes of the person you want to be. 

A two-column table displays the profile properties and values for your hypothetical 
site visitor. The properties and values come from your site’s profile repository. 

Tip: The table contains Login and Password properties. However, you do not need to 
specify values for these properties in order to preview a page. For example, assuming 
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your profile repository contains a Gender property, you can specify Male as the Gender 
value to preview a page as any male visitor. 

2. Set the values for the properties you want to use by clicking in the appropriate Value 
cells. (You can adjust these values later if necessary.) 

Depending on the property, you can enter values in one of the following ways: 

 Type text directly into the Value cell. 

 Select a value from a drop-down list. 

 Click the “…” button to add, remove, or edit values in a pop-up editor window. 

For more information on specifying properties, please refer to Setting Up Visitor 
Profiles. 

After you specify your visitor attributes, you can define a date and time or select the page you want to 
preview. (For details, see Specifying a Date and Time and Selecting the Page You Want to Preview.) 

Specifying a Date and Time 

By default, you preview pages using the current date and time. However, if you have set up any date- or 
time-sensitive content, you can specify an appropriate date and time to check that the content will 
appear as planned. 

Click Step 2 Optionally, choose a date. 

1. If you want to change the date, click on the date button in the Preview window. When 
the pop-up calendar (shown below) opens, click on the month, year, and date you 
want to use, and then click OK. 

 

2. If necessary, use the Time fields to set a new preview time: 

 

Once you set your date and time conditions, you can select the page you want to 
preview. (For details, see Selecting the Page You Want to Preview.) 
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Selecting the Page You Want to Preview 

Once you specify your visitor attributes and optional date/time conditions, you can select the page you 
want to preview. 

To choose a page for previewing: 

1. Click Step 3 Choose the page you want to view. 

2. Select the appropriate Web application from the list at the top of the window. The list 
of pages at the bottom of the window changes according to the application you 
selected. 

3. Open the appropriate folder and click on the page you want to see. Note: To see if any 
new pages have been added to this application, select Refresh from the View menu. 

4. Select File > Preview. The ATG Control Center opens the specified page in your Web 
browser, allowing you to see how the page will look to someone with your visitor 
attributes under the specified time conditions. 

You can navigate to other site pages from your preview page. As you interact with the site, you can see 
how your actions affect your profile properties by clicking the Refresh toolbar button in the Preview 
window. 

If you make any changes to your selection of profile property values or date/time conditions, and you 
would like to see how these changes affect the page you are previewing, select File > Apply. 
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12 Performing User Sampling 

The user sampling features in the Scenarios module allow you to test the success of your scenarios and 
promotional campaigns. To use these features, you divide your site visitors into groups, treat them 
differently, and then monitor their behavior. Using the results, you can fine-tune your scenarios to work 
more effectively. Example: you devise a campaign to promote products according to the age group of the 
site visitor. You want to check that this strategy is successful, so you create a scenario that sets up two 
groups of site visitors, using age as a criterion for one but not for the other. For Group A , you display 
specific products to specific age groups. For Group B, you display all products regardless of the age group 
of the visitor. You monitor the results to see which strategy generates more sales. 

You can also use these features to test the design of your Web site. For example, assume you design a 
new-look corporate Web site that uses a dramatically different navigation model from your old site. You 
are concerned that the new design makes some pages too difficult to find. You decide to compare the 
new site with the old one by counting the number of times your Investor Relations page is displayed 
during a single month. In the Scenarios module, you create a scenario that displays the old site to Group A 
and the new site to Group B, and then you track the number of times the page is visited during the test 
period. 

How User Sampling Works 
There are two methods for performing user sampling in the Scenarios module: short term sampling and 
long term sampling. The first method involves dividing visitors into groups for the duration of a single 
test only. With the second method, long term sampling, you divide visitors into groups by first marking 
their profiles, and you then use those groups to perform various tests over the course of a long period. 

The following sections describe how to set up user sampling for both methods. 

Performing Short Term User Sampling 

To perform short term user sampling, you create a scenario that includes an element called a 
Randomizing Fork. This element acts in a similar way to a regular Fork element (see Using Fork Elements 
in Scenarios), except that the first element in the fork always divides the group of site visitors into 
segments according to a percentage you specify. For example, you could choose to divide the group into 
two equal segments, 50% in each group. The following image shows a Randomizing Fork element 
triggered by a Session Starts element: 
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The next elements in each branch define the object of the test. In the following example, the scenario 
contains two Action elements that show different promotions to the two groups of visitors: 

 

You then add recorder elements that monitor the results of the test. In this example, you want to measure 
the success of the two promotions you show, so you add Event elements to account for possible visitor 
behavior after seeing the promotions (registers to become a member, leaves the site, or logs in). Then you 
add recorder elements to track the parts of the behavior that interest you: 
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In this example, you add Audit Trail recorder elements to count the number of times that visitors respond 
to the two promotions either by registering or by leaving the site. The system stores this information in a 
dataset called QF Signups that you have created specifically for this test. (For information about Audit 
Trail elements, see Creating an Audit Trail.) 

When the test period is complete, you compare the data for the two groups of users by creating a report 
that displays the data that you tracked with the recorder elements. 

Floating or Fixed Randomizing Forks? 

By default, the system divides the percentage of site visitors equally among the number of branches you 
create for the Randomizing Fork. However, you can change this behavior and specify a fixed percentage 
for one or more branches. For example, in a fork with three branches, you can specify a fixed percentage 
of 50% for the first branch. The system adjusts the percentage for the other two branches to 25% each so 
that the total percentage is always 100. 

The following example shows a fixed Randomizing Fork: 
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If you specify a fixed percentage for all branches in a fork and define amounts that add up to more than 
100, the system displays the value for each fork as a fraction of your new total. 

To use the fixed percentage feature, double-click on the dice icon of the element that you want to turn 
into a fixed percentage. Select Fixed and type the value you want to use. Then click the check mark. The 
following image shows the element after you double-click it: 

 

Performing Long Term User Sampling 

Long term user sampling is similar to short term sampling with one important difference: with long term 
sampling, the test groups you set up persist from one scenario to the next, so you can compare the 
behavior of different groups of visitors across many scenarios and over a long period of time. 

To set up this type of sampling, you create a scenario that assigns site visitors to one of several test 
groups. The scenario sets the test group assignment as a property in each visitor’s profile. The following 
image shows how the scenario might look: 

 

On the specified date, the scenario changes a property called Test Group in each visitor’s profile to either 
GroupA, GroupB, or GroupC. (Note that this property does not ship with the ATG platform. Your database 
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administrator must add a similar property to your profile repository if you want to perform long term user 
sampling.) 

Each registered visitor now belongs to one of the three test groups. You can use these groups to test any 
aspect of a scenario or your Web site design that you choose, either by setting up a scenario specifically to 
perform user sampling, or by inserting test elements into other scenarios. In addition, because these test 
groups are simply profile properties set to specific values, you can use them in targeters as well as in 
scenarios. 



A T G  P e r s o n a l i z a t i o n  G u i d e  f o r  B u s i n e s s  U s e r s  

 

1 8 4  

1 2  -  P e r f o r m i n g  U s e r  S a m p l i n g  

μ
 



A T G  P e r s o n a l i z a t i o n  G u i d e  f o r  B u s i n e s s  U s e r s  

 

1 8 5  

1 3  -  U s i n g  W o r k f l o w s  

μ
13 Using Workflows 

Workflows are graphical tools that are designed to help you manage the online automation of many 
types of business process or activity. Like scenarios, workflows track the progress of a subject through a 
specific process. In the case of scenarios, the subject is a site visitor, and the process is a series of events 
that define some form of activity on or related to your Web site. Workflows use a similar concept, except 
the subject is an entity such as a customer support case or a sales inquiry, and the process is a series of 
events that define the lifecycle of that entity. For example, you could design a workflow in which the 
subject is an online expense report and the stages of its lifecycle (the elements in the workflow) are 
submission, approval, and reimbursement. 

The following illustration shows a workflow for an expense report. (Note that the illustration is broken into 
two parts, but the workflow itself contains no break.) 

 

 

This workflow contains two tasks: Submission and Approval. The Submission task is completed by an 
employee, and the Approval task is completed by a manager. If the manager approves the expense 
report, the Reimburse Employee custom action is triggered; this action reads relevant information, such as 
the employee’s identity and the amount to reimburse, from the expense report repository, and it initiates 
the payment. The report’s status property in the repository is then set to “Reimbursed.” If the manager 
rejects the expense report, the report’s status is set to “Rejected,” and the workflow reverts to the 
Submission task, allowing the employee to revise his or her expenses. 

You design the workflow in the ATG Control Center, and a page developer sets up any relevant site pages; 
including any forms necessary for completion of the different stages of the workflow. In the example of 
the expense report, the page developer could create a site page accessible by employees that includes an 
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online version of a report and also contains a Submit button; and a page accessible by managers that 
includes a list of pending expense reports as well as Approve and Reject buttons. 

The key differences between workflows and scenarios can be summarized as follows: 

 The subjects that progress through scenarios are site visitors; the subjects that 
progress through workflows represent other entities such as documents. (The subjects 
of scenarios are user profiles, but the subjects of workflows can be any repository 
item.) 

 Scenarios are used to track and respond to Web site activities such as page visit or 
login events. Workflows are used to track business activities that are completed either 
fully or partially through a Web site. 

 Scenarios are frequently used on extranets and commercial Web sites; workflows are 
frequently used on intranets or other Web sites that support a community of users. 

 The subjects progressing through a scenario have no direct interaction with it 
(participation in a scenario is completely transparent to the site visitor). Site users can, 
however, interact directly with a workflow. 

 Scenarios and workflows are derived from the same base package of code 
(atg.process), but they use different subclasses of this code, and the sets of 
elements available for building scenarios and workflows in the ATG Control Center are 
different. 

Important: You can create workflows only if your application developers have created custom workflow 
elements for your organization. You cannot create a workflow from a default set of elements as you can 
for scenarios. For more information on this restriction, see Creating a Workflow. 

This chapter includes information on the following topics: 

Accessing Workflow Menu Items 

Security Access in Workflows 

Viewing Workflows 

Creating a Workflow 

Using Workflow Elements 

Enabling Workflows 

Printing Workflows 

Deleting Workflows 

Moving or Renaming Workflows 

Accessing Workflow Menu Items 
If your ATG product suite contains ATG Content Administration, or if your application developers have 
added any custom workflow types to your system, a Workflow menu item appears in the main ATG 
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Control Center window, as shown in the following illustration (note that ATG Content Administration and 
Commerce items also appear in this example): 

 

ATG Control Center window with Workflow menu item 

If you expand the Workflow menu item, the types of workflow defined for your system are displayed. You 
can create new workflows of only the types that appear. The following illustration shows two workflow 
types: Registration and Expense Reports. 
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Security Access in Workflows 
As described in the previous section, the Workflow menu item appears only if your ATG product suite 
includes ATG Content Administration or if an application developer has added at least one custom 
workflow type to your system. 

In addition, your ability to access the Workflow item in the main ATG Control Center navigation menu is 
determined by the security rights that the ATG system administrator assigns to your group in the People 
and Organizations > Control Center Groups window. The administrator can also define an additional layer 
of security that controls access to individual workflows and task elements. For more information, refer to 
the ATG Personalization Programming Guide. 

Viewing Workflows 
To see a list of the workflows that already exist in your system, select Workflow from the main menu and 
then select the type of workflow you want to view (in the example at the beginning of this chapter, either 
Registration or Expense Reports). The Workflow window appears as shown below: 
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Workflow window 

The window has the following features: 

 

Feature Displays… 

Left panel List of folders containing the workflows of the specified type (in the 
example, Registration) that have already been created for your Web site. 
Workflows are identified by the  icon. 

Right panel Workflows in the selected folder. You can add new workflows to this list 
by clicking the New Workflow Definition button on the toolbar. For more 
information, see Creating a Workflow. 

Name column Name of each workflow in the selected folder. The arrow next to the 
column title shows how workflows are sorted in this list; clicking the 
column title reverses the sort order. 

Author column User name of workflow creator 

Created column Date of workflow creation 

Last Modifier column ATG Control Center user name of the person who last saved changes to 
the workflow 
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Last Modified column Date when latest changes were saved 

 

To edit an existing workflow, click the name of the workflow to change. The Workflow Editor window 
appears, as shown below, and the workflow you selected is opened for editing: 

 

Workflow Editor 

For information on editing the elements that make up a workflow, see Using Workflow Elements. 

Creating a Workflow 
Important: You can create workflows only for the custom workflow types that the application developers 
have set up for your site. There are no default workflow types included in the ATG platform for ATG 10.0.2, 
although one is provided with ATG Content Administration. For more information on creating custom 
workflow types, refer to the ATG Personalization Programming Guide. 

Follow these steps to create a workflow: 

1. Display the Workflow window as described above, selecting the type of workflow you 
want to create. 

2. Click on the New Workflow Definition button. The New Workflow Definition window 
appears. 

3. Select the folder where you want to store this workflow. 

4. Type a name for the new workflow in the Workflow Definition Name field. It is 
recommended that workflow names be unique across the ATG product suite to avoid 
ATG Control Center errors. 

5. Click OK. The new workflow opens in the Workflow Editor. For information on defining 
it, see the next section, Using Workflow Elements. 
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Using Workflow Elements 

Although the Registration workflow is the only type of workflow you can create by default, there are some 
workflow elements that are common to all workflows and will be available in any custom workflow types 
that your application developers create. This section describes how to use these standard elements. Note 
that many of them (such as fork elements) are similar or identical to the elements you use in scenarios. 

The following standard elements can be used to build a workflow: 

 Start 

 Branch 

 Task 

 Outcome 

 Time 

 Condition 

 Action 

 Workflow Fork 

 Fork 

 Otherwise 

 Go To 

 Stop 

These elements are described in the sections that follow. 

Accessing Element Editors 

Most of the elements you can use to build a workflow are configurable. To access the editor that you use 
to configure an element, double-click the element after you have added it to the workflow. 

Using Start Elements in Workflows 

 

When you open a new workflow in the workflow editor, it contains a Start element, which represents the 
event that occurs when the workflow begins to run. This element is always the first in a workflow, and it 
cannot be deleted. (For more information on starting a workflow, see Enabling Workflows). 

Double-click this element to access a set of controls that allow you to edit the attributes of the workflow 
as a whole. 
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Control Purpose 

Default Display 
Name 

The name that appears for this workflow on your Web site pages. You can 
specify a separate display name for each locale supported by your 
application (for example, English, French, or Japanese). If you do not specify 
a different display name for each locale, the default display name is used. 

Default Description The description of the workflow that displays on your Web site pages. You 
can specify a separate description for each locale supported by your 
application. 

Locale for Editing 
Names 

The locale that applies to the Display Name and the Description fields. For 
example, to edit the Display Name for French, select French from the list. To 
edit the default display names, select Unspecified from the list. 

Note: The contents of the locale list are determined by the 
validLocaleNames property of the Nucleus component 
/atg/dynamo/servlet/RequestLocale. For more information, see the 
Internationalization chapter of the ATG Programming Guide. 

Form URI The URI of a form that you can display to the site user when the workflow 
starts up. You can use this form to request data from the site user that the 
workflow may require in order to proceed. 

Set Access Rights A set of users who are permitted to run the workflow. You define the set 
through a standard ATG Control Center security access dialog box. For more 
information, refer to Setting Up Security Access for Workflows in the ATG 
Personalization Programming Guide. 

 

Using Task Elements in Workflows 

 

A task represents an individual step or stage in a workflow, such as Submit or Approve. A task element has 
a label that describes the associated activity, and it is always followed by a fork that contains at least one 
branch beginning with an outcome element. 

When you select a task element, the initial label as well as the entire following fork becomes selected. 

The editor for a task element consists of a set of controls that allow you to edit the task’s attributes, 
including: 

 

Control Purpose 

Task Name The text that appears as the name for this element in the workflow. 
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Default Display 
Name 

The name that appears for this task on your Web site pages. You can specify 
a separate display name for each locale supported by your application (for 
example, English, French, or Japanese). If you do not specify a different 
display name for each locale, the default display name is used. 

Default Description The text that appears as the description of the task on your Web site pages. 
You can specify a separate description for each locale supported by your 
application. 

Locale for Editing 
Names 

The locale that applies to the Display Name and the Description fields. For 
example, to edit the Display Name for French, select French from the list. To 
edit the default display names, select Unspecified from the list. 

Note: The contents of the locale list are determined by the 
validLocaleNames property of the Nucleus component 
/atg/dynamo/servlet/RequestLocale. For more information, see the 
Internationalization chapter of the ATG Programming Guide. 

Assignable Indicates whether a user can assign the task to another user for completion. 
For more information, refer to Setting Up Security Access for Workflows in the 
ATG Personalization Programming Guide. 

Set Access Rights A set of users who are allowed to run the task. You define the set through a 
standard ATG Control Center security access dialog box. For more 
information, refer to Setting Up Security Access for Workflows in the ATG 
Personalization Programming Guide. 

 

Using Outcome Elements in Workflows 

Outcome elements always follow task elements, and each outcome element represents one possible 
result of a task. For example, an Approve task might have two outcome elements: Accept and Reject. 

By default, outcome elements appear in a fork element that has only one branch, as shown in the 
following illustration: 

 

To add another branch to the fork, move the mouse over the dotted line that extends from the circle at 
the beginning of the fork, and click the triangle that appears: 
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For more information on editing forks, see Using (Regular) Fork Elements in a Workflow. 

Note that time elements can appear between the task and outcome elements. See Using Time Elements 
in Workflows. 

For every outcome element, you would typically have a corresponding button on one of your site’s pages. 
For example, you might have an Approve or Reject button that would correspond to the possible 
outcome elements of the Approval task in an expense report workflow. Clicking on a workflow action 
button signals the completion of a task, initiates any action elements associated with the outcome 
element, and moves the project into the next task in the workflow. 

The editor for an outcome element consists of a set of controls that allow you to edit the outcome’s 
attributes, including: 

 

Control Purpose 

Outcome Name The name for this element in the workflow. 

Default Display Name The name that appears for this outcome element on your Web site 
pages. You can specify a separate display name for each locale 
supported by your application (for example, English, French, or 
Japanese). If you do not specify a different display name for each 
locale, the default display name is used. 

Default Description The description of the outcome element on your Web site pages. You 
can specify a separate description for each locale supported by your 
application. 

Locale for Editing Names The locale that applies to the Display Name and the Description fields. 
For example, to edit the Display Name for French, select French from 
the list. To edit the default display names, select Unspecified from the 
list. 

Note: The contents of the locale list are determined by the 
validLocaleNames property of the Nucleus component 
/atg/dynamo/servlet/RequestLocale. For more information, see 
the Internationalization chapter of the ATG Programming Guide. 

Form URI The URI of a form that you can display to the site user when the 
outcome occurs. You can use this form to request data from the site 
user that you may need for the workflow to proceed. 
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Using Time Elements in Workflows 

 

Workflow time elements perform the same function as time elements in a scenario: they require a specific 
time condition to be satisfied before the process can continue. The time conditions you can define are as 
follows: 

 

Time condition Purpose 

Wait An amount of time to wait before proceeding, for example Wait 5 Minutes. 

At At a specific time of day, for example At 8:00 AM. 

Between The beginning and end of a specific time interval, for example Between Dec 1, 
2003 and Dec 31, 2003. You can specify the interval as times only, dates only, or a 
combination of dates and times. To change the type of interval, click the 
diamond that appears after the word Between when you are editing this 
element. 

On On a specific date, day of the week, weekday, or day of the month, for example 
On the 1st Monday of the Month at 8:00 AM. To change the type, click the 
diamond that appears after the word On when you are editing this element. 

 

Note that time elements can appear as the first element after a task element. 

For more information on working with time elements, see Using Time Elements in Scenarios. 

Using Condition Elements in Workflows 

 

Workflow condition elements perform the same function as condition elements in a scenario: they require 
a specific condition to be met before the process can continue to the next element. However, whereas 
scenario conditions allow you to set a condition based only on a property of a preceding event, workflow 
conditions can be based on a property of the workflow type itself. For example, the Registration workflow 
type, for which the subjects are items in the demo Registration repository, has properties that correspond 
to the fields on a registration form. In this case, you could create a condition element that would test the 
following: 
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If the workflow contains custom event elements, the conditions can also be based on the properties of 
those events. 

Another function of condition elements is to use them to compare a variable that you defined earlier in 
the workflow to a given value. (This type of condition element also exists in scenarios.) For more 
information, see the description of the Set Variable action in the next section. 

Using Action Elements in Workflows 

 

While task elements represent the steps that users perform as part of the workflow process, action 
elements represent the steps that you want the workflow engine to perform, usually in response to the 
preceding element in the workflow. For example, you could add an action element that sends an e-mail to 
an employee who submitted an expense report, notifying him or her that the report has been approved. 

 

Action Purpose 

Change Change a specified property in the workflow. 

Example: Change Registration's Request Status to rejected 

Also use this element to change any variables that you set earlier in the 
workflow by means of the Set Variable action. 

Record Audit Trail Track data that monitors scenario or workflow activities. See Recording 
Scenario Activity for more information. 

Record Event Track data for inclusion in reports, to track the result of the preceding 
workflow element and store information about it in a specified dataset. 

Send Notification Send a specified e-mail message to a given recipient or group of 
recipients. You can define the recipients as users (people with user 
profiles in the Profile repository) or e-mail addresses. This action is the 
same as the Send Notification scenario action; for more information, see 
Send Notification in the scenarios chapter of this guide. 

Send Task Notification Send an e-mail to the owner of a specific task in the workflow. For 
example, you can set the action to inform the owner of the next task in 
the workflow that the task is ready to be performed. 

Example: Send Task Notification: /notifyaccepted.jsp to owner of task 
Submit. 
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Fork elements let you split a workflow into two or more branches, each branch representing a possible 
path that the workflow can follow. There are two types of fork element you can add to workflows: 
workflow fork elements and regular fork elements. 

Using Workflow Fork Elements 

All the branches in a workflow fork element must be completed before the workflow can proceed to the 
next element after the fork. For that reason, a workflow fork is appropriate for situations where two or 
more tasks can be active at the same time and can be completed independently; as long as all tasks are 
completed, the order in which they occur is not important. 

 

A solid circle at the end of the workflow fork differentiates it from a regular fork. (Regular forks have no 
circle at the end.) 

Note: You can change a regular fork into a workflow fork by right-clicking it and selecting Require All 
Branches to Succeed from the drop-down menu. You can also use this technique to add the functionality 
of a workflow fork to the fork elements that you include in scenarios. 

Using (Regular) Fork Elements in a Workflow 

Regular fork elements (in other words, non-workflow fork elements) are the same as the fork elements 
you use in scenarios. They allow you to divide a workflow into separate branches that represent parallel 
“if” conditions. For example, you could create a fork with two branches, each containing different 
condition elements. The workflow could proceed along both branches, either branch, or neither branch, 
depending on the success or failure of the condition element. Unlike workflow forks, regular forks allow 
the workflow to proceed if only one branch is completed. 

 

Note: You can change a regular fork into a workflow fork by right-clicking on it and selecting Require All 
Branches to Succeed from the drop-down menu. 

For more information on using regular fork elements, see Using Fork Elements in Scenarios. 
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Add Branch 

By default, forks and workflow forks have two branches. If you want to insert additional branches into 
either type of element, select the Add Branch menu option. For more information, see Using Fork 
Elements in Scenarios. 

Using Otherwise Elements in Workflows 

An Otherwise element is a special type of condition element that can appear at the beginning of one 
branch of a fork. It allows you to define how the workflow should proceed if none of the other branches is 
completed. For examples and more detail, refer to Using Otherwise Elements in Scenarios. 

Using Go To Elements in Workflows 

 

Go To elements allow the workflow to jump directly to a specified task element. A Go To element can 
transfer execution only to a task element that is on its own branch or on any ancestor branches of a 
nested fork. It cannot transfer execution to an element in another branch on the same fork, or to a branch 
that follows it. 

Double-clicking the Go To element displays an editor that allows you to specify the task element to which 
you want the workflow to jump. Only valid destinations appear as choices. 

Using Stop Elements in Workflows 

 

A Stop element represents the end of a workflow. When this element is reached, the workflow stops 
running. This element cannot be deleted, and it is always the last in a workflow. 

As shown in the example below, you can also add a Stop element to the branch of a fork in cases where 
you do not want the workflow to proceed after that branch is followed: 
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In this case, if the registration request is rejected, the Reject branch is followed and the workflow stops 
executing after all the elements on the Reject branch are completed. If the registration request is 
approved, the workflow follows the Approve branch and continues to the next task after the fork. 

Enabling Workflows 
Unlike scenarios, workflows do not have to be enabled or disabled within the ATG Control Center in order 
to make them active or inactive. As long as the Web application that uses them is running, workflows are 
started whenever an event occurs that represents the beginning of a workflow (for example, an employee 
clicks the Submit button for his or her expense report). This behavior is in contrast to the startup behavior 
of scenarios. When you start the Scenarios module, all enabled scenarios are started and begin waiting for 
their specified events to occur. 

Note for developers: The event that represents the beginning of a workflow must trigger the workflow 
by calling the StartWorkflow method of the WorkflowView object associated with this event. See the 
Javadoc for atg.workflow.WorkflowView in the ATG API Reference. 

Printing Workflows 
To print a workflow: 

1. Display the workflow in the editing window. 

2. Select File > Print. A dialog box appears, prompting you to choose whether to have 
the system scale the workflow to fit the page or print it full size (on multiple pages if 
necessary). The page size and orientation are the ones you have currently selected for 
your printer. Select Scale to Fit Page unless the workflow is so short that you are sure it 
will fit on the page. 

3. Click OK. A standard print dialog box appears, allowing you to print the workflow to 
the specified printer. 

You can also choose to save the workflow in JPEG format for use as an image in another application. To do 
so, select File > Save as JPEG and then specify a name and location for the file. 
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Deleting Workflows 

If you delete a workflow, remember to edit as appropriate any site pages that include forms or other items 
that refer to the workflow. 

Follow these steps to delete an existing workflow. 

1. Display the list of existing workflows in the Workflow window. 

2. Select the workflow you want to delete. 

3. Select File > Delete Workflow Definition. 

Moving or Renaming Workflows 
Important: If you rename a workflow, you may have to update references you’ve made to it on your site 
pages depending on the means your pages use to identify a workflow. If your pages use the workflow 
name shown in the ATG Control Center, and you do not update them, errors will occur whenever the 
workflow is invoked on the Web site. 

Follow these steps to rename an existing workflow or move it to another folder. 

1. Display the list of existing workflows in the Workflow window. 

2. Select the workflow you want to move or rename. (To select a workflow without 
opening it, click its entry in any column except the Name column.) 

3. Select File > Move/Rename Workflow Definition. (Note: You cannot move or rename a 
workflow that is currently open in the ATG Control Center. To close the workflow, 
navigate to it by using the arrow buttons in the toolbar, and then select File > Close.) 

The Rename Workflow Definition dialog box appears. 

4. To move the workflow to a different folder, select the destination folder from the list at 
the top of the dialog box. To rename the workflow, type the new name (do not include 
spaces). 

5. Click OK. 
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Index 

A 
A Form Is Submitted scenario event, 115 
action elements 

Add Stage Reached, 137 
Remove Stage(s) Reached, 137 

Action scenario element, 133 
Action workflow element, 196 
Add Items to Slot scenario action, 136 
Add Marker To Profile scenario action, 137 
Add Stage Reached action element, 137 
An Email Is Received scenario event, 115 
At elements in scenarios, 113 
At Priority option in slots, 144 
ATG Business Commerce, 4 
ATG Business Control Center, 3 
ATG Consumer Commerce, 4 
ATG Content Administration, 4 
ATG Control Center 

main menu, 6 
overview, 3 
security access, 6 
starting, 4 
stopping, 7 

ATG platform, parts of, 1 
ATG Portal, 4 

B 
Between elements in scenarios, 113 
Browser condition, in content targeters, 80 
Business Process Stage Reached scenario event, 126 
business process tracking 

adding stages, 137 
removing stages, 137 

C 
Change scenario action, 134 
Change workflow action, 196 
Clicks a Link scenario event, 117 
cold call mailings. See targeted e-mail 
Commerce applications 

documentation for, 7 
components, creating, 7 
condition elements 

Has Reached Stage, 132 
Most Recent Stage Reached, 133 

Condition scenario element, 128 
Condition workflow element, 195 
content groups 

defining rules for, 58 
deleting, 64 
overview, 10, 53 
sample rules for, 61 

content items 
adding, 49 
deleting, 52 
editing, 47 
editing properties, 49, 50 
matching to target audience. See content targeters 
overview, 9, 47 

content properties. See content items 
content repository editor, 47 
content targeters 

adding, 69 
compared to scenarios, 100 
creating macros for, 84 
defining rules for, 72, 83 
deleting, 90 
deleting rules from, 86 
environment conditions, 80 
overview, 10, 65 
sample rules for, 86 
site performance, 72 
sorting results, 82 
using roles in, 27, 40 
using within slots, 147 
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Control Center. See ATG Control Center 

D 
dates, specifying in scenario conditions, 129, 131 
derived property values, 17 
Disable Scenario scenario action, 135 
document paths, specifying in scenarios, 133 
Dynamo Application Framework, overview, 1 
Dynamo path option in scenario elements, 133 
Dynamo Shuts Down scenario event, 118 
Dynamo Starts scenario event, 118 
Dynamo User Directory, 20 

E 
elements in scenarios. See scenarios 
e-mail campaigns. See targeted e-mail 
environment conditions, in content targeters, 80 
event elements 

Business Process Stage Reached, 126 
Event scenario element, 114 

F 
Fork elements in workflows, 197 
Fork scenario element, 138 
function property in organizational roles, 26 

G 
global roles 

description of, 25 
providing unique names for, 27 

Go To workflow element, 198 
GSA Repository Cache Invalidation Received scenario 

event, 124 

H 
Has Reached Stage condition element, 132 
help for the ATG Control Center, 8 

I 
inherited property values, 17 
Is Referred by External Site scenario event, 118 
Items Requested scenario event, 119 

J 
JPEGs, saving scenarios and workflows as, 162, 199 

L 
Locale condition, in content targeters, 80 
Logs In scenario event, 119 
Logs Out scenario event, 120 

M 
matching content items to the target audience 

overview, 10 
with content targeters, 65 
with scenarios, 66 

message bean properties, referencing in targeted e-mail, 
168 

Most Recent Stage Reached condition element, 133 

N 
Nucleus components. See components, creating 

O 
On elements in scenarios, 112 
online help, 8 
organizational roles 

description of, 26 
function property, 26 

organizations 
assigning other organizations, 24 
assigning roles, 28 
assigning users, 23 
child, 24 
creating, 21 
deleting, 23 
displaying membership, 24 
duplicating, 22 
inheritance, 24, 29 
overview, 19 
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Otherwise scenario element, 142 
Otherwise workflow element, 198 
Outcome workflow element, 193 

P 
Page and Components menu option, 7 
People and Organizations menu option, 7 
People scenario element, 111 
Person condition, in content targeters, 80 
Personalization module, overview, 2 
personalization process, steps in, 9 
personalized content. See content targeters 
previewing a Web site 

overview, 10, 173 
using the Preview window, 174 
using the Profiles window, 173 

priority level 
scenario segments, 107 
slot items, 144 

production server 
connecting to, 4 

profile groups 
creating, 36 
defining rules for, 38 
deleting, 44 
overview, 9, 33 
relationship to organizations and roles, 33 
sample rules for, 42 
using roles in, 27, 40 

Profile Marker Added scenario event, 124 
Profile Marker Removed scenario event, 125 
Profile Marker Replaced scenario event, 126 
profile properties 

changing, 16 
Profile Property Updated by Admin scenario event, 120 
Profile Property Updated by User scenario event, 120 
Profile Registered by Admin scenario event, 121 
Profile Repository menu option, 7 
Profile Repository window, 18 
profile sub-types, 16 
Profile Updated by Admin scenario event, 121 
Profile Updated by User scenario event, 121 
profiles 

adding new, 18 
deleting, 18 
editing, 16 
overview, 9, 13 

Q 
Quincy Funds demo, 2 

R 
Randomizing Fork element. See user sampling 
Record Audit Trail scenario action, 136 
Record Audit Trail workflow action, 196 
Record Event scenario action, 136 
red dots 

in scenarios, 153 

Redirect to Page scenario action, 135 
Registers scenario event, 121 
relative dates, specifying in scenario conditions, 131 
Remove All Markers From Profile scenario action, 137 
Remove Items from Slot scenario action, 136 
Remove Markers From Profile scenario action, 137 
Remove Stage(s) Reached action element, 137 
Request condition, in content targeters, 80 
roles 

assigning, 28 
creating, 24 
deleting, 28 
global, 25 
inheritance, 29 
naming, 27 
organizational, 26 
overview, 19 
relationship to profile groups, 33 
using for access control, 31 
using in content targeters, 27, 40 
using in profile groups, 27, 40 

rule macros, 84 

S 
Scenario Ends event, 152 
scenario segments 

priority among, 107 
significance of, 107 

scenarios 
access control, 101 
Action element, 133, 143 
adding custom elements, 143 
adding segments, 107 
arrow symbol, 109 
Audit Trail element, 152 
changing active, 154 
commas in expressions, 108 
compared to content targeters, 100 
Condition element, 128, 143 
creating, 101 
creating from a template, 160 
deleting elements, 108 
disabling, 153 
document paths in, 133 
editing elements, 108 
enabling, 153 
ending, 151 
Event element, 114, 143 
Fork element, 138 
migration feature, 154 
moving, 165 
moving between elements, 108 
organizing, 156 
Otherwise element, 142 
overview, 99 
People element, 111 
performance, 165 
Person’s Scenario Values property, 164 
Person’s Test Group property, 182 
printing, 162 
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read-only, 109 
recorder elements, 152 
recording activity, 152 
renaming, 165 
repeating elements, 109 
requiring elements to succeed, 140 
saving as JPEGs, 162 
segments, 107 
slots. See slots 
starting, 153 
Stop element, 142 
stopping, 135, 151, 153 
templates, 157 
Time element, 112 
tips for creating efficient, 165 
using dates within conditions, 129 
using for content targeting, 66 
using to update profile properties, 162 
Verify Changes option, 154 
viewing by type, 156 

Scenarios module, overview, 2 
security access, 7 
Send Email scenario action, 135 
Send Notification scenario action, 134 
Send Notification workflow action, 196 
Send Task Notification workflow action, 196 
Session Ends scenario event, 122 
Session Starts scenario event, 122 
Set Variable scenario action, 133 
slots 

active, 145, 149 
creating a scenario to fill, 145 
Event Generation mode, 145 
filling with content, 145 
from JMS messages, 149 
multisite, 148 
overview, 143 
passive, 145 
removing, 150 
types of items contained by, 143 
using a targeter to fill, 147 
using event elements to define, 149 

SOLID Server, starting, 4 
staging server 

connecting to, 4 
Start workflow element, 191 
Stop workflow element, 198 
Switches Site Context scenario event, 122 

T 
targeted e-mail 

addressing messages, 170 
cold call mailings, 170 
creating messages, 167 
creating scenarios for, 170 
overview, 167 
referencing message properties in, 168 
sending, 170 
setting up, 170 
using targeting services to address, 170 

targeting business rules. See content targeters 
Task workflow element, 192 
templates 

scenario. See scenarios 
testing a Web site on groups of users. See user sampling 
Time elements in scenarios, 112, 131 
Time workflow element, 195 
Today’s condition, in content targeters, 80 
Today’s scenario condition element, 129 
tracking sensors. See tracking visitor behavior with the 

Personalization module 
tracking visitor behavior with scenarios 

examples, 162 
overview, 10, 162 

tracking visitor behavior with the Personalization module 
adding new tracking sensors, 93 
defining how sensors change profiles, 94 
overview, 10, 91 
removing tracking sensors, 96 
setting tracking sensor properties, 95 

U 
user directory, 20 
user profiles 

editing, 16 
user sampling 

overview, 179 
persistent, 182 
Randomizing Fork element, 179, 181 
sample scenarios, 179 
setting up, 179 
specifying a fixed or floating percentage, 181 

users 
assigning to a role, 28 
assigning to an organization, 23 

Users window, 18 
Utilities menu option, 7 

V 
Views scenario event, 124 
visitor behavior 

tracking. See tracking visitor behavior 
Visits scenario event, 123 

W 
Wait elements in scenarios, 112 
With Dynamo path option in scenario elements, 133 
Workflow Editor, 190 
workflow elements 

Action element, 196 
Change action, 196 
Condition element, 195 
editing, 191 
Fork elements, 197 
Go To elements, 198 
Otherwise elements, 198 
Outcome element, 193 
Record Audit Trail action, 196 
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Send Notification action, 196 
Send Task Notification action, 196 
Start element, 191 
Stop elements, 198 
Task element, 192 
Time element, 195 
Workflow Fork elements, 197 

Workflow Fork element, 197 
Workflow menu item in ATG Control Center, 186 
Workflow window, 188 
workflows 

accessing, 186, 188 

creating, 190 
deleting, 200 
moving, 200 
overview of, 185 
printing, 199 
renaming, 200 
saving as JPEGs, 199 
security rights for, 188 
starting, 199 
viewing, 188 
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