|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 10 8/11 Information Library|
- display mounted resource information
dfmounts [-F FSType] [-h] [-o specific_options] [restriction]...
dfmounts shows the local resources shared through a distributed file system FSType along with a list of clients that have the resource mounted. If restriction is not specified, dfmounts shows file systems that are currently shared on any NFS server. specific_options as well as the availability and semantics of restriction are specific to particular distributed file system types.
If dfmounts is entered without arguments, remote resources currently mounted on the local system are displayed, regardless of file system type. However, the dfmounts command does not display the names of NFS Version 4 clients.
The output of dfmounts consists of an optional header line (suppressed with the -h flag) followed by a list of lines containing whitespace-separated fields. For each resource, the fields are:
resource server pathname clients ...
Specifies the resource name that must be given to the mount(1M) command.
Specifies the system from which the resource was mounted.
Specifies the pathname that must be given to the share(1M) command.
Is a comma-separated list of systems that have mounted the resource. Clients are listed in the form domain., domain.system, or system, depending on the file system type.
A field can be null. Each null field is indicated by a hyphen (-) unless the remainder of the fields on the line are also null, in which case the hyphen can be omitted.
Fields with whitespace are enclosed in quotation marks (" ").
Specify filesystem type. Defaults to the first entry in /etc/dfs/fstypes. Note: currently the only valid FSType is nfs.
Suppress header line in output.
Specify options specific to the filesystem provided by the -F option. Note: currently no options are supported.
file system types
See attributes(5) for descriptions of the following attributes: