|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 10 8/11 Information Library|
- lists device groups which contain devices that match criteria
/usr/sbin/getdgrp [-ael] [criteria]... [dgroup]...
getdgrp generates a list of device groups that contain devices matching the given criteria. The criteria is given in the form of expressions.
The following options are supported:
Specifies that a device must match all criteria to be included in the list generated by this command. The option has no effect if no criteria are defined.
Specifies that the list of device groups on the command line should be excluded from the list generated by this command. Without the -e option the named device groups are included in the generated list. The flag has no effect if no devices are defined.
Specifies that all device groups (subject to the -e option and the dgroup list) should be listed even if they contain no valid device members. This option has no affect if criteria is specified on the command line.
The following operands are supported:
Defines criteria that a device must match before a device group to which it belongs can be included in the generated list. Specify criteria as an expression or a list of expressions which a device must meet for its group to be included in the list generated by getdgrp. If no criteria are given, all device groups are included in the list.
Devices must satisfy at least one of the criteria in the list. However, the -a option can be used to define that a "logical and" operation should be performed. Then, only those groups containing devices which match all of the criteria in a list will be included.
There are four possible expressions types which the criteria specified in the criteria argument may follow:
Selects all device groups with a member whose attribute attribute is defined and is equal to value.
Selects all device groups with a member whose attribute attribute is defined and does not equal value.
Selects all device groups with a member which has the attribute attribute defined.
Selects all device groups with a member which does not have the attribute attribute defined.
See putdev(1M) for a complete listing and description of available attributes.
Defines a set of device groups which should be included in or excluded from the generated list. Device groups that are defined and which contain devices matching the criteria are included.
If the -e option is used, this list defines a set of device groups to be excluded. When the -e option is used and criteria is also defined, the generated list will include device groups containing devices which match the criteria and are not in the command line list.
The following exit values are returned:
Successful completion of the task.
Command syntax was incorrect, invalid option was used, or an internal error occurred.
Device table or device group table could not be opened for reading.
See attributes(5) for descriptions of the following attributes: