|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 10 8/11 Information Library|
- DNS lookup utility
host [-aCdilmrsTvw] [-c class] [-N ndots] [-R number] [-t type] [-W wait] [-4 | -6] name [server]
The host utility performs simple DNS lookups. It is normally used to convert names to IP addresses and IP addresses to names. When no arguments or options are given, host prints a short summary of its command line arguments and options.
The name argument is the domain name that is to be looked up. It can also be a dotted-decimal IPv4 address or a colon-delimited IPv6 address, in which case host by default performs a reverse lookup for that address. The optional server argument is either the name or IP address of the name server that host should query instead of the server or servers listed in /etc/resolv.conf.
The following options are supported:
Use only IPv4 transport. By default, both IPv4 and IPv6 transports can be used. Options -4 and -6 are mutually exclusive.
Use only IPv6 transport. By default, both IPv4 and IPv6 transports can be used. Options -4 and -6 are mutually exclusive.
Equivalent to setting the -v option and asking host to make a query of type ANY.
Make a DNS query of class class. This can be used to lookup Hesiod or Chaosnet class resource records. The default class is IN (Internet).
Attempt to display the SOA records for zone name from all the listed authoritative name servers for that zone. The list of name servers is defined by the NS records that are found for the zone.
Generate verbose output. This option is equivalent to -v. These two options are provided for backward compatibility. In previous versions, the -d option switched on debugging traces and -v enabled verbose output.
Specifies that reverse lookups of IPv6 addresses should use the IP6.INT domain as defined in RFC 1886. The default is to use RFC 3152 domain IP6.ARPA.
List mode. This option makes host perform a zone transfer for zone name, displaying the NS, PTR and address records (A/AAAA). If combined with -a, all records will be displayed. The argument is provided for compatibility with previous implementations. Options -la is equivalent to making a query of type AXFR.
Sets the memory usage debugging flags: record, usage, and trace.
Set the number of dots that have to be in name for it to be considered absolute. The default value is that defined using the ndots statement in /etc/resolv.conf, or 1 if no ndots statement is present. Names with fewer dots are interpreted as relative names and will be searched for in the domains listed in the search or domain directive in /etc/resolv.conf.
Make a non-recursive query. Setting this option clears the RD (recursion desired) bit in the query made by host. The name server receiving the query does not attempt to resolve name. The -r option enables host to mimic the behaviour of a name server by making non-recursive queries and expecting to receive answers to those queries that are usually referrals to other name servers.
Change the number of UDP retries for a lookup. The number argument indicates how many times host will repeat a query that does not get answered. The default number of retries is 1. If number is negative or zero, the number of retries will default to 1.
Specifies that the host not send the query to the next name server if any server responds with a SERVFAIL response, which is the reverse of normal stub resolver behavior.
Select the query type. The type argument can be any recognised query type: CNAME, NS, SOA, SIG, KEY, and AXFR, among others. When no query type is specified, host automatically selects an appropriate query type. By default it looks for A, AAAA, and MX records, but if the -C option is specified, queries are made for SOA records. If name is a dotted-decimal IPv4 address or colon-delimited IPv6 address, host queries for PTR records.
If a query type of IXFR is chosen the starting serial number can be specified by appending an equal followed by the starting serial number (for example: -t IXFR=12345678).
Use a TCP connection when querying the name server. TCP is automatically selected for queries that require it, such as zone transfer (AXFR) requests. By default host uses UDP when making queries.
Generate verbose output. This option is equivalent to -d.
Wait forever for a reply. The time to wait for a response will be set to the number of seconds given by the hardware's maximum value for an integer quantity.
Wait for wait seconds for a reply. If wait is less than one, the wait interval is set to one second.
Resolver configuration file
See for descriptions of the following attributes:
RFC 1035, RFC 1886, RFC 3152
See the BIND 9 Administrator's Reference Manual. As of the date of publication of this man page, this document is available at https://www.isc.org/software/bind/documentation.