|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 10 8/11 Information Library|
- list or provide labels for file systems
labelit [-F FSType] [-V] [-o FSType-specific-options] special [operands]
The labelit utility is used to write or display labels on unmounted disk file systems.
The following options are supported:
Specify the FSType on which to operate. The FSType should either be specified here or be determinable from /etc/vfstab by matching the special with an entry in the table. If no matching entry is found, the default file system type specified in /etc/default/fs will be used.
Echo complete command line. This option may be used to verify and validate the command line. Additional information obtained using a /etc/vfstab lookup is included in the output. The command is not executed.
Specify FSType-specific options. See the manual page for the labelit module specific to the file system type.
The following operands are supported. If no operands are specified, labelit will display the value of the labels.
The disk partition (for example, /dev/rdsk/c0t3d0s6). The device may not be on a remote machine.
FSType-specific operands. Consult the manual page of the FSType-specific labelit command for detailed descriptions.
See largefile(5) for the description of the behavior of labelit when encountering files greater than or equal to 2 Gbyte ( 231 bytes).
The following exit values are returned:
Write or display of labels was successful.
An error occurred.
List of default parameters for each file system.
Default local file system type. Default values can be set for the following flags in /etc/default/fs. For example:
The default partition for a command if no FSType is specified.
See attributes(5) for descriptions of the following attributes:
This utility may not be supported for all FSTypes.