|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 10 8/11 Information Library|
- network lock daemon
/usr/lib/nfs/lockd [-g graceperiod] [-l listen_min_backlog] [-t timeout] [nthreads]
It forwards fcntl(2) locking requests for NFS mounted file systems to the lock manager on the NFS server.
It generates local file locking operations in response to requests forwarded from lock managers running on NFS client machines.
State information kept by the lock manager about these locking requests can be lost if the lockd is killed or the operating system is rebooted. Some of this information can be recovered as follows. When the server lock manager restarts, it waits for a grace period for all client-site lock managers to submit reclaim requests. Client-site lock managers, on the other hand, are notified by the status monitor daemon, statd(1M), of the restart and promptly resubmit previously granted lock requests. If the lock daemon fails to secure a previously granted lock at the server site, then it sends SIGLOST to a process.
Administrators can make changes to the startup parameters for lockd by logging in as root and editing the /etc/default/nfs file (See nfs(4)).
The following options are supported:
Deprecated in favor of GRACE_PERIOD. Specify the number of seconds that all clients (both NLM and NFSv4) have to reclaim locks after the server reboots. It also controls the NFSv4 lease interval. This option is equivalent to the LOCKD_GRACE_PERIOD parameter.
Specify the listener backlog (listen_min_backlog). listen_min_backlog is the number connect requests that are queued and waiting to be processed before new connect requests start to get dropped.
Specify the number of seconds to wait before retransmitting a lock request to the remote server. The default value is 5 seconds. Equivalent of the LOCKD_RETRANSMIT_TIMEOUT parameter in the nfs file.
Specify the maximum number of concurrent threads that the server can handle. This concurrency is achieved by up to nthreads threads created as needed in the kernel. nthreads should be based on the load expected on this server. If nthreads is not specified, the maximum number of concurrent threads will default to 20. Equivalent of the LOCKD_SERVERS parameter in the nfs file.
See attributes(5) for descriptions of the following attributes:
The lockd service is managed by the service management facility, smf(5), under the service identifier:
This daemon might not exist in a future release of Solaris.