|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 10 8/11 Information Library|
- move print requests
lpmove [request-ID] destination
lpmove source destination
The first form of lpmove moves specific print requests (request-ID) to a specific destination.
The second form of the lpmove command moves all print requests from one destination (destination1) to another (destination2). This form of lpmove also rejects new print requests for destination1.
lpmove moves individual requests or entire queues only within an instance of a print service, not between a local and a remote queues or local queues on different instances of a print service. Requests can only be moved if the print service or protocol supports it. The LP print server and IPP print protocol both support moving requests between queues. The BSD print protocol does not.
When moving requests, lpmove does not check the acceptance status of the destination to which the print requests are being moved (see accept(1M)). lpmove does not move requests that have options (for example, content type or requiring a special form) that cannot be handled by the new destination.
The following operands are supported:
The specific print request to be moved. Specify request-ID as the identifier associated with a print request as reported by lpstat. See lpstat(1).
The name of the printer or class of printers (see lpadmin(1M)) to which lpmove moves a specified print request. Specify destination using atomic, URI-style (scheme://endpoint), POSIX-style (server:destination) syntax.
The name of the destination from which lpmove moves all print requests. Specify destination using atomic, URI-style (scheme://endpoint), POSIX-style (server:destination) syntax.
The following exit values are returned:
An error occurred.
System printer configuration database
User-configurable printer database
LDAP version of /etc/printers.conf
NIS version of /etc/printers.conf
NIS+ version of /etc/printers.conf
See attributes(5) for descriptions of the following attributes:
When IPP is in use, the user is prompted for a passphsrase if the remote print service is configured to require authentication.