|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 10 8/11 Information Library|
- store mail in a mailbox
/usr/lib/mail.local [-f sender] [-d] recipient
mail.local reads the standard input up to an end-of-file and appends it to each user's mail file (mailbox). This program is intended to be used by sendmail(1M) as a mail delivery agent for local mail. It is not a user interface agent.
Messages are appended to the user's mail file in the /var/mail directory. The user must be a valid user name.
Each delivered mail message in the mailbox is preceded by a "Unix From line" with the following format:
From sender_address time_stamp
The sender_address is extracted from the SMTP envelope address (the envelope address is specified with the -f option).
A trailing blank line is also added to the end of each message.
The mail files are locked with a .lock file while mail is appended.
The mail files are created with mode 660, owner is set to recipient, and group is set to mail. If the ``biff'' service is returned by getservbyname(3SOCKET), the biff server is notified of delivered mail. This program also computes the Content-Length: header which will be used by the mailbox reader to mark the message boundary.
The following options are supported:
Specifies the "envelope from address" of the message. This flag is technically optional, but should be used.
Specifies the recipient of the message. This flag is also optional and is supported here for backward compatibility. That is, mail.local recipient is the same as mail.local -d recipient.
Turn on LMTP mode.
Specify the sender's name (for backward compatibility).
Do not advertise 8BITMIME support in LMTP mode.
Return a permanent error instead of a temporary error if a mailbox exceeds quota.
The following operand is supported:
The recipient of the mail message.
Used to set the appropriate time zone on the timestamp.
The following exit values are returned:
An error occurred.
user's mail file
See attributes(5) for descriptions of the following attributes: