|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 10 8/11 Information Library|
- create database maps for sendmail
makemap [-N] [-d] [-f] [-o] [-r] [-s] [-v] [-C file] [-c cachesize] [-D commentchar] [-e] [-l] [-t delim] [-u] mantype mapname
makemap creates the database maps used by the keyed map lookups in sendmail(1M). makemap reads from the standard input and outputs to the specified mapname.
In all cases, makemap reads lines from the standard input consisting of two words separated by whitespace. The first is the database key, the second is the value. The value may contain %n strings to indicated parameter substitution. Literal percents should be doubled (%%). Blank lines and lines beginning with # are ignored.
makemap handles three different database formats. Database format is selected using the maptype parameter. See OPERANDS.
The following options are supported:
Use the specified hash and B-Tree cache size (cachesize).
Use the specified sendmail configuration file (file) for looking up the TrustedUser option.
Allow duplicate keys in the map. This is only allowed on B-Tree format maps. If two identical keys are read, both be inserted into the map.
Use the specified character to indicate a comment (which is ignored) instead of the default of '#'.
Allow empty value (right hand side).
Normally, all upper case letters in the key are folded to lower case. This flag disables that behavior. This is intended to mesh with the -f flag in the K line in sendmail.cf. The value is never case folded.
List supported map types.
Include the null byte that terminates strings in the map. This must match the -N flag in the K line in sendmail.cf
Append to an old file. This allows you to augment an existing file.
Allow replacement of existing keys. Normally makemap complains if you repeat a key, and does not do the insert.
Ignore safety checks on maps being created. This includes checking for hard or symbolic links in world writable directories.
Use the specified delimiter (delim) instead of whitespace.
Dump (unmap) the content of the database to standard output. Note that, if the -t option is also provided, the specified delimiter is used when the content is dumped instead of whitespace.
Verbosely print what it is doing.
The following operands are supported:
File name of the database map being created.
Specifies the database format. The following maptype parameters are available:
Specifies DBM format maps.
Specifies B-Tree format maps.
Specifies hash format maps.
See attributes(5) for descriptions of the following attributes: