|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 10 8/11 Information Library|
- daemon to monitor metadevices
/usr/sbin/mdmonitord [-t time_interval]
The mdmonitord utility is part of Solaris Volume Manager. It monitors and checks RAID1 (mirrors), RAID5 and hot spares.
There are two methods for checking:
At fixed time intervals.
When a RAID-1 (mirror), RAID-5, or hot spare fails. A failure generates an error event which triggers a check of these metadevices.
The following options are supported:
Time interval in seconds. The default value is 0, which causes probes to occur only upon an error. If you want to run mdmonitord at a regular interval, a value of 1800 (seconds, every half hour) is recommended as a starting point.
The following exit values are returned:
An error occurred.
See attributes(5) for descriptions of the following attributes:
svcs(1), metaclear(1M), metadb(1M), metadetach(1M), metahs(1M), metainit(1M), metaoffline(1M), metaonline(1M), metaparam(1M), metarecover(1M), metarename(1M), metareplace(1M), metaroot(1M), metaset(1M), metassist(1M), metastat(1M), metasync(1M), metattach(1M), svcadm(1M), md.tab(4), md.cf(4), mddb.cf(4), md.tab(4), attributes(5), smf(5), md(7D)
Since frequent probes can affect performance, it is recommended that the intervals between probes be limited.
The mdmonitord service is managed by the service management facility, smf(5), under the service identifier: