|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 10 8/11 Information Library|
- mount xmemfs file systems
mount -F xmemfs [generic_options] -o[largebsize,]size=sz [-O] special mount_point
xmemfs is obsolete. Users requiring large physical memory should migrate to 64-bit platform support.
xmemfs is an extended memory file system which provides file system semantics to manage and access large amounts of physical memory which can exceed 4 GB in size.
mount attaches a xmemfs file system to the file system hierarchy at the pathname location mount_point, which must already exist. If mount_point has any contents prior to the mount operation, these remain hidden until the file system is once again unmounted. The attributes (mode, owner, and group) of the root of the xmemfs filesystem are inherited from the underlying mount_point, provided that those attributes are determinable. If not, the root's attributes are set to their default values.
The special argument is not currently used by xmemfs but a placeholder, (such as xmem), needs to be specified nevertheless.
See mount(1M) for the list of supported generic_options.
Specify xmemfs file system specific options in a comma-separated list with no intervening spaces. If invalid options are specified, a warning message is printed and the invalid options are ignored.
The size=sz specific option is required.
The following options are available:
The sz argument specifies the desired size of this particular xmemfs file system. If the sz argument has a k suffix, the number is interpreted as kilobytes. An m suffix is interpreted as megabytes and g is interpreted as gigabytes. A sz specified with no suffix is interpreted as bytes.
In all cases, the actual size of the file system is the number of bytes specified, rounded up to the physical pagesize of the system or to the large page size if largebsize is specified.
This specific_option is required.
If largebsize is specified, xmemfs uses the large memory page size as the file system block size. On IA32, the large memory page size with mmu36 which supports PAE (Physical Address Extension) is 2 MB. The large memory page size without mmu36/PAE is 4 MB. If there is no large page support, the file system block size is PAGESIZE.
Overlay mount. Allow the file system to be mounted over an existing mount point, making the underlying file system inaccessible. If a mount is attempted on a pre-existing mount point without setting this flag, the mount fails, producing the error device busy.
table of mounted file systems
See attributes(5) for descriptions of the following attributes:
If the directory on which a file system is to be mounted is a symbolic link, the file system is mounted on the directory to which the symbolic link refers, rather than on top of the symbolic link itself.
The only file types allowed on xmemfs are directories and regular files. The execution of object files resident in xmemfs is not supported. Execution is prevented by not allowing users to set execute permissions on regular files.
Support for xmemfs may be removed in a future release of Solaris.