|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 10 8/11 Information Library|
- generate message IDs
The msgid utility generates message IDs.
A message ID is a numeric identifier that uniquely identifies a message. Although the probability of two distinct messages having the same ID is high, this can be greatly reduced with the appropriate priority or facility.level designator (see syslogd(1M)). Specifically, the message ID is a hash signature on the message's unexpanded format string, generated by STRLOG_MAKE_MSGID() as defined in <sys/strlog.h>.
syslogd(1M) is a simple filter that takes strings as input and produces those same strings, preceded by their message IDs, as output. Every message logged by syslogd(1M) includes the message ID. The message ID is intended to serve as a small, language-independent identifier.
Example 1 Using the msgid command to generate a message ID
The following example uses the msgid command to generate a message ID for the echo command.
example# echo hello | msgid205790 hello
Example 2 Using the msgid command to generate a message catalog
The following example uses the msgid command to enumerate all of the messages in the binary ufs, to generate a message catalog.
example# strings /kernel/fs/ufs | msgid 137713 free: freeing free frag, dev:0x%lx, blk:%ld, cg:%d, ino:%lu, fs:%s 567420 ialloccg: block not in mapfs = %s 845546 alloc: %s: file system full ...
See attributes(5) for descriptions of the following attributes: