|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 10 8/11 Information Library|
- generate a list of path names versus i-numbers
ncheck [-F FSType] [-V] [generic_options] [-o FSType-specific_options] [special]...
ncheck with no options generates a path-name versus i-number list of all files on special. If special is not specified on the command line the list is generated for all specials in /etc/vfstab which have a numeric fsckpass. special is the raw device on which the file system exists.
Specify the FSType on which to operate. The FSType should either be specified here or be determinable from /etc/vfstab by finding an entry in the table that has a numeric fsckpass field and an fsckdev that matches special.
Echo the complete command line, but do not execute the command. The command line is generated by using the options and arguments provided by the user and adding to them information derived from /etc/vfstab. This option may be used to verify and validate the command line.
Options that are commonly supported by most FSType-specific command modules. The following options are available:
Limit the report to the files on the i-list that follows. The i-list must be separated by commas with no intervening spaces.
Print the names “.” and “. .” which are ordinarily suppressed.
Report only special files and files with set-user-ID mode. This option may be used to detect violations of security policy.
Specify FSType-specific_options in a comma separated (without spaces) list of suboptions and keyword-attribute pairs for interpretation by the FSType-specific module of the command.
See largefile(5) for the description of the behavior of ncheck when encountering files greater than or equal to 2 Gbyte ( 231 bytes).
list of default parameters for each file system
See attributes(5) for descriptions of the following attributes:
This command may not be supported for all FSTypes.