|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 10 8/11 Information Library|
- display the contents of a System Management BIOS image
smbios [-BeOsx] [-i id] [-t type] [-w file] [file]
The smbios utility displays the contents of the System Management BIOS (SMBIOS) image exported by the current system or stored in a file. SMBIOS is an industry-standard mechanism for low-level system software to export hardware configuration information to higher-level system management software. The SMBIOS data format itself is defined by the Distributed Management Task Force (DMTF). Refer to http://www.dmtf.org for more information about SMBIOS and to obtain a copy of the SMBIOS specification and implementation guidelines.
The SMBIOS image consists of a table of structures, each describing some aspect of the system software or hardware configuration. By default, smbios displays the entire contents of the current SMBIOS image. If the -s option is specified, smbios displays a summary of the structures that are present in the image. If the -w option is specified, smbios writes a copy of the SMBIOS image to the specified file. smbios can then be applied to the resulting file to display its content.
smbios attempts to display each structure and its content in a human- readable fashion. If smbios does not recognize a structure's type or content, the raw hexadecimal data for the structure is displayed.
The following options are supported:
Disable header validation for broken BIOSes.
By default, smbios attempts to validate the SMBIOS header by verifying the anchor strings, header checksums, and version number. This option might be necessary when a BIOS has a non-compliant header.
Display the contents of the SMBIOS entry point rather than the contents of the SMBIOS structure table.
Display only the specified structure, named by its integer id.
Display obsolete structure types.
By default, smbios elides output for structures whose type is marked as obsolete in the DMTF SMBIOS specification.
Display only a summary listing of the structure identifiers and types, instead of the content of each selected structure.
Display only those structures whose type matches the specified integer type, as defined the DMTF SMBIOS specification.
Write a copy of the SMBIOS image to the specified file and exit.
The SMBIOS entry point is written to the start of the file with its structure table address set to the file offset of the structure table, and a new entry point checksum is computed.
Display raw hexadecimal data for the selected structures in addition to human-readable output.
By default, hexadecimal data is only displayed if smbios cannot display human-readable output for the selected structures.
The following operands are supported:
Specifies an alternate SMBIOS image to display instead of the current system's SMBIOS image.
The following exit values are returned:
Successful completion. All structures in the SMBIOS image were examined successfully.
A fatal error occurred, such as failure to open the specified file or device, or corruption in the image.
Invalid command-line options were specified.
Kernel SMBIOS image device. This device special file is used to export a snapshot of the current system SMBIOS image.
See attributes(5) for descriptions of the following attributes:
The command-line options are Evolving. The human-readable output is Unstable.
System Management BIOS Reference Specification (see http://www.dmtf.org)
The implementation of a System Management BIOS image is entirely at the discretion of the system and BIOS vendors. Not all systems export an SMBIOS. The SMBIOS structure content varies widely between systems and BIOS vendors and frequently does not comply with the guidelines included in the specification. Some structure fields might not be filled in by the BIOS at all, and others might be filled inwith non-conforming values.