|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 10 8/11 Information Library|
- manage the server for the Sun Web Console
/usr/sbin/smcwebserver subcommand options
The smcwebserver utility manages the Sun Web Console server. Sun Web Console is a browser-based interface that performs systems management. System administrators can manage systems, devices and services from the console.
When the console webserver is running, you can view the console by opening a browser and pointing to:
host is the machine where the console has been installed and the console server is running.
The smcwebserver service is managed by the service management facility (SMF) (see smf(5)), under the fault management resource identifier (FMRI):
Administrative actions on this service, such as enabling, disabling, or requesting restart, can be performed using svcadm(1M). smcwebserver can only be started by the superuser or someone in the Primary Administrator role.
The configuration properties of this service can be modified with svccfg(1M).
smcwebserver supports an SMF property that controls remote access to the Sun Web Console server. The property, options/tcp_listen, has a default value of false, which disallows remote access. The value true allows remote access. See EXAMPLES.
The following subcommands are supported:
Disable automatic start or stop during system boot or shutdown. Until the administrator reruns the script with the smcwebserver enable subcommand the webserver can be started/stopped only when the administrator executes the script manually using the following command:
# /usr/sbin/smcwebserver [start | stop]
Enable the webserver to startup automatically during subsequent system boot and gracefully stop during system shutdown.
Stop and subsequently start the console webserver.
The format of the restart subcommand is:
restart [-U username]
Start the console webserver.
The format of the start subcommand is:
start [-U username]
Stop the console webserver.
Display status of the console webserver.
The format of the status subcommand is:
The following options are supported:
The user identity to run the server as. Once the server has successfuly started under the specified identity, all subsequent starts will automatically be done under that identity until you change it via this option, or by changing the com.sun.web.console.user configuration property via the smreg(1M) command. The default is to run the server under the noaccess identity.
Display non-localized output suitable for programmatic parsing. If the server is running, the output will be:
If the server is not running, the output will be:
Display the usage statement.
Display console version information.
Example 1 Displaying the Usage Statement
The following command displays the smcwebserver usage statement:
% smcwebserver --help
Example 2 Determining if the Server is Running
The following shell command will start the server if it is not already running.
ans=`smcwebserver -p | grep running | cut -d"=" -f2` if [ "$ans" = "no" ]; then smcwebserver start fi
Example 3 Using SMF Property to Allow Remote Access
The following sequence of commands allows remote access to the Sun Web Console server.
# svccfg -s svc:/system/webconsole \ setprop options/tcp_listen = true # svcadm refresh svc:/system/webconsole
See environ(5) for descriptions of the following environment variables that affect the execution of smcwebserver:
If you do not specify this environment variable, your PATH is searched for a suitable java. Otherwise, depending on the OS, the following default locations are used:
The following exit values are returned:
An error occurred.
See attributes(5) for descriptions of the following attributes: