|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 10 8/11 Information Library|
- communicate with a network entity using SNMP GETBULK requests
snmpbulkget [application options] [common options] oid [oid]...
The snmpbulkget utility is an SNMP application that uses the SNMP GETBULK operation to send information to a network manager. You can specify one or more object identifiers (OIDs) on the command line. Each variable name must be entered in the format specified in snmp_variables(4).
If the network entity has an error processing the request packet, an error packet is returned and a message displayed, indicating the way in which the request was malformed.
The following options are supported:
Set the non-repeaters field in the GETBULK PDU. This specifies the number of supplied variables that should not be iterated over. The default is 0.
Set the max-repetitions field in the GETBULK PDU. This specifies the maximum number of iterations over the repeating variables. The default is 10.
In addition to this option, snmpbulkget takes the common options described in the snmpcmd(1M) manual page.
Example 1 Retrieving Multiple Objects
The following snmpbulkget command retrieves the variable system.sysDescr.0 (which is the lexicographically next object to system) and the first five objects in the ifTable:
# snmpbulkget -v2c -Cn1 -Cr5 -Os -c public zeus system ifTable
This command produces output such as the following:
sysDescr.0 = STRING: "SunOS zeus.net.cmu.edu 4.1.3_U1 1 sun4m" ifIndex.1 = INTEGER: 1 ifIndex.2 = INTEGER: 2 ifDescr.1 = STRING: "lo0" [...]
See attributes(5) for descriptions of the following attributes:
A usage syntax error. A usage message is displayed. Also used for timeout errors.
An error occurred while executing the command. An error message is displayed.
As the name implies, snmpbulkget uses the SNMP GETBULK message, which is not available in SNMPv1.