|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 10 8/11 Information Library|
- fbconfig module for configuring the Sun XVR-600 and XVR-1200 Graphics Devices
fbconfig [-dev device-filename] [-res video-mode [now | try] [noconfirm | nocheck]] [-file machine | system] [-deflinear true | false] [-defoverlay true | false] [-linearorder first | last] [-outputs swapped | direct] [-slave disable | multiview | stereo | bnc] [-accum enable | disable] [-g gamma-correction-value] [-gfile gamma-correction-file] [-fake8 enable | disable] [-doublewide enable | disable] [-doublehigh enable | disable] [-multisample available | disable | forceon] [-samples 1 | 2 | 4 | 8 | 16 | adaptive] [-defdepth 8 | 24] [-offset xval yval] [-propt] [-prconf] [-defaults]
fbconfig [-propt] [-prconf]
fbconfig [-help] [-res ?]
SUNWjfb_config configures the Sun XVR-600 and XVR-1200 Graphics Accelerator and some of the X11 window system defaults for the Sun XVR-600 and XVR-1200.
You can specify options for only one device at a time. If you want to specify options for multiple devices, you must invoke the SUNWjfb_config utility multiple times.
You can use the SUNWjfb_config utility to specify Sun XVR-600 or XVR-1200 specific options. Use the normal window system options to specify default depth, default visual class and so forth. Specify these as device modifiers on the command line. See Xsun(1)
You can also specify which OWconfig file to update. By default, SUNWjfb_config updates the machine-specific file in the /etc/openwin. You can specify an alternate file by using the -file option. For example, the system-global OWconfig file in the /usr/openwin directory tree can be updated instead.
Both of these standard OWconfig files can only be written by root. Consequently, the SUNWjfb_config program, which is owned by the root user, always runs with setuid root permission.
The first form of SUNWjfb_config shown in the SYNOPSIS section stores the specified options in the OWconfig file. These options initialize the Sun XVR-600 and XVR-1200 device the next time the window system is run on that device. Updating options in the OWconfig file provides persistence of these options across window system sessions and system reboots.
The second and third forms which invoke only the -prconf, -propt, -help, and -res ? options, do not update the OWconfig file. Additionally, for the third form all other options are ignored.
The following options are supported:
Enable or disable frame buffer memory. If enabled, frame buffer memory is allocated for the accelerated accumulation buffer for windows. If disabled, software accumulation buffering for windows is used. Accelerated accumulation buffers for pBuffers are always available as memory allows.
Specify the SunSun XVR-600 or XVR-1200 special file. The default is /dev/fbs/jfb0.
Reset all option values except -dev to their default values.
This option sets the resolution override to none which implies the last video mode setting is preserved. If no monitor is attached, the video mode is set to 1152x900x66.
Both the Sun XVR-600 and XVR-1200 possess two types of visuals: linear and nonlinear. Linear visuals are gamma corrected and nonlinear visuals are not. There are two visuals that have both linear and nonlinear versions: 24-bit TrueColor and 8-bit StaticGray.
If the value of this option is true, the default visual is set to the linear visual that satisfies other specified default visual selection options (specifically, the Xsun defdepth and defclass options; see Xsun(1)). If false, or if there is no linear visual that satisfies the other default visual selection options, the non-linear visual specified by these other options is chosen as the default visual. This option cannot be used when the -defoverlay option is present, because the Sun XVR-600 and XVR-1200 do not possess a linear overlay visual.
Both the Sun XVR-600 and XVR-1200 provide an 8-bit PseudoColor visual whose pixels are disjoint from the rest of the visuals. This is called the overlay visual. Windows created in this visual will not damage windows created in other visuals. The converse, however, is not true. Windows created in other visuals will damage overlay windows.
If the value of this option is true, the overlay visual is the default visual. If false, the nonoverlay visual that satisfies the other default visual selection options, such as defdepth and defclass, is chosen as the default visual. See Xsun(1). Whenever -defoverlay true is used, the default depth and class chosen on the openwin command line must be 8-bit PseudoColor. If not, a warning message is printed and the -defoverlay option is treated as false. This option cannot be used when the -deflinear option is present, because the Sun XVR-600 and XVR-1200 do not possess a linear overlay visual.
Set the depth (bits per pixel) on the device. Possible values for the -defdepth option are 8 or 24. You must log out of the current window system session and log back in again for the change to take effect. Any depth setting in the Xserver command line takes precedence over what is set using fbconfig. The default is determined by the X Server smf(5) default depth property. You can query this property with the following command:
% /usr/sbin/svccfg -s svc:/application/x11/x11-server listprop \ 'options/default_depth'
Configure the two outputs of the Sun XVR-1200 into one vertical virtual display. The default is disable.
This option is not applicable to the Sun XVR-600 device.
Configure the two outputs of the Sun XVR-1200 into one horizontal virtual display. The default is disable.
This option is not applicable to the Sun XVR-600 device.
Enable or disable simple 8 bit X windows to be rendered without a hardware colormap to reduce colormap flashing. You might notice performance reductions. The default is disable.
Specifies which OWconfig file to update. If machine is specified, the machine-specific OWconfig file in the /etc/openwin directory tree is updated. If system is specified, the global OWconfig file in the /usr/openwin directory tree is updated. If the specified file does not exist, it is created. This option has no effect unless other options are specified. The default is machine.
Change the gamma correction value. All linear visuals provide gamma correction. By default, the gamma correction value is 2.22. Any value less than zero is illegal. This option can be used while the window system is running. Changing the gamma correction value affects all of the windows displayed by linear visuals.
Load the gamma correction table from the file specified by gamma-correction file. You should format this file to provide the gamma correction values for R, G, and B channels on each line. Specify each value in hexadecimal format and separate it from another value by at least 1 space. The gamma-correction file file should provide 1024 such triplets.
You can load the gamma correction table with this option can while the window system is running. The new gamma correction affects all the window being displayed using the linear visuals. When gamma correction is done using a user specified table, the gamma correction value is undefined. By default, the window system assumes a gamma correction value of 2.22 and loads the gamma table it creates corresponding to this value.
The following is an example of a gamma-correction file file:
0x000 0x000 0x000 0x001 0x001 0x001 0x002 0x002 0x002 ... ... 0x3ff 0x3ff 0x3ff
Print a list of the SUNWjfb_config command line options, along with a brief explanation of each.
If set to disable, no multisample is possible. If set to available, multisample is possible but is selected on a per-window basis using a library interface. If set to forceon, all Sun OpenGL windows are rendered using multisampling. Query the number of samples used with -propt or the xglinfo(1) utility. The xglinfo utility can return the number of multisamples if -multisample is set to enable. The default is disable.
Adjust the position of the specified stream by the value specified. This option is only implemented in -doublewide and -doublehigh modes. For -doublewide, use the xval to position the rightmost stream. Negative is left (overlaps with the left stream). For -doublehigh, use the yval to position the bottom stream. Negative is up (overlaps with top stream). The default is [0, 0].
If either -doublewide or -doublehigh are enabled, reverse the position of the two outputs relative to each other. The default is direct.
Print the current values of all Sun XVR-600 and XVR-1200 options in the OWconfig file specified by the -file option for the device specified by the -dev option. Print the values of options as they will be in the OWconfig file after the call to SUNWjfb_config completes.
This is a typical display:
# fbconfig -dev jfb2 -propt --- OpenWindows Configuration for /dev/fbs/jfb2 --- OWconfig: machine Video Mode: 1280x1024x60 Accum: Enabled (allocate an accumulation buffer if possible) Multisample Information: Multisample Mode: Disabled (multisample visuals will not be available) Samples Per Pixel: N/A (multisampling disabled) Screen Information: DoubleWide: Disabled DoubleHigh: Disabled Output Configuration: Direct Offset/Overlap: [0, 0] Visual Information: Default Visual: Non-Linear Normal Visual Visual Ordering: Linear Visuals are last Gamma Correction Value: 2.22 Gamma Correction Table: Available Fake8 rendering: disabled Default Visual Depth (defdepth): 8
Print the Sun XVR-1200 hardware configuration. This is a typical display:
# fbconfig -dev jfb2 -prconf --- Hardware Configuration for /dev/fbs/jfb2 --- Type: XVR-1200 Sun Serial Number: 3753101000022 Hardware Revision: -01 rev01 Manufacture Date: Thu Aug 8 12:54:16 2002 PROM Information: @(#)jfb.fth 1.8 02/10/18 SMI Monitor/Resolution Information: EDID Data: Available - EDID version 1 revision 3 Monitor type: Sun P/N 365-1415 S/N 0216ME0353 Current resolution setting: 1280x1024x60 (custom) Monitor possible resolutions: 1024x768x60, 1024x768x70, 1024x768x75, 1152x900x66, 1280x1024x60, 1280x1024x75, 1280x1024x76, 640x480x60, 800x600x75 Framelock Configuration: Slave Mode: Disabled Memory Information: Total Video Memory: 134217728 Video Memory Used: 15728640 Total Texture Memory: 268435456 Texture Memory Used: 0 Total Display List Memory: 33554432
Specify the video mode of the monitor connected to the specified Sun XVR-600 or XVR-1200 device.
The -res option requires you to specify the video-mode. You can specify video-mode in the format of widthxheightxrate or as a symbolic name.
Specify video-mode in the format of widthxheightxrate, where width is the screen width in pixels, height is the screen height in pixels, and rate is the vertical frequency of the screen refresh.
You can use the s suffix to specify stero video modes. The s suffix of 960x680x112s and 960x680x108s means that these are stereo video modes.
The -res option also accepts formats with @ (at sign) in front of the refresh rate instead of x, (280x1024@76). Some video-modes, supported by Sun XVR-600 and XVR-1200, might not be supported by the monitor.
The list of video-modes supported by the Sun XVR-600 and XVR-1200 device and the monitor can be obtained by running SUNWjfb_config with the -res ? option. See SYNOPSIS.
Some video modes have symbolic names defined for them. Instead of using the widthxheightxrate format, you can specify one of the symbolic names as the argument to the -res option. The meaning of the symbolic name none is that when the window system is run the screen resolution will be the video mode that is currently programmed in the device.
The following symbolic names and their corresponding video modes are supported:
svga 1024x768x60 1152 1152x900x76 1280 1280x1024x76 stereo 960x680x112s ntsc 640x480x60i pal 768x575x50i none Programmed video mode
The -res option accepts additional, optional arguments immediately following the video mode specification. The following additional, optional arguments are supported:
If present, updates the video mode be updated in the OWconfig file. Programs the Sun XVR-600 or XVR-1200 device to display the video mode. This is useful for changing the video mode before starting the window system.
Do not use this suboption with SUNWjfb_config while the configured device is being used, for example, while running the window system. Unpredictable results can occur.
If you want to run SUNWjfb_config with the now suboption, first bring the window system down. If you use the now suboption within a window system session, the video mode is changed immediately. The width and height of the affected screen will not change until the window system is exited and re-entered again. Additionally, the system might not recognize changes in stereo mode. This usage is discouraged.
Using the -res option, the user could potentially put the system into an unusable state, a state where there is no video output. This can happen if there is ambiguity in the monitor sense codes for the particular code read. To reduce the chance of this, the default behavior of SUNWjfb_config is to print a warning message to this effect and to prompt the user to find out if it is okay to continue. The -noconfirm option instructs SUNWjfb_config to bypass this confirmation and to program the requested video mode anyway. This option is useful when SUNWjfb_config is run from a shell script.
If present, the normal error checking based on the monitor sense code is suspended. The video mode specified is accepted regardless of whether it is appropriate for the currently attached monitor. This option is useful if a different monitor is to be connected to the Sun XVR-600 or XVR-1200 device. Use of this option implies noconfirm.
If present, programs the specified video mode on a trial basis. You are asked to confirm the video mode by entering a y within 10 seconds. You can terminate the trial before 10 seconds by entering any character but y or RETURN.
Terminating the trial by entering a character other than y or RETURN restores the previous video mode. SUNWjfb_config does not change the video mode in the OWconfig file. Other specified options still take effect. If a carriage return is typed, the user is prompted for a yes or no answer on whether to keep the new video mode. This option implies the now suboption.
If you want to run SUNWjfb_config with the now suboption, first bring the window system down. If you use the now suboption within a window system session, the video mode is changed immediately. The width and height of the affected screen will not change until the window system is exited and re-entered again. Additionally, the system might not recognize changes in stereo mode. This usage is strongly discouraged.
Request the number of samples to compute per display pixel. The requested number of samples per pixel will be used if -multisample is not disabled and resources exist for the request. If set to adaptive, variable multisampling is possible, whith the minimum samples per pixel set to 2. Query the number of samples used with -propt or the xglinfo(1) utility. The xglinfo utility can return the number of multisamples after you specify the option -multisample enable. The default is 16.
Enable or disable a specific port. Specify multiview for the DB9 connector, stereo for the mini-DIN connector, or bnc for the bnc connector. Specify disable to disable a specific port. If set, the option is an exclusive slave instance in the Framelock Configuration Setup. The default is disable.
multiview and bnc are only applicable to the Sun XVR-1200 device.
For a given invocation of SUNWjfb_config command line if an option does not appear on the command line, the corresponding OWconfig option is not updated; it retains its previous value.
When the window system is run, if an option has never been specified by way of SUNWjfb_config, a default value is used. The options and their corresponding defaults are as follows:
The default for the -res option of none means that when the window system is run the screen resolution will be the video mode that is currently programmed in the device.
This provides compatibility for users who are used to specifying the device resolution through the PROM. This means that the PROM ultimately determines the default video mode.
Example 1 Switching the Resolution of the Monitor Type
The following example switches the monitor type to 1280 × 1024 at 76 Hz resolution:
example% fbconfig –dev jfb0 –res 1280x1024x76
Device special file for the XVR-600 or XVR-1200 high performance single screen
Device special file for the XVR-1200 first video out
Device special file for the XVR-1200 second video out
jfb microcode file
jfb microcode loader file
See attributes(5) for descriptions of the following attributes:
The Xsun(1) man page, which is not part of the SunOS man page collection.