|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 10 8/11 Information Library|
- fbconfig module for configuring the XVR-50 and the Sun XVR-100 Graphics Accelerator
For XVR-50: /usr/lib/fbconfig/SUNWpfb_config [-dev device-filename] [-res video-mode [now | try] [noconfirm | nocheck]] [-file machine | system] [-fake8 enable | disable] [-g enable | disable | gamma-value] [-defaults]
For Sun XVR-100: /usr/lib/fbconfig/SUNWpfb_config [-dev device-filename] [-res video-mode [now | try] [noconfirm | nocheck]] [-file machine | system] [-fake8 enable | disable] [-g enable | disable | gamma-value] [-doublewide enable | disable] [-doublehigh enable | disable] [-outputs swapped | direct] [-depth 8 | 24] [-offset xval yval] [-defaults]
For Sun XVR-100 and XVR-50: /usr/lib/fbconfig/SUNWpfb_config [-pt] [-prconf]
/usr/lib/fbconfig/SUNWpfb_config [-help] [-res \?]
SUNWpfb_config is the XVR-50 and the Sun XVR-100 device dependent layer for fbconfig(1M). It configures the XVR-50 and the Sun XVR-100 Graphics Accelerator and some of the X11 window system defaults for the XVR-50 and Sun XVR-100. The Sun XVR-100 provides the capability to drive two monitors, each with a unique video stream (Stream #1 and Stream #2). The XVR-50 drives one video stream.
The first two forms of SUNWpfb_config shown in the SYNOPSIS section sets options for the XVR-50 and the Sun XVR-100 devices. It stores the specified options in the OWconfig file. These options initialize the XVR-50 and the Sun XVR-100 devices the next time the window system is run on that device. Updating options in the OWconfig file provides persistence of these options across window system sessions and system reboots. The XVR-50 and the Sun XVR-100 devices are immediately programmed if you specify the -res now.
The third form, which invokes the -prconf and -propt options, queries the XVR-50 and the Sun XVR-100 device for status.
The fourth form, which invokes the -help, and -res \? options, provides instruction on using SUNWpfb_config. Additionally, for the fourth form all other options are ignored.
You can only specify options for only one XVR-50 or Sun XVR-100 device at a time. If you want to specify options for multiple XVR-50 or Sun XVR-100 devices, you must use multiple invocations of the SUNWpfb_config command.
You can only use SUNWpfb_config to specify XVR-50 or Sun XVR-100 specific options. You can use the normal window system options to specify the default depth, default visual class and so forth as device modifiers on the command line when the X Server is started. See dtlogin(1) for information regarding the Xservers File.
You can also specify the OWconfig file to update. The machine-specific file in the /etc/openwin directory tree is updated by default. You can used the -file option to specify an alternate file. For example, you can update the system-global OWconfig file in the /usr/openwin directory tree instead.
The following options are supported:
Reset all option values to their default values.
Set the depth (bits per pixel) for the window system. Possible values for the -depth option are 8 or 24. You must log out of the current window system session and log back in again for the change to take effect. Any depth setting in the Xserver command line takes precedence over what is set using fbconfig. The default is 8. This option is only available with Solaris 8 or Solaris 9.
Specify the XVR-50 or the Sun XVR-100 special file. The default is /dev/fb.
Configure the two outputs of the Sun XVR-100 into one vertical virtual display. You must log out of the current window system session and log back in again for the change to take effect. The default is disable.
Configure the two outputs of the Sun XVR-100 into one horizontal virtual display. You must log out of the current window system session and log back in again for the change to take effect. The default is disable.
Enable or disable simple 8 bit X windows to be rendered without a hardware colormap to reduce colormap flashing. You might notice performance reductions. You must log out of the current window system session and log back in again for the change to take effect. The default is disable.
Specifies which OWconfig file to update. If machine is specified, the machine-specific OWconfig file in the /etc/openwin directory tree is updated. If system is specified, the global OWconfig file in the /usr/openwin directory tree is updated. If the specified file does not exist, it is created. This option has no effect unless other options are specified. The default is machine.
This option allows you to change the gamma correction value. All linear visuals provide gamma correction. By default , the gamma correction value is 2.22. Any value less than zero is illegal.
This option can be used while the window system is running. Changing the gamma correction value will affect all the windows being displayed using the linear visuals. You must log out of the current window system session and log back in again for the change to take effect. The default is disable.
Print a list of the SUNWpfb_config command line options, along with a brief explanation of each option.
Adjust the position of the secondary stream on the Sun XVR-100. This option is currently implemented only for the -doublewide and -doublehigh modes. For -doublewide, use the xval to position the DVI stream, if -outputs are direct (VGA stream if -outputs are swapped). A negative value specifies the overlapped region with the primary stream. This is similar for -doublehigh, except the yval is used. Positive values are treated as 0. You must log out of the current window system session and log back in again for the change to take effect. The default is [0, 0].
Reverse the positions of the -doublewide or -doublehigh outputs relative to each other on the Sun XVR-100. You must log out of the current window system session and log back in again for the change to take effect. The default is direct.
Print the current values of all XVR-50 and Sun XVR-100 options in the OWconfig file specified by the -file option for the device specified by the -dev option. Print the values of options as they will be in the OWconfig file after the call to SUNWpfb_config completes.
This is a typical display for the Sun XVR-100:
--- Graphics Configuration for /dev/fbs/pfb0 --- OWconfig: machine Video Mode: not set Depth: not set Screen Information: Doublewide: Disable Doublehigh: Disable Offset/Overlap: [0.0] Output Configuration: Direct Fake8 Rendering: Disable Gamma Configuration: Disable
Print the XVR-50 and Sun XVR-100 hardware configuration.
This is a typical display:
--- Hardware Configuration for /dev/fbs/pfb0 --- Type: XVR-100 ASIC: version 0x5159 REV : version 0x3000000 PROM: version 4.2 Monitor/Resolution Information: EDID Data: Not Available Current resolution setting: 1152x900x66 Depth Information: Possible depths: 8, 24 Current depth: 8
Specify the video mode that drives the monitor connected to the specified XVR-50 or Sun XVR-100 device.
Video modes are built-in. The -res option requires you to specify the video-mode. You can specify video-mode in the format of widthxheightxrate or as a symbolic name.
Specify video-mode in the format of widthxheightxrate, where width is the screen width in pixels, height is the screen height in pixels, and rate is the vertical frequency of the screen refresh. An example video mode specified in this format is 1280x1024x60.
The -res option also accepts formats with @ preceding the refresh rate instead of x (1280x1024@60).
Some video modes have symbolic names defined for them. Instead of the form widthxheightxrate format, you can specify one of the symbolic names as the argument to the -res option. The meaning of the symbolic name “none” is that when the window system is run the screen resolution is the video mode that is currently programmed in the device.
The following symbolic names and their corresponding video modes are supported:
Name Corresponding Video Mode svga 1024x768x60 1152 1152x900x76 1280 1280x1024x75 none Programmed video mode
Some video-modes, supported by XVR-50 and Sun XVR-100, might not be supported by the monitor. Use the -res \? option to obtain the list of video-modes supported by the XVR-50 and Sun XVR-100 device and the monitor.
The –res option also accepts additional, optional arguments immediately following the video mode specification. The following additional, optional arguments are supported:
If present, the normal error checking based on the monitor sense code is suspended. The video mode specified by the user is accepted regardless of whether it is appropriate for the currently attached monitor. This option is useful if a different monitor is to be connected to the XVR-50 or the Sun XVR-100 device. Use of this option implies noconfirm as well.
You could put the system into an unusable state using the -res option, which has no video output. To reduce the chance of this, the default behavior of SUNWpfb_config is to print a warning message and to ask the user whether to continue. The noconfirm option bypasses this confirmation. This option is useful when you are running SUNWpfb_config from a shell script.
If present, updates the video mode in the OWconfig file and immediately programs the XVR-50 or Sun XVR-100 device to display this video mode. This is useful for changing the video mode before starting the window system.
Do not use this suboption with SUNWpfb_config while the configured device is being used (for example, while running the window system) as unpredictable results can occur.
If you want to run SUNWpfb_config with the now suboption, first bring the window system down, and executed from the console command line. If you use the now option within a window system session, the video mode is changed immediately. The width and height of the affected screen will not change until the window system is exited and re-entered again. Additionally, the system might not recognize changes in stereo mode. This usage is discouraged.
If present, programs the specified video mode on a trial basis. You are asked to confirm the video mode by entering a y within 10 seconds. You can terminate the trial before 10 seconds by entering any character but y or <RETURN>.
This sub-option should not be used with SUNWpfbconfig while the configured device is being used (for example, while running the window system) as unpredictable results may occur. To run SUNWpfbconfig with the try sub-option, the window system should be brought down first, and executed from the console command line.
Print a list of defined video-mode names.
For a given invocation of SUNWpfb_config command line if an option does not appear on the command line, the corresponding OWconfig option is not updated; it retains its previous value.
When the window system is run, if a XVR-50 or Sun XVR-100 option has never been specified by SUNWpfb_config, a default value is used. The options and their corresponding defaults for a XVR-50 are as follows:
Option Default -dev /dev/fb -file machine -res none -fake8 disable -g disable
The options and their corresponding defaults for a Sun XVR-100 are as follows:
Option Default -dev /dev/fb -file machine -res none -fake8 disable -g disable -depth 8 (Solaris 8 and Solaris 9) -doublewide disable -doublehigh disable -outputs direct -offset [0,0]
The default for the -res option none means that when the window system is run, the screen resolution will be the video mode that is currently programmed in the XVR-50 or Sun XVR-100 PROM.
This provides compatibility for users who are used to specifying the device resolution through the XVR-50 or the Sun XVR-100 PROM. On some devices (e.g. GX) this is the only way of specifying the video mode. This means that the PROM ultimately determines the default XVR-50 or Sun XVR-100 video mode.
Example 1 Switching the Monitor Type
The following example switches the monitor type to the resolution of 1280 × 1024 at 60 Hz:
example% fbconfig –res 1280x1024x60
Device special file for XVR-50 or Sun XVR-100 single screen
Device special file for the Sun XVR-100 first video out
Device special file for the Sun XVR-100 second video out
Device special file
See attributes(5) for descriptions of the following attributes: