|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 10 8/11 Information Library|
- manage WCI RSM controller configurations
/usr/platform/sun4u/sbin/wrsmconf create -c controller_id -f config_file
wrsmconf initial -f config_file [-c controller_id]
wrsmconf remove [-c controller_id]
wrsmconf topology [-c controller_id]
wrsmconf dump -c controller_id -f config_file
wrsmconf provides a means to create, install, retrieve, and remove configurations for WCI remote shared memory (RSM) controllers.
The following options are supported:
Create a set of per-node configurations for the specified controller and store them to the file config_file. The created file contains a per-node configuration for each node specified in the input for the specified controller. The file has a checksum on it and cannot be modified directly. This file can be used in a wrsmconf initial call on each node to install the node's configuration into the local driver.
A list of nodes and WCI devices connected to those nodes is read from standard input. For each connected pair of links, specify the nodename (uname -n), safari port id, and link number on both sides of the connection. The format of the information looks like this:
This interface is intended for installing configurations for testing (such as for SunVTS). Only direct-connect, non-striped configurations for 1 to 3 nodes can be specified. FM node ids and RSM hardware addresses are assigned to the specified nodes contiguously and in order starting from 0.
Install the configuration for the local node stored in the file config_file into the driver as the initial configuration for the specified controller. This command fails under the following circumstances:
If controller_id is specified and the configuration in the file is not for the specified controller.
If the file does not contain a valid configuration for the local node or if the checksum in the file shows it has been modified.
If a configuration has already been installed for the controller. If this happens, use wrsmconf remove to remove the existing configuration.
Disable communication through the installed configuration for all controllers or the specified controller and remove the configuration(s) from the driver.
For each installed controller (or for the specified controller), print to stdout the set of nodes this controller is configured to reach, including the nodename, FM node id, and RSM hardware address for each node. The following is example output:
FM Node ID Node Name Controller Instance Controller HW Addr 0 hpc00 0 101 0 hpc00 1 333 1 hpc01 0 102 1 hpc01 1 54 1 hpc01 2 34 2 hpc03 0 103 2 hpc03 1 103 2 hpc03 2 103
Fetch the installed configuration for the specified controller from the driver and store it into the file config_file along with a checksum to protect the data. This configuration can later be installed with the command wrsmconf initial.
This command returns 0 on successful completion, and a non-zero value if an error occured.
See attributes(5) for descriptions of the following attributes: