|Skip Navigation Links|
|Exit Print View|
|man pages section 4: File Formats Oracle Solaris 10 8/11 Information Library|
- file containing service configuration parameters for the DHCP service
The dhcpsvc.conf file resides in directory /etc/inet and contains parameters for specifying Dynamic Host Configuration Protocol (DHCP) service configuration settings, including the type and location of DHCP data store used.
The description of the dhcpsvc.conf file in this man page is informational only. The preferred method of setting or modifying values within the dhcpsvc.conf file is by using dhcpconfig(1M) or the dhcpmgr(1M) utility. Do not edit the dhcpsvc.conf file.
The dhcpsvc.conf file format is ASCII; comment lines begin with the crosshatch (#) character. Parameters consist of a keyword followed by an equals (=) sign followed by the parameter value, of the form:
The following Keyword and Value parameters are supported:
String. automatic or manual. Enables support of BOOTP clients. Default is no BOOTP. Value selects BOOTP address allocation method. automatic to support all BOOTP clients, manual to support only registered BOOTP clients. server mode only parameter.
Integer. Number of seconds the server caches data from data store. Used to improve performance. Default is 10 seconds. server mode only parameter.
Integer. Container version. Used by DHCP administrative tools to identify which version of the public module is being used to administer the data store. CONVER should not be changed manually.
TRUE/FALSE. If TRUE, the DHCP daemon can be run. If FALSE, DHCP daemon process exits immediately if the daemon is started. Default is TRUE. Generic parameter.
String. Defines name service domain that DHCP administration tools use when managing the hosts table. Valid only when HOSTS_RESOURCE is set to nisplus or dns.
String. Defines what name service resource should be used by the DHCP administration tools when managing the hosts table. Current valid values are files, nisplus, and dns.
TRUE/FALSE. Toggles ICMP echo verification of IP addresses. Default is TRUE. server mode only parameter.
String. Comma-separated list of interface names to listen to. Generic parameter.
Integer. Local facility number (0–7 inclusive) to log DHCP events to. Default is not to log transactions. Generic parameter.
Integer. Number of seconds before OFFER cache timeouts occur. Default is 10 seconds. server mode only parameter.
Path to DHCP data tables within the data store specified by the RESOURCE parameter. The value of the PATH keyword is specific to the RESOURCE.
String. Comma-separated list of host names and/or IP addresses of relay destinations. relay mode only parameter.
Integer. Max number of BOOTP relay hops before packet is dropped. Default is 4. Generic parameter.
Integer. Number of minutes between automatic dhcptab rescans. Default is not to do rescans. server mode only parameter.
Data store resource used. Use this parameter to name the public module. See the PATH keyword in dhcp_modules(5).
String. The private layer provides for module-specific configuration information through the use of the RESOURCE_CONFIG keyword. See dhcp_modules(5).
Providers can access RESOURCE_CONFIG using the configure function by specifying an optional service provider layer API function:
int configure(const char *configp);
If this function is defined by the public module provider, it is called during module load time by the private layer, with the contents of the RESOURCE_CONFIG string acquired by the administrative interface (in the case of the dhcpmgr, through the use of a public module-specific java bean extending the dhcpmgr to provide a configuration dialog for this information.
server or relay. Selects daemon run mode. Default is server.
Integer. The number of seconds a secondary server waits for a primary server to respond before responding itself. Default is 20 seconds. This is a server mode only parameter.
Integer. Number of seconds to wait for a response from the DNS server before timing out. If this parameter is present, the DHCP daemon updates DNS on behalf of DHCP clients, and waits the number of seconds specified for a response before timing out. You can use UPDATE_TIMEOUT without specifying a number to enable DNS updates with the default timeout of 15 seconds. If this parameter is not present, the DHCP daemon does not update DNS for DHCP clients.
TRUE/FALSE. Toggles verbose mode, determining amount of status and error messages reported by the daemon. Default is FALSE. Set to TRUE only for debugging. Generic parameter.