|Skip Navigation Links|
|Exit Print View|
|man pages section 4: File Formats Oracle Solaris 10 8/11 Information Library|
- login-based device permissions
The /etc/logindevperm file contains information that is used by login(1) and ttymon(1M) to change the owner, group, and permissions of devices upon logging into or out of a console device. By default, this file contains lines for the keyboard, mouse, audio, and frame buffer devices.
The owner of the devices listed in /etc/logindevperm is set to the owner of the console by login(1). The group of the devices is set to the owner's group specified in /etc/passwd. The permissions are set as specified in /etc/logindevperm.
Fields are separated by TAB and/or SPACE characters. Blank lines and comments can appear anywhere in the file; comments start with a hashmark, ` # ', and continue to the end of the line.
The first field specifies the name of a console device (for example, /dev/console). The second field specifies the permissions to which the devices in the device_list field (third field) will be set. These permissions must be expressed in octal format. For example, 0774. A device_list is a colon-separated list of device names. A device name must be a /dev link. A directory or logical name in the device name may be either one of the following:
a fully qualified name. For example, fbs.
a regular expression. For example, [a-z0-9.]+ (see regexp(5) for more information on regular expressions).
a wildcard character “*” specifying all directory or node names (except “.” and “..”). For example, /dev/fbs/* specifies all frame buffer devices.
Some examples of /etc/logindevperm file entries include:
/dev/usb/[0-9a-f]+[.][0-9a-f]+/[0-9]+/[a-z0-9.]+ /dev/usb/[0-9a-f]+[.][0-9a-f]+/[0-9]+/* /dev/usb/[0-9a-f]+[.][0-9a-f]+/*/*
specify all ugen(7D) endpoints and status nodes.
Drivers may also be specified to limit the permission changes to minor nodes owned by the specified drivers. For example,
/dev/console 0600 /dev/usb/[0-9a-f]+[.][0-9a-f]+/[0-9]+/* \ driver=usb_mid,scsa2usb,usbprn # libusb devices
Due to the persistence of devfs(7FS) minor node management, the user should be logged in as root if the list of minor nodes will be reduced and the devices should all be plugged in.
Upon logout the owner and group of these devices will be reset by ttymon(1M) to owner root and root's group as specified in /etc/passwd (typically other). The permissions are set as specified in the /etc/logindevperm file.
File that contains user group information.
/etc/logindevperm provides a superset of the functionality provided by /etc/fbtab in SunOS 4.x releases.