|Skip Navigation Links|
|Exit Print View|
|man pages section 7: Device and Network Interfaces Oracle Solaris 10 8/11 Information Library|
- Platform-dependent Beep driver for BBC-based hardware.
The bbc_beep driver generates beeps on platforms (including Sun Blade 1000) that use BBC-based registers and USB keyboards. When the KIOCCMD ioctl is issued to the USB keyboard module (see usbkbm(7M)) with command KBD_CMD_BELL/KBD_CMD_NOBELL, usbkbm(7M) passes the request to the bbc_beep driver to turn the beep on and off, respectively.
64–bit ELF kernel driver
See attributes(5) for descriptions of the following attributes:
Writing Device Drivers