|Skip Navigation Links|
|Exit Print View|
|man pages section 7: Device and Network Interfaces Oracle Solaris 10 8/11 Information Library|
- Netra—based application watchdog timer driver
The ntwdt driver is a multithreaded, loadable, non-STREAMS pseudo driver that provides an application with an interface for controlling a system watchdog timer.
The ntwdt driver implements a virtual watchdog timer that a privileged application (Effective UID == 0) controls via IOCTLs.
You configure the ntwdt driver by modifying the contents of the ntwdt.conf file.
An open() fails if:
Effective user ID is not zero.
/dev/ntwdt is not present or driver is not installed.
/dev/ntwdt has already been successfully open()'d.
Special character device.
SPARC ntwdt driver binary.
Driver configuraton file.
See attributes(5) for descriptions of the following attributes:
Writing Device Drivers