|Skip Navigation Links|
|Exit Print View|
|man pages section 7: Device and Network Interfaces Oracle Solaris 10 8/11 Information Library|
- Kernel object filesystem
The objfs filesystem describes the state of all modules currently loaded by the kernel. It is mounted during boot at /system/object.
The contents of the filesystem are dynamic and reflect the current state of the system. Each module is represented by a directory containing a single file, 'object.' The object file is a read only ELF file which contains information about the object loaded in the kernel.
The kernel may load and unload modules dynamically as the system runs. As a result, applications may observe different directory contents in /system/object if they repeatedly rescan the directory. If a module is unloaded, its associated /system/object files disappear from the hierarchy and subsequent attempts to open them, or to read files opened before the module unloaded, elicits an error.
Mount point for objfs file system
See attributes(5) for descriptions of the following attributes:
The content of the ELF files is private to the implementation and subject to change without notice.