|Skip Navigation Links|
|Exit Print View|
|man pages section 7: Device and Network Interfaces Oracle Solaris 10 8/11 Information Library|
- ACPI Thermal Zone Monitor
The tzmon is a pseudo driver that serves as an ACPI thermal zone monitor. Thermal zones are logical regions within a computer system for which ACPI performs temperature monitoring and control functions. The number of thermal zones on a system with ACPI support varies. For example, some systems may have one or more thermal zones, while others may have none. See the Advanced Configuration and Power Interface Specification, (ACPI) Version 3.0A. for more details.
The tzmon handles thermal Zone events from ACPI and polls the temperature for each zone exposed by the ACPI implementation. If threshold temperatures are reached, tzmon takes appropriate action. For example, if the temperature is sufficiently high and the ACPI implementation supports it, tzmon initiates system shutdown.
Note that by default, system temperature control functions are usually performed by the BIOS and may supersede tzmon functions, depending on the BIOS implementation. Also, many ACPI implementations expose no thermal zones and in these cases, tzmon performs no functions.
See attributes(5) for descriptions of the following attributes:
Advanced Configuration and Power Interface Specification, (ACPI), Version 3.0A.