|Skip Navigation Links|
|Exit Print View|
|man pages section 9: DDI and DKI Kernel Functions Oracle Solaris 10 8/11 Information Library|
- find out the allowed burst sizes for a DMA mapping
#include <sys/conf.h> #include <sys/ddi.h> #include <sys/sunddi.h> int ddi_dma_burstsizes(ddi_dma_handle_t handle);
Solaris DDI specific (Solaris DDI).
A DMA handle that was filled in by a successful call to ddi_dma_setup(9F).
ddi_dma_burstsizes() returns the allowed burst sizes for a DMA mapping. This value is derived from the dlim_burstsizes member of the ddi_dma_lim_sparc(9S) structure, but it shows the allowable burstsizes after imposing on it the limitations of other device layers in addition to device's own limitations.
ddi_dma_burstsizes() returns a binary encoded value of the allowable DMA burst sizes. See ddi_dma_lim_sparc(9S) for a discussion of DMA burst sizes.
This function can be called from user or interrupt context.