|Skip Navigation Links|
|Exit Print View|
|man pages section 9: DDI and DKI Kernel Functions Oracle Solaris 10 8/11 Information Library|
- retrieve NDI event service cookie
#include <sys/sunldi.h> int ldi_get_eventcookie(ldi_handle_t lh, char *name ddi_eventcookie_t * ecp);
Solaris DDI specific (Solaris DDI)
null-terminated string containing the event name.
Pointer to the kernel event cookie.
The ldi_get_eventcookie() function queries the device tree for a cookie matching the given event name and returns a reference to that cookie. The search is performed by calling up the device tree hierarchy of the device represented by the layered driver handle until the request is satisfied by a bus nexus driver, or the top of the dev_info tree is reached.
The cookie returned by this function can be used to register a callback handler with ldi_add_event_handler(9F).
Cookie handle is returned.
Request was not serviceable by any nexus driver in the target device's ancestral device tree hierarchy.
This function may be called from user or kernel contexts.