|Skip Navigation Links|
|Exit Print View|
|man pages section 9: DDI and DKI Properties and Data Structures Oracle Solaris 10 8/11 Information Library|
- introduction to kernel data structures and properties
Section 9P describes kernel properties used by device drivers. Section 9S describes the data structures used by drivers to share information between the driver and the kernel. See Intro(9E) for an overview of device driver interfaces.
In Section 9S, reference pages contain the following headings:
NAME summarizes the purpose of the structure or property.
SYNOPSIS lists the include file that defines the structure or property.
INTERFACE LEVEL describes any architecture dependencies.
DESCRIPTION provides general information about the structure or property.
STRUCTURE MEMBERS lists all accessible structure members (for Section 9S).
SEE ALSO gives sources for further information.
Of the preceding headings, Section 9P reference pages contain the NAME, DESCRIPTION, and SEE ALSO fields.
Every driver MUST include <sys/ddi.h> and <sys/sunddi.h>, in that order, and as final entries.
The following table summarizes the STREAMS structures described in Section 9S.
The following table summarizes structures that are not specific to STREAMS I/O.
Do not declare arrays of structures as the size of the structures can change between releases. Rely only on the structure members listed in this chapter and not on unlisted members or the position of a member in a structure.